コラボレーション : Cisco Outbound Option

IPCC Enterprise の IP ダイヤラ障害

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、IP ダイヤラが利用者へのダイヤルに失敗する原因の 1 つを説明し、Cisco IP Contact Center(IPCC)Enterprise 環境でのソリューションを提供しています。

前提条件

要件

次の項目に関する知識があることが推奨されます。

  • Cisco ICM

  • Cisco Outbound Option

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco ICM バージョン 5.x および それ 以降

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

典型的な予言するか進歩的なコールフローはここにあります(図を 1)参照して下さい:

  1. IP ダイヤラは Media Routing (MR) インターフェイスを通してエージェントを要求します。

  2. ルータは対応可能なエージェントを選択するためにルーティングスクリプトを実行します。

  3. ルータは対応可能なエージェントを戻します。

  4. Peripheral Gateway (PG)は対応可能なエージェントを予約します。

  5. IP ダイヤラはエージェント Line 1 に予約 コールを保持するためにコールを送信します。

  6. IP ダイヤラは顧客にそれからコールを送信します。

  7. IP ダイヤラは着信 リアルタイム プロトコル(RTP) ストリームを分析し、ライブ人を検出する。

  8. カスタマー コールは第 2 行を通ってエージェントの電話に到着します。 ダイヤラ 予約はコンピュータ テレフォニー インテグレーション (CTI) サーバによってカスタマー コールに応答します。

図 1 –典型的な予言するか進歩的なコール プロセス

/image/gif/paws/64926/ipdialerfailure_01.gif

図 1 では、DLR は IP ダイヤラを表し、RTR はルータを表します。

問題

IP ダイヤラは顧客にコールを送信しません。 このログに基づいて、IP ダイヤラは TFTPサーバからコンフィギュレーション ファイルをダウンロードしません:

13:00:06 dialer-baDialer Trace: Unable to get XML Config file
 [SEPDA005002f000.cnf.xml] from Call Manager; 1 of 50 Attempts 
13:00:06 dialer-baDialer Trace: Getting Configuration File
 [SEPDA005002f000.cnf.xml] from TFTP Server [192.168.210.246] 
13:00:06 dialer-baDialer Trace: Unable to get XML Config file
 [SEPDA005002f000.cnf.xml] from Call Manager; 2 of 50 Attempts 

原因

この設定 に関する 問題は TFTPServer の登録値を正しく設定しないと発生します。 この問題はまた TFTPサーバなしでインストールされる CallManager Server を指すことができます。 いずれにしても、IP ダイヤラは顧客にコールを送信しません。

TFTPServer のためのレジストリ ナビゲーション パスはここにあります(図を 2)参照して下さい:

HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\<inst_name>\Dialer\TFTPServer
図 2 – TFTPServer レジストリキー

ipdialerfailure_02.gif

解決策

この問題を解決するためにこれらのステップを完了して下さい:

  1. Cisco ICM ダイヤラ セットアップを実行して下さい。

  2. CallManager TFTPサーバの名前を除くすべての既存のパラメーターを、保って下さい。 Call Manager TFTPサーバ フィールドの正しい CallManager TFTPサーバ名前をタイプして下さい。

    この CallManager Server が TFTPサーバ 機能をサポートするようにして下さい。

    図 3 –送信 オプション ダイヤラ Properties

    /image/gif/paws/64926/ipdialerfailure_03.gif

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Document ID: 64926