コラボレーション : Cisco Unified Contact Center Express

リアルタイム レポートエラーを解決する方法

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、リアルタイム レポートの実行を試みるとエラーが発生する理由について説明し、Cisco IP Contact Center(IPCC)Express 環境における可能なソリューションを提供します。

前提条件

要件

次の項目に関する知識があることが推奨されます。

  • Cisco CallManager

  • Cisco Customer Response Solutions(CRS)

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco CallManager バージョン 3.x 以降

  • Cisco CRS バージョン 3.x 以降

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

問題

顧客対応アプリケーション(CRA)管理者 Web ページ(図 1 参照)からリアルタイム レポートを実行しようとすると、レポートに失敗し、次のエラー メッセージが表示される。

Unable to connect to the server
図 1:CRA 管理者 Web ページからのリアルタイム レポートの実行

/image/gif/paws/64057/realtime_report_error_01.gif

原因

このエラーは次のいずれかの理由によって発生する可能性があります。

  • ブラウザのプロキシ サーバ設定がオリジナルのリモート メソッド呼び出し(RMI)通信を妨害している。

  • Response Time Reporter(RTR)サブシステムまたはデータベース サブシステムが動作していない。

  • ネットワーク インターフェイス カード(NIC)のバインド順序が不正確である。

解決策

この項では、原因に応じて問題を修正する手順を段階的に説明します。

原因 1 の解決策: 不適切なプロキシ サーバ設定

ブラウザのプロキシ サーバ設定をオフにしてこの問題を解決することができます。 次の手順を実行します。

  1. Internet Explorer のブラウザ ウィンドウを開きます。

  2. [Tools] > [Internet Options] を選択します。

    [Internet Options] ダイアログボックスが表示されます。

  3. [Connections] タブをクリックします。(図 2 を参照)

  4. [LAN Settings] をクリックします。

    図 2:[Internet Options] ダイアログボックス

    /image/gif/paws/64057/realtime_report_error_02.gif

    [Local Area Network (LAN) Settings] ダイアログボックスが表示されます。

    図 3:ローカル エリア ネットワークの設定

    realtime_report_error_03.gif

  5. プロキシ サーバ セクションの [Use a proxy server for your LAN] チェックボックスのチェックを外します。( 図 3 参照)

  6. [OK] を 2 回クリックします。

原因 2 の解決策: 動作していない RTR またはデータベースサブシステム

RTR サブシステムまたはデータベース サブシステムが動作していないためにエラーが発生した場合、当該のサブシステムを起動して問題を解決します。 次の手順を実行します。

  1. CRA 管理者ページから [System] > [Engine] を選択します。

  2. RTR サブシステムとデータベース サブシステムが両方とも稼働しているかどうか検証します。

    サブシステムのいずれかが動作していない場合は、そのサブシステムを起動します。

原因 3 の解決策: 不正確な NIC バインド順序

Voice over IP(VoIP)モニタを実行する CRS サーバに 2 個の NIC が取り付けられている場合、次のことを確認します。

  • 正常な CRS トラフィック用の NIC が TCP/IP バインド順序のトップにあること。

  • VoIP モニタ トラフィック用の NIC が他方の NIC の後で TCP/IP にバインドされていること。

不正確な NIC バインド順序によりエラー メッセージが表示された場合、次の手順を実行して NIC バインド順序を修正します。

  1. [Start] > [Settings] をクリックします。

  2. [Network and Dial-up Connections] を右クリックし、ショートカット メニューから [Open] を選択します。

    [Network and Dial-up Connections] ウィンドウが表示されます(図 4 参照)

  3. [Advanced] > [Advanced Settings] を選択します。

    図 4:ネットワークとダイヤルアップ接続

    /image/gif/paws/64057/realtime_report_error_04.gif

    [Advanced Settings] ダイアログボックスが表示されます。

    図 5:詳細設定

    realtime_report_error_05.gif

  4. [Connections] セクションの [Local Area Connections 2] を選択します。

  5. [Move Up] ボタンをクリックします。(図 5 参照)

  6. [OK] をクリックして変更を確定します。

    新しい NIC バインド順序が表示されます。

    図 6:新しい NIC バインド順序

    realtime_report_error_06.gif

    上記の解決策で問題が解決しない場合は、回避策として Windows のサービスから CRS Node Manager を再起動してください。

IPCC 7.x Webview レポートがプルできない

新しくインストールされた HDS/webview サーバにおいて、webview レポートでデータを取得することができない。 この問題はリアルタイム エージェント レポートのみで発生する。

解決策

Configuration Manager からペリフェラル構成をチェックしたところ、新しい HDS が Agent Distribution(エージェント レポートを受信する管理者ワークステーションのリスト)に追加されていないことが判明しました。

配信リストに新しい管理者ワークステーション(AW)のサイト名を追加しました。 これにより問題は解決しました。

エージェント再教育ページが表示されない

Apache サービスを開始できない。 std.out log で次のエラー メッセージを受信する。 Can't load server.xml

解決策

この問題は server.xml が C:\icm\tomcat\conf フォルダの中で抜けていたので引き起こされています。 この問題を解決するには、次の回避策を実行します。

  1. C:\icm\tomcat\conf フォルダからの server.xml.custom ファイルのコピーを作成して下さい

  2. そのファイルを server.xml に名称変更します。

  3. Apache サービスを開始します。

    これにより、再教育ページが正常にロードされます。


関連情報


Document ID: 64057