音声 : メディア ゲートウェイ コントロール プロトコル(MGCP)

Unity ボイスメール統合での Call Manager と Avaya S8700/G650 間の Q.SIG PRI トランクの設定

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2006 年 8 月 20 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

Cisco CallManager と Avaya S8700/G650 間に Q.SIG PRI トランクを設定する手順をシスコのお客様とビジネス パートナーに提供することが、このドキュメントの目的です。 さらに、このドキュメントでは、Cisco と Avaya の両方の IP 電話にボイス メール サポートを提供するために、Cisco CallManager のプラットフォームに Cisco Unity を付加する方法の詳細な手順を説明しています。 IP-PBX の相互運用性とボイス メールの統合が必要とされる状況では、これは特に重要です。 Avaya の設定画面キャプチャは、標準エミュレーション ツールで作成されたものです。 それに代えて、Avaya S8700/G650 での設定作業には Avaya Site Administration(ASA)ツールも使用できます。 どちらの場合でも、出力表示は同じです。 IP-PBX の相互運用性とボイス メール統合に関する本ドキュメントでは、外部での使用が想定されています。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • 使用されている Avaya IP-PBX システムは、Avaya Communication Manager 2.0 が稼働する Avaya S8700/G650 です。 Q.SIG 機能は、このソフトウェア バージョンで標準装備になっています。

  • このドキュメントで使用される Avaya の IP 電話は、Phone Firmware Version 2.01 が稼働する 4610SW と 4620 です。

  • Cisco Call Manager 4.1.(2) は Cisco IOS を実行する NM-HDV モジュールによって 3745 Media Gateway Control Protocol (MGCP) ゲートウェイを制御するために使用されましたか。 バージョン 12.2.15ZJ3。 テストはまた Cisco IOS によって繰り返されましたか。 バージョン 12.3.8.T5。

  • ボイス メール統合テストでは、バージョン 4.0(4) SR1 が稼働する Cisco Unity が使用されています。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

テスト セットアップ

使用された Avaya IP-PBX システムは Avaya 通信マネージャ 2.0 を実行する Avaya S8700/G650 でした。 Q.SIG 機能は、このソフトウェア バージョンで標準装備になっています。 使用された AvayaIP 電話は 4610SW および 4620 実行電話ファームウェアのバージョン 2.01 でした。 Cisco 側で Cisco IOS を実行する NM-HDV モジュールによって 3745 MGCP ゲートウェイを制御するのに、Cisco Call Manager 4.1.2 が使用されましたか。 バージョン 12.2.15ZJ3。 テストはまた Cisco IOS によって繰り返されましたか。 バージョン 12.3.8.T5。 ボイス メール統合テストでは、バージョン 4.0(4) SR1 が稼働する Cisco Unity が使用されています。

テスト環境のトポロジ

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-top.gif

Cisco と Avaya の IP-PBX システムの相互運用性

次のセクションでは、Avaya Communication Manager 2.0 が稼働する Avaya S8700/G650 と CallManager バージョン 4.1(2) が稼働する Cisco CallManager プラットフォーム間に Q.SIG トランクを設定するのに役立つ手順と画面キャプチャを提供しています。なお、Avaya S8700/G650 に物理的な ISDN PRI 接続を提供するために、Cisco 3745 MGCP デバイスが使用されています。

Avaya S8700/G650 IP-PBX システムでの手順

次の手順を実行します。

  1. S8700 サーバにログインします。 必要な Q.SIG 機能が S8700 サーバで有効になっていることを確認するために display system-parameters customer コマンドを実行します。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-proced1.gif

  2. DS-1 カードを Q.SIG PRI 用に設定します。

    2.gif

  3. トランク グループを設定します。 add trunk-group # と入力します。# には対象のトランクを指定します。

    次の 3 つの画面キャプチャはトランク設定に関するものです。 トランク グループが作成されたら、グループに DS0 チャネルを 23 付加します。 これはポート割当ての例です: 01A0901 は意味します: Gateway# 1、キャビネット A、Slot# 9、DS0 channel# group1。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-3.gif

    4.gif

    5.gif

  4. シグナリング グループを追加して、作成済のトランク グループをポイントします。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-6.gif

  5. ルート パターンを追加して、シグナリング グループをポイントします。 この例では、ルート パターン 4 が、手順 4 で作成されたシグナリング グループ 1 をポイントしています。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-7.gif

  6. コールのルーティングに作成したルート パターンを使用するために、AAR テーブルにエントリを追加します。 この例では、Cisco IP Phone の内線 4XXX へのコールに 4 で始まる AAR エントリが使用されており、これがルート パターン # 4 を示すことになります。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-8.gif

  7. 発信者名を送信するために、各 IP Phone で発信者番号(Caller ID)が有効になっていることを確認します。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-9.gif

Cisco CallManager での手順

次の手順を実行します。

  1. ヘアピニングなどの問題を防止するために、サービス パラメータで、Start Path Replacement の Minimum と Maximum の値が適切に設定されていることを確認します。

    次の 2 つの画面キャプチャは、Q.SIG のサービス パラメータ設定に関するものです。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-10.gif

    11.gif

  2. MGCP ゲートウェイとして Cisco 3745 を追加し、NM-HDV T1 モジュールを Q.SIG PRI 用に設定します。

    次の 5 つの画面キャプチャは、この設定に関するものです。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-2.gif

    13.gif

    15.gif

    16.gif

    17.gif

  3. 最後の手順として、PBX に経路切替要求のための番号を提供するために Cisco CallManager ピックアップ グループを作成します。 コール ピックアップ番号が Path PINX Replacement ID Service パラメータにも入力されていることを確認してください(手順 1 参照)。 さらに、Avaya のシステムでは、ピックアップ グループへのルーティングのためにルート パターンが必要です。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-8.gif

    注: Cisco CallManager Service Parameters(Advanced)の中の(Device - PRI and MGCP Gateway)にある次の 2 つのクラスタワイド パラメータが PBX の Q.SIG 設定と一致していることを確認してください。 PBX トランクは、すべて、これらの CallManager パラメータどおりに設定する必要があります。

    • ASN.1 ROSE OID Encoding: このパラメータでは、Remote Operations Service Element(ROSE)のための Invoke Object ID(OID)のエンコード方法が指定されます。 別途、シスコのサポート エンジニアからの指示がない限り、このパラメータはデフォルトのままにしておきます。 これは必須フィールドで、デフォルトは Use Local Value です。

      このパラメータで有効な値を次に示します。

      • Use Local Value:これはほとんどのテレフォニー システムでサポートされており、Q.SIG Variant サービス パラメータが ISO(Protocol Profile 0x9F)にセットされている場合に使用する必要があります。

      • Use Global Value (ISO):これを使用するのは、接続された PBX で Use Local Value がサポートされていない場合だけです。

      • Use Global Value (ECMA):これを使用する必要があるのは、Q.SIG Variant サービス パラメータが ECMA(Protocol Profile 0x91)にセットされている場合です。

    • Q.SIG Variant: このパラメータはトランクが Q.SIG のために設定されるとき送信 Q.SIG ファシリティ 情報要素で送信 される プロトコル プロファイルを規定 します。 別途、シスコのサポート エンジニアからの指示がない限り、このパラメータはデフォルトのままにしておきます。 これは必須フィールドで、デフォルトは ISO (Protocol Profile 0x9F) です。

      このパラメータに使用可能な値を次に示します。

      • ECMA (Protocol Profile 0x91):通常、これは ECMA PBX で使用され、Protocol Profile 0x91 だけを使用できます。 このサービス パラメータが ECMA(Protocol Profile 0x91)にセットされていると、ASN.1 Rose OID Encoding サービス パラメータを Use Global Value(ECMA)にセットする必要があります。

      • ISO (Protocol Profile 0x9F):これが現在の ISO 推奨値です。 このサービス パラメータが ISO(Protocol Profile 0x9F)にセットされていると、ASN.1 Rose OID Encoding サービス パラメータを Use Local Value にセットする必要があります。

        警告: CallManager Administration の Trunk Configuration ウィンドウで Tunneled Protocol フィールドが Q.SIG にセットされた状態でクラスタ間トランクを使用する場合、Cisco CallManager では ECMA はサポートされません。 このサービス パラメータを ECMA(Protocol Profile 0x91)にセットしていると、すべてのクラスタ間トランクで Tunneled Protocol フィールドを None にセットする必要があります。

        qsig.gif

Cisco 3745 の設定

次に示すのは、Cisco 3745 MGCP デバイスでの show version と show running-configuration コマンドの出力です。 Cisco 3745 上の Controller T1 1/0 が Avaya S8700/G650 DS1 PRI カードに接続されています。 Cisco 3745 と Avaya S8700/G650 間の PRI リンクに Q.SIG シグナリングが設定されています。

CCME_CUE_3745# sh vers
Cisco Internetwork Operating System Software 
IOS (tm) 3700 Software (C3745-IS-M), Version 12.2(15)ZJ3, EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2003 by cisco Systems, Inc.
Compiled Thu 25-Sep-03 22:25 by eaarmas
Image text-base: 0x60008954, data-base: 0x61C2C000

ROM: System Bootstrap, Version 12.2(8r)T2, RELEASE SOFTWARE (fc1)
ROM: 3700 Software (C3745-IS-M), Version 12.2(15)ZJ3, EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)

CCME_CUE_3745 uptime is 39 minutes
System returned to ROM by reload
System image file is "flash:c3745-is-mz.122-15.ZJ3.bin"

cisco 3745 (R7000) processor (revision 2.0) with 246784K/15360K bytes of memory.
Processor board ID JMX0814L3E2
R7000 CPU at 350Mhz, Implementation 39, Rev 3.3, 256KB L2, 2048KB L3 Cache
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
Primary Rate ISDN software, Version 1.1.
2 FastEthernet/IEEE 802.3 interface(s)
25 Serial network interface(s)
1 terminal line(s)
2 Channelized T1/PRI port(s)
1 ATM AIM(s)
2 Voice FXS interface(s)
2 Voice E & M interface(s)
1 cisco service engine(s)
DRAM configuration is 64 bits wide with parity disabled.
151K bytes of non-volatile configuration memory.
125184K bytes of ATA System CompactFlash (Read/Write)
Configuration register is 0x2102

CCME_CUE_3745# sh run
Building configuration...

Current configuration : 3291 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CCME_CUE_3745
!
logging queue-limit 100
!
voice-card 1
 dspfarm
!
voice-card 5
 dspfarm
!
ip subnet-zero
!
!
no ip domain lookup
!
isdn switch-type primary-qsig
!
no voice hpi capture buffer
no voice hpi capture destination 
!
!
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 172.28.221.18  
ccm-manager config
mta receive maximum-recipients 0
!
!
controller T1 1/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 1/1
 framing sf
 linecode ami
!
!
!
interface FastEthernet0/0
 description CCME-CUE-3745_to_cat3550
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 99
!
interface FastEthernet0/0.2
 description NEW_S8700_G650
 encapsulation dot1Q 300
 ip address 172.28.221.49 255.255.255.240
 ip helper-address 172.28.221.19
 h323-gateway voip bind srcaddr 172.28.221.49
!
interface FastEthernet0/0.3
 description MODULAR_MESSAGING_SOLUTION
 encapsulation dot1Q 900
 ip address 172.28.221.129 255.255.255.240
 ip helper-address 172.28.221.19
!
interface FastEthernet0/0.4
 encapsulation dot1Q 301
 ip address 10.1.3.1 255.255.255.128
 ip helper-address 172.28.221.19
!
interface FastEthernet0/0.5
 encapsulation dot1Q 302
 ip address 10.1.3.129 255.255.255.128
 ip helper-address 172.28.221.19
!
interface FastEthernet0/0.6
 encapsulation dot1Q 90
 ip address 90.1.1.254 255.255.255.0
 ip helper-address 172.28.221.19
!
interface Serial0/0
 description CCME-CUE-3745_to_3600
 ip address 25.0.0.1 255.0.0.0
 clockrate 256000
 no fair-queue
!
interface Serial1/0:23
 no ip address
 no logging event link-status
 isdn switch-type primary-qsig
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 isdn bchan-number-order ascending
 no cdp enable
!
interface Service-Engine2/0
 no ip address
 shutdown
!
router eigrp 100
 network 10.0.0.0
 network 25.0.0.0
 network 90.0.0.0
 network 172.28.0.0
 auto-summary
!
ip http server
ip classless
!
call rsvp-sync
!
voice-port 1/0:23
!
voice-port 4/0/0
!
voice-port 4/0/1
!
voice-port 4/1/0
!
voice-port 4/1/1
!
mgcp
mgcp call-agent 172.28.221.18 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp package-capability rtp-package
no mgcp package-capability res-package
mgcp package-capability sst-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
!
mgcp profile default
!
!
!
dial-peer cor custom
!
dial-peer voice 1 pots
 application mgcpapp
 port 1/0:23
!
dial-peer voice 999410 pots
 application mgcpapp
 port 4/1/0
!
!
line con 0
 password cisco
 login
line 65
 flush-at-activation
 no activation-character
 no exec
 transport preferred none
 transport input all
line aux 0
line vty 0 4
 password cisco
 login
!
end

Cisco と Avaya の IP-PBX システムの相互運用性のためのテスト済機能

このセクションでは、Cisco CallManager 4.1(2) プラットフォームと Communication Manager 2.0 が稼働する Avaya S8700/G650 間の Q.SIG PRI トランクでテストされた機能を一覧表示しています。

  • 名前と番号の表示(双方向)

  • コール転送

  • 2 つのシステム間の会議コール

Cisco と Avaya の IP 電話をサポートするための Cisco Unity ボイスメールの統合

ここでは、Avaya Communication Manager 2.0 が稼働する Avaya S8700/G650 と CallManager バージョン 4.1(2) が稼働する Cisco CallManager プラットフォーム間でのコールのために Q.SIG トランクが使用できます。なお、Avaya S8700/G650 に物理的な ISDN PRI 接続を提供するためには、Cisco 3745 MGCP デバイスが使用されます。 Cisco と Avaya の両方の IP 電話にボイス メール サポートを提供するために、Cisco CallManager プラットフォームに Cisco Unity サーバを追加できます。 これを有効にするには、管理者が Cisco CallManager プラットフォームで Cisco Unity を設定する必要があります。 このセクションでは、Cisco CallManager Administration 管理ページで Cisco Unity を設定する方法を示した画面キャプチャ付きの手順が紹介されています。

注:  ほとんどの設定は、Cisco Voice Mail Port Wizard で実行されます。

Cisco CallManager への Cisco Unity の付加

次の手順を実行します。

  1. 機能の下で、音声メール > 音声メールポート ウィザードを選択して下さい。 Create a new Cisco Voice Mail Server and add ports to it を選択して、Next をクリックします。

    19.gif

  2. AvayaUM3 のように、Cisco Voice Mail Server の名前を入力して、Next をクリックします。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-20.gif

  3. 必要な Voice Mail Port の数を選択して、Next をクリックします。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-21.gif

  4. Voice Mail Port のための Description と Device Pool に入力します。 設定例では、Description として Avaya VMailPorts と入力されており、Device Pool には Default が選択されています。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-4.gif

  5. Beginning Directory Number には 4406 のように入力し、Display には Voicemail のように入力して、Next をクリックします。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-2.gif

  6. 次の画面では、「Do you want to add these directory numbers to a Line Group?」との質問が表示されます。 『Yes』 を選択 して下さい。 ディレクトリ番号を復帰改行文字 グループに追加し、『Next』 をクリック して下さい。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-3.gif

  7. AvayaUM3 のような、前に入力した Voice Mail Server に一致する Line Group Name を入力します。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-4.gif

  8. 次の画面では、これまでに入力した設定が表示されます。 設定に変更がなければ、Finish をクリックします。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-5.gif

  9. Hunt List Administration の Web ページで、Add a New Hunt List をクリックします。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-6.gif

  10. Hunt List Name と Description に、Avaya VMailHL のように入力します。 さらに、Cisco CallManager Group には、Default を選択します。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-7.gif

  11. Hunt List の追加が成功すると、次の画面キャプチャのようになります。 Add Line Group をクリックします。

    28.gif

  12. 設定済の Line Group を選択します。 この場合は、AvayaUM3 です。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-9.gif

  13. 次の画面キャプチャには、ライン グループの挿入が成功したことが示されています。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-30.gif

  14. > ハントするパイロットはルートプラン > ルート/ハントするに行きます。 表示された Hunt Pilot 画面で、Add a New Hunt Pilot をクリックします。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-31.gif

  15. Hunt Pilot に 4408 のように入力して、さらに、Avaya VMail HL のように Hunt List を選択し、Insert をクリックします。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-2.gif

  16. > 音声メールパイロット Feature > Voice Mail の順に進み、生じる画面の新しい音声メールパイロットを『Add』 をクリック して下さい。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-3.gif

  17. 設定済の Hunt Pilot 番号に一致する Voice Mail Pilot 番号を入力します。 この場合は、Hunt Pilot と Voice Mail Pilot の番号はどちらも 4408 です。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-4.gif

  18. > 音声メール プロファイル Feature > Voice Mail の順に進み、新しい音声メール プロファイルを『Add』 をクリック して下さい。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-5.gif

  19. 音声メール プロファイル名前および説明を、AvayaVMailProfile のような入力し、ステップ 17 の音声メールパイロット数を選択して下さい。 この場合、音声メールパイロット数は 4408 です。

    36.gif

  20. メッセージ待機インディケーター (MWI)オン/オフ数を追加する新しいメッセージ待っている数機能 > 音声メール > メッセージ待機インディケーター > Add をクリックして下さい。 Message Waiting Indicator On/Off 番号に関する画面キャプチャを 2 枚示します。

    37.gif

    38.gif

テスト済の Cisco Unity ボイスメール機能

次に、Cisco CallManager 4.1(2) プラットフォームと Communication Manager 2.0 が稼働する Avaya S8700/G650 間での Q.SIG PRI トランクで、Cisco Unity Voice Mail のアクセスに使用される Avaya IP 電話でテストされた Cisco Unity ボイスメール機能を一覧表示します。

  • Internal greeting

  • Busy greeting

  • MWI

  • Easy message access

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 63790