音声とユニファイド コミュニケーション : Cisco Unity

Unity IP ファクシミリ着信ゲートウェイの設定例

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 11 月 11 日) | フィードバック


目次


概要

Cisco Unity 受信ファクシミリは Cisco Unity 3.1(5)および Cisco IOS から開始している Unity IP ファクシミリ コンフィギュレーション ウィザードでサポートされますか。 ソフトウェア リリース 12.2(8)T。 このサービスでは、ユーザは受信ボックスの添付ファイルとしてファクスを受信でき、Cisco Unity Telephony User Interface(TUI)から新規ファクス メッセージの警告を受けることができます。

受信ファクシミリはファックス ゲートウェイ(Cisco IOS ルータこの場合)によって最初に受け取られます。 このゲートウェイは TIFF ファイルとして接続されるファクシミリ情報の E メールにファクシミリを変換します。 ゲートウェイはまた「サブジェクトに自動番号識別(ANI) (または発番号)および DNIS (または着番号)追加 します: 」ファクシミリ E メールの部分。 SMTP セッションがそれから、Microsoft Exchange と共に、E メールが受信され、処理される Cisco Unity サーバにこのファクシミリ E メールを送信 するのに利用されています。 件名の DNIS は解析され、正しいデスティネーション インボックスは Unity IP ファクシミリ コンフィギュレーション ウィザードの以前のコンフィギュレーションに基づいて判別されます。

この資料は Cisco IOSゲートウェイの設定にゲートウェイを得て必要であるか何が Cisco Unity IP ファクシミリ機能を使用するために焦点を合わせ。 受信ファクシミリ用の Cisco Unity のための設定に関する詳細については、Unity IP ファクシミリ受信 ゲートウェイコンフィギュレーション例を参照して下さい。 オフランプまたは発信 ゲートウェイコンフィギュレーション 支援に関しては、Unity IP ファクシミリ送信 ゲートウェイコンフィギュレーション例を参照して下さい。

前提条件

要件

このドキュメントを読むには、SMTP に関する基本的な知識が必要です。また、Cisco IOS の VoIP 設定に精通している必要もあります。 Unity IP ファクシミリ コンフィギュレーション ウィザードが付いているはたらく Cisco Unity サーバはこの資料に完全な運用システムを持つために定義されたゲートウェイコンフィギュレーションと共に使用される必要性をインストールしました。 サポートする IOS Gateway 側面で、Microsoft Exchange 2000 が付いている Cisco Unity バージョン 3.1(1) または それ 以降かパートナー メッセージ記憶装置として 2003 と共に Cisco IOS ルータが T.37 オンランプ機能性および Cisco IOS ソフトウェア リリース 12.2(8)T またはそれ以降必要となります。 IP ファクシミリ設定の Cisco Unity 部分に関する詳細については、Unity IP ファクシミリ コンフィギュレーション ウィザードを参照して下さい。

T.37 オンランプは Media Gateway Control Protocol (MGCP) ネットワークでサポートされません。 T.37 を使用する際のプラットフォームとその他の制限事項の詳細については、『T.37 ストア アンド フォワード ファックス設定ガイド』を参照してください。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • IOS ゲートウェイとして Cisco 3725

  • Cisco IOS ソフトウェア リリース 12.3(8)T4

ゲートウェイは Cisco 37xx プラットフォームに制限 されません。 IP PLUS および Cisco IOS ソフトウェア リリース 12.2(8)T のどの音声ゲートウェイでもはたらく必要があります。 Cisco IOS ソフトウェア リリース 12.2T の特定の Ciscoゲートウェイ モデルによるサポートに関する詳細については、T.37 ストア アンド フォワード ファクシミリの設定表 5.1 を参照して下さい。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

ユーザが受信 ファックス コールを開始することは非常に容易です。 ファクシミリはあらゆる正常なファクシミリのように送信 されます。 ただし、それは別のファクシミリで受け取られません。 その代り、ファクシミリは Cisco IOSゲートウェイで終わります。 ファクシミリを終えるために典型的なデバイスのように機能するゲートウェイはファクシミリを受け取ります。 ゲートウェイは TIFF ファイルにファクシミリを変換します。 ゲートウェイはそれから添付ファイルとして TIFF イメージの設定されたメール サーバに当たる E メールを形成します。 ANI および DNIS は「サブジェクトに挿入されます: 」E メールのフィールド。 ゲートウェイはそれから Cisco Unity サーバに E メールを転送するのに SMTP セッションを利用します。 Cisco Unity IP ファクシミリ機能観点から、これらは Cisco オンランプ ゲートウェイの機能です:

  • ファクシミリの受け取りに成功するために規格が G3 ファクシミリを基づかせていたように機能して下さい。

  • 適切な TIFF ファイルにすべての受け取られたファクシミリ ページ の 情報を変換して下さい。

  • 設定されたメール サーバに E メールとしてファクシミリ TIFF ファイルを中継で送るのに SMTP を使用して下さい。 E メールは Cisco Unity サーバで作成されたファクシミリ インボックスに当たる必要があります。

  • DNIS番号が E メールで「サブジェクト入ることを確かめて下さい: 」#### が受信 ファックス コールの DNIS であるところ、適切な形式のフィールドの[DNIS=####]。

  • Cisco Unity IP ファクシミリ サービスは非表示 メールボックスにメッセージを提供できません。

事柄の Cisco Unity 側面でファクシミリ インボックスは IP ファクシミリ コンフィギュレーション ウィザードを使用して作成されます。か。 すべてのファクシミリ電子メールはこのインボックスに送る必要があります。か。 これらの電子メールはそれから「E メールの DNIS に基づいてサブジェクト解析されます: 」ユーザが定義するルールに従うフィールド。か。 Cisco Unity ファクシミリ サービスは Cisco Unity ファクシミリ インボックスから解析する DNIS に基づいて適切なユーザのインボックスへファクシミリ E メールを移動するそれから役割があります。か。 ユーザが E メール TIFF形式の添付ファイルとして実際のファクシミリを見ることを覚えておくことは重要です。か。 ユーザは Cisco Unity TUI からの新しいファクシミリ メッセージの警告することができます。

また、音声 および FAX コールのための同じ数を設定することも技術的に可能性のあるです。か。 ただし、Cisco はこれをするために、音声コールからファックス コールを分けるために IOSルータがファクシミリ トーンを聞き取る必要があるのでこれに公式のサポートを提供しません。か。通常、なぜなら音声コール コールは自動転送に行くはずですまたは音声メールにユーザの電話をおよび可能性のある順方向に呼び出して下さい。か。 ルータが既にコールに応答している場合、自動転送をするのにルータを使用する必要があります。か。 これは通常 Cisco Unity に自動転送 機能性を提供してほしい環境で望ましくないです。

ゲートウェイの設定

はたらくこのアプリケーションのための Cisco IOSコンフィギュレーションで持たなければならない少数のコマンドがあります。 送信ファクシミリ(「オフランプ」)機能性に必要な設定コマンドでこれらのいくつかがオーバーラップするかもしれません。

  • ファクシミリ インターフェイスの種類 ファクシミリ メールはゲートウェイで設定される必要があります。 このコマンドを設定すると、T.37 ストア アンド フォワード ファックス コールがゲートウェイで処理されるようになります。 このコマンドなしで受信されたファックス コールは SMTP によって正しくルーティングされないので失敗します。 T.37 ルータ デバッグはこのコマンドが追加されるまでまた利用できないです。 このコマンドを設定した後は、ルータをリロードする必要があることに注意してください。

    vnt-3725-51(config)#fax interface-type fax-mail 
    You must reload the router
  • Ciscoゲートウェイは T.37 ファクシミリ オンランプを実行するために追加ソフトウェアが要求します。 このソフトウェアは受信されたファックス コールを処理する必要があるときゲートウェイによって動作する TCL スクリプトです。 このスクリプト ソフトウェアはルータの内蔵フラッシュでロードされるか、または TFTPサーバのロードすることができます。 ソフトウェアは Cisco.com からダウンロード可能であり、TCLware の下のダウンロードのアクセス セクションにあります。 ファイルはファクシミリ オンランプのために必要の app_faxmail_onramp.2.0.1.3.tcl です。 このファイルは、ゲートウェイからアクセス可能な場所に配置する必要があります。 この場合ファイルはルータ 内蔵フラッシュにロードされます:

    vnt-3725-51#copy tftp flash
    Address or name of remote host []? 172.18.106.4
    Source filename []? app_faxmail_onramp.2.0.1.3.tcl
    Destination filename [app_faxmail_onramp.2.0.1.3.tcl]? 
    Accessing tftp://172.18.106.4/app_faxmail_onramp.2.0.1.3.tcl...
    Loading app_faxmail_onramp.2.0.1.3.tcl from 172.18.106.4 (via FastEthernet0/0): !!!
    [OK - 12262 bytes]
    
    12262 bytes copied in 0.116 secs (105707 bytes/sec)
    vnt-3725-51#

    このファイルに関する情報と、このファイルが配置されている場所をルータに伝達する必要があります。 これはこのグローバル 設定 コマンドの助けによってされます:

    vnt-3725-51(config)#call application voice onramp flash:app_faxmail_onramp.2.0.1.3.tcl 
    vnt-3725-51(config)#
    *Nov 19 15:28:40.094: //-1//HIFS:/hifs_ifs_cb: hifs ifs file read 
       succeeded. size=12262, url=flash:app_faxmail_onramp.2.0.1.3.tcl
    *Nov 19 15:28:40.094: //-1//HIFS:/hifs_free_idata: hifs_free_idata: 0x64FFAF70
    vnt-3725-51(config)# 

    ファイルが正常に読み込まれたことルータからの確認コンソールメッセージに注意して下さい。 ファイルがフラッシュするの代りに TFTPサーバにある場合、コマンドは次のとおりです:

    call application voice onramp tftp://172.18.106.4/app_faxmail_onramp.2.0.1.3.tcl
    

    T.37 スクリプトをダウンロードする方法に関する詳細については T.37 ストア アンド フォワード ファクシミリの設定を参照して下さい。

  • ip domain-name コマンドは Exchange を用いる SMTP コミュニケーションの時にルータによって使用されます。 このコマンドなしで、ルータからの Exchange への最初の SMTP 接続は含まれています「EHLO < ホスト名 > が」。 これにより Exchange はセッション(無効アドレス)を終了します。 この資料の例に関しては、ゲートウェイはドメイン gateway.com を使用します。 このようにコマンドな:

    ip domain name gateway.com
    
  • mta send server が < IP アドレスまたは DNSname> ポートは <number> コマンド 受信ファクシミリ電子メールを受信するメール サーバをルータを指すのに使用されています。 このコマンドなしで受け取ったファクシミリをどこに送信 するか、ルータは知らないし、ファックス コールは失敗します。 このコマンドの多数の例を設定することは可能性のあるです。 ただし、設定の第一審だけ使用されます。 他の例は SMTP トランザクションが(無効 な rcpt のようなへの:)失敗する最初のリスト サーバにときだけ使用されます。 それから次の設定されたサーバはリストの上に移動されます。 このサーバはそれに続くオンランプ ファックス コールのためにそれから使用されます。 これは設定される複数のメール サーバがある場合解決するとき覚えてが重要です。

    この例では、14.80.113.13 は SMTP トランザクション失敗がこのサーバへあるまで常に使用されます。 失敗の後で、14.84.31.12 はルータによって上位置にすべてのそれに続くオンランプ ファックス コールのために使用されるように移動されます。

    mta send server 14.80.113.13 port 25
    mta send server 14.84.31.12 port 25
  • mta 送信とサブジェクト コマンドは「サブジェクトに呼出および着番号を含めるようにゲートウェイに指示したものです: 」E メールの行。 これは適切なメールボックスにファクシミリ E メールをルーティングするのにこれが使用されているので Cisco Unity IP ファクシミリ機能にとって重要です。 コール(mta 送信とサブジェクト $d$)をルーティングするのに Cisco Unity は呼出 し 番号を使用できる間、まだ両方とも命じる mta 送信とサブジェクトを使用することを推奨します。

    mta send with-subject both
  • mta 送信 mail-from ホスト名 <name> および mta 送信 mail-from ユーザ名 <name> コマンドは必要 SMTP トランザクション失敗を防ぐためにです。 」形式「username@hostname」の eメールアドレスからの有効なは「メール サーバによって見られなければなりません。 さもなければ SMTP トランザクションは切断されて、ファクシミリ E メールは決して送信 されません。 設定される何がこれらのコマンドの助けによってエンドユーザがで「見るものからのです: 」ファクシミリ E メールのフィールド。 のため「からの: 」"fax-mail@vnt-3725-51.gateway.com" のアドレス、コマンド外観のような:

    mta send mail-from hostname vnt-3725-51.gateway.com
    mta send mail-from username fax-mail

    発信者番号にユーザ名として現われてほしい場合コマンド mta 送信 mail-from ユーザ名 $s$ を使用して下さい。

  • ダイヤル ピアはゲートウェイを通してファックス コールをルーティングするために設定される必要があります。 POTSダイヤルピア 設定は非常に簡単です。 incoming called-number コマンドはこのダイヤル ピアがゲートウェイに入って来る受信 呼出 し 番号を一致することを可能にします。 ほとんどの現実 の 世界シナリオに通常設定される特定のファックス番号があります。 direct-inward-dial コマンドは使用することである番号として MMoIPダイヤルピアを一致するとき受け取った呼出 し 番号を奪取 します。 port コマンドはゲートウェイの物理ポートとこの POTSダイヤルピアを関連付けます。 T.37 オンランプ観点からの重要なコマンドはアプリケーション <name> コマンドです。 このコマンドは特定の POTSダイヤルピアとオンランプ ファクシミリ アプリケーションを関連付けます。 <name> フィールドはコール アプリケーション 音声 <name> <file location> コマンドのユーザによって定義されます。 この例では、POTSダイヤルピアはそれが名前であるのでアプリケーション オンランプを使用しますコマンド コール アプリケーション 音声オンランプ flash:app_faxmail_onramp.2.0.1.3.tcl と以前に定義された。

    送信 VoIP 側に関しては、マルチメディアか MMoIPダイヤルピアは通常 VOIPダイヤルピアの代りに必要です。 POTSダイヤルピアのように、MMoIPダイヤルピアはまた送信 application コマンド アプリケーション fax_on_vfc_onramp_app を必要とします。 この application コマンドはコマンド show call application voice summary を検知 するとき調べられる場合があるスクリプトをレファレンス。 必要のスクリプトは fax_on_vfc_onramp_app です。 このアプリケーションが MMoIPダイヤルピアを通したアウトバウンドコールだけで使用されるように送信 キーワードを覚えていることもまた重要です。

    destination-pattern コマンドが特定の送信 MMoIPダイヤルピアにインバウンドコール呼出し番号を一致させるのに使用されています。 たいていの場合、このユーザの受信 ファックス番号が付いているダイヤルピアの一方。 情報型ファクシミリ コマンドは T.37 ファクシミリと発信 MMoIP ピアを関連付けます。 ダイヤル ピアのこのコマンドなしで、ゲートウェイは MMoIP 同位を使用しないし、オンランプ ファックス コールは失敗します。

    session target mailto: < エンドユーザが E メール観点からだれであるか eメールアドレス > コマンドに識別されています。 多くの T.37 オンランプ実装がこのコマンドを特定のメール ユーザにファクシミリ E メールを当たるのに使用する間、Cisco Unity IP ファクシミリ機能は E メールがユーザ設定ファクシミリ インボックスに当たることを必要とします。 すべてのファクシミリ電子メールはこの 1 つのメールボックスに送られます。 Cisco Unity は「サブジェクトでそれから DNIS番号を使用します: 」適切なエンドユーザ メールボックスにファクシミリ E メールをルーティングする E メールのフィールド。

    dial-peer voice 9995590 pots
     application onramp
     incoming called-number .
     direct-inward-dial
     port 2/0:23
    !
    dial-peer voice 1 mmoip
     application fax_on_vfc_onramp_app out-bound
     destination-pattern 9995590
     information-type fax
    session target mailto:fax-in@vnt-dhanes.com

製品マニュアルおよびコマンド詳細に関する詳細については、IP アプリケーション ガイド上の Cisco FAX サービス設定 T.37 蓄積交換ファクシミリ セクションを参照して下さい。 Cisco Unity サーバに接続されるアクティブ T.37 ゲートウェイのすべてのコンフィギュレーションにはサンプル全体設定を参照して下さい。 受信 ファックス コールは ISDN T1 PRI 2/0:23 で受信されます。 それから Cisco Unity サーバへの SMTP 送信ファクシミリ E メールはインターフェイス ファースト イーサネット 0/0 によってルータを接続を終了します。

完全な設定例

この設定は Cisco Unity 受信ファクシミリ機能のための最小 Cisco IOSコンフィギュレーションの例です。 最も重要な設定コマンドは太字で示されています。

vnt-3725-51#show run
Building configuration...
 
Current configuration : 1808 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname vnt-3725-51
!
boot-start-marker
boot-end-marker
!
!
no network-clock-participate slot 2 
no network-clock-participate aim 0 
no network-clock-participate aim 1 
voice-card 2
 dspfarm
!
no aaa new-model
ip subnet-zero
ip cef
!         
!
ip domain name gateway.com
ip name-server 14.80.113.13
no ftp-server write-enable
isdn switch-type primary-ni
!
!
fax interface-type fax-mail
mta send server 14.80.113.13 port 25
mta send subject this is a test fax inbound to unity
mta send with-subject both
mta send mail-from hostname vnt-3725-51.gateway.com
mta send mail-from username fax-mail
 
!
!
controller T1 2/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 2/1
 framing sf
 linecode ami
!
!
interface FastEthernet0/0
 ip address 14.80.51.14 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown 
 duplex auto
 speed auto
!
interface Serial2/0:23
 no ip address
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
ip default-gateway 14.80.51.1
ip classless
ip route 0.0.0.0 0.0.0.0 14.80.51.1
ip http server
!
!
control-plane
!
!
call application voice onramp flash:app_faxmail_onramp.2.0.1.3.tcl
!         
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 2/0:23
!
!
dial-peer voice 9995590 pots
 application onramp
 incoming called-number .
 direct-inward-dial
 port 2/0:23
!
dial-peer voice 1 mmoip
 application fax_on_vfc_onramp_app out-bound
 destination-pattern 9995590
 information-type fax
 session target mailto:fax-in@vnt-unity.com
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

現在仕様が解決しますこの設定のための入手可能な情報をありません。


関連情報


Document ID: 63423