音声とユニファイド コミュニケーション : Cisco Unity Express

Cisco CallManager Express および Cisco Unity Express の設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2006 年 10 月 31 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

この資料は Cisco Unified CallManager Express (CME)に設定 例を 4.0 および Cisco Unity Express (CUE) 2.2.2、およびテレフォニーネットワークのこれら二つのシステムを統合方法を提供したものです。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • 適切なハードウェアをインストールする。

  • 適切な Cisco IOS をダウンロードし、インストールして下さいか。 ソフトウェア。

  • Cisco Unified CallManager Express ソフトウェアをダウンロードする。

  • Cisco Unity Express ソフトウェアをダウンロードする。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS ソフトウェア リリース 12.4(9)T が稼働する Cisco 3725 ルータ

  • Cisco IOS ソフトウェア リリース 12.1 が稼働する Cisco Catalyst 3550 スイッチ

  • Cisco IP 7960 Phone

  • Cisco Unified CallManager Express 4.0

  • Cisco Unity Express 2.2.2

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションでは、このドキュメントで説明されている機能を設定するための情報を提供します。

注: このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/62609/tdcmecue-1.gif

ローカル DHCP サーバの定義

最適化された IP テレフォニー ネットワークでは、電話用の IP アドレスと PC 用の IP アドレスは、異なるネットワークセグメントで設定する必要があります。 Dynamic Host Control Protocol(DHCP; 動的ホスト制御プロトコル)を使用すると、再利用可能な IP アドレスが自動的に DHCP クライアントに割り当てられます。 Cisco IOS の DHCP サーバ機能には、DHCP クライアントに対して、ルータ内の指定されたアドレス プールからの IP アドレスの割り当てと管理を行う DHCP サーバのフル機能が実装されています。 Cisco IOS DHCP サーバは、データベースからの DHCP 要求に応じられない場合、ネットワーク管理者が定義した 1 つ以上のセカンダリ DHCP サーバに要求を転送できます。

図 1 は、DHCP クライアントが DHCP サーバに IP アドレスを要求する際に発生する基本手順を示しています。 クライアント(Host A)は、Cisco IOS DHCP サーバを探すために、DHCPDISCOVER ブロードキャスト メッセージを送信します。 DHCP サーバは、DHCPOFFER ユニキャスト メッセージを通じて、IP アドレス、MAC アドレス、ドメイン名、IP アドレスのリースなどの設定パラメータをクライアントに提示します。

図 1 — DHCPサーバからの IP アドレスのための DHCP 要求

/image/gif/paws/62609/tdcmecue-2.gif

クライアントは、DHCPREQUEST ブロードキャスト メッセージを DHCP サーバに返すことで、提示された IP アドレスを正式に要求します。 DHCP サーバは DHCPACK ユニキャスト メッセージをクライアントに返して、その IP アドレスをクライアントに割り当てることを確約します。

次の設定では、2 つのローカル DHCP サーバをセットアップし、1 つを音声用、もう 1 つをデータ用に使用します。 2 つの DHCP サーバを作成すると、2 つのサブネットワークができるため、競合のない適切なアドレス割り当てが可能になります。

次の手順では、IP アドレスの共有プールを作成します。このプールでは、すべての DHCP クライアントがオプション 150 TFTP サーバの IP アドレスを含め、同じ情報を受け取ります。 この方法で DHCP サービスを設定すると、DHCP プールを 1 つしか設定しなくて済むという利点があります。

  1. 特権EXECモードを開始するためにコマンド イネーブルを入力して下さい。

    Router>enable
    
  2. グローバル コンフィギュレーション モードを開始するためにコマンド configure terminal を入力して下さい。

    Router#configure terminal
    
  3. DHCPサーバ アドレス プールの名前を作成し、DHCPプール設定 モードを開始するためにコマンド IP DHCP プール プール名を入力して下さい。

    Router(config)#ip dhcp pool Voice
    
  4. DHCPアドレスプールおよびオプションのマスクの IP アドレスを規定 するためにコマンド network ip-address マスクを入力して下さい。

    Router(dhcp-config)#network 172.22.100.0 255.255.255.0
    
  5. Cisco Unified IP Phone ダウンロード イメージ コンフィギュレーション ファイル TFTPサーバアドレスを規定 するためにコマンドオプション 150 ip ip-address を入力して下さい。

    Router(dhcp-config)#option 150 ip 172.22.1.107
    
  6. IP トラフィックを送信 するか、または受信するのに IP 電話が使用するルータを規定 するためにコマンド デフォルト ルータ IP アドレスを入力して下さいローカルサブネットに外部である。

    Router(dhcp-config)#default-router 172.22.100.1
    
  7. 設定を終了するためにコマンド端を入力して下さい。

    Router(dhcp-config)#end
    

    注:  データ アドレスの範囲のためのローカル DHCPサーバを作成するために同じプロシージャを繰り返して下さい。

ルータ インターフェイスの設定

この場合、プラットフォーム 3725 はコア スイッチに接続するために使用できる 2 つのファーストイーサネットインターフェイスが含まれています。 ただし、データトラフィックを、音声トラフィック送信するためにできたいと思い、1 つのただインターフェイスを使用インターネットにデフォルト ゲートウェイを通してアクセスできます。 これには、インター VLAN 通信と呼ばれる方法を使用するのが適しています。この方法を使用すると、1 つのインターフェイスをいくつかのサブインターフェイスに分割して、複数の論理セグメントまたは VLAN を作成できます。 この機能を使うと、ルータは 1 VLAN のパケットを受信し、別の VLAN に転送できます。 そのためには、スイッチとルータ間の物理接続上で、Inter-Switch Link(ISL; スイッチ間リンク)または 802.1Q トランキングを有効にする必要があります。 サブインターフェイスに IP アドレスが設定されると、ルータは各 VLAN に関連付けられているネットワークを直接接続されているネットワークとして認識します。

図 2 は、FastEthernet 0/0 インターフェイスがトランク ポートに接続されているスイッチに、ルータが接続されているようすを示しています。 FastEthernet インターフェイスは、各 VLAN 用の論理インターフェイサとして複数のサブインターフェイスに分割されており、各ブロードキャスト ドメインのゲートウェイとして機能する IP アドレスが 1 つ割り当てられています。

図 2 — VLAN 間ルーティングを設定して下さい

tdcmecue-3.gif

これが 802.1Q フレーム タグ付けを使用するルータ 3725 に必要な設定を示します:

  1. 特権EXECモードを開始するためにコマンド イネーブルを入力して下さい。

    Router>enable
    
  2. グローバル コンフィギュレーション モードを開始するためにコマンド configure terminal を入力して下さい。

    Router#configuration terminal
    
  3. インターフェイス設定モードを開始するためにライン インターフェイス ファーストイーサネットポートを入力して下さい。

    Router(config)#interface fastethernet 0/0.1
    
  4. ネイティブ VLAN を作成するためにコマンド カプセル化 [dot1q/ISL] ID 数字ネイティブを入力して下さい。

    Router(config-if)#encapsulation dot1q 1 native
    
  5. インターフェイスに有効なアドレスを割り当てるためにコマンド IP アドレス IP アドレス マスクを入力して下さい。

    Router(config-if)#ip address 172.22.1.154 255.255.255.0
    
  6. そのインターフェイスの設定から出るためにコマンド終了を入力して下さい。

    Router(config-if)#exit
    
  7. port.id 数字音声 サブインターフェイスの設定を作成し、入力するためにライン インターフェイス ファーストイーサネットを入力して下さい。

    Router(config)#interface fastethernet 0/0.100
    
  8. ID 数字トランクを有効に するためにコマンド カプセル化 [dot1q/ISL] を入力して下さい。

    Router(config-if)#encapsulation dot1q 100
    
  9. 音声 サブインターフェイスへの有効なアドレスを割り当てるためにコマンド IP アドレス IP アドレス マスクを入力して下さい。

    Router(config-if)#ip address 172.22.100.1 255.255.255.0
    
  10. port.id 数字データ サブインターフェイスの設定を作成し、入力するためにライン インターフェイス ファーストイーサネットを入力して下さい。

    Router(config)#interface fastethernet 0/0.20
    
  11. ID 数字トランクを有効に するためにコマンド カプセル化 [dot1q/ISL] を入力して下さい。

    Router(config-if)#encapsulation dot1q 20
    
  12. データ サブインターフェイスへの有効なアドレスを割り当てるためにコマンド IP アドレス IP アドレス マスクを入力して下さい。

    Router(config-if)#ip address 172.22.101.1 255.255.255.0
    
  13. 設定を終了するためにコマンド端を入力して下さい。

    Router(config-if)#end
    

ネットワーク タイム プロトコルの設定

Network Time Protocol(NTP; ネットワーク タイム プロトコル)を使用すると、Cisco Unified CallManager Express ルータをクロック マスターと呼ばれるネットワーク内の単一のクロックに同期させることができます。 NTP はすべてのインターフェイスでデフォルトでディセーブルにされますが、それは Cisco Unified CallManager Express のために必要です。 従って、有効に なるようにして下さい。 このプロシージャは Cisco 3725 の NTP を有効に するためにステップを説明します:

  1. 特権EXECモードを開始するためにコマンド イネーブルを入力して下さい。

    Router>enable
    
  2. グローバル コンフィギュレーション モードを開始するためにコマンド configure terminal を入力して下さい。

    Router#configure terminal
    
  3. 現地 の 時間帯を設定 するためにコマンド clock timezone ゾーン時間オフセットを入力して下さい。

    Router(config)#clock timezone central -8
    
  4. 夏時間を規定 するために繰り返すコマンド clock summer-time ゾーンを入力して下さい。 デフォルトでは、夏時間は無効になっています。

    Router(config)#clock summer-time central recurring
    
  5. このルータのクロックが規定 された NTP サーバと同期されるようにコマンド NTP サーバのIPアドレスを入力して下さい。 ここでは、TFTP サーバと同じアドレスを指定します。

    Router(config)#ntp server 172.22.1.107
    
  6. 設定を終了するためにコマンド端を入力して下さい。

    Router(config)#end
    

Catalyst スイッチ 3550 での VLAN の設定

音声トラフィックとデータ トラフィックを切り離すには、それぞれの Virtual Local Area Network(VLAN; バーチャル ローカル エリア ネットワーク)を個別に作成します。 そのためには、Catalyst スイッチ上に 2 つの VLAN を作成し、1 つを音声用、もう 1 つをデータ用とします。 これによって、複数のブロードキャスト ドメインを作成し、ネットワークのループの可能性を防ぐ 2 つの論理的なサブネットワークを作成します。 実際に電話および PC は物理的に接続されますが、異なるサブネットワークで論理的に分かれます。 ここでは、Catalyst 3550 で音声用の VLAN を作成する手順について説明します。

図 3 は、VLAN を作成することによってスイッチが 1 つのスイッチド環境内に複数のブロードキャスト ドメインを持つようすを示しています。 ここでは、音声用の VLAN とデータ用の VLAN が作成されています。 2 つの完全に独立したサブネットによって、電話と PC はそれぞれの VLAN 上で通信を行うことができます。

図 3 — VLAN 外観

/image/gif/paws/62609/tdcmecue-4.gif

  1. 特権EXECモードを開始するためにコマンド イネーブルを入力して下さい。

    Switch>enable
    
  2. グローバル コンフィギュレーション モードを開始するためにコマンド configure terminal を入力して下さい。

    Switch#configure terminal
    
  3. スイッチの VLAN を作成するためにコマンド VLAN vlan-id を入力して下さい。

    Switch(config)#vlan 100
    
  4. VLAN に名前をつけるために指令名 VLAN 名前を入力して下さい。

    Switch(config)#name Voice
    
  5. 設定を終了するためにコマンド端を入力して下さい。

    Switch(config)#end
    

    注: 同じ手順でデータ用の VLAN を作成します。

Catalyst スイッチ 3550 でのインターフェイスの設定

Cisco 3725 ルータと Catalyst 3550 スイッチの間のトランキング プロセスを完成させるには、ルータに接続するインターフェイスを設定する必要があります。 トランクが同じリンク内の異なる VLAN からのトラフィックを単一のリンクで伝送できるようにするには、スイッチのインターフェイス設定とルータのインターフェイス設定を一致させる必要があります。 たとえば、スイッチで設定した各 VLAN に対して、VLAN インターフェイス int vlan 1 を作成することができます。 ここでは、デフォルトのインターフェイス VLAN(int vlan 1)を管理 VLAN として使用します。 インターフェイス VLAN を作成して適切に設定したら、そのインターフェイス上でトランキングを有効にする必要があります。 Catalyst 3550 スイッチのインターフェイスの設定を次に示します。

  1. 特権EXECモードを開始するためにコマンド イネーブルを入力して下さい。

    Switch>enable
    
  2. グローバル コンフィギュレーション モードを開始するためにコマンド configure terminal を入力して下さい。

    Switch#configure terminal
    
  3. 設定したいと思うインターフェイスに入るためにライン インターフェイス VLAN vlan-id を入力して下さい。

    Switch(config)#interface vlan 1
    
  4. インターフェイスに有効なアドレスを指定するためにコマンド IP アドレス IP アドレス マスクを入力して下さい

    Switch(config-if)#ip address 172.22.1.201 255.255.255.0
    
  5. そのインターフェイスの設定を終了するためにコマンド終了を入力して下さい。

    Switch(config-if)#exit
    
  6. 外部ネットワークにアクセスを可能にするためにコマンド ip default-gateway ip-address を入力して下さい。

    Switch(config)#ip default-gateway 172.22.1.1
    
  7. トランキングのために有効に なる必要があるインターフェイスに入るためにライン インターフェイス ファーストイーサネットポートを入力して下さい

    Switch(config)#interface fastethernet 0/19
    
  8. 帯がタグ付けされている方式を選択するためにコマンド スイッチポートトランクカプセル化 [dot1q/ISL] を入力して下さい。

    Switch(config-if)#switchport trunk encapsulation dot1q
    
  9. トランクを有効に するためにコマンド switchport mode trunk を入力して下さい。

    Switch(config-if)#switchport mode trunk
    
  10. トランクのすべての VLAN を割り当てるためにコマンドをスイッチポートトランクによって許可される VLAN すべて入力して下さい。

    Switch(config-if)#switchport trunk allowed vlan all
    
  11. そのルータの二重とデュプレクスモードを、同じ有効に するためにコマンド二重[十分に/半分]入力して下さい。

    Switch(config-if)#duplex full
    
  12. データの速度を設定するためにコマンド速度数を入力して下さい。

    Switch(config-if)#speed 100
    
  13. 設定を終了するためにコマンド端を入力して下さい。

    Switch(config-if)#end
    

Cisco 7960 IP Phone に接続するためのポートの設定

Cisco 7960 IP Phone は PC またはその他のデバイスへの接続をサポートします。 従って、Cisco 7960 IP Phone に Catalyst 3550 シリーズ スイッチを接続するインターフェイスは音声 および データ トラフィックのミックスを運ぶことができます。 同じリンク上の音声用 VLAN とデータ用 VLAN からのトラフィックを伝送し、これらの VLAN をネットワーク全体に拡張できるようにするには、インターフェイスをトランクとして設定する必要があります。 トランク モードが有効に なれば トラフィックがどのように分けられるか規定 するために、異なる VLAN のための 2 つのスイッチポートは設定する必要があります。 音声用 VLAN では音声トラフィックを伝送するように設定し、ネイティブ VLAN ではその他のトラフィックをタグなしで通過させるように設定します。 音声トラフィックとデータ トラフィックを異なる VLAN で伝送するようにポートを設定するには、次の手順を実行します。

図 4 スイッチと電話の間で作成されるトランクを示します。 このトランクは 802.1q タイプのカプセル化を反映しているため、別々の VLAN をネットワーク全体に拡張できます。

図 4 —トランキング

/image/gif/paws/62609/tdcmecue-5.gif

  1. 特権EXECモードを開始するためにコマンド イネーブルを入力して下さい。

    Switch>enable
    
  2. グローバル コンフィギュレーション モードを開始するためにコマンド configure terminal を入力して下さい。

    Switch#configure terminal
    
  3. 電話を接続するのに使用されるポートを入力するためにライン インターフェイス ファーストイーサネットポートを入力して下さい。

    Switch(config)#interface fastethernet0/21
    
  4. VLANトランクでポートを設定するためにコマンド switchport mode trunk を入力して下さい。

    Switch(config-if)#switchport mode trunk
    
  5. ポートを 802.1q カプセル化をサポートするために設定するためにコマンド スイッチポートトランクカプセル化 dot1q を入力して下さい。

    Switch(config-if)#switchport trunk encapsulation dot1q
    
  6. Cisco IP Phone に特定のVLAN によってすべての音声トラフィックを転送するように指示するためにコマンド スイッチポート音声VLAN vlan-id を入力して下さい。

    Switch(config-if)#switchport voice vlan 100
    
  7. Cisco IP Phone に特定のVLAN によってすべてのデータトラフィックを転送するように指示するためにコマンド switchport trunk native vlan vlan-id を入力して下さい。

    Switch(config-if)#switchport trunk native vlan 20
    
  8. 設定を終了するためにコマンド端を入力して下さい。

    Switch(config-if)#end
    

Cisco Unified CallManager Express のパラメータの設定

設定プロセスにおける次の手順は、IP Phone がオンラインになったときや、リブートしたときに、IP Phone が自動的にデフォルト値を見つけ出して自分自身を設定できるように eXtensible Markup Language(XML)形式の電話機コンフィギュレーション ファイルを修正することです。 セキュリティ目的で、権限なしであらゆる電話から接続を防ぐために非自動登録に自動登録オプションを消して下さい。 Cisco Unified CallManager Express システムに必要なテレフォニー パラメータ値を設定するには、次の手順を実行します。 このプロシージャによって、コンフィギュレーション ファイルを構築します。 従って、電話は彼ら自身をリセットするためにパラメータ値をダウンロードできます。

  1. 特権EXECモードを開始するためにコマンド イネーブルを入力して下さい。

    Router>enable
    
  2. コンフィギュレーションモードを開始するためにコマンド configure terminal を入力して下さい。

    Router#configure terminal
    
  3. コマンド tftp-server フラッシュするを入力して下さい: ルータによって動作される IP Phone によって指定 ファイルに TFTP アクセスを提供するファイル名割り当て Cisco Unified CallManager Express ルータ。

    Router(config)#tftp-server flash:P00307020300.bin
    
  4. 電話コンフィギュレーションモードを開始するためにコマンド telephony-service を入力して下さい。

    Router(config)#telephony-service
    
  5. このプラットフォームがサポートされる IP 電話の最大数を設定 するためにコマンド max-ephones 最大値数字電話を入力して下さい。

    Router(config-telephony)#max-ephones 144
    
  6. このプラットフォームにあることができる拡張の最大数を設定 するためにコマンド max-dn 最大値ディレクトリ数を入力して下さい。

    Router(config-telephony)#max-dn 500
    
  7. システムへのあらゆる電話の接続を防ぐためにコマンドを自動 reg ephone 入力しないで下さい。

    Router(config-telephony)#no auto-reg-ephone
    
  8. IP Phone がシステムで登録するのに使用するファームウェアファイルを識別するためにコマンド ロード 電話のタイプ ファームウェアファイルを入力して下さい。

    Router(config-telephony)#load 7960 P0030700300
    
  9. Cisco Unified CallManager Express ルータが IP Phone 登録のために使用する IP アドレスをおよびポート番号を確認するためにコマンド IPソースアドレス IP アドレスを入力して下さい。 デフォルトのポートは 2000 です。

    Router(config-telephony)#ip source-address 172.22.1.107
    
  10. コマンドを XML コンフィギュレーション ファイルを構築するために作成します cnf ファイルを入力して下さい。

    Router(config-telephony)#create cnf-files
    
  11. コール転送 方式を規定 するためにコマンド転送システム全コンサルタントを入力して下さい。 デフォルトの方法は次のとおりです。

    Router(config-telephony)#transfer-system full-consultant
    
  12. 外部コールを送信するために 9 つにダイヤルするとき別のトーンを作成するためにコマンド セカンダリ ダイヤルトーン 9 を入力して下さい。

    Router(config-telephony)#secondary-dialtone 9
    
  13. 設定を終了するためにコマンド端を入力して下さい。

    Router(config-telephony)#end
    

IP Phone のプロビジョニング

Cisco Unified CallManager Express パラメータは設定 されます従って IP 電話は登録し、機能し始めることができます。 ただし、呼び出しを作り、受信し始める前に Cisco Unified CallManager Express システムでほしいと思う特定の IP 電話を登録する必要があります。 次の手順では、個々の ephone-dn を設定して、それぞれを 1 つ以上の ephone の 1 つ以上のボタンに関連付けます。 ephone-dn は仮想回線(内線)であり、これを使用することでコール接続を行うことが可能になります。 LAN 環境でサポートされるには、Cisco CallManager Express ルータでそれぞれの物理的な電話機を ephone として設定する必要があります。 二重回線モードの ephone-dn を作成するには、ephone-dn コマンドと dual-line キーワードを使用します。 その理由は、1 つの音声ポートと 2 つのチャネルを使用して 2 つの独立したコールを処理するためです。 このモードを使用すると、コール転送、コール ウェイティング、および会議オプションが利用可能になります。 このプロシージャは二重行モードでの ephone および ephone dns を登録します:

  1. Execモードを開始するためにコマンド イネーブルを入力して下さい。

    Router>enable
    
  2. コンフィギュレーションモードを開始するためにコマンド configure terminal を入力して下さい。

    Router#configure terminal
    
  3. 2 つのチャネルで拡張を作成するためにコマンド ephone-dn dn タグ二重行を入力して下さい。

    Router(config)#ephone-dn 11 dual-line
    
  4. 有効な拡張番号を設定するためにコマンド number number を入力して下さい。

    Router(config-ephone-dn)#number 1001
    
  5. この ephone-dn に名前を関連付けるために指令名名前を入力して下さい。

    Router(config-ephone-dn)#name John Smith
    
  6. ephone-dn 設定を残すためにコマンド終了を入力して下さい。

    Router(config-ephone-dn)#exit
    
  7. 物理的 な 電話 設定を入力するためにコマンド ephone 電話タグを入力して下さい。

    Router(config)#ephone 1
    
  8. どの電話が設定されるか規定 するためにコマンド MAC アドレス[MAC アドレス]入力して下さい。

    Router(config-ephone)#mac-address 0030.94C2.D6E7
    
  9. 電話の種類を規定 するためにコマンドの種類電話のタイプを入力して下さい。

    Router(config-ephone)#type 7960
    
  10. 拡張とボタン番号およびライン特性を関連付けるために Command ボタン ボタン数(分離器) dn タグを入力して下さい。 この場合、a を使用して下さい: (正常なリングを意味するコロン)区切り記号。

    Router(config-ephone)#button 1:11
    
  11. 設定を終了するためにコマンド端を入力して下さい。

    Router(config-ephone)#end
    

Cisco CallManager Express でのダイヤル プランの設定

ダイヤル プラン パターンとは、短縮内線番号を完全な E.164 番号に変換するためのグローバル プレフィクスを指定する一連の数字です。 この設定によって、Cisco Unified CallManager Express システムは完全な E.164 電話番号 パターンに短縮された拡張番号 プレフィクスのためのディジット パターンをマッピング できます。 このプロシージャはダイヤルプラン パターンのための設定を示します:

  1. Execモードを開始するためにコマンド イネーブルを入力して下さい。

    Router>enable
    
  2. コンフィギュレーションモードを開始するためにコマンド configure terminal を入力して下さい。

    Router#configure terminal
    
  3. telephony-service コンフィギュレーションモードを開始するためにコマンド telephony-service を入力して下さい。

    Router(config)#telephony-service
    
  4. 電話に拡張番号を一致させるためにコマンド dialplan パターン タグ パターン 拡張 長さ 長さを入力して下さい。

    Router(config-telephony)#dialplan-pattern 1 5123781291 extension length 4
    
  5. 設定を終了するためにコマンド端を入力して下さい。

    Router(config-telephony)#end
    

PSTN への接続

この作業では、Public Switched Telephone Network(PSTN; 公衆電話交換網)に接続できるように FXO 音声ポートを設定します。 ネットワークの外にある電話機に接続するには、コールの受発信に必要なハードウェア(音声ポート)とダイヤル ピアを設定します。

この設定は 3 つの部分に分けられます。 まず、ダイヤルインを受け入れる内線(着信コールを取り次ぐ受付係など)に着信コールを転送するように FXO ポートを設定する必要があります。 このプロシージャは FXO ポートを設定するのを助けます:

  1. Execモードを開始するためにコマンド イネーブルを入力して下さい。

    Router>enable
    
  2. コンフィギュレーションモードを開始するためにコマンド configure terminal を入力して下さい。

    Router#configure terminal
    
  3. 音声ポート設定モードを開始し、設定するべきかどんなポートを規定 するためにコマンド 音声ポート スロット/ポートを入力して下さい。 このポートは電話ケーブルが接続されているポートで、この例では音声ポート 1/0 です。

    Router(config)#voice-port 2/1/0
    
  4. 専用回線を、ディジット 引数によって規定 される 拡張への自動リング(PLAR)接続規定 し、自動的に着信コールを転送するためにコマンド 接続 PLAR ディジットを入力して下さい。

    Router(config-voiceport)#connection plar 1001
    
  5. 設定される呼び出し側ID情報が FXO ポートで受け取られるようにコマンド caller-id イネーブルを入力して下さい。

    Router(config-voiceport)#caller-id enable
    
  6. 音声ポート 設定を残すためにコマンド終了を入力して下さい。

    Router(config-voiceport)#exit
    

次に、Cisco CallManager Express システムが特定の FXO ポートに電話番号を関連付けてコールを発信できるようにするために、いくつかのダイヤル ピアを作成する必要があります。 処理の順序と制約を考慮しながら、ダイヤル ピアを必要な数だけ作成する必要があります(市内電話、長距離電話、国際電話など)。 ダイヤル ピアの詳細については、『Cisco IOS プラットフォーム上でのダイヤルピアとコール レッグについて』を参照してください。 その後、ダイヤル ピアと宛先パターンに音声ポート番号を割り当てます。 このプロシージャは市内電話のためのダイヤル ピアを設定します:

  1. アウトバウンドPOTS ダイヤル ピアを設定するためにコマンド dial-peer voice タグ POTS を入力して下さい。

    Router(config)#dial-peer voice 1 pots
    
  2. コールを送信するためにプレフィクスおよび宛先番号が含まれているダイヤルするユーザが必要がある数のパターンを規定 するためにコマンド destination-pattern string を入力して下さい。

    この番号にはさまざまな文字を使用できます。 ただし、このプロシージャはプレフィクス 9 (外部コールを送信する数ダイヤル)、[] (角カッコ)で設定します市内電話 ダイヤル ピアおよび範囲を示すために 6 つを「」。 (ドット)入力されたディジットを一致するため。 詳細については、『ダイヤル プラン、ダイヤル ピア、およびディジット操作の設定』の「ディジット ストリッピングとプレフィクス」セクションを参照してください。

    Router(config-dial-peer)#destination-pattern 9[2-9]......
    

    注: 特殊文字の ^ と $ は明示的に一致した数字としてカウントされますが、( ) 内のパターンは明示的に一致した数字としてはカウントされません。

  3. このピアへの呼び出しが送信されるポートを規定 するためにコマンド ポート スロット/ポートを入力して下さい。

    Router(config-dial-peer)#port 2/1/0
    
  4. 外部コールを送信するために数がダイヤルトーンを与えること規定 するためにコマンド プレフィクス数文字カンマを入力して下さい。

    Router(config-dial-peer)#prefix 9,
    
  5. 設定を終了するためにコマンド端を入力して下さい。

    Router(config-dial-peer)#end
    

最後に、アナログ電話機が Foreign Exchange Station(FXS)ポートに接続できるように、ダイヤル ピアを作成する必要があります。 FXS インターフェイスは、一般的な電話機、キーセット、PBX への接続を可能にし、呼び出し音、電圧、およびダイヤル トーンを提供する RJ-11 コネクタです。 ルータの FXS ポートを設定するには、このダイヤル ピアに FXS ポートを割り当てて、宛先番号または内線番号を指定する必要があります。 これは FXS ポートを設定するプロシージャです:

  1. コンフィギュレーションモードを開始するためにコマンド configure terminal を入力して下さい。

    Router#configure terminal
    
  2. アウトバウンドPOTS ダイヤル ピアを設定するためにコマンド dial-peer voice タグ POTS を入力して下さい。

    Router(config)#dial-peer voice 5 pots
    
  3. コールを送信するためにダイヤルするユーザが必要がある数のパターンを規定 するためにコマンド destination-pattern string を入力して下さい。 ここでは、他のダイヤル ピアとの混乱を避けるために、宛先パターンの内線番号の長さを IP Phone と同じにします。

    ダイヤル ピアで、アナログ式電話から市内電話、長距離および国際電話のコールを作れます。

    Router(config-dial-peer)#destination-pattern 1005
    
  4. このピアへの呼び出しが送信される FXS インターフェイスに対応するポートを規定 するためにコマンド ポート スロット/ポートを入力して下さい。

    Router(config-dial-peer)#port 2/0/0
    
  5. 設定を終了するためにコマンド端を入力して下さい。

    Router(config-dial-peer)#end
    

Cisco Unity Express ソフトウェアへの IP 接続の有効化

この場合 Cisco Unity Express 2.2.2 から Cisco Unified CallManager Express 4.0 を統合必要があります。 これをするために、2 つのインターフェイスを作成する必要があります従って Cisco Unity Express と Cisco Call Manager Express 間の通信は起こることができます。 1 つ目のインターフェイスは、前の「ルータ インターフェイスの設定」セクションで設定した、Cisco CallManager Express をホスティングするルータへのインターフェイスです。 2 つ目のインターフェイスは、Cisco Unity Express と Cisco CallManager Express のポートと IP アドレスを相互に関連付けるインターフェイスです。 このタスクを実現させるためにこれらのステップを完了して下さい:

  1. Execモードを開始するためにコマンド イネーブルを入力して下さい。

    Router>enable
    
  2. コンフィギュレーションモードを開始するためにコマンド configure terminal を入力して下さい。

    Router#configure terminal
    
  3. Cisco Unity Express インターフェイス設定モードを開始するためにライン インターフェイス サービス エンジン スロット/ユニットを入力して下さい。

    Router(config)#interface service-engine 1/0
    
  4. Cisco IOS ルータのためのインターフェイスの種類および数を規定 するためにコマンド ip unnumbered type number を入力して下さい。

    Router(config-if)#ip unnumbered fastethernet 0/0.1
    
  5. Cisco Unity Express モジュールインターフェイスの IP アドレスを規定 するためにコマンド service-module IP アドレス キュー IP アドレス サブネット・マスクを入力して下さい。 この IP は、Cisco Unity Express をホスティングする Cisco IOS ルータと同じサブネット上に存在する必要があります。

    Router(config-if)#service-module ip address 172.22.1.155 255.255.255.0
    
  6. Cisco IOS ルータの IP アドレスを規定 するためにコマンド service-module ip default-gateway IP アドレスをそのホスト Cisco Unity Express 入力して下さい。

    Router(config-if)#service-module ip default-gateway 172.22.1.154
    

    注: これらのステップは proxy-arp がサービス エンジン 設定で非番号ように参照されるインターフェイス(FastEthernet0/0.1)で現在 有効に なる場合その時だけはたらきます。 Proxy-arp はイーサネットインターフェイスでデフォルトで有効に なり、Show ip interface FastEthernet0/0.1 を発行する場合インターフェイスの proxy-arp の動作状態は確認することができます。 proxy-arp が無効である場合、インターフェイスコンフィギュレーションの下で ip proxy-arp を発行する場合再び有効にすることができます

  7. インターフェイスコンフィギュレーションを終了するためにコマンド終了を入力して下さい。

    Router(config-if)#exit
    
  8. Cisco Unity Express モジュールにスタティック ルートを確立するためにコマンド IP ルート IP アドレス マスク サービス エンジン スロット/数を入力して下さい。

    Router(config)#ip route 172.22.1.155 255.255.255.255 service-engine 1/0
    
  9. 設定を終了するためにコマンド終了を入力して下さい。

    Router(config)#end
    

    注: Cisco Unity Express モジュール CLI にイネーブル モードがあるが、Cisco Unity Express はパスワード機能がありません。 ルータのモードを有効に する アクセスのどのネットワーク管理者でも Cisco Unity Express CLI にアクセスできます。 Cisco Unity Express CLI にユーザ ID またはパスワード制御がありません。 アクセスはルータで制御されています。 記録が必要となる場合、ログオン アクセスの AAA/RADIUS モニタリングのルータを設定する必要があります。

Cisco Unity Express ボイスメールをコールするための Cisco CallManager Express 電話機のダイヤル ピアの設定

Cisco CallManager Express と Cisco Unity Express の間の通信を容易にするには、専用のダイヤル ピアが必要になります。 このダイヤル ピアの宛先パターンは、Cisco Unity Express などのアプリケーションに専用の電話番号セットを割り当てます。 ここで考慮すべきことは、ボイスメール番号がダイヤル ピアの宛先パターンの範囲に含まれている必要があることと、ダイヤル ピアを使用するためのトリガーとなるボイスメール番号にコールを転送するように ephone-dn を設定する必要があることです。 Cisco Unity Express のダイヤル ピアは、Session Initiation Protocol(SIP)を使用して通話セッションを確立し、Dual Tone MultiFrequency(DTMF)トーンを SIP 通知メッセージに変換する必要があります。 また、Voice Activity Detection(VAD; 音声アクティビティ検出)をオフにして、コーデックを指定する必要があります。

  1. Execモードを開始するためにコマンド イネーブルを入力して下さい。

    Router>enable
    
  2. コンフィギュレーションモードを開始するためにコマンド configure terminal を入力して下さい。

    Router#configure terminal
    
  3. 音声 カプセル化の方式のダイヤル ピアを定義するためにコマンド dial-peer voice タグ voip を入力して下さい。

    Router(config)#dial-peer voice 2 voip
    
  4. ダイヤル ピアに使用するべきプレフィクスか E.164 完全な数を規定 するためにコマンド destination-pattern string を入力して下さい。

    Router(config-dial-peer)#destination-pattern 2...
    
  5. ホスト Cisco Unified CallManager Express ルータと Cisco Unity Express モジュール間の呼び出しのためのセッションプロトコルとして SIP を規定 するためにコマンド セッションプロトコル sipv2 を入力して下さい。

    Router(config-dial-peer)#session protocol sipv2
    
  6. ネットワーク仕様アドレスを Voice over IP ダイヤル ピアから呼び出しを受信するために指定するためにコマンド session target ipv4:destination-ip アドレスを入力して下さい。

    Router(config-dial-peer)#session target ipv4:172.22.1.155
    
  7. SIP を使用して DTMF トーンを転送するためにコマンド dtmf-relay 一口呼出を通知しますメッセージを入力して下さい。

    Router(config-dial-peer)#dtmf-relay sip-notify
    
  8. ダイヤル ピアのためのスピーチの音声 コーデック 比率を規定 するためにコマンド コーデック コーデックを入力して下さい。

    Router(config-dial-peer)#codec g711ulaw
    

    注: どのミスマッチでも着信 発信 コール失敗という結果に終るかもしれませんようにコーデックのミスマッチがないことを常に確認して下さい。

  9. 特定のダイヤル ピアを使用する呼び出しのための VAD をディセーブルにするためにコマンド no vad を入力して下さい。

    Router(config-dial-peer)#no vad
    
  10. 設定を終了するためにコマンド終了を入力して下さい。

    Router(config-dial-peer)#end
    

ボイスメール アクセスの設定

Cisco Unified CallManager Express 設定は以前に作成したダイヤル ピアのためのデスティネーションパターンの範囲の内にある音声メール数の作成を含む必要があります。 音声メール番号は Cisco IP Phone の Messages ボタンが押される、または使用中か未解答コールは音声メールに転送されますときダイヤルされる電話番号です。 音声メール電話番号を設定するためにこれらのステップを完了して下さい。 さらに未解答を転送するために、ephone dns が設定する音声メールへの使用中呼び出しは番号が付いています。

  1. Execモードを開始するためにコマンド イネーブルを入力して下さい。

    Router>enable
    
  2. コンフィギュレーションモードを開始するためにコマンド configure terminal を入力して下さい。

    Router#configure terminal
    
  3. telephony-service コンフィギュレーションモードを開始するためにコマンド telephony-service を入力して下さい。

    Router(config)#telephony-service
    
  4. Messages ボタンが押されるときダイヤルされる番号を定義するためにコマンド音声メール電話番号を入力して下さい。

    Router(config-telephony-service)#voicemail 2000
    
  5. 設定を終了するためにコマンド終了を入力して下さい。

    Router(config-telephony-service)#exit
    
  6. ephone-dn コンフィギュレーションモードを以前に作成される拡張を修正するために開始するためにコマンド ephone-dn dn タグを入力して下さい。

    Router(config)#ephone-dn 11
    
  7. 使用中拡張への着信コールが音声メールに転送されるようにコール転送を設定するためにコマンド Call Forward Busy ディレクトリ番号を入力して下さい。

    Router(config-ephone-dn)#call-forward busy 2000
    
  8. 無応答 拡張への着信コールが音声メールに転送されるようにコール転送を設定するためにコマンド 自動転送 noan ディレクトリ番号 タイムアウト秒を入力して下さい。

    Router(config-ephone-dn)#call-forward noan 2000 time 10
    
  9. 設定を終了するためにコマンド端を入力して下さい。

    Router(config-ephone-dn)#end
    

    注: システムに接続されているすべての Cisco IP Phone に対して手順 6 〜 9 を繰り返します。

MWI の設定

MWI メカニズムとは、ボイスメール メッセージが届いていることをユーザに知らせるため Cisco IP Phone のライト インジケータを点灯させる仕組みです。 MWI メカニズムは、ボイスメール メッセージが残されるとオンになり、ユーザがボイスメールを聞き終えるとオフになります。 MWI メカニズムを機能させるためには、2 つの ephone-dn を作成し、一方の ephone-dn(たとえば ephone-dn 8000)で MWI 機能を有効にし、もう一方の ephone-dn(たとえば ephone-dn 8001)で MWI 機能を無効にします。

内線番号(内線 1001)にかかってきたコールに対して応答がない場合、IP Phone はそのコールをボイスメールに転送し、発信者はそこにメッセージを残します。 メッセージが記録されれば、Cisco Unity Express は ephone-dn を送信します(処理する MWI に MWI 通知 コールを 8000) 通知 コールのためのコーリングパーティ ID として 1001) ext.拡張を追加 し、ext. (。 ダイヤルされる数は 80001001 です。 光は拡張をつけます(1001) ext。

その内線電話(内線 1001)のユーザがすべてのボイスメールを聞き終えると、Cisco Unity Express は MWI 処理用の ephone-dn(内線 8001)に MWI 通知コールを発信し、通知コールの発信者 ID として内線番号(内線 1001)を付加します。 ここでダイヤルされる番号は 80011001 です。 ユーザが音声メールを受信した後、光は消えます。 これは MWI ephone dns を設定するプロシージャです:

  1. Execモードを開始するためにコマンド イネーブルを入力して下さい。

    Router>enable
    
  2. コンフィギュレーションモードを開始するためにコマンド configure terminal を入力して下さい。

    Router#configure terminal
    
  3. Cisco IP Phone 行のための拡張を作成するためにコマンド ephone-dn を入力して下さい。

    Router(config)#ephone-dn 14
    
  4. ephone-dn と電話か拡張を関連付けるためにコマンド number number を入力して下さい。

    Router(config-ephone-dn)#number 8000....
    
  5. コマンド mwi を入力して下さい[で|を離れて]仕様 ephone dns を外部ボイスメール システムから MWI 通知を受信するために設定するため。

    Router(config-ephone-dn)#mwi on
    
  6. 設定を終了するためにコマンド端を入力して下さい。

    Router(config-ephone-dn)#end
    

    注: 同じ手順で内線 8001 を作成し、MWI をオフに設定します。

ボイスメール アプリケーションの設定

今後は接続がルータからモジュールに確立する必要があることを、NM Cisco 実際の Unity Express モジュールで作られるコンフィギュレーション必要のほとんど従ってそれは意味します。 Cisco Unity Express に Cisco IOS CLI コマンドにおける EXEC およびコンフィギュレーションモードに同様に動作するコンフィギュレーションモードおよび EXEC があります。 Cisco Unity Express を入力するために service-module サービス エンジンを 1/0 の session コマンド発行して下さい。 これは音声メールを設定するプロシージャです:

  1. モジュールに接続するためにコマンド service-module サービス エンジン 1/0 セッションを入力して下さい。

    Router#service-module service-engine 1/0 session
    
  2. Execモードを開始するためにコマンド イネーブルを入力して下さい。

    se-172-22-1-155>enable
    
  3. コンフィギュレーションモードを開始するためにコマンド configure terminal を入力して下さい。

    se-172-22-1-155#configure terminal
    
  4. 音声メールのためのアプリケーション 設定を入力するためにコマンド ccn アプリケーション音声メールを入力して下さい。

    se-172-22-1-155(config)#ccn application voicemail
    
  5. アプリケーションの説明を入力するためにコマンドの記述「テキスト」を入力して下さい。

    se-172-22-1-155(config-application)#description "Cisco Voicemail"
    
  6. コマンド maxsessions をこのアプリケーションに同時にアクセスできるサブスクライバの数を規定 するために番号が付いています入力して下さい。 この値の詳細については、『アプリケーションおよびトリガー間のポートの共有』を参照してください。

    se-172-22-1-155(config-application)#maxsessions 4
    
  7. アプリケーション 設定を終了するためにコマンド終了を入力して下さい。

    se-172-22-1-155(config-application)#exit
    
  8. コンフィギュレーションモードを終えるためにコマンド終了を入力して下さい。

    se-172-22-1-155(config)#exit
    

自動応答アプリケーションの設定

自動応答アプリケーションを使用すると、コールへの応答を自動オペレータに行わせることができ、発信者にさまざまなオプションを含むメニューを提示できます。 たとえば、Cisco Unity Express システムに自動転送があれば、発信者は歓迎されたメッセージを受信し、それからオプションを特定の部門(たとえば、販売、HR 等)または特定の人に転送されるために選択できます(たとえば、ジョン・スミス、アレックス ルイス等)。 このプロシージャはオートアテンダントに設定を提供します:

  1. モジュールに接続するためにコマンド service-module サービス エンジン スロット/数セッションを入力して下さい。

    Router#service-module service-engine 1/0 session
    
  2. Execモードを開始するためにコマンド イネーブルを入力して下さい。

    se-172-22-1-155#enable
    
  3. コンフィギュレーションモードを開始するためにコマンド configure terminal を入力して下さい。

    se-172-22-1-155#configure terminal
    
  4. アプリケーションを設定するために規定 するためにコマンド ccn アプリケーション autoattendant を入力して下さい。

    se-172-22-1-155(config)#ccn applicatio autoattendant
    
  5. アプリケーションの説明を入力するためにコマンドの記述「テキスト」を入力して下さい。

    se-172-22-1-155(config-application)#description "Cisco Auto-Attendant"
    
  6. コマンド maxsessions をこのアプリケーションに同時にアクセスできる発信者の数を規定 するために番号が付いています入力して下さい。 この値の詳細については、『アプリケーションおよびトリガー間のポートの共有』を参照してください。

    se-172-22-1-155(config-application)#maxsessions 4
    
  7. アプリケーションのためのパラメータを規定 するためにコマンドパラメータ「名前」「値」を入力して下さい。

    se-172-22-1-155(config-application)#parameter "operExtn" "1001"
    
  8. アプリケーション 設定を終了するためにコマンド終了を入力して下さい。

    se-172-22-1-155(config-application)#exit
    
  9. 設定を終了するためにコマンド終了を入力して下さい。

    se-172-22-1-155(config)#exit
    

アプリケーションの SIP トリガーの設定

ボイスメールと自動応答を設定した後は、特定の信号やトリガーが呼び出されたときにボイスメール アプリケーションと自動応答アプリケーションが起動するようにシステムを設定する必要があります。 このトリガーとは電話番号です。 発信者が指定された電話番号をダイヤルすると、SIP サブシステムがボイスメールや自動応答を起動します。 このプロシージャは音声メールのための SIP トリガーを設定します:

  1. モジュールに接続するためにコマンド service-module サービス エンジン スロット/数セッションを入力して下さい。

    Router#service-module service-engine 1/0 session
    
  2. Execモードを開始するためにコマンド イネーブルを入力して下さい。

    se-172-22-1-155>enable
    
  3. コンフィギュレーションモードを開始するためにコマンド configure terminal を入力して下さい。

    se-172-22-1-155#configure terminal
    
  4. トリガー コンフィギュレーションモードとして機能する電話番号を規定 するためにコマンド ccn トリガー一口 phonenumber 数を入力して下さい。 この番号は、Cisco Unity Express をポイントする SIP ダイヤル ピアの destination-pattern フィールドで設定したいずれかのパターンと一致していてもかまいません。

    se-172-22-1-155(config)#ccn trigger sip phonenumber 2000
    
  5. トリガーが入るときアプリケーションの名前を開始するために規定 するためにコマンド ライン アプリケーション ストリングを入力して下さい。

    se-172-22-1-155(config-trigger)#application voicemail
    
  6. トリガーを有効に するために有効に なる コマンドを入力して下さい。

    se-172-22-1-155(config-trigger)#enabled
    
  7. コマンド maxsessions をアプリケーションが同時に処理できる発信者の最大数を規定 するために番号が付いています入力して下さい。 この値の詳細については、『アプリケーションおよびトリガー間のポートの共有』を参照してください。

    se-172-22-1-155(config-trigger)#maxsessions 4
    
  8. トリガー 設定を終了するためにコマンド終了を入力して下さい。

    se-172-22-1-155(config-trigger)#exit
    
  9. 設定を終了するためにコマンド終了を入力して下さい。

    se-172-22-1-155(config)#exit
    

    注: 同じ手順を自動応答アプリケーションと promptmgmt アプリケーションに対しても繰り返します。

ユーザの設定

次に、システムを利用するユーザとグループを作成します。 拡張およびアクセス音声メールがある個人全員はユーザである必要があります。 Cisco Unity Express に初めてアクセスすると、デフォルトで管理者ユーザが作成されます。 この管理者にはボイス メールボックスを割り当てられません。 ただし、音声メールおよびオートアテンダント アプリケーションが含まれている管理者はシステムを設定できます。 このプロシージャはユーザを作成し、電話番号を割り当てます:

  1. モジュールに接続するためにコマンド service-module サービス エンジン スロット/数セッションを入力して下さい。

    Router#service-module service-engine 1/0 session
    
  2. Execモードを開始するためにコマンド イネーブルを入力して下さい。

    se-172-22-1-155>enable
    
  3. コマンド ユーザ名 USERID を規定 された ユーザ ID でサブスクライバを作成するために作成します入力して下さい。

    se-172-22-1-155#username John create
    
  4. コンフィギュレーションモードを開始するためにコマンド configure terminal を入力して下さい。

    se-172-22-1-155#configure terminal
    
  5. このサブスクライバのための拡張を規定 するためにコマンド ユーザ名 USERID phoneumber 数を入力して下さい。

    se-172-22-1-155(config)#username John phonenumber 1002
    
  6. 設定を終了するためにコマンド終了を入力して下さい。

    se-172-22-1-155(config)#exit
    

    注: この手順を繰り返して必要な数のユーザを登録します。ユーザ数は Cisco Unity Express システムでサポートされる制限を超えないようにしてください。 管理者ユーザには、Cisco Unity Express の設定と変更を行えるように、必ずパスワードと PIN を割り当ててください。 パスワードと PIN の詳細については、『ユーザの追加と修正』を参照してください。

メールボックスの設定

Cisco Unity Express データベースを設定するためにサブスクライバに音声 メールボックスを割り当てて下さい。 メールボックス加入者とは、前のセクションで作成したユーザです。 管理者ユーザのように、すべての加入者や内線にメールボックスを割り当てる必要はありません。 メールボックスを効率的に使用するには、メールボックスを割り当てる前に、加入者や内線の役割と目的を考慮する必要があります。

音声メールは圧縮されていないし、G.711 コーデックを使用します。 G.711 オーディオの毎秒は 480 の K バイト/分に 64 キロビット/秒に、そう 8 つの K バイト/二番目に変換します匹敵します。 このリストは各 Cisco Unity Express モジュールタイプのための収蔵可能量概略を表示します:

  • Cisco Unity Express Advanced Integration モジュール(AIM-CUE) — 14 時間

  • Cisco Unity Express ネットワーク モジュール(NM-CUE) — 100 時間

  • Cisco Unity Express 拡張 な キャパシティ(NM-CUE-EC) — 300 時間

この設定では、個人用のメールボックスを作成します。 個人用メールボックスは特定の加入者に割り当てられ、その加入者だけがアクセスできます。 発信者がこのメールボックスにメッセージを残すと、Message Waiting Indicator(MWI; メッセージ ウェイティング インジケータ)ライトが点灯します。 音声 メールボックスを設定するためにこれらのステップを完了して下さい:

  1. モジュールに接続するためにコマンド service-module サービス エンジン スロット/数セッションを入力して下さい。

    Router#service-module service-engine 1/0 session
    
  2. Execモードを開始するためにコマンド イネーブルを入力して下さい。

    se-172-22-1-155>enable
    
  3. コンフィギュレーションモードを開始するためにコマンド configure terminal を入力して下さい。

    se-172-22-1-155#configure terminal
    
  4. 名の値のためのメールボックスを作成するためにコマンド 音声 メールボックス 所有者名を入力して下さい。

    se-172-22-1-155(config)#voice mailbox owner John
    
  5. メールボックスの説明を示すためにコマンドの記述「テキスト」を入力して下さい。

    se-172-22-1-155(config-mailbox)#description "John's Mailbox"
    
  6. 新しいメールボックスをアクティブにするか、または無効メールボックスを再稼働するためにコマンド イネーブルを入力して下さい。

    se-172-22-1-155(config-mailbox)#enable
    
  7. メッセージがメールボックスで保存される日数を設定 するためにコマンド 有効期限日に入って下さい。 デフォルトは 30 日です。

    se-172-22-1-155(config-mailbox)#expiration time 10
    
  8. コマンドを秒のメールボックスの記憶域のサイズを規定 するために mailboxsize 秒を入力して下さい。

    se-172-22-1-155(config-mailbox)#mailboxsize 300
    
  9. コマンドを秒の着信メッセージの最大サイズを、規定 するために messagesize 秒を入力して下さい。

    se-172-22-1-155(config-mailbox)#messagesize 120
    
  10. メールボックス 設定を終了するためにコマンド端を入力して下さい。

    se-172-22-1-155(config-mailbox)#end
    
  11. 設定を終了するためにコマンド終了を入力して下さい。

    se-172-22-1-155(config)#exit
    

    注: ボイス メールボックスを必要とするすべてのユーザに対して同じ手順を繰り返します。

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

問題: ユーザが Cisco Unity Express の GUI からログインできない

Cisco Unity Express ユーザは Cisco Unity Express GUI によってログインできないし、Cisco Unity Express を途絶えましたホスト ルータが付いている連絡先を受け取ります。 新しい CCME Web管理者 ユーザ名 および パスワード エラーメッセージを入力して下さい

この問題を解決するには、次の手順を実行します。

  1. Cisco CallManager Express の設定で、このドキュメントで説明した設定コマンドのいずれかが抜けていないかどうかを確認します。

  2. 設定が正しい場合は、Cisco CallManager Express ルータで default-gateway が設定されていない可能性があります。 この状況は、管理者が設定を保存せずにルータをリロードした場合に起こります。 Cisco CallManager Express の設定で、Cisco Cisco Unity Express への IP 接続が可能かどうかを確認してください。

  3. このエラー メッセージは、管理者が Cisco CallManager Express の Web 管理者ユーザ名とパスワードを変更する際に、Cisco Unity Express システムでは、新しいユーザ名とパスワードを使用するように更新されていない場合にも表示されます。 新しい Cisco Unified CallManager Express ユーザ名 および パスワードのシステムをアップデートするために述べられる Unity Express GUI パスワードの回復でプロシージャを使用して下さい。

  4. Cisco Unity Express モジュールをリロードするために service-module サービス エンジン スロット/ポート reload コマンドを使用して下さい。

    注: Cisco Unity Express モジュールのリロードでは、ルータをリブートする必要はありません。 Cisco Unity Express モジュールとルータは別々にリブートできます。 ただし IP接続がルータとモジュールの間で再確立されるまで、ルータを、呼び出し範囲モジュール リブートしない場合。 データ損失またはファイル 破損を避けるためにルータのパワーサイクルを行う前にモジュールのシャットダウンを常に行って下さい。

CallManager Express と Cisco Unity Express の設定に関する問題のトラブルシューティングの詳細については、『Cisco Unity Express システム機能のトラブルシューティング』を参照してください。

問題: IP Phone は呼出された IP Phone が鳴るか、または使用中の間、呼出しかビジートーンを聞く場合がありません

これはネットワーク トポロジです:

tdcmecue-6.gif

Cisco Unified CallManager Express に登録されている 2 Skinny Client Control Protocol(SCCP)電話、IP Phone 1 および IP Phone 2 があります。 IP Phone 2 は Call Forward Busy および Cisco Unity Express に音声メールを転送される自動転送 noan あるために設定されます。

Cisco Unity Express がまたはダウンしている状況を考えてみれば登録します、コールが IP Phone 1 から IP Phone 2. IP Phone 1 への聞かなかったり呼出しビジートーンをとき IP Phone 2 つのリングまたはではない音声メールへの試みられた転送に使用中になされる。 Cisco Unity Express が稼働しているとき、すべては予想通りはたらきます。 この問題のための原因は SIP のためのデフォルト再試行が Cisco Unity Express に余りに長い誘うことです。

この問題を解決するために、SIP リトライを誘います 6 のデフォルト値以外より低い値に設定して下さい。 この出力例が示すと同時に SIP-UA 設定の下で誘いますタイマーを SIP 再試行を設定できます:

configure terminal
 sip-ua
 retry invite 2

!--- For example, SIP retry invite two.

問題: SIP トンネルによって AA を挿入する PSTN 失敗からの呼び出し

自動転送(AA)パイロット番号を挿入する受信 PSTN 呼び出し(SIP)は SIP トンネルによってはたらきません。 AA を挿入する IP Phone (SCCP)からの内部 コールはうまく働きます。

キュー AA は CallManager Express と通信するのに SIP プロトコルを使用します。 この場合、コールはまた PSTN から起きる SIP コールです。 この問題を解決するために、これらのコマンドを発行する必要があります:

CME(config)#voice service voip
CME(conf-voi-serv)#allow-connections sip to sip

注: この機能は Cisco Unified CallManager Express 4.0 および それ以降だけでサポートされます。

問題: NTP サーバで設定される CME ルータによって同期しないクロックを挿入して下さい

キューの NTP は CallManager Express と同期することができません。 CallManager Express ルータは NTP サーバで設定されます。 キュー クロックは正確な時間を表示する。 ただし、CallManager Express は正しい時刻を表示する。

この問題を解決するためにこれらのコマンドを発行して下さい:

CallManager Express ルータ:

ntp master

キュー:

ntp server x.x.x.x


!--- Where x.x.x.x is the ip address of the CME router which is configured as a NTP server.

述べられたコンフィギュレーション変更を手掛りおよび CallManager Express で行ったら、CallManager Express ルータの show ntp status コマンドを発行して下さい。 クロックが同期化されることがわかるはずです。

問題: 外部コールがキュー自動転送に転送されるとき、北アメリカ リング バック トーンはイギリス リング バック トーンの代りに聞かれます

キューにインストールされる英国英語 ローカルがあります。 インストールされる Cisco Unified CallManager に米国英国および英国英語 ローカルがあります。

この問題を解決するために、音声ゲートウェイの適切な音声ポートの下で cptone GB コマンドを設定して下さい。 これは出力例です:

aus-3725-03
voice-port 2/0/0
 trunk-group PSTN_ANALOG_IN_OUT_TG
 echo-cancel coverage 32
 no vad
 no comfort-noise
 cptone GB
 connection plar 42700
 description cptone EXAMPLE
 caller-id enable

注: リングバックトーンは音声ゲートウェイによって生成されます。

問題: ハント グループの最終番号を鳴らしていない CCME ハント グループ

設定される ephone ハントする コマンドでコールは最終的な dn の後でキュー VM システムに転送されて得ないし、発信者はビジートーンを受け取ります。

問題を解決するために、希望値に最大値リダイレクトを増加して下さい。

この問題は ephone ハントする コマンドが規定 される何が最大値リダイレクト コマンドで多くよりであるホップで設定される場合発生する場合があります。

これは ephone ハントするおよび最大値リダイレクトの設定例です:

注: 省略される出力例。

デバイス名 1
!
!
ephone-hunt 12 sequential

!--- Your ephone hunt group configuration would exist here.

!
!
!
telephony-service
 no auto-reg-ephone
 load 7960-7940 P00307020300
 max-ephones 144
 max-dn 500
 ip source-address 172.22.1.107 port 2000
 max-redirect 15
 service phone videoCapability 1
 dialplan-pattern 1 5123781291 extension-length 4
 voicemail 2000
 max-conferences 8 gain -6
 transfer-system full-consult
 secondary-dialtone 9
 create cnf-files version-stamp Jan 01 2002 00:00:00

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 62609