IP : IP ルーテッド プロトコル

Catalyst 3550 シリーズ スイッチの設定例を使ったポリシー ルーティング

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2004 年 4 月 9 日) | 英語版 (2015 年 10 月 6 日) | フィードバック


目次


概要

この文書では、Catalyst 3550 シリーズ スイッチにおけるポリシー ルーティングの設定例について説明します。 Catalyst 3550 シリーズ スイッチはハードウェア ベースの転送を行うため、転送された情報は Ternary Content Addressable Memory(TCAM)にプログラムされます。 TCAM が Policy Based Routing(PBR)をサポートできるようにするには、スイッチ データベース管理(SDM)テンプレートを変更してフォーマットする必要があります。 また、144 ビット レイヤ 3 TCAM をサポートするように SDM テンプレートを変更する必要があります。 SDM の詳細については、『Catalyst 3550 シリーズ スイッチの Switching Database Manager の説明と設定』を参照してください。

注: Catalyst 3550 では、使用可能な route-maps コマンドに制限があります。

前提条件

要件

この設定を試す前に、次の領域に精通していることを確認してください。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS(R) ソフトウェア リリース 12.1.19-EA1a

  • Cisco Catalyst 3550

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ポリシー ルーティングをイネーブルにする前に、グローバル コンフィギュレーション モードで次のいずれかのコマンドを設定し、設定を記述し、スイッチをリロードする必要があります。

  • sdm prefer extended-match

  • sdm prefer access extended-match

  • sdm prefer routing extended-match

CAT3550(config)# access-list 10 permit 20.20.20.0 0.0.0.255
CAT3550(config)# route-map pbr permit 10
CAT3550(config-route-map)# match ip address 10
CAT3550(config-route-map)# set ip next-hop 12.12.12.12

CAT3550(config)# int vlan 3
CAT3550(config-if)# ip policy route-map pbr
CAT3550(config-if)#
06:12:31: %L3TCAM-3-SIZE_CONFLICT: PBR requires enabling extended routing

CAT3550# show run int vlan 3
Building configuration...

Current configuration : 60 bytes
!
interface Vlan3
ip address 55.55.55.1 255.255.255.0

!--- Command not taken - you need to enable SDM.

end

CAT3550# conf t
Enter configuration commands, one per line. End with CNTL/Z.
CAT3550(config)# sdm prefer extended-match
Changes to the running SDM preferences have been stored, but cannot take effect 
until the next reload.
Use 'show sdm prefer' to see what SDM preference is currently active.
CAT3550(config)# end

CAT3550# write
06:14:11: %SYS-5-CONFIG_I: Configured from console by console
Building configuration...
[OK] 

ltd-1-2# reload
Proceed with reload? [confirm]

サポート対象外のコマンドを認識しておく必要があります。この設定が存在する場合は、『サポート対象外の route map コマンド』を参照してください。

!
access-list 10 permit 20.20.20.0 0.0.0.255
route-map pbr permit 10
match ip address 10
set ip default next-hop 12.12.12.12
!

インターフェイスで、ポリシー ルート マップを設定しようとすると、次のエラー メッセージが生成されます。

CAT3550(config)# int vlan 3
CAT3550(config-if)# ip policy route-map pbr
CAT3550(config-if)# end
CAT3550#
00:02:29: %PBR-3-UNSUPPORTED_RMAP: Route-map pbr not supported for Policy-Based Routing

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/47900/cat3550pbr-1.gif

設定

このドキュメントでは次の設定を使用しています。

この設定では、トラフィック ソースを 20.20.20.X(アクセス リスト 10)から取得し、取得したトラフィック ソースを 30.30.30.2 に送信します。この設定により、10.10.10.2 に設定されていたデフォルト ゲートウェイが上書きされます。

CAT3550(Cisco Catalyst 3550)
CAT3550# show running-config 
Building configuration...
.
.
!
interface Vlan1
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan2
 ip address 20.20.20.1 255.255.255.0
 ip policy route-map pbr
!
interface Vlan3
 ip address 30.30.30.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.10.10.2
ip classless
ip http server
!
!
access-list 10 permit 20.20.20.0 0.0.0.255
route-map pbr permit 10
 match ip address 10
 set ip next-hop 30.30.30.2
!
.
!
end

set ip next-hop コマンドの出力に一致トラフィックが表示されなくても、これはスイッチの正常な動作です。 これは、スイッチがハードウェア上でだけ動作するためであり、show コマンドがソフトウェアで処理された情報のみを表示するためです。 ルーティング テーブルおよびプロセスはスイッチによってチェックされないため、set ip next-hop は常にハードウェア内で動作しています。 これはパケットを受信し、そのパケットが route-map ステートメントに分類されると、ルーティング テーブルをチェックせずに指定したネクスト ホップに直接送信されます。

set ip default next-hop コマンドは、最初に、宛先への別のルートが存在するかどうかルーティング テーブル全体をチェックします。 ルートが存在しない場合は、デフォルトのネクスト ホップが使用されます。

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

トラブルシューティングのためのコマンド

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

注: debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

  • debug ip policy:「ポリシー ルーティングされた」、または「ポリシー拒否された」パケットを表示します。 debug ip policy コマンドの出力例を次に示します。

  *Dec 5 13:33:23.607: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
  *Dec 5 13:33:23.607: IP: route map pbr, item 10, permit
  *Dec 5 13:33:23.607: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4 (Vlan3),len 100, policy routed
  *Dec 5 13:33:23.607: IP: Vlan2 to Vlan3 30.30.30.1
  *Dec 5 13:33:23.707: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
  *Dec 5 13:33:23.707: IP: route map pbr, item 10, permit
  *Dec 5 13:33:23.707: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4 (Vlan3),len 100, policy routed
  *Dec 5 13:33:23.707: IP: Vlan2 to Vlan3 30.30.30.1
  *Dec 5 13:33:23.847: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
  *Dec 5 13:33:23.847: IP: route map pbr, item 10, permit

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 47900