IP : Open Shortest Path First(OSPF)

OSPF が Not-So-Stubby Area にデフォルト ルートを挿入する方法

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 10 月 10 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、Open Shortest Path First(OSPF)が Not So Stubby Area(NSSA)にデフォルト ルートを挿入する方法を示します。 NSSA 用の area border router(ABR; エリア境界ルータ)は、デフォルトでは NSSA に対してデフォルト ルートを発信しません。 area <x> nssa default-information originate コマンドを使用する必要があります。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次の図で示されるネットワーク構成を使用しています。

/image/gif/paws/47870/ospfdb11a.gif

設定

このドキュメントでは、次に示す設定を使用しています。

ルータ 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 area 1 nssa

end

近接ルータであることを示しています。
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20
 ip address 6.0.0.2 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0
 area 1 nssa default-information originate

end

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show ip ospf database — Link State Advertisement (LSA; リンクステート アドバタイズメント)のリストを表示する、リンク状態データベースにそれらをタイプします。 このリストでは、LSA ヘッダーの情報だけが表示されます。

  • show ip route — ルーティング テーブルの現在のステータスを表示する。

Not So Stubby Area の OSPFデータベースを検査して下さい

OSPFデータベースがどのように検知 するか見るために、show ip ospf database コマンドを使用して下さい。

r2.2.2.2#show ip ospf database

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

           Router Link States (Area 0) 

Link ID    ADV Router     Age     Seq#          Checksum   Link count 
2.2.2.2    2.2.2.2        600     0x80000001    0x9583          1 

           Summary Net Link States (Area 0) 

Link ID    ADV Router      Age     Seq#          Checksum 
5.0.0.0     2.2.2.2        600     0x80000001    0x8E61 

           Router Link States (Area 1) 

Link ID    ADV Router     Age     Seq#           Checksum   Link count 
1.1.1.1    1.1.1.1        864     0x8000005E     0xD350         2 
2.2.2.2    2.2.2.2        584     0x8000001E     0xF667         2 

           Summary Net Link States (Area 1) 

Link ID    ADV Router     Age     Seq#          Checksum 
6.0.0.0    2.2.2.2        585     0x80000004    0xA87C 

           Type-7 AS External Link States (Area 1) 

Link ID    ADV Router     Age     Seq#          Checksum   Tag 
0.0.0.0    2.2.2.2        601     0x80000001    0xD0D8      0 

NSSA のための ABR は 0.0.0.0 のリンク ID の型 7 および LSA を開始します。 これは、このルータの OSPF 設定で area 1 nssa default-information-originate コマンドを実行したためです。

r2.2.2.2#show ip ospf database nssa-external 0.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Type-7 AS External Link States (Area 1) 

  LS age: 650 
  Options: (No TOS-capability, No Type 7/5 translation, DC) 
  LS Type: AS External Link 
  Link State ID: 0.0.0.0 (External Network Number ) 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0xD0D8 
  Length: 36 
  Network Mask: /0 
        Metric Type: 2 (Larger than any link state path) 
        TOS: 0 
        Metric: 1 
        Forward Address: 0.0.0.0 
        External Route Tag: 0 

ABR はデフォルト ルートを持っていないのに、0.0.0.0 型 7 LSA を開始します。

r2.2.2.2#show ip route 0.0.0.0 
% Network not in table 

r1.1.1.1#show ip route ospf 
O IA 6.0.0.0/8 [110/65] via 5.0.0.2, 00:00:18, Serial2/1/0 
O*N2 0.0.0.0/0 [110/1] via 5.0.0.2, 00:00:18, Serial2/1/0 

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 47870