IP : Open Shortest Path First(OSPF)

OSPF でのスタブ エリアまたは完全スタブ エリアにデフォルト ルートを挿入する方法

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 6 月 10 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、Open Shortest Path First(OSPF)からスタブ エリアまたは完全スタブ エリアにデフォルト ルートを挿入する方法について説明します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次の図で示されるネットワーク構成を使用しています。

/image/gif/paws/47869/ospfdb10a.gif

設定

このドキュメントでは、次に示す設定を使用しています。

ルータ 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 area 1 stub

end

近接ルータであることを示しています。
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20
 ip address 6.0.0.2 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0
 area 1 stub

end

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

  • show ip ospf database — Link State Advertisement (LSA; リンクステート アドバタイズメント)のリストを表示する、リンク状態データベースにそれらをタイプします。 このリストでは、LSA ヘッダーの情報だけが表示されます。

  • show ip ospf database summary <link 州の id> —エリア境界ルータ(ABR)サマリー リンクを表示する。

  • show ip route — ルーティング テーブルの現在のステータスを表示する。

スタブエリアの OSPFデータベースを検査して下さい

スタブエリアのための ABR は 0.0.0.0 のリンク ID の要約LSA を起こします。 それはデフォルト ルートを持たなくてもこれをします。 これが show ip ospf database コマンドで起こるのを表示できます。

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age    Seq#           Checksum   Link count 
2.2.2.2    2.2.2.2     19     0x80000001     0x8F8B         1 

                Summary Net Link States (Area 0) 

Link ID   ADV Router   Age     Seq#           Checksum 
5.0.0.0    2.2.2.2     9       0x80000001     0x8E61 

                Router Link States (Area 1) 

Link ID   ADV Router   Age     Seq#           Checksum   Link count 
1.1.1.1    1.1.1.1     1335    0x80000059     0x56DA         2 
2.2.2.2    2.2.2.2     4       0x80000013     0x7FF3         2 

                Summary Net Link States (Area 1) 

Link ID   ADV Router   Age     Seq#               Checksum 
0.0.0.0    2.2.2.2     20      0x80000001         0x75C0 
6.0.0.0    2.2.2.2     13      0x80000001         0x2709 


r2.2.2.2#show ip ospf database summary 0.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  

                Summary Net Link States (Area 1) 

  LS age: 184 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 0.0.0.0 (summary Network Number)
  
!--- The ABR (Router 2.2.2.2) injects a default route 
  !--- into the stub area. 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0x75C0 
  Length: 28 
  Network Mask: /0 
        TOS: 0  Metric: 1 
  

r2.2.2.2#show ip route 0.0.0.0 
% Network not in table

!--- The ABR (Router 2.2.2.2) does not have a default route
!--- in its routing table.


r1.1.1.1#show ip route ospf 
O IA 6.0.0.0/8 [110/65] via 5.0.0.2, 00:04:23, Serial2/1/0 
O*IA 0.0.0.0/0 [110/65] via 5.0.0.2, 00:04:23, Serial2/1/0 

完全スタブエリアの OSPFデータベースを検査して下さい

スタブエリアから完全スタブエリアにスタブエリア例のエリア 1 を変更する場合、ABR はまだエリア 1.に 0.0.0.0 要約LSA をインジェクトします。 唯一の違いは、他の集約 LSA が完全スタブ エリアには送信されないことです。

注: 行った唯一のコンフィギュレーション変更を ABR にありました。 no-summary 文は OSPF 設定に追加されました: area 1 stub no-summary

このコマンド 出力は OSPFデータベースが完全スタブエリアをのように見えるもの示します。

r2.2.2.2#show ip ospf database

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age     Seq#         Checksum     Link count 
2.2.2.2    2.2.2.2     617     0x80000001   0x8F8B           1 

                Summary Net Link States (Area 0) 

Link ID   ADV Router   Age     Seq#         Checksum 
5.0.0.0    2.2.2.2     608     0x80000001   0x8E61 

                Summary ASB Link States (Area 0) 

Link ID   ADV Router   Age     Seq#         Checksum 
1.1.1.1    2.2.2.2     243     0x80000003   0x8F5E 

                Router Link States (Area 1) 

Link ID   ADV Router   Age     Seq#         Checksum     Link count 
1.1.1.1    1.1.1.1     1934    0x80000059   0x56DA           2 
2.2.2.2    2.2.2.2     247     0x80000015   0x7BF5           2 

                Summary Net Link States (Area 1) 

Link ID   ADV Router   Age     Seq#               Checksum 
0.0.0.0    2.2.2.2     249     0x80000003         0x71C2  

!--- Notice that this is the only summary LSA 
!--- in the totally stub area. 


r1.1.1.1#show ip route ospf 
O*IA 0.0.0.0/0 [110/65] via 5.0.0.2, 00:04:11, Serial2/1/0 

ABR は 6.0.0.0/8 のための要約LSA を起こしません。 その結果、ルータ 1.1.1.1 にもはや 6.0.0.0/8 のためのルートがありません。 このルータが保持する唯一のエリア間ルートは、デフォルト ルートです。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 47869