IP : Open Shortest Path First(OSPF)

OSPF 仮想リンク

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 6 月 1 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

Open Shortest Path First(OSPF)自律システム内のすべてのエリアは、バックボーン エリア(エリア 0)に物理的に接続されている必要があります。 これが不可能な場合には、仮想リンクを使用して、非バックボーン エリア経由でバックボーンに接続できます。 分割されたバックボーンの 2 箇所を非バックボーン エリア経由で接続するために、仮想リンクを使用することもできます。 仮想リンクを設定するエリア(中継エリア)には、完全なルーティング情報が必要です。 中継エリアをスタブ エリアにすることはできません。 このドキュメントでは、仮想リンク環境における OSPF データベースについて検証します。 仮想リンクの詳細については、『OSPF Design Guide』を参照してください。

前提条件

要件

次の項目に関する知識があることが推奨されます。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/47866/ospfdb7.gif

設定

このドキュメントでは、次の設定を使用します。

Router1.1.1.1
Current configuration:

hostname Router1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0

router ospf 2
 network 4.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 1
 area 1 virtual-link 3.3.3.3

!--- Area 1 is the transit area.
!--- IP address 3.3.3.3 is the router
!--- ID of the router between Area 1
!--- and Area 2 (Router3.3.3.3). See
!--- the next Note.

end

OSPFルータ ID は通常ボックスまたは最も数字の大きいループバックアドレスの最も高い IP アドレス、存在 する 1 つです。 Router ID はブート時に OSPFプロセスが再起動することだけまたはいつでも計算されます。 Router ID を見つける show ip ospf interface コマンドを発行して下さい。

Router2.2.2.2
Current configuration:

hostname Router2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0

interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20 point-to-point
 ip address 6.0.0.2 255.0.0.0

router ospf 2
 network 6.0.0.0 0.255.255.255 area 1
 network 5.0.0.0 0.255.255.255 area 1

end

Router3.3.3.3
Current configuration:

hostname Router3.3.3.3

interface Loopback0
 ip address 3.3.3.3 255.0.0.0

interface Ethernet0/0
 ip address 12.0.0.3 255.0.0.0

interface ATM2/0.20 point-to-point
 ip address 6.0.0.3 255.0.0.0

router ospf 2
 network 12.0.0.0 0.255.255.255 area 2
 network 6.0.0.0 0.255.255.255 area 1
 area 1 virtual-link 1.1.1.1

!--- Area 1 is the transit area.
!--- IP address 1.1.1.1 is the router
!--- ID of the router between Area 1
!--- and Area 0 (Router1.1.1.1).

end

仮想リンクがどのように動作するか

最初に、仮想リンクは Router3.3.3.3 (仮想リンクのもう一方の端)に達する方法を Router1.1.1.1 が知らないのでダウンしています。 エリアの Link State Advertisement (LSA; リンクステート アドバタイズメント)すべてあふれる 1 つの必要および Shortest Path First (SPF) アルゴリズムは Router1.1.1.1 のためのすべての 3 人のルータによってエリア 1 の内で知るためにエリア 1.によって Router3.3.3.3 に達する方法を、実行する必要があります。

トランジットエリアによって互いに達する方法をルータが知っていた後仮想リンクを渡る隣接関係を形成することを試みます。 仮想リンクの 2 つの端間の OSPF パケットはマルチキャスト パケットではないです。 それらは仮想リンクのもう一方の端にトンネル伝送されるので、ソース 5.0.0.1 からの宛先 6.0.0.3 へトンネル伝送されたパケットです。 仮想リンク ルータの間のファイアウォールがあれば、IP OSPF (間の 89) IP プロトコル ポートを 5.0.0.1 と 6.0.0.3 の間にある仮想リンク トンネル 発信インターフェイス 有効に する必要があることに注意することは重要です。

ルータが仮想リンクで隣接するようになれば、Router3.3.3.3 はエリア 0 で今その結果リンクが。あるのでそれ自身をエリア境界ルータ(ABR)と、Router3.3.3.3 作成しますエリア 0 とエリア 1.の 12.0.0.0/8 のための要約LSA を考慮します。

仮想リンクが不適切に設定されているどういうわけか場合、Router3.3.3.3 はエリア 0 のインターフェイスを持っていないのでそれ自身を ABR と考慮しません。 これが事実である場合、要約LSA を作成しませんし、エリア 1.に 12.0.0.0/8 をアドバタイズしません。

OSPF は IP の上を動作し、プロトコル 番号 89 を使用します。 OSPF は TCP および UDP のような他のどの転送 プロトコルにも、頼りません。

最短パスの計算

このセクションは Router2.2.2.2 の観点から最短パスを計算します。

自身の LSA の Router2.2.2.2 外観は Router3.3.3.3 がネイバーであることがわかり。 それそして Router3.3.3.3 がネイバーとして Router2.2.2.2 を見ることを確認する Router3.3.3.3 の LSA の外観。 ルータが両方とも相手として互いに会う場合、到達可能と見なされます。

各ルータはまた(show ip ospf neighbor コマンドで表示できる)ローカル ネイバー テーブル ネイバーのインターフェイスおよびインターフェイスがよくある IPサブネットにあることを確認するためにチェックします。

このチェックは非番号 インターフェイスで実行された。

それらがよくあるサブネットにある場合、ルータはネイバーのルータISA にリストされているあらゆるスタブ ネットワークのためのルーティングをインストールします。 この例では、6.0.0.0/8 は Router2.2.2.2 が既に直接接続されるエリア 1 の Router3.3.3.3 の LSA にリストされている唯一のスタブ ネットワークです。

Router3.3.3.3 は Router1.1.1.1 の LSA のための同じチェックをしますが、Router1.1.1.1 の LSA に有用なスタブ ネットワークがありません。

結局エリアの到達可能な ルータ LSA の 1 つは、データベースの要約LSA の Router2.2.2.2 外観検査されます。 それはエリア 1 の 12.0.0.0/8 のための 2 要約LSA を見つけ、要約LSA のメトリックとアドバタイズ ルータに達するメトリックである最も低いトータルコストで 1 つを選択します。

  • Router2.2.2.2 は 64 + 75 = 139 のコストで Router1.1.1.1 によって 12.0.0.0 に達することができます。

  • Router2.2.2.2 は 1 + 10 = 11.のコストで Router3.3.3.3 によって 12.0.0.0 に達することができます。

Router2.2.2.2 は 11.のメトリックの Router3.3.3.3 によってルーティング テーブルにルートをインストールします。

この出力は以前に説明される各ルータのルーティング テーブルで OSPF ルーティングを示したものです:

Router1.1.1.1#show ip route ospf

!--- Output suppressed.

O    6.0.0.0/8 [110/65] via 5.0.0.2, 00:38:12, Serial2/1/0
O IA 12.0.0.0/8 [110/75] via 5.0.0.2, 00:38:02, Serial2/1/0

Router2.2.2.2#show ip route ospf

!--- Output suppressed.

O IA 4.0.0.0/8 [110/74] via 5.0.0.1, 00:38:08, Serial0/1/0
O IA 12.0.0.0/8 [110/11] via 6.0.0.3, 00:38:12, ATM1/0.20

!--- This is the route in this example.

Router3.3.3.3#show ip route ospf

!--- Output suppressed.

O    4.0.0.0/8 [110/75] via 6.0.0.2, 00:38:18, ATM2/0.20
O    5.0.0.0/8 [110/65] via 6.0.0.2, 00:38:28, ATM2/0.20

仮想リンクの代りの GREトンネルの使用

また Router1.1.1.1 と Router3.3.3.3 間の一般的ルーティングカプセル化を構築し、エリア 0 にトンネルを置くことができます。 GREトンネルと仮想リンク間の主な違いはこの表に説明があります:

GREトンネル 仮想リンク
トンネルのすべてのトラフィックはトンネルエンドポイントによってカプセル化され、カプセル化を解除されます。 ルーティング更新はトンネル伝送されますが、データトラフィックはそのまま送られます。
各パケット原因オーバーヘッドのトンネルヘッダー。 データトラフィックはあらゆるトンネル オーバーヘッドに応じてありません。
トンネルはスタブエリアを通過できます。 トランジットエリアはスタブエリアのルータが外部目的地のためのルーティングを備えていないのでスタブエリアである場合もありません。 データがそのまま送られるので、外部目的地に宛てたパケットがまたトランジットエリアであるスタブエリアに送信 される場合、パケットは正しくルーティングされません。 スタブエリアのルータは特定の外部目的地のためのルーティングを備えていません。

確認

ここでは、設定が正常に動作していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

OSPF データベースの検査

これは show ip ospf database コマンドを発行するときこのネットワーク環境がどのようにある OSPFデータベース一見です。

Router1.1.1.1#show ip ospf database

       OSPF Router with ID (1.1.1.1) (Process ID 2)

                Router Link States (Area 0)

Link ID   ADV Router    Age             Seq#          Checksum   Link count
1.1.1.1   1.1.1.1       919             0x80000003    0xD5DF         2
3.3.3.3   3.3.3.3       5     (DNA)     0x80000002    0x3990         1

                Summary Net Link States (Area 0)

Link ID   ADV Router    Age                 Seq#         Checksum
5.0.0.0   1.1.1.1       1945                0x80000002   0xAA48
5.0.0.0   3.3.3.3       9     (DNA)         0x80000001   0x7A70
6.0.0.0   1.1.1.1       1946                0x80000002   0xA749
6.0.0.0   3.3.3.3       9     (DNA)         0x80000001   0xEA3F
12.0.0.0  3.3.3.3       9     (DNA)         0x80000001   0xF624

                Router Link States (Area 1)

Link ID   ADV Router    Age             Seq#          Checksum   Link count
1.1.1.1   1.1.1.1       1946            0x80000005    0xDDA6         2
2.2.2.2   2.2.2.2       10              0x80000009    0x64DD         4
3.3.3.3   3.3.3.3       930             0x80000006    0xA14C         2

                Summary Net Link States (Area 1)

Link ID   ADV Router    Age             Seq#           Checksum
4.0.0.0   1.1.1.1       1947            0x80000002     0x9990
4.0.0.0   3.3.3.3       911             0x80000001     0xEBF5
12.0.0.0  1.1.1.1       913             0x80000001     0xBF22
12.0.0.0  3.3.3.3       931             0x80000001     0xF624

Router2.2.2.2#show ip ospf database

       OSPF Router with ID (2.2.2.2) (Process ID 2)

                Router Link States (Area 1)

Link ID   ADV Router    Age     Seq#          Checksum   Link count
1.1.1.1   1.1.1.1       1988    0x80000005    0xDDA6        2
2.2.2.2   2.2.2.2       50      0x80000009    0x64DD        4
3.3.3.3   3.3.3.3       969     0x80000006    0xA14C        2

                Summary Net Link States (Area 1)

Link ID   ADV Router    Age      Seq#          Checksum
4.0.0.0   1.1.1.1       1988     0x80000002    0x9990
4.0.0.0   3.3.3.3       950      0x80000001    0xEBF5
12.0.0.0  1.1.1.1       955      0x80000001    0xBF22
12.0.0.0  3.3.3.3       970      0x80000001    0xF624

Router3.3.3.3#show ip ospf database

       OSPF Router with ID (3.3.3.3) (Process ID 2)

                Router Link States (Area 0)

Link ID   ADV Router    Age          Seq#          Checksum   Link count
1.1.1.1   1.1.1.1       6   (DNA)    0x80000003    0xD5DF         2
3.3.3.3   3.3.3.3       977          0x80000002    0x3990         1

                Summary Net Link States (Area 0)

Link ID   ADV Router    Age            Seq#          Checksum
5.0.0.0   1.1.1.1       1027  (DNA)    0x80000002    0xAA48
5.0.0.0   3.3.3.3       986            0x80000001    0x7A70
6.0.0.0   1.1.1.1       1027  (DNA)    0x80000002    0xA749
6.0.0.0   3.3.3.3       987            0x80000001    0xEA3F
12.0.0.0  3.3.3.3       987            0x80000001    0xF624

                Router Link States (Area 1)

Link ID   ADV Router    Age    Seq#          Checksum   Link count
1.1.1.1   1.1.1.1       2007   0x80000005    0xDDA6         2
2.2.2.2   2.2.2.2       68     0x80000009    0x64DD         4
3.3.3.3   3.3.3.3       987    0x80000006    0xA14C         2

                Summary Net Link States (Area 1)

Link ID   ADV Router    Age      Seq#         Checksum
4.0.0.0   1.1.1.1       2007    0x80000002    0x9990
4.0.0.0   3.3.3.3       967     0x80000001    0xEBF5
12.0.0.0  1.1.1.1       973     0x80000001    0xBF22
12.0.0.0  3.3.3.3       987     0x80000001    0xF624

                Router Link States (Area 2)

Link ID   ADV Router    Age    Seq#          Checksum   Link count
3.3.3.3   3.3.3.3       987    0x80000003    0xCF5          1

                Summary Net Link States (Area 2)

Link ID   ADV Router    Age    Seq#        Checksum
4.0.0.0   3.3.3.3       968    0x80000001  0xEBF5
5.0.0.0   3.3.3.3       988    0x80000001  0x7A70
6.0.0.0   3.3.3.3       988    0x80000001  0xEA3F

仮想リンクを通して学ばれる LSA に DoNotAge オプションがあることに注意して下さい。 仮想リンクは Demand Circuit のように扱われます。

Router1.1.1.1#show ip ospf database router 1.1.1.1

       OSPF Router with ID (1.1.1.1) (Process ID 2)

                Router Link States (Area 0)

  LS age: 1100
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 1.1.1.1

!--- For router links, Link State ID is always the same as the Advertising Router.

  Advertising Router: 1.1.1.1

!--- This is the router ID of the router that created this LSA.

  LS Seq Number: 80000003
  Checksum: 0xD5DF
  Length: 48
  Area Border Router

!--- Bit B in the router LSA indicates that this router is an ABR.

   Number of Links: 2

!--- There are two links in Area 0.

    Link connected to: a Virtual Link
     (Link ID) Neighboring Router ID: 3.3.3.3

!--- Router ID of the neighbor on the other end of the virtual link.

     (Link Data) Router Interface address: 5.0.0.1

!--- The interface that this router uses to send packets to the neighbor.

      Number of TOS metrics: 0
       TOS 0 Metrics: 65

!--- The metric comes from the cost for this router to reach the neighboring router:
!--- the ATM link has a cost of 1 and the serial link has a cost of 64.

    Link connected to: a Stub Network

!--- This represents the Ethernet segment 4.0.0.0/8.

     (Link ID) Network/subnet number: 4.0.0.0
     (Link Data) Network Mask: 255.0.0.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 10

                Router Link States (Area 1)

  LS age: 122
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 1.1.1.1
  Advertising Router: 1.1.1.1
  LS Seq Number: 80000006
  Checksum: 0xDBA7
  Length: 48
  Area Border Router
   Number of Links: 2

!--- There are two links in Area 1.

    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 2.2.2.2
     (Link Data) Router Interface address: 5.0.0.1
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 5.0.0.0
     (Link Data) Network Mask: 255.0.0.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

Router1.1.1.1#show ip ospf database router 2.2.2.2

       OSPF Router with ID (1.1.1.1) (Process ID 2)

                Router Link States (Area 1)

  LS age: 245
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 2.2.2.2
  Advertising Router: 2.2.2.2
  LS Seq Number: 80000009
  Checksum: 0x64DD
  Length: 72
   Number of Links: 4

!--- There are four links in Area 1.


    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 3.3.3.3
     (Link Data) Router Interface address: 6.0.0.2
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 6.0.0.0
     (Link Data) Network Mask: 255.0.0.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 1.1.1.1
     (Link Data) Router Interface address: 5.0.0.2
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 5.0.0.0
     (Link Data) Network Mask: 255.0.0.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

Router1.1.1.1#show ip ospf database router 3.3.3.3

       OSPF Router with ID (1.1.1.1) (Process ID 2)

                Router Link States (Area 0)

  Routing Bit Set on this LSA
  LS age: 5 (DoNotAge)
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 3.3.3.3
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0x3990
  Length: 36
  Area Border Router
   Number of Links: 1

!--- There is one link in Area 0.


    Link connected to: a Virtual Link
     (Link ID) Neighboring Router ID: 1.1.1.1
     (Link Data) Router Interface address: 6.0.0.3
      Number of TOS metrics: 0
       TOS 0 Metrics: 65

                Router Link States (Area 1)

  Routing Bit Set on this LSA
  LS age: 1137
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 3.3.3.3
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000006
  Checksum: 0xA14C
  Length: 48
  Area Border Router
   Number of Links: 2

!--- There are two links in Area 1.


    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 2.2.2.2
     (Link Data) Router Interface address: 6.0.0.3
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 6.0.0.0
     (Link Data) Network Mask: 255.0.0.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

Router3.3.3.3 はエリア 0 (仮想リンク)にリンクがあるのでそれ自身を ABR と考慮します。 その結果、それは表示できるエリア 0 生成します、およびエリア 1 に show ip ospf database summary コマンドを発行するとき 12.0.0.0 のための要約LSA を。

Router3.3.3.3#show ip ospf database summary 12.0.0.0

       OSPF Router with ID (3.3.3.3) (Process ID 2)

                Summary Net Link States (Area 0)

  LS age: 1779
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 12.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000001
  Checksum: 0xF624
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 10

                Summary Net Link States (Area 1)

  LS age: 1766
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 12.0.0.0 (summary Network Number)
  Advertising Router: 1.1.1.1
  LS Seq Number: 80000001
  Checksum: 0xBF22
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 75

  LS age: 1781
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 12.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000001
  Checksum: 0xF624
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 10

また Router3.3.3.3 がエリア 0 およびエリア 1.から学んだ情報すべてのためのエリア 2 の要約LSA を作成することに、注意して下さい。

Router3.3.3.3#show ip ospf database summary self-originate

       OSPF Router with ID (3.3.3.3) (Process ID 2)

                Summary Net Link States (Area 0)

  LS age: 155
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 5.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0x7871
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 65

  LS age: 155
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 6.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0xE840
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 1

  LS age: 156
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 12.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0xF425
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 10

                Summary Net Link States (Area 1)

  LS age: 157
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 4.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0xE9F6
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 75

  LS age: 165
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 12.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0xF425
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 10

                Summary Net Link States (Area 2)

  LS age: 167
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 4.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0xE9F6
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 75

  LS age: 168
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 5.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0x7871
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 65

  LS age: 168
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 6.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0xE840
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 1

トラブルシューティング

ここでは、設定に関するトラブルシューティングについて説明します。

トラブルシューティングのためのコマンド

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

  • debug ip ospf adj — OSPF隣接を構築するか、または壊すために含まれるイベントを表示する。

ルータは隣接するようになり、物理リンクと同じような仮想リンクによって LSA を交換します。 debug ip ospf adj コマンドのルータISA か出力を検査する場合隣接関係を表示できます:

Router3.3.3.3#
May 26 17:25:03.089: OSPF: Rcv hello from 1.1.1.1 area 0 from OSPF_VL3 5.0.0.1
May 26 17:25:03.091: OSPF: 2 Way Communication to 1.1.1.1 on OSPF_VL3, state 2WAY
May 26 17:25:03.091: OSPF: Send DBD to 1.1.1.1 on OSPF_VL3
                           seq 0xD1C opt 0x62 flag 0x7 len 32
May 26 17:25:03.135: OSPF: End of hello processing
May 26 17:25:03.139: OSPF: Rcv DBD from 1.1.1.1 on OSPF_VL3
                           seq 0x1617 opt 0x22 flag 0x7 len 32
                           mtu 0 state EXSTART
May 26 17:25:03.175: OSPF: First DBD and we are not SLAVE
May 26 17:25:03.179: OSPF: Rcv DBD from 1.1.1.1 on OSPF_VL3
                           seq 0xD1C opt 0x22 flag 0x2 len 172
                           mtu 0 state EXSTART
May 26 17:25:03.183: OSPF: NBR Negotiation Done. We are the MASTER
May 26 17:25:03.189: OSPF: Send DBD to 1.1.1.1 on OSPF_VL3
                           seq 0xD1D opt 0x62 flag 0x3 len 172
May 26 17:25:03.191: OSPF: Database request to 1.1.1.1
May 26 17:25:03.191: OSPF: sent LS REQ packet to 5.0.0.1, length 36
May 26 17:25:03.263: OSPF: Rcv DBD from 1.1.1.1 on OSPF_VL3
                           seq 0xD1D opt 0x22 flag 0x0 len 32
                           mtu 0 state EXCHANGE
May 26 17:25:03.267: OSPF: Send DBD to 1.1.1.1 on OSPF_VL3
                           seq 0xD1E opt 0x62 flag 0x1 len 32
May 26 17:25:03.311: OSPF: Rcv DBD from 1.1.1.1 on OSPF_VL3
                           seq 0xD1E opt 0x22 flag 0x0 len 32
                           mtu 0 state EXCHANGE
May 26 17:25:03.311: OSPF: Exchange Done with 1.1.1.1 on OSPF_VL3
May 26 17:25:03.315: OSPF: Synchronized with 1.1.1.1 on OSPF_VL3, state FULL
May 26 17:25:03.823: OSPF: Build router LSA for area 0,
                           router ID 3.3.3.3, seq 0x80000029
May 26 17:25:03.854: OSPF: Dead event ignored for 1.1.1.1 on demand circuit OSPF_VL3

Router3.3.3.3#show ip ospf neighbor

Neighbor ID       Pri       State        Dead Time       Address         Interface
2.2.2.2           1         FULL/  -     00:00:38        6.0.0.2         ATM2/0.20

Router3.3.3.3#show ip ospf virtual-links

Virtual Link OSPF_VL3 to router 1.1.1.1 is up
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 1, via interface ATM2/0.20, Cost of using 65
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:01
    Adjacency State FULL (Hello suppressed)
    Index 1/2, retransmission queue length 0, number of retransmission 0
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 0, maximum is 0
    Last retransmission scan time is 0 msec, maximum is 0 msec

仮想リンク上の隣接関係が show ip ospf neighbor コマンド出力で表示することに注意して下さい。 それらを見る唯一の方法はルータISA を検知 し、隣接関係がアップする、または発行します show ip ospf virtual-links コマンドをですので debug コマンドを観察すること。


関連情報


Document ID: 47866