IP : Open Shortest Path First(OSPF)

OSPF が複数エリアへの外部ルートを伝搬する方法

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 10 月 29 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、Open Shortest Path First(OSPF)で外部ルートを複数のネットワーク エリアに伝搬する方法を示します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次の図で示されるネットワーク構成を使用しています。

/image/gif/paws/47865/ospfdb6a.gif

設定

このドキュメントでは、次に示す設定を使用しています。

ルータ 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0

interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
router ospf 4
 redistribute static metric 5 metric-type 1
 network 5.0.0.0 0.255.255.255 area 1
 network 4.0.0.0 0.255.255.255 area 1

ip route 9.0.0.0 255.0.0.0 4.0.0.2

end

近接ルータであることを示しています。
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20
 ip address 6.0.0.2 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0

end

ルータ 3.3.3.3
Current configuration:

hostname r3.3.3.3

interface Loopback0
 ip address 3.3.3.3 255.0.0.0

interface ATM2/0.20 point-to-point
 ip address 6.0.0.3 255.0.0.0
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0

end

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show ip ospf database — Link State Advertisement (LSA; リンクステート アドバタイズメント)のリストを表示する、リンク状態データベースにそれらをタイプします。 このリストでは、LSA ヘッダーの情報だけが表示されます。

  • show ip ospf database [router] [link-state-id] —データベースのルータの LSA すべてのリストを表示する。 LSA は各ルータによって生成 されます。 これらの基本的な LSA は状態およびリンク の 発信コストと共にルータのリンク、かインターフェイスすべてを、リストします。 これらは、生成されたエリア内でだけフラッディングされます。

  • show ip ospf database summary <link 州の id> —エリア境界ルータ(ABR)サマリー リンクを表示する。

  • show ip ospf database external — 外部LSAs についてのだけ情報を表示する。

  • show ip ospf database asbr-summary — 自律システム境界ルータ 要約LSA についてのだけ情報を表示する。

OSPF データベースの検査

この出力に show ip ospf database コマンドを使用してこのネットワーク環境が、どのようにある OSPFデータベース一見示されています。

r2.2.2.2#show ip ospf database
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Router Link States (Area 0) 
  
Link ID    ADV Router    Age    Seq#          Checksum   Link count 
2.2.2.2    2.2.2.2       93     0x80000020    0xCD0B         2 
3.3.3.3    3.3.3.3       1225   0x8000000D    0x9057         2 
  
                Summary Net Link States (Area 0) 
  
Link ID    ADV Router    Age   Seq#           Checksum 
4.0.0.0     2.2.2.2      73    0x80000001     0xFFE6 
5.0.0.0     2.2.2.2      1651  0x80000006     0x8466 
  
                Summary ASB Link States (Area 0) 
  
Link ID   ADV Router    Age   Seq#           Checksum 
1.1.1.1    2.2.2.2      74    0x80000001     0x935C 
  
                Router Link States (Area 1) 
  
Link ID   ADV Router   Age   Seq#         Checksum    Link count 
1.1.1.1   1.1.1.1      89    0x80000011   0xFF59          3 
2.2.2.2   2.2.2.2      88    0x80000033   0x2130          2 
  
                Summary Net Link States (Area 1) 
  
Link ID   ADV Router  Age    Seq#         Checksum 
6.0.0.0   2.2.2.2     94     0x8000001F   0xCC43 
  
                Type-5 AS External Link States 
  
Link ID   ADV Router   Age   Seq#         Checksum   Tag 
9.0.0.0   1.1.1.1      135   0x80000001   0x3AE8      0 

外部ルートを OSPF にアドバタイズするために、autonomous system boundary router(ASBR; 自律システム境界ルータ)によって(タイプ 5)外部 LSA が作成されます。

r2.2.2.2#show ip ospf database external 9.0.0.0
          OSPF Router with ID (2.2.2.2) (Process ID 2)
                   Type-5 AS External Link States
     Routing Bit Set on this LSA
     LS age: 286
     Options: (No TOS-capability, DC)
     LS Type: AS External Link
     Link State ID: 9.0.0.0 (External Network Number )
  
!--- 9.0.0.0/8 is advertised by the
   !--- ASBR (Router 1.1.1.1).

   Advertising Router: 1.1.1.1
   LS Seq Number: 80000001
   Checksum: 0x3AE8
   Length: 36
   Network Mask: /8
         Metric Type: 1 (Comparable directly to link state metric)
         TOS: 0
         Metric: 5
         Forward Address: 0.0.0.0
		  
!--- Forwarding address is not specified since there
  		!--- are no OSPF neighbors on Router 1.1.1.1's Ethernet.
    !--- When the forward address is 0.0.0.0, this means that 
    !--- the traffic for this network is to be sent to the 
    !--- advertising router (1.1.1.1).
 
External Route Tag: 0  

ASBR が他のエリアに到達する可能性をアドバタイズするために、ABR は(タイプ 4)ASBR 集約 LSA を作成します。

r2.2.2.2#show ip ospf database asbr-summary 1.1.1.1 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Summary ASB Link States (Area 0) 
  
  LS age: 266 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(AS Boundary Router) 
  Link State ID: 1.1.1.1 (AS Boundary Router address)
  
!--- ABR (Router 2.2.2.2) is advertising that it knows how
  !--- to reach the ASBR (Router 1.1.1.1). 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0x935C 
  Length: 28 
  Network Mask: /0 
        TOS: 0  Metric: 64
		
!--- The ABR's cost to reach the ASBR.
 

ABR(ルータ 2.2.2.2)は、ASBR(ルータ 1.1.1.1)から学習した外部ルートをすでに設定し、エリア 1 からエリア 0 に外部 LSA をフラッドしました(外部 LSA は、変更されないでエリアに対してフラッドされます)。 ただし ASBR に達する方法を、ASBR はエリア 0 のエリア 0。ルータに知りませんありません。 ABR が ASBR 集約 LSA を作成し、ルータ 1.1.1.1 への到達可能性をエリア 0 にアドバタイズするのはこのためです。

注: 次に出力の設定 されるこのこのセットアップ例の OSPFデータベースについてのより多くの詳細しか説明しないために示されます。 この情報について詳しく知っている場合、計算最短パス セクションをスキップして下さい。


r2.2.2.2#show ip ospf database router 1.1.1.1 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Router Link States (Area 1) 
  
  Routing Bit Set on this LSA 
  LS age: 109 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, Link State Id is always the 
  !--- same as the Advertising Router. 

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that created
  !--- this LSA. 

  LS Seq Number: 80000011 
  Checksum: 0xFF59 
  Length: 60 
  AS Boundary Router
  
!--- Bit E in the router LSA indicates that this 
  !--- router originates external LSAs. 

   Number of Links: 3
   
!--- There are three links in area 1. 

  
    Link connected to: a Stub Network
	
!--- This line represents the Ethernet segment 
    !--- 4.0.0.0/8.
 
     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
	   
!--- OSPF cost of the Ethernet segment. 

  
    Link connected to: another Router (point-to-point)
	
!--- This line shows that Router 1.1.1.1 is a 
	!--- neighbor with Router 2.2.2.2. 

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 5.0.0.1
	 
!--- The interface address that connects to 
	 !--- Router 2.2.2.2 is 5.0.0.1.
 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64
	   
!--- OSPF cost of the link connecting the two routers. 

  
    Link connected to: a Stub Network
	
!--- This line represents the serial link 5.0.0.0/8. 

     (Link ID) Network/subnet number: 5.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64
	   
!--- OSPF cost of the serial link. 

  
r2.2.2.2#show ip ospf database router 2.2.2.2 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Router Link States (Area 0) 
  
  LS age: 135 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000020 
  Checksum: 0xCD0B 
  Length: 48 
  Area Border Router
   Number of Links: 2
  
    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 3.3.3.3 
     (Link Data) Router Interface address: 6.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 
  
    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 
  
  
                Router Link States (Area 1) 
  
  LS age: 130 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000033 
  Checksum: 0x2130 
  Length: 48 
  Area Border Router
   Number of Links: 2
  
    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 5.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 
  
    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 5.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 
  

r2.2.2.2#show ip ospf database router 3.3.3.3 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Router Link States (Area 0) 
  
  LS age: 1280 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 3.3.3.3 
  Advertising Router: 3.3.3.3 
  LS Seq Number: 8000000D 
  Checksum: 0x9057 
  Length: 48 
   Number of Links: 2 
  
    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 6.0.0.3 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 
  
    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

あるエリアから他のエリアへのルートをアドバタイズするために、ABR で(タイプ 3)集約 LSA が作成されます。

r2.2.2.2#show ip ospf database summary 4.0.0.0 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Summary Net Link States (Area 0) 
  
  LS age: 184 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 4.0.0.0 (summary Network Number)
  
!--- 4.0.0.0/8 is advertised into area 0 by 
  !--- the ABR (Router 2.2.2.2).
 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0xFFE6 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 74 



r2.2.2.2#show ip ospf database summary 5.0.0.0 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Summary Net Link States (Area 0) 
  
  LS age: 1768 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 5.0.0.0 (summary Network Number)
 
 !--- 5.0.0.0/8 is advertised into area 0 by 
  !--- the ABR (Router 2.2.2.2). 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000006 
  Checksum: 0x8466 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 64 



r2.2.2.2#show ip ospf database summary 6.0.0.0 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Summary Net Link States (Area 1) 
  
  LS age: 216 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 6.0.0.0
  
!--- 6.0.0.0/8 is advertised into area 1 by the ABR(2.2.2.2).
 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000001F 
  Checksum: 0xCC43 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 1 

最短パスの計算

このセクションでは、ルータ 3.3.3.3 から見た最短パスを計算します。

ルータ 3.3.3.3 は自身の LSA を参照し、ルータ 2.2.2.2 が近接ルータであることを認識します。 続いてルータ 2.2.2.2 の LSA を参照し、ルータ 2.2.2.2 がルータ 3.3.3.3 を近接ルータとして認識していることを確認します。 ルータが両方とも相手として互いに会う場合、到達可能と見なされます。

さらに各ルータはローカルの近接ルータ テーブル(show ip ospf neighbor コマンドで表示できる)をチェックし、自身のインターフェイスと近接ルータのインターフェイスが共通の IP サブネット上にあることを確認します。

注: このチェックは非番号 インターフェイスで実行された。

インターフェイスが共通のサブセットにある場合、ルータは近接ルータの LSA にリストされているすべてのスタブ ネットワークへのルートを設定します。 この例では、60.0.0.0/8 はルータが 3.3.3.3 既に直接接続されるエリア 0 のルータ 2.2.2.2's LSA にリストされている唯一のスタブ ネットワークです。

エリア 0 のすべての到達可能な ルータ LSA を検査した後、データベースの要約LSA のルータ 3.3.3.3 外観。 それは 4.0.0.0/8 および 5.0.0.0/8 のための要約LSA を見つけます。 ルータ 3.3.3.3 でこの集約 LSA を作成したアドバタイジング ルータへの到達方法が分かっている場合は、そのルートを自身のルーティング テーブルに設定します。 例では、アドバタイズ ルータはルータ 3.3.3.3 が達する方法を知っているルータ 2.2.2.2 です。 それはルーティング テーブルに 4.0.0.0/8 および 5.0.0.0/8 のためのルーティングをインストールします。 これらのルートへのメトリックは、アドバタイジング ルータへ到達するまでのメトリックに、集約 LSA のメトリックを足したものになります。 集約 LSA のメトリックは、集約 LSA を作成するときの対象となるエリア内ルートまたはエリア間ルートに到達するコストから計算されます。

すべての内部 OSPF ルート(エリア内およびエリア間)を計算した後、ルータ 3.3.3.3 は外部 LSA を検査します。 最初に ASBR 1.1.1.1 によって作成された外部 LSA 9.0.0.0/8 を検査し、次にこの ASBR までの到達方法を計算します。 ルータ 3.3.3.3 によってルータ 1.1.1.1 に対する ASBR 集約 LSA が検査されます。これは ABR(ルータ 2.2.2.2)によって作成されたものです。 これにより、ルータ 3.3.3.3 では ABR を経由して ASBR に到達可能であることが判明します。 この結果、ルータ 3.3.3.3 は 9.0.0.0/8 へのルートを自身のルーティング テーブルに設定します。 この例では、これが E1 ルートです。したがって、メトリックは、ルータ 3.3.3.3 が ABR に到達するためのメトリックと、ABR が ASBR に到達するためのメトリック、および外部 LSA のメトリックを足し合わせたものになります。

この出力は説明される各ルータのルーティング テーブルで OSPF ルーティングを示したものです。

r3.3.3.3#
show ip route ospf
 
O IA 4.0.0.0/8 [110/75] via 6.0.0.2, 00:07:59, ATM2/0.20 
O IA 5.0.0.0/8 [110/65] via 6.0.0.2, 00:07:59, ATM2/0.20 
O E1 9.0.0.0/8 [110/70] via 6.0.0.2, 00:07:59, ATM2/0.20 
  

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 5.0.0.1, 00:06:55, Serial0/1/0 
O E1 9.0.0.0/8 [110/69] via 5.0.0.1, 00:06:55, Serial0/1/0 
  

r1.1.1.1#show ip route 9.0.0.0 
Routing entry for 9.0.0.0/8 
  Known via "static", distance 1, metric 0 
  Redistributing via ospf 4 
  Advertised by ospf 4 metric 5 metric-type 1 
  Routing Descriptor Blocks: 
  * 4.0.0.2 
      Route metric is 0, traffic share count is 1

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 47865