IP : Open Shortest Path First(OSPF)

マルチアクセス ネットワークで接続されている OSPF ルータ

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 10 月 29 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、マルチアクセス ネットワークで接続されている 2 台の Open Shortest Path First(OSPF)ルータについて説明します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次の図で示されるネットワーク構成を使用しています。

/image/gif/paws/47863/ospfdb4a.gif

設定

このドキュメントでは、次に示す設定を使用しています。

ルータ 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Ethernet2/0/2
 ip address 5.0.0.1 255.0.0.0
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

近接ルータであることを示しています。
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Ethernet0/0/2
 ip address 5.0.0.2 255.0.0.0
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show ip ospf database — Link State Advertisement (LSA; リンクステート アドバタイズメント)のリストを表示する、リンク状態データベースにそれらをタイプします。 このリストでは、LSA ヘッダーの情報だけが表示されます。

  • show ip ospf database [router] [link-state-id] —データベースのルータの LSA すべてのリストを表示する。 LSA は各ルータによって生成 され、これらの基本的な LSA は状態およびリンク の 発信コストと共にルータのリンク、かインターフェイスすべてを、リストします。 これらは、生成されたエリア内でだけフラッディングされます。

OSPF データベースの検査

このネットワーク環境がある OSPFデータベース一見が show ip ospf database コマンドの出力をどのように検知 するか見るため。

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router  Age   Seq#         Checksum  Link count 
1.1.1.1   1.1.1.1     107   0x80000018   0x7966        2 
2.2.2.2   2.2.2.2     106   0x80000015   0x6770        2 

                Net Link States (Area 0) 

Link ID   ADV Router  Age   Seq#         Checksum 
5.0.0.2   2.2.2.2     102   0x80000004   0x7E9D 
  

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 147 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, the Link State Id is always the 
  !--- same as the Advertising Router. 

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that created 
  !--- this LSA.
 
  LS Seq Number: 80000018 
  Checksum: 0x7966 
  Length: 48 
   Number of Links: 2 

    Link connected to: a Transit Network
    
!--- This router (1.1.1.1) has a link connected to 
    !--- a transit network that has a designated router (DR)
    !--- and backup designated router (BDR) listed here.  

     (Link ID) Designated Router address: 5.0.0.2
	 
!--- The DR's interface IP address is 5.0.0.2.
 
     (Link Data) Router Interface address: 5.0.0.1
	 
!--- This router's (1.1.1.1) interface address 
     !--- connected to the DR is 5.0.0.1. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
       
!--- The OSPF cost of the link is 10.
 

    Link connected to: a Stub Network 
    
!--- This represents the subnet of the Ethernet segment
    !--- 4.0.0.0/8. 

     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
       
!--- The cost of the link is 10. 


r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 162 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000015 
  Checksum: 0x6770 
  Length: 48 
   Number of Links: 2 

    Link connected to: a Transit Network 
     (Link ID) Designated Router address: 5.0.0.2
     
!--- The DR's interface IP address is 5.0.0.2.
 
     (Link Data) Router Interface address: 5.0.0.2
     
!--- Since these values are equal, router
     !--- (2.2.2.2) is the DR. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 
  

r2.2.2.2#show ip ospf database network 5.0.0.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Net Link States (Area 0) 

  Routing Bit Set on this LSA 
  LS age: 182 
  Options: (No TOS-capability, DC) 
  LS Type: Network Links 
  Link State ID: 5.0.0.2 (address of Designated Router)
  
!--- This is the IP address of the DR 
  !--- (not the router ID). 

  Advertising Router: 2.2.2.2
  
!--- This is the router ID of the router that 
  !--- created this LSA.

  LS Seq Number: 80000004 
  Checksum: 0x7E9D 
  Length: 32 
  Network Mask: /8
  
!--- Binary and the DR's interface address with the 
  !--- mask to get to network 5.0.0.0/8. 

        Attached Router: 2.2.2.2
	
!--- The DR's router ID, along with a list of routers 
    !--- adjacent on the transit network. 

        Attached Router: 1.1.1.1 

最短パスの計算

このセクションはルータ 1.1.1.1 の観点から最短パスツリーを計算します。

ルータ 1.1.1.1 は自身の LSA を調べ、DR のインターフェイス アドレスが 5.0.0.2 であるトランジット ネットワークへのリンクがあることを確認します。 次に、link state ID が 5.0.0.2 のネットワーク LSA を探します。 ネットワーク LSA には接続されているルータのリスト(ルータ 1.1.1.1 と 2.2.2.2)があります。 これは、これらのルータがこのトランジット ネットワーク経由で到達可能であることを意味しています。 ルータ 1.1.1.1 は自身の ID がリストにあることを確認できます。 それはそれからこれらの付属のルータの何れかによるルーティングを計算できます。

ルータ 1.1.1.1 はルータ 2.2.2.2 の LSA を探して、同じトランジット ネットワーク 5.0.0.2 に接続されているリンクが含まれていることを確認します。 この時点で、ルータ 1.1.1.1 はルータ 2.2.2.2 の LSA にあるすべてのスタブ ネットワークへのルートを開設できます。

ルータ 1.1.1.1 は、ルーティング テーブルに 6.0.0.0/8 へのルートを設定します。これは、6.0.0.0/8 が自身の LSA にスタブ ネットワークとしてリストされているためです。

r1.1.1.1#show ip route ospf 
O    6.0.0.0/8 [110/20] via 5.0.0.2, 00:03:35, Ethernet2/0/2 

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/20] via 5.0.0.1, 00:03:18, Ethernet0/0/2 

OSPF リンクステートデータベースはそれがブロードキャストネットワークまたは非ブロードキャストネットワークである場合同一に見えます。 主な違いは近隣探索メカニズムです。 ブロードキャスト ネットワークでは、近接ルータはマルチキャスト hello パケットによって検出されます。 非ブロードキャスト ネットワークの場合、近接ルータはスタティックに設定され、近接ルータ間の隣接関係を確立するためにユニキャスト hello パケットが送出されます。

非ブロードキャスト マルチアクセス ネットワークでのネクストホップ

非ブロードキャスト マルチアクセス(NBMA)ネットワークのネクスト ホップの問題を探索するため、この例の外観。 これらはトランジット ネットワーク上にある 3 台のルータです(ルータ non_DR_a、ルータ non_DR_b、およびルータ DR)。 それはのハブ・アンド・スポーク トポロジー フレーム リレー、非同期転送モード (ATM)、または X.25 のような NBMA メディアです。

/image/gif/paws/47863/ospfdb4b.gif

ルータ non_DR_a がルータ non_DR_b 経由のルートを計算する場合、ルータ non_DR_b をネクストホップとします。 ただし、ルータ non_DR_a にこれらのルータは互いを ping できないことを意味するルータ non_DR_b に Virtual Circuit (VC)がありません。 OSPF は到達することができないネクスト・ホップのルーティング テーブルにルーティングをインストールします。

この問題の解決策は、2 つ目の frame-relay map 文を追加して、ルータ DR に繋がる VC を経由してすべての近接ルータが到達可能になるようにすることです。たとえば、次のようにします。

interface Serial0 
 frame-relay map ip 1.1.1.1 700 broadcast
 
!--- This is a map for the DR. 

 frame-relay map ip 1.1.1.2 700 broadcast
 
!--- This is a map on the same VC data-link connection 
 !--- identifier (DLCI) for a non-DR router. 

Intermediate System-to-Intermediate System (ISIS) プロトコルのそれとこの動作を比較するとき、ルータはネクスト ホップがネイバーでなければ、ネクスト ホップを通した ISISルートをインストールしません。 これはルータが十分に一致しなければ ISIS がマルチポイント インターフェイスで動作しないことを意味します。

OSPF はネクスト ホップがネイバーではないインストールし、到達可能直通レイヤ2 ではないですのにルーティングを。 ただし、この問題は map 文を複数設定することで解決できます。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 47863