IP : Open Shortest Path First(OSPF)

ポイントツーマルチポイント リンクによって接続された OSPF ルータ

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 10 月 29 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、ポイントツーマルチポイント リンクによって接続されている 2 台の Open Shortest Path First(OSPF)ルータについて説明します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/47862/ospfdb3a.gif

設定

このドキュメントでは、次の設定を使用します。

ルータ 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 ip ospf network point-to-multipoint
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

近接ルータであることを示しています。
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Serial2/1/0
 ip address 5.0.0.2 255.0.0.0
 ip ospf network point-to-multipoint
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

  • show ip ospf database — Link State Advertisement (LSA; リンクステート アドバタイズメント)のリストを表示する、リンク状態データベースにそれらをタイプします。 このリストでは、LSA ヘッダーの情報だけが表示されます。

  • show ip ospf database [router] [link-state-id] —データベースのルータの LSA すべてのリストを表示する。 LSA は各ルータによって生成 されます。 これらの基本的な LSA は状態およびリンク の 発信コストと共にルータのリンクかインターフェイスすべてを、リストします。 これらは、生成されたエリア内でだけフラッディングされます。

OSPF データベースの検査

このネットワーク環境がある OSPFデータベース一見が show ip ospf database コマンドの出力をどのように検知 するか見るため。

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age    Seq#           Checksum   Link count 
1.1.1.1  1.1.1.1       206    0x8000000A     0x158C       3 
2.2.2.2  2.2.2.2       206    0x8000000B     0x791        3 

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 224 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, Link State Id is always the same 
  !--- as the Advertising Router (next line).

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that created 
  !--- this LSA.

  LS Seq Number: 8000000A 
  Checksum: 0x158C 
  Length: 60 
   Number of Links: 3 

    Link connected to: another Router (point-to-point) 
   
 !--- This line shows that this router(1.1.1.1) is a 
	   !--- neighbor with 2.2.2.2.

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 5.0.0.1 
     
!--- This line shows the interface on this router 
	    !--- (1.1.1.1) that connects the neighbor (2.2.2.2).

      Number of TOS metrics: 0 
       TOS 0 Metrics: 64  
       
!--- The OSPF cost of the link is 64.


    Link connected to: a Stub Network 
    
!--- This router's (1.1.1.1) interface on the 
    !--- point-to-multipoint network. 

     (Link ID) Network/subnet number: 5.0.0.1 
     (Link Data) Network Mask: 255.255.255.255
     
!--- Notice the mask. Only the interface is advertised,
     !--- not the whole subnet. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 0
      
 !--- The OSPF cost for this router to reach its 
       !--- own interface is zero. 


    Link connected to: a Stub Network
	
!--- Represents the subnet of the Ethernet segment 4.0.0.0/8. 

     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
	   
!--- The cost of the link is 10.


r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 253 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000000B 
  Checksum: 0x791 
  Length: 60 
   Number of Links: 3 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 5.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 5.0.0.2 
     (Link Data) Network Mask: 255.255.255.255 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 0 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10

最短パスの計算

このセクションはルータ 2.2.2.2 の観点から最短パスツリーを計算します。

ルータ 2.2.2.2 は自身の LSA を参照し、ルータ 1.1.1.1 が近接ルータであることを認識します。 ルータ 2.2.2.2 がルータ 1.1.1.1 の LSA を参照し、1.1.1.1 が 2.2.2.2 を近接ルータとして認識していることを確認します。 ルータが両方とも相手として互いに会う場合、到達可能と見なされます。

さらに各ルータはローカルの近接ルータ テーブル(show ip ospf neighbor コマンドで表示できる)をチェックし、自身のインターフェイスと近接ルータのインターフェイスが共通の IP サブネット上にあることを確認します。 確認ができたら、両ルータは近接ルータの LSA にリストされているスタブ ネットワークへのルートを設定します。

この例では、ルータ 1.1.1.1 のルータ LSA 内にスタブ ネットワークとして 4.0.0.0/8 がリストされているため、ルータ 2.2.2.2 は自身のルーティング テーブル内に 4.0.0.0/8 への経路を開設します。 ルータ 1.1.1.1 では 5.0.0.1/32 もスタブとしてリストされています。これはポイントツーマルチポイント ネットワークに対するインターフェイスです。 従って、ルータ 2.2.2.2 はルーティング テーブルに 5.0.0.1/32 のための OSPFルートをインストールします。

Router 2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 5.0.0.1, 00:09:26, Serial0/1/0 
O    5.0.0.1/32 [110/64] via 5.0.0.1, 00:09:26, Serial0/1/0
  
Router 1.1.1.1#show ip route ospf 
O    6.0.0.0/8 [110/74] via 5.0.0.2, 00:00:49, Serial2/1/0 
O    5.0.0.2/32 [110/64] via 5.0.0.2, 00:00:49, Serial2/1/0

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 47862