IP : Open Shortest Path First(OSPF)

番号付きポイントツーポイント リンクによって接続された OSPF ルータ

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 10 月 29 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、番号付きポイントツーポイント リンクによって接続されている 2 台の Open Shortest Path First(OSPF)ルータについて説明します。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは、次の図で示されるネットワーク構成を使用しています。

/image/gif/paws/47861/ospfdb2a.gif

設定

このドキュメントでは、次に示す設定を使用しています。

ルータ 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

ルータ 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Serial2/1/0
 ip address 5.0.0.2 255.0.0.0
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

OSPF データベースの検査

このネットワーク環境の情報が OSPF データベースにどのように格納されているかを確認するには、show ip ospf database コマンドの出力を調べます。.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age   Seq#          Checksum   Link count 
1.1.1.1   1.1.1.1      522   0x80000002    0x96D3         3 
2.2.2.2   2.2.2.2      401   0x80000003    0x9FC2         3 

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 540 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, the Link State Id is always the same 
  !--- as the Advertising Router (the next line).

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that  
  !--- created this LSA. 

  LS Seq Number: 80000002 
  Checksum: 0x96D3 
  Length: 60 
   Number of Links: 3 

    Link connected to: another Router (point-to-point)
    
!--- This entry shows that this router (1.1.1.1) is a neighbor
    !--- with 2.2.2.2.

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 5.0.0.1
     
!--- Interface on this router (1.1.1.1) which connects the 
     !--- neighbor (2.2.2.2).

      Number of TOS metrics: 0 
       TOS 0 Metrics: 64
     	
!--- The OSPF cost of the link is 64.


    Link connected to: a Stub Network
	
!--- This represents the subnet of the serial link 5.0.0.0/8. 

     (Link ID) Network/subnet number: 5.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64
		
!--- The OSPF cost of the link is 64.


    Link connected to: a Stub Network
	
!--- This represents the subnet of the 
!--- Ethernet segment 4.0.0.0/8.

     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
		
!--- The OSPF cost of the link is 10.

  

r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 424 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000003 
  Checksum: 0x9FC2 
  Length: 60 
   Number of Links: 3 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 5.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 
  
    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 5.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64

最短パスの計算

このセクションはルータ 2.2.2.2 の観点から最短パスツリーを計算します。

ルータ 2.2.2.2 は自身の LSA を参照し、ルータ 1.1.1.1 が近接ルータであることを認識します。 ルータ 2.2.2.2 がルータ 1.1.1.1 の LSA を参照し、1.1.1.1 が 2.2.2.2 を近接ルータとして認識していることを確認します。 ルータが両方とも相手として互いに会う場合、到達可能と見なされます。

さらに各ルータはローカルの近接ルータ テーブル(show ip ospf neighbor コマンドで表示できる)をチェックし、自身のインターフェイスと近接ルータのインターフェイスが共通の IP サブネット上にあることを確認します。 確認ができたら、両ルータは近接ルータの LSA にリストされているスタブ ネットワークへのルートを設定します。

この例では、ルータ 1.1.1.1 のルータ LSA 内にスタブ ネットワークとして 4.0.0.0/8 がリストされているため、ルータ 2.2.2.2 は自身のルーティング テーブル内に 4.0.0.0/8 への経路を開設します。 ルータ 1.1.1.1 はまたスタブ ネットワークとして 5.0.0.0/8 をリストしました。 ただし 5.0.0.0/8 のための接続ルータがあるので、ルータ 2.2.2.2 は 5.0.0.0/8 のための OSPFルートをインストールしません。 接続ルータは学習したルートより動的によいです常に。

Router 2_2_2_2#
show ip route ospf
 
O    4.0.0.0/8 [110/74] via 5.0.0.1, 00:09:26, Serial0/1/0 

Router 1_1_1_1#show ip route ospf 
O    6.0.0.0/8 [110/74] via 5.0.0.2, 00:00:49, Serial2/1/0 

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連情報


Document ID: 47861