IP : Open Shortest Path First(OSPF)

非番号シリアル リンクによって接続された OSPF ルータ

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 6 月 1 日) | 英語版 (2015 年 8 月 22 日) | フィードバック



目次


概要

ip unnumbered コンフィギュレーション コマンドでは、シリアル インターフェイスに明示的な IP アドレスを割り当てることなく IP 処理をイネーブルにできます。 IP アンナンバード インターフェイスは、ルータ上にすでに設定されている別のインターフェイスの IP アドレスを「借りる」ことができます。 これは、ネットワークとアドレス空間を節約できます。 ip unnumbered コマンドの詳細については、『Understanding and Configuring the ip unnumbered Command』を参照してください。 このドキュメントでは、非番号シリアル リンクで接続されている 2 台の Open Shortest Path First(OSPF)ルータについて説明します。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

この文書では、次のダイヤグラムに示すネットワーク設定を使用します。

/image/gif/paws/47860/ospfdb1.gif

設定

このドキュメントでは、次の設定を使用します。

ルータ 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Serial2/1/0
 ip unnumbered Ethernet2/0/0
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0

end

ルータ 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Serial2/1/0
 ip unnumbered Ethernet0/0/4
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0

end

確認

このセクションは設定がきちんと機能することを確認するために情報を提供します。

特定の show コマンドは、アウトプットインタープリタ登録ユーザ専用)でサポートされています。 このツールを使用して、show コマンドの出力の解析を表示できます。

  • show ip ospf database — リンク状態データベースの Link State Advertisement (LSA; リンクステート アドバタイズメント)のリストを表示する。 このリストでは、LSA ヘッダーの情報だけが表示されます。

  • show ip ospf database [router] [link-state-id] —データベースのルータISA (タイプ 1 LSA)のコンテンツを表示する。 ルータISA は各ルータによって生成 されます。 これらの基本的な LSA は状態およびリンク の 発信コストと共にルータのリンク、かインターフェイスすべてを、リストします。 これらは、生成されたエリア内でだけフラッディングされます。

OSPF データベースの検査

それがこのネットワーク環境を与えられる時 OSPFデータベース一見が、show ip ospf database コマンドの出力をどのように検知 するか見るため。

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router  Age   Seq#           Checksum     Link count 
1.1.1.1   1.1.1.1     254   0x8000001A     0xA6FA           2 
2.2.2.2   2.2.2.2     253   0x80000017     0x4858           2 

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  

                Router Link States (Area 0) 

  LS age: 279 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1   
  
!--- For router links, Link State Id is always the same as the 
  !--- Advertising Router (next line). 

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router which created 
  !--- this LSA.

  LS Seq Number: 8000001A 
  Checksum: 0xA6FA 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point)
	
!--- This line shows that this router (1.1.1.1) is a neighbor 
 !--- with 2.2.2.2.

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 0.0.0.12
		
!--- In the case of unnumbered link, use the MIB II IfIndex  
  !--- value. This value usually starts with 0. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 
	   
!--- This is the OSPF cost of the link that connects 
!--- the two routers.


    Link connected to: a Stub Network 
	
!--- This entry represents the Ethernet segment 4.0.0.0/8.

     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10  
	   
!--- This is the OSPF cost of the Ethernet segment. 



r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  

                Router Link States (Area 0) 

  LS age: 295 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000017 
  Checksum: 0x4858 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 0.0.0.10 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

最短パスの計算

このセクションはルータ 2.2.2.2 の観点から最短パスツリーを計算します。

ルータ 2.2.2.2 は自身の LSA を参照し、ルータ 1.1.1.1 が近接ルータであることを認識します。 それそして 1.1.1.1 がネイバーとして 2.2.2.2 を見ることを確認するルータ 1.1.1.1's LSA の外観。 両方のルータが互いにネイバーとして認識しあっている場合、両ルータは到達可能と見なされます。 ルータは相手の LSA にそれからリストされているあらゆるスタブ ネットワークのためのルーティングをインストールします。

この例では、ルータ 1.1.1.1 が LSA のスタブ ネットワークとして 4.0.0.0/8 をリストするのでルータ 2.2.2.2 はルーティング テーブルに 4.0.0.0/8 のためのルートをインストールします。 これは show ip route ospf コマンドの助けによって見られます。

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 4.0.0.1, 00:06:01, Serial0/1/0 

r1.1.1.1#show ip route ospf 
O    6.0.0.0/8 [110/74] via 6.0.0.2, 00:06:16, Serial2/1/0 

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連情報


Document ID: 47860