IP : Integrated Intermediate System-to-Intermediate System(IS-IS)

IS-IS での MTU の不一致に関する問題

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2001 年 12 月 11 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

Intermediate System-to-Intermediate System(IS-IS)の HELLO パケットは、maximum transmission unit(MTU; 最大伝送ユニット)の最大限の大きさまでパディングされます。 IS-IS の HELLO パケット(IIH)を MTU の最大サイズまでパディングすることの利点は、大規模なフレームの転送によるエラーや、近接インターフェイス間での MTU の不一致によるエラーを早期に検出できるようになることです。

IIH の埋め込みは消すことができます(Cisco IOS でか。 IS-IS ルーティング プロセスにおけるルータ コンフィギュレーション モードの no hello padding コマンドを用いるルータのすべてのインターフェイスのためのソフトウェア リリース 12.0(5)T および 12.0(5)S)。 また IIH のパディングは、ポイントツーポイントまたはマルチポイントのインターフェイスに対して、選択的にオフにすることもできます。この場合は、ルータの設定モードで IS-IS ルーティング プロセスに対して no hello padding multi-point または no hello padding point-to-point コマンドを実行します。 no isis hello padding インターフェイス設定コマンドを使用すると、個々のインターフェイスに対して HELLO パケットのパディングをオフにすることができます。

ユーザは両方のインターフェイスの MTU が同じまたはなら順序で HELLO パディングをトランスレーショナル ブリッジングの場合にはネットワーク帯域幅を、浪費することを避けますディセーブルにします。 HELLO パディングが無効の間、Ciscoルータはまだ完全な MTU サイズにパッドを入れられる最初の 5 IS-IS hellos を送信 します。 これは MTU 不一致の検出の利点を維持することです。 連続した hellos はもはやパッドを入れられません。

この文書では、IS-IS が稼働している接続された 2 台のルータのインターフェイスで、MTU の不一致がある場合に発生する問題について説明します。 ルータ F の MTU は、インターフェイス設定コマンドの mtu 2000 によって、デフォルト値の 1500 バイトから 2000 バイトに変えられています。 シリアルインターフェイスは「フラップされました」。 従って、実施される新しい MTU 値のために shutdownコマンドでシリアル 0 をディセーブルにして下さい次に no shutdown コマンドでそれを有効に します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

問題

この問題を記述するのに使用されるネットワークダイアグラムおよびコンフィギュレーションはここに示されています:

/image/gif/paws/47201/isis_mtu_01.gif

ルータ H ルータ F
clns routing
 !

 interface Serial0
  no ip address
  no ip directed-broadcast
  no ip mroute-cache
  encapsulation frame-relay
  frame-relay lmi-type ansi
 !
 interface Serial0.1 

  ip address 10.10.10.4 255.255.255.0
  no ip directed-broadcast
  ip router isis  
  clns router isis 
  frame-relay map clns 132 broadcast
  frame-relay map clns 131 broadcast
  frame-relay map ip 10.10.10.1 132 broadcast
  frame-relay map ip 10.10.10.3 131 broadcast
 !
 interface Serial0.2 point-to-point
  ip address 10.20.20.4 255.255.255.0
  no ip directed-broadcast
  ip router isis 
  clns router isis 
  frame-relay interface-dlci 130   
 !
 router isis 
  passive-interface Ethernet0
  net 49.0001.4444.4444.4444.00
  is-type level-1
clns routing

!
interface Serial2
mtu 2000
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial2.1 point-to-point
 ip address 10.20.20.2 255.255.255.0
 no ip directed-broadcast
 ip router isis 
 clns router isis 
 frame-relay interface-dlci 103   
!
router isis 
 net 49.0001.2222.2222.2222.00
 is-type level-1

両方のルータで、ルータ F と show clns neighbors コマンドでルータ H 間の隣接関係の状態を表示できます。 ルータ F での出力には、ルータ H との隣接関係は INIT 状態であると表示されます。 ルータ H からの出力では、ルータ F との隣接関係が型あるであり、プロトコルが中間システム(ES-IS)システムに端であることがわかります。 この出力によって、Connectionless Network Service(CLNS; コネクションレス型ネットワーク サービス)の隣接関係に問題があることが分かります。

Router_H# show clns neighbors

System Id      SNPA                Interface   State  Holdtime  Type Protocol
Router_F       DLCI 130            Se0.2       Up     294       IS   ES-IS
Router_G       DLCI 131            Se0.1       Up     7         L1   IS-IS
Router_E       DLCI 132            Se0.1       Up     27        L1   IS-IS


Router_F# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_H       Se2.1       DLCI 103            Init   26        L1   IS-IS

debug isis adj-packets コマンドで IS-IS 隣接パケット デバッグを有効にする場合、ルータ F がシリアル 2.1 サブインターフェイスのシリアル IIH を送信 し、受け取ることがわかります。

Router_F# debug isis adj-packets
IS-IS Adjacency related packets debugging is on
ISIS-Adj: Sending serial IIH on Serial2.1
ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1, cir id 00
ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT
ISIS-Adj: Action = GOING UP, new type = L1
ISIS-Adj: Sending serial IIH on Serial2.1
ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1, cir id 00
ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT
ISIS-Adj: Action = GOING UP, new type = L1
ISIS-Adj: Sending serial IIH on Serial2.1
ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1, cir id 00
ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT
ISIS-Adj: Action = GOING UP, new type = L1
ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1,cir id 00
ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT
ISIS-Adj: Action = GOING UP, new type = L1
ISIS-Adj: Sending serial IIH on Serial2.1

この出力はルータ H がルータ F.からシリアル 0.2 の IIH を受け取らないことを示したものです。 従って、IS-IS 隣接関係は形成されません。 この場合、隣接関係は End System(ES)になっています。

Router_H# debug isis adj-packets
IS-IS Adjacency related packets debugging is on
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01
ISIS-Adj: Sending L1 IIH on Serial0.1
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01
ISIS-Adj: Sending serial IIH on Serial0.2
ISIS-Adj: Rec L2 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01
ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01 
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01
ISIS-Adj: Sending L1 IIH on Serial0.1
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01
ISIS-Adj: Rec L2 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01 
ISIS-Adj: Sending serial IIH on Serial0.2
ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01 
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

問題の原因

ES hellos が完全な MTU サイズにパッドを入れられない一方 IIH がリンクの完全な MTU にパッドを入れられるのでルータ H はルータ F から hellos を受け取りません。 これは MTU は 2000 年であり、ルータ H.によって無視される 2000 バイト HELLO を送信 することをルータ F が判断するので起こります。

解決策

ソリューションはリンクの両側に同じ MTU があることを確かめることです。 これをする 1 つの方法はここに示されているように mtu コマンドを使用することです:

Router_F# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router_F(config)# interface serial 2
Router_F(config-if)# mtu 1500
Router_F(config-if)# shutdown
Router_F(config-if)# no shutdown
Router_F(config-if)# ^Z
Router_F#

これにより、ルータ H とルータ F が隣接関係になり、互いのトラフィックをルートするようになります。

Router_H# show clns neighbors

System Id      SNPA                Interface   State  Holdtime  Type Protocol
Router_F       DLCI 130            Se0.2       Up     28        L1   IS-IS
Router_G       DLCI 131            Se0.1       Up     8         L1   IS-IS
Router_E       DLCI 132            Se0.1       Up     29        L1   IS-IS


Router_F# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_H       Se2.1       DLCI 103            Up     24        L1   IS-IS

MTU ミスマッチによる CLNS 隣接問題はまたここに示されているように clns mtu コマンドを使用して解決することができます:

Router_F#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router_F(config)#interface serial2
Router_F(config-if)#clns mtu 1500
Router_F(config-if)#^Z
Router_F#

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 47201