ストレージ ネットワーキング : ファイバ チャネル

FCIP を使った MDS から MDS 802.1Q の設定

2016 年 6 月 18 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2005 年 10 月 28 日) | 英語版 (2016 年 4 月 25 日) | フィードバック


目次


概要

このドキュメントでは、MDS に 802.1Q Multilayer Director Switch(MDS)を使用した Fibre Channel Over TCP/IP(FCIP)の設定例を紹介します。

FCIP は、IP ベース ネットワーク上のファイバ チャネル(FC)ストレージ エリア ネットワーク(SAN)のアイランドの相互接続が単一の FC ファブリックの統一さた SAN を形成できるメカニズムを解説します。 FCIP は IP ベース ネットワーク サービスを利用して、ローカル エリア ネットワーク、メトロポリタン エリア ネットワーク、またはワイドエリア ネットワーク上の SAN アイランド間の接続を提供します。

FCIP によって接続される Fibre Channel SAN

ips8_dot1q_1.gif

FCIP はネットワーク層転送としてポート 3225 で Transmission Control Protocol(TCP)を使用します。

前提条件

要件

IP バックボーンは必要がありま操作上および要求された帯域幅をである FCIP リンクを渡って動作するアプリケーションをサポートするために提供します—これはレイヤ2 (L2)またはレイヤ3 (L3)トポロジーである可能性があります。 L3 トポロジの場合、中間ルータまたはマルチレイヤ スイッチをセットアップし、FCIP トンネルの送信元および宛先 IP アドレスの間で IP トラフィックを適切に転送するように設定する必要があります。 FCIP ピア間のパスにあるすべてのネットワーク デバイスで Quality of Service(QoS)またはトラフィック シェーピングが実現される場合、マルチレイヤ ディレクタ スイッチ(MDS)FCIP プロファイルで TCP 関連パラメータと機能を設定する前に、IP インフラストラクチャを管理するネットワーク管理者に問い合わせて必要な詳細を取得する必要があります。 MDS の IP Storage(IPS; IP ストレージ)サービス モジュールでサブインターフェイスが設定されている場合は、MDS と隣接関係にあるイーサネットのスイッチでは 802.1Q トランキングがサポートされており、さらに、802.1Q トランキングに設定されている必要があります。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • バージョン 1.2.(2a) を実行する IPS サービスモジュール(DS-X9308-SMIP)との MD 9509

  • バージョン 1.2.(2a) を実行する IPS サービスモジュール(DS-X9308-SMIP)との MD 9216

  • Catalyst OS (CatOS)を実行する Catalyst 6509 7.4(3)

  • Emulex LP9K HBA が搭載された Win2003 Server(HPQ Pro-Liant-P4)

  • IBM ストレージ アレイ(ESS-2105-F20)

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

FCIP は次の仕様で構成されてます。

ANSI T11

  1. FC-SW-2 は E_Port およびファブリック動作を含む FC スイッチの動作と相互作用を記述します。

  2. FC-BB-2 は TCP ネットワーク バックボーンをまたがる FC スイッチド ネットワークの拡張に関するマッピングで、E_Port と B_Port をサポートする参照モデルを定義します。

IETF IPS ワーキンググループ

  1. TCP 上の FC は IP ネットワーク上の FC フレームを転送するための TCP/IP 要件に対応します。

  2. FC フレーム カプセル化は、一般的なファイバ カプセル化フォーマットを定義します。

IEEE 802 規格

すべての型の IEEE 802 LAN は ISO/IEC 15802-3 で指定どおりに MAC ブリッジとともに、接続されるかもしれません。 この規格は割り当てブリッジドLAN インフラストラクチャ内の VLANトポロジの定義、オペレーションおよび管理 VLAN ブリッジのオペレーションを定義します。

FCIP をまたがる 2 台の SAN スイッチまたはファブリック間の相互接続は FCIP リンクと呼ばれ、1 つ以上の TCP 接続を含む場合があります。 FCIP リンクの両端は、実装に応じて仮想 E ポート(VE_port)または B_port に関連付けられます。 FC-BB と FC-BB-2 は両方の方式の違いを記述します。 IP サービス モジュール(DS-X9308-SMIP)では両方のモードがサポートされていますが、デフォルトでは VE_Port となっています。これは、すべての関連ピアが DS-X9308-SMIP モジュールの場合に推奨されるモードでもあります。 MDS プラットフォームでの VE_Port の機能では、TE ポート機能もサポートされています。これによって、1 つの FCIP インスタンス上の複数の仮想 SAN(VSAN)からのトラフィックのトランキングが可能になります。 Cisco X9308-SMIP モジュールに装備されている Gigabit Ethernet(GE; ギガビット イーサネット)インターフェイスでは、FCIP トンネルごとに低帯域幅が必要とされるような状況で、複数の FCIP トンネル間で 1 Gbps の帯域幅の利用するために、802.1Q がサポートされています。 FCIP プロファイルの TCP パラメータがデフォルトの状態のままである場合は、dot1q を使用して帯域幅を共有しても、FCIP トンネルごとの確定的な帯域幅は割り当てられないことを理解しておく必要があります。

設定

MDS については、両方のプラットフォームの IPS 設定ガイドを熟知している必要があります。 手動のほとんどの最新バージョンは Cisco.com の IP ストレージの設定で見つけることができます。 イーサネット スイッチ側で、1 つは dot1q 幹線コンフィギュレーション仕様について詳しく知っている必要があります。 この特定の 例では、ハイブリッド CatOS を実行する Catalyst は配置されます; 異なる構成は他の開発元から他の Ciscoスイッチまたはスイッチに適用されるかもしれません。

ハイブリッドモードを実行する Catalyst 6000 シリーズに関してはイーサネットVLAN トランクの設定を参照して下さい。 Native IOS に関しては、VLAN の設定を参照して下さい。 Native IOS が稼働している Catalyst XL 型スイッチに関しては VLAN の設定を参照して下さい。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは次の図に示すネットワーク構成を使用しています。

トポロジ 2

/image/gif/paws/47101/ips8_dot1q_2.gif

トポロジ 2 は、IP クラウドのどちらか一方の側で、802.1Q トランクで稼動している 1 つの FCIP トンネルを表しています。 IP クラウドは VLAN 1000 から VLAN 500 にトラフィックをおよび VLAN 500 から VLAN から 1000 ルーティングする 1 つのマルチレイヤ スイッチ(Catalyst 6500)に縮小されます。 IPサブネット 100.100.100.0/30 への VLAN 1000 概念上マップ、および IPサブネット 100.100.100.4/30 への VLAN 500 マップ。 MD が dot1q 帯をなる下記のコンフィギュレーションセクションでクリアにマッピング し、取得する方法。 わかりやすくするために、両方の 1 物理インターフェイスを渡る 1 FCIP トンネルだけ MDSes 定義されます; 現実には、1 つは複数の FCIP トンネル間の 1 ギガビットインターフェイスの帯域幅を共有するのに dot1q トランキングだけを使用します。

設定

IPS-8 モジュールを搭載した MDS 9509(バイソン)
bison# sh ver

Cisco Storage Area Networking Operating System (SAN-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2003 by Cisco Systems, Inc. All rights reserved.
The copyright for certain works contained herein are owned by
Andiamo Systems, Inc. and/or other third parties and are used and
distributed under license.

Software
BIOS: version 1.0.8
loader: version 1.2(2)
kickstart: version 1.2(2a)
system: version 1.2(2a)

BIOS compile time: 08/07/03
kickstart image file is: bootflash:/k122a
kickstart compile time: 9/23/2003 11:00:00
system image file is: bootflash:/s122a
system compile time: 10/8/2003 18:00:00

Hardware
RAM 1024584 kB

bootflash: 500736 blocks (block size 512b)
slot0: 0 blocks (block size 512b)

bison uptime is 1 days 15 hours 45 minute(s) 44 second(s)

Last reset 
Reason: Unknown
System version: 1.2(2a)
Service: 

bison# sh run

Building Configuration ...
fcip profile 1
ip address 100.100.100.1

!--- FCIP profile 1 is bound to the local relevant IPS interface. 
!--- In this example, it is the IP address of interface Gig4/1.

vsan database
vsan 200 name test 
vsan 600 
vsan 601 

fcdomain priority 1 vsan 1
fcdomain domain 1 preferred vsan 1
fcdomain domain 1 preferred vsan 600
fcdomain domain 1 preferred vsan 601

interface fcip1
no shutdown
switchport trunk allowed vsan 600-601
use-profile 1
peer-info ipaddr 100.100.100.6


<!--- peer IP address is the address on remote MDS Canterbury
<!--- configured on interface Gig4/1.500.

vsan database
vsan 600 interface fc3/1
vsan 601 interface fc3/8

boot system bootflash:/s122a sup-1
boot kickstart bootflash:/k122a sup-1
boot system bootflash:/s122a sup-2
boot kickstart bootflash:/k122a sup-2
boot asm-sfn bootflash:/ilc1.bin module 4

ip domain-name cisco.com
ip name-server 144.254.10.123
ip default-gateway 10.48.69.129
ip route 100.100.100.4 255.255.255.252 100.100.100.2 distance 2

!--- The next hop IP address is 100.100.100.2 
!--- and is owned by the intermediate 
!--- Ethernet multilayer switch Aspendos.

zone name z-fcip2 vsan 600
member pwwn 50:05:07:63:00:d0:94:4c
member pwwn 10:00:00:00:c9:32:a6:e3

zone name Zone_a1 vsan 601
member pwwn 10:00:00:00:00:01:00:00
member pwwn 10:00:00:00:00:05:00:00

zone default-zone permit vsan 1
zone default-zone permit vsan 603

zoneset distribute full vsan 600

zoneset name zs-fcip2 vsan 600
member z-fcip2

zoneset name Agilent_1 vsan 601
member Zone_a1

zoneset activate name zs-fcip2 vsan 600

zoneset activate name Agilent_1 vsan 601

interface fc3/1
no shutdown

!--- Output supressed.

interface fc3/8
no shutdown

interface mgmt0
ip address 10.48.69.151 255.255.255.192

interface GigabitEthernet4/1
no shutdown

interface GigabitEthernet4/1.1000
ip address 100.100.100.1 255.255.255.252

switchport mtu 3000
no shutdown

!--- Here the subinterface 1000 is configured, 
!--- which ties into dot1q VLAN 1000 on the Ethernet switch.
!--- The MTU size is changed from the default 1500 bytes to 3000, 
!--- because the intermediate switch supports jumbo frames 
!--- on both L2 and L3.

IPS-8 モジュールを搭載した MDS 9216 (カンタベリー)
canterbury# sh run

Building Configuration ...
fcip profile 1
ip address 100.100.100.6

vsan database
vsan 600 
vsan 601 

fcdomain domain 2 preferred vsan 600
fcdomain domain 2 preferred vsan 601

interface fcip1
use-profile 1
peer-info ipaddr 100.100.100.1

vsan database
vsan 600 interface fc1/1
vsan 601 interface fc1/8

boot system bootflash:/s122a 
boot kickstart bootflash:/k122a 
fcalias name test vsan 1

ip domain-name cisco.com
ip name-server 144.254.10.123
ip default-gateway 10.48.69.129
ip route 10.61.0.0 255.255.0.0
ip route 10.61.0.0 255.255.0.0 10.48.69.200
ip route 100.100.100.0 255.255.255.252 100.100.100.5 distance 2

!--- Static IPS route required to reach the FCIP peer address.
 
line vty
exec-timeout 0

switchname canterbury
system default switchport trunk mode auto

zone name z-fcip2 vsan 600
member pwwn 50:05:07:63:00:d0:94:4c
member pwwn 10:00:00:00:c9:32:a6:e3

zone default-zone permit vsan 777
zoneset distribute full vsan 600

zoneset name zs-fcip2 vsan 600
member z-fcip2

zoneset activate name zs-fcip2 vsan 600
zoneset activate name Agilent_1 vsan 601

interface GigabitEthernet2/1
no shutdown

interface GigabitEthernet2/1.500
ip address 100.100.100.6 255.255.255.252

switchport mtu 3000
no shutdown

interface fc1/1
no shutdown

interface fc1/8
no shutdown

interface mgmt0
ip address 10.48.69.156 255.255.255.128

IPS-8 モジュールが付いている Catalyst 6000 (Aspendos)
Aspendos> (enable) sh vlan 500

VLAN Name                             Status    IfIndex Mod/Ports, Vlans
---- -------------------------------- --------- ------- -------------------
500  VLAN0500                         active    191     1/1
                                                        3/3
                                                        15/1

VLAN Type SAID MTU  Parent RingNo BrdgNo Stp    Brdg   Mode   Trans1 Trans2
---- ---- ---- ---- ------ ------ ------ ------ ------ ------ ------ ------
500  enet 100  500  1500   -      -      -      -      -      0      0


VLAN MISTP-Inst DynCreated RSPAN
---- ---------- ---------- --------
500  -          static     disabled

Aspendos> (enable) sh vlan 1000

VLAN Name                             Status    IfIndex Mod/Ports, Vlans
---- -------------------------------- --------- ------- -------------------
1000 fcip-extra-hop                   active    131     3/7
                                                        15/1

VLAN Type SAID MTU  Parent RingNo BrdgNo Stp    Brdg   Mode   Trans1 Trans2
---- ---- ---- ---- ------ ------ ------ ------ ------ ------ ------ ------
1000 enet 101  000  1500   -      -      -      -      -      0      0

VLAN MISTP-Inst DynCreated RSPAN
---- ---------- ---------- --------
1000 -          static     disabled

Aspendos> (enable) sh trunk 3/3

* - indicates vtp domain mismatch
Port Mode Encapsulation Status        Native vlan
---- ---- ------------- ------------- -----------
3/3  on   dot1q         trunking      1

Port Vlans allowed on trunk
---- ----------------------------------------------------------------------
3/3  1,500

Port Vlans allowed and active in management domain 
---- ----------------------------------------------------------------------
3/3  1,500

Port Vlans in spanning tree forwarding state and not pruned
---- ----------------------------------------------------------------------
3/3  1,500

Aspendos> (enable) sh trunk 3/7

* - indicates vtp domain mismatch
Port Mode Encapsulation Status       Native vlan
---- ---- ------------- ------------ -----------
3/7  on   dot1q         trunking     1

Port Vlans allowed on trunk
---- ----------------------------------------------------------------------
3/7  1,1000

Port Vlans allowed and active in management domain 
---- ----------------------------------------------------------------------
3/7  1,1000

Port Vlans in spanning tree forwarding state and not pruned
---- ----------------------------------------------------------------------
3/7  1,1000

!--- Note that VLAN 500 is trunked on port 3/3, which is physically connected 
!--- to MDS Canterbury while port 3/7 trunks for VLAN 1000 and is connected 
!--- to MDS Bison. The port 15/1 is an internal port and directs to the 
!--- multilayer entitity in the switch.


Aspendos> (enable) sh port jumbo 

Jumbo frames MTU size is 9216 bytes.
Jumbo frames enabled on port(s) 1/2,3/1-16.

!--- L2 Jumbo support must be enabled for all relevant ports.
 

Aspendos> (enable) sh spantree 3/3 

Port Vlan Port-State Cost Prio Portfast Channel_id
---- ---- ---------- ---- ---- -------- ----------
3/3  1    forwarding 4    32   disabled 0 
3/3  500  forwarding 4    32   disabled 0 

Aspendos> (enable) sh spantree 3/7

Port Vlan Port-State Cost Prio Portfast Channel_id
---- ---- ---------- ---- ---- -------- ----------
3/7  1    forwarding 4    32   disabled 0 
3/7  1000 forwarding 4    32   disabled 0 

Aspendos> (enable) sh spantree 15/1

Port Vlan Port-State Cost Prio Portfast Channel_id
---- ---- ---------- ---- ---- -------- ----------
15/1 192  forwarding 4    32   enabled  0 
15/1 500  forwarding 4    32   enabled  0 
15/1 691  forwarding 4    32   enabled  0 
15/1 1000 forwarding 4    32   enabled  0

!--- All relevant ports on the Catalyst are forwarding 
!--- for their respective VLANs.


Aspendos> (enable) ses 15

Trying Router-15...
Connected to Router-15.
Escape character is '^]'.

User Access Verification

Password: 
Aspendos_MSFC2> en
Password: 
Aspendos_MSFC2#

!
interface Vlan500
mtu 3000
ip address 100.100.100.5 255.255.255.252
end

Aspendos_MSFC2# sh run int vlan 1000
Building configuration...

Current configuration : 113 bytes
!
interface Vlan1000
description "test-vlan-fcip-1000"
mtu 3000
ip address 100.100.100.2 255.255.255.252
end

!--- The VLANs 500 and 1000 are configured properly on the MSFC 
!--- of the Catalyst 6000.
!--- Both subnets are directly connected to the same Ethernet 
!--- switch, so no additional routes are needed here. Also note 
!--- that the MTU size is changed accordingly on the MDS Gigabit 
!--- interfaces to 3000 bytes. This change is required to support 
!--- jumbo multilayer switching.

確認

このセクションでは、設定が正しく動作していることを確認する方法について説明します。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show interface gig x/y:FCIP プロファイルにバインドされている関連ギガビット インターフェイスのステータスを表示します。

  • show ips stats tcp int gig x/y: 関連ギガビット インターフェイスの TCP 統計情報とアクティブな接続を表示します。

  • show ips arp int gig x/y:関連ギガビット インターフェイスのすべてのアドレス解決プロトコル(ARP)エントリを表示します。 ネクスト ホップまたはピアがこのリストに存在する必要があります。

  • show ips ip route int gig x/y:関連ギガビット インターフェイスをまたがる特定のルートを表示します。

  • show interface fcip x:FCIP インターフェイスのステータスとこの FCIP トンネルに関するすべての詳細を表示します。

  • show profile fcip x:プロファイルがバインドされた IP アドレスとすべての設定済み TCP パラメータを表示します。

  • show int fcip x counters:FCIP トンネルを経由して送信されるフレームがあるかどうかを確認するために使用します。

  • show fcdomain vsan x:すべてのドメイン関連詳細をリスト表示します。 ファブリックが FCIP トンネルをまたがって形成されることを確認するために使用します。

  • show fcns da vsan x:関連する VSAN のすべての pwwn、FC4-Type、および FCID を表示します。 予想されるすべてのエントリが FCIP トンネルをまたがって配信されることを確認するために使用します。

注: dot1q インターフェイスは、FCIP の通常の物理インターフェイスとして機能します。 正常な処理を確認するのに必要なのは、show interface gig x/y.z コマンドだけです。z はサブインターフェイスを意味します。 ローカル MD ギガビットインターフェイスに接続されるデバイスによってはインターフェイスおよびポートが正しく設定されることを確認するために関連したドキュメンテーションを参考にして下さい。

トラブルシューティング

カウンタ履歴を作成するには、show コマンドを複数回発行してください。 特定の時点との関連がなく、一度だけ収集されるカウンタはほとんど役に立ちません。

さらに詳細なトラブルシューティングには、次に示す設定を使用してください。

MDS 9509(バイソン)
bison# sh int gig 4/1.1000

GigabitEthernet4/1.1000 is up
    Hardware is GigabitEthernet, address is 0005.3000.a85a
    Internet address is 100.100.100.1/30
    MTU 3000 bytes

!--- Configured to 3000 bytes.

    5 minutes input rate 488 bits/sec, 61 bytes/sec, 0 frames/sec
    5 minutes output rate 488 bits/sec, 61 bytes/sec, 0 frames/sec
    1785 packets input, 996030 bytes
      0 multicast frames, 0 compressed
      0 input errors, 0 frame, 0 overrun 0 fifo
    1812 packets output, 354152 bytes, 0 underruns
      0 output errors, 0 collisions, 0 fifo
      0 carrier errors

!--- MTU is configured to 3000 bytes to avoid unnecessary 
!--- TCP segmentation and limit overhead.


bison# sh ips stats tcp int gig 4/1 de

TCP Statistics for port GigabitEthernet4/1
    TCP send stats
      337202017 segments, 222637392068 bytes
      130562402 data, 205533417 ack only packets
      503 control (SYN/FIN/RST), 0 probes, 1105737 window updates
      7 segments retransmitted, 2208 bytes
      4 retransmitted while on ethernet send queue, 40061909 packets split
      250922624 delayed acks sent
    TCP receive stats
      932985742 segments, 921498012 data packets in sequence, 
        936715052100 bytes in sequence
      770241 predicted ack, 856752348 predicted data
      0 bad checksum, 0 multi/broadcast, 0 bad offset
      0 no memory drops, 0 short segments
      0 duplicate bytes, 16 duplicate packets
      0 partial duplicate bytes, 0 partial duplicate packets
      53128 out-of-order bytes, 165 out-of-order packets
      0 packet after window, 0 bytes after window
      5 packets after close
      76225562 acks, 192030009160 ack bytes, 0 ack toomuch,
        5851 duplicate acks
      0 ack packets left of snd_una, 0 non-4 byte aligned packets
      9124012 window updates, 0 window probe
      1381 pcb hash miss, 984 no port, 103 bad SYN, 0 paws drops
    TCP Connection Stats
      272 attempts, 107 accepts, 163 established
      511 closed, 3 drops, 206 conn drops
      3 drop in retransmit timeout, 20 drop in keepalive timeout
      0 drop in persist drops, 0 connections drained
    TCP Miscellaneous Stats
      61792500 segments timed, 76225541 rtt updated
      124 retransmit timeout, 0 persist timeout
      5760 keepalive timeout, 5740 keepalive probes
    TCP SACK Stats
      0 recovery episodes, 0 data packets, 0 data bytes
      0 data packets retransmitted, 0 data bytes retransmitted
      0 connections closed, 0 retransmit timeouts
    TCP SYN Cache Stats
      107 entries, 107 connections completed, 0 entries timed out
      0 dropped due to overflow, 0 dropped due to RST
      0 dropped due to ICMP unreach, 0 dropped due to bucket overflow
      0 abort due to no memory, 0 duplicate SYN, 0 no-route SYN drop
      0 hash collisions, 0 retransmitted

100.100.100.1:64860 100.100.100.6:3225 ESTABLISH 0 0
100.100.100.1:64862 100.100.100.6:3225 ESTABLISH 0 0
100.100.100.1:3225 0.0.0.0:0 LISTEN 0 0

!--- No specific counters are maintained per subinterface.
!--- All stats for all subinterfaces on Gig 4/1 are seen here.


bison# sh ips arp interface gig 4/1

Protocol Address Age (min) Hardware Addr Type Interface
Internet 100.100.100.2 13 0008.e21e.c7bc ARPA GigabitEthernet4/1.1000 

!--- No specific ARP table is maintained per subinterface.
!--- All entries for all subinterface on Gig4/1 are seen here.


bison# sh ips ip route int gig 4/1

Codes: C - connected, S - static

No default gateway

S 100.100.100.4/30 via 100.100.100.2, GigabitEthernet4/1.1000
C 100.100.100.0/30 is directly connected, GigabitEthernet4/1.1000

!--- IPS routes are derived from the main-interface, 
!--- not specifically per subinterface. The next hop is verified here.


bison# sh cdp ne int gig 4/1

Capability Codes: R - Router, T - Trans-Bridge, B - Source-Route-Bridge
S - Switch, H - Host, I - IGMP, r - Repeater

Device ID   Local Intrfce Hldtme Capability Platform Port ID
----------- ----- ------- ------ ---------- -------- -------
TBM06033144 (Aspe Gig4/1  136    T S        WS-C6506 3/7 

!--- Use this command if the neighbor supports it to verify 
!--- physical connectivity.


bison# sh fcip profile 1

FCIP Profile 1
Internet Address is 100.100.100.1 (interface GigabitEthernet4/1.1000)
Listen Port is 3225
TCP parameters
SACK is enabled
PMTU discovery is enabled, reset timeout is 3600 sec
Keep alive is 60 sec
Minimum retransmission timeout is 200 ms
Maximum number of re-transmissions is 4
Send buffer size is 0 KB
Maximum allowed bandwidth is 1000000 kbps
Minimum available bandwidth is 15000 kbps
Estimated round trip time is 1000 usec
Congestion window monitoring is enabled, burst size is 10 KB 

!--- The profile parameters are an easy way to directly verify 
!--- the configured TCP/IP parameters per FCIP instance.
 

bison# sh int fcip 1

fcip1 is trunking
Hardware is GigabitEthernet
Port WWN is 20:c2:00:05:30:00:7a:de
Peer port WWN is 20:42:00:0c:30:6c:24:40
Admin port mode is auto, trunk mode is on
Port mode is TE
vsan is 1
Trunk vsans (allowed active) (1,600-601)
Trunk vsans (operational) (1,600-601)
Trunk vsans (up) (1,600-601)
Trunk vsans (isolated) ()
Trunk vsans (initializing) ()
Using Profile id 1 (interface GigabitEthernet4/1.1000)
Peer Information
Peer Internet address is 100.100.100.6 and port is 3225
Special Frame is disabled
Maximum number of TCP connections is 2
Time Stamp is disabled
QOS control code point is 0
QOS data code point is 0
B-port mode disabled
TCP Connection Information
2 Active TCP connections
Control connection: Local 100.100.100.1:64860, Remote 100.100.100.6:3225
Data connection: Local 100.100.100.1:64862, Remote 100.100.100.6:3225
2 Attempts for active connections, 0 close of connections
TCP Parameters
Path MTU 3000 bytes
Current retransmission timeout is 200 ms
Round trip time: Smoothed 2 ms, Variance: 1
Advertized window: Current: 118 KB, Maximum: 118 KB, Scale: 1
Peer receive window: Current: 118 KB, Maximum: 118 KB, Scale: 1
Congestion window: Current: 10 KB, Slow start threshold: 112 KB
5 minutes input rate 200 bits/sec, 25 bytes/sec, 0 frames/sec
5 minutes output rate 200 bits/sec, 25 bytes/sec, 0 frames/sec
1306 frames input, 891212 bytes
472 Class F frames input, 46972 bytes
834 Class 2/3 frames input, 844240 bytes
0 Error frames timestamp error 0
867 frames output, 252424 bytes
470 Class F frames output, 48860 bytes
397 Class 2/3 frames output, 203564 bytes
0 Error frames 0 reass frames

!--- Here, the specific details per FCIP interface are shown 
!--- by a running FCIP instance. You can also derive the 
!--- TCP parameters of the peer with this output.


bison# sh fcdomain vsan 600

The local switch is the Principal Switch.

Local switch run time information:
State: Stable
Local switch WWN: 22:58:00:05:30:00:7a:df
Running fabric name: 22:58:00:05:30:00:7a:df
Running priority: 2
Current domain ID: 0x01(1) 

Local switch configuration information:
State: Enabled
FCID persistence: Disabled
Auto-reconfiguration: Disabled
Contiguous-allocation: Disabled
Configured fabric name: 20:01:00:05:30:00:28:df
Configured priority: 128
Configured domain ID: 0x01(1) (preferred)

Principal switch run time information:
Running priority: 2

Interface        Role          RCF-reject
---------------- ------------- ------------
fcip1            Downstream    Disabled
---------------- ------------- ------------

bison# sh fcdomain vsan 601

The local switch is the Principal Switch.

Local switch run time information:
State: Stable
Local switch WWN: 22:59:00:05:30:00:7a:df
Running fabric name: 22:59:00:05:30:00:7a:df
Running priority: 2
Current domain ID: 0x01(1) 

Local switch configuration information:
State: Enabled
FCID persistence: Disabled
Auto-reconfiguration: Disabled
Contiguous-allocation: Disabled
Configured fabric name: 20:01:00:05:30:00:28:df
Configured priority: 128
Configured domain ID: 0x01(1) (preferred)

Principal switch run time information:
Running priority: 2

Interface        Role          RCF-reject
---------------- ------------- ------------
fcip1            Downstream    Disabled
---------------- ------------- ------------

!--- Similar to normal (E)ISL troubleshooting, verify 
!--- that the fabric is formed as expected.


bison# sh fcns da vsan 600-601

VSAN 600:
-------- ---- ----------------------- -------- ---------------------------
FCID     TYPE PWWN                    (VENDOR) FC4-TYPE:FEATURE
-------- ---- ----------------------- -------- ---------------------------
0x010001 N    10:00:00:00:c9:32:a6:e3 (Emulex) scsi-fcp:init 
0x020001 N    50:05:07:63:00:d0:94:4c (IBM)    scsi-fcp:target fc..

Total number of entries = 2

VSAN 601:
-------- ---- ----------------------- -------- ---------------------------
FCID     TYPE PWWN                    (VENDOR) FC4-TYPE:FEATURE
-------- ---- ----------------------- -------- ---------------------------
0x010001 N    10:00:00:00:c9:32:a6:e2 (Emulex) scsi-fcp:init 
0x010100 N    10:00:00:00:00:05:00:00 
0x020100 N    10:00:00:00:00:01:00:00 

Total number of entries = 3

MDS 9216(カンタベリー)
canterbury# sh int gig 2/1.500

GigabitEthernet2/1.500 is up
    Hardware is GigabitEthernet, address is 0005.3000.ade6
    Internet address is 100.100.100.6/30
    MTU 3000 bytes
    5 minutes input rate 2248 bits/sec, 281 bytes/sec, 0 frames/sec
    5 minutes output rate 696 bits/sec, 87 bytes/sec, 0 frames/sec
    2263 packets input, 482038 bytes
      0 multicast frames, 0 compressed
      0 input errors, 0 frame, 0 overrun 0 fifo
    2479 packets output, 1077822 bytes, 0 underruns
      0 output errors, 0 collisions, 0 fifo
      0 carrier errors

canterbury# sh cdp ne int gig 2/1

Capability Codes: R - Router, T - Trans-Bridge, B - Source-Route-Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID   Local Intrfce Hldtme Capability Platform Port ID
----------- ----- ------- ------ ---------- -------- -------
TBM06033144 (Aspe Gig2/1  165    T S        WS-C6506 3/3

!--- If the neighbor supports CDP, use this command
!--- to verify physical connectivity.


canterbury# sh fcip profile 1
FCIP Profile 1
Internet Address is 100.100.100.6 (interface GigabitEthernet2/1.500)
Listen Port is 3225
TCP parameters
SACK is enabled
PMTU discovery is enabled, reset timeout is 3600 sec
Keep alive is 60 sec
Minimum retransmission timeout is 200 ms
Maximum number of re-transmissions is 4
Send buffer size is 0 KB
Maximum allowed bandwidth is 1000000 kbps
Minimum available bandwidth is 15000 kbps
Estimated round trip time is 1000 usec
Congestion window monitoring is enabled, burst size is 10 KB

canterbury# sh int fcip 1
fcip1 is trunking
Hardware is GigabitEthernet
Port WWN is 20:42:00:0c:30:6c:24:40
Peer port WWN is 20:c2:00:05:30:00:7a:de
Admin port mode is auto, trunk mode is auto
Port mode is TE
vsan is 1
Trunk vsans (allowed active) (1,600-601)
Trunk vsans (operational) (1,600-601)
Trunk vsans (up) (1,600-601)
Trunk vsans (isolated) ()
Trunk vsans (initializing) ()
Using Profile id 1 (interface GigabitEthernet2/1.500)
Peer Information
Peer Internet address is 100.100.100.1 and port is 3225
Special Frame is disabled
Maximum number of TCP connections is 2
Time Stamp is disabled
QOS control code point is 0
QOS data code point is 0
B-port mode disabled
TCP Connection Information
2 Active TCP connections
Control connection: Local 100.100.100.6:3225, Remote 100.100.100.1:64860
Data connection: Local 100.100.100.6:3225, Remote 100.100.100.1:64862
0 Attempts for active connections, 0 close of connections
TCP Parameters
Path MTU 3000 bytes
Current retransmission timeout is 200 ms
Round trip time: Smoothed 2 ms, Variance: 1
Advertized window: Current: 118 KB, Maximum: 118 KB, Scale: 1
Peer receive window: Current: 118 KB, Maximum: 118 KB, Scale: 1
Congestion window: Current: 10 KB, Slow start threshold: 112 KB
5 minutes input rate 184 bits/sec, 23 bytes/sec, 0 frames/sec
5 minutes output rate 184 bits/sec, 23 bytes/sec, 0 frames/sec
1163 frames input, 336700 bytes
722 Class F frames input, 72176 bytes
441 Class 2/3 frames input, 264524 bytes
0 Error frames timestamp error 0
1588 frames output, 917216 bytes
724 Class F frames output, 70288 bytes
864 Class 2/3 frames output, 846928 bytes
0 Error frames 0 reass frames

ネイティブVLANミスマッチの注

条件によっては、隣接関係にある(Catalyst)イーサネット スイッチのシステム ログに、native vlan mismatch というエラーメッセージが表示される場合があります。 これは、それらのスイッチのトランクポートでの設定が誤っていることを示しています。 .1000 のサブインターフェイスが MD IP サービス モジュールのメインインターフェイスの 1 つで設定される場合、Catalyst スイッチの隣接したスイッチポートは 1000 のその同じ VLAN ID のためにトランキングする必要があります。 、どういうわけか、Catalyst はポートVLANネイティブ VLAN として VLAN を 1000 実行しています、エラーメッセージは生成され、接続は MD 側からの dot1q カプセル化 された フレームがスイッチによって理解されないし、廃棄されるので、壊れています。 ネイティブVLANミスマッチ エラーの例は下記に示されています。

2003 Nov 13 02:36:39 %CDP-4-NVLANMISMATCH:Native vlan mismatch detected on port 3/7
2003 Nov 13 02:37:26 %CDP-4-NVLANMISMATCH:Native vlan mismatch detected on port 3/3

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 47101