IP : Open Shortest Path First(OSPF)

OSPF を使用した、大規模なサービス プロバイダーのダイヤル ネットワークの設計

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2005 年 8 月 10 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

ダイヤル ネットワークの設計は、インターネット サービス プロバイダー(ISP)にとって困難な課題となっています。 各 ISP はダイヤル ネットワークの設計に固有の方法を使用します。 ただし、すべての ISP は、ダイヤル ネットワークの設計時には、次のような同じ懸念を共有します。

  • プール ルーティングはどのように ISP コアに伝搬する必要があるか。

  • どんなルーティング プロトコルがコアにそれらのルーティングを運ぶのに使用する必要がありますか。

  • それらのダイヤル式ルーティングはコアに送信 する前に要約する必要がありますか。

  • プールが配られるとき何が考慮に入れる必要がありますか。

  • プールがスタティックである場合には、どうすればよいか。

このドキュメントでは、前述のほとんどの質問について説明します。また、Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)の Open Shortest Path First(OSPF)を ISP のダイヤル環境で使用する場合の設計方法についても説明します。 多くの場合、ISP のコア ネットワークには OSPF が使用されています。 この資料では、ダイヤル プール ルーティングを運ぶための別途のプロトコルを導入することを避けます—コアにダイヤル プール ルーティングを伝搬するのに OSPF を使用します。

ネットワーク トポロジ

ここに示されているトポロジーは典型的な ISP ダイヤル ネットワーク ネットワーク・トポロジです。 ダイヤルアップ サービスを提供する ISP には、通常、一連の Network Access Server(NAS; ネットワーク アクセス サーバ)があり、一般的には AS5300 か AS5800 が使用されています。 サーバは ISP にダイアルインし、インターネットサービスを利用したいと思うすべてのユーザに IP アドレスのプロビジョニングするに責任があります。 NAS サーバは一般的に Cisco 6500 ルータである集約デバイスにそれから接続されます。 6500 ルータは、ダイヤルアップ ルートをコアに伝搬して、コア ルータからエンドユーザにインターネット サービスを提供できるようにします。 図 1 典型的な Point of Presence (POP) シナリオを示します。

図 1 –典型的な POP シナリオ

ispdial.jpg

ISP のダイヤルアップ プール

ISP はプール IP アドレスの 2 つの型を一般的に取扱います:

  • スタティック

  • 中央

スタティック プール

静的なプールによって、ISP に IP アドレスの各 NAS サーバに専用されている設定 される仕様があります。 NAS に出会うユーザはプールから専用 IP アドレスの 1 受け取ります。 たとえば NAS1 静的なプール アドレス 範囲が 192.168.0.0/22 なら、およそ 1023 IP アドレスがあります。 NAS1 に出会うユーザは 192.168.0.0 から 192.168.3.254 に範囲のアドレスの 1 つを受け取ります。

中央プール

中央プールを使用する場合、ISP は、1 つの POP 内のすべての NAS 全体に配布される、より広範囲な IP アドレスを設定します。 NAS に出会うユーザは非常に大きい範囲である中央プールから IP アドレスを受け取ります。 たとえば、中央プールのアドレスの範囲が 192.168.0.0/18 に設定されており、14 台の NAS サーバにアドレスが分散されている場合、IP アドレスはおよそ 14000 あります。

静的なプールとのダイヤル式設計

ルーティングの観点からすれば、スタティック プールを管理する方が簡単です。 静的なプールが NAS で定義されるとき、プールはコアにルーティングの目的で伝搬する必要があります。

NAS からのダイヤル式ルーティングを伝搬するのにこれらのメソッドを使用して下さい:

  • NAS で再配布されてプール アドレスが 0 を、無効にするために指すプール IPアドレス範囲にスタティック ルートを作成して下さい。

  • OSPF領域のループバックを含む OSPF ポイントツーポイントネットワークタイプとの NAS のループバックのプール IP アドレスを、割り当てて下さい。

  • 集約が ABR で実行されたことができるので NAS 自律システム境界ルータ(ASBR)の方に指すプール IP アドレスのためのエリア境界ルータ(ABR)のスタティック ルートを—これです好まれる方法設定して下さい。

0 を無効にするために指すプール アドレス 範囲にスタティック ルートを作成して下さい

この方式を使用する場合、スタティック ルートは各 NAS のために作成する必要があります。 そのスタティック ルートは静的なプール アドレスが 192.168.0.0/22 なら 0 を。たとえば無効にするために、NAS のスタティック ルート 設定次のとおりです指す正確で静的なプール範囲 アドレスをカバーする必要があります:

NAS1(config)# ip route 192.168.0.0 255.255.252.0 null0
NAS1(config)# router ospf 1
NAS1(config-router)# redistribute static subnets
NAS1(config-router)# end

このプール アドレスが OSPF に再配布され、OSPF は、タイプ 5 の外部 Link-State Advertisement(LSA; リンクステート アドバタイズメント)の形式で、この情報をコアに伝搬します。

OSPF ポイントツーポイントネットワークタイプとの NAS のループバックのプール アドレスを割り当てて下さい

この方法を使用する場合には、スタティック ルートは必要ありません。 プール アドレスは、ループバック インターフェイス上のサブネットとして割り当てられます。 ループバックインターフェイスのデフォルト ネットワークタイプは RFC 2328 に従って、/32 として OSPFleavingcisco.com でアドバタイズする必要があるループバックです、—こういうわけでポイントツーポイントにループバックのネットワークタイプを変更して下さい。 ポイントツーポイントネットワークタイプはこの場合 192.168.0.0/22 であるループバックのサブネット アドレスをアドバタイズするために OSPF を強制します。 次に設定を示します。

NAS1(config)# interface loopback 1
NAS1(config-if)# ip addreess 192.168.0.1 255.255.252.0
NAS1(config-if)# ip ospf network-type point-to-point
NAS1(config-if)# router ospf 1
NAS1(config-router)# network 192.168.0.0 0.0.3.255 area 1
NAS1(config-router)# end

この設定はルータISA のルータ スタブ リンクを作成し、内部OSPFルートとして外部 OSPFルートよりもむしろ伝搬します。

設定して下さい NAS (ASBR)を指すプール アドレスのための ABR のスタティック ルートを

この方法を使用する場合は、NAS には何も設定する必要がありません。 設定はすべて ABR つまり集約デバイスで行われます。 アドレス プールは静的です。 従って、スタティック ルートは容易に生成され、ルータはそれぞれ NAS の方に自律システム境界ルータ(ASBR)ネクスト ホップを指すことができます。 これらのスタティック ルートは、OSPF 配下で再配布されるスタティック サブネットを使用して OSPF に再配布する必要があります。 次に、例を示します。

ABR(config)# ip route 192.168.0.0 255.255.252.0 <next-hop ip address (NAS1)>
ABR(config)# ip route 192.168.4.0 255.255.252.0 <next-hop ip address (NAS2)>

! --- and so on for the remaining 12 NAS boxes.

ABR(config)# router ospf 1
ABR(config-router)# redistribute static subnets
ABR(config-router)# end

集約を ABR で実行できるので、この方法を使用することをお勧めします。 集約はまた最初の 2 つのメソッドに発生する場合がありますが集約 コンフィギュレーションは集約 設定がこのルータでだけ必要のこの方式と比べて各 NAS で必要です。

静的なプールが隣接するブロックにある場合、集約は ABR ですべてのスタティック・ルートが ABR にあるので実行されたことができます。 次に、例を示します。

ABR(config)# router ospf 1
ABR(config-router)# summary-address 192.168.0.0 255.255.192.0
ABR(config-router)# end

中央アドレス プールからの動的IP 割り当てを用いるダイヤル式設計

この方法でダイヤルアップを設計する場合は、IP アドレスの中央プールが Remote Authentication Dial-In User Service(RADIUS)サーバに設定されていることが前提となります。 POP ごとに Dialed Number Information Service(DNIS; 着信番号情報サービス)の番号が設定されており、RADIUS サーバには DNIS ごとに別々の IP アドレス プールが設定されています。 さらに、DNIS のための呼び出しを終了するすべての NAS は同じエリアにあり、同じ集約ルータに話します。

IP アドレスの中央プールを使用すると、ルーティング プロトコルの設計が少し複雑になります。 POP のための DNIS番号にダイヤルするとき、接続するおよびその DNIS に中央 IP アドレス プールからあなたに割り当てられる IP アドレスありません NAS についての保証が。 その結果、各 NAS の集約は DNIS プールから割り当てられるアドレスのために不可能です。 再配布された接続されたサブネットは各 NAS で必要です従って ABR か集約デバイスにすべての情報を伝搬できます。 そこに 1 つの問題はこの設計にあります—外部LSAs が ASBR でおよびこの設計でしか要約することができないので ASBR、NAS サーバはどのように ABR 行います NAS から来る外部ルートのための集約をありますか。

この設計の問題を解決するために、Cisco は NAS サーバが属するエリアが Not So Stubby Area (NSSA)で設定されることを推奨します(図を 2)参照して下さい:

図 2 – Not So Stubby Area の設定

/image/gif/paws/44944/ispdial2.jpg

OSPF の NSSA の詳細については、『OSPF Not-So-Stubby Area(NSSA)』を参照してください。

NSSA とエリアを定義する場合利点はここにあります:

  • ABR では LSA タイプ 7 から LSA タイプ 5 への再生成または変換を行えるので、すべての NAS ルートを ABR で集約できる。

  • NSSA では外部 LSA が使用できないので、各 POP では別の POP に属するルートは転送されない。

再配布されるの設定は、接続されたサブネットすべての NAS を渡る IP アドレス プールが static — NAS ことができるその中央 IPアドレス範囲内の IP アドレスを運ぶではないのですべての NAS で必要です。

NAS1(config)# router ospf 1
NAS1(config-router)# redistribute connected subnets
NAS1(config-router)# end

すべての NAS のこの設定を行う場合、集約 設定は ABR ですべての LSA 型 7s が ABR で再生し、LSA 型 5s に変換されるので行われます。 ABR が全く新しい LSA 型 5 を生成し、アドバタイズ ルータ ID が ABR ルータの ID であるので、ABR は ASBR として機能し、以前に LSA 型 7s だったルーティングの集約を可能にします(NAS によって開始される)。

ABR(config)# router ospf 1
ABR(config-router)# summary-address 192.168.0.0 255.255.192.0
ABR(config-router)# end

ABR と NAS の間のエリアが NSSA であることに注意してください。このエリアは、次のように設定できます。

ABR(config)# router ospf 1
ABR(config-router)# network 10.10.10.0 0.0.0.255 area 1 nssa
ABR(config-router)# end

エリアのスケーラビリティの問題

1 エリアで多くの NAS サーバが、各 NAS がエリアへの 1000 ありまたはより多くのルーティングを再配布すれば場合、質問は起こります—何 NAS サーバから成り立つ各 エリアは必要がありますか。 すべての NAS サーバが同じエリアにある場合、エリアはのですべての NAS サーバからの 1000 不安定になることができますまたはより多くのルーティングを運ぶエリア必要。 14 の NAS サーバのこの例では、膨大な数であるそれは可能性としては 14000 のルーティングを再配布できます。 より多くのスケーラビリティをエリアに持って来るために、Cisco は複数のサブエリアにエリアを分ける 1 エリアである程度不安定になる場合各 エリアが他のエリアに影響を与えないようにするためにことを、推奨します(図を 3)参照して下さい:

図 3 –エリアを分けて下さい

ispdial3.jpg

NAS サーバの数を判別するために 1 エリアで保存するために各 NAS がインジェクトするルーティングの数を確認して下さい。 1 エリアの 3 つの NAS サーバは各 NAS が 3000 インジェクトするまたはより多くのルーティングを場合十分である場合もあります。 余りにも多くのエリアがあったら、ABR が各 エリアに集約の作成が過剰にされた原因になることができるので各 エリアに不十分な NAS サーバを置かないで下さい。 ただし、すべてのエリアを、エリアに入ってくる集約ルートの再配布をいっさい許可しない全体としてスタブな NSSA にすれば、この問題を解決できます。 この操作は各 NAS が自身の 1000 運ぶまたはより多くのルーティングに加えて情報 量を減らし、ABR が各 エリアに要約LSA の再配布によって運ぶロードの量を減らします。 ここに示されているように設定を、行うために ABR に no-summary キーワードを追加して下さい:

ABR#(config)# router ospf 1
ABR#(config-router)# network 10.10.10.0 0.0.0.255 area 1 nssa no-summary
ABR#(config-router)# end

ABR と NAS サーバの間のリンクは、各エリアの外に知らせる必要はないので、これらの接続済みのルートに対しては、各エリア内の集約を ABR で作成する必要はありません。 NSSA の主な利点は、NSSA は外部 LSA を転送しないので、1 つのエリア内の 3000 以上のすべてのルートが他のエリアにリークしないことです。 ABR がすべての NSSA LSA タイプ 7 をエリア 0 に変換するときにも、NSSA の特性に従って、ABR は LSA タイプ 5 を他のエリアには送信しません。

結論

ISP のダイヤル ネットワークの設計は、困難な課題となる場合がありますが、いくつかの点を考慮すれば、改良を加えてよりスケーラブルなソリューションを実現できます。 NSSA を使用すれば、NAS ごとに転送が必要なルートの数を、NSSA を使用しない場合と比べて大幅に減らすことができるので、スケーラビリティを管理する上で効果的です。 また、NAS サーバでは、redistribute connected 設定コマンドを実行する必要があるので、特に IP アドレスの中央プールを使用する場合には、集約を利用してルーティング テーブルのサイズを小さくするのも効果的です。 各 NAS で連続した IP アドレス ブロックを割り当てれば、各 POP を 1 つの大きなブロックに集約し、過剰な数のルートをコアが転送する必要がないようにして、集約作業を効率化することもできます。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 44944