IP : IP マルチキャスト

GRE トンネルを介したマルチキャスト

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 8 月 21 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、総称ルーティング カプセル化(GRE)トンネル上のマルチキャストの設定例を紹介します。

多くのネットワークシナリオで Protocol Independent Multicast (PIM)およびルータ間のマルチキャストトラフィックを送信 するのに GREトンネルを使用するようにネットワークを設定したいと思います。 通常、これは IPマルチキャストルーティングのために設定されないマルチキャストソースおよびレシーバが IP クラウドで分かれるとき発生します。 そのようなネットワークシナリオでは、有効に なる PIM で IP クラウドを渡るトンネルを設定することはレシーバの方にマルチキャスト パケットを転送します。 この資料は GREトンネル上のマルチキャストに関して設定、確認および関連 問題を記述したものです。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワークダイアグラムが示すように、マルチキャストソース(10.1.1.1) R102 に接続され、マルチキャスト グループ 239.1.1.20 のために設定されます。 マルチキャストレシーバー(10.2.2.3) R104 に接続され、グループ 239.1.1.20 のためのマルチキャスト パケットを受信するために設定されます。 マルチキャストルーティングのために設定されない R102 および R104 を分けることは IP クラウドです。

トンネルはループバックインターフェイスでソースをたどられる R102 への R104 の間で設定されます。 IP PIM 希薄-稠密 モード コマンドはトンネルインターフェイスで設定され、マルチキャストルーティングは R102 および R104 で有効に なります。 グループのための Rendezvous Point (RP) 設定によってトンネルに転送されるべきトンネルインターフェイス割り当て sparse(疎)モードまたは稠密モード パケットの希薄-稠密 モードコンフィギュレーション。

注:  稠密モードに関しては—トンネルに設定されてマルチキャストソースアドレス 10.1.1.1 のための正常な RPF を確認するために PIM稠密モードが IP mroute 10.1.1.0 255.255.255.0 トンネル 0 コマンドは R104 で設定されます。 着信(10.1.1.1 は予約パス転送(RPF が)あるようにこの mroute 文を使用して、239.1.1.20) Tunnel0 (Tu0)上のマルチキャスト パケット確認されます。 正常なチェックが発信インターフェイスリスト(オイル)インターフェイスに、マルチキャスト パケット転送された後。

注:  希薄モードに関しては—トンネルに設定されて PIM 希薄モードがこれらのポイントが当たるようにして下さい:

  • 共有ツリーにマルチキャストトラフィック フローの正常な RPF 確認に関しては(*、G) RP から、IP mroute rp-address nexthop コマンドはトンネルインターフェイスをその指します RP アドレスのために設定される必要があります。

    R102 が RP (RP アドレス 2.2.2.2)この場合、そしてであるという想定のもとでそのトラフィックのための正常な RPF チェックに共有ツリー上のフローを確認する mroute IP mroute 2.2.2.2 255.255.255.255 トンネル 0 コマンドはあります。

  • マルチキャストの正常な RPF 確認に関しては(S は、G)最短パスツリー (SPT)上のトラフィック フロー、ip mroute source-address nexthop コマンド マルチキャストソースのために設定される必要がありまトンネルインターフェイスを指します。

    この場合 SPT トラフィックがトンネルインターフェイスにフローしているとき、IP mroute 10.1.1.0 255.255.255.0 トンネル 0 コマンドは R104 で着信の正常な RPF 確認を確認するために設定されます(10.1.1.1 は、239.1.1.20) Tu0 上のマルチキャスト パケット インターフェイスします。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/43584/mcast-gre2.gif

設定

このドキュメントでは、次の設定を使用します。

この実行コンフィギュレーション ファイルに従ってルータ 102 を設定して下さい:

R102
version 12.2
!hostname r102
!
!ip subnet-zero
no ip domain-lookup

!--- It stops IP domain lookup, which improves 
!--- the show command response time.

!
ip multicast-routing

!--- Enables IP multicast routing.

!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 
!--- Tunnel Source interface.

!
interface Tunnel0

!--- Tunnel interface configured for PIM and carrying 
!--- multicast packets to R104.

 ip address 192.168.24.1 255.255.255.252
 ip pim sparse-dense-mode
 tunnel source Loopback0
 tunnel destination 4.4.4.4
!
interface Ethernet0/0

!--- Interface connected to Source.

 ip address 10.1.1.2 255.255.255.0
 ip pim sparse-dense-mode
!
!
interface Serial8/0
 ip address 192.168.23.1 255.255.255.252

!--- Note IP PIM sparse-dense mode is 
!--- not configured on Serial interface.

!router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 10.1.1.0 0.0.0.255 area 0
 network 192.168.23.0 0.0.0.255 area 0
!
ip classless
ip pim bidir-enable
!
line con 0
line aux 0
line vty 0 4
 login
!
end

この実行コンフィギュレーション ファイルに従ってルータ 104 を設定して下さい:

R104
r104#
version 12.2
!
hostname r104
!
!
ip subnet-zero
no ip domain-lookup

!--- It stops IP domain lookup, which improves 
!--- the show command response time.

!
ip multicast-routing

!--- Enables IP multicast routing.

!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255

!--- Tunnel Source interface.

!
interface Tunnel0
 ip address 192.168.24.2 255.255.255.252

!--- Tunnel interface configured for PIM 
!--- and carrying multicast packets.

 ip pim sparse-dense-mode
 tunnel source Loopback0
 tunnel destination 2.2.2.2
!
interface Ethernet0/0
 ip address 10.2.2.2 255.255.255.0
 ip pim sparse-dense-mode
!
interface Serial9/0
 ip address 192.168.34.1 255.255.255.252

!--- Note IP PIM sparse-dense mode is not 
!--- configured on Serial interface.

!
!
router ospf 1
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 10.2.2.0 0.0.0.255 area 0
 network 192.168.34.0 0.0.0.255 area 0
!
ip classless
no ip http server
ip pim bidir-enable
ip mroute 10.1.1.0 255.255.255.0 Tunnel0


!--- This mroute ensures a successful RPF check 
!--- for packets flowing from the source.
!--- 10.1.1.1 over Shared tree in case of Dense 
!--- more and SPT in case of Sparse mode.

!
ip mroute 2.2.2.2 255.255.255.255 tunnel 0


!--- This mroute is required for RPF check when 
!--- Sparse mode multicast traffic is 
!--- flowing from RP (assuming R102 with 2.2.2.2 as RP)
!--- towards receiver via tunnel  
!--- before the SPT switchover.

line con 0
line aux 0
line vty 0 4
 login
!
end

確認

ここでは、設定が正常に動作していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

  • レシーバが R104 にグループ 239.1.1.20 のための IGMP 加入 メンバシップ 要求を送信 したことを show ip igmp group —確認します。

    r104#show ip igmp groups 
    IGMP Connected Group Membership
    Group Address    Interface          Uptime    Expires   Last Reporter
    239.1.1.20       Ethernet0/0        00:00:04  00:02:55  10.2.2.3
  • ソース 10.1.1.1 がグループ 239.1.1.20 のためのパケットをマルチキャストし始めるとき R102 は(*,239.1.1.20)およびインストールすることを show ip mroute group-address —確認します(10.1.1.1、239.1.1.20) R102 mrouteテーブルのエントリ。

    注: (10.1.1.1 は、239.1.1.20) エントリ、オイル Tunnel0 です。

    r102#show ip mroute 239.1.1.20
    IP Multicast Routing Table
    Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
           L - Local, P - Pruned, R - RP-bit set, F - Register flag,
           T - SPT-bit set, J - Join SPT, M - MSDP created entry,
           X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
           U - URD, I - Received Source Specific Host Report
    Outgoing interface flags: H - Hardware switched
    Timers: Uptime/Expires
    Interface state: Interface, Next-Hop or VCD, State/Mode
    
    (*, 239.1.1.20), 00:00:09/00:02:59, RP 0.0.0.0, flags: D
      Incoming interface: Null, RPF nbr 0.0.0.0
      Outgoing interface list:
        Tunnel0, Forward/Sparse-Dense, 00:00:09/00:00:00
        Ethernet0/0, Forward/Sparse-Dense, 00:00:09/00:00:00
    
    (10.1.1.1, 239.1.1.20), 00:00:09/00:02:58, flags: T
      Incoming interface: Ethernet0/0, RPF nbr 0.0.0.0
      Outgoing interface list:
        Tunnel0, Forward/Sparse-Dense, 00:00:09/00:00:00
  • 10.1.1.1 からソースをたどられるグループ 239.1.1.20 のためのマルチキャスト パケットを転送している間 R104 にあることを show ip mroute group-address — (*,239.1.1.20)および確認します(10.1.1.1、239.1.1.20) エントリ。

    注: (10.1.1.1 は、239.1.1.20)、着信インターフェイス Tunnel0 であり、RPF ネイバーは 192.168.24.1 — R102 のトンネル ヘッドエンドです。 RPF 確認は R104 で設定される mroute に基づいて行われマルチキャスト パケットはイーサネットで接続されるレシーバへのオイルに 0/0 のインターフェイス押し出されます。

    r104#show ip mroute 239.1.1.20
    IP Multicast Routing Table
    Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
           L - Local, P - Pruned, R - RP-bit set, F - Register flag,
           T - SPT-bit set, J - Join SPT, M - MSDP created entry,
           X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
           U - URD, I - Received Source Specific Host Report
    Outgoing interface flags: H - Hardware switched
    Timers: Uptime/Expires
    Interface state: Interface, Next-Hop or VCD, State/Mode
    
    (*, 239.1.1.20), 00:07:10/00:00:00, RP 0.0.0.0, flags: DCL
      Incoming interface: Null, RPF nbr 0.0.0.0
      Outgoing interface list:
        Tunnel0, Forward/Sparse-Dense, 00:07:10/00:00:00
        Ethernet0/0, Forward/Sparse-Dense, 00:07:10/00:00:00
    
    (10.1.1.1, 239.1.1.20), 00:01:13/00:02:24, flags: CLT
      Incoming interface: Tunnel0, RPF nbr 192.168.24.1, Mroute
      Outgoing interface list:
        Ethernet0/0, Forward/Sparse-Dense, 00:01:13/00:00:00
  • show ip rpf ip-address — 10.1.1.1 から送信されるパケットの RPF 確認を行って下さい。 次の例は 10.1.1.1 のための RPF がマルチキャスト(S を、G)パケット受け取っているトンネル 0 によってあることを確認します。

    r104>show ip rpf 10.1.1.1
    RPF information for ? (10.1.1.1)
      RPF interface: Tunnel0
      RPF neighbor: ? (192.168.24.1)
      RPF route/mask: 10.1.1.1/24
      RPF type: static
      RPF recursion count: 0
      Doing distance-preferred lookups across tables

トラブルシューティング

ここでは、設定に関するトラブルシューティングについて説明します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

注: debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

GREトンネル上のマルチキャストがはたらかない場合、これらの 1 つは原因である場合もあります:

  • UP/UP トンネル—トンネル ソース と 宛先はトンネルの各終わりで一致する。 R104 の設定が間、たとえば、R102 のトンネル宛先が 2.2.2.2 の代りに IP アドレス 10.2.2.2 に変更されたら、トンネルは起動しません。

    トンネルのステータスを確認するために show interface tunnel 0 コマンドを発行して下さい。

  • マルチキャスト パケットは RPF障害が理由で廃棄されます。

    show ip mroute count コマンドを発行して下さい。 RPF障害のためのこのコマンドおよび増加するカウンターの出力例はこの出力で示されています:

    r104#show ip mroute count
    IP Multicast Statistics
    3 routes using 1642 bytes of memory
    2 groups, 0.50 average sources per group
    Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
    Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)
    
    Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0
    
    Group: 239.1.1.20, Source count: 1, Packets forwarded: 11, Packets received: 45
      Source: 10.1.1.1/32, Forwarding: 11/0/100/0, Other: 25/14/0
    
    
    !--- After some time, the show ip mroute count command 
    !--- is issued again. You can see the RPF failed counter increasing:
    
    r104#show ip mroute count
    IP Multicast Statistics
    3 routes using 1642 bytes of memory
    2 groups, 0.50 average sources per group
    Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
    Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)
    
    Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0
    
    Group: 239.1.1.20, Source count: 1, Packets forwarded: 11, Packets received: 50
      Source: 10.1.1.1/32, Forwarding: 11/0/100/0, Other: 30/19/0
    r104#

    また show ip rpf source コマンドを発行できます。 RPF インターフェイスがソース マルチキャスト パケットが received —この例のトンネル 0 であるインターフェイスと同じであることを確認して下さい。 RPF 失敗に関する詳細については IP マルチキャスト の トラブルシューティングガイドを参照して下さい。

  • PM ネイバー R104 が表示されていないので PIM neighbors — ルータ R102 は Tunnel0 インターフェイスに転送していません。

    次のコマンドを発行します。

    • トンネル上のネイバー R104 を示す show ip pim neighbor — R102 の show ip pim neighbor コマンドを使用できます。

    • show ip pim int —またネイバーがあることを示す show ip pim int コマンドを使用できます。

    • interface level ip pim sparse-dense-mode コマンドがトンネルの両端で設定されること、そして Ip multicast-routing が有効に なることを ip pim sparse-dense-mode —確認して下さい。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 43584