音声とユニファイド コミュニケーション : Cisco Unified Communications Manager(CallManager)

Cisco IOS MGCP ゲートウェイの設定

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2012 年 9 月 26 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントで提供する情報は次のとおりです。

  • 単純な Media Gateway Control Protocol(MGCP)設定の手順の説明

  • 2 組の Foreign Exchange Office(FXO)および 2 個の Foreign Exchange Station(FXS)ポートを使用するルータ用の設定を作成するために必要な最低限のコマンドに限った提示

Cisco IOS を実行するこの資料の指示は Cisco 音声 ゲートウェイ 200 (VG200)および Cisco 2600 および 3600 シリーズ ルータのためにはたらきますか。 ソフトウェアリリース 12.1(5)T およびそれ以降。 他の Cisco IOS MGCP ゲートウェイの場合にサポートされているソフトウェア リリースについては、Cisco IOS ソフトウェアのドキュメントを参照してください。

症状:

アナログの FXO ポートと FXS ポートがある Cisco IOS MGCP ゲートウェイで、Cisco CallManager を設定する際に発生する可能性のある症状には、次のものがあります。

  • MGCP ゲートウェイが Cisco CallManager に登録されない。 『Cisco Unified CallManager の MGCP ゲートウェイ の 登録失敗』を参照してください。

  • FXO ポートで発信者 ID が機能しない。 これは、MGCP 用に設定されている場合、FXO ポートでは発信者 ID をサポートしていないことが原因です。 代わりに、H.323 モードでゲートウェイを設定します。

  • ユーザが完全にオフフックにならないと、フックフラッシュ時にオーバーヘッド ページングが FXO ポートをロックアップする。 shut に続けて no shut を発行した場合、ポートはリセットされません。 これは Cisco Bug ID CSCef62275登録ユーザ専用)に関連する問題であり、Cisco IOS ソフトウェア リリース 12.3(14)T 以降では解決されています。

このドキュメントは、6 部で構成されるドキュメント セットの第 2 部です。

前提条件

要件

次の項目に関する知識があることが推奨されます。

  • Cisco CallManager を使用した MGCP をサポートしている Cisco IOS ソフトウェア リリースを実行する Cisco IOS ゲートウェイ

  • Cisco VG200

Cisco ルータ上の MGCP をサポートしている Cisco IOS ソフトウェア リリースのシリーズは他にもあります。 Cisco IOS ソフトウェア リリース 12.1XM は、一例です。

注意 注意: いくつかの Mgcp コマンドのための構文は他の Cisco IOS ソフトウェア リリースで異なっています。 必要な構文を確認するには、コンフィギュレーションに対応するドキュメントを参照してください。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco VG200 / 2 X FXS / 2 X FXO / 1 ファスト イーサネット 10/100 ポート X 1 Cisco IOS ソフトウェア リリース 12.1(5)T

  • MCS7835 上で稼働する Cisco CallManager 3.0(5a) X 1

  • アナログ電話機 X 2

  • Cisco 7960 IP Phone X 2

Cisco CallManager と Cisco IOS ゲートウェイの間の推奨される互換ソフトウェア リリースについては、『Cisco Unified CME と Cisco IOS ソフトウェア バージョンの互換性マトリックス』を参照してください。

: ccm-manager コマンドの拡張に基づき、Cisco IOS ソフトウェア リリース 12.2(11)T 以降が推奨されます。 ccm-manager コマンドには、すべてのルータ(2600、3600)と VG200 に Cisco IOS ソフトウェア リリース 12.1(5)XM 以降が必要です。

Cisco 2600 と 3600 ルータで Cisco IOS ソフトウェア リリース 12.1(3)T 以降を実行する場合、MGCP がサポートされています。 必要なソフトウェア リリースは、イネーブルにする必要のある機能によって異なります。 Cisco CallManager サーバで、ソフトウェア リリース 3.0(5)a 以降を実行している必要があります。 ルータの設定は、すべてのタイプのルータで同一です。 Cisco CallManager の設定も、すべてのタイプのルータで同一です。

Cisco IOS ソフトウェア リリース 12.1(5)XM1 以降では VG200 をサポートします。 必要なソフトウェア リリースは、イネーブルにする必要のある機能によって異なります。 VG200 は、これよりも前の Cisco CallManager ソフトウェア リリースでもサポートされていますが、ソフトウェア リリース 3.0(5)a 以降を使用してください。

Cisco ルータ上の MGCP をサポートしている Cisco IOS ソフトウェア リリースのシリーズは他にもあります。 Cisco IOS ソフトウェア リリース 12.1XM は、一例です。

注意 注意: いくつかの Mgcp コマンドのための構文は他の Cisco IOS ソフトウェア リリースで異なっています。 必要な構文を判別するには、コンフィギュレーションに対応するドキュメントを参照してください。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

実行する作業

次の手順を実行します。

  1. Cisco IOS ゲートウェイ イーサネット インターフェイスの IP アドレスを設定します。

  2. Cisco IOS ゲートウェイに一意の名前を割り当てます。

  3. シグナリング プロトコルとして MGCP を実行するように、Cisco IOS ゲートウェイを設定します。

  4. Cisco CallManager サーバの IP アドレスまたはドメイン ネーム システム(DNS)名を設定します。

  5. コーデック タイプおよびデュアル トーン多重周波数(DTMF)リレー機能を選択します。

  6. Cisco CallManager サーバと通信することを Cisco IOS ゲートウェイに指示します。

  7. MGCP アプリケーションを音声ポートにバインドします。

  8. 音声ポートをイネーブルにします。

  9. IP 接続をイネーブルにします。

詳細手順

このドキュメントの以降の部分では、VG200 を使用しています。 この VG200 は、出荷時のデフォルト設定で起動されています。

次の手順を実行します。

  1. VG200 イーサネット インターフェイスに IP アドレスを設定し、インターフェイスを有効に設定します。

    router(config)#interface fastethernet 0/0
    router(config-if)#ip address 172.16.1.206 255.255.255.0
    router(config-if)#no shut
    
  2. VG200 に一意の名前を割り当てます。 これにより、Cisco CallManager サーバによって識別できるようになります。

    router(config)#hostname VG200A 
    
    /* This is how CallManager keeps track of the MGCP network */
    /* devices it is communicating with. This name must be     */
    /* unique.                                                 */
  3. シグナリング プロトコルとして MGCP を実行するように、VG200 を設定します。

    VG200A(config)#mgcp
    
  4. Cisco CallManager サーバの IP アドレスまたは DNS 名を設定します。

    VG200A(config)#mgcp call-agent 172.16.1.252
    
    VG200A(config)#ccm-manager config server 172.16.1.252
    
    VG200A(config)#ccm-manager config
    

    メディア ゲートウェイ上の MGCP エンドポイントに対するコール エージェントのアドレスおよびプロトコルを設定するには、mgcp call-agent コマンドを使用します。 このコマンドでは、使用するプロトコルのバージョンを指定できます。 詳細については、『mgcp call-agent』を参照してください。

    ccm-manager config server コマンドは、Media Gateway Control Protocol(MGCP)ゲートウェイが Cisco CallManager XML コンフィギュレーション ファイルのダウンロード元として使用する、TFTP サーバの指定に使用します。

    ccm-manager config コマンドは、Cisco CallManager XML コンフィギュレーション ファイルのダウンロードを有効に設定するために必要です。

    次のコマンドを発行して、Cisco CallManager クラスタ内に冗長 Cisco CallManager を設定します。

    VG200(config)#ccm-manager redundant-host [ip-address |
      dns-name] [ip-address | dns-name] 
    VG200(config)#ccm-manager switchback {graceful | immediate
      |schedule-time hh:mm | uptime-delay minutes} 
  5. コーデック タイプ DTMF リレー機能を選択します。

    VG200A(config)#mgcp dtmf-relay codec all mode out-of-band
    
  6. 次のコマンドを発行して、MGCP での Cisco CallManager のサポートを有効にします。

    VG200A(config)#ccm-manager mgcp
    
  7. MGCP アプリケーションを音声ポートにバインドします。

    VG200 にあるポートのタイプおよびポートの取り付け順序を判別するには、show voice port コマンドを発行します。

    VG200A(config)#dial-peer voice 1 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/0/0
    
    /* FXO port */
    
    VG200A(config)#dial-peer voice 2 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/0/1
    
    /* FXO port */
    
    VG200A(config)#dial-peer voice 3 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/1/0
    
    /* FXS port */
    
    VG200A(config)#dial-peer voice 4 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/1/1
    
    /* FXS port */

    一部の Cisco IOS ソフトウェア リリースでは、application MGCPAPP コマンドの大文字と小文字が区別されます。 大文字と小文字が区別されるソフトウェア リリースかどうか不明な場合は、常に大文字を使用してこのコマンドを発行してください。 大文字と小文字が区別されるソフトウェア リリースかどうかを確認するには、show running-config コマンドの出力を調べます。 Cisco IOS ソフトウェア リリース 12.1(5)T では、大文字と小文字が区別されません。

  8. 音声ポートが有効に設定されていることを確認します。

    : shutdown コマンドおよび no shutdown コマンドは、音声インターフェイス カード(VIC)の両方のポートに影響します。 このコマンドは、これらのポートの 1 つだけで発行してください。

    VG200A(config)#voice-port 1/0/0
    VG200A(config-voiceport)#no shutdown
    Both ports are in service
    
    /* FXO port */
    
    VG200A(config)#voice-port 1/1/0
    VG200A(config-voiceport)#no shutdown
    Both ports are in service
    
    /* FXS port */s
  9. IP 接続をイネーブルにします。

    VG200 で通信しているいずれかの VoIP デバイスが、別のサブネットワークまたは VLAN 上にある場合は、IP ルーティングを有効に設定します。 デフォルト ネットワーク、つまりラスト リゾート ゲートウェイを作成する必要もあります。 この手順では、両方のタスクを実行する方法を示します。

    VG200A(config)#ip routing
    VG200A(config)#ip route 0.0.0.0 0.0.0.0 ip_address_of_gateway
    
    

    VG200 は IP ルータではありません。 ルーティング情報プロトコル(RIP)、Interior Gateway Routing Protocol(IGRP)、または Open Shortest Path First(OSPF)プロトコルなどの IP ルーティング プロトコルは実行できません。 IP 接続に関しては、エンド ステーション(クライアント)に似た動作をします。

    他の Cisco IOS ゲートウェイ(原則的には、音声インターフェイスを持つルータ)上に、スタティック ルートの代わりにルーティング プロトコルを設定できます。 VoIP デバイス間の IP 接続を確保することが重要です。

    IP ルーティングを有効に設定した場合、ip routing コマンドは通常デフォルトでオンであるため、設定に含まれません。 デフォルトのコマンドは、Cisco ルータ コンフィギュレーションに含まれていません。 VG200 Cisco IOS イメージでは、no ip routing コマンドを初期設定にハードコードすることで、このデフォルト動作がオーバーライドされています。 この設定は、イメージのブート時に次の場所に作成されます。

    • write erase コマンドによって設定がクリアされたプラットフォーム上

    • 設定されていない VG200 上

    ip route 0.0.0.0 0.0.0.0 ip_address_of_gateway コマンドを発行すると、VG200 はルーティング テーブル上にラスト リゾート ゲートウェイをインストールすることになります。 show ip route コマンドによってこれを確認します。 次の例の場合、ゲートウェイ IP アドレスは、172.16.1.1 です。

    VG200A#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is 172.16.1.1 to network 0.0.0.0
    
    C    172.16.0.0/16 is directly connected, FastEthernet0/0
    S*   0.0.0.0/0 [1/0] via 172.16.1.1
    VG200A#

    このラスト リゾート ゲートウェイに実効性を持たせるには、ip classless コマンドも必要です。 ip classless コマンドは、デフォルトで有効になっています。 このコマンドは、有効に設定したときにコンフィギュレーションに含まれ、無効に設定したときにも no 形式で含まれる、Cisco IOS ソフトウェアの数少ないデフォルト コマンドの 1 つです。 コンフィギュレーションに no ip classless の行が含まれている場合、ip classless を有効に設定するには、ip classless コマンドを発行します。

注意 注意: Cisco Unified CallManager はすべてのダイヤル計画関連の設定要素を制御します。 MGCP によって管理されるエンドポイント(ダイヤルピア ステートメントに application mgcpapp コマンドを含むエンドポイント)については、MGCP ゲートウェイに次の要素を設定しないでください。 次の機能は、いずれも設定しないでください。

  • ダイヤルピア

    • destination-pattern

    • session target

  • 音声ポート

    • connection { plar | tie-line | trunk }

要約

これで、Cisco CallManager サーバと通信するように VG200 を準備できました。 VG200 では、接続の確立を試行して、定期的にメッセージを送信します。 この接続は、Cisco CallManager サーバの設定が完了すると、自動的に確立されます。 VG200 に変更をさらに加える必要はありません。

設定の完了後に、次の例に示すように、ゲートウェイ ポートをリセットします。

router(config)#voice-port 1/0/0
router(config-voiceport)#shutdown
Both ports are out of service
router(config-voiceport)#no shutdown

設定

次の表に、このドキュメントで説明している VG200A の完結した設定を示します。

VG200A 設定
VG200A#show running-config           
Building configuration...

Current configuration : 1244 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname VG200A
!
boot system flash
boot system rom
boot system tftp vg200 172.16.1.253
no logging buffered
logging rate-limit console 10 except errors
no logging console
enable secret #####
enable password #####
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
mgcp
mgcp call-agent 172.16.1.252
mgcp dtmf-relay codec all mode out-of-band
mgcp sdp simple
call rsvp-sync
!
!
!
!
!
ccm-manager mgcp
!
!
interface FastEthernet0/0
 ip address 172.16.1.206 255.255.0.0
 no ip mroute-cache
 speed auto
 full-duplex
!
ip default-gateway 172.16.1.1
ip classless
no ip http server
!
snmp-server engineID local 000000090200000196983000
snmp-server community public RO
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer voice 1 pots
 application mgcpapp
 port 1/0/0
!
dial-peer voice 2 pots
 application mgcpapp
 port 1/0/1
!
dial-peer voice 3 pots
 application mgcpapp
 port 1/1/0
!
dial-peer voice 4 pots
 application mgcpapp
 port 1/1/1
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password ww
 login
!
end

VG200A#

VG200A バージョン情報
VG200A>show version
Cisco Internetwork Operating System Software
IOS (tm) VG200 Software (VG200-I6S-M), Version 12.1(5)T,  
RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2000 by Cisco Systems, Inc.
Compiled Sat 11-Nov-00 10:33 by ccai
Image text-base: 0x80008088, data-base: 0x807D4784

ROM: System Bootstrap, Version 12.1(1r) [phanguye 1r], RELEASE 
SOFTWARE (fc1)

VG200A uptime is 19 hours, 37 minutes
System returned to ROM by reload
System image file is "flash:vg200"

cisco VG200 (MPC860) processor (revision 0x102) with 28672K/
4096K bytes of memory
y.
Processor board ID JAB0414058X (0)
M860 processor: part number 0, mask 49
1 FastEthernet/IEEE 802.3 interface(s)
2 Voice FXO interface(s)
2 Voice FXS interface(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

VG200A>

IOS MGCP ゲートウェイのトラブルシューティング

IOS MGCP ゲートウェイで、発信コールと着信コールのいずれかの単方向コールの失敗が個別に発生することがあります。 この問題を解決するには、MGCP ゲートウェイを設定します。 通常、これには、PRI インターフェイスと FXO インターフェイスの一方または両方の再設定が含まれます。 次に、グローバル コンフィギュレーション モードで no mgcp IOS コマンドおよび mgcp コマンドを発行して、ゲートウェイ上の mgcp プロトコルを再開します。

MGCP IOS ゲートウェイに接続されているアナログ電話からはコールを発信できません。 ビジー音が聞こえます。

この問題を解決するには、次の手順を実行します。

  1. 該当するポートに application mgcpapp コマンドが設定されていることを確認します。

  2. Cisco CallManager によって生成されたダイヤルピアがダイヤルピア リストの先頭にリストされるように、一般電話サービス(POTS)ダイヤルピアの順序を変更します。 MGCP によって制御されている正しいダイヤルピアによって、内向きおよび外向きのコール制御が処理されることを確認します。


関連情報


Document ID: 42105