IP : シリアル トンネル(STUN)

BSTUN でのトンネリング非同期プロトコルの設定例

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

Cisco の実装では、専用のネイティブ非同期のプロトコルは直接サポートされません。 ただし、Block Serial Tunnel (BSTUN) async-genericトンネリングはこのデータをトンネル伝送する限られた能力を提供できます。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

通貨 ATM か PC からの別の PC とトンネリング ハイパーターミナルと Cisco IOS で通信する Diebold の TC500 のような Async プロトコルに直接支援か実装がありませんか。 名前が意味するので、これはデータのこの型を運ぶ機能がある一般的 な 実装です。 これは BSTUN async-generic として知られ、IBM か企業 IOSフィーチャセットを必要とします。

BSTUN async-generic は最初に 安全 装置からレポート中のデバイスに単方向、小さいパケットを伝送するように設計されていました。 しかし BSTUN async-generic はインタラクティブトラフィックを運ぶことができます。 要するに次に、この実装はネイティブ、非同期デバイスに接続し、シリアルインターフェイスとメモリバッファにデータを受け取ります。 定期的に、バッファー内のデータは TCPパケットにそしてカプセル化され、リモートサイトで接続される非同期デバイスにカプセル化を解除され、送信 される BSTUN ピアに送られます。

BSTUN async-generic は単純化したオペレーションです。 ルータはフレーム(SOF)、フレームの終わり(EOF)、または async プロトコルのアドレッシング スキーマの開始するのナレッジを持つために設定されるべき機能がありません。 フレームのアドレス部分が各フレームに、1 バイト長で、フレームの同じところなら、この資料の exampled 以降としてフレームのアドレスを、どこで見つけるか asp address-offset コマンドはルータに規定 するために発行することができます。 しかし多くの場合プロトコルに含まれていたアドレス部分がありません。 async プロトコル 構築を知らないことは時間までに分かれない場合ルータが他からの個々のパケットを検知することができないことを意味します。 9600 ビット/秒の帯の間でおよそ 40 ms がきちんと別のものからの 1 パケットを検知する時間のルータ十分な量を提供するために必要となります。 ルータはそれへのデータ ストリームがシリアルインターフェイスで、次に TCP にこのデータをラップすることを単に見ます。 ルータによってが着信 フレームのあらゆる側面にできる作るルーティング決定を基づいていた可能性がありません。 従って、BSTUN async-generic はルータのシリアル インターフェイスへ物理的に設計されていた 1 つのそうただデバイス大使館員である必要があります。 ローカル確認応答 機能がありません。 BSTUN は IBM3270 BISYNC プロトコルだけのための local-ack をサポートします。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

ネットワーク構成図

このドキュメントでは、次の図で示されるネットワーク構成を使用しています。

/image/gif/paws/41983/bstun_41983-A.gif

PC は両方とも Microsoft のハイパーターミナルを使用しますまたは PC の 1 つの代わりに接続は Ciscoルータのコンソールポートにある可能性があります。 Lab Scenario で前もって設定されないルータから設定されるこれらの設定 例はコンフィギュレーションを表し必要とされる設定の関連した部分を示します。 9600 ビット/秒を仮定するこれらは 8N1 接続設定されます。

設定

このドキュメントでは、このセクションで示す設定を使用しています。

  • 主要なルータ(Cisco 1700 ルータ)

  • リモートルータ(Cisco 3640 ルータ)

  • 主要なルータ(Cisco 3600 ルータ)

  • リモート #1 (Cisco 1700 ルータ)

  • リモート #2 (Cisco 1700 ルータ)

主要なルータ(Cisco 1700 ルータ)
main#show running-config 
Building configuration...
.
.
.
ip subnet-zero
bstun peer-name 10.1.1.1
bstun protocol-group 1 async-generic
interface loopback0
   ip address 10.1.1.1 255.0.0.0
interface serial0
   physical-layer async
   encapsulation bstun
   asp role secondary
   bstun group 1
   bstun route all tcp 30.1.1.1
interface serial1
   ip address 20.1.1.1 255.0.0.0
ip route 0.0.0.0 0.0.0.0 20.1.1.2
line 1
   speed 9600
   databits 8
   parity none
   stopbits 1
.
.
.
!
end

リモートルータ(Cisco 3640 ルータ)
REMOTE#show running-config 
Building configuration...
bstun peer-name 30.1.1.1.
bstun protocol-group 1 async-generic
interface loopback 0
   ip address 30.1.1.1
interface ethernet1/0
   shutdown
interface serial 2/0
   physical-layer async
   encapsulation bstun
   asp role primary
   bstun group 1
   bstun route all tcp 10.1.1.1
   
interface serial 2/1
   ip address 20.1.1.2 255.0.0.0
ip route 0.0.0.0 0.0.0.0 20.1.1.1
line 65
   speed 9600
   parity none
   databits 8
   stopbits 1
.
.
!
end

注: シリアルインターフェイスの physical-layer async コマンドを発行するとき、TTY ラインはシリアルインターフェイスに割り当てられます。 この TTY 行定義はデータビット、ストップビット、パリティおよび速度が設定されるところです。 これはどのシリアルインターフェイスかとどの行が対応するか判別する数式です。

line#= (slot# X 32) + interface# + 1

リモートルータの設定出力の show line は右端 カラムで対応する ライン数を示します。 Serial2/0 はラインによって 65 表され、このリンクのための物理的 な 定義はラインの下で 65 設定されます

REMOTE#sh line 
   Tty Typ     Tx/Rx        A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int 
*    0 CTY                      -        -          -        -        -          0           0         0/0           - 
    65 TTY   9600/9600  -        -          -        -        -      0           0         0/0     Se2/0 
   129 AUX 9600/9600  -        -          -        -        -        0           0         0/0       - 
   130 VTY                     -        -          -        -        -          0           0         0/0       - 
   131 VTY                     -        -          -        -        -          0           0         0/0       - 
   132 VTY                     -        -          -        -        -          0           0         0/0       - 
   133 VTY                     -        -          -        -        -          0           0         0/0       - 
   134 VTY                     -        -          -        -        -          0           0         0/0       - 

Line(s) not in async mode -or- with no hardware support: 
1-64, 66-128 

このシナリオでは、タンデムは遠隔 ATM デバイスと通信します。 この設定 例では、async プロトコルは 4800 7E2 プロトコルを作動させ、タンデムに接続される主要なルータはリモート 1700 シリーズ ルータへ 3600 シリーズ ルータです。 このネットワークダイアグラムを参照して下さい。

bstun_41983-B.gif

主要なルータ(Cisco 3600 ルータ)
main#show running-config 
Building configuration...
bstun peer-name 10.1.1.1.
bstun protocol-group 1 async-generic
bstun protocol-group 2 async-generic
interface loopback 0
   ip address 10.1.1.1
interface serial1/0
   encapsulation frame-relay
interface serial 1/0.1 point-to-point
   ip address 20.1.1.1 255.255.255.0
   frame-relay interface-dlci 100
interface serial 1/0.2 point-to-point
   ip address 20.2.1.1 255.255.255.0
   frame-relay interface-dlci 200
interface serial 2/0
   physical-layer async
   encapsulation bstun
   asp role secondary
   bstun group 1
   bstun route all tcp 30.1.1.1
   
interface serial 2/1
 physical-layer async
   encapsulation bstun
   asp role secondary
   bstun group 2
   bstun route all tcp 30.2.1.1
   
ip route 30.2.1.0 255.255.0.0 20.2.1.2
ip route 0.0.0.0 0.0.0.0 20.1.1.2
line 65
   speed 4800
   parity even
   databits 7
   stopbits 1
.
line 66
   speed 4800
   parity even
   databits 7
   stopbits 1
.
!
end

リモート #1 (Cisco 1700 ルータ)
REMOTE1#show running-config 
Building configuration...
bstun peer-name 30.1.1.1
bstun protocol-group 1 async-generic
interface loopback0
   ip address 30.1.1.1 255.255.0.0
interface serial0
   physical-layer async
   encapsulation bstun
   asp role primary
   bstun group 1
   bstun route all tcp 10.1.1.1
interface serial1
   encapsulation frame-relay
interface serial1.1 point-to-point
   ip address 20.1.1.2 255.255.255.0
   frame-relay interface-dlci 100
ip route 0.0.0.0 0.0.0.0 20.1.1.1
line 1
   speed 4800
   databits 7
   parity even
   stopbits 2
.
.
.
!
end

リモート #2 (Cisco 1700 ルータ)
REMOTE2#show running-config
Building configuration...
bstun peer-name 30.2.1.1
bstun protocol-group 2 async-generic
interface loopback0
   ip address 30.2.1.1 255.255.0.0
interface serial0
   physical-layer async
   encapsulation bstun
   asp role primary
   bstun group 2
   bstun route all tcp 10.1.1.1
interface serial1
   encapsulation frame-relay
interface serial1.1 point-to-point
   ip address 20.2.1.2 255.255.255.0
   frame-relay interface-dlci 100
ip route 0.0.0.0 0.0.0.0 20.2.1.1
line 1
   speed 4800
   databits 7
   parity even
   stopbits 2
.
.
.
!
end

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

BSTUN はシリアルインターフェイスに bstun route all tcp コマンドが発行されるときパケットを受信し、それをカプセル化し、リモートルータにこの TCPパケットを送信 します。 TCPパケットはリモートルータで受け取られ、カプセル化を解除されます。 データはシリアルインターフェイスで送信されます。 この接続がはたらかない場合、着信 データは debug asp packet と最初に確認する必要があります。 シリアルインターフェイスのルータによって受け取ったデータを見ます。 ルータがプロトコル 構築を備えていないし、async に従ってプロトコルを変えるので、サンプル デバッグは提供されません。 ルータによって見られるデータ ストリームは送信 されるものがデバイスによって一致する必要があります。 それが一致する場合デバイスを一致するために、もっとより多分、速度、データビット、パリティ、またはストップビットは設定されません。 これはデータが受け取られない場合同様に事実である場合もあります。

データがシリアルインターフェイスで受け取られる場合、接続が開いているまたは閉じるかどうか示すために show bstun コマンドを発行して下さい。 trasmitted パケットだけを持つ Openステートは TCP がリモート BSTUN ピアに送信 されることを示します。 この時点で、ローカル BSTUN peer-name の IP アドレスからのリモート BSTUN peer-name IP アドレスへの pingテストは確認しま IP がであるかどうか設定され、きちんとはたらきます。 ping テストが正常である場合、遠隔で、パケットが非同期デバイスにシリアルインターフェイスに受信され、送信 されるかどうか確認するために debug asp packet コマンドを発行して下さい。

解決するためにこれらのステップを完了して下さい。

  1. データが debug asp packet コマンドでホスト ルータに受け取られることを確認して下さい。

  2. BSTUN peer-name IP アドレスからのリモート BSTUN peer-name のリモートIPアドレスに pingテスト ソース ping を用いる IP接続を確認して下さい。

  3. 遠隔で、パケットが debug asp packet コマンドでリモートデバイスに送信されることを確認して下さい。

  4. async プロトコルにルータに送信されるパケットに含まれているアドレスがある場合に相当して発行することはアドレスがパケットで含まれている適切なバイト番号を用いるインターフェイスの下で asp offset-address コマンドを有利である場合もあります。 これのデフォルト値はパケットが asp offset-address 01 コマンドで C1 がアドレスの 01C1ABCDEF、シリアルインターフェイス設定することができればである場合、たとえば 0。です。 場合によっては、これはルータがフレーム化されたパケットとちょうどデータ ストリームとしてデータを処理することルータがパケットを識別するようにし、確率を高めます。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 41983