IP : IP マルチキャスト

ランデブー ポイントのフィルタリング ポリシーを実装する方法

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 12 月 17 日) | 英語版 (2015 年 4 月 27 日) | フィードバック


目次


概要

このドキュメントでは、ダイナミックな RP 設定が適用されている(Auto-RP)マルチキャスト環境の RP マッピング エージェントでランデブー ポイント(RP)のフィルタリング ポリシーを実装する方法を説明します。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • Protocol Independent Multicast (PIM)の基本的な知識

使用するコンポーネント

この資料の全体にわたって参照としてこのダイアグラムを使用して下さい:

/image/gif/paws/41680/rp_announce_02.gif

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

Auto-RP

Auto-RP はネットワークの各ルータのための RP 情報を学ぶダイナミックな方法です。 これは IP Multicast によってすべてのグループからRP の情報を配信するとき実現します。

すべての PIM対応 ルータは自動的に Cisco RP ディスカバリ グループに加入します(224.0.1.40)それらがすべてのグループからRP のマッピング情報を受け取るようにする。 この情報は RP マッピングエージェントと問い合わせられるエンティティによって配信されます。 マッピングエージェント自身は別のものに加入します group — Cisco RP がグループをアナウンスする(224.0.1.39)。 RP が定期的なマルチキャストメッセージで彼ら自身をアドバタイズするすべての候補は RP をアナウンスしますグループ アドレスを目指しました。

マッピングエージェントはすべての RP 候補発表を受信し、情報の表を作成します。 複数の RP がマルチキャストグループ範囲のために彼ら自身をアナウンスする場合、マッピングエージェントは 1 つだけを—最も高い IP アドレスの RP 選択します。 それは RP ディスカバリ メッセージを使用してネットワークのすべての PIM ルータにそれから RP をアドバタイズします。 マッピングエージェントは 60 秒毎に(デフォルト設定)この情報を送信 します。

RP アドレスのフィルタリング

ある特定のマルチキャスト グループのためのある特定の RP をフィルタリングするのに ip pim rp-announce-filter rp-list access-list group-list access-list コマンドを使用できます。

マッピングエージェントで設定される場合 ip pim rp-announce-filter rp-list access-list group-list access-list コマンドに意味がありますただ。 RPリスト access-list は場合許可された group-list access-list コマンドで規定 される マルチキャスト範囲のために受け入れられる候補者 RP の access-list を定義します。

注: このコマンドの使用には注意が必要です。 RPリストによって一致する RP に(割り当て文によって許可される) group-list によってフィルタリングされるマルチキャスト グループがあります。 否定される RP はグループ全員のための候補 RP としてマルチキャスト グループのフィルタリングに応じて(明示的のか暗黙の deny によって)および「盲目的に」受け入れられますありません。 すなわち、RPリストによって許可される RP だけ group-list によってフィルタリングされるマルチキャスト グループがあります。 他の RP はすべてチェックなしで受け入れられます。

追加 RP はフィルタをです必要効果的にチェックなしで受け入れられる RP をフィルタリングするためにアナウンスします。 フィルタリング例はこのプロシージャを明白にします。

例のフィルタリング

Components Used セクションのダイアグラムでは、R2 および R4 は(RP ディスカバリ メッセージによってこの情報をアドバタイズする)のための候補 RP として彼ら自身をこれらのグループ アナウンスします:

  • 224.1.0.1

  • 224.1.0.2

  • 224.1.0.3

R3 はマッピングエージェントで設定され、この情報を収集し、表を作成し、ただの PIM対応 ルータである R6 に 1 RP アドレスだけ送信 します。 Intermediate System-to-Intermediate System(IS-IS)はユニキャストルーティングプロトコルとしてこの例で使用されますが、他のどのプロトコルも同様にはたらきます。 PIM 希薄-稠密 モードは必要それらのグループのために設定される RP を持っていることなしでグループ 224.0.1.39 および 224.0.1.40 のためのマルチキャスト 情報を受け取るためにです。 すなわち、希薄-稠密 モードは稠密モードのように既知 RP がない場合はたらきます。 RP が知られているとき、希薄-稠密 モードは RP がそれ自身をアドバタイズするグループのために使用されます。

R2 の設定

hostname R2

ip multicast-routing

interface Loopback0
 ip address 50.0.0.2 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Serial3/0
 ip address 10.2.0.2 255.255.255.0
 ip router isis
 ip pim sparse-dense mode

router isis 
 net 49.0002.0000.0000.0002.00

ip pim send-rp-announce Loopback0 scope 16 group-list groupB
!         
!         
ip access-list standard groupB
 permit 224.1.0.1
 permit 224.1.0.2
 permit 224.1.0.3

R4 設定

hostname R4

ip multicast-routing

interface Loopback0
 ip address 50.0.0.4 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Serial3/0
 ip address 10.3.0.4 255.255.255.0
 ip router isis
 ip pim sparse-dense mode

router isis 
 net 49.0002.0000.0000.0004.00

ip pim send-rp-announce Loopback0 scope 16 group-list groupA
!         
!         
ip access-list standard groupA
 permit 224.1.0.1
 permit 224.1.0.2
 permit 224.1.0.3

R3 設定

hostname R3

ip multicast-routing

interface Loopback0
 ip address 50.0.0.3 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Ethernet1/0.1
 encapsulation dot1Q 65
 ip address 65.0.0.3 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

interface Serial2/0
 ip address 10.2.0.3 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

interface Serial3/0
 ip address 10.3.0.3 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

router isis 
 net 49.0002.0000.0000.0003.00

R6 設定

hostname R6

ip multicast-routing

interface Loopback0
 ip address 50.0.0.6 255.255.255.255
 ip router isis
 
interface Ethernet1/0.1
 encapsulation dot1Q 65
 ip address 65.0.0.6 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

router isis 
 net 49.0002.0000.0000.0006.00

それらのグループの何れかのための可能性のある RP にはたらく RP としておよび R2 があるただので R4 をフィルタリングしたいと思ったら、RP をアナウンスします R3 のフィルタを設定して下さい:

ip pim rp-announce-filter rp-list filtering-RP group-list filtering-group
!         
!         
ip access-list standard filtering-RP
 permit 50.0.0.2
 deny    50.0.0.4


!--- ACL "filtering-RP" specifically allows R2 and explicitly denies R4.


ip access-list standard filtering-group
 permit 224.1.0.1
 permit 224.1.0.2
 permit 224.1.0.3

それから、現在のグループからRP のアソシエーションをクリアするために、R3 および R6 両方で clear ip pim rp-mapping コマンドを発行して下さい。

ただし、R6 を表示すれば、情報が期待するものではないことがわかります:

R6#show ip pim rp mapping 
PIM Group-to-RP Mappings

Group(s) 224.1.0.1/32
  RP 50.0.0.4 (?), v2v1

!--- RP is R4

    Info source: 65.0.0.3 (?), elected via Auto-RP
         Uptime: 00:00:02, expires: 00:02:55
Group(s) 224.1.0.2/32
  RP 50.0.0.4 (?), v2v1

!--- RP is R4

    Info source: 65.0.0.3 (?), elected via Auto-RP
         Uptime: 00:00:02, expires: 00:02:55
Group(s) 224.1.0.3/32
  RP 50.0.0.4 (?), v2v1

!--- RP is R4

    Info source: 65.0.0.3 (?), elected via Auto-RP
         Uptime: 00:00:02, expires: 00:02:55

R3 を表示する場合、フィルタリングが実際に実行されたことがわかります:

R3# show ip pim rp mapping
PIM Group-to-RP Mappings
This system is an RP-mapping agent

!--- This line confirms that R3 is configured as the mapping agent.


Group(s) 224.1.0.1/32
  RP 50.0.0.4 (?), v2v1

!--- No filtering has taken effect.

    Info source: 50.0.0.4 (?), elected via Auto-RP

!--- R4 is elected because it has a higher IP address.

         Uptime: 00:09:06, expires: 00:02:53
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), via Auto-RP
         Uptime: 00:09:29, expires: 00:02:27
Group(s) 224.1.0.2/32
  RP 50.0.0.4 (?), v2v1
    Info source: 50.0.0.4 (?), elected via Auto-RP
         Uptime: 00:09:06, expires: 00:02:51
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), via Auto-RP
         Uptime: 00:09:29, expires: 00:02:27
Group(s) 224.1.0.3/32
  RP 50.0.0.4 (?), v2v1
    Info source: 50.0.0.4 (?), elected via Auto-RP
         Uptime: 00:09:06, expires: 00:02:51
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), via Auto-RP
         Uptime: 00:09:29, expires: 00:02:28

R4 のアドレスはとりわけ否定され、マルチキャスト グループのあらゆるフィルタリングに応じてありません—マッピングエージェントによって「盲目的に」受け入れられます。 マッピングエージェントは最も高い IP アドレスに基づいて 1 RP を選択します(次にこの例で、50.0.0.4)および R6 にこの情報を転送します。

別の RP をアナウンスします効果的に R4 アドレスをフィルタリングするために割り当て R4 がグループ全員を否定するフィルタを設定すれば:

ip pim rp-announce-filter rp-list filtering-R4 group-list filtering-groupR4

ip access-list standard filtering-R4
 permit 50.0.0.4
ip access-list standard filtering-groupR4
 deny   any

RP を受け取るとすぐ R3 を表示し、debug ip pim auto-rp コマンドをアナウンスすれば R4 からのメッセージを有効に する場合、これらのメッセージを次のように表示できます:

R3#
*Apr 30 09:09:06.651: Auto-RP(0): Received RP-announce, from 50.0.0.4, RP_cnt 1, ht 181
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.1/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.3/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.2/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Received RP-announce, from 50.0.0.4, RP_cnt 1, ht 181
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.1/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.3/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.2/32 for RP 50.0.0.4

それからグループからRP の表を表示するとき、しか R2 を次のように表示なできます:

R3#show ip pim rp mapping 
PIM Group-to-RP Mappings
This system is an RP-mapping agent

Group(s) 224.1.0.1/32
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), elected via Auto-RP
         Uptime: 00:00:04, expires: 00:02:52
Group(s) 224.1.0.2/32
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), elected via Auto-RP
         Uptime: 00:00:04, expires: 00:02:54
Group(s) 224.1.0.3/32
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), elected via Auto-RP
         Uptime: 00:00:04, expires: 00:02:55

最終的には 224.1.0.1 のための RP として R2 がありたいと思えばおよび R4、R3 でこの設定があります 224.1.0.2 および 224.1.0.3 のための RP として:

hostname R3

ip multicast-routing

interface Loopback0
 ip address 50.0.0.3 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Ethernet1/0.1
 encapsulation dot1Q 65
 ip address 65.0.0.3 255.255.255.0
 ip router isis
 ip pim sparse-dense-mode

interface Serial2/0
 ip address 10.2.0.3 255.255.255.0
 ip router isis
 ip pim sparse-dense-mode

interface Serial3/0
 ip address 10.3.0.3 255.255.255.0
 ip router isis
 ip pim sparse-dense-mode

router isis
 net 49.0002.0000.0000.0003.00

ip pim rp-announce-filter rp-list filtering-RP2 group-list filtering-group2
ip pim rp-announce-filter rp-list filtering-RP4 group-list filtering-group4
!        
!        
ip access-list standard filtering-RP2
 permit 50.0.0.2

ip access-list standard filtering-RP4
 permit 50.0.0.4

ip access-list standard filtering-group2
 permit 224.1.0.1

ip access-list standard filtering-group4
 permit 224.1.0.2
 permit 224.1.0.3

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 41680