ブロードバンド ケーブル : ケーブル モデム終端システム(CMTS)

ブリッジ モードでの uBR7100 のオールインワン設定

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、Dynamic Host Configuration Protocol(DHCP)、Time-of-Day(ToD)および TFTP サーバとして機能する Cisco uBR7100 ケーブルモデム終端システム(CMTS)の設定例を紹介します。 また、CMTS でのコマンドライン インターフェイス(CLI)によるデータオーバーケーブル サービス インターフェイス仕様(DOCSIS)コンフィギュレーション ファイルの構築方法についても説明します。 この設定は、CMTS がブリッジ モードで設定されている間、「Cisco CMTS のオールインワン設定」と呼ばれます。 現在 uBR7100 プラットフォームはブリッジングをサポートする唯一の CMTS プラットフォームです。

前提条件

要件

このドキュメントの読者は、ブリッジング、DOCSIS、DHCP、ToD、および TFTP プロトコルについての基本的な知識が必要です。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco uBR7100 ケーブル モデム終端システム

  • DOCSIS 準拠のケーブル モデム

  • Cisco IOS(R) ソフトウェア リリース 12.1(7)EC または それ 以降

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

説明

DOCSIS 準拠のケーブル モデムは、正常にオンラインになるために 3 種類のサーバへの接続を必要とします。

CATV 事業者のほとんどは、Cisco Network Registrar(CNR)を DHCP、ドメイン ネーム サーバ(DNS)、および TFTP サーバとして使用しています。 ToD サーバは CNR の一部ではありません。 ToD サーバは、ケーブル事業者のシステムのプラットフォームの種類によって使用されるかどうかが決まります。 ToD は RFC-868 leavingcisco.com 準拠である必要があります。 UNIX システムでは Solaris に含まれています; 唯一、/etc のディレクトリの inetd.conf ファイルに次の行が含まれていることを確認する必要があります。

# Time service is used for clock synchronization.
#
time    stream  tcp     nowait  root    internal
time    dgram   udp     wait    root    internal

Windows の場合、最も一般的に使用されているソフトウェアは、 ゲートウェイ leavingcisco.com です。

次の表に、CMTS に異なるサーバ機能が追加された各 Cisco IOS ソフトウェア リリースを示します。

サーバ機能 Cisco IOS ソフトウェア リリース
DHCP 12.0(1)T
ToD 12.0(4)XI
TFTP 11.0(全プラットフォーム対応)

このドキュメントでは、これらの各機能について説明します。 これらの機能すべてを備えた CMTS に対する設定は、「CMTS のオールインワン設定」と呼ばれています。 この設定がされていれば、ケーブル プラントのテスト用に他のサーバを必要とせず、高速インターネット アクセスを行うことができます。

また、TFTP サーバではなく CMTS 上にある DOCSIS コンフィギュレーション ファイルを設定できるようになります。 リリース ノートによると、この機能を使用するには、Cisco IOS ソフトウェア リリース 12.1(2)EC1 以上が必要です。

この「オールインワン設定」は、ラボ環境、初期テスト、小規模な配備、およびトラブルシューティングにとっては非常に便利ですが、非常に多数のケーブル モデムのサポートには対応していません。 そのため、多数のケーブル モデムを使用する稼働中のケーブル プラントでは、この設定の使用は推奨しません

シスコのテクニカルサポートのエンジニアは、ケーブルの問題をトラブルシューティングする間変数を削除するためしばしばこの設定を使用します。

ルーティングとブリッジングの動作

Cisco uBR7100 シリーズ ルータでは、次の動作モードをサポートします。

  • ルーティング モード:ルーティング動作モードは Cisco CMTS ルータの標準的なデフォルト モードです。 このモードでは、DHCP サーバなどの Cisco IOS ソフトウェア ルーティング機能の広い範囲を提供し、各インターフェイスを介してどのパケットが送信されるのかを制御し ます。

  • トランスペアレント ブリッジング モード:ケーブル インターフェイスとポート アダプタ インターフェイス間のブリッジング動作は、パフォーマンスおよびセキュリティの問題がある可能性があるため DOCSIS CMTS のインストールでは通常使用されません。 しかし、ブリッジングは顧客宅内機器(CPE)のデバイス数に制限がある CMTS 環境では非常に有効です。このような環境は、典型的な集合住宅用設備(MDU)またはマルチテナント設備(MTU)の環境、特に CMTS が既存のブリッジングのネットワークと置き換えられている環境です。

Integrated Routing and Bridging(IRB)

Integrated Routing and Bridging(IRB)動作ではホストまたはネットワークの特定のセグメント内でブリッジングができ、またそのホストは他の、2 つのネットワークを相互接続するための別のルータを使用しないルートされたネットワーク上のデバイスと接続することができます。

注: Cisco IOS ソフトウェア リリース 12.1(7)EC 以降を使用する場合にのみトランスペアレント ブリッジングと IRB 動作はサポートされます。 トランスペアレント ブリッジングと IRB 動作の詳細については、Cisco.com およびシスコのドキュメント CD-ROM から入手できる『Cisco IOS ブリッジングおよび IBM ネットワーキング コンフィギュレーション ガイド、リリース 12.1』の「ブリッジング」の章を参照してください。

ブリッジ グループ仮想インターフェイス

ubr7100_config_bridge_1.gif

ブリッジングはデータリンク層で動作し、ルーティングはネットワーク層で動作するため、異なるプロトコル コンフィギュレーション モデルを使用します。 たとえば、基本的な IP モデルではすべてのブリッジ インターフェイスは同じネットワークに属している必要がありますが、ルーテッド インターフェイスはそれぞれ別個のネットワークを表します。

IRB では、ブリッジ グループ仮想インターフェイスは、特定のプロトコルが 1 つのブリッジ グループでブリッジおよびルーティングの両方が行われる場合に、プロトコル設定モデルの混同を避けるために使用されます。

ブリッジ グループ仮想インターフェイスはブリッジングをサポートしない通常のルーテッド インターフェイスですが、ルーテッド インターフェイスに対応するブリッジ グループを代表します。 BVI には、対応するブリッジ グループに適用されるすべてのネットワーク レイヤ アトリビュート(ネットワーク レイヤ アドレスやフィルタなど)があります。 この仮想インターフェイスに割り当てられているインターフェイス番号は、この仮想インターフェイスが表すブリッジ グループに対応しています。 この番号が仮想インターフェイスとブリッジ グループ間のリンクになります。

ブリッジ グループ仮想インターフェイスで特定のプロトコルのルーティングを有効にすると、ルーテッド インターフェイスから送信された、ブリッジ ドメイン内のホスト宛てのパケットは、ブリッジ グループの仮想インターフェイスにルーティングされ、対応するブリッジ インターフェイスに転送されます。 ブリッジ グループ仮想インターフェイスにルーティングされたすべてのトラフィックは、対応するブリッジ グループにブリッジド トラフィックとして転送されます。 ブリッジド インターフェイスで受信されたすべてのルーティング可能なトラフィックは、ブリッジ グループ仮想インターフェイスから直接送信されたかのように、他のルーテッド インターフェイスにルーティングされます。

ブリッジ インターフェイスに到達したがルーテッド インターフェイスに送信予定またはルーテッド パケットを受信するためにルート可能なパケットを受信するには、ブリッジ グループ仮想インターフェイスにも適切なアドレスが必要です。 MAC アドレスおよびネットワーク アドレスはブリッジ グループ仮想インターフェイスに次の方法で割り当てられます。

  • ブリッジ グループ仮想インターフェイスは、ブリッジ グループ仮想インターフェイスに関連付けられたブリッジ グループのブリッジ インターフェイスに 1 つから MAC アドレスを「借り」ます。

  • 同じブリッジ グループで指定されているプロトコルをルーティングおよびブリッジングするには、ブリッジ グループ仮想インターフェイスのプロトコルのネットワーク層の属性を設定する必要があります。

  • プロトコル属性はブリッジ インターフェイスに設定しないでください。また、ブリッジング属性をブリッジ グループ仮想インターフェイスに設定できません。

ブリッジ グループを代表するブリッジ グループ仮想インターフェイスは 1 だけなので、そしてブリッジ グループは複数の異なるカプセル化方式に設定されたさまざまなメディア タイプで構成される可能性があるため、パケットを正しく切替えるために必要な特定のカプセル化方式を使ってブリッジ グループ仮想インターフェイスを設定する必要があります。

CMTS の Cisco IOS DHCP サービス

Cisco IOS ソフトウェア リリース 12.0(1)T 以降を実行している Cisco ルータには、DHCP サーバとして動作する機能があります。 この DHCP サービスは、ケーブル モデムや PC や ワークステーションなどの CPE に DHCP リースを提供するために設定されることがあります。

ケーブル モデムがオンラインになるために一般的に必要な次の DHCP オプションの最小セットがあります。

  • IP アドレス(DHCP パケット ヘッダの yiaddr フィールド)

  • サブネット マスク(DHCP オプション 1)

  • グリニッジ標準時(GMT)からの現地時間のタイム オフセット(秒)(DHCP オプション 2)

  • デフォルト ルータ(DHCP オプション 3)

  • ToD サーバの IP アドレス(DHCP オプション 4)

  • ログ サーバ(DHCP オプション 7)

  • TFTP サーバの IP アドレス(DHCP パケット ヘッダの siaddr フィールド)

  • DOCSIS コンフィギュレーション ファイルの名前(DHCP パケット ヘッダの file フィールド)

  • DHCP リース時間(秒)(DHCP オプション 51)

ルータでは、これらのオプションは次のコマンドで設定することができます。

!
ip dhcp pool cm-platinum
 network 10.1.4.0 255.255.255.0
 bootfile platinum.cm
 next-server 10.1.4.1
 default-router 10.1.4.1
 option 7 ip 10.1.4.1
 option 4 ip 10.1.4.1
 option 2 hex ffff.8f80
 lease 7 0 10
!

次は、これらのコマンドの説明です。

  • dhcp pool:ケーブル モデムの範囲の名前(cm-platinum)を定義します。

  • network:IP アドレスとサブネット マスクを指定します(DHCP オプション 1)。

  • bootfile:ブート ファイル名を指定します。ここでは platinum.cm です。

  • next-server;TFTP サーバの IP アドレスを指定します。この例では、インターフェイス c4/0 のプライマリ IP アドレスです。

  • default-router:デフォルト ゲートウェイを定義します。この例では、インターフェイス c4/0 のプライマリ IP アドレスです(DHCP オプション 3)。

  • option 7:ログ サーバの DHCP オプションを定義します。

  • option 4:ToD サーバの IP アドレス(インターフェイス c4/0 のプライマリ IP アドレス)を指定します。

  • option 2:GMT の時刻オフセットオプションで – 8 時間(– 8 時間は - 28800 秒で、これは 16 進数で ffff.8f80 に等しい)を指定します。

    注: タイム オフセットの値を 10 進数から 16 進数に変換する方法の詳細は、「DHCP オプション 2(タイム オフセット)の 16 進数値の計算方法」を参照してください。

  • lease:リース期間(7 日間、0 時間、10 分)を設定します。

CPE のデバイスに対して、次のオプションが正常に動作するために必要な最小限です。

  • IP アドレス(DHCP パケット ヘッダの yiaddr フィールド)

  • サブネット マスク(DHCP オプション 1)

  • デフォルト ルータ(DHCP オプション 3)

  • 1 台または複数台の DNS の IP アドレス(DHCP オプション 6)

  • ドメイン名(DHCP オプション 15)

  • DHCP リース時間(秒)(DHCP オプション 51)

ルータでは、これらのオプションは次のコマンドで設定することができます。

! 
ip dhcp pool pcs-irb

!--- The scope for the hosts.

   network 172.16.29.0 255.255.255.224

!--- The IP address and mask for the hosts.

   next-server 172.16.29.1

!--- TFTP server; in this case, the secondary address is used.

   default-router 172.16.29.1
   dns-server 172.16.30.2

!--- DNS server (which is not configured on the CMTS).

   domain-name cisco.com
   lease 7 0 10
!

DHCP サーバのその他の機能

次は、 Cisco IOS ソフトウェア DHCP サーバから使用できるその他の機能です。

  • ip dhcp ping:リースの機能の前に ping を行います。これにより、DHCP サーバがすでに使用されている IP アドレスにリースを発行しないようにすることができます。

  • ip dhcp database:CMTS の電源の再投入時に MAC アドレスと IP アドレスの関係を維持するために外部データベースに DHCP バインディングを保存する機能です。

  • show ip dhcp:DHCP サーバの動作をモニタするために使用する一連のコマンドです。

  • debug ip dhcp server:DHCP サーバの動作をトラブルシューティングするために使用できる一連のコマンドです。

これらの追加関数や機能については、すべて『Cisco IOS ソフトウェア DHCP サーバ』マニュアルの Cisco IOS DHCP サーバ機能のリリース ノートで説明されています。

Cisco IOS TFTP サービス

ケーブル モデムの ToD サーバへの接続が試みられた後は、DOCSIS コンフィギュレーション ファイルをダウンロードするために TFTP サーバへの接続に進みます。 バイナリ形式の DOCSIS コンフィギュレーション ファイルがシスコ CMTS のフラッシュ デバイスにコピーできる場合は、ルータはそのファイルに対する TFTP サーバとして動作できます。

これは DOCSIS コンフィギュレーション ファイルをフラッシュにダウンロードする手順です。

  1. DOCSIS コンフィギュレーション ファイルが置かれているサーバに CMTS が到達できることを確認するために ping コマンドを発行します。

    Ubr7111# ping 172.16.30.2
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.30.2, timeout is 2 seconds:
    
    !--- Output suppressed.
    
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
  2. ファイル(ここでは、silver.cm というファイル)を CMTS のフラッシュにコピーします。

    Ubr7111# copy tftp flash
    
    Address or name of remote host []? 172.16.30.2
    Source filename []? silver.cm
    Destination filename [silver.cm]?
    
    Accessing tftp://172.16.30.2/silver.cm...
    Loading silver.cm from 172.16.30.2 (via Ethernet2/0): !
    [OK - 76/4096 bytes]
    
    76 bytes copied in 0.152 secs
  3. フラッシュを検査し、dir コマンドを使用して、ファイルのサイズが正しいことを確認します。

    Ubr7111# dir
    
    Directory of disk0:/
    
       1  -rw-          74   Feb 13 2001 16:14:26  silver.cm
       2  -rw-    10035464   Feb 14 2001 15:44:20  ubr7100-ik1s-mz.121-11b.EC.bin
    
    47890432 bytes total (17936384 bytes free)
  4. CMTS で TFTP サービスを有効にするには、グローバル コンフィギュレーション モードで次のコマンドを発行します。

    tftp-server slot0:silver.cm alias silver.cm
    
  5. 設定の次の行を確認して、ステップ 4 を確認します。

    !
    tftp-server slot0:silver.cm alias silver.cm
    tftp-server server
    !

ルータの TFTP サーバの設定に関する詳細については、「その他のファイル転送の機能コマンド」を参照してください。

Cisco IOS ToD サービス

ケーブル モデムが問題なく DHCP リースを取得すると、次は ToD サーバとの接続を試みます。 Cisco IOS ソフトウェア リリース 12.0(4) XI 以降を実行する Cisco CMTS 製品では、RFC 868 leavingcisco.com の ToD サービスを提供できます。

よくある誤解は、ケーブル モデムがオンラインになるために使用する必要がある ToD サービスがシスコのルータで一般的に設定されているネットワーク タイム プロトコル(NTP)サービスと同じだというものです。 NTP サービスと ToD サービスには互換性がありません。 ケーブル モデムは NTP サーバとは対話できません。 ケーブル モデムがオンラインになる過程の一部として ToD サーバへの接続を試みる必要があるとき、DOCSIS 1.0 無線周波数干渉(RFI)仕様の最新版に準拠しているモデムは、ToD サーバに到達できない場合でもオンラインになります。

この仕様の最新リリースによれば、ケーブル モデムが ToD サーバに接続できない場合でも、オンラインになる処理が継続される場合があります。 ただし、成功するまで、ToD サーバへの接続を定期的に試行します。 DOCSIS 1.0 RFI 仕様の以前のバージョンでは、ケーブル モデムが ToD サーバに接続できない場合は、そのモデムはオンラインにはなれません。 古いファームウェアを実行しているケーブル モデムでは、この古いバージョンの仕様に準拠している場合があることに注意してください。

注: 一部のベンダーのケーブル モデムは Cisco IOS ソフトウェア ToD サービスと相互運用しません。 これらのモデムが DOCSIS 1.0 RFI 仕様の最新バージョンに準拠していれば、オンラインになる処理を継続できます。 この相互運用性の問題は、Cisco Bug ID CSCdt24107登録ユーザ専用)に記述されています。

Cisco CMTS で ToD を設定するには、次のグローバル コマンドを発行します。

service udp-small-servers max-servers no-limit
!
cable time-server
!

内部 DOCSIS コンフィギュレーション ファイル ジェネレータ

Cisco IOS ソフトウェア リリース 12.1(2)EC 以降(EC リリース群)を実行しているシスコ CMTS 製品は、DOCSIS コンフィギュレーション ファイルを作成し、内部に保存するよう設定できます。 そのようにすると、外部の DOCSIS コンフィギュレーション ファイル作成ツールにアクセスする必要がなくなるので便利です。 内部の設定ツールを使用して DOCSIS コンフィギュレーション ファイルを作成する場合、そのファイルは TFTP を経由して自動的に有効になります。 さらに、直接接続されたケーブル インターフェイス上のケーブル モデムからだけは、このコンフィギュレーション ファイルをダウンロードできます。

次の設定例では、2 つの DOCSIS コンフィギュレーション ファイルの作成を示します。

最初の例では、disable.cm を呼び出しています。これによって、ケーブル モデムがオンラインになることができるますが、サービス プロバイダーのネットワークのアクセスから CPE デバイスへの接続を回避できます。 この例では場合、access-denied コマンドです。 この例では、ダウンストリーム側とアップストリーム側のスピードは共に 1 Kbps で、最大バースト サイズは 1600 バイトであることに注意してください。

cable config-file disable.cm
   access-denied
   service-class 1 max-upstream 1
   service-class 1 max-downstream 1600
   timestamp
!

CATV 事業者は、ケーブル モデムを介した CPE へのアクセスを拒否するがケーブル モデムがオンラインになることは許可する場合にこの disable.cm DOCSIS コンフィギュレーション ファイルを使用します。 これは、ケーブル モデムがオンラインになることができない CNR の exclude オプションを使用して ケーブル モデムが繰り返しオンラインになろうとして帯域幅を消費するよりもより効率的な CPE サービスを拒否する方法です。

この DOCSIS コンフィギュレーション ファイルを使用するケーブル モデムでは、show cable modem コマンドを発行すると、次の出力が示されています。

Cable1/0/U0 10  online(d)  2287  0.50  6  0  10.1.4.65  0010.7bed.9b45

この出力の詳細については、このドキュメントの「高度な設定の検証に関するヒント」を参照してください。 online(d) というステータスは、ケーブル モデムがオンラインであるが、アクセスは拒否されていることを示しています。

2 番目の例では、platinum.cm と呼ばれる DOCSIS コンフィギュレーション ファイルを作成します。 この場合、アップストリームの最大速度が 1Mbps であり、保証されているアップストリームの値は 100Kpbs になっています。また、ダウンストリームの最大速度は 10Mbps で、最大で 30 の CPE デバイスを接続できます。

cable config-file platinum.cm
   service-class 1 max-upstream 1000
   service-class 1 guaranteed-upstream 100
   service-class 1 max-downstream 10000
   service-class 1 max-burst 1600
   cpe max 30
   timestamp
!

CMTS で DOCSIS コンフィギュレーション ファイルを設定する際には、tftp server slot0:platinum.cm alias platinum.cm という文は必要ありません。これは、メモリ上に .cm ファイルが保存されておらず、 設定の中にあるためです。

内部 DOCSIS コンフィギュレーション ファイルのツールに関する詳細は、「Cisco CMTS コンフィギュレーション コマンド」に記載されています。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

一般的なラボ セットアップ トポロジを、次の図に示します。

/image/gif/paws/29243/ubr7100_config_bridge_2.gif

設定

このドキュメントでは、次の設定を使用します。

この設定は、uBR7100 CMTS プラットフォームでのみサポートされます。

DOCSIS コンフィギュレーション ファイルの設定など、オールインワン設定をサポートしている Cisco IOS ソフトウェア リリースは、Cisco IOS ソフトウェア リリース 12.1(2)EC とそれ以降の EC 群のリリースです。 この設定で使用された Cisco IOS ソフトウェア トレインは ubr7100-ik1s-mz.121-11b.EC.bi n です。

基本的なオールインワン設定

この設定では、これまでに説明したすべての項目についてまとめてします。 次の 2 つの DHCP の範囲があります。 1 つはケーブル モデム用のもので、もう 1 つはケーブル モデムより内部にあるホスト用のものです。

1 つの DOCSIS コンフィギュレーション ファイルが、platinum.cm という名前で作成されます。 このファイルは、cm-platinum という DHCP プールに適用されます。 もう 1 つの DOCSIS コンフィギュレーション ファイルである disabled.cm は、この時点ではどれにも適用されません。

コメントは、関連するコマンドの後に青で表示されています。 オールインワン設定コマンドは、太字で表されています。

基本的なオールインワン設定
ubr7100# show run
Building configuration...
 
Current configuration : 3511 bytes
!
! Last configuration change at 01:12:37 PST Mon Sep 3 2001
!
version 12.1
no service pad
service timestamps debug datetime msec localtime

!--- Provides useful timestamps on all log messages.

service timestamps log datetime localtime
no service password-encryption
service linenumber
service udp-small-servers max-servers no-limit

!--- Supports a large number of modems or hosts attaching quickly.

 
!
hostname ubr7111
!
boot system flash disk0:ubr7100-ik1s-mz.121-11b.EC.bin
!
cable spectrum-group 3 frequency 40800000
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable timeserver

!---  Allows cable modems to obtain ToD from the uBR7100.

!
cable config-file platinum.cm
 service-class 1 max-upstream 128
 service-class 1 guaranteed-upstream 10
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1600
 cpe max 8
 timestamp
!
clock timezone PST -9
clock calendar-valid
ip subnet-zero
no ip routing

!--- Disables routing on the CMTS.

no ip domain-lookup

!--- Prevents the CMTS from looking up domain names or attempting 
!--- to connect to machines (for example, when mistyping commands).

ip host ubr7111 172.16.26.103
ip domain-name cisco.com
ip name-server 171.68.10.70
ip name-server 171.69.2.132
ip name-server 171.68.200.250
no ip dhcp relay information check
 
ip dhcp excluded-address 10.45.50.1 10.45.50.5
!
ip dhcp pool cm-platinum

!--- Name of the DHCP pool. This scope is for the cable modems attached 
!--- to interface cable 4/0.

   network 10.1.4.0 255.255.255.0

!--- Pool of addresses for scope modems-c1/0.

   bootfile platinum.cm

!--- DOCSIS configuration file name associated with this pool.

   next-server 10.1.4.1

!--- IP address of the TFTP server which sends the boot file.

   default-router 10.1.4.1

!--- Default gateway for cable modems; necessary to get DOCSIS files.

   option 7 ip 10.1.4.1

!--- Log Server DHCP option.

   option 4 ip 10.1.4.1

!--- ToD server IP address.

   option 2 hex ffff.8f80

!--- Time offset for ToD, in seconds (HEX), from GMT.
!--- Pacific Standard Time offset from GMT = –28,000 seconds = ffff.8f80

   lease 7 0 10

!--- Lease 7 days 0 hours 10 minutes.

! 
ip dhcp pool pcs-irb

!--- Name of the DHCP pool. This scope is for the CPE attached to
!--- the cable modems that are connected to interface cable 1/0.

   network 172.16.29.0 255.255.255.0

!--- Pool of addresses for scope pcs-c4 (associated with the secondary address).

   next-server 172.16.29.1
   default-router 172.16.29.1
   dns-server 172.16.29.1
   domain-name cisco.com
   lease 7 0 10
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
!
!
!
!
bridge irb
!
!
interface FastEthernet0/0
 ip address 14.66.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 no keepalive
 duplex half
 speed auto
 no cdp enable
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface FastEthernet0/1
 ip address 14.66.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 shutdown
 duplex auto
 speed 10
 no cdp enable
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Cable1/0
 ip address 14.66.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 no keepalive
 cable packet-cache
 cable downstream annex B
 cable downstream modulation 256qam
 cable downstream interleave-depth 32
 cable downstream frequency 525000000
 no cable downstream rf-shutdown
 cable downstream rf-power 55
 cable upstream 0 frequency 17808000
 cable upstream 0 power-level 0
 cable upstream 0 channel-width 3200000
 no cable upstream 0 shutdown
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address 10.1.4.1 255.255.255.0
!
ip default-gateway 14.66.1.1
ip classless
no ip http server
!
no cdp run
bridge 1 protocol ieee
 bridge 1 route ip
alias exec scm show cable modem
!
line con 0
 exec-timeout 0 0
 privilege level 15
 length 0
line aux 0
line vty 0 4
 privilege level 15
 no login
line vty 5 15
 login
!
end

基本設定の検証に関するヒント

このセクションでは、設定が正しく動作していることを確認する方法について説明します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

  1. show version コマンドを発行して、このコマンドが Cisco IOS ソフトウェア リリースでサポートされていることを確認します。

  2. DOCSIS コンフィギュレーション ファイルがフラッシュにあることを確認します。

    Ubr7111# dir
    
    Directory of disk0:/
     
        1  -rw-          74   Feb 13 2001 16:14:26  silver.cm
        2  -rw-    10035464   Feb 14 2001 15:44:20  ubr7100-ik1s-mz.121-11b.EC.bin
     
    47890432 bytes total (17936384 bytes free)

    注: ファイル silver.cm は DOCSIS CPE Configurator ツールを使用して作成されました。 CMTS 設定で作成された platunum.cm ファイルの場合には、tftp server slot0:platinum.cm alias platinum.cm という文は必要ありません。これは、.cm ファイルがなく、これが 設定の中にあるためです。

  3. show cable modem コマンドを発行してケーブル モデムがオンラインであることを確認します。

    Ubr7111# show interface cable 1/0 modem 0
    
    SID   Priv bits  Type      State     IP address    method    MAC address
    75    00         host      unknown   172.16.29.2   static    00c0.4f97.61c5
    75    00         modem     up        10.1.4.2      dhcp      0010.7bed.9b23
    76    00         modem     up        10.1.4.3      dhcp      0002.fdfa.0a63
    77    00         host      unknown   172.16.29.3   dhcp      00a0.243c.eff5
    77    00         modem     up        10.1.4.5      dhcp      0010.7bed.9b45
    78    00         modem     up        10.1.4.4      dhcp      0004.2752.ddd5
    79    00         modem     up        10.1.4.6      dhcp      0002.1685.b5db
    80    00         modem     up        10.1.4.7      dhcp      0001.64ff.e47d

    すべてのケーブル モデムがオンラインであることに注意してください。 インターフェイス ケーブル 1/0/U0 に接続されているものは、ネットワーク 10.1.4.0 にあります。 これらの IP アドレスは、cm-platinum という DHCP プールから取得されることが設定から分かります。

    また、各々 MAC アドレス 0010.7bed.9b23、および 0010.7bed.9b45 を持つケーブル モデムの背後に CPE があることに注意してください。 これらのケーブル モデムはデフォルトのブリッジング設定によってオンラインになります。 これらの PC は DHCP で設定されているため、IP アドレスはネットワークから取得できます。

    Ubr7111# show interface cable 1/0 modem 0
    
    SID   Priv bits  Type      State     IP address    method    MAC address
    75    00         host      unknown   172.16.29.2   static    00c0.4f97.61c5
    75    00         modem     up        10.1.4.2      dhcp      0010.7bed.9b23
    76    00         modem     up        10.1.4.3      dhcp      0002.fdfa.0a63
    77    00         host      unknown   172.16.29.3   dhcp      00a0.243c.eff5
    77    00         modem     up        10.1.4.5      dhcp      0010.7bed.9b45
    78    00         modem     up        10.1.4.4      dhcp      0004.2752.ddd5
    79    00         modem     up        10.1.4.6      dhcp      0002.1685.b5db
    80    00         modem     up        10.1.4.7      dhcp      0001.64ff.e47d

    このスクリーン ショットでは、これらの PC が pcs-c4 と呼ばれるプールから IP アドレスを取得することを示します。

    ubr7100_config_bridge_3.gif

    また、この PC では、IP アドレスを自動的に取得するように TCP/IP 設定が設定されていることが分かります。

    ubr7100_config_bridge_4.gif

高度なオールインワン設定

このセクションでは、DHCP プールに階層機能を組み込んだ、より高度な設定例について説明します。 DHCP プールの階層が動作する方法は、ある DHCP プールが他の DHCP プールのネットワーク番号のサブセットになっているネットワーク番号を持ち、他のプールの特性をすべて継承するというものです。 これにより、DHCP サーバ設定の繰り返しを減らすことができます。 ただし、異なるパラメータを持つ同じ項目が設定されている場合は、そのパラメータは上書きされます。 この例では、platinum.cm というブート ファイルがある一般用プールについて説明します。このプールのサブセットに disable.cm というブート ファイルが作成されます。

基本例で作成した DHCP プールの他に、この例では 2 台のケーブル モデムに対する要件があります。

最初に、ケーブル モデム0010.7bed.9b45 はアクセスを拒否されます。 これは IP アドレスを許可されますが、オンラインになりません。 次のプールを作成します。

ip dhcp pool cm-0010.7bed.9b45
   host 10.1.4.65 255.255.255.0
   client-identifier 0100.107b.ed9b.45
   bootfile disable.cm

この設定例で最も注目に値する機能は、個々のケーブル モデムの MAC アドレスに対応する特別な DHCP プールを指定する箇所です。 このような仕様では、DHCP サーバでこれらのモデムに一義的な DHCP オプションを送ることができます。 特定のケーブル モデムを指定するには、client-identifier パラメータが使用されます。 client-identifier には、エントリに対応するデバイスの MAC アドレスの先頭に 01 を付加して設定します。 01 は DHCP のハードウェア タイプのイーサネットに対応します。

注: モデムのコンフィギュレーション ファイルを変更する場合、設定されているパラメータをケーブル モデムで手動で取得できるようにするために次の手順を実行する必要があります。

  1. clear ip dhcp binding ip address コマンドを使用して、 IP DHCP のバインディング テーブルをクリアします。

  2. clear cable modem mac address res コマンドを発行して、問題のケーブル モデムをリセットします。

2 番目に、ケーブル モデム 0010.7bed.9b23 にも特別な要件があります。 これは、別の Quality of Service(QoS)を取得するということです。 つまり、次の設定の一部分で示すように、この範囲には異なるブート ファイルが関連付けられています。

ip dhcp pool cm-0010.7bed.9b23
   host 10.1.4.66 255.255.255.0
   client-identifier 0100.107b.ed9b.23
   bootfile silver.cm
!

特定のケーブル モデムに対して DHCP プールを設定する場合には、常に関連のある名前を付けることをお勧めします。 また、host コマンドを使用して特定の IP アドレスをプールに割り当てるため、グローバル コマンドの ip dhcp exclude 10.1.4.60 10.1.4.70 を追加する必要があります。 このコマンドは、DHCP にこの範囲のアドレスを使用しないように指示します。

高度な設定の検証に関するヒント

この設定の検証は、ケーブル モデム、特に 0010.7bed.9b450010.7bed.9b23 が取得するサービスに重点を置きます。 これらが手動で設定されたアドレスおよびサービスの両方を取得することを確認する必要があります。

テストで最初に行うのは、0010.7bed.9b45 をオンラインし、しかしサービスが拒否されていることです。 show cable modem コマンドを発行します。

7246VXR# show cable modem

Interface   Prim Online     Timing Rec    QoS CPE IP address      MAC address
            Sid  State      Offset Power
Cable4/0/U0 7    online     2813    0.00  7   0   10.1.4.7        0002.1685.b5db
Cable4/0/U0 8    online     2809    0.25  7   0   10.1.4.10       0002.fdfa.0a63
Cable4/0/U0 9    online     2288   -0.25  5   1   10.1.4.66       0010.7bed.9b23
Cable4/0/U0 10   online(d)  2287    0.50  6   0   10.1.4.65       0010.7bed.9b45
Cable4/0/U0 11   online     2809   -0.50  7   0   10.1.4.6        0001.64ff.e47d
Cable4/0/U0 12   online     2812   -0.50  7   0   10.1.4.9        0004.2752.ddd5

次の点に注意してください。

  • ケーブル モデム 0010.7bed.9b23 が、範囲 cm-0010.7bed.9b23 で指定された IP アドレス 10.1.4.66 を取得しています。 このモデムに接続されたコンピュータがあり、このコンピュータは自身の IP アドレスをプール pcs-c4 から取得しています。

  • ケーブル モデム 0010.7bed.9b23 は、異なる QoS を取得しています。

  • ケーブル モデム 0010.7bed.9b45 が、範囲 cm-0010.7bed.9b45 で指定された IP アドレス 10.1.4.65 を取得しています。 このモデムに接続されたコンピュータがあります。 ただし、サービスは拒否されるため、CPE の値は 0 です。

  • 0010.7bed.9b45 のオンライン状態は online(d) であり、これはこのケーブル モデムがオンラインになっているものの、そのケーブル ネットワークへのアクセスが拒否されていることを示しています。

    ケーブル モデムで発行する debug cable mac log verbose コマンドの次の出力を検討してください。

    21:52:16:  78736.550 CMAC_LOG_RESET_RANGING_ABORTED              
    21:52:16:  78736.554 CMAC_LOG_STATE_CHANGE                       reset_interface_state
    21:52:16:  78736.558 CMAC_LOG_STATE_CHANGE                       reset_hardware_state
    21:52:17:  78737.024 CMAC_LOG_STATE_CHANGE                       wait_for_link_up_state
    21:52:17:  78737.028 CMAC_LOG_DRIVER_INIT_IDB_RESET              0x082B9CA8
    21:52:17:  78737.032 CMAC_LOG_LINK_DOWN                          
    21:52:17:  78737.034 CMAC_LOG_LINK_UP                            
    21:52:17:  78737.040 CMAC_LOG_STATE_CHANGE                       ds_channel_scanning_state
    21:52:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to down
    21:52:18:  78738.386 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:19:  78739.698 CMAC_LOG_DS_64QAM_LOCK_ACQUIRED             747000000
    21:52:19:  78739.702 CMAC_LOG_DS_CHANNEL_SCAN_COMPLETED          
    21:52:19:  78739.704 CMAC_LOG_STATE_CHANGE                       wait_ucd_state
    21:52:20:  78740.368 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:22:  78742.396 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:22:  78742.398 CMAC_LOG_ALL_UCDS_FOUND                     
    21:52:22:  78742.402 CMAC_LOG_STATE_CHANGE                       wait_map_state
    21:52:22:  78742.406 CMAC_LOG_FOUND_US_CHANNEL                   1
    21:52:24:  78744.412 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:24:  78744.416 CMAC_LOG_UCD_NEW_US_FREQUENCY               39984000
    21:52:24:  78744.420 CMAC_LOG_SLOT_SIZE_CHANGED                  8
    21:52:24:  78744.500 CMAC_LOG_UCD_UPDATED                        
    21:52:24:  78744.560 CMAC_LOG_MAP_MSG_RCVD                       
    21:52:24:  78744.564 CMAC_LOG_INITIAL_RANGING_MINISLOTS          41
    21:52:24:  78744.566 CMAC_LOG_STATE_CHANGE                       ranging_1_state
    21:52:24:  78744.570 CMAC_LOG_RANGING_OFFSET_SET_TO              9610
    21:52:24:  78744.574 CMAC_LOG_POWER_LEVEL_IS                     55.0  dBmV (commanded)
    21:52:24:  78744.578 CMAC_LOG_STARTING_RANGING                   
    21:52:24:  78744.580 CMAC_LOG_RANGING_BACKOFF_SET                0
    21:52:24:  78744.586 CMAC_LOG_RNG_REQ_QUEUED                     0
    21:52:24:  78744.622 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:24:  78744.626 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:24:  78744.628 CMAC_LOG_RNG_RSP_SID_ASSIGNED               10
    21:52:24:  78744.632 CMAC_LOG_ADJUST_RANGING_OFFSET              2286
    21:52:24:  78744.636 CMAC_LOG_RANGING_OFFSET_SET_TO              11896
    21:52:24:  78744.638 CMAC_LOG_STATE_CHANGE                       ranging_2_state
    21:52:24:  78744.644 CMAC_LOG_RNG_REQ_QUEUED                     10
    21:52:25:  78745.654 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:25:  78745.658 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:25:  78745.660 CMAC_LOG_RANGING_SUCCESS                    
    21:52:25:  78745.680 CMAC_LOG_STATE_CHANGE                       dhcp_state
    21:52:25:  78745.820 CMAC_LOG_DHCP_ASSIGNED_IP_ADDRESS           10.1.4.65
    21:52:25:  78745.824 CMAC_LOG_DHCP_TFTP_SERVER_ADDRESS           10.1.4.1
    21:52:25:  78745.826 CMAC_LOG_DHCP_TOD_SERVER_ADDRESS            10.1.4.1
    21:52:25:  78745.830 CMAC_LOG_DHCP_SET_GATEWAY_ADDRESS           
    21:52:25:  78745.834 CMAC_LOG_DHCP_TZ_OFFSET                     -28800
    21:52:25:  78745.836 CMAC_LOG_DHCP_CONFIG_FILE_NAME              disable.cm
    21:52:25:  78745.840 CMAC_LOG_DHCP_ERROR_ACQUIRING_SEC_SVR_ADDR  
    21:52:25:  78745.846 CMAC_LOG_DHCP_COMPLETE                      
    21:52:25:  78745.968 CMAC_LOG_STATE_CHANGE                       establish_tod_state
    21:52:25:  78745.978 CMAC_LOG_TOD_REQUEST_SENT                   
    21:52:26:  78746.010 CMAC_LOG_TOD_REPLY_RECEIVED                 3192525217
    21:52:26:  78746.018 CMAC_LOG_TOD_COMPLETE                       
    21:52:26:  78746.020 CMAC_LOG_STATE_CHANGE                       security_association_state
    21:52:26:  78746.024 CMAC_LOG_SECURITY_BYPASSED                  
    21:52:26:  78746.028 CMAC_LOG_STATE_CHANGE                       configuration_file_state
    21:52:26:  78746.030 CMAC_LOG_LOADING_CONFIG_FILE                disable.cm
    21:52:26: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to up
    21:52:27:  78747.064 CMAC_LOG_CONFIG_FILE_PROCESS_COMPLETE       
    21:52:27:  78747.066 CMAC_LOG_STATE_CHANGE                       registration_state
    21:52:27:  78747.070 CMAC_LOG_REG_REQ_MSG_QUEUED                 
    21:52:27:  78747.076 CMAC_LOG_REG_REQ_TRANSMITTED                
    21:52:27:  78747.080 CMAC_LOG_REG_RSP_MSG_RCVD                   
    21:52:27:  78747.082 CMAC_LOG_COS_ASSIGNED_SID                   1/10
    21:52:27:  78747.088 CMAC_LOG_RNG_REQ_QUEUED                     10
    21:52:27:  78747.090 CMAC_LOG_NETWORK_ACCESS_DENIED
    21:52:27:  78747.094 CMAC_LOG_REGISTRATION_OK                    
    21:52:27:  78747.096 CMAC_LOG_STATE_CHANGE                       establish_privacy_state
    21:52:27:  78747.100 CMAC_LOG_PRIVACY_NOT_CONFIGURED             
    21:52:27:  78747.102 CMAC_LOG_STATE_CHANGE                       maintenance_state
    21:52:31:  78751.122 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:31:  78751.124 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:37:  78757.164 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:37:  78757.168 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:43:  78763.206 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:43:  78763.210 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:49:  78769.250 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:49:  78769.252 CMAC_LOG_RNG_RSP_MSG_RCVD

    このデバッグ出力から、ネットワーク アクセス(NETWORK_ACCESS)が拒否(DENIED)されていることが分かります。

Ubr7100# show cable modem detail

Interface   SID  MAC address    Max CPE  Concatenation  Rx SNR
Cable1/0/U0 7    0002.1685.b5db 10       yes            33.52
Cable1/0/U0 8    0002.fdfa.0a63 10       yes            33.24
Cable1/0/U0 9    0010.7bed.9b23 1        no             33.29
Cable1/0/U0 10   0010.7bed.9b45 1        no             33.23
Cable1/0/U0 11   0001.64ff.e47d 10       yes            33.20
Cable1/0/U0 12   0004.2752.ddd5 10       yes            33.44

特別な範囲のケーブル モデムの Max CPE が 1 で、他は 10 であることに注意してください。 範囲 platinum.cm の設定を確認すると、10 CPE が指定されています。 一方、範囲 disable.cm には 1 CPE だけが指定されています。 事前設定された DOCSIS コンフィギュレーション ファイル silver.cm にも、CPE は 1 つしか指定されていません。

Ubr7111# show interface cable 1/0 modem 0

SID   Priv bits  Type      State     IP address    method    MAC address
7     00         modem     up        10.1.4.7      dhcp      0002.1685.b5db
8     00         modem     up        10.1.4.10     dhcp      0002.fdfa.0a63
9     00         host      unknown   172.16.29.2   static    00c0.4f97.61c5
9     00         modem     up        10.1.4.66     dhcp      0010.7bed.9b23
10    00         modem     up        10.1.4.65     dhcp      0010.7bed.9b45
11    00         modem     up        10.1.4.6      dhcp      0001.64ff.e47d
12    00         modem     up        10.1.4.9      dhcp      0004.2752.ddd5

ケーブル モデムが正しいレベルのサービスを取得していることを確認するには、show cable qos profile コマンドを発行します。

Ubr7111# show cable qos profile

ID  Prio Max       Guarantee Max        Max   TOS  TOS   Create  B     IP prec.
         upstream  upstream  downstream tx    mask value by      priv  rate
         bandwidth bandwidth bandwidth  burst                    enab  enab
1   0    0         0         0          0     0x0  0x0   cmts(r) no    no
2   0    64000     0         1000000    0     0x0  0x0   cmts(r) no    no
3   7    31200     31200     0          0     0x0  0x0   cmts    yes   no
4   7    87200     87200     0          0     0x0  0x0   cmts    yes   no
5   4    64000     0         512000     0     0x0  0x0   cm      no    no
6   0    1000      0         1600000    0     0x0  0x0   cm      no    no
7   0    128000    10000     10000000   1600  0x0  0x0   cm      no    no
8   0    0         0         0          0     0x0  0x0   mgmt    no    no
10  0    0         0         0          0     0x0  0x0   mgmt    no    no
12  0    0         100000000 0          0     0x0  0x0   mgmt    no    no

QoS ID 7 が platinum.cm の設定に一致していることに注意します。

cable config-file platinum.cm
 service-class 1 max-upstream 128
 service-class 1 guaranteed-upstream 10
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1600
 cpe max 10
 timestamp

同様のことが、disable.cm の DOCSIS 設定でも起きています。

Ubr7111# show ip dhcp binding

IP address       Hardware address        Lease expiration        Type
10.1.4.6         0100.0164.ffe4.7d       Mar 08 2001 07:58 AM    Automatic
10.1.4.7         0100.0216.85b5.db       Mar 08 2001 07:58 AM    Automatic
10.1.4.9         0100.0427.52dd.d5       Mar 08 2001 07:58 AM    Automatic
10.1.4.10        0100.02fd.fa0a.63       Mar 08 2001 08:36 AM    Automatic
10.1.4.65        0100.107b.ed9b.45       Infinite                Manual
10.1.4.66        0100.107b.ed9b.23       Infinite                Manual

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 29243