マルチプロトコル ラベル スイッチング(MPLS) : MPLS

MPLS VPN のマルチキャスト サポートの設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2005 年 8 月 10 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

この文書では、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)VPN に対するマルチキャストのサポートの設定について、設定例と一般的なガイドラインを説明します。 この機能は Cisco IOS で導入されましたか。 ソフトウェア リリース 12.0(23)S and?12.2(13)T。

前提条件

要件

この設定を開始する前に、次の要件が満たされていることを確認してください。

  • サービス プロバイダーでは、Cisco Multicast VPN 機能を使用するために、マルチキャストが可能なコアを用意する必要があります。

使用するコンポーネント

この文書の情報は、Cisco IOS ソフトウェア リリース 12.2(13)T に基づいています。

注: この機能をサポートしているプラットフォームに関する最新情報を得るには、Software Advisor登録ユーザのみ)を使用してください。 この機能をサポートする新しいプラットフォームが追加されると、Software Advisor ではサポートされているプラットフォームのリストが動的に更新されます。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

バックグラウンド情報に関しては、MPLS VPNs の IP Multicast サポートのための Cisco IOS ソフトウェア リリース 12.2(13)T 新しい 機能 ドキュメントを参照して下さい。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

ネットワーク構成図

このドキュメントでは、次の図で示されるネットワーク構成を使用しています。

/image/gif/paws/29220/config_mpls_vpn1.gif

設定

このネットワーク ダイアグラムは、サービス プロバイダーのバックボーンを表しています。 このネットワークは、ルータ R2、R3、および R4 で構成されています。 このバックボーンは、MPLS VPN をサポートするように設定されています。 R2 と R4 は Provider Edge(PE; プロバイダー エッジ)ルータであり、一方 R3 は Provider(P; プロバイダー)ルータです。 R1 と R5 は、Customer Edge(CE; カスタマー エッジ)ルータを表しており、これは同じ VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)のインスタンス(yellow)に属します。

マルチキャストサービスを提供するために、バックボーンはマルチキャストルーティングを実行するために設定する必要があります。 この目的のために選択するマルチキャスト プロトコルは、Protocol Independent Multicast(PIM)になります。そして、R3 は Rendezvous Point(RP; ランデブー ポイント)として設定する必要があります。 R2 と R4 も、VRF yellow に対してマルチキャスト ルーティングを実行するよう設定します。 PIM 希薄/稠密モードは、PE と CE との間のマルチキャスト ルーティング プロトコルとして設定します。 R2 は、VRF yellow に対する RP になるよう設定されています。

マルチキャスト 接続をテストするために、R5 の s0/0 インターフェイスはマルチキャスト グループ 224.2.2.2 に加わるために設定されます。 R1 のループバック アドレスから 224.2.2.2 に ping を送信します。 Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)のエコーはマルチキャスト パケットです。これに対して、ICMP 応答はユニキャスト パケットです。これはこのパケットの IP 宛先アドレスが R1 のループバック アドレスであるためです。

この文書で紹介する設定には、次のものが含まれます。

R1-(CE)
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
!
clock timezone CET 1
ip subnet-zero
no ip domain lookup
!
ip multicast-routing 

!--- Enable multicast routing.

!
!
interface Loopback0
 ip address 100.0.0.1 255.255.255.255
!
interface Serial0/0
 ip address 10.1.0.1 255.255.255.0
 ip pim sparse-dense-mode

!--- PIM sparce-dense mode is used between the PE and CE.
!--- PIM sparce-dense mode is the multicast routing protocol.

 
!
router rip
 version 2
 network 10.0.0.0
 network 100.0.0.0
 no auto-summary
!
ip classless
no ip http server
ip pim bidir-enable
!
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!         
end

R2-(PE)
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
!
clock timezone CET 1
ip subnet-zero
no ip domain lookup
!
ip vrf yellow
 rd 2:200
 route-target export 2:200
 route-target import 2:200
 mdt default 239.1.1.1

!--- Configure the default Multicast Distribution Tree (MDT) 
!--- for VRF yellow.

 mdt data 239.2.2.0 0.0.0.255 threshold 1

!--- Configure the range global addresses for 
!--- data MDTs and the threshold.

ip multicast-routing 

!--- Enable global multicast routing.

ip multicast-routing vrf yellow 

!--- Enable multicast routing in VRF yellow.

ip cef
mpls label protocol ldp
tag-switching tdp router-id Loopback0
!
!
!
interface Loopback0
 ip address 50.0.0.2 255.255.255.255
 ip pim sparse-dense-mode


!--- Multicast needs to be enabled on loopback 
!--- interface. This is used as a source  
!--- for MPBGP sessions between PE routers that participate in MVPN.


!
interface Loopback100
 ip vrf forwarding yellow
 ip address 100.0.0.2 255.255.255.255
 ip pim sparse-dense-mode
!

!--- This router needs to be RP for 
!--- multicast in VRF yellow. Therefore, multicast
!--- needs to be enabled on the interface which is used as RP.


!
interface Serial1/0
 ip vrf forwarding yellow
 ip address 10.1.0.2 255.255.255.0
 ip pim sparse-dense-mode

!--- Multicast is enabled on PE-CE interfaces in VRF.


!         
interface Serial2/0
 ip address 10.2.0.2 255.255.255.0
 ip pim sparse-dense-mode

!--- Service provider core needs to run multicast
!--- to support MVPN services,
!--- so multicast is enabled on PE-P links.


 tag-switching ip        
!         
router ospf 1
 router-id 50.0.0.2
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 50.0.0.0 0.0.0.255 area 0
!
router rip
 version 2
 no auto-summary
 !
 address-family ipv4 vrf yellow
 version 2
 redistribute bgp 1
 network 10.0.0.0
 network 100.0.0.0
 default-metric 5
 no auto-summary
 exit-address-family
!
router bgp 1
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 redistribute rip
 neighbor 50.0.0.4 remote-as 1
 neighbor 50.0.0.4 update-source Loopback0
 neighbor 50.0.0.4 activate
 neighbor 50.0.0.6 remote-as 1
 neighbor 50.0.0.6 update-source Loopback0
 neighbor 50.0.0.6 activate
 no auto-summary
 !
 address-family ipv4 vrf yellow
 redistribute connected
 redistribute rip
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 50.0.0.4 activate
 neighbor 50.0.0.4 send-community extended
 neighbor 50.0.0.6 activate
 neighbor 50.0.0.6 send-community extended
 no auto-summary
 exit-address-family
!         
ip classless
no ip http server
ip pim bidir-enable
ip pim vrf yellow send-rp-announce Loopback100 scope 100
ip pim vrf yellow send-rp-discovery Loopback100 scope 100

!--- Configure auto-RP. The R2's loopback 
!--- 100 is the RP in VRF yellow.

!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

R3-(P)
version 12.2 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname R3 
! 
! 
clock timezone CET 1 
ip subnet-zero 
! 
ip multicast-routing  

!--- Enable global multicast routing.
 
ip cef 
mpls label protocol ldp 
tag-switching tdp router-id Loopback0 
! 
! 
! 
interface Loopback0 
 ip address 50.0.0.3 255.255.255.255 
 ip pim sparse-dense-mode 
! 
! 
interface Serial1/0 
 ip address 10.2.0.3 255.255.255.0 
 ip pim sparse-dense-mode

!--- Enable multicast on links to PE routers 
!--- which have MVPNs configured.

 
 tag-switching ip 
! 
interface Serial2/0 
 ip address 10.3.0.3 255.255.255.0 
 ip pim sparse-dense-mode 
 tag-switching ip 
! 
router ospf 1 
 router-id 50.0.0.3 
 log-adjacency-changes 
 network 10.0.0.0 0.255.255.255 area 0 
 network 50.0.0.0 0.0.0.255 area 0 
! 
ip classless 
no ip http server 
ip pim bidir-enable 
ip pim send-rp-announce Loopback0 scope 100 
ip pim send-rp-discovery Loopback0 scope 100 

!--- R3 is configured to announce itself as 
!--- the RP through auto-RP.
 
! 
! 
! 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 login  
! 
end

R4-(PE)
version 12.2 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname R4 
! 
! 
clock timezone CET 1 
ip subnet-zero 
no ip domain lookup 
! 
ip vrf yellow 
 rd 2:200 
 route-target export 2:200 
 route-target import 2:200 
 mdt default 239.1.1.1 

!--- Configure the default MDT address.
 
 mdt data 238.2.2.0 0.0.0.255 threshold 1 

!--- Configure the data MDT range and threshold.
 
! 
ip multicast-routing  

!--- Enable global multicast routing.
 
ip multicast-routing vrf yellow  

!--- Enable multicast routing in VRF yellow.
 
ip cef 
mpls label protocol ldp 
tag-switching tdp router-id Loopback0 
! 
! 
! 
interface Loopback0 
 ip address 50.0.0.4 255.255.255.255 
 ip pim sparse-dense-mode 
! 
interface Loopback100 
 ip vrf forwarding yellow 
 ip address 100.0.0.4 255.255.255.255 
 ip pim sparse-dense-mode 
! 
interface Serial1/0 
 ip address 10.3.0.4 255.255.255.0 
 ip pim sparse-dense-mode 
 tag-switching ip 
! 
interface Serial2/0 
 ip vrf forwarding yellow 
 ip address 10.4.0.4 255.255.255.0 
 ip pim sparse-dense-mode 

!--- Enable the PIM toward the CE.
 
! 
router ospf 1 
 router-id 50.0.0.4 
 log-adjacency-changes 
 network 10.0.0.0 0.255.255.255 area 0 
 network 50.0.0.0 0.0.0.255 area 0 
! 
router rip 
 version 2 
 no auto-summary 
 ! 
 address-family ipv4 vrf yellow 
 version 2 
 redistribute bgp 1 
 network 10.0.0.0 
 network 100.0.0.0 
 default-metric 5 
 no auto-summary 
 exit-address-family 
! 
router bgp 1 
 no synchronization 
 no bgp default ipv4-unicast 
 bgp log-neighbor-changes 
 redistribute rip 
 neighbor 50.0.0.2 remote-as 1 
 neighbor 50.0.0.2 update-source Loopback0 
 neighbor 50.0.0.2 activate 
 no auto-summary 
 ! 
 address-family ipv4 vrf yellow 
 redistribute connected 
 redistribute rip 
 no auto-summary 
 no synchronization 
 exit-address-family 
 ! 
 address-family vpnv4 
 neighbor 50.0.0.2 activate 
 neighbor 50.0.0.2 send-community extended 
 no auto-summary 
 exit-address-family 
! 
ip classless 
no ip http server 
ip pim bidir-enable 
! 
! 
! 
! 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 login 
! 
end

R5-(CE)
version 12.2 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname R5 
! 
! 
clock timezone CET 1 
ip subnet-zero 
no ip domain lookup 
! 
ip multicast-routing  

!--- Enable global multicast routing in the CE.
 
! 
! 
interface Loopback0 
 ip address 100.0.0.5 255.255.255.255 
! 
interface Serial0/0 
 ip address 10.4.0.5 255.255.255.0 
 ip pim sparse-dense-mode 
 ip igmp join-group 224.2.2.2 
! 
router rip 
 version 2 
 network 10.0.0.0 
 network 100.0.0.0 
 no auto-summary 
! 
ip classless 
no ip http server 
ip pim bidir-enable 
! 
! 
! 
! 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 login 
!          
end

設計ヒント

  • MPLS VPNs (MVPN)のためのマルチキャストは VPN 設定の上に設定されます。 MPLS VPN ネットワークは慎重に設計する必要があります。MPLS VPN ネットワークの推奨事項が最初に守られる必要があります。

  • サービス プロバイダーのコアは、ネイティブなマルチキャスト サービス用に設定する必要があります。 コアは、PIM Sparse mode(PIM-SM; PIM 希薄モード)、Source specific multicast(PIM-SSM)、または Bidirectional PIM(PIM-BIDIR; 双方向 PIM)用に設定する必要があります。 稠密モードPIM (PIM-DM)は MVPN コンフィギュレーションのコア プロトコルとしてサポートされません。 プロバイダのコアのサポートされているプロトコルのミックスを設定することは可能性のあるです。 これは、ある PIM モードによって一部のマルチキャスト グループが処理され、さらに他の PIM モードによって他のグループが処理されている場合に設定できます。

  • すべてのマルチキャストプロトコルはマルチキャスト VRF の内でサポートされます。 つまり、マルチキャスト VRF 内では、PIM-SM、PIM-SSM、PIM-BIDIR の他に、MSDP および PIM-DM も使用できます。

  • MVPN サービスは、VRF ごとに別個に追加できます。 つまり、1 つの PE ルータに、マルチキャストが有効な VRF と、ユニキャストだけの VRF の両方を設定できます。

  • マルチキャストのために単一 ユニキャスト VRF のすべてのサイトが設定されてはなりません。 マルチキャストが有効に ならないところいくつかのサイトです(および MVPN PE ルータのインターフェイスを)持っていることは可能性のある。 ルータで、マルチキャスト以外が有効になっているインターフェイスを指すような計算が行われないようにする必要があります。 このような計算が行われると、マルチキャスト転送が失敗します。

  • 複数の VRF は同じ MVPN マルチキャスト ドメインに属することができます。 IP アドレッシングはマルチキャスト ドメインの内でユニークである必要があります。 マルチキャスト ドメイン間のまたはグローバル な マルチキャストルーティングテーブルへのルーティングやパケットのリークは現在 可能性のあるではないです。

  • MDT デフォルト 設定は MVPN がはたらくことができるがように必須です。 データ MDT を設定することはオプションです。 それは 1 つを設定することを選択する場合強く推奨されていますデータ MDT のためのしきい値を設定 するために。

  • デフォルトの MDT の IP アドレスによって、VRF が属するマルチキャスト ドメインが決まります。 したがって、複数の VRF に同じデフォルト MDT アドレスを割り当てることが可能です。 ただし、それらはその間のマルチキャスト パケットを共有し、マルチキャスト ドメインの他の必要条件を観察する必要があります(ユニークな IP アドレッシング方式のような)。

  • データ MDT はかもしれましたりまたは異なる PE ルータの IP アドレスの同じ範囲で設定されないかもしれません。 これは、プロバイダーのコアで使用されている PIM モードによって変わります。 サービスプロバイダー コアが希薄モードPIM を使用している場合、各 PE ルータはデータ MDT グループのために IP アドレスのユニークな範囲を使用する必要があります。 サービスプロバイダー コアが Source-Specific Multicast を使用している場合、すべての PE ルータは各マルチキャスト ドメインのデータ MDT のための IP アドレスの同じ範囲で設定されるかもしれません。

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show ip igmp groups ルータに直接接続され、Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)によって学習されたマルチキャスト グループと受信装置の情報を表示します。

  • show ip pim mdt bgp MDT デフォルト グループの Route Distinguisher(RD; ルート識別子)の Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)によるアドバタイズメントの詳細を表示します。

  • IP PIM VRF が <vrf-name> mdt send — ルータが規定 された VRF で作ったデータ MDT アドバタイズメントを表示することを示して下さい

  • IP PIM VRF <vrf-name> mdt レシーブを示して下さい—規定 された VRF のルータによって受け取ったデータ MDT アドバタイズメントを表示する。

  • show ip mroute プロバイダーのコアにある IP マルチキャスト ルーティング テーブルの内容を表示します。

  • show ip mroute VRF <vrf-name> —クライアントの VRF のマルチキャストルーティングテーブルを表示する。

設定がきちんと機能していることを確認するためにこれらのステップを完了して下さい。

  1. PE がデフォルト MDT トンネルのための IGMPグループに加わったことを確認して下さい。

    デフォルトmdt コマンドが VRF 設定の下で発行された後それが設定されれば、PE はかもしれませんデフォルト MDT グループに加入しないために。 ループバックを設定したら、この問題を解決するために、VRF から mdt コマンドをいったん削除して元に戻します。

    • PE-R2 に関しては、show ip igmp groups コマンドを発行して下さい。

      IGMP Connected Group Membership
      Group Address  Interface   Uptime     Expires   Last Reporter
      224.0.1.40     Serial2/0   02:21:23   stopped   10.2.0.2
      239.1.1.1      Loopback0   02:36:59   stopped   0.0.0.0
    • PE-R4 に関しては、show ip igmp groups コマンドを発行して下さい。

      IGMP Connected Group Membership 
      Group Address  Interface    Uptime    Expires   Last Reporter
      224.0.1.40     Loopback0    02:51:48  00:02:39  50.0.0.4
      239.1.1.2      Loopback0    02:51:45  stopped   0.0.0.0
      239.1.1.1      Loopback0    02:51:45  stopped   0.0.0.0
      239.2.2.0      Loopback0    01:40:03  stopped   0.0.0.0 
  2. 受け取った各 PE があるように BGP アドバタイズメントを確認して下さい。

    注: この例に関しては、ピア PE PE-R2 および PE-R4 からソースをたどられる MDTs をチェックして下さい。

    • PE-R2 に関しては、提示 IP PIM mdt bgp コマンドを発行して下さい。

      MDT-default group 239.1.1.1 
      rid: 50.0.0.4 next_hop: 50.0.0.4 
       
      WAVL tree nodes
      
      MDT-default: 239.1.1.1  Tunnel0     source-interface: Loopback0
    • PE-R4 に関しては提示 IP PIM mdt bgp コマンドを発行して下さい

      MDT-default group 239.1.1.1 
      rid: 50.0.0.2 next_hop: 50.0.0.2 
       
      WAVL tree nodes
      
      MDT-default: 239.1.1.1  Tunnel0     source-interface: Loopback0 
      MDT-data   : 239.2.2.0  Tunnel0     source-interface: Loopback0 
  3. データ MDTs をチェックして下さい。

    注: この例に関しては、PE-R2 および PE-R4 によって供給されるか、または加入されるデータ MDT をチェックして下さい。

    • PE-R2 に関しては、提示 IP PIM VRF 黄色 mdt send コマンドを発行して下さい。

      MDT-data send list for VRF: yellow 
        (source, group)                     MDT-data group      ref_count 
        (100.0.0.1, 224.2.2.2)              239.2.2.0           1 
    • PE-R2 に関しては、提示 IP PIM VRF 黄色 mdt レシーブ コマンドを発行して下さい。

      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group
      Joined MDT-data groups for VRF: yellow 
        group: 239.2.2.0 source: 0.0.0.0 ref_count: 1 
    • デフォルト MDT をグローバル な マルチキャストルーティングテーブルの中から探して下さい。

      注: この情報に注意して下さい:

      1. 発信インターフェイスリストは PE の MVRF 黄色です。

      2. P ルータはこのグループを通常のマルチキャスト グループと見なしています。

      3. 各 PE はデフォルト MDT におけるソースで、PE ルータにだけあります。

      4. New フラグは、Z、これがマルチキャスト トンネルであることを示します。

    • PE-R2 に関しては、show ip mroute 239.1.1.1 コマンドを発行して下さい。

      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 239.1.1.1), 02:37:16/stopped, RP 50.0.0.3, flags: SJCFZ 
        Incoming interface: Serial2/0, RPF nbr 10.2.0.3 
        Outgoing interface list: 
          MVRF yellow, Forward/Sparse-Dense, 02:21:26/00:00:28 
      
      (50.0.0.2, 239.1.1.1), 02:37:12/00:03:29, flags: FTZ 
        Incoming interface: Loopback0, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Serial2/0, Forward/Sparse-Dense, 02:36:09/00:02:33 
      (
      50.0.0.4, 239.1.1.1), 02:36:02/00:02:59, flags: JTZ 
        Incoming interface: Serial2/0, RPF nbr 10.2.0.3 
        Outgoing interface list: 
          MVRF yellow, Forward/Sparse-Dense, 02:21:26/00:00:28
    • P-R3 に関しては、show ip mroute 239.1.1.1 コマンドを発行して下さい。

       
      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 239.1.1.1), 02:50:24/stopped, RP 50.0.0.3, flags: S 
        Incoming interface: Null, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Serial1/0, Forward/Sparse-Dense, 02:34:41/00:03:16 
          Serial2/0, Forward/Sparse-Dense, 02:49:24/00:02:37 
      
      (50.0.0.2, 239.1.1.1), 02:49:56/00:03:23, flags: T 
        Incoming interface: Serial1/0, RPF nbr 10.2.0.2 
        Outgoing interface list: 
          Serial2/0, Forward/Sparse-Dense, 02:49:24/00:02:37 
      
      (50.0.0.4, 239.1.1.1), 02:49:47/00:03:23, flags: T 
        Incoming interface: Serial2/0, RPF nbr 10.3.0.4 
        Outgoing interface list: 
          Serial1/0, Forward/Sparse-Dense, 02:34:41/00:03:16 
    • PE-R4 に関しては、show ip mroute 239.1.1.1 コマンドを発行して下さい。

      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 239.1.1.1), 02:51:06/stopped, RP 50.0.0.3, flags: SJCFZ 
        Incoming interface: Serial1/0, RPF nbr 10.3.0.3 
        Outgoing interface list: 
          MVRF yellow, Forward/Sparse-Dense, 02:51:06/00:00:48 
      
      (50.0.0.2, 239.1.1.1), 02:50:06/00:02:58, flags: JTZ 
        Incoming interface: Serial1/0, RPF nbr 10.3.0.3 
        Outgoing interface list: 
          MVRF yellow, Forward/Sparse-Dense, 02:50:06/00:00:48 
      
      (50.0.0.4, 239.1.1.1), 02:51:00/00:03:10, flags: FTZ 
        Incoming interface: Loopback0, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Serial1/0, Forward/Sparse-Dense, 02:35:24/00:03:00 
  4. データ MDTs をグローバル な マルチキャストルーティングテーブルの中から探して下さい。

    注: PE-R2 に関しては、発信インターフェイスが tunnel0 であることに注意して下さい。

    • ソースが(VRF 側)見つけられる PE-R2 に関しては show ip mroute VRF 黄色 224.2.2.2 コマンドを発行して下さい。

      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 224.2.2.2), 2d01h/stopped, RP 100.0.0.2, flags: S 
        Incoming interface: Null, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Tunnel0, Forward/Sparse-Dense, 2d01h/00:02:34 
      
      (100.0.0.1, 224.2.2.2), 00:05:32/00:03:26, flags: Ty 
        Incoming interface: Serial1/0, RPF nbr 10.1.0.1 
        Outgoing interface list: 
          Tunnel0, Forward/Sparse-Dense, 00:05:37/00:02:34
    • ソースが(グローバル な マルチキャストルート)見つけられる PE-R2 に関しては show ip mroute 239.2.2.0 コマンドを発行して下さい。

      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 239.2.2.0), 02:13:27/stopped, RP 50.0.0.3, flags: SJPFZ 
        Incoming interface: Serial2/0, RPF nbr 10.2.0.3 
        Outgoing interface list: Null 
      
      (50.0.0.2, 239.2.2.0), 02:13:27/00:03:22, flags: FTZ 
        Incoming interface: Loopback0, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Serial2/0, Forward/Sparse-Dense, 02:13:27/00:03:26

    注: マルチキャストの送信元が接続されている PE ルータだけが、データ MDT グループ アドレスのマルチキャスト トラフィックの発信元として表示されます。

トラブルシューティング

  • PE ルータがダイナミック トンネル インターフェイスを通して PIM 隣接関係を確立したことを確認する提示 IP PIM VRF neighbor コマンドを発行して下さい。 彼らが場合、デフォルト MDT は正しく動作します。

  • デフォルト MDT が機能しない場合、MVPN に加わっているローカルルータによってリモート PE ルータのループバックが知られていることを確認する提示 IP PIM mdt bgp コマンドを発行して下さい。 そうでない場合、PIM が MP BGPセッションのソースとして使用されるループバックインターフェイスで有効に なることを確認して下さい

  • PE ルータ間のマルチキャストを渡すために SP コアが正しく設定されることを確認して下さい。 テストの目的で 1 PE ルータのループバックインターフェイスの ip igmp join-group を設定するかもしれないし、別の PE ルータのループバックからソースをたどられる PING をマルチキャストします。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 29220