アプリケーション ネットワーキング サービス : Cisco LocalDirector 400 シリーズ

LocalDirector 4.1.1 のコンテンツ ロード バランシングのトラブルシューティング

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2005 年 1 月 17 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


Cisco は Cisco LocalDirector のための終りの販売をアナウンスしました。 詳細については、LocalDirector 400 シリーズ 廃止および終りの販売注意および製品速報参照して下さい。


目次


概要

この文書では、Cisco LocalDirector 416(バージョン 4.1.1)で使用できるコンテンツ ロード バランシング機能のトラブルシューティングを行うための、設定例と追加コマンドについて説明します。

注: LocalDirector のコードの最新リリースでは、コンテンツ ロード バランシングに関するいくつかの問題が解決されています。 バージョン 4.2.4 または それ 以上を使用することが強く推奨されます。 詳細については Software Download ページ登録ユーザのみ)を参照して下さい。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

この設定は、次のバージョンのソフトウェアとハードウェアを使用して開発、テストされています。

  • Windows 2000 サーバ、Windows NT 4.0 サービスパック 4.0、および Windows 98 を実行していてクライアントが LocalDirector 416 (バージョン 4.1.1)、

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

ネットワーク構成図

/image/gif/paws/28847/load_balancing.jpg

設定

クライアントの /index.htm ページに対する要求は、サーバ 172.18.124.205 または 172.18.124.207 に送信されます。 /rtp/local-director に関する get 要求は、サーバ 172.18.124.101 に送信されます。 その他のすべての要求は 172.18.124.206 に送信されます。

LocalDirector 416(バージョン 4.1.1)
Current configuration:
 syslog output 20.3
 no syslog console
 enable password 000000000000000000000000000000 encrypted
 hostname 38-ld416
 no shutdown ethernet 0
 no shutdown ethernet 1
 no shutdown ethernet 2
 interface ethernet 0 auto
 interface ethernet 1 auto
 interface ethernet 2 auto
 mtu 0 1500
 mtu 1 1500
 mtu 2 1500
 multiring all
 no secure  0
 no secure  1
 no secure  2
 ping-allow 0
 ping-allow 1
 no ping-allow 2
 ip address 172.18.124.209 255.255.255.0
 route 0.0.0.0 0.0.0.0 172.18.124.1 1
 arp timeout 30
 no rip passive
 rip version 1
 failover ip address 0.0.0.0
 no failover
 failover hellotime 30
 password cisco
 snmp-server enable traps
 snmp-server community public
 no snmp-server contact
 no snmp-server location
 no dns-boomerang enable
 content-rule nsteam depth 1024 "/index*.htm*"
 content-rule jahrule depth 1024 "/rtp/local-director/*"
 virtual 172.18.124.219:80:0:tcp:jahrule is
 virtual 172.18.124.219:80:0:tcp is
 virtual 172.18.124.219:80:0:tcp:nsteam is
 service 172.18.124.219:80:0:tcp clb-close
 real 172.18.124.205:80:0:tcp is
 real 172.18.124.101:80:0:tcp is
 real 172.18.124.206:80:0:tcp is
 real 172.18.124.207:80:0:tcp is
 bind 172.18.124.219:80:0:tcp:jahrule 172.18.124.101:80:0:tcp
 bind 172.18.124.219:80:0:tcp 172.18.124.206:80:0:tcp
 bind 172.18.124.219:80:0:tcp:nsteam 172.18.124.205:80:0:tcp
 bind 172.18.124.219:80:0:tcp:nsteam 172.18.124.207:80:0:tcp
end

show コマンドの出力例

show real

「実際の」サーバのステータスを確認します。

LocalDirector# show real
  Real Machines:  
                                                       No Answer  TCP Reset   DataIn   Machine

                            Connect  State Thresh   Reassigns  Reassigns   Conns  
 172.18.124.205:80:0:tcp       0      IS      8         0          0         0
 172.18.124.101:80:0:tcp       0      IS      8         0          0         0
 172.18.124.206:80:0:tcp       0      IS      8         0          0         0
 172.18.124.207:80:0:tcp       0      IS      8         0          0         0

show server

サービスの設定を確認します。

LocalDirector# show service
  Virtual Machine(s)              Service
 172.18.124.219:80:0:tcp         clb-close

show rule

ルールを表示します。

LocalDirector# show rule
  Name            Depth           Content-String
  nsteam          1024            "/index*.htm*"
  jahrule         1024            "/rtp/local-director/*"

特定のルールを表示します。

LocalDirector# show rule jahrule

  Name            Depth           Content-String
  jahrule         1024            "/rtp/local-director/*"

show bind

バインディングを確認します。

LocalDirector# show bind

 Virtual Machine(s)                      Real Machines/Urls
 172.18.124.219:80:0:tcp:jahrule(IS)
 172.18.124.101:80:0:tcp (IS)
 172.18.124.219:80:0:tcp (IS)
 172.18.124.206:80:0:tcp (IS)
 172.18.124.219:80:0:tcp:nsteam(IS)
 172.18.124.205:80:0:tcp (IS)
 172.18.124.207:80:0:tcp (IS)

ルールの編集

  1. no bind コマンドを使用してアンバインドを行います。

  2. no-inservice コマンドを使用して、仮想サーバを無効にします。

  3. no virtual コマンドを使用して、仮想サーバを削除します。

  4. no rule コマンドを入力してルールを編集します。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 28847