アプリケーション ネットワーキング サービス : Cisco Application and Content Networking System(ACNS)ソフトウェア

WCCP を使用する逆プロキシキャッシングに対するキャッシュエンジンの設定方法

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック



目次


概要

ここでは、Web Cache Coordination Protocol(WCCP)を使用して逆プロキシ キャッシングに対してシスコのキャッシュ エンジンを設定する方法を説明します。

ハードウェアおよびソフトウェアのバージョン

この設定の作成とテストは、次のソフトウェアとハードウェアのバージョンで行われています。

  • クリアされたコンフィギュレーションと Cisco IOS ソフトウェア リリース 2.3 および ACNS バージョン 4.0 をおよびラボ 環境の ACNS 5.0 実行する Cisco Cache Engine 560。

  • Cisco IOS® ソフトウェア リリース 12.1(2)を実行する Cisco 2600 ルータ。
このドキュメントにある情報は、研究環境内の機器を 使用して作成されました。 デバイスは、すべてクリア(デフォルト)設定で 起動しています。 実際にネットワークで使用する前に、予想されるコマンドによる 影響について理解しておいてください。

ネットワーク図


設定

Cache Engine 560 (キャッシュソフトウェア リリース 2.3 か ACNS ソフトウェア リリース 4.0 または 5.0)
Current configuration:
!
!
user add admin uid 0 
password 1 "eeSdy9dcy" 
capability admin-access
!
!
!
hostname ce
!
interface ethernet 0
 ip address 10.0.0.2 255.255.255.0
!--- Important: If you configure the Cache Engine
!--- with a private address, it must get translated
!--- to a public address.
 ip broadcast-address 10.0.0.255 exit ! interface ethernet 1 exit ! ip default-gateway 10.0.0.1 ip name-server 171.70.168.183 ip domain-name cisco.com ip route 0.0.0.0 0.0.0.0 10.0.0.1 cron file /local/etc/crontab ! wccp router-list 1 10.0.0.1 wccp reverse-proxy router-list-num 1 wccp version 2 ! authentication login local enable authentication configuration local enable rule no-cache url-regex .*cgi-bin.* rule no-cache url-regex .*aw-cgi.* ! !

Cisco 2600 ルータ(Cisco IOS ソフトウェア リリース 12.1[2])
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2611-5
!
enable secret 5 $1$9VQ.$BTPbq8xlE2dsKwKPDDmpL/
!
!
ip subnet-zero
ip wccp 99
!
!
interface Ethernet0/0
 description Interface to the Internet 
 ip address 172.17.63.194 255.255.255.192
 no ip redirects
!
interface Serial0/0
 no ip address
 no ip mroute-cache
 shutdown
!
interface Ethernet0/1
 ip address 10.0.0.1 255.255.255.0
!
interface Ethernet1/0
 ip address 10.1.0.1 255.255.255.0
 ip wccp 99 redirect out
!
interface Ethernet1/1
 no ip address
 shutdown
 full-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.63.193
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

debug コマンドと show コマンド

debug コマンドを使用する前に、『debug コマンドに関する重要な情報』を参照してください。

キャッシュ エンジンの debug および show コマンドは次のとおりです。

  • show wccp cache - WCCP CE 情報を示して下さい
  • show wccp flows - WCCP パケットフローを示して下さい
  • show wccp routers - WCCP ルータ リストを表示して下さい
  • show wccp services -設定される Show wccp services
  • show wccp slowstart - WCCP に遅い開始するを表示して下さい
  • show wccp status -ステータスを実行する WCCP を示して下さい
  • show statistics http savings - HTTP セーブ統計量を表示する
  • デバッグ wccp 全 WCCP はすべてのデバッグをつけます
  • debug wccp events - WCCP イベント
  • debug wccp packets - WCCP パケット関連の情報
ルータの debug および show コマンドは次のとおりです 。
  • show ip wccp 99 detail -このコマンドはサービス グループのための Cache Engine および WCCP ルータ統計情報を表示するものです。
  • show ip wccp 99 view -サービス グループ意見情報
  • debug ip wccp events - WCCP イベント
  • debug ip wccp packets - WCCP パケット関連の情報

確認

逆プロキシ キャッシングがこれらのコマンドを使用していることを確認して下さい。

WCCP キャッシュ/Content Engine ステータスをチェックするためにこのコマンドを発行して下さい:

 
router#sh ip wccp 99 detail 
WCCP Cache-Engine information: 
       IP Address:            10.0.0.2 
       Protocol Version:      2.0 
       State:                 Usable                              
	   !--- This cache is active.
       Initial Hash Info:     00000000000000000000000000000000 
                              00000000000000000000000000000000 
       Assigned Hash Info:    FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF 
                              FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF 
       Hash Allotment:        256 (100.00%) 
       Packets Redirected:    93 
       Connect Time:          00:15:27

ルータの WCCP 透過的な 反転 リダイレクションをチェックするためにこのコマンドを発行して下さい:

 
router#sh ip wccp 99 
Global WCCP information: 
    Router information: 
        Router Identifier:                   172.17.63.194 
        Protocol Version:                    2.0 
    Service Identifier: 99 
        Number of Cache Engines:             1 
        Number of routers:                   1 
        Total Packets Redirected:            93                   
		!--- The router is redirecting.
        Redirect access-list:                -none- 
        Total Packets Denied Redirect:       0 
        Total Packets Unassigned:            0 
        Group access-list:                   -none- 
        Total Messages Denied to Group:      0 
        Total Authentication failures:       0


キャッシュ/Content Engine の HTTP 統計情報をチェックするためにこのコマンドを発行して下さい:

 
cache#sh statistic http request 
                              Statistics - Requests 
                                                Total             % of Requests 
                            --------------------------------------------------- 
     Total Received Requests:                      23                         - 
              Forced Reloads:                       2                       8.7 
               Client Errors:                       0                       0.0 
               Server Errors:                       0                       0.0 
         URL Blocked (Reset):                       0                       0.0 
                 URL Blocked:                       0                       0.0 
      Sent to Outgoing Proxy:                       0                       0.0 
Failures from Outgoing Proxy:                       0                       0.0 
Excluded from Outgoing Proxy:                       0                       0.0 
             ICP Client Hits:                       0                       0.0 
             ICP Server Hits:                       0                       0.0 
               If-Range Hits:                       0                       0.0 
           HTTP 0.9 Requests:                       0                       0.0 
           HTTP 1.0 Requests:                       0                       0.0 
           HTTP 1.1 Requests:                      23                     100.0 
       HTTP Unknown Requests:                       0                       0.0 
           Non HTTP Requests:                       0                       0.0 
          Non HTTP Responses:                       0                       0.0 
      Chunked HTTP Responses:                       0                       0.0 
        Http Miss Due To DNS:                       0                       0.0 
     Http Deletes Due To DNS:                       0                       0.0 
  Objects cached for min ttl:                       4                      17.4

要求のキャッシングを確認するためにこのコマンドを発行して下さい:

 
cache#sh stat http sav 
                         Statistics - Savings 
                        Requests                          Bytes 
         ----------------------------------------------------------- 
  Total:                      23                          16481 
   Hits:                       6                           2205 
   Miss:                      17                          14276 
Savings:                    25.0 %                         13.4 %

コマンドの概要

これらの Cache engine コマンドはこの設定で使用されました。
  • wccp バージョン{1 | 2}
  • wccp router-list number ip-address
  • wccp router-list-num 番号
これらの router コマンドはこの設定で使用されました。
  • IP wccp {web-cache | サービス番号}
  • IP wccp {web-cache | サービス番号}リダイレクト
  • IP wccp バージョン 2


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報



Document ID: 28832