ダイヤルとアクセス : 総合デジタル通信網(ISDN)、個別線信号方式(CAS)

CiscoルータでADTRAN ターミナル・アダプタを使用する方法

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2005 年 9 月 9 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

ADTRAN ISDN ターミナル アダプタ(TA)を使用すると、Basic Rate Interface(BRI; 基本速度インターフェイス)を使用せずに、ルータへの BRI 接続を実現できます。 (シリアル ポートに接続されている)TA では、BRI コールを終端して、データを同期データ ストリームとしてルータに送信します。

ドキュメント アウトライン Ciscoルータを使用する方法を ADTRAN ISU™ TA にこの。 続行する前に ADTRAN の ウェッブサイトの製品マニュアルを参照することをleavingcisco.com 推奨します。

前提条件

要件

BRI 回線が正常に動作していることを確認します。 この構成での展開の前に、BRI ポートが備わったルータの回線を使用して、回線をテストできます。 また、ピア デバイスの検証とテストを行い、正常に機能することを確認します。

一部のアプリケーションでは、ADTRAN ISU で同期 Multilink PPP(MPPP; マルチリンク PPP)がサポートされている必要があります。 同期 MP がサポートされている ISU は、ISU Express(部品番号 1200.081L5、1200.081L6、および 1202.081 L6)、ISU 2x64(1200.051L1 および 1200.051L2)、および第 2 世代 ISU 128(1202.029L2 および 1202.029L3)です。

Cisco ルータで MPPP を使用するには、ISU のソフトウェア リビジョンが最新のものである必要があります。 製品ごとに最低限必要なソフトウェア リビジョンを次の表に示します。

ユニット 部品番号 ソフトウェア リビジョン
ISU 128 1202.029 E.00
ISU 2x64 1200.051 D.00 または G.00
ISU Express L6 1200.081L6 K.28
ISU Express L6 1202.081L6 D.43

要件は変更される場合がありますので、『Cisco ルータで ADTRAN ターミナル アダプタを使用する方法』 でファームウェアの要件を確認してください。leavingcisco.com

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • 同期シリアル インターフェイスを搭載しているルータ。 シリアル インターフェイスは、内蔵されているか、WIC/ネットワーク モジュールに搭載されています。

  • Cisco IOS がありませんか。 この設定のためのソフトウェア制限事項。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

ダイヤリング方式

TA でダイヤルを開始する方式には、次の 3 つがあります。

  • V.25 または V.25bis ダイヤリング

  • Data Terminal Ready(DTR; データ ターミナル レディ)ダイヤリング

  • キーパッド ダイヤル

V.25 または V.25bis ダイヤリング

この方式を使用すると、ルータから TA に電話番号が送信されます。 この方式により、ルータは ISDN コールの発信と受信ができます。 V.25 または V.25bis ダイヤリングを有効にするには、ルータ インターフェイスで dialer in-band コマンドを設定する必要があります。 次に、例を示します。

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer in-band
   dialer idle-timeout 300
   dialer map ip 172.25.254.98 name Remote broadcast 5551212&5551213
   ppp authentication chap
   dialer-group 1

ISU を V.25bis ダイヤリングおよび MPPP に合わせて設定する必要があります。

ルータでは、対象トラフィックを受信すると、DTR と Request To Send(RTS; 送信要求)を生成します。これらの要求を受けて、TA は 1 つめの B チャネルでダイヤルを開始します。 ただし、ルータからは、TA に 2 つめの B チャネルの接続を開始するようには指示されません。 この場合、ADTRAN は、2 つめの B チャネルをダイヤルするようにプログラミングされているか、送信先の 2 つ目の番号が同じダイヤラ ストリング内に含まれている必要があります。 ルータのシリアル インターフェイスは、ポイントツーポイント インターフェイスであるため、ADTRAN で設定されている B チャネルの番号は認識できません。

ルータで ppp multilink コマンドを設定しないでください。実際にマルチリンク接続を処理しているのは TA で、ルータでは TA からの同期ストリーム処理だけが必要です。

(BRI インターフェイスで行うように)複数のダイヤラ マップを使用しても、このマルチリンクの問題は解決しません。

DTR ダイヤル

この方式を使用すると、ルータは、特定の 1 つの電話番号に対してコールを発信できますが、着信コールは受信できません。 この方式では、リモート サイトの電話番号が TA のメモリに保存されている必要があります。 TA は、DTR のアップを検知すると、TA に保存されている番号にダイヤルします。 これには、シリアル インターフェイスで dialer dtr コマンドを実行する必要があります。 次に、例を示します。

例:

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer dtr
   dialer idle-timeout 300
   ppp authentication chap

ADTRAN は DTR ダイヤリング、マルチリンク PPP などに合わせて設定され、宛先の電話番号がプログラムされている必要があります。

両方の B チャネルが ADTRAN からダイヤルされます。

キーパッドダイヤル

TA によっては、キーパッドが搭載されていて、TA から直接インタラクティブにダイヤルできるものがあります。 この方式では、接続時に、そのつどユーザが TA のキーパッドから番号を入力してダイヤルする必要があります。 この方式は、主に接続を確認するテストで使用します。 必要なルータの設定は、次のとおりです。

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer in-band
   dialer idle-timeout 300
   dialer map ip 172.25.254.98 name Remote broadcast
   ppp authentication chap

配線

ルータのシリアル ポートを TA に接続するには、(片方が DB-60 シリアル ポートまたはスマート シリアルの)V.35 DTE ケーブルを使用してください。 ケーブルのサンプルを次の図に示します。

adtran_ta1.gif

TA に RS-232 ポートしか搭載されていない場合は、上記のケーブルに加えて、V.35 to RS-232(DB-25)の変換ケーブルが必要です。 または、DB-60-to-DB-25 RS-232 ケーブル 1 本でも代用できます。

ケーブル接続に関する詳細についてはシリアルケーブルの製品カタログ セクションを参照して下さい。

V.25bis を使用した設定例

このセクションでは、V.25bis を使用した設定例を紹介します。

/image/gif/paws/28080/adtran_ta2.gif

ADTRAN ISUの設定

このセクションでは、ADTRAN ISU の設定に関するヒントを紹介します。 ただし、TA を、leavingcisco.com 機能性のような設定する前に ADTRAN の ウェッブサイトを、機能参照すればコンフィギュレーションパラメータは変更するかもしれません。

  1. ADTRAN の TA を PC に接続します。 これにより、TA のルータへの接続に先立って、TA にアクセスして各種パラメータを設定できます。

    「Terminal」と記されている RJ-45-to-DB-9 アダプタを PC の COM ポート(通信ポート)に接続します。 アダプタの RJ-45 側の端を、フラットサテン型のロール型 RJ-45--RJ-45 ケーブル(部品番号 CAB-500RJ=)に接続します。このケーブルは、コンソール接続用にすべてのシスコ ルータに付属しています。 また、ロール型ケーブルを ADTRAN 背面の DB-25 ポート(RS-232 のラベル表示)に接続する場合は、「MODEM」と記されている RJ-45 to DB-25 アダプタ(部品番号 CAB-25AS-MMOD)が必要です。

  2. AT を入力して下さい! RS366/Maintenance ポートに接続された、使用場合 V (または! V)メインメニューを得るため。 続いて、Ctrl キーを押した状態で C キーを押し、設定メニューに移動します。

    次のようなメニューが表示されます(TA のモデルによって異なる場合があります)。

     Ctl-V STATUS   Ctl-T TEST   Ctl-C CONFIG   Ctl-D DIAL   Ctl-X EXIT
                             ISU 128 Configuration Menu
    
     1) Netw. options = Dial Line           17) RTS Options = 1 ms delay
     2) Switch Protocl = National ISDN1     18) CTS Options = Forced CTS
     3) Call type = Data 64Kbps             19) CD Options = Normal
     4) SPID 1 = 51255511110101             20) DTR Options = Idle when Off
     5) SPID 2 = 51255511120101             21) DSR Options = OFF Idle+Test
     6) LDN 1 = 5551111                     22) Transmit Clock = Normal
     7) LDN 2 = 5551112                     23) Protocol = PPP asyn-sync
     8) Dial options = V.25                 24) Method = Multilink
     9) V.25 = V.25 HDLC FLAGS              25) Quick setup
    10) Auto answer = Enabled
    11) Answer tone = No Answer tone
    12) Connect Timout = 30 sec (def)
    13) Call Screening = Answer any
    14) DTE options = Synchronous
    15) Bit Rate = 128000
    16) Connector Type = RS-232
    ____________________________________________________________________________
    
    Select =                                    Enter SELECT    Esc NO CHANGE
    ____________________________________________________________________________
    
     Ctl-V STATUS   Ctl-T TEST   Ctl-C CONFIG   Ctl-D DIAL   Ctl-X EXIT
  3. 対応する番号を使用して、各アトリビュートの設定モードに入ります。

    最小限、次のアトリビュートを設定する必要があります。

    • Switch Protocol: 電話会社が規定しているスイッチ タイプ。

    • Call Type: 64K または 56K データのどちらかを指定します(回線のタイプに基づきます)。

    • SPID1、SPID2、LDN1、LDN2: 該当する場合は、電話会社から提供されている SPID および LDN を割り当てます。

    • Dial Options: V.25。

    • V.25: V.25 HDLC(同期シリアルの場合)または V.25 ASYNC(非同期シリアルの場合)。

    • DTE options: Synchronous(同期シリアルの場合)または Asynchronous(非同期シリアルの場合)。

    • Bit Rate: 128000(56K コールの場合は 112000)。

    • プロトコル: PPP asyn-sync。

    • Method: Multilink。

    各パラメータの可能性のある オプションのための ADTRAN の ウェッブサイトの ISUleavingcisco.com データシート/手動を参照することを推奨します。 ほとんどの場合、上記の例で問題ありません。

ルータの設定およびテスト

ルータの設定とテストを行うには、次の手順を実行します。

  1. ルータのシリアル ポートに V.35 ケーブルまたは RS-232 DTE ケーブルを接続します。 使用する必要があるケーブルの種類に関する詳細についてはケーブル接続するセクションを参照して下さい。

  2. show controller serial x(ルータが接続されているケーブルのタイプを表示)を使用して、ルータ側のケーブルが DTE であることを確認します。 次に、例を示します。

    Router#show controller serial 1
    HD unit 1, idb = 0xCF6E8, driver structure at 0xD4A30
    buffer size 1524  HD unit 1, RS-232 DTE cable
    cpb = 0xE3, eda = 0x940, cda = 0x800
    ...
    ...

    また、ADTRAN のコネクタ タイプの設定(上記の例では、オプション 16)が、使用するケーブルと一致していることを確認します。

  3. ルータを次のように設定します。

    username peer password 0 cisco
    !
    interface Serial1 
    ip address 192.168.180.2 255.255.255.0 
    encapsulation ppp 
    dialer in-band
     
    !--- Enable V.25bis dialing. 
    
    dialer map ip 192.168.180.22 name peer 5551111&5551112
     
    !--- Dialer map for the peer. 
    !--- Note the multiple numbers separated by "&"
     
    dialer-group 1 
    pulse-time 1 
    ppp authentication chap
    !
    ip classless
    ip route 192.168.180.22 255.255.255.255 Serial1
    dialer-list 1 protocol ip permit

    始動への TA に関しては両方のチャネル、ADTRAN で第 2 数を保存しなければなりませんまたは Cisco ダイヤラマップ ステートメント (推奨)で [phonenumber1]&[phonenumber2] を使用して下さい。 シリアル インターフェイスは、1 つのポイントツーポイント インターフェイスにしか過ぎないため、複数のダイヤラ マップが用意されていても、マルチリンク接続には反映されません。

    ADTRAN は、1 つめの番号にダイヤルしてネゴシエートと認証を行い、その後すぐに 2 つめの番号にダイヤルします。 TA でマルチリンクが処理されるため、ルータで ppp multilink コマンドを設定していないことに注意してください。

    シリアル インターフェイスを非同期モードで使用する場合は、シリアル インターフェイスの設定で physical-layer async コマンドを使用します。 ただし、非同期通信がサポートされていないシリアル インターフェイス ハードウェアもあります。 このようなインターフェイスにモデムを接続する場合は、『AUX ポート上のモデムを使用したダイヤルアウトの設定』を参照してください。 このドキュメントでは AUX ポートを使用します。 ただし、これらの設定手順はよく似ています。

  4. リモート ルータに対して ping を実行します。 ルータから TA にダイヤラ ストリングが送信され、ISDN リンクが開始されます。 ISDN リンクがアップすると、ルータによって PPP のネゴシエートが実行され、認証が行われます。 これで、トラフィックが送信できるようになります。

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

トラブルシューティングのためのコマンド

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

debug コマンドを使用する前に、『debug コマンドに関する重要な情報』を参照してください。

  • debug dialer:ダイヤラ対応インターフェイスで受信したパケットに関するデバッグ情報を表示します。 インターフェイスで Dial-on-Demand Routing(DDR; ダイヤルオンデマンド ルーティング)が有効になっている場合は、すべてのコールの原因(ダイヤリング原因といいます)に関する情報も表示されます。 詳細については、『Debug コマンド』ドキュメントの debug dialer 情報を参照してください。

  • debug serial interface:シリアル接続の失敗に関する情報を表示するには、debug serial interface EXEC コマンドを使用します。 詳細については、Debug コマンド ドキュメントの debug interface serial 情報を参照して下さい。

  • debug ppp negotiation:Link Control Protocol(LCP; リンク制御プロトコル)、認証、Network Control Protocol(NCP; ネットワーク制御プロトコル)など、PPP コンポーネントとのネゴシエート時の PPP トラフィックと交換に関する情報を表示します。 PPP ネゴシエーションが正常に行われると、最初に LCP 状態が開放され、次に認証、最後に NCP をネゴシエートします。 debug ppp negotiation の出力の見方については、『debug ppp negotiation の出力について』のドキュメントを参照してください。

  • debug ppp authentication:Challenge Authentication Protocol(CHAP)パケット交換や Password Authentication Protocol(PAP; パスワード認証プロトコル)交換など、PPP の認証プロトコル メッセージを表示します。 詳細は、次の文書を参照してください。 PPP (CHAP か PAP)認証のトラブルシューティング

デバッグ出力

debug dialer と debug ppp negotiation をアクティブにしてから、ピアに対して ping を実行します。 ルータはダイヤルを試行する必要があります。 ISDN 接続が確立されると、PPP ネゴシエーションが開始されます。 正常なコールのデバッグ出力は次のようになります。

Router#show debug
Dial on demand:  Dial on demand events debugging is on
PPP:  
  PPP authentication debugging is on  
  PPP protocol negotiation debugging is on
Router#ping 192.168.180.22
  Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 192.168.180.22, timeout is 2 seconds:
 Serial1: Dialing cause ip (s=192.168.180.2,d=192.168.180.22)

!--- Dialing cause is ping to 192.168.180.22.

   Serial1: Attempting to dial 5551111&5551112
   
!--- Call is dialed out using Serial1 
   !---(which is connected to the ADTRAN).
   !--- Remember that ADTRAN handles the ISDN L1-L3, so ISDN messages
   !--- will not be visible on the router.

   Se1 UNKNOWN(0x00FF): LCP not open, discarding packet.
   Se1 UNKNOWN(0x00FF): LCP not open, discarding packet
   Se1 LCP: I CONFREQ [Closed] id 49 len 15

!--- PPP Negotiation begins.

   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: Lower layer not up, discarding packet
   %LINK-3-UPDOWN: Interface Serial1, changed state to up.
   Se1 PPP: Treating connection as a callout
   Se1 PPP: Phase is ESTABLISHING, Active Open
   Se1 LCP: O CONFREQ [Closed] id 47 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x048333B0 (0x0506048333B0)
   Se1 LCP: I CONFACK [REQsent] id 48 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x048333B0 (0x0506048333B0)
   Se1 LCP: I CONFREQ [ACKrcvd] id 50 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: O CONFACK [ACKrcvd] id 50 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: State is Open
   Se1 PPP: Phase is AUTHENTICATING, by both
   Se1 CHAP: O CHALLENGE id 11 len 42 from "Router"
   Se1 CH.AP: I CHALLENGE id 11 len 30 from "peer"
   Se1 CHAP: O RESPONSE id 11 len 42 from "Router"
   Se1 CHAP: I SUCCESS id 11 len 4
   Se1 CHAP: I RESPONSE id 11 len 30 from "peer"
   Se1 CHAP: O SUCCESS id 11 len 4 
   
!--- Authentication is successful.

   Se1 PPP: Phase is UP
   Se1 IPCP: O CONFREQ [Closed] id 16 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: I CONFREQ [REQsent] id 1 len 10
   Se1 IPCP: Address 192.168.180.22 (0x0306CF12B416)
   Se1 IPCP: O CONFACK [REQsent] id 1 len 10
   Se1 IPCP: Address 192.168.180.22 (0x0306CF12B416)
   %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, 
   changed state to up
   Se1 IPCP: TIMEout: Time 0x476F808 State ACKsent
   Se1 IPCP: O CONFREQ [ACKsent] id 17 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: I CONFACK [ACKsent] id 17 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: State is Open
   Se1 IPCP: Install route to 192.168.180.22
   dialer Protocol up for Se1

debug ppp negotiation の出力の見方については、『debug ppp negotiation の出力について』のドキュメントを参照してください。

トラブルシューティング手順

このセクションでは、一般的なトラブルシューティング手順について説明します。 作業ステップで問題が発生した場合、詳細については ADTRAN の技術文書を参照してください。

  1. ADTRAN の前面のディスプレイに、次のように表示されていることを確認します。

    Adtran ISU 128
    [Switch-type] Ready

    これによって、ISDN の設定(スイッチタイプ、Service Profile Identifier(SPID; サービス プロファイル識別子)、Local Directory Number(LDN; 市内電話番号)など)が正しく設定されていて、電話会社に受け入れられていることが確認できます。

  2. ADTRAN のキーパッドを使用して、ピアへのテスト接続を開始します。 これにより、ISDN 回線、および TA における ISDN 関連の設定が正しいことが確認できます。

  3. ピアに対して ping を実行します。 ADTRAN のフロントパネル ディスプレイの次を見るはずです: 「呼出します[PHONENUMBER」。 この表示は、少なくとも V.25bis が正常に動作していることを示しています。 このメッセージが表示されない場合は、ケーブルを交換し、さらに TA を交換してください。 こうすると、ケーブルに問題があるのか、TA の V.35 インターフェイスに問題があるのかが判別できます。

  4. debug dialer をアクティブにします。 ping を実行します。 デバッグ出力が次のように表示されることを確認します。

    Serial1: Dialing cause ip (s=192.168.180.2, d=192.168.180.22)
    Serial1: Attempting to dial 5551111&5551112

    このメッセージが表示されない場合は、DDR 関連で問題が発生しています。 上記のとおりにルータが設定されていることを確認してください。 また、ルーティングおよび対象トラフィックの定義が設定されていることを確認します。

  5. debug serial interface をアクティブにしてから、ping を実行し、TA で Data Set Ready(DSR; データ セット レディ)が生成されることを確認します。

    ルータから PPP のネゴシエートが実行されるのは、ルータが DSR のアップを検知したときだけです。 DSR がアップにならない場合は、下位レイヤ(ISDN、ハードウェア、ケーブル接続など)のトラブルシューティングを行う必要があります。


関連情報


Document ID: 28080