IP : Open Shortest Path First(OSPF)

OSPF プロセス間の再配布時に生じる最適でないルーティング

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 11 月 3 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

この資料では、Open Shortest Path First(OSPF)プロセス間で再配布が行われる際に、最適ではないルーティングが生じる問題について説明し、さらにその解決策を紹介します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

問題

ネットワーク上の複数の箇所にある別々の OSPF プロセス間で再配布が行われるとき、最適なルーティングが行われない状態、さらに悪い場合にはルーティング ループの状態に陥る場合があります。

次のトポロジには、OSPF 1 と OSPF 2 のプロセスが存在します。ルータ 1(R1)およびルータ 2(R2)は、OSPF 1 から OSPF 2 へ再配布を行っています。

/image/gif/paws/28025/2ospf-redis-1.jpg

ルータ R1 と R2 の設定は次のとおりです。

R1
hostname r1  
!  
ip subnet-zero  
!  
interface Loopback0  
 ip address 10.255.255.1 255.255.255.255  
!  
interface Loopback1  
 ip address 192.168.255.1 255.255.255.255  
!  
interface Ethernet0/0  
 ip address 10.0.0.1 255.255.255.0  
!  
interface Ethernet1/0  
 ip address 192.168.0.1 255.255.255.0  
!  
router ospf 1  
 router-id 10.255.255.1  
 log-adjacency-changes  
 passive-interface Loopback0  
network 10.0.0.0 0.0.0.255 area 0
 network 10.255.255.1 0.0.0.0 area 0 
!  
router ospf 2  
 router-id 192.168.255.1  
 log-adjacency-changes  
 redistribute ospf 1 subnets match internal
 
!--- Redistributing OSPF 1 into OSPF 2.
 
 passive-interface Loopback1  
 network 192.168.0.0 0.0.0.255 area 0  
 network 192.168.255.1 0.0.0.0 area 0  
!  
ip classless  
!  
end

R2
hostname r2  
!  
ip subnet-zero  
!  
 
interface Loopback0  
 ip address 10.255.255.2 255.255.255.255  
!  
interface Loopback1  
 ip address 192.168.255.2 255.255.255.255  
!  
interface Ethernet0/0  
 ip address 10.0.0.2 255.255.255.0  
!  
interface Ethernet1/0  
 ip address 192.168.0.2 255.255.255.0  
!  
router ospf 1  
 router-id 10.255.255.2  
 log-adjacency-changes  
 passive-interface Loopback0  
network 10.0.0.0 0.0.0.255 area 0 
 network 10.255.255.2 0.0.0.0 area 0  
!  
router ospf 2  
 router-id 192.168.255.2  
 log-adjacency-changes  
 redistribute ospf 1 subnets match internal

!--- Redistributing OSPF 1 into OSPF 2. 

 passive-interface Loopback1  
 network 192.168.0.0 0.0.0.255 area 0  
 network 192.168.255.2 0.0.0.0 area 0  
!  
ip classless  
 
end

上記のトポロジーでは、R4 E1/0 はエリア 1 にあり、E0/0 はエリア 0 にあります。 したがって、R4 は Area Border Router(ABR; エリア境界ルータ)であり、ネットワーク 10.0.1.0/24 を inter-area(IA; エリア間)ルートとして R1R2 にアドバタイジングしています。 R1 および R2 は OSPF 2.にこの情報を再配布しています。 上記の R1R2 の設定では、設定コマンドの redistribute が強調表示されています。 従って外部 リンクステート アドバタイズメント(LSA)が OSPF 2 ドメイン全体伝搬するので、R1 および R2 は両方 OSPF 2 によって IA と外部タイプ 2 (E2)として OSPF 1 によって約 10.0.1.0/24 を学ぶ行っています。

IA ルーティングが E1 か E2 ルーティングに常に好まれるので、予期は 10.0.1.0/24 がネクスト・ホップ R4 の IA ルートであること、R1 および R2 のルーティング テーブルで見ることです。 ただしルーティング テーブルを表示するとき、別の何かが見られる、10.0.1.0/24 は- R1 で…ネクスト・ホップ R4 の IA ルートですが、R2 で、10.0.1.0/24 はネクスト・ホップ R1 の E2 ルートです。

これは R1 のための show ip route コマンドのコマンド 出力です。

r1#show ip route 
 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 
 

!--- The gateway of the last resort is not set.
 
 
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks 
O E2    10.255.255.2/32 [110/1] via 192.168.0.2, 00:24:21, Ethernet1/0 
C       10.0.0.0/24 is directly connected, Ethernet0/0 
O IA    10.0.1.0/24 [110/20] via 10.0.0.4, 00:23:49, Ethernet0/0 
C       10.255.255.1/32 is directly connected, Loopback0 
O IA    10.255.255.4/32 [110/11] via 10.0.0.4, 00:23:49, Ethernet0/0 
     192.168.255.0/32 is subnetted, 3 subnets 
O       192.168.255.3 [110/11] via 192.168.0.3, 00:26:09, Ethernet1/0 
O       192.168.255.2 [110/11] via 192.168.0.2, 00:26:09, Ethernet1/0 
C       192.168.255.1 is directly connected, Loopback1 
C    192.168.0.0/24 is directly connected, Ethernet1/0 
O    192.168.1.0/24 [110/20] via 192.168.0.3, 00:26:09, Ethernet1/0 

これは R2 のための show ip route コマンドのコマンド 出力です。

r2#show ip route 
 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 
 

!--- The gateway of last resort is not set. 

 
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks 
C       10.255.255.2/32 is directly connected, Loopback0 
C       10.0.0.0/24 is directly connected, Ethernet0/0 
O E2    10.0.1.0/24 [110/20] via 192.168.0.1, 00:25:34, Ethernet1/0 
O E2    10.255.255.1/32 [110/1] via 192.168.0.1, 00:25:34, Ethernet1/0 
O E2    10.255.255.4/32 [110/11] via 192.168.0.1, 00:25:34, Ethernet1/0 
     192.168.255.0/32 is subnetted, 3 subnets 
O       192.168.255.3 [110/11] via 192.168.0.3, 00:26:45, Ethernet1/0 
C       192.168.255.2 is directly connected, Loopback1 
O       192.168.255.1 [110/11] via 192.168.0.1, 00:26:45, Ethernet1/0 
C    192.168.0.0/24 is directly connected, Ethernet1/0 
O    192.168.1.0/24 [110/20] via 192.168.0.3, 00:26:45, Ethernet1/0 

この問題が発生する理由

ルータの複数の OSPF プロセスを、ソフトウェア観点から有効に するとき、プロセスは独立 して います。 OSPFプロトコルは、1 OSPFプロセスの中で、外部ルート上の内部ルートを常に優先します。 ただし、OSPF はプロセスがルーティング テーブルにインストールする必要がある)決定するときルートをプロセス間の OSPFルート選択をしません(たとえば、OSPF メトリックおよびルート型は考慮に入れられません。

異なる OSPF プロセスの間に相互対話がないし、タイブレイカーはアドミニストレーティブ ディスタンスです。 従って、OSPF プロセスに両方とも 110 のデフォルトの管理者距離があるので、ルートがルーティング テーブルにそれを作ることインストールすることを試みる最初のプロセス。 従って、異なる OSPF プロセスからのルーティングのためのアドミニストレーティブ ディスタンスは可能性の関係である特定の OSPF プロセスのルーティングが人間意図によって別のプロセスのルーティングに好まれる、ないように設定し。

管理上の距離に関する詳細は、「管理上の距離の概要」を参照してください。 シスコのルータがルートを選択してルーティング テーブルに記載する方法の詳細については、「Cisco ルータにおける経路の選択」を参照してください。

解決策

解決策 1

このような場合、ルータはアドミニストレーティブ ディスタンスに基づいて最良 の ルートを選択していることを確認するのでこの動作を防ぐ論理的な方法は OSPF 2.の外部ルートのアドミニストレーティブ ディスタンスを増加することです。 こうすればは OSPF 2.に OSPF 1 から再配布された外部ルートに、OSPF 1 によって学習されたルーティング常に好まれます。 これは下記の設定に示すように sub-router configuration コマンド距離 ospf 外部 <value> を使用してされます。

R1
hostname r1  
!  
ip subnet-zero  
!  
interface Loopback0  
 ip address 10.255.255.1 255.255.255.255  
!  
interface Loopback1  
 ip address 192.168.255.1 255.255.255.255  
!  
interface Ethernet0/0  
 ip address 10.0.0.1 255.255.255.0  
!  
interface Ethernet1/0  
 ip address 192.168.0.1 255.255.255.0  
!  
router ospf 1  
 router-id 10.255.255.1  
 log-adjacency-changes  
 passive-interface Loopback0  
 network 10.0.0.0 0.0.0.255 area 0  
 network 10.255.255.1 0.0.0.0 area 0  
!  
router ospf 2  
 router-id 192.168.255.1  
 log-adjacency-changes  
 redistribute ospf 1 subnets match internal  
 passive-interface Loopback1  
 network 192.168.0.0 0.0.0.255 area 0  
 network 192.168.255.1 0.0.0.0 area 0  
 distance ospf external 115  

!--- Increases the administrative distance of external 
!--- routes to 115. 

!  
ip classless  
!  
end 

R2
hostname r2  
!  
ip subnet-zero  
!  
interface Loopback0  
 ip address 10.255.255.2 255.255.255.255  
!  
interface Loopback1  
 ip address 192.168.255.2 255.255.255.255  
!  
interface Ethernet0/0  
 ip address 10.0.0.2 255.255.255.0  
!  
interface Ethernet1/0  
 ip address 192.168.0.2 255.255.255.0  
!  
router ospf 1  
 router-id 10.255.255.2  
 log-adjacency-changes  
 passive-interface Loopback0  
 network 10.0.0.0 0.0.0.255 area 0  
 network 10.255.255.2 0.0.0.0 area 0  
!  
router ospf 2  
 router-id 192.168.255.2  
 log-adjacency-changes  
 redistribute ospf 1 subnets match internal  
 passive-interface Loopback1  
 network 192.168.0.0 0.0.0.255 area 0  
 network 192.168.255.2 0.0.0.0 area 0  
 distance ospf external 115  

!--- Increases the administrative distance of 
!--- external routes to 115. 

!  
ip classless  
!  
end 

OSPF 2 にある外部ルートの管理上の距離を変更した結果のルーティング テーブルを次に示します。

これは R1 のための show ip route コマンドのコマンド 出力です。

r1#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 
 

!--- The gateway of the last resort is not set.

 
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks 
O       10.255.255.2/32 [110/11] via 10.0.0.2, 00:00:35, Ethernet0/0 
C       10.0.0.0/24 is directly connected, Ethernet0/0 
O IA    10.0.1.0/24 [110/20] via 10.0.0.4, 00:00:35, Ethernet0/0 
C       10.255.255.1/32 is directly connected, Loopback0 
O       10.255.255.4/32 [110/11] via 10.0.0.4, 00:00:35, Ethernet0/0 
     192.168.255.0/32 is subnetted, 3 subnets 
O       192.168.255.3 [110/11] via 192.168.0.3, 00:00:35, Ethernet1/0 
O       192.168.255.2 [110/11] via 192.168.0.2, 00:00:35, Ethernet1/0 
C       192.168.255.1 is directly connected, Loopback1 
C    192.168.0.0/24 is directly connected, Ethernet1/0 
O    192.168.1.0/24 [110/20] via 192.168.0.3, 00:00:35, Ethernet1/0 

これは R2 のための show ip route コマンドのコマンド 出力です。

r2#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 
 

!--- The gateway of the last resort is not set. 

 
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks 
C       10.255.255.2/32 is directly connected, Loopback0 
C       10.0.0.0/24 is directly connected, Ethernet0/0 
O       10.255.255.1/32 [110/11] via 10.0.0.1, 00:01:28, Ethernet0/0 
O IA    10.0.1.0/24 [110/20] via 10.0.0.4, 00:01:28, Ethernet0/0 
O       10.255.255.4/32 [110/11] via 10.0.0.4, 00:01:28, Ethernet0/0 
     192.168.255.0/32 is subnetted, 3 subnets 
O       192.168.255.3 [110/11] via 192.168.0.3, 00:01:28, Ethernet1/0 
C       192.168.255.2 is directly connected, Loopback1 
O       192.168.255.1 [110/11] via 192.168.0.1, 00:01:28, Ethernet1/0 
C    192.168.0.0/24 is directly connected, Ethernet1/0 
O    192.168.1.0/24 [110/20] via 192.168.0.3, 00:01:28, Ethernet1/0 

場合によっては、OSPF 2 から再配布がまた OSPF 1 にあり、OSPF 2 に再配布される他のルーティング プロトコルがそれらの外部ルートのための OSPF 2 の subobtimalルーティングに(ルーティング情報プロトコル[RIP]、Enhanced Interior Gateway Routing Protocol (EIGRP) 静的アドレス、等)ことに注意することは重要です、これ導く場合がありますあるとき。

解決策 2

2 つの異なる OSPF プロセスを設定する最終的な原因がある特定のルーティングをフィルタリングすることである場合新しい 機能は Cisco IOS にありますか。 ABR のルートフィルタリングをすることを可能にするソフトウェア リリース 12.2(4)T は OSPF ABR タイプ 3 LSA フィルタリングを呼出しました。

秒 OSPFプロセスを設定するかわりに、OSPF 2 の一部、上述の例でであるリンクは OSPF 1.の中の別のエリアで、設定できます。 それから、この新しい 機能との R1 および R2 の必須ルートフィルタリングを実装できます。 この機能の詳細は、「OSPF ABR Type 3 LSA フィルタリング」を参照してください。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 28025