ロング リーチ イーサネット(LRE)とデジタル加入者線(xDSL) : Symmetrical High-Data-Rate DSL(G.SHDSL)

G.SHDSL ポートを経由したCPE バックツーバック設定

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2005 年 6 月 10 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、Multirate Symmetric High-Speed Digital Subscriber Line(G.SHDSL)ポートを使用して、2 台のルータをバックツーバック接続で設定する例を紹介します。 それはどのように G.SHDSL Cisco 記述しますか。 ルータははたらくためにように設定することができますか。Central Office (CO) DSLデバイス別の遠隔 G.SHDSL CPEデバイスからの接続を終える。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS を実行する 828 Customer Premises Equipment (CPE)か。 ソフトウェア リリース 12.2(8)T1

  • Cisco IOS ソフトウェア リリース 12.2(8)T が稼働する 2612 ルータ

  • WAN インターフェイス カード(WIC)-1SHDSL を使用している 2612 ルータ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/25900/dsl_cpe_config1.gif

設定

このドキュメントでは、次の設定を使用します。

この設定では 828A は機器タイプ「CO で設定されます」、CO からのシグナリングを模倣します。 間、G.SHDSL WIC との 2612 が機器タイプ「CPE で設定される」。

DSL5-828A(CO として動作する Cisco 828 CPE)
DSL5-828A#show run
Building configuration...

Current configuration : 769 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname DSL5-828A
!
!
ip subnet-zero
!
!
!
!
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 hold-queue 100 out
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/35 
  encapsulation aal5snap
 !
 pvc 8/35 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl equipment-type CO
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface Dialer0
 ip address 1.1.1.1 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer-group 1
!
ip classless
ip http server
ip pim bidir-enable
!
!         
dialer-list 1 protocol ip permit
!
line con 0
 stopbits 1
line vty 0 4
!
scheduler max-task-time 5000
end

DSL4-2612A(CPE として動作する Cisco 2612 ルータ)
dsl4-2612a#show run
Building configuration...

Current configuration : 927 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname dsl4-2612a
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
!
!
!
interface ATM0/0
 no ip address
 no atm ilmi-keepalive
 pvc 0/35 
  encapsulation aal5snap
 !
 pvc 8/35 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl equipment-type CPE
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface Ethernet0/0
 ip address 172.16.1.2 255.255.255.0
 shutdown
 half-duplex
!         
interface TokenRing0/0
 no ip address
 shutdown
 ring-speed 16
!
interface Dialer0
 ip address 1.1.1.2 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer-group 1
!
ip classless
ip http server
ip pim bidir-enable
!
!
dialer-list 1 protocol ip permit
!
call rsvp-sync
!
!
mgcp profile default
!         
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

コマンド リファレンス

このセクションでは、変更されたコマンドについて説明します。 この機能と使用される他のコマンドはすべて Cisco IOS ソフトウェア リリース 12.2 コマンド レファレンス 書で文書化されています。

変更されたコマンド

  • dsl equipment-type

  • dsl linerate

  • dsl operating-mode (g.shdsl)

dsl equipment-type

CO 機器か CPE として機能するために DSL ATMインターフェイスを設定する ATMインターフェイス モードの dsl equipment-type コマンドを発行して下さい。 デフォルト機器タイプを復元するのにこのコマンドの no 形式を使用して下さい。

  • dsl equipment-type {CO | CPE}

  • no dsl equipment-type

これらのコマンドのためのシンタクスの記述は次のとおりです:

  • 共同 DSL ATMインターフェイスを CO 機器として機能するために設定します。

  • cpe - DSL ATM インターフェイスが CPE として動作するよう設定します。

デフォルト

DSL ATM インターフェイスは CPE として動作します。

インターフェイス コマンド モード

G.SHDSL WIC のための ATMインターフェイスはこれらの Cisco IOS ソフトウェア リリースに統合されていました:

  • 12.2(4)XL - Cisco 2600 シリーズ ルータ

  • 12.2(8)T - Cisco 2600 シリーズ ルータおよび Cisco 3600 シリーズ ルータ

使用上のガイドライン

この設定コマンドは、特定の ATM インターフェイスに適用されます。 このコマンドを発行する前に、ATM インターフェイスを指定する必要があります。 また、コマンドを発行する前に、ATM インターフェイスを shutdown 状態にしておく必要があります。 この例に CO 機器として機能するために DSL ATMインターフェイス 1/1 を設定する方法を示されています。

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 1/1 
Router(config-if)#dsl equipment-type co 

Router(config-if)#end 
Router# clear interface atm 0/1 

Router#

関連コマンド

  • dsl linerate - DSL ATM インターフェイスのライン レートを指定します。

  • dsl operating-mode (g.shdsl) - DSL ATM インターフェイスの動作モードを指定します。

dsl linerate

DSL ATMインターフェイスのためのライン比率を規定 する ATMインターフェイス モードの dsl linerate コマンドを発行して下さい。 デフォルト回線 比率を復元するのにこのコマンドの no 形式を使用して下さい。

  • DSL 回線レート{キロビット/秒 | 自動}

  • no dsl linerate

これらのコマンドのためのシンタクスの記述は次のとおりです:

  • kbps - DSL ATM インターフェイスのライン レートを、1 秒あたりのキロビット数で指定します。 指定できる値は、72、136、200、264、392、520、776、1032、1160、1544、2056、および 2312 です。

  • auto - 遠端の DSL Access Multiplier(DSLAM)または WIC とネゴシエーションを行って、最適なライン レートを自動的にトレインするように DSL ATM インターフェイスを設定します。

デフォルト

DSL ATM インターフェイスは、自動的に遠端の DSLAM または WIC とライン レートを同期します。

インターフェイス コマンド モード

G.SHDSL WIC のための ATMインターフェイスはこれらの Cisco IOS ソフトウェア リリースに統合されていました:

  • 12.2(4)XL - Cisco 2600 シリーズ ルータ

  • 12.2(8)T - Cisco 2600 シリーズ ルータおよび Cisco 3600 シリーズ ルータ

使用上のガイドライン

この設定コマンドは、特定の ATM インターフェイスに適用されます。 このコマンドを発行する前に、ATM インターフェイスを指定する必要があります。 また、コマンドを発行する前に、ATM インターフェイスを shutdown 状態にしておく必要があります。 この例に 1040 キロビット/秒ラインレートで動作するために DSL ATMインターフェイス 0/1 を設定する方法を示されています:

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 0/1 
Router(config-if)#dsl linerate 1040 

Router(config-if)#end 
Router#clear interface atm 0/1 

Router# 

関連コマンド

  • dsl equipment-type - DSL ATM インターフェイスが、CO 装置または CPE として動作するよう設定します。

  • dsl operating-mode (g.shdsl) - DSL ATM インターフェイスの動作モードを指定します。 デフォルト動作モードを復元するのにこのコマンドの noform を使用して下さい。

dsl operating-mode (g.shdsl)

ATMインターフェイスのための DSL の動作モードを規定 するために dsl operating-mode ATMインターフェイス コマンドを発行して下さい。 デフォルト動作モードを復元するのにこのコマンドの no 形式を使用して下さい。

  • dsl operating-mode gshdsl 対称別館{A | B}

  • no dsl operating-mode

これらのコマンドのためのシンタクスの記述は次のとおりです:

  • gshdsl - DSL ATM インターフェイスが、ITU G.991.2 に準拠したマルチレート高速モードで動作するよう設定します。

  • symmetric - DSL ATM インターフェイスが、ITU G.991.2 に準拠した対称モードで動作するよう設定します。

  • 別館{A | B} —地方のオペレーティング パラメータを規定 します。 北米の場合は A、ヨーロッパの場合は B を入力します。 デフォルトは A です。

デフォルト設定

デフォルト動作モードは G.SHDSL 対称 ANNEX A です。

インターフェイス コマンド モード

G.SHDSL WIC のための ATMインターフェイスは Cisco IOS ソフトウェア リリース 12.1(3)X で導入され、これらの Cisco IOS ソフトウェア リリースに統合。

  • 12.2(2)T - Cisco 1700 シリーズ ルータ

  • 12.2(4)XL - Cisco 2600 シリーズ ルータ

  • 12.2(8)T - Cisco 2600 シリーズ ルータおよび Cisco 3600 シリーズ ルータ

使用上のガイドライン

この設定コマンドは、特定の ATM インターフェイスに適用されます。 このコマンドを発行する前に、ATM インターフェイスを指定する必要があります。 また、コマンドを入力する前に、ATM インターフェイスを shutdown 状態にしておく必要があります。 この例に G.SHDSL モードで動作するために DSL ATMインターフェイス 0/0 を設定する方法を示されています。

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 0/0 
Router(config-if)#dsl operating-mode gshdsl symmetric annex A 

Router(config-if)#end 
Router#clear interface atm 0/1 

Router#

関連コマンド

  • dsl equipment-type - DSL ATM インターフェイスが、CO 装置または CPE として動作するよう設定します。

  • dsl linerate - DSL ATM インターフェイスのライン レートを指定します。

確認

この出力がコンソール セッションを渡って行くことを見るはずです。 ルータに Telneted、コンソールメッセージを表示する term mon コマンドを発行して下さい。

00:51:25: %GSI-6-RESET: Interface ATM0/0, bringing up the line. 
It may take several seconds for the line to be active. 
00:52:09: %ATM-5-UPDOWN: Changing VC 0/35 VC-state to PVC activated. 
00:52:09: %ATM-5-UPDOWN: Changing VC 8/35 VC-state to PVC activated. 
00:52:10: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
00:52:10: %DIALER-6-BIND: Interface Vi1 bound to profile Di0 
00:52:11: %LINK-3-UPDOWN: Interface ATM0/0, changed state to up 
00:52:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0, changed state to up 
00:52:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up 

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

  • show running-config - 現在の設定を確認し、すべてのコントローラのステータスを表示します。

  • show controllers atm slot/port - ATM コントローラの統計情報を表示します。

  • show atm vc - Permanent Virtual Circuit(PVC; 相手先固定接続)のステータスを確認します。

  • show dsl interface atm - G.SHDSL モデムのステータスを表示します。

  • show interface atm - ATM インターフェイスのステータスを表示します。

これは show atm vc コマンドからの出力例です。 アクティブな PVC がアップしていることを確認します。

dsl4-2612a#show atm vc 
           VCD /                                        Peak  Avg/Min Burst 
Interface  Name         VPI   VCI  Type   Encaps   SC   Kbps   Kbps   Cells  Sts 
0/0        1              0    35  PVC    SNAP     UBR    2304                UP 
0/0        2              8    35  PVC    MUX      UBR    2304                UP

これは show dsl interface atm コマンドからの出力例です。 行がダウンしている場合、行は非アクティブです。 いくつかの値は正確ではないかもしれません。 文は現われます。 装置タイプや動作モードの設定が、ご使用のアプリケーションに対して適切かどうかを調べることもできます。

dsl4-2612a#show dsl interface atm 0/0 
Globespan G.SHDSL/SDSL Chipset Information 

 Equipment Type:         Customer Premise 
 Operating Mode:         G.SHDSL Annex A 
 Clock Rate Mode:        Auto rate selection Mode 
 Reset Count:            1 
 Actual rate:            2312 Kbps 
 Modem Status:           Data (0x1) 
 Received SNR:           39 dB 
 SNR Threshold:          23 dB 
 Loop Attenuation:      -0.3400 dB 
 Transmit Power:         7.5 dBm 
 Receiver Gain:          4.3900 dB 
 Last Activation Status: No Failure (0x0) 
 CRC Errors:             33372 
 Chipset Version:        1 
 Firmware Version:       R1.5 

dsl4-2612a#show dsl interface atm 0/0 
Globespan G.SHDSL/SDSL Chipset Information 

Line is not active. Some of the values printed may not be accurate. 
 Equipment Type:         Customer Premise 
 Operating Mode:         G.SHDSL Annex A 
 Clock Rate Mode:        Auto rate selection Mode 
 Reset Count:            1 
 Actual rate:            2312 Kbps 
 Modem Status:           Idle (0x0) 
 Received SNR:           38 dB 
 SNR Threshold:          23 dB 
 Loop Attenuation:      -0.3400 dB 
 Transmit Power:         7.5 dBm 
 Receiver Gain:          4.3900 dB 
 Last Activation Status: No Failure (0x0) 
 CRC Errors:             33372 
 Chipset Version:        1 
 Firmware Version:       R1.5

ATM 回線上で ping を実行できない場合は、両方のルータの ATM インターフェイスに対して show interface コマンドを発行して、ATM インターフェイスが UP/UP 状態であることを確認します。 ATM インターフェイスのステータスを表示するには、show interface atm コマンドを発行します。 この例が示すので ATM スロット、ポートおよび行プロトコルが稼働していることを確かめて下さい。

DSL5-828A#show interfaces atm0 
ATM0 is up, line protocol is up 
  Hardware is PQUICC_SAR (with Globespan G.SHDSL module) 
  MTU 1500 bytes, sub MTU 1500, BW 2312 Kbit, DLY 80 usec, 
     reliability 255/255, txload 1/255, rxload 1/255 
  Encapsulation ATM, loopback not set 
  Encapsulation(s): AAL5, PVC mode 
  10 maximum active VCs, 2 current VCCs 
  VC idle disconnect time: 300 seconds 
  Last input never, output 00:00:08, output hang never 
  Last clearing of "show interface" counters never 
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
  Queueing strategy: None 
  5 minute input rate 0 bits/sec, 0 packets/sec 
  5 minute output rate 0 bits/sec, 0 packets/sec 
     261 packets input, 11170 bytes, 0 no buffer 
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
     264 packets output, 11388 bytes, 0 underruns 
     0 output errors, 0 collisions, 2 interface resets 
     0 output buffer failures, 0 output buffers swapped out

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

トラブルシューティングのためのコマンド

debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

  • debug atm events - ATM 関連のイベントが生成されたときに、そのイベントを識別します。

  • どのインターフェイスがトラブルがあるか debug atm errors —示します。

これはアップするために 30 秒または回線のための多くを奪取 するかもしれませんことに)このセクションにリストされているデバッグを実行する ATMインターフェイスからのサンプル デバッグ情報および来るオンラインです(留意して下さい。

01:07:15: ATM0/0 dslsar_1a_reset: PLIM type is 19, Rate is 2304Mbps 
01:07:15: ATM0/0 dslsar_1a_shutdown: state=4 
01:07:15: dslsar disable ATM0/0 

01:07:15: %GSI-6-RESET: Interface ATM0/0, bringing up the line.
It may take several seconds for the line to be active. 
01:07:15: Resetting ATM0/0 
01:07:15:  dslsar_1a_config(ATM0/0) 
01:07:15:  dslsar_1a_enable(ATM0/0) 
01:07:15: ATM0/0: dslsar_init(825AD084,FALSE) 
01:07:15: dslsar disable ATM0/0 

01:07:16: ATM0/0 dslsar_init: DSLSAR TXRX disabled 

01:07:16: ATM0/0 dslsar_1a_enable: restarting VCs: 0 
01:07:16: (ATM0/0)1a_enable,calling atm_activate_pvc, vcd = 1, vc = 0x82A17BE0adb->flags = 0x4800C 
01:07:16: (ATM0/0)1a_enable,calling atm_activate_pvc, vcd = 2, vc = 0x82A1863Cadb->flags = 0x4800C 
dsl4-2612a# 
dsl4-2612a# 
01:07:16: %SYS-5-CONFIG_I: Configured from console by console 
01:07:19: dslsar disable ATM0/0 

01:08:03: ATM0/0 dslsar_MatchSARTxToLineSpeed(): usbw 2304, clkPerCell 6360 prev_clkPerCell 9702 
01:08:03: ATM0/0 dslsar_update_us_bandwidth(): upstream bw =2304 Kbps 
01:08:09:  dslsar_periodic: ENABLING DSLSAR 

01:08:09: dslsar enable ATM0/0 

01:08:09:  dslsar_1a_setup_vc(ATM0/0): vc:1 vpi:0 vci:35 state 2 
01:08:09: ATM0/0 dslsar_vc_setup: vcd 1, vpi 0, vci 35, avgrate 0 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 2304, tbds_per_tsi = 15, max_pkt_len = 4470, 
max_tx_time = 1862ATM0/0 last_address 0x12E14 

01:08:09: %ATM-5-UPDOWN: Changing VC 0/35 VC-state to PVC activated. 
01:08:09:  dslsar_1a_setup_vc(ATM0/0): vc:2 vpi:8 vci:35 state 2 
01:08:09: ATM0/0 dslsar_vc_setup: vcd 2, vpi 8, vci 35, avgrate 0 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 1 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 
01:08:09: CONFIGURING VC 2 (8/35) IN TX SCHEDULE TABLE SET 1 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 2:  slot 1 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 2 (8/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 2, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 

01:08:09: %ATM-5-UPDOWN: Changing VC 8/35 VC-state to PVC activated. 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 
01:08:09: CONFIGURING VC 2 (8/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 2:  slot 1 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 2 (8/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 2, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 

01:08:10: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
01:08:10: %DIALER-6-BIND: Interface Vi1 bound to profile Di0 
01:08:11: %LINK-3-UPDOWN: Interface ATM0/0, changed state to up 
01:08:11:  dslsar_atm_lineaction(ATM0/0): state=4 
01:08:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0, changed state to up 
01:08:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up

関連情報


Document ID: 25900