IP : Open Shortest Path First(OSPF)

フォワーディング アドレスのタイプ 5 LSA パス選択への影響

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 1 月 7 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

この文書では、ルータが任意の外部ネットワーク用に 2 つのタイプ 5 link-state advertisement(LSA; リンクステート アドバタイズメント)を受信した場合の、Open Shortest Path First(OSPF)パス選択の動作について説明します。 この例では、一方の LSA のフォワーディング アドレスはゼロ(0.0.0.0)に、他方の LSA のフォワーディング アドレスはゼロ以外に設定します。

前提条件

要件

このドキュメントの読者は次の項目に関する知識が必要です。

  • IP ルーティング全般

  • OSPF ルーティング プロトコルの概念と条件

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco 2503 ルータ

  • Cisco IOS(R) すべてのルータで動作するソフトウェア リリース 12.2(24a)

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

タイプ5 LSA 転送アドレスがパス選択に与える影響

両方のLSA に設定されない転送アドレス

OSPF タイプ 5 LSA のフォワーディング アドレスが、タイプ 5 LSA のパス選択にどのように影響するかについて、下記のトポロジを使用して説明します。

/image/gif/paws/25493/type5_lsa_01.gif

上記のダイアグラムでは、すべてのルータは、ルータ 8 以外の、型 5 LSA を生成する自律システム境界ルータ(ASBR)であるのでこの資料、ルータのコンフィギュレーション 3 およびルータ 4 が最も重要であるの為エリア 0 の OSPF を実行しています。 下記に示すとおり、ルータ 3 とルータ 4 にはネットワーク 200.200.200.0 255.255.255.0 へのスタティック ルートがあり、これが OSPF に再配布されています。

ルータ 3
interface Ethernet0
 ip address 172.16.3.3 255.255.255.0
 ip ospf cost 15
!
interface Serial0
 ip address 172.16.2.3 255.255.255.0
!
router ospf 7
 redistribute static subnets
 network 172.16.2.0 0.0.0.255 area 0
!
ip route 200.200.200.0 255.255.255.0 172.16.3.8

ルータ 4
interface Ethernet0
 ip address 172.16.3.4 255.255.255.0
!
interface Serial0
 ip address 172.16.7.4 255.255.255.0
!
router ospf 7
 redistribute static subnets
 network 172.16.7.0 0.0.0.255 area 0
!
ip route 200.200.200.0 255.255.255.0 172.16.3.8

ルータ 3 およびルータ 4 は OSPFプロセスでネットワーク 172.16.3.0 255.255.255.0 が含まれていません; 従って、両方のルータが生成する型 5 LSA に設定 される 0.0.0.0 へのフォーワーディングアドレスがあります

この例では、ルータ 5 を使用して、外部 LSA を表示できます。 外部LSAs を表示するために、ルータ 5.の show ip ospf database external コマンドを発行して下さい。 このコマンドの出力結果を次に示します。

ルータ 5
router-5# show ip ospf database external

            OSPF Router with ID (172.16.6.5) (Process ID 7)

                Type-5 AS External Link States

  Routing Bit Set on this LSA
  LS age: 1514
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.3.3
  LS Seq Number: 80000030
  Checksum: 0x93C0
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

  Routing Bit Set on this LSA
  LS age: 1922
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.7.4
  LS Seq Number: 80000027
  Checksum: 0x83D4
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

router-5#

上記を見てわかるとおり、ルータ 3 とルータ 4 の両方で生成されるタイプ 5 LSA のフォワーディング アドレスが、0.0.0.0 に設定されます。 この場合、ルータ 5 のルーティング テーブルにインストールされる LSA は、LSA を生成している ASBR へのメトリックと比較して決定されます。 ルータ 5 の show ip ospf border-routers コマンドの発行によって、ルータ 5 に ASBR のためにあるメトリックを表示できます。 このコマンドの出力結果を次に示します。

ルータ 5
router-5# show ip ospf border-routers

OSPF Process 7 internal Routing Table

Codes: i - Intra-area route, I - Inter-area route

i 172.16.7.4 [74] via 172.16.6.6, Ethernet0, ASBR, Area 0, SPF 14
i 172.16.3.3 [64] via 172.16.2.3, Serial0, ASBR, Area 0, SPF 14
router-5#

上に示されているように、64 は ASBR 172.16.7.4 に達するメトリックは 74 であるが ASBR 172.16.3.3 に達するルータ 5 メトリックです; 従って、ルータ 5 はルーティング テーブルに選択します(下記に示されている)置くために ASBR 172.16.3.3 によって生成される LSA を。

ルータ 5
router-5# 
show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O E2 200.200.200.0/24 [110/20] via 172.16.2.3, 19:59:25, Serial0
     172.16.0.0/24 is subnetted, 3 subnets
C       172.16.6.0 is directly connected, Ethernet0
O       172.16.7.0 [110/74] via 172.16.6.6, 19:59:25, Ethernet0
C       172.16.2.0 is directly connected, Serial0
router-5#

片方の LSA にのみ設定され、他方の LSA には設定されない転送アドレス

この文書のこの部分に関しては、上記と同じトポロジを使用します。 ルータ 4 の設定も変更はありませんが、ルータ 3 の設定は、OSPF プロセスのエリア 0 にネットワーク 172.16.3.0 255.255.255.0 を含むように変更されています。 ルータ 3 設定は太字で強調表示されている変更と下記に示されています。

ルータ 3
interface Ethernet0
 ip address 172.16.3.3 255.255.255.0
 ip ospf cost 15
!
interface Serial0
 ip address 172.16.2.3 255.255.255.0
!
router ospf 7
 redistribute static subnets
 network 172.16.2.0 0.0.0.255 area 0
 network 172.16.3.0 0.0.0.255 area 0
!
ip route 200.200.200.0 255.255.255.0 172.16.3.8

上記の設定変更を行った結果、ルータ 3 によって生成されるタイプ 5 LSA は、フォワーディング アドレスがルータ 8 の IP アドレスに設定されます。これは、ルータ 5 から抜粋される、下記のデータベースの出力に示すとおりです。

ルータ 5
router-5# show ip ospf database external

            OSPF Router with ID (172.16.6.5) (Process ID 7)

                Type-5 AS External Link States

  Routing Bit Set on this LSA
  LS age: 270
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.3.3
  LS Seq Number: 80000033
  Checksum: 0x5138
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 172.16.3.8
        External Route Tag: 0

  Routing Bit Set on this LSA
  LS age: 258
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.7.4
  LS Seq Number: 80000029
  Checksum: 0x7FD6
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

router-5#

上記を見てわかるとおり、ルータ 3 によって生成されたタイプ 5 LSA のフォワーディング アドレスが 172.16.3.8 と設定されるのに対し、ルータ 4 によって生成されたタイプ 5 LSA のフォワーディング アドレスは 0.0.0.0 のままです。

この場合、ルータ 5 ルーティング テーブルにインストールされるべき LSA は ASBR とルータ 5 メトリックを比較することによって判別されます(LSA のために設定 された 172.16.3.8 のフォーワーディングアドレスに達するためにルータ 5 メトリックへの 0.0.0.0 のフォーワーディングアドレスとの LSA を生成したルータは ASBR (3) ルータによって 4)生成しました。

メトリックを ASBR に見るために、ルータ 5.の show ip ospf border コマンドを発行して下さい。 出力結果を次に示します。

ルータ 5
router-5# show ip ospf border-routers

OSPF Process 7 internal Routing Table

Codes: i - Intra-area route, I - Inter-area route

i 172.16.7.4 [74] via 172.16.6.6, Ethernet0, ASBR, Area 0, SPF 15
i 172.16.3.3 [64] via 172.16.2.3, Serial0, ASBR, Area 0, SPF 15
router-5#

上記の出力では、ルータ 4 へのメトリックは 74 です。 これはルータ 5 メトリックと show ip route 172.16.3.8 コマンドを使用して見られる場合がある 172.16.3.8 のフォーワーディングアドレスに達するために比較されます。 このコマンドの出力結果を次に示します。

ルータ 5
router-5# show ip route 172.16.3.8
Routing entry for 172.16.3.0/24
  Known via "ospf 7", distance 110, metric 79, type intra area
  Last update from 172.16.2.3 on Serial0, 00:30:49 ago
  Routing Descriptor Blocks:
  * 172.16.2.3, from 172.16.3.3, 00:30:49 ago, via Serial0
      Route metric is 79, traffic share count is 1

router-5#

つまり、ASBR ルータ 4 に到達するためのメトリック(すなわち 74)が、(ルータ 3 によって生成される)フォワーディング アドレス 172.16.3.8 に到達するためのメトリック(すなわち 79)と比較されます。 従って、ルーティング テーブルにインストールされる LSA は下記の show ip route のルータ 5 出力に示すようにルータ 4 によって、生成される LSA です。

ルータ 5
router-5# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O E2 200.200.200.0/24 [110/20] via 172.16.6.6, 00:35:14, Ethernet0
     172.16.0.0/24 is subnetted, 4 subnets
C       172.16.6.0 is directly connected, Ethernet0
O       172.16.7.0 [110/74] via 172.16.6.6, 00:35:14, Ethernet0
C       172.16.2.0 is directly connected, Serial0
O       172.16.3.0 [110/79] via 172.16.2.3, 00:35:14, Serial0
router-5#

複数の ASBR からの再割り当てされたルートのメトリックが資料に示すように等しいとき、フォーワーディングアドレスは型 5 LSA パス選択の動作を変更します。 ルータが両方の LSA でフォーワーディングアドレスが設定されていると同じ宛先に 2 型 5 LSA を受け取るときルータはフォーワーディングアドレスにメトリックに基づいて比較をします。 より小さいメトリックを提供するフォーワーディングアドレスとの LSA はルーティング テーブルに置かれます。

再割り当てされたルートのメトリックが異なっている場合、ルータはフォーワーディングアドレスに最も低いメトリックおよびない最も低いメトリックのルートを優先します。


関連情報


Document ID: 25493