音声 : H.323

Cisco IOS Telephony Service(ITS)の設定とトラブルシューティング

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2008 年 6 月 20 日) | 英語版 (2015 年 11 月 12 日) | フィードバック


目次


概要

以前 IP Keyswitch として知られている Cisco IOS Telephony Service (ITS)、IP テレフォニー コール処理 ソリューションは Cisco IOS に統合か。 ソフトウェア 音声、ビデオおよび統合されたデータ(AVVID)のための Cisco アーキテクチャで合う。 基本的な概念は、音声ゲートウェイに直接取り付けられている数台の IP Phone に対し、最低限の PBX/キースイッチ機能を提供するというものです。 Cisco ITS は、WAN を持たない、あるいは衛星回線による WAN 接続しかない支店に速やかに設置することができます。

Cisco ITS は、そのようなサイトに電話サービスを設置したいけれど、Cisco CallManager が備えているすべての電話機能は必要としないという状況に適しています。 この資料では、ITS 機能をサンプル ネットワークに設置する例について説明します。

Cisco ITS は、Cisco CallManager と一緒に使用されている Survivable Remote Site Telephony(SRST)機能とは異なります。また機能的にも異なります。

前提条件

要件

設定を開始する前に、次の前提条件が満たされていることを確認してください。

  • Cisco IOS Telephony Service バージョン 2.01 に慣れていること。

  • IP アドレッシング、Dynamic Host Configuration Protocol(DHCP; ダイナミック ホスト コンフィギュレーション プロトコル)、Network Time Protocol(NTP; ネットワーク タイム プロトコル)、TFTP、および HTTP など、TCP/IP 基礎事項に関する基本知識。

  • Command-line Interface(CLI; コマンドライン インターフェイス)による設定など、Cisco IOS ソフトウェア基本事項に関する基本知識。

  • ダイヤルピアや音声ポートの設定、QoS(Quality of Service)など、VoIP 基本事項に関する基本知識。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS ソフトウェア リリース 12.2(8)T 以降、最小限の IP Plus(1700 シリーズでの IP/VOX Plus)機能セットを備えたもの。 この資料では、Cisco IOS ソフトウェアでサポートされている Cisco ITS 2.0 を想定しています。

  • 設定例では IP PLUS 機能セットを使用する IOS ソフトウェア リリース 12.2(11)T を使用した Cisco 3660 ゲートウェイが使用されています。ほとんどの IAD 2400、1700、2600、3600、および 3700 シリーズ ルータも現在使用可能です。 現在のバージョンとソフトウェアのサポート情報については、Cisco IOS ソフトウェアのリリース ノートで確認してください。

  • この例では、Cisco ITS 2.0.3 ソフトウェア バンドルが使用されています。 ソフトウェアダウンロードからこのバンドルをダウンロードできます: Cisco Unified CallManager Express/ITS および SRST登録ユーザのみ)。

  • Cisco ITS をサポートするには、各プラットフォームで最大量のメモリを用意することを推奨します。特に、プラットフォームに最大数の電話と Distinguished Name(DN; 識別名)を設定する場合には大量のメモリが必要です。

  • この例では、支店側スイッチとして Catalyst 3500 シリーズ XL スイッチが使用されています。 品質とセキュリティの理由から、VLAN を音声用とデータ用に分けて設定します。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

ネットワーク図

このドキュメントでは次の図に示すネットワーク構成を使用しています。

/image/gif/paws/25100/config_troubleshoot_its1.gif

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

次の表では、個別の VLAN を介した音声とデータの転送に関する情報を示しています。 また、ネットワークとインターフェイスのアドレスとポートも示しています。

目的 VLAN ネットワーク Interface インターフェイスのアドレス
データ 50 10.1.50.0/24 Fa0/0.50 10.1.50.1/24
音声 150 10.1.150.0/24 Fa0/0.150 10.1.150.1/24

Cisco ITS ルータは、Cisco IOS ソフトウェア リリース 12.2(11)T と IP Plus の機能セットが動作している 3660 です。 Cisco ITS ファイルはソフトウェアダウンロードから .tar か .zip 形式でダウンロードする必要があります: Cisco Unified CallManager Express/ITS および SRST登録ユーザのみ)。

これを解凍したら、TFTP を経由して各ファイルをルータのフラッシュに転送する必要があります。 個々のファイルをコピーするたびにフラッシュを消去しないようにしてください。 次の表は、Cisco ITS 2.0.3 にあるファイルの一覧です(これらのすべてのファイルが必要なわけではありません)。

ファイル名 説明
P003G302.bin Cisco 7910 IP Phone 用に Cisco ITS で使用される電話用ロード ファイル。 電話用ロード ファイルには、以前のバージョンの修正の説明を含む別個のリリース ノートがあります。 (必須)
P004G302.bin Cisco 7960 IP Phone 用に Cisco ITS で使用される電話用ロード ファイル。 電話用ロード ファイルには、以前のバージョンの修正の説明を含む別個のリリース ノートがあります。 (必須)
admin_user.html システム設定のための管理者用 Web ページ
ephone_admin.html 電話管理のための Web ページ。
normal_user.html ユーザ(管理者以外)が電話の転送や他の機能などの管理を行うための Web ページ。
telephony_service.html 各ユーザが管理者として電話を設定したり、システムを設定したりするためにアクセスするトップレベルの Web ページ。 (オプション)
logohome.gif
en_dest_busy.au 通話中の内線用の音声プロンプトのサンプル。 its_Cisco.2.0.0.tcl script で使用。
en_dest_unreachable.au 到達不能な内線用の音声プロンプトのサンプル。 its_Cisco.2.0.0.tcl script で使用。
en_disconnect.au 切断されたまたは登録されていない内線用の音声プロンプトのサンプル。 its_Cisco.2.0.0.tcl script で使用。
en_enter_dest.au 相手先に到達したことをユーザに知らせる音声プロンプトのサンプル。 its_Cisco.2.0.0.tcl script で使用。
en_reenter_dest.au 相手先に再到達したことをユーザに知らせる音声プロンプトのサンプル。 its_Cisco.2.0.0.tcl script で使用。
en_welcome.au ユーザのグリーティングを知らせる音声プロンプトのサンプル。 its_Cisco.2.0.0.tcl script で使用。
its_Cisco.2.0.0.tcl コールを内線に送る自動案内のサンプル用の TCL スクリプト。 このサンプル .au ファイルでは、ユーザに応答し、番号を入力するよう指示し、任意の宛先へコールを送ります。
music-on-hold.au 保留中の音楽に使用するオーディオ ファイルのサンプル。

次のファイルも Cisco ITS-2.0.3.zip ファイルに含まれているものですが、ITS ルータのフラッシュにコピーする必要はありません。

ファイル名 説明
CiscoIOSTSP.zip この Telephony Application Programming Interface(TAPI)Service Provider(TSP; TAPI サービス プロバイダー)は Cisco ITS 用に開発されたもので、TAPI(Windows 2000 オペレーティング システムの一部)と ITS との間のインターフェイスの役割を果たします。 TSP は電話ダイヤラおよび ACT のような TAPI ベース アプリケーションを可能にします! Cisco ITS で IP 電話にコール制御を提供するソフトウェア。 Cisco ITS の TAPI 実装はない完全な TAPI スタック、「TAPI ライト」実装でありではない。 ここでは次の項目がサポートされています。
  • 1 回線上に複数のアドレス。
  • アプリケーションによるアドレス ブック ダイヤリングを使用したコールの発信。
  • アプリケーションによるコールへの応答または着信拒否。
  • スクリーン ポップを使用したコールの保留。
  • アプリケーションで使用できる発信者 ID 情報の作成。
  • コールを保留にし、同じ回線の異なるアドレス上でコールを切り替えます。
TSP には、IP Phone の 1 対 1 のリモート制御を行うためのインターフェイスが備えられています。 複数の TSP を同一のコンピュータで実行することができますが、各 TSP で使用できる IP Phone は 1 つだけです。 この TSP では Media Service Provider(MSP)はサポートされていないため、Cisco SoftPhone はサポートされていません。

Cisco CallManager に含まれている TSP は、ITS ではサポートされていません。

設定

Catalyst 3500XL での VLAN の設定

Cisco ITS は、IP Phone と Cisco CallManager が Catalyst スイッチを経由して音声ゲートウェイに接続されている LAN 上で使用されます。 音声データを搬送する VLAN について、これらの装置を正しく設定することは非常に大切です。 このセクションでは、Catalyst 3500XL の設定の概要と、これに対応する音声ゲートウェイ 3660 ルータでの LAN 接続について説明します。

  1. 音声とデータ用の VLAN は、次の例に示すように、未設定のスイッチに設定する必要があります。

    Cat3500BranchSwitch# vlan database
    Cat3500BranchSwitch(vlan)# vlan 50 name corporate-data-vlan
    VLAN 50 added:
    Name: corporate-data-vlan
    Cat3500BranchSwitch(vlan)# vlan 150 name corporate-voice-vlan
    VLAN 150 added:
    Name: corporate-voice-vlan
    Cat3500BranchSwitch(vlan)#
    Cat3500BranchSwitch(vlan)# exit
    APPLY completed.
    Exiting....
    Cat3500BranchSwitch#
  2. 次の例は、Catalyst 3500XL と 3660 ルータ間のインターフェイスの設定例です。

    interface FastEthernet0/1
     description Port to 3660 (supports Dot1q)
     duplex full
     speed 100
     switchport trunk native 50
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 1,50,150,1002-1005
     switchport mode trunk
    !
    
  3. 次に示すものは、電話接続に使用されるポートの例です。

    interface FastEthernet0/2
     description DOT1Q port to IP Phone
     switchport trunk encapsulation dot1q
     switchport trunk native vlan 50
     switchport mode trunk
     switchport voice vlan 150
     spanning-tree portfast
    !
    

詳細については、『Catalyst 2900 シリーズ XL および Catalyst 3500 シリーズ XL スイッチ』を参照してください。

Cisco ITS ルータでの VLAN の設定

Cisco ITS ルータで VLAN を設定するには、次の手順を実行します。

  1. 最初のステップとして、次に示すように、QoS パラメータと VLAN を 3660 インターフェイスに設定します。

    ! 
    class-map match-all L3-to-L2_VoIP-Cntrl
     match ip dscp af31 
    class-map match-all L3-to-L2_VoIP-RTP
     match ip dscp ef 
    !
    !
    policy-map output-L3-to-L2
     class L3-to-L2_VoIP-RTP
      set cos 5
     class L3-to-L2_VoIP-Cntrl
      set COs 3
    !
    
  2. これらのポリシーがインターフェイスに適用され、VLAN が構築されます。

    interface FastEthernet0/0
     description Catalyst 3500 Branch Office Switch
     no ip address
     no ip mroute-cache
     load-interval 30
     speed 100
     full-duplex
    !
    interface FastEthernet0/0.50
     encapsulation dot1Q 50
     ip address 10.1.50.1 255.255.255.0
     service-policy output output-L3-to-L2
    !
    interface FastEthernet0/0.150
     description native subnet 10.1.150.0 voice
     encapsulation dot1Q 150
     ip address 10.1.150.1 255.255.255.0
     service-policy output output-L3-to-L2
    !
    

詳細については、『Catalyst 2900 シリーズ XL および Catalyst 3500 シリーズ XL スイッチ』を参照してください。

Cisco ITS ルータでの DHCP サーバの設定

次のステップは 3660 ルータの DHCPサーバを設定して必要です。 ない IP アドレスが静的に設定されれば外部 DHCPサーバがあるときだけこのステップを必要とします。 次の例では、IP Phone および他の VLAN 上にある他のデバイスに対する DHCP スコープを示しています。

ip dhcp excluded-address 10.1.50.1 10.1.50.10
ip dhcp excluded-address 10.1.150.1 10.1.150.10
!
ip dhcp pool ip-phones
 network 10.1.150.0 255.255.255.0  

!--- This defines the range of IP addresses to be assigned.

 default-router 10.1.150.1
 option 150 ip 10.1.150.1   

!--- This must be the IP address of the ITS router.  

!
ip dhcp pool Data-clients
 network 10.1.50.0 255.255.255.128
 default-router 10.1.50.1 
 domain-name cisco.com
 dns-server 10.1.50.100 
 netbios-name-server 10.1.50.100 
!

特定のデバイスに対してのみ DHCP を有効にしたい場合は、host コマンドを使用して DHCP スコープを作成します(上で示した network コマンドは使用しません)。 IP アドレスを与えたい IP Phone に対して、クライアントの識別子やハードウェアのアドレスも設定する必要があります。 クライアント識別子には、01 + 電話の MAC アドレスを指定します。ハードウェアのアドレスには、パラメータとして、その電話の MAC アドレスを含める必要があります。

詳細は、『Cisco IOS DHCP サーバ』を参照してください。

Cisco ITS ルータでの時刻の設定

IP Phone は自身の日付および時刻の設定を Cisco ITS ルータから受信するため、ルータ上の時刻が正しく設定されていることが重要です。 可能であれば、NTP を設定することを強く推奨します。 時間帯、および必要に応じてサマータイムを指定し、NTP サーバを設定してください。 次に例を示します。

its-router(config)# clock time EST -5
its-router(config)# clock summer-time EST recurring 
its-router(config)# ntp server 172.18.106.15

NTP の詳細は、『基本的なシステム管理コマンドの実行』を参照してください。

3660 での Cisco ITS の設定

基本設定

3660 上に Cisco ITS を設定するには、次の設定を入力する必要があります。

telephony-service
 load 7910 P004G302       

!--- This is the load file minus the .bin extension. 
!--- Only the 7910, 7940/7960, and 7935 IP Phones are supported.


 load 7960-7940 P003G302  

!--- This is the load file minus the .bin extension.

 ip source-address 10.1.150.1 port 2000  

!--- This is the ip address of the Cisco ITS router on the voice subnet.

 max-ephones 48  

!--- This is the total number of phones that will be allowed to register.
!--- The maximum varies by platform and sometimes by software level.


 max-dn 192      

!--- This is the maximum number of directory numbers that can be configured 
!--- on this gateway (maximum varies by platform and sometimes by software level).

 voicemail 52222 

!--- This is the number that will be dialed when the "Messages" 
!--- button is pressed on the phone (optional).

!

他のコマンドのほとんどはオプションです。 必須なのは、「load」文で(すべての電話に必要なわけではありません)、ip source-addressmax-ephones、および max-dn コマンドです。

Cisco ITS ルータは Cisco Unified CallManager のバージョンからのロード ファイルと先に動作するようにより 3.1 設計されています; たとえば、SEPDEFAULT.cnf ファイルから設定を得る XML ファイルからのよりもむしろロード ファイル。 このコマンドが設定にあることを確かめて下さい:

tftp-server 
  flash:XMLDefault.cnf.xml

その他のテレフォニーサービスのオプションについては、次のとおりです。

Its-router(config-telephony)# telephony-service
its-router(config-telephony)# ? 
  Cisco IOS Telephony Service configuration commands:
  admin-password      define password for admin user
  admin-username      define username for admin user
  date-format         Set date format for IP Phone display 
  default             Set a command to its defaults
  dialplan-pattern    Define E.164 telephone number prefix
  directory           Define directory naming order
  dn-webedit          enable Edit DN through Web
  exit                Exit from telephony-service configuration mode
  ip                  Define IP address and port for Telephony-Service/Fallback
  keepalive           Define keepalive timeout period to unregister IP phones
  load                Select the IP phone firmware load file
  max-conferences     Define max number of 3 party G.711 conferences
  max-dn              Maximum directory numbers supported 
  max-ephones         Define max number of IP phones
  moh                 Define music-on-hold filename
  mwi                 Define IP address and port for MWI Server
  no                  Negate a command or set its defaults
  reset               reset ethernet phone
  time-format         Set time format for IP Phone display 
  time-webedit        enable Edit Time through Web
  timeouts            Define timeout value for IP phone
  transfer-pattern    Define valid call transfer destinations
  url                 Define Ephone URL's
  voicemail           Set the voicemail access number called when the MESSAGES IP
                      phone button is pressed

its-router(config-telephony)#

注意 注意: 日付か時刻形式の変更のようなテレフォニーサービスへの変更の多数は、電話がリセットするように要求します。 max-ephones や max-dn 設定などのオプションを変更した場合は、ルータの完全なリロードが必要になります。 すべての電話をリセットするには、次のように入力してください。

its-router(config-telephony)# telephony-service
its-router(config-telephony)# reset all

いくつかのこれらのオプションは以降のセクションで説明されています; 他は Cisco IOS Telephony Service バージョン 2.01 を示すことによって検索することができます。

ITS ルータでの TFTP の設定

ITS ルータで TFTP を設定するには、次の手順を実行します。

  1. すべてのファイルがルータのフラッシュに正しく転送されていることを確認してください。 少なくとも、P003G302.bin と P004G302.bin はロードされている必要があります。 これらがロードされると、フラッシュは次の例のようになります。

    Its-router# show flash
    System flash directory:
    File Length    Name/status
    1    16084816  c3660-is-mz.122-11.T 
    2    229542    admin_user.html 
    3    42484     en_dest_busy.au 
    4    26376     en_dest_unreachable.au 
    5    14352     en_disconnect.au 
    6    19512     en_enter_dest.au 
    7    17167     en_reenter_dest.au 
    8    17486     en_welcome.au 
    9    4152      ephone_admin.html 
    10   5968      its_Cisco.2.0.0.0.tcl 
    11   29092     logohome.gif 
    12   496521    music-on-hold.au 
    13   35138     normal_user.html 
    14   268008    P003G302.bin 
    15   258360    P004G302.bin 
    16   522       telephony_service.html 
    17   54        SEPDEFAULT.cnf     
    
    !--- This file will not show up until telephony-service is configured.
    
    18   249       XMLDefault.cnf.xml 
    
    !--- This file will not show up until telephony-service is configured.
    
    [17551227 bytes used, 49033349 available, 66584576 total]
    65536K bytes of processor board System flash (Read/Write)
    
    its-router#
    
  2. この設定では、IP Phone が TFTP ごとに Cisco ITS ルータからロード ファイルをダウンロードできるようにする必要があります。 これらのファイル名は大文字小文字が区別されることに注意してください。

    tftp-server flash:P003G302.bin
    tftp-server flash:P004G302.bin
    tftp-server flash:SEPDEFAULT.cnf
    tftp-server flash:XMLDefault.cnf.xml
    
  3. SEPDEFAULT.cnf および XMLDefault.cnf.xml ファイルは telephony-service および IPソースアドレス commandsare が発行したら自動的に作成されます

  4. XMLDefault.cnf.xml ファイルには、ATA アダプタの登録先のルータのいずれかのイーサネット ポートの IP アドレスが含まれています。 これらのファイルはルータに固有であり、複数のルータで共有することはできません。

ITS ルータでの IP Phone の設定

ITS ルータで IP Phone を設定するには、次の手順を実行します。

  1. この時点で、IP Phone が接続され DHCP アドレスを受け取っていれば、Cisco ITS ルータに登録できます。 IP Phone にはまだ回線が設定されていません。 show ephone コマンドを発行し、次のような出力を確認することで、電話が登録されたことが分かります。

    its-router# show ephone
    ephone-1 Mac:0006.D74B.0F46 TCP socket:[1] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.10 50568 Telecaster 7960 keepalive 889 max_line 6
    
    
    ephone-2 Mac:0006.D74B.1361 TCP socket:[2] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.11 52397 Telecaster 7960 keepalive 872 max_line 6
    
    
    ephone-3 Mac:0006.D74B.107C TCP socket:[3] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.12 51116 Telecaster 7960 keepalive 871 max_line 6
    
    
    ephone-4 Mac:0008.E31B.7A8A TCP socket:[5] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.13 50321 Telecaster 7960 keepalive 867 max_line 6
    
    its-router#
  2. これらの電話の設定は、CLI または Web 管理から行うことができます (このドキュメントの「Cisco ITS ルータの Web 管理の設定」セクションを参照してください)。 Cisco 7910 IP Phone には特殊な設定情報があります。「7910 IP Phone 用の Cisco ITS の設定」セクションを参照してください。

    !
    ephone-dn 1
     number 1000
     name George P Burdell
     call-forward noan 52222 timeout 10
     no huntstop
    !
    ! 
    ephone-dn 2
     number 1000
     name George P Burdell
     preference 1
     call-forward busy 52222
     call-forward noan 52222 timeout 10
    !
    !
    ephone-dn 10
     number 1111
     name Helpdesk
     no huntstop
    !
    !
    ephone-dn 11
     number 1111
     name Helpdesk
     preference 1
    !
    !
    ephone-dn 12
     number 1111
     name Helpdesk
     preference 2
    !
    !
    ephone-dn 13
     number 1111
     name Helpdesk
     preference 3
    !
    
  3. 各 ephone-dn が 1 本の回線を表します。 必要に応じてこれらの回線を複数の電話に割り当てることができます。 この例では、あるユーザに対して、2 本の回線で内線 1000 が設定されています。 4 回線のハント グループになっているヘルプデスクの回線も追加されています。 ここで ephone を設定し、実際の電話装置に回線を割り当てます。

    !
    ephone 1
     username "gpburdell" password letmein
     mac-address 0006.D74B.0F46
     button 1:10 2:11 3:12 4:13 5:1 6:2
    !
    !
    !
    ephone 2
     Mac-address 0006.D74B.1361
     button 1:15 2:10 3:11 4:12 5:13
     speed-dial 1 1000
    !
    
  4. button タグは、ephone-dn タグを引用しています。 show ephone コマンドの出力は、次のようになります。

    its-router# show ephone
    ephone-1 Mac:0006.D74B.0F46 TCP socket:[3] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.14 52311 Telecaster 7960 keepalive 6 max_line 6
    button 1: dn 10 number 1111 IDLE 
    button 2: dn 11 number 1111 IDLE 
    button 3: dn 12 number 1111 IDLE 
    button 4: dn 13 number 1111 IDLE 
    button 5: dn 1 number 1000 IDLE 
    button 6: dn 2 number 1000 IDLE 
    Username: gpburdell Password: letmein 
    
    
    ephone-2 Mac:0006.D74B.1361 TCP socket:[2] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.11 50512 Telecaster 7960 keepalive 7 max_line 6
    button 1: dn 15 number 1001 IDLE 
    button 2: dn 10 number 1111 IDLE 
    button 3: dn 11 number 1111 IDLE 
    button 4: dn 12 number 1111 IDLE 
    button 5: dn 13 number 1111 IDLE 
    speed dial 1:1000
    
    its-router#
    Ephone 1 Ephone 2
    回線 1 1111 回線 1 1001
    回線 2 1111 回線 2 1111
    回線 3 1111 回線 3 1111
    回線 4 1111 回線 4 1111
    回線 5 1000 回線 5 1111
    回線 6 1000 回線 6 George P Burdell

  5. コールが 1111 に送られてくると、だれかがそれを取るまで呼び出し音が鳴ります(コールの転送は設定されていません)。 ephone-dn 10(ephone 1 の 回線 1、あるいは ephone 2 の回線 2)が使用中の場合、1111 への次のコールは自動的に ephone-dn 10 に送られます。これは huntstop が設定されておらず、優先順位が高い(デフォルトの優先順位は 0)ためです。 優先順位が同じである場合は、両方の回線で呼び出し音が鳴ります。

  6. 1000 に向けてコールが発呼され、だれもこれを取らなかった場合、ボイスメールに転送されます(このコール転送設定では内線 5222)。 ephone-dn 1 が使用中である場合、回復は ephone-dn 2.にルーティングされます。 これは huntstop が設定されないというファクトおよび規則的なダイヤル ピアルーティングが理由でそうなったものです。 この場合、ビジー時の転送設定は、ビジー状態の時に別の DN へコールを転送(たとえば、1000 がビジーのとき、1001 へ転送)したい場合以外は必要ありません。 ephone-dn 2 では、ビジーまたは応答がない場合にコールを転送する設定が必要です。これは、コールのルート先となる優先順位の高い内線 1000 が他にないためです(このような内線がある場合でも、暗黙的に huntstop が設定されているため、コールは終了してしまいます)。

通常のダイヤルピア ルーティングの詳細については、ボイスに関する技術サポートを参照してください。

ephone 1 にも、「gpburdell」用のユーザ名とパスワードがあります。 これを使用すると、ユーザは同じ telephony_service.html の Web ページにアクセスおよびログインでき、自身の転送先(ビジー、応答がない場合、すべての場合)および短縮ダイヤルの変更、さらには市内電話の検索が行えます。

Ephone 2 にラインの 6.速度ダイヤルがあります。 そのボタンが押される場合、1001 は 1000 にダイヤルします。 speed-dial コマンド自体はボタン 位置を規定 しません。 それは最初の自由な行が 1000 に番号を付ける速度ダイヤルであること、この場合言います。 この場合、回線 6 が短縮ダイヤルになることは、直接的には設定されていません。 たとえば、他の短縮ダイヤルが設定されると(「短縮ダイヤル 2、1004」)、エラーは発生しませんが、どちらも表示されません。

ephone-dns のその他の設定コマンドには次のものが含まれています。

its-router(config-ephone-dn)# ?
Ephone DN configuration commands:
  application   The selected application
  call-forward  Define E.164 telephone number for call forwarding
  caller-id     Configure port caller id parameters
  cor           Class of Restriction on dial-peer for this dn
  default       Set a command to its defaults
  description   dn desc, for DN Qualified Display Name
  exit          Exit from ephone-dn configuration mode
  hold-alert    Set Call On-Hold timeout alert parameters
  huntstop      Stop hunting on Dial-Peers
  intercom      Define intercom/auto-call extension number
  loopback-dn   Define dn-tag to create loopback dn pair with this ephone-dn
  mwi           set message waiting indicator options (mwi)
  name          Define dn user name
  no            Negate a command or set its defaults
  number        Define E.164 telephone number 
  paging        set audio paging mode
  preference    Preference for the attached dial-peer for the primary dn number
  translate     Translation rule

its-router(config-ephone-dn)#

次に示すものは、ephone のその他の設定コマンドです。

Its-router(config-ephone-dn)# ephone 1
its-router(config-ephone)# ?
Ethernet phone configuration commands:
  button        define button to dn map
  default       Set a command to its defaults
  exit          Exit from ephone configuration mode
  Mac-address   define ethernet phone MAC address
  no            Negate a command or set its defaults
  paging-dn     set audio paging dn group for phone
  reset         reset ethernet phone
  speed-dial    Define ip-phone speed-dial number
  username      define username to access ethernet phone from Web
  vm-device-id  define voice-mail id string

its-router(config-ephone)#

注意 注意: 電話が変更適用する ephone-dn、または ephone へのあらゆる変更の後でリセットされなければなりません。 これは ephone で reset コマンドを使っても行えます。また、先に説明したテレフォニーサービスの設定メニューでグローバルに行うこともできます。

7910 IP Phone 用の Cisco ITS の設定

7960 IP Phone と異なり、7910 には回線ボタンが 1 つしかありません。 この電話でコール ウェイティングや転送をサポートするには、回線が 2 本必要です。 したがって、この電話に対しては、次のように同じ DN を使って 2 本の回線を設定します。

ephone-dn  20
 number 1020
 no huntstop
!
!
ephone-dn 21
 number 1020
 preference 1
!
...
ephone 10
 button 1:20 2:21
!

回線が 2 本ある場合でも、これらの回線を同時に保留状態にすることはできません。 1 本目の回線が保留状態のとき、回線ボタンを押すと 2 本目の回線が選択され、2 回目の電話をかける(あるいは応答する)ことになります。 2 回目のコールが接続された後、保留ボタンを押すと 2 本目の回線が保留状態になり、1 本目の回線に再接続されます。 再度保留ボタンを押すと、1 本目の回線と 2 本目の回線が切り替わります。 再度回線ボタンを押すと、現在接続されている相手との通信が切断されます。

Cisco ITS ルータの Web 管理の設定

Cisco ITS サーバを Web 経由で間違いなく管理するため、さらにはユーザが Web 経由で自身の電話を管理できるようにするためには、次のファイルがフラッシュにコピーされている必要があります。

  • admin_user.html

  • ephone_admin.html

  • logohome.gif

  • normal_user.html

  • telephony_service.html

Web ページを Web 経由で管理できるようにするには、次のグローバル設定コマンドを入力する必要があります。

ip http server
  ip http path flash

他のコマンドは、テレフォニーサービス設定のセクションで入力する必要があります。

telephony-service
 admin-username administrator 

 !--- This sets up the administrator account used to access the web page.

 admin-password cisco  

 !--- This sets up the password for the admin account.

 dn-webedit    

 !--- (optional) This permits the editing of DNs through the web interface.

 time-webedit  

 !--- (optional) This permits editing of the system time through the web interface.

!

Cisco ITS ルータに Web 経由でアクセスするには、ブラウザで次の URL を指定します。

http://ITSrouter_ipaddr/telephony_service.html

この URL はどのユーザでも同じです。 他の .html ファイルは、telephony-service.html の Web ページから呼び出される内部ファイルです。 他のファイルを直接開くと、JavaScript エラーが発生します。 この Web ページを使用するユーザは、次に示すように初めに ephone を設定する必要があります。

ephone 1
 username "gpburdell" password letmein

ユーザ(この例では「gpburdell」)は、ログイン、転送情報の変更、電話番号検索が行え、さらに自分自身の短縮ダイヤルの設定を変更することもできます。 また、オンライン ヘルプも使用できます。

管理者は、電話または DN の追加、削除、および変更、さらにはシステムの変更を行えます。 Web ページは Cisco IOS 設定を定期的に取得することができず、またブラウザの更新ボタンでは情報を更新できません。そのため、Web 経由で設定を行う場合には、コマンドラインによる設定と同様に問題が生じる場合があることに注意してください。 実際、そういう風にでリフレッシュすることを試みるとき GUI ページから記録 され、「コンフィギュレーション変更を見るために、コンフィギュレーション変更与えられません」エラーメッセージ ボックスを失敗しました。 Cisco ITS ルータから最新の情報を取得できるのは、メイン メニューの Update ボタンだけです。

Web ページ上で Write System Configuration ボタンをクリックすると、変更がただちに NVRAM に書き込まれます。 しかし、通常のユーザの場合、vty、コンソール、および予備回線上にアクティブなセッションがない限り、10 分ごとに変更が書き込まれます。

通常の設定の変更には vty 回線の空きは 1 本だけで十分ですが、作業を更新する場合、Cisco ITS で vty 回線に少なくとも 4 本の空きがあることを確認してください。

コール履歴情報は、管理者も参照できます。 次のように、初めに設定で有効にしておく必要があります。

call-history-mib retain-timer 500
call-history-mib max-size 500

MIB テーブルに保存されるコール履歴の最大数は 500 エントリで、最大分数は 500 分です。

ログインした後に GUI から View System Configuration を選択し、View Call History Information を選択すると、コールの記録が表示されます。

Cisco ITS ルータでの PSTN 接続の設定

ITS ルータに音声インターフェイス カードがあり、IP Phone でコールの発信と受信を行えるようにそれらのカードを設定したいと仮定します。 この作業は、ルータ上の他の音声接続と大きく異なるものではありません。 各 ephone-dn に割り当てられた番号を持つ ephone を、ルータの Foreign Exchange Station(FXS)ポートとして考えることができます。

その他の ITS 機能の設定

保留機能の設定

外部からの発信者に対する付加的な機能としては、Music on Hold(MoH; 保留音)や Tone on Hold(ToH; 保留トーン)があります。 ToH はデフォルトで常にオンに設定されており、オフにすることはできません。 MoH は、Public Switched Telephone Network(PSTN; 公衆電話交換網)または G.711 でのオンネット コールを保留にしたときに流すことができます。 同じ ITS ルータの IP Phone 同士のコールが保留にされたときは、常に ToH のビープ音しか聞こえません。 MoH 使用する場合は、フラッシュにオーディオ ファイルがあることを確認した後、次のように設定してください。

telephony-service
 moh music-on-hold.au

MoH として再生される .au または .wav ファイルは、G.711 u-law または a-law 形式である必要があります。 コール ウェイティングと ToH の区別は次のとおりです。コール ウェイティングはビープ間隔が 10 秒ごとの周期的なビープ音として聞こえます。 コール ウェイティング中の複数の回線がある場合も、10 秒ごとにトーンが 1 回送信されます。 しかし、ToH では 8 秒間隔で 3 回のビープ音が繰り返し聞こえます(1 つのトーンが 3 回繰り返されます)。 ToH はコール ウェイティング トーンよりも高い優先順位を持っています。 両方のトーンがまったく同時に発せられた場合、ユーザには ToH が最初に聞こえ、8 秒後に次の ToH が聞こえ、さらに 2 秒後になってようやくコール ウェイティング トーンが聞こえます。

コールが保留にされた後、ユーザにコールが保留のままであることを知らせる音声の送信には、次のようないくつかのオプションがあります。

Its-router(config-ephone-dn)# hold-alert 15 ?
  idle        alert on-hold originator only if idle
  originator  alert on-hold originator always
  shared      alert all phones that share the line

1 秒間のリング アラートが設定された間隔(15 ~ 300 秒)で、コールを保留にした側がアイドル状態の場合はこの側に対して常に送られるように設定することができます。 もう 1 つのオプションは、同じ回線を共有しているすべての電話に対してアラートを送るように設定することです。 デフォルトでは、コールがどれだけ保留状態にされていてもアラートは発せられません。

会議の設定

全通話者が G.711 ユーザであり、会議用リソースが使用できる場合、3 者による会議がサポートされています。 会議用リソースは次のようにして設定します。

telephony-service
 max-conferences 10

会議に参加する通話者のだれかが保留ボタンを押すと、他の 2 人の通話者には MoH または ToH が聞こえます。 ただし、この音楽またはトーンが聞こえていても、2 人の通話者は互いに会話をすることができます。

転送の設定

着信コールの転送機能には、多くの場合、別の設定が必要です。 デフォルトでは、Cisco ITS に登録された IP Phone は、同じ ITS ルータに登録されている他の IP Phone に転送することができます。 PSTN や VoIP の宛先など、その他の転送はできません。 これらの転送を行うには、次のようにテレフォニーサービスで転送パターンを登録する必要があります。

Telephony-service
 transfer-pattern 9.......

ここで、コールを PSTN にルーティングするためのアナログ電話回線のダイヤルピアがあるとすると、IP Phone からは最初に 9 をダイヤルして、任意の 7 桁の番号にコールを転送できるようになります。 ITS による 2 次的なダイヤルトーンに対するオプションはありません。

注意 注意: パーティが両方ともハングアップした後でさえもこれにより両方のポートは使用中に残りますかもしれないので、特に気をつけて時 ITS ルータの外国為替事務所 (FXO) ポートによって入り、別の FXO ポートによって出かけた着信転送であって下さい。 『ボイス - FXO コール切断問題』を参照してください。 契約しているプロバイダーで FXO による切断監視方式がサポートされていない場合は、転送されたコールを PSTN に返すことはできません。

他の VoIP の宛先(他の ITS ルータなど)から到達したコールを転送するには、loopback-dn が必要です。 これは、このドキュメントで扱う範囲を超えた高度なトピックです。

インターコムの設定

インターコム機能を使用すると、2 つの IP Phone の間で press-to-talk 機能が使用できるようになります。 これは共有回線ではサポートされていません。つまり、インターコムのオペレーション用に設定された ephone-dn は、1 台の IP Phone とのみ関連付けられることを意味しています。

!
ephone-dn 30
number A1234
name "Intercom"
intercom A4321 label "Office A"
!
!
ephone-dn 31
number A4321
name "Intercom"
intercom A1234 label "Office B"
!
...
!
ephone 3
Mac-address 0006.D74B.107C
button 1:16 6:30
!
!
!
ephone 4
Mac-address 0008.E31B.7A8A
button 1:17 6:31
!

ここで、ephone 4 で回線 6 が押されると、ephone 3 の回線 6 に電話がかかります(たとえば、A1234 へ自動的にかかります)。 デフォルトでは、相手先の電話がオンフックの場合、その電話はオフフックになり、会話モードになった後、マイクロフォンの音が消されます。 intercom コマンドのその他のオプションには、barge-inno-auto-answer があります。 barge-in オプションを使用すると、着信したインターコム コールによって既存のコールが強制的に保留状態になります。 次に、その電話はインターコム コールにただちに応答できるようになります。 no-auto-answer オプションを使用すると、インターコム コールは自動的にピックアップされず、単に呼び出し音が鳴るだけです。

インターコム コールがあると、短縮電話の場合のように、画面の右側に intercom 文で設定されたラベルが表示されます。 このラベルのオプションがない場合、回線表示の左側に名前(ephone-dn で設定されている場合)が、インターコムの番号が右側に表示されます。

Cisco 7910 でのインターコム機能の使用は推奨されません。それは、この電話機にはマイクロフォンが無く、スピーカは消音状態を無効にすることができないため、応答するために受話器を取る必要があるためです。

ページングの設定

ページング機能は、上で説明したインターコム機能と同様に動作しますが、ボタンを押して応答するというオプションが無く、単方向の音声ストリームのみを提供する点が異なります。 アイドル状態の電話だけページングによって達します; 使用中の電話はページを受け取りません。 ページングでは、ユニキャスト(最大 10 デバイス)、マルチキャスト、またはその両方を使用した音声配信をサポートしています(そのため、マルチキャストでの音声を受信できない電話にも配信できます)。 マルチキャスト ページングを使用することを推奨します。 ページングを受ける内線には、一意の IP マルチキャスト アドレスが必要です。

たとえば 3 つのページング グループが作成されると、言って下さい: 「個人を」、「クールではない人々」、および「全員冷却して下さい」、最初の 2 グループの合計単にです。 音声の配送方法はマルチキャストで、これは次のように設定します。

!
ephone-dn 40
 number 4001
 name "Cool People"
 paging ip 239.0.1.20 port 2000
!
!
ephone-dn 41
 number 4002
 name "Uncool People"
 paging ip 239.0.1.21 port 2000
! 
!
ephone-dn 42
 number 4000
 name "All People"
 paging ip 239.0.1.22 port 2000
 paging group 40,41
!

IP Phone では、224.x.x.x アドレスでのマルチキャストがサポートされません。

次に示すように、各 ephone を設定し、ページング DN に割り当てます(各 ephone に対するその他の設定は省略)。 各 IP Phone は 1 つのページング グループにのみ属することに注意してください。 また、ページング用に設定された ephone-dn には、電話のボタンを割り当てないでください。

!
ephone 1
 paging-dn 40
!
ephone 2
 paging-dn 40
!
ephone 3
 paging-dn 41
!
ephone 4
 paging-dn 41
!
ephone 5
 paging-dn 42
!

この設定により、ページング番号 4001(「Cool People」)が ephone 1 および ephone 2 に、ページング番号 4002(「Uncool People」)が ephone 3 および ephone 4 に、そしてページング番号 4000(「All People」)が ephone 1 ~ 5 に割り当てられました。

たとえば、4001 に対するすべてのコールは(ビジー状態でない限り)ephone 1 と 2 に接続されます。

ページングは、ITS ルータから最大 1 ルータ ホップ離れた範囲までサポートされます。

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

次に示す show telephony-service コマンド(特に all)を発行すると、設定のスナップショットが表示されます。

its-router# show telephony-service ?
  admin        Show telephony-service admin username and password
  all          Show telephony-service details
  dial-peer    Show telephony-service dialpeers 
  ephone       Show ephone configuration
  ephone-dn    Show ephone-dn configuration
  voice-port   Show telephony-service voice ports
  |            Output modifiers
<cr>

次に示す show ephone コマンドを発行すると、IP Phone の現在の状態を見ることができます。 たいていの場合、必要となるのは自分自身による show ephone の実行です。

Its-router# show ephone ?
  7910              7910 phone status
  7940              7940 phone status
  7960              7960 phone status
  H.H.H             mac address
  dn                Dn with tag assigned
  offhook           Offhook phone status
  registered        Registered ephone status
  remote            non-local phones (with no arp entry)
  ringing           Ringing phone status
  summary           Summary of all ephone
  tapiclients       Ephone status of tapi client
  telephone-number  Telephone number assigned
  unregistered      Unregistered ephone status
  |                 Output modifiers
  <cr>

show ephone-dn コマンドの出力は、show voice port コマンドの出力に非常によく似ています。 多くの一般的な問題に対しては、このコマンドよりも他のツールの方が便利な場合があります。

Its-router# show ephone-dn ? 
  <1-960>   dn tag
  loopback  Show ephone-dn in loopback mode
  summary   Summary of all ephone-dn
  |         Output modifiers
  <cr>

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

トラブルシューティングのためのコマンド

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

debug コマンドを使用する前に、『debug コマンドに関する重要な情報』を参照してください。

Cisco ITS には、いくつかのトラブルシューティング コマンドとデバッグ機能があり、情報をより容易に収集することができます。

問題のトラブルシューティングの際に有効なデバック機能がいくつかあります。 特に debug ephone コマンドは、Cisco ITS だけが備えているコマンドです。

Its-router# debug ephone ?
  alarm       Enable ephone alarm message debugging
  detail      Enable ephone detail debugging
  error       Enable ephone error debugging
  keepalive   Enable ephone keepalive debugging
  loopback    Enable ephone loopback debugging
  moh         Enable ephone music-on-hold debugging
  mwi         Enable ephone mwi debugging
  pak         Enable ephone packet debugging
  raw         Enable ephone raw protocol debugging
  register    Enable ephone registration debugging
  state       Enable ephone state debugging
  statistics  Enable ephone statistics debugging

1 台または 2 台の電話に関する問題のトラブルシューティングを行う際、問題が登録、Message Waiting Indicator(MWI)、MoH に関係していない限り、ほとんどの場合は debug ephone error および debug ephone state コマンドが有効です。 電話が何台もある場合は、関連のある機器の MAC アドレスだけに出力を絞り込むのがよい方法です。 次に、例を示します。

its-router# debug ephone state Mac-address 0009.433C.E5EC
EPHONE state debugging is enabled for phone 0009.433C.E5EC

リモート VoIP の宛先へのコールなどに関する問題には、debug voip ccapi inoutdebug vtsp all コマンドなど、Cisco ルータの VoIP に関するより一般的な debug コマンドが必要な場合があります。 PSTN シグナリングやその他の実装特有の項目に対するトラブルシューティングについては、このドキュメントでは触れていません。 詳細は、次の文書を参照してください。

1004 から 1002 までコールのためのサンプル debug ephone state コマンド出力はここにあります。 show ephone コマンド出力の関連した部分は下記に示されています。

ephone-3 Mac:0006.D74B.107C TCP socket:[5] activeLine:0 REGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:1
IP:10.1.150.12 51718 Telecaster 7960 keepalive 92 max_line 6
button 1: dn 16 number 1002 IDLE 


ephone-4 Mac:0008.E31B.7A8A TCP socket:[2] activeLine:0 REGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:1
IP:10.1.150.13 50396 Telecaster 7960 keepalive 96 max_line 6
button 1: dn 17 number 1004 IDLE

ここで、デバッグの内容を調べます。 OFFHOOK メッセージがあり、電話が発呼され(このトレースでは、取得された個々の番号は記述されていません)、応答されています。 OpenReceive チャネル メッセージは各電話に送られ、確認される以降です; StartMedia メッセージはオーディオをにか送信 するどんな IP アドレスおよびポート各電話に述べています。 最後に、ONHOOK メッセージが現れます。

Its-router# debug ephone state
EPHONE state debugging is enabled
its-router#
Sep 26 18:39:40.837: ephone-4[2]:OFFHOOK
Sep 26 18:39:40.837: ephone-4[2]:SIEZE on activeline 0
Sep 26 18:39:40.837: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsOffHook
Sep 26 18:39:40.837: DN 17 Voice_Mode
Sep 26 18:39:40.837: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:40.841: dn_tone_control DN=17 tonetype=33:DtInsideDialTone onoff=1 pid=113
Sep 26 18:39:40.841: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:40.841: dn_tone_control DN=17 tonetype=33:DtInsideDialTone onoff=1 pid=113
Sep 26 18:39:42.349: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:42.853: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:43.105: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:43.609: ephone-4[2]:Skinny-to-Skinny call DN 17 to DN 16 instance 1
Sep 26 18:39:43.609: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsRingOut
Sep 26 18:39:43.609: ephone-4[2]:Call Info DN 17 line 1 ref 52 called 1002 calling 1004 
origcalled calltype 2
Sep 26 18:39:43.609: ephone-4[2]: John Doe calling 
Sep 26 18:39:43.609: ephone-4[2]: Jane Doe
Sep 26 18:39:43.609: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:43.609: ephone-3[5]:SetCallState line 1 DN 16 ref 53 TsRingIn
Sep 26 18:39:43.613: ephone-3[5]:Call Info DN 16 line 1 ref 53 called 1002 calling 1004 
origcalled calltype 1
Sep 26 18:39:43.613: ephone-3[5]: John Doe calling 
Sep 26 18:39:43.613: ephone-3[5]: Jane Doe
Sep 26 18:39:43.613: ephone-3[5]:Ringer Inside Ring On
Sep 26 18:39:43.613: dn_tone_control DN=17 tonetype=36:DtAlertingTone onoff=1 pid=113
Sep 26 18:39:51.926: ephone-3[5]:OFFHOOK
Sep 26 18:39:51.926: ephone-3[5]:Ringer Off
Sep 26 18:39:51.926: ephone-3[5]:ANSWER call
Sep 26 18:39:51.926: ephone-3[5]:Answer Incoming call from ephone-(4) DN 17
Sep 26 18:39:51.926: ephone-3[5]:SetCallState line 1 DN 16 ref 53 TsConnected
Sep 26 18:39:51.926: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsConnected
Sep 26 18:39:51.926: ephone-4[2]:OpenReceive DN 17 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:39:51.926: ephone-3[5]:OpenReceive DN 16 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:39:51.926: dn_tone_control DN=16 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:51.930: DN 17 End Voice_Mode
Sep 26 18:39:51.930: DN 17 Voice_Mode
Sep 26 18:39:51.930: DN 16 Voice_Mode
Sep 26 18:39:51.930: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:52.182: ephone-4[2]:OpenReceiveChannelAck:IP 10.1.150.13, port=23094, 
dn_index=17, dn=17
Sep 26 18:39:52.182: ephone-3[5]:StartMedia 10.1.150.13 port=23094
Sep 26 18:39:52.182: DN 17 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:39:52.182: ephone-3[5]:OpenReceiveChannelAck:IP 10.1.150.12, port=22778, 
dn_index=16, dn=16
Sep 26 18:39:52.182: ephone-4[2]:StartMedia 10.1.150.12 port=22778
Sep 26 18:39:52.182: DN 17 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:40:01.254: ephone-3[5]:ONHOOK
Sep 26 18:40:01.254: ephone-4[2]:CloseReceive
Sep 26 18:40:01.254: ephone-4[2]:StopMedia
Sep 26 18:40:01.254: ephone-3[5]:call clean up this DN 16 was called by other DN 17
Sep 26 18:40:01.254: this ephone-3 other ephone-(4) other DN state CONNECTED
Sep 26 18:40:01.254: ephone-3[5]:CloseReceive
Sep 26 18:40:01.254: ephone-3[5]:StopMedia
Sep 26 18:40:01.254: DN 16 End Voice_Mode
Sep 26 18:40:01.254: ephone-3[5]:SetCallState line 1 DN 16 ref 53 TsOnHook
Sep 26 18:40:01.254: ephone-3[5]:SpeakerPhoneOnHook
Sep 26 18:40:01.254: DN 17 End Voice_Mode
Sep 26 18:40:01.254: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsOnHook
Sep 26 18:40:01.254: ephone-4[2]:SpeakerPhoneOnHook
Sep 26 18:40:01.258: ephone-3[5]:SpeakerPhoneOnHook
Sep 26 18:40:01.354: DN 16 Voice_Mode
Sep 26 18:40:01.354: DN 16 End Voice_Mode
Sep 26 18:40:01.354: dn_tone_control DN=16 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:40:01.366: SkinnyReportDnState DN 17 ONHOOK
Sep 26 18:40:01.366: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113

関連情報


Document ID: 25100