音声 : H.323

Cisco IOS ゲートキーパーのコール ルーティングについて

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2010 年 11 月 15 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

Cisco ゲートキーパーは、ゲートウェイを論理的なゾーンにグループ化し、ゾーン間のコール ルーティングを実行するために使用されます。 ゲートウェイは、Public Switched Telephone Network(PSTN; 公衆電話交換網)と H.323 ネットワークの間のエッジ ルーティングの決定を担当します。 Cisco ゲートキーパーは、H.323 ネットワーク内のデバイス間のコア コール ルーティングを処理し、一元化されたダイヤル プラン管理を行います。 Cisco ゲートキーパーが存在しない場合、それぞれの終端側ゲートウェイの明示的な IP アドレスは、発信側ゲートウェイで設定され、Voice over IP(VoIP)ダイヤルピアと照合される必要があります。 Cisco ゲートキーパーが存在する場合、ゲートウェイはリモートの VoIP ゲートウェイとの VoIP コールを確立しようとするときにゲートキーパーに照会します。

たとえば、コールとともに提示されると、ゲートウェイは、そのコールをそのダイヤル プランに従ってテレフォニー レッグと IP レッグのどちらに送信するのかを判断します。 IP レッグの場合、ゲートウェイは最良のエンドポイントを選択するために Cisco ゲートキーパーに照会します。 次に、Cisco ゲートキーパーは、着信側エンドポイントがローカル ゾーン内にあるデバイスなのか、リモートの Cisco ゲートキーパーによって制御されるリモート ゾーンにあるデバイスなのかを判断します。

前提条件

要件

Cisco は、『H.323 ゲートキーパーについて』の知識を持っていることを推奨します。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco 2500、2600、3600、3700、7200、および MC3810 シリーズ ルータ

  • この資料は Cisco IOS の特定のバージョンに特定ではないですか。 ただし、このドキュメントの設定は、Cisco IOS ソフトウェア リリース 12.2(19) でテスト済みです。 H.323 ゲートキーパーの機能をサポートするために必要な Cisco IOS 機能を確認するには、Software Advisor登録ユーザ専用)を参照してください。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

ARQ およびLRQ メッセージ

Admission Request(ARQ; アドミッション要求)と Location Request(LRQ; ロケーション要求)は、ゲートキーパーにコール ルーティング決定処理を開始するように指示する 2 つの H.225 Registration, Admission, Status(RAS)メッセージです。

  • ARQ — H.323 エンドポイント(通常ゲートウェイ)によって Cisco ゲートキーパに送られるローカルゾーン メッセージ。 ゲートキーパーは、次の場合にエンドポイントから ARQ を受信します。

    • ローカル ゾーン エンドポイントがコールを開始する。 または

    • ローカル ゾーン エンドポイントは、着信コールを承認するように許可を要求する。

    ゲートキーパーは、Admission Confirm(ACF; アドミッション確認)または Admission Reject(ARJ; アドミッション拒否)メッセージで ARQ メッセージに応答します。 Cisco ゲートキーパーは、コールを許可するように設定されている場合、ACF メッセージ(宛先ゲートウェイ IP アドレスなどの情報を含む)で応答します。 設定されていない場合は ARJ メッセージで応答します。

  • LRQ — これらのメッセージはゲートキーパーの間で交換され、区域間(リモートゾーン)呼び出しのために使用されます。 たとえば、ゲートキーパー A は、リモート ゾーン デバイス用のコール アドミッションを要求しているローカル ゾーン ゲートウェイから ARQ を受信します。 ゲートキーパー A はインターゾーンコール 要求を是認するか、または拒否することを設定するかどうか、そして要求されたリソースは登録されているかどうかに左右される Location Confirm (LCF)または Location Reject (LRJ) メッセージが付いている LRQ メッセージへのゲートキーパー B. Gatekeeper 応答に B それから LRQ メッセージを送ります。

詳細は、『H.323 ゲートキーパーについて: ゲートキーパーからゲートウェイへのコール フロー』を参照してください。

関連する H.225 RAS メッセージ
ARQ アドミッション要求 LRQ ロケーション要求
ACF アドミッション確認 LCF ロケーション確認
ARJ アドミッション拒否 LRJ ロケーション拒否

設定の重要な概念: ゾーンおよびテクノロジー プレフィックス

Cisco ゲートキーパー コール ルーティング決定処理を理解するには、ゾーン プレフィクスとテクノロジー プレフィクスを理解することが重要です。 一般に(2、3 の例外はあるものの)、ゾーン プレフィクスはゾーンへのルーティングを決定し、それに対してテクノロジー プレフィクスはそのゾーンのゲートウェイを決定します。

ゾーン プレフィクス

ゾーン プレフィクスは、コールがホップオフするゾーンを特定する、着番号の一部です。 ゾーン プレフィクスは、通常は設定されたゾーンにエリア コードを関連付けるために使われます。

Cisco ゲートキーパーは、コールがリモート ゾーンにルーティングされるか、ローカルに処理されるかどうかを決定します。 たとえば、この設定 の 抜粋に従って、ゲートキーパー (GK) A は GK-B に 214 の.......呼び出しを転送します。 エリア コード(512)へのコールはローカルに処理されます。

gatekeeper
     zone local GK-A abc.com
     zone remote GK-B abc.com 172.22.2.3 1719
	
!--- The IP address configured above should be the RAS 
 !--- address of the remote gatekeeper.    
 !--- and should be reachable from the local gateway. 
 !--- In order to find out the RAS address on the remote gatekeeper,
 !--- issue the 
show gatekeeper zone status
 command 
 !--- on the remote gateway.
 
     zone prefix GK-B 214.......
     zone prefix GK-A 512.......

テクノロジー プレフィクス

テクノロジー プレフィクスは、Cisco ゲートウェイとゲートキーパーによってサポートされるオプションの H.323 標準ベースの機能であり、H.323 VoIP ネットワーク内のコール ルーティングでの柔軟性をより多く提供できます。 Cisco ゲートキーパーは、同じタイプのエンドポイントをともにグループ化するテクノロジー プレフィクスを使用します。 テクノロジー プレフィクスは、ゲートウェイのタイプ、クラス、またはプールを特定するためにも使用できます。

Cisco ゲートキーパーは、着番号に一致する、(ゲートウェイによって)登録された E.164 アドレスがないときに、コールをルーティングするためにテクノロジー プレフィクスを使用します。 実際、これは、ほとんどの Cisco IOS ゲートウェイがその H.323 IDだけを登録するので(Foreign Exchange Station(FXS)ポートが設定されていない限り)、一般的なシナリオです。 E.164 アドレスが登録されていない場合、Cisco ゲートキーパーは 2 つのオプションに依存してコール ルーティング決定を行います。

  • Technology Prefix Matches オプションを指定すると、Cisco ゲートキーパーは宛先ゲートウェイまたはゾーンを選択するために着番号に追加されたテクノロジー プレフィクスを使用します。

  • Default Technology Prefixes オプションを使用すると、Cisco ゲートキーパーは、解決していないコール アドレスのルーティングにデフォルト ゲートウェイを割り当てます。 この割り当ては、ゲートウェイの登録済みのテクノロジー プレフィクスに基づいています。

次の表は、利用可能な設定オプションをまとめたものです。

ゲートウェイ上
VoIP Interface このコマンドは、定義済みのテクノロジー プレフィクスで Cisco ゲートウェイを登録します。 テクノロジー プレフィクス登録情報は、RAS Registration Request(RRQ; RAS 登録要求)メッセージで Cisco ゲートキーパーに送信されます。 次に、例を示します。
GWY-B1(config)#interface ethernet 0/0
GWY-B1(config-if)#h323-gateway voip tech-prefix ?
     WORD: A technology prefix that the interface will register
     with the Gatekeeper.
VoIP Dial-peer このコマンドは、ダイヤルピアによって照合された着番号の先頭にテクノロジー プレフィクスを付加します。 登録には使用されませんが、Cisco ゲートキーパーとのコール セットアップ用に使用されます。 たとえば、着番号 5551010 は 1#5551010 になります。
GWY-B1(config)#dial-peer voice 2 voip
GWY-B1(config-dial-peer)#tech-prefix ?
     WORD: A string.

変更した着番号は、コール セットアップで終端側ゲートウェイにも送信されます。 終端側ゲートウェイの Plain Old Telephone Service(POTS; 一般電話サービス)ダイヤルピアがコールを完了するために更新されていることを確認します。

ゲートキーパー上
Gatekeeper Default Technology Prefix このコマンドは、登録済みのゲートウェイに、解決されていないルーティング コール アドレス用のデフォルトとして指定されたテクノロジー プレフィクスを設定します。 たとえば、ゾーン内のほとんどのゲートウェイが同じタイプのコールをルーティングし、それらがテクノロジー プレフィクス 1# とともに登録されている場合、デフォルト テクノロジー プレフィクスとして 1# を使用するように Cisco ゲートキーパーを設定できます。 そのため、発信元ゲートウェイが着番号の先頭に 1# を追加する必要はなくなります。 有効なテクノロジー プレフィクスのない着番号は、1# で登録されたゲートウェイの 1 つにルーティングされます。
GK-B(config)#gatekeeper
GK-B(config-gk)#gw-type-prefix 1# default-technology

デフォルト ゲートウェイが複数ある場合、zone prefix <gk_id> <e.164_pattern>gw-priority <0-10> コマンドでゲートウェイの優先順位の使用に影響を与えることができます。

Gatekeeper Hop-Off Zone ホップオフ設定は、着番号のゾーン プレフィクスに関係なく、ゾーン プレフィクス選択を無効にして、指定されたゾーンにホップオフするようにコールを強制するために使用できます。 たとえば、次の設定では、テクノロジー プレフィクス 2# のすべてのコールは GK-A ゾーンに転送されます。
GK-B(config)#gatekeeper 
GK-B(config-gk)#gw-type-prefix 2# hopoff GK-A
Gatekeeper Static Gateway Technology Prefix Registration あるゲートウェイのテクノロジー プレフィクスを静的に登録するために使用できます。 ゲートウェイ VoIP インターフェイス設定がゲートウェイ上で達成するのに従い、ゲートキーパー上で同じ結果を取得します。 ゲートウェイの数が多い場合、この設定はゲートウェイ上で行うことをお勧めします。 一般に、各ゲートウェイ用のすべてのテクノロジー プレフィクスでゲートキーパーを設定するよりも、各ゲートウェイでテクノロジー プレフィクスを設定するほうが簡単です。
GK-B(config)#gatekeeper 
GK-B(config-gk)#gw-type-prefix 1# gw ipaddr ?
     A.B.C.D  Gateway's call signaling IP address

ゲートキーパー コール ルーティング アルゴリズム/決定処理

次の図は、Cisco IOS ソフトウェア リリースの 12.4 より前のもので ARQ と LRQ のメッセージを受信した後のゲートキーパー コール ルーティング決定処理を示しています。

gk-call-routing-1.gif

gk-call-routing-2.gif

エイリアス ベースのコール ルーティング

ゲートキーパー コール ルーティングは、Cisco IOS ソフトウェア リリース 12.4 以降で変更されています。 H.323-ID と email-ID ベースの照合は、宛先 E.164 番号(DNIS)を処理する前に実行されます。 エンドポイントが指定された H.323-ID/email-ID を登録したことが見つかった場合、ACF が送信されます。 次の図は、新しいエイリアス ベースのコール ルーティング処理を説明しています。

/image/gif/paws/24462/gk-call-routing-2a.gif

Voice Infrastructure and Application(VIA)機能は、既存の Cisco ゲートキーパー イメージのソフトウェア機能拡張です。 この機能拡張で、Cisco ゲートキーパーは、同一のプラットフォーム上の 2 つのコール レッグ(IP 間ゲートウェイ)を認識でき、また、複数の IP 間ゲートウェイにわたってトラフィックのロードバランシングができます。複数の IP 間ゲートウェイは事前に定義された VIA ゾーンに含まれます(ゲートウェイとゲートキーパーの両方)。 これらのゲートキーパーは Internet Telephony Service Provider(ITSP)ネットワークの端にあり、VoIP 転送ポイントや、VoIP トラフィックがリモート ゾーン宛先の途中でチャネルを通る転送ゾーンと似ています。 VIA ゾーンの IP 間のゲートウェイは、着信コールを終了し、それらを最終の宛先へと再度開始します。 VIA ゾーンの詳細については、『Cisco マルチサービス IP 間ゲートウェイ機能でのリモート/ローカル間のネットワーク』を参照してください。

/image/gif/paws/24462/gk-call-routing-2b.gif

規定 された invia または outvia ゾーンが構成(すなわちローカルかリモートゾーンと定義されません)になければ、ARJ メッセージは送信 されます。

指定 viazone に登録されている IP-IP GW を選択するためにこのアルゴリズムは使用されます:

  1. tech-prefix が(エイリアス ベースの一致で)あったら、この tech-prefix を登録した規定 された viazone のゲートウェイのリストを通って検知 して下さい。

  2. tech-prefix がない場合、規定 された viazone に登録されているゲートウェイの全体のリストを通って検知 して下さい。

  3. 利用可能 なリソースがあるステップ 1 または 2 で見つけられる最初の IP-IP GW を選択して下さい。

  4. リストのすべての IP-IP GW がリソースからある場合、(リソースからあるかもしれませんのに)ある最初の IP-IP GW を選択して下さい。

  5. IP-IP GW がない場合、失敗を戻して下さい。

ローカル ゾーン コールの例

このセクションで提供される例では、2 つのゲートウェイは対応する H.323 ID を伴う Cisco ゲートキーパーで登録します。 さらに、ゲートウェイ(GWY)A2 は E.164 アドレスで登録します。 次の図は、このセクションのすべての例で使用されます。

gk-call-routing-3.gif

このセクションの 3 つのシナリオは、ゲートキーパーが ARQ メッセージに基づいたコールをルーティングするために使用するステップごとの決定処理について説明します。

対応する出力だけがこれらの設定キャプチャに表示されます。

シナリオ 1: テクノロジー プレフィクスが設定されていない

GK-A
!
gatekeeper
zone local GK-A abc.com
no shutdown
!
GWY-A1 GWY-A2
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718 

!--- The IP address configured here should 
!--- be the RAS address of GK-A
!--- and should be reachable from the gateway. 
!--- In order to find out the RAS address,
!--- issue the 
show gatekeeper zone status
 
!--- command on GK-A.
 
h323-gateway voip h323-id GW-A1@abc.com 
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512

!--- On outgoing calls through POTS dial-peers,
!--- all explicit digit matches are dropped, 
!--- which is the reason
!--- for adding the prefix 512. This has nothing to  
!--- do with technology prefixes.

!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras

!--- Uses RAS messages (GK) to get 
!--- call setup information.


!
gateway
!
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718

!--- The IP address configured here  
!--- should be the RAS address of GK-A.
!--- and should be reachable from the gateway. 
!--- In order to find out the RAS address,
!--- issue the 
show gatekeeper zone status

!--- command on GK-A.
 
h323-gateway voip h323-id GW-A2@abc.com
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0

!--- This is the FXS port.

!
gateway
!

GK-A でキャプチャされた次の出力は、実際の登録を示しています。 GWY-A2 も FXS ポートの E.164 ID を登録していることに注目してください。

GK-A#show gatekeeper endpoints
                    GATEKEEPER ENDPOINT REGISTRATION
                    ================================
CallSignalAddr  Port  RASSignalAddr   Port  Zone Name         Type    F
--------------- ----- --------------- ----- ---------         ----    --
172.22.1.1      1720  172.22.1.1      49317 GK-A              VOIP-GW
    H323-ID: GW-A1@abc.com
172.22.1.2      1720  172.22.1.2      58196 GK-A              VOIP-GW
    E164-ID: 9725551010
    H323-ID: GW-A2@abc.com
Total number of active registrations = 2

最初のコール アクション: ユーザ A1 は 972-555-1010 のユーザ A2 を呼び出します。 ARQ の図を使用して、決定処理を実行します。

GK-A は GWY-A1 からの ARQ を受信します。

  1. テクノロジー プレフィクスは一致しますか。 なし

  2. ゾーン プレフィクスは一致しますか。 なし

  3. arq reject-unknown-prefix コマンドは設定されていますか。 いいえ。ターゲット ゾーンはローカル ゾーンと同じです。

  4. ターゲット ゾーンはローカルですか。

  5. テクノロジー プレフィクスはステップ 1 で見つかりましたか。 なし

  6. ターゲット アドレスは登録されていますか。 はい。 ACF を送信します。

コール セットアップは正常に行われました。

GWY-A2 は宛先 E.164 ID を登録しています(FXS ポート)。 そのため、ゲートキーパーはコールを許可することができました。

2 番目のコール アクション: ユーザ A2 は 512-555-1212 をダイヤルしてユーザ A1 を呼び出します。

GK-A は GWY-A2 からの ARQ を受信します。

  1. テクノロジー プレフィクスは一致しますか。 なし

  2. ゾーン プレフィクスは一致しますか。 なし

  3. arq reject-unknown-prefix コマンドは設定されていますか。 いいえ。ターゲット ゾーンはローカル ゾーンと同じです。

  4. ターゲット ゾーンはローカルですか。 ○

  5. テクノロジー プレフィクスはステップ 1 で見つかりましたか。 なし

  6. ターゲット アドレスは登録されていますか。 なし

  7. デフォルト テクノロジー プレフィクスは設定されていますか。 いいえ送信 ARJ

コール セットアップは失敗しました。

シナリオ 2 ではテクノロジー プレフィクスでこのコール ルーティング問題を修正する方法について説明します。

シナリオ 2: テクノロジー プレフィックスが設定される

このシナリオでは、次の設定変更が行われています。

  • GWY-A1h323-gateway voip tech-prefix 1# コマンドを追加しました。 GWY-A1 は、テクノロジー プレフィクス 1# で GK-A を登録します。

  • GWY-A1 — テクノロジープリフィックス 1# に GWY-A2 からの着信 呼出 し 番号をマッチさせること destination-pattern コマンドで POTSダイヤルピアを追加しました。

  • GK-Azone prefix GK-A コマンドを追加しました。 GK-A が管理するローカル ゾーン プレフィクスを定義します。

  • GK-Aarq reject-unknown-prefix コマンドを追加しました。 これによって、GK-A は、管理するゼロ プレフィクス用に ARQ コールだけを受け付けることを強制されます。 シナリオ 1 では、これは設定されませんでした。 そのため、ターゲット ゾーンはデフォルトとしてローカル ゾーンに設定されました。

  • GWY-A2 — VOIPダイヤルピア 設定の下で tech-prefix 1# コマンドを追加しました。 このように、GWY-A2 はディジット 1# を発信 VoIP コールの先頭に付加します。 GK-A は、宛先ゲートウェイとして GWY-A1 を選択するように、1# パターンを特定します。

GK-A
gatekeeper
zone local GK-A abc.com
zone prefix GK-A 512.......
zone prefix GK-A 972.......
arq reject-unknown-prefix
no shutdown
!
GWY-A1 GWY-A2
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1# 
!
dial-peer voice 3 pots
incoming called-number 972.......
destination-pattern 1#512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras
!
gateway
!
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
tech-prefix 1#
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0
!
gateway
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A2@abc.com
!

GK-A でキャプチャされた次の出力は、登録されたテクノロジー プレフィクスを示しています。

GK-A#show gatekeeper gw-type-prefix
        
        GATEWAY TYPE PREFIX TABLE
        =========================
        Prefix: 1#*
        Zone GK-A master gateway list:
        172.22.1.1:1720 GW-A1

: h323-gateway voip tech-prefix 1# コマンドで GW-A1 を設定する代わりに、この情報をコマンドで GK-A に手動で設定することによって、同じように達成できます。

GK-A(config-gk)#gw-type-prefix 1#* gw ipaddr 172.22.1.1

コール アクション: ユーザ A2 は 512-555-1212 をダイヤルしてユーザ A1 を呼び出します。

GK-A は GWY-A2 からの ARQ を受信します。

  1. テクノロジー プレフィクスは一致しますか。

    テクノロジー プレフィクスが一致した後、ゲートキーパーはゾーン プレフィクスを解析するためにそれを除去します。 この除去は、ゲートキーパーの分析によってだけ実行されます。 発信側ゲートウェイは、終端側ゲートウェイへのコール セットアップ内に引き続きテクノロジー プレフィクスを追加します。

  2. ゾーン プレフィクスは一致しますか。 はい。 ターゲット ゾーンをローカル ゾーンと同じに設定します。

  3. エイリアス名(テクノロジー プレフィクスを除去した後)は登録済みのゲートウェイと一致しますか。 いいえ(Yes の場合は、送信 ACF)。

  4. ターゲット ゾーンはローカルですか。

  5. テクノロジー プレフィクスはステップ 1 で見つかりましたか。

  6. テクノロジー プレフィクス付きのローカル ゲートウェイは見つかりましたか。 はい。 ACF を送信します。

    コール セットアップは正常に行われました。

この GK-A debug コマンド出力は、前述の動作を示したものです。

この debug コマンドは役に立ちますが、隠されているデバッグです。 そのため、パーサーはデバッグを示しません。

GK-A#debug gatekeeper main 5
      
    *Jun 19 09:50:10.086: gk_rassrv_arq: arqp=0x631CC400, crv=0x82, answerCall=0
    *Jun 19 09:50:10.086: gk_dns_locate_gk(): No Name servers
    *Jun 19 09:50:10.086: rassrv_get_addrinfo(1#5125551010): Matched tech-prefix 1#
    *Jun 19 09:50:10.086: rassrv_get_addrinfo(1#5125551010): Matched zone prefix 512
    *Jun 19 09:50:10.118: gk_rassrv_arq: arqp=0x631CC400, crv=0x1A, answerCall=1

これは、より直感的にできる代替設定です。

  • h323-gateway voip tech-prefix 512 コマンドを発行して、テクノロジー プレフィクス 512 付きで登録するように GWY-A1 を設定します。

  • このように、destination-pattern がすでに 512 を含んでいるので、GWY-A2 は VoIP ダイヤルピア コール レッグ内でプレフィクスを引き渡す必要がありません。 そのため、GWY-A2 設定の tech-prefix 1# コマンドを取り除き、GWY-A1 の pots ダイヤル ピアの destination-pattern からも 1# を削除してください。

シナリオ 3: デフォルトのテクノロジー プレフィックスが設定される

このシナリオでは、GWY-A1 はテクノロジー プレフィクス 1# 付きで登録されており、GK-A はデフォルト テクノロジー プレフィクス ゲートウェイに一致するテクノロジー プレフィクスなしでコールをルーティングするように設定されます。 そのため、GWY-A2 は宛先テクノロジー プレフィクスを通すように設定する必要はありません。

GK-A
!
gatekeeper
zone local GK-A abc.com
zone prefix GK-A 512.......
zone prefix GK-A 972.......
gw-type-prefix 1#* default-technology
arq reject-unknown-prefix 
no shutdown
!
GWY-A1 GWY-A2
!
interface Ethernet0/0 
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com 
h323-gateway voip tech-prefix 1# 
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras
!
gateway
!
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0
!
gateway
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A2@abc.com
!

GK-A でキャプチャされた次の出力は、登録されたテクノロジー プレフィクスを示しています。

GK-A#show gatekeeper gw-type-prefix
        
        GATEWAY TYPE PREFIX TABLE
        =========================
        Prefix: 1#* (Default gateway-technology)
        Zone GK-A master gateway list:
        172.22.1.1:1720 GW-A1

コール アクション: ユーザ A2 は 512-555-1212 をダイヤルしてユーザ A1 を呼び出します。

GK-A は GWY-A2 からの ARQ を受信します。

  1. テクノロジー プレフィクスは一致しますか。 なし

  2. ゾーン プレフィクスは一致しますか。 はい。 ターゲット ゾーンをローカル ゾーンと同じに設定します。

  3. ターゲット ゾーンはローカルですか。

  4. テクノロジー プレフィクスはステップ 1 で見つかりましたか。 なし

  5. ターゲット アドレスは登録されていますか。 なし

  6. デフォルト テクノロジー プレフィクスは設定されていますか。 はい。 テクノロジー プレフィクス付きのローカル ゲートウェイ(1 つだけが利用可能)を選択します。

  7. ACF を送信します。

    コール セットアップは正常に行われました。

リモート ゾーン コールの例

ここで示す例では、2 つの H.323 ゾーンである、 GK-A で制御されるものと GK-B で制御されるものがあります。

/image/gif/paws/24462/gk-call-routing-4.gif

このセクションのシナリオは、ゲートキーパーが ARQ メッセージと LRQ メッセージに基づいたコールをルーティングするために使用するステップごとの決定処理について説明します。

対応する出力だけがこれらの設定例に表示されます。

シナリオ 1: デフォルトのテクノロジー プレフィックスで設定されたゾーン ゲートキーパー

このシナリオでは、GWY-A1 はテクノロジー プレフィクス 1# とともに GK-A に登録され、GWY-B1 はテクノロジー プレフィクス 2# とともに GK-B に登録されます。 両方のゲートキーパーはデフォルトのテクノロジー プレフィクス ゲートウェイで設定されます。

GK-A GK-B
!
gatekeeper
zone local GK-A abc.com 172.22.1.3
zone remote GK-B abc.com 172.22.2.3 1719
zone prefix GK-B 214.......
zone prefix GK-A 512.......
gw-type-prefix 1#* default-technology
arq reject-unknown-prefix
no shutdown
! 
!
gatekeeper
zone local GK-B abc.com 172.22.2.3
zone remote GK-A abc.com 172.22.1.3 1719
zone prefix GK-B 214.......
zone prefix GK-A 512.......
gw-type-prefix 2#* default-technology
no shutdown
!
GWY-A1 GWY-B1
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1#
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern ..........
session target ras
!
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
h323-gateway voip tech-prefix 2#
!
dial-peer voice 1 pots
destination-pattern 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
!
gateway
!

コール アクション: ユーザ A1 は 214-555-1111 をダイヤルしてユーザ A1 を呼び出します。

GK-A は GWY-A1 からの ARQ を受信します。

  1. テクノロジー プレフィクスは一致しますか。 なし

  2. ゾーン プレフィクスは一致しますか。 はい。 ターゲット ゾーンをリモート GK-B ゾーン(214)と同じに設定します。

  3. ターゲット ゾーンはローカルですか。 なし

  4. LRQGK-B に送信します。

GK-B は GK-A から LRQ を受信します。

  1. テクノロジー プレフィクスは一致しますか。 なし

  2. ゾーン プレフィクスは一致しますか。 はい。 ターゲット ゾーンをローカル ゾーンと同じに設定します。

  3. ターゲット ゾーンはローカルですか。

  4. テクノロジー プレフィクスはステップ 1 で見つかりましたか。 なし

  5. ターゲット アドレスは登録されていますか。 なし

  6. デフォルト テクノロジー プレフィクスは設定されていますか。 はい。 テクノロジー プレフィクス付きのローカル ゲートウェイ(2#)を選択します。

  7. LCF を GK-A に送信します。

    GK-A は、終端側ゲートウェイ情報とともに GK-B から LCF を受信します。

    GK-A は ACF を GWY-A1 に送信します。

    コール セットアップは正常に行われました。

シナリオ 2: デフォルトのテクノロジー プレフィックスなしで設定されるゾーン ゲートキーパー

このシナリオでは、GWY-A1 はテクノロジー プレフィクス 1# とともに GK-A に登録され、GWY-B1 はテクノロジー プレフィクス 2# とともに GK-B に登録されます。 GWY-A1 は(214)へのコールを実行するときに着番号文字列にテクノロジー プレフィクス 2# を追加し、GWY-B1 は(512)へのコールを実行するときに着番号文字列にテクノロジー プレフィクス 1# を追加します。

GK-A GK-B
!
gatekeeper
zone local GK-A abc.com
zone remote GK-B abc.com 172.22.2.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
arq reject-unknown-prefix
no shutdown
!
!
gatekeeper
zone local GK-B abc.com 172.22.2.3
zone remote GK-A abc.com 172.22.1.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
no shutdown
!
GWY-A1 GWY-B1
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1#
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 214.......
session target ras
tech-prefix 2# 
!
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
h323-gateway voip tech-prefix 2#
!
dial-peer voice 1 pots
destination-pattern 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
tech-prefix 1# 
!
gateway
!

最初のコール アクション: ユーザ B1 は 512-555-1212 をダイヤルしてユーザ A1 を呼び出します。

GK-B は GWY-B1 からの ARQ を受信します。

  1. テクノロジー プレフィクスは一致しますか。 なし

  2. ゾーン プレフィクスは一致しますか。 なし

    GK-B が 1# テクノロジー プレフィクスを感知していないので、着番号の一部であると見なされ、それをゾーン プレフィクスとして読み取ります。

  3. ターゲット ゾーンはローカルですか。

    GK-B は、arq reject-unknown-prefix コマンドが設定されていないので、デフォルトの target zone equals local zone を取ります。

  4. テクノロジー プレフィクスはステップ 1 で見つかりましたか。 なし

  5. ターゲット アドレスは登録されていますか。 なし

  6. デフォルト テクノロジー プレフィクスは設定されていますか。 なし

  7. ARJ を GWY-B1 に送信します。

    コール セットアップは失敗しました。

次の出力は、この動作をさらに具体的に示すために GK-B でキャプチャされました。


!--- From debug gatekeeper main 5.

      
GK-B#
gk_rassrv_arq: arqp=0x62F6A7E0, crv=0x22, answerCall=0
gk_dns_locate_gk(): No Name servers
rassrv_get_addrinfo(1#5125551212): Tech-prefix match failed
rassrv_get_addrinfo(1#5125551212): unresolved zone prefix, using source zone GK-B
rassrv_get_addrinfo(1#5125551212): unknown address and no default technology defined
gk_rassrv_sep_arq(): rassrv_get_addrinfo() failed (return code = 0x103)

!--- From debug ras.


GK-B#
RecvUDP_IPSockData successfully rcvd message of length 156 from 172.22.2.1:51141
ARQ (seq# 1796) rcvdparse_arq_nonstd: ARQ Nonstd decode succeeded, remlen= 156
IPSOCK_RAS_sendto: msg length 4 from 172.22.2.3:1719 to 172.22.2.1: 51141
RASLib::RASSendARJ: ARJ (seq# 1796) sent to 172.22.2.1

この問題を解決するため、リモート ゾーン テクノロジー プレフィクスを特定するようにゲートキーパーを設定します。

  • これを GK-B に追加します。

    GK-B(config-gk)#gw-type-prefix 1# hopoff GK-A
    
  • これを GK-A に追加します。

    GK-A(config-gk)#gw-type-prefix 2# hopoff GK-B
    

終端側ゲートウェイ内の POTS ダイヤルピアが、テクノロジー プレフィクス付きで着信ダイヤル文字列と一致するように更新する必要があることに注目してください。

GK-A GK-B
!
gatekeeper
zone local GK-A abc.com
zone remote GK-B abc.com 172.22.2.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
arq reject-unknown-prefix
gw-type-prefix 2# hopoff GK-B
no shutdown
!
!
gatekeeper
zone local GK-B abc.com 172.22.2.3
zone remote GK-A abc.com 172.22.1.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
gw-type-prefix 1# hopoff GK-A
no shutdown
!
GK-B GWY-B1
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1#
!

!--- This dial-peer is used for 
!--- incoming calls from the PSTN.

dial-peer voice 1 pots
incoming called-number 512.......
direct-inward-dial
port 1/0:23
!
dial-peer voice 2 voip
destination-pattern 214.......
session target ras
tech-prefix 2# 
!

!--- This dial-peer is used to 
!--- terminate (512) calls coming
!--- from the VoIP network. Notice 
!--- that the technology prefix 
!--- is matched to select the dial-peer 
!--- but does not pass it to 
!--- the PSTN.
 
dial-peer voice 3 pots
destination-pattern 1#512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 4 voip
destination-pattern 972.......
session target ras
! 
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
h323-gateway voip tech-prefix 2#
!
dial-peer voice 1 pots
incoming called-number 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
tech-prefix 1# 
!
dial-peer voice 3 pots
destination-pattern 2#214....... 
port 3/0:23
prefix 214 
! 
gateway
!

2 番目のコール アクション: ユーザ B1 は 512-555-1212 をダイヤルしてユーザ A1 を呼び出します。

GK-B は GWY-B1 からの ARQ を受信します。

  1. テクノロジー プレフィクスは一致しますか。

  2. ホップオフ テクノロジー プレフィクスは存在しますか。

  3. LRQ を GK-A に送信します。

    LRQ は GK-A 分析用の着番号にテクノロジー プレフィクスを含んでいます。

GK-A は GK-B から LRQ を受信します。

  1. テクノロジー プレフィクスは一致しますか。

  2. ホップオフ テクノロジー プレフィクスは存在しますか。 なし

    コール ルーティング分析を続行するために、GK-A はテクノロジー プレフィクスを除去します。 テクノロジー プレフィクスは、ゲートウェイがコール レッグを設定するときに着番号に残っています。

  3. ゾーン プレフィクスは一致しますか。 はい。 ターゲット ゾーンをローカル ゾーンと同じに設定します。

  4. ターゲット ゾーンはローカルですか。

  5. テクノロジー プレフィクスはステップ 1 で見つかりましたか。

  6. テクノロジー プレフィクス付きのローカル ゲートウェイを見つけましたか。

  7. LCF を GK-B に送信します。

    GK-B は、終端側ゲートウェイ情報とともに GK-A から LCF を受信します。

    GK-B は ACF を GWY-B1 に送信します。

    コール セットアップは正常に行われました。

次のコマンド出力は、この動作をさらに具体的に示すために GK-B でキャプチャされました。


!--- From debug gatekeeper main 5.


GK-B#
gk_rassrv_arq: arqp=0x62ED2D68, crv=0x24, answerCall=0
gk_dns_locate_gk(): No Name servers
rassrv_get_addrinfo(1#5125551212): Matched tech-prefix 1#
rassrv_put_remote_zones_from_zone_list() zone GK-A
gk_rassrv_irr: irrp=0x62F0D8FC, from 172.22.2.1:51141
GK-B#
GK-B#

!--- From debug ras.


RecvUDP_IPSockData successfully received message of 
length 156 from 172.22.2.1:51141
ARQ (seq# 1809) rcvdparse_arq_nonstd: ARQ Nonstd decode 
succeeded, remlen= 156
IPSOCK_RAS_sendto: msg length 104 from 
172.22.2.3:1719 to 172.22.1.3: 1719
RASLib::RASSendLRQ: LRQ (seq# 1042) sent to 172.22.1.3
IPSOCK_RAS_sendto: msg length 7 from 172.22.2.3:1719 to 172.22.2.1: 51141
RASLib::RASSendRIP: RIP (seq# 1809) sent to 172.22.2.1
RecvUDP_IPSockData successfully rcvd message of length 
131 from 172.22.1.3:1719
LCF (seq# 1042) rcvdparse_lcf_nonstd: LCF Nonstd 
decode succeeded, remlen= 131
IPSOCK_RAS_sendto: msg length 34 from 172.22.2.3:1719 
to 172.22.2.1: 51141
RASLib::RASSendACF: ACF (seq# 1809) sent to 172.22.2.1
RecvUDP_IPSockData successfully rcvd message of length 
76 from 172.22.2.1:51141

検証とトラブルシューティングに関するコマンド

このセクションでは、ゲートキーパーとゲートウェイのコール ルーティング問題を確認してトラブルシューティングを行うために使用される show コマンドと debug コマンドのリストを示します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

  • show gateway:ゲートウェイの E.164 および H.323 エイリアス登録を確認するために使用されます。

  • show gatekeeper endpoints:ゲートキーパーとともに登録された E.164 と H.323 エイリアスを確認するために使用されます。

  • show gatekeeper gw-type-prefix:ゲートキーパーで E.164 プレフィクス登録を確認するために使用されます。

  • ゲートキーパのゾーン プレフィクスの表示 | status:ゾーン ステータスと設定パラメータを確認するために使用されます。

  • debug ras:ゲートウェイとゲートキーパーに適用できます。

  • debug h225 asn1:ゲートウェイとゲートキーパーに適用できます。

  • show dial-peer voice:ダイヤル ピアの下で設定済みのテクノロジー プレフィクスを確認するために使用されます。


関連情報


Document ID: 24462