ブロードバンド ケーブル : 無線周波数(RF)光ファイバ / 同軸ハイブリッド(HFC)

Cisco CMTS のケーブル変調プロファイルの設定

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 3 月 5 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

Cisco ケーブルモデム終端システム(CMTS)では、音声およびデータのケーブル モデム プラントの RF 設定の変調プロファイルを処理できます。 Cisco IOS(R) ソフトウェアはほとんどの場合最適であるデフォルト変調 プロファイルが付属しています。 したがって、デフォルト設定を変更しないでください。 ただし、変調のニーズがお客様のプラントで異なる場合は、Cisco IOS ソフトウェアで、変調プロファイルをカスタマイズし、お客様のニーズに合わせて設定できます。

注意 注意: 変調の変更およびデータオーバーケーブル サービス インターフェイス仕様(DOCSIS)を理解している熟練者のみがこれらのパラメータを変更する必要があります。 そうでない場合、コマンドは物理層に影響を与えるため、変更によって、サービスの中断または質の低下が発生する可能性があります。

このドキュメントでは変調プロファイルを変更するための設定コマンドについて説明します。 また、このドキュメントは設定済みのパラメータを確認するために使用する show コマンドも示します。

CMTS Cisco IOS ソフトウェア リリースでは、事前設定された 1 つの変調プロファイルがメモリに常駐しています。この変調プロファイルにより、4 位相偏移変調(QPSK)の典型的なプロファイルが定義されます。 Cisco uBR7100、uBR7200、および uBR10000 シリーズ CMTS は最大 8 つのケーブル変調プロファイルをサポートします。 デフォルトはプロファイル 1 です。

デフォルトの設定済みパラメータを確認するには、次のように、show cable modulation-profile コマンドを発行します。

ubr7246#show cable modulation-profile

Mod IUC     Type Preamb Diff FEC    FEC   Scrambl Max  Guard Last Scrambl Preamb
                 length enco T      CW    seed    B    time  CW           offset
                             BYTES  size          size size  short
1   request qpsk 64     no   0x0    0x10  0x152   0    8     no   yes     952
1   initial qpsk 128    no   0x5    0x22  0x152   0    48    no   yes     896
1   station qpsk 128    no   0x5    0x22  0x152   0    48    no   yes     896
1   short   qpsk 72     no   0x5    0x4B  0x152   6    8     no   yes     944
1   long    qpsk 80     no   0x8    0xDC  0x152   0    8     no   yes     936

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

構文の説明

cable modulation-profile コマンド

変調プロファイルを定義するには、cable modulation-profile global configuration コマンドを発行します。 指定された変調プロファイルを削除するには、no cable modulation-profile コマンドを発行します。

  • cable modulation-profile profile {iuc | mix | qam-16 | qpsk} fec-tbytes fec-len burst-len guard-t mod scrambler seed diff pre-len last-cw uw-len

  • no cable modulation-profile profile {iuc | mix | qam-16 | qpsk} fec-tbytes fec-len burst-len guard-t mod scrambler seed diff pre-len last-cw uw-len

これらのコマンドはそれぞれ 1 つの行にある必要があります。

これらのオプションはすべて Cisco IOS ソフトウェア リリース 12.1(1)EC 以降で使用できます。 以前のリリースでは、初期、ロング、要求、ショート、またはステーション オプションのみが使用できました。 すべての機能を含む Cisco IOS ソフトウェア リリース 12.0T または 12.0SC の新しいリリースがある場合があります。

表 1:パラメータの説明

パラメータ 説明
profile 変調プロファイル番号:有効な値は 1 ~ 8 で、1 はデフォルトの変調プロファイルです。

このコマンドを正しく使用するには、1 行に各アップストリーム バースト タイプのすべてのパラメータを入力します。 バースト プロファイルが不完全な場合、動作の信頼性が低下したり、モデム接続が失われたりする原因となります。

mix 要求、初期レンジング、およびステーション メンテナンス バーストは QPSK を使用して送信されるのに対して、16-QAM を使用してショートおよびロング グラント バーストが送信されるデフォルトの QPSK/16-QAM1 混合変調プロファイルを作成します。 バースト パラメータは、各バースト タイプのデフォルトの値に設定されます。
qam-16 すべてのバーストが 16-QAM を使用して送信されるデフォルトの 16-QAM 変調プロファイルを作成します。 バースト パラメータは、各バースト タイプのデフォルトの値に設定されます。
QPSK すべてのバーストが QPSK を使用して送信されるデフォルトの QPSK 変調プロファイルを作成します。 バースト パラメータは、各バースト タイプのデフォルトの値に設定されます。
fec-tbytes FEC2 コード ワードごとに訂正可能なバイト数:有効な値 0 ~ 10 で、0 は FEC なしを意味します。 これは FEC デコーダが 1 コード ワード内で訂正できるバイト数です。 コード ワードは情報バイト(k バイト)およびエラー訂正用のパリティ バイトから成ります。 パリティ バイト数は、訂正可能なエラー(T)数の 2 倍です。 T のサイズはチャネル障害によって決まります。
fec-len FEC コード ワードの情報バイトの長さ:有効な値は 16 ~ 253 バイトです。 この値は FEC コード ワード当たりの情報バイト数(k バイト)を指定します。
burst-len ミニスロットの最大バースト長:有効な値は 0 ~ 255 で、0 は制限なしを意味します。 これは、ショート データ グラント バースト プロファイルを使用するパケットとロング データ グラント バースト プロファイルを使用するパケットの区切りを判別するために使用します。 パケットの伝送に必要なアップストリーム時間がこの値より大きい場合は、ロング データ グラント バースト プロファイルが使用されます。 所要時間がこの値以下の場合は、ショート データ グラント バースト プロファイルが使用されます。
guard-t ガード時間(シンボル単位):連続するバースト間の時間。 有効値は 0 ~ 255 シンボルです。 1 つのバーストが確実に終了してから次のバーストが始まるように、バースト伝送の最後に発生するブランクの時間を表します。
mod 変調:有効なオプションは 16qam および qpsk です。 変調タイプは、変調シンボル当たり 4 ビット(16-QAM)、または変調シンボル当たり 2 ビット(QPSK)のいずれかを選択する際に使用されます。 16-QAM では、位相と振幅の両方を使用して情報を伝送します。 QPSK では、信号搬送波の位相で情報を伝送します。 16-QAM では QPSK と同じ BER5 を実現するために、約 7 dB3 高い C/N4 が必要です。 ただし、16-QAM は QPSK の 2 倍の速度で情報を転送します。
scrambler スクランブラをイネーブルまたはディセーブルにする:有効なオプションは scrambler および no-scrambler です。 スクランブラは、ほぼランダムな伝送シンボル シーケンスを作成するために使用されます。これにより、チャネル内で伝送されるエネルギーのスペクトル分布が均一になります。 スクランブラ シードは、ビットをスクランブルする疑似ランダム機能を開始するための初期値です。 送信装置と受信装置の両方でシード値がわかっているので、受信装置で逆スクランブルを実行し、オリジナル データのみを残すことができます。
seed 16 進形式のスクランブラ シード:有効な値は 0x0000 ~ 0x7FFF です。
diff 差分符号化をイネーブルまたはディセーブルにする:有効なオプションは diff および no-diff です。 差分符号化は、シンボルの絶対位相ではなく、2 つの変調シンボル間の位相変化によって情報を伝送する手法です。 この技術は受信した信号の絶対位相を無意味にして、同じ C/N の BER を実質的に 2 倍にします。
pre-len ビット単位のプリアンブル長:有効な値は 2 ~ 128 です。 プリアンブル長(およびプリアンブル オフセット)は、変調シンボルの同期文字列の定義に使用されます。これらの文字列は、送信されたバーストの位相およびタイミングを受信装置に認識させます。
last-cw FEC が最終コード ワードでどのように処理されるか:有効なオプションは、固定コードワード長の fixed、および短縮された最終コード ワードの shortened です。
uw-len アップストリーム固有ワード長:有効なオプションは 8 ビット固有ワードの uw8 または 16 ビット固有コード ワードの uw16 です。

1 QAM = 直交振幅変調

2 FEC = 前方誤り訂正

3 dB = デシベル

4 C/N = 搬送波対雑音比

5 BER = ビット エラー レート

デフォルト設定

デフォルトは変調プロファイル 1 です。

コマンド モード

コマンド モードはグローバル設定です。

表 2:コマンド履歴

Cisco IOS ソフトウェア リリース 変更箇所
11.3 NA このコマンドが導入されました。
12.0(7)XR2 このコマンドが使用されました。
12.0(6)SC および 12.1(3a)EC1 mixqpsk、および 16qam オプションが追加されました。

使用上のガイドライン

変調プロファイルはアップストリーム チャネル記述子(UCD)のメッセージで送信される 6 個のバースト プロファイルの集合です。 これらのプロファイルは次のアップストリーム メッセージ タイプのモデム伝送パラメータを設定します。

  • 要求

  • 初期メンテナンス

  • ステーション メンテナンス

  • ショート グラント

  • ロング グラント

デフォルトの変調プロファイル 1 を除くすべての変調プロファイルを削除するために、no cable modulation-profile コマンドを発行できます。変調プロファイル 1 の場合、no cable modulation-profile コマンドはバースト内のすべてのパラメータをデフォルト値に設定します。

注意 注意: 変調プロファイルを変更すると、物理層に対する変更が発生します。 物理層の特性の変更はルータのパフォーマンスおよび機能に影響するため、熟練したユーザのみがこのタスクを処理してください。

cable modulation-profile コマンドを正しく使用するには、1 行に各アップストリーム バースト タイプのすべてのパラメータを入力します。 バースト プロファイルが不完全な場合、動作の信頼性が低下したり、モデム接続が失われたりする原因となります。

注意 注意: スクランブラをオフにした場合、パケットが失われる場合があります。 したがって、ラボのテスト環境でのみスクランブラをオフにします。

バースト プロファイルのエラーまたは互換性のない設定によって、モデムで次のいずれかが発生します。

  • 接続のドロップ

  • ショートまたはロング データ パケットのドロップ

  • ネットワークへの接続の失敗

DOCSIS レシーバを実装せずにモデムの送信を受信できるバースト プロファイル セットを作成できます。

160 K シンボル/秒および 2560 K シンボル/秒のデータ レートでは、固有ワード長、プリアンブル長、および FEC サイズの影響を受けやすくなります。 これらの値が正しく選択されていないと、これらのシンボル レートでの接続性が低下するか、まったく接続できなくなることがあります。

設定例

カスタマイズされた例

この項の例は混合変調の変調プロファイルです。 初期、要求、およびステーション メンテナンス メッセージは QPSK で送信され、ショートおよびロング データ パケットは 16-QAM で送信されます。 16-QAM 変調は QPSK よりも帯域幅効率が向上しますが、QPSK は 16-QAM より堅牢です。

この例では、要求バーストには次の値が定義されています。

  • fec-tbytes: 0

  • fec-len: 16 KB

  • burst-len: 1

  • guard-t: 8

  • modQPSK

  • スクランブラ イネーブル

  • seed: 152

  • 差分符号化ディセーブル

  • pre-len: 64 ビット

  • last-cwfixed

  • uw-lenuw8

それ以外の初期、ステーション、ショート、およびロング バーストは、プロファイル 2 と同様に定義されています。

ubr7246#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

ubr7246(config)#cable modulation-profile 2 request 0 16 1 8 qpsk
                scrambler 152 no-diff 64 fixed uw8
ubr7246(config)#cable modulation-profile 2 initial 5 34 0 48 qpsk
                scrambler 152 no-diff 128 fixed uw16
ubr7246(config)#cable modulation-profile 2 station 5 34 0 48 qpsk
                scrambler 152 no-diff 128 fixed uw16
ubr7246(config)#cable modulation-profile 2 short 6 75 6 8 16qam
               scrambler 152 no-diff 144 fixed uw8
ubr7246(config)#cable modulation-profile 2 long 8 220 0 8 16qam
                scrambler 152 no-diff 160 fixed uw8
ubr7246(config)#^Z

ubr7246#

この出力のコマンドはそれぞれ 1 つの行にある必要があります。

この変調プロファイルのすべてのバースト(要求、初期、ステーション、ショート、およびロング)を作成するためには、modulation profile コマンドを使用します。 そうしないと、パフォーマンスの問題またはサービスの中断が発生する可能性があります。

この例は次の機器を使用します。

表 2:設定例の機器

名前 モデル 用途 [Software Version] イメージ名
ケーブル ヘッド端末 uBR7246 CMTS Cisco IOS ソフトウェア リリース 12.1(1a) ubr7200-ik1st-mz.121-1a.T1
ホーム オフィス uBR924 ケーブル モデム Cisco IOS ソフトウェア リリース 12.2(1) ubr920-k8o3v6y5-mz.122-1.bin
  PC DHCP サーバ WinNT1 Server 4.0 Cisco Network Registrar 3.5
TFTP サーバ WinNT Server 4.0 Cisco TFTP
ToD2 Server WinNT Server 4.0 任意の NTP3 または ToD サーバ

1 WinNT = Microsoft Windows NT

2 ToD = Time of Day

3 NTP = ネットワーク タイム プロトコル

この設定例は uBR7246 の設定全体を示します。 太字で表示されるコマンドは変調プロファイルの設定に関連するコマンドです。

uBR7246 の設定
ubr7246#show run

Building configuration...
Current configuration:
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname ubr7246
!
enable password ww
!
cable modulation-profile 2 request 0 16 1 8 qpsk scrambler 
152 no-diff 64 fixed uw8
cable modulation-profile 2 initial 5 34 0 48 qpsk scrambler 
152 no-diff 128 fixed uw16
cable modulation-profile 2 station 5 34 0 48 qpsk scrambler 
152 no-diff 128 fixed uw16
cable modulation-profile 2 short 6 75 6 8 16qam scrambler 
152 no-diff 144 fixed uw8
cable modulation-profile 2 long 8 220 0 8 16qam scrambler 
152 no-diff 160 fixed uw8

!--- Note: These commands should each be on one line.

no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet2/0
 ip address 172.16.30.20 255.255.255.192
!
interface Cable3/0
 ip address 192.168.5.1 255.255.255.0 secondary
 ip address 10.2.3.1 255.255.255.0
 no keepalive
 cable downstream rate-limit token-bucket shaping
 cable downstream annex B
 cable downstream modulation 256qam
 cable downstream interleave-depth 32
 cable upstream 0 frequency 20000000
 cable upstream 0 power-level 0
 cable upstream 0 modulation-profile 2
 no cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 no cable upstream 5 shutdown
 cable source-verify dhcp
 cable dhcp-giaddr policy
 cable helper-address 172.16.30.3
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.30.1
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password ww
 login tacacs
!
end

完全にするために、このドキュメントでは uBR924 ケーブル モデムの 1 つの設定も示しています。 これは、ケーブル モデムがオンラインになり、DHCP サーバから IP アドレスを取得した後に受信する基本的なブリッジ設定です。

uBR924 の設定
uBR924-445b#show run

Building configuration...
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname uBR924-445b
!
logging rate-limit console 10 except errors
!
clock timezone - -8
ip subnet-zero
no ip routing
no ip finger
!
ip audit notify log
ip audit PO max-events 100
no ip dhcp-client network-discovery
call RSVP-sync
!
!
!
interface Ethernet0
 ip address 10.2.3.3 255.255.255.0
 no ip route-cache
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface cable-modem0
 no ip route-cache
 bridge-group 59
 bridge-group 59 spanning-disabled
 h323-gateway voip interface
 h323-gateway voip id 3620-gk ipaddr 172.16.30.5 1718
 h323-gateway voip h323-id test2
!
ip classless
ip http server
no ip http cable-monitor
!
snmp-server packetsize 4096
snmp-server manager
!
voice-port 0
 input gain -2
 output attenuation 0
!
voice-port 1
 input gain -2
 output attenuation 0
!
dial-peer voice 1 pots
 destination-pattern 3333
 port 0
!
dial-peer voice 2 pots
 destination-pattern 4444
 port 1
!
dial-peer voice 10 voip
 destination-pattern 1111
 session target ras
!
gateway
!
!
line con 0
 transport input none
line vty 0 4
!
end

変調プロファイル組み込みテンプレート

新しい変調プロファイルの定義を簡素化するために、cable modulation-profile コマンドを使用できます。 このコマンドは、3 つの定義済みテンプレートのいずれかに基づいて、完全な変調プロファイルをすばやく作成します。 3 つのテンプレートを次に示します。

  • qpsk:このテンプレートは QPSK を使用するためにすべての内部使用コード(IUC)用に最適化された変調プロファイルです。

  • qam-16:このテンプレートは 16-QAM を使用するためにすべての IUC 用に最適化された変調プロファイルです。

    シスコはこの変調プロファイルの使用を推奨しません。

  • mix:このテンプレートは、データ トラフィックに 16-QAM を使用し、メンテナンスと要求のトラフィックに QPSK を使用するために最適化された変調プロファイルです。

メンテナンス トラフィックで QPSK の安定性を利用し、データ トラフィックで 16-QAM のスピードを活用するためには、mix を使用します。 これらのテンプレートの 1 つを使用する新しい変調プロファイルを作成するには、cable modulation-profile コマンドを発行します。 このドキュメントの次の項では cable modulation-profile コマンドの使用方法を示します。

QPSK 変調プロファイルの例

QPSK テンプレートを使用して CMTS を設定するには、グローバル コンフィギュレーションの cable modulation-profile profile qpsk コマンドを発行します。 この出力はコマンドの使用法を示します。

ubr7246#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

ubr7246(config)#cable modulation-profile 2 qpsk

ubr7246(config)#end

このコマンドを発行した後、CMTS はこのプロファイルのすべての構成済み設定をロードします。 これらの設定は、次のように表示されます。

ubr7246#show run | include modulation-profile 2

cable modulation-profile 2 request 0 16 0 8 qpsk scrambler 152 no-diff 64 fixed uw8
cable modulation-profile 2 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 2 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 2 short 5 75 6 8 qpsk scrambler 152 no-diff 72 fixed uw8
cable modulation-profile 2 long 8 220 0 8 qpsk scrambler 152 no-diff 80 fixed uw8

すべての IUC が自動的に QPSK 変調で作成された点に注意してください。

: cable modulation-profile profile {mix | qam-16 | qpsk} コマンドを発行した後、パラメータの一部を手動で変更できます。

16-QAM 変調プロファイルの例

16-QAM テンプレートを使用して CMTS を設定するには、グローバル コンフィギュレーションの cable modulation-profile profile qam-16 コマンドを発行します。 この出力はコマンドの使用法を示します。

ubr7246#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

ubr7246(config)#cable modulation-profile 3 qam-16

ubr7246(config)#end

このコマンドを発行した後、CMTS はこのプロファイルのすべての構成済み設定をロードします。 これらの設定は、次のように表示されます。

ubr7246#show run | include modulation-profile 3

cable modulation-profile 3 request 0 16 0 8 16qam scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 3 initial 5 34 0 48 16qam scrambler 152 no-diff 256 fixed uw16
cable modulation-profile 3 station 5 34 0 48 16qam scrambler 152 no-diff 256 fixed uw16
cable modulation-profile 3 short 6 75 6 8 16qam scrambler 152 no-diff 144 fixed uw8
cable modulation-profile 3 long 8 220 0 8 16qam scrambler 152 no-diff 160 fixed uw8

混合変調プロファイルの例

QPSK と 16-QAM 変調プロファイルを結合し、より高速でより堅牢な、効率の良いテンプレートがあります。

混合テンプレートを使用して CMTS を設定するには、グローバル コンフィギュレーションの cable modulation-profile profile mix コマンドを発行します。 この出力はコマンドの使用法を示します。

ubr7246#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

ubr7246(config)#cable modulation-profile 4 mix

ubr7246(config)#end

このコマンドを発行した後、CMTS はこのプロファイルのすべての構成済み設定をロードします。 これらの設定は、次のように表示されます。

ubr7246#show run | include modulation-profile 4

cable modulation-profile 4 request 0 16 0 8 qpsk scrambler 152 no-diff 64 fixed uw16
cable modulation-profile 4 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 4 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 4 short 6 75 6 8 16qam scrambler 152 no-diff 144 fixed uw8
cable modulation-profile 4 long 8 220 0 8 16qam scrambler 152 no-diff 160 fixed uw8

ショートおよびロング IUC は 16-QAM を使用することに注意してください。 要求、初期、およびステーションは QPSK を使用します。

混合プロファイルでは、ロングおよびショート IUC のデフォルトの固有ワード設定は 8 ビット固有ワード(UW8)です。 シスコでは UW16 の使用をお勧めします。 より長い固有ワードを使用した方が、ノイズが多い状況で有利であり、また訂正できない FEC エラーの発生が減少します。

固有ワードを UW8 から UW16 に変更するには、cable modulation-profile profile コマンドを発行します。 固有ワードを UW8 から UW16 に変更した後で、show run | include modulation-profile 4 コマンドを発行した場合の出力を次に示します。

ubr7246#show run | include modulation-profile 4

cable modulation-profile 4 request 0 16 0 8 qpsk scrambler 152 no-diff 64 fixed uw16
cable modulation-profile 4 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 4 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 4 short 6 75 6 8 16qam scrambler 152 no-diff 144 fixed uw16
cable modulation-profile 4 long 8 220 0 8 16qam scrambler 152 no-diff 160 fixed uw16

show cable modulation-profile コマンドの項では、show cable modulation-profile コマンドの使用法を詳しく説明します。 CMTS がすべてのパラメータを正しく理解したことを確認するには、変調プロファイルを設定した後でこのコマンドを発行します。

関連コマンド

cable upstream modulation-profile コマンド

変調プロファイルをインターフェイスに割り当てるには、cable upstream n modulation-profile インターフェイス コンフィギュレーション コマンドを発行します。 デフォルトのプライマリ変調プロファイル(プロファイル 1)をインターフェイスに割り当てるには、no cable upstream n modulation-profile インターフェイス コマンドを発行します。

  • cable upstream n modulation-profile primary-profile-number [secondary-profile-number]

  • no cable upstream n modulation-profile primary-profile-number [secondary-profile-number]

表 4:パラメータの説明

パラメータ 説明
n ケーブル モデム スロットのポート番号。ポート番号は 0 から始まります。
primary-profile number インターフェイスに追加されるデフォルトの変調プロファイル
secondary-profile number インターフェイスに追加される追加の変調プロファイル

デフォルト設定

デフォルトはプライマリ変調プロファイル(プロファイル 1)です。

コマンド モード

コマンド モードは、インターフェイス設定です。

表 5:コマンド履歴

Cisco IOS ソフトウェア リリース 変更箇所
11.3 NA このコマンドが初めて導入されました。
12.0(7)XR2 および 12.1(1a)T1 このコマンドは Cisco IOS ソフトウェア リリース 12.x 群に導入されました。
12.1(3a)EC1 Dynamic Upstream Modulation 機能を有効にするために、このコマンドが変更され、primary-profile-number および secondary-profile-number パラメータが追加されました。
12.1(5)EC このコマンドが Cisco uBR7100 シリーズ ユニバーサル ブロードバンド ルータに対応しました。
12.1(7)CX このコマンドが Cisco uBR-MC16S ラインカード向けに拡張されました。

使用上のガイドライン

変調プロファイルは、固定アップストリーム周波数を用いて設定することも、インターフェイス上で割り当てられたスペクトル グループを用いて設定することもできます。 Dynamic Upstream Modulation 機能では、変調プロファイルを使用してアップストリーム信号品質を追跡します。 この機能は、アップストリーム信号が、設定されている変調方式をサポートできるかどうかをチェックし、必要に応じてより安定した変調方式に調整します。 リターン パスの状態が改善されると、アップストリーム チャネルはより高度な変調方式に戻されます。

Dynamic Upstream Modulation とスペクトル グループを同じインターフェイスで設定すると、Cisco uBR-MC1xC および Cisco uBR-MC16S ケーブル モデム カードは次の順序で対処方法を試行します。

  1. 変調スイッチオーバ

  2. 周波数ホッピング

  3. チャネル幅リダクション

この例はプライマリ変調プロファイル 2 とセカンダリ変調プロファイル 1 をポート(インターフェイス)0 に割り当てます。

Router(config-if)#cable upstream 0 modulation-profile 2 1

show cable modulation-profile コマンド

このコマンドの構文は show cable modulation-profile [profile] [iuc-code] です。

表 6:パラメータの説明

パラメータ 説明
profile (任意選択)プロファイル番号:有効値は 1 ~ 8 です。
iuc-code (任意選択)内部使用コード:有効なオプションは次のとおりです。
  • request:要求バースト(IUC 1)
  • reqdata:要求/データ バースト(IUC 2)
  • initial:初期レンジング バースト(IUC 3)
  • station:ステーション レンジング バースト(IUC 4)
  • short:ショート グラント バースト(IUC 5)
  • long:ロング グラント バースト(IUC 6)

デフォルト設定

デフォルトの動作およびデフォルト値はありません。

コマンド モード

コマンド モードは特権 EXEC です。

表 7:コマンド履歴

Cisco IOS ソフトウェア リリース 変更箇所
11.3 XA このコマンドが初めて導入されました。
12.(0)7XR2 このコマンドが使用されました。
12.1(3a)EC1 このコマンドがサポートされ、reqdata タイプが追加されました。

使用上のガイドライン

show cable modulation-profile コマンドを使用すると、変調プロファイル グループの情報が表示されます。 変調プロファイルは UCD メッセージで送信される 6 個のバースト プロファイルの集合です。 これらのプロファイルは次のアップストリーム メッセージ タイプのモデム伝送パラメータを設定します。

  • 要求

  • Reqdata

  • 初期メンテナンス

  • ステーション メンテナンス

  • ショート グラント

  • ロング グラント

これは show cable modulation-profile コマンドからの出力例です:

ubr7246#show cable modulation-profile 1

Mod IUC     Type Preamb Diff FEC    FEC   Scrambl Max  Guard Last Scrambl Preamb
                 length enco T      CW    seed    B    time  CW           offset
                             BYTES  size          size size  short
1   request qpsk 64     no   0x0    0x10  0x152   1    8     no   yes     952
1   initial qpsk 128    no   0x5    0x22  0x152   0    48    no   yes     896
1   station qpsk 128    no   0x5    0x22  0x152   0    48    no   yes     896
1   short   qpsk 72     no   0x5    0x4B  0x152   6    8     no   yes     944
1   long    qpsk 80     no   0x8    0xDC  0x152   0    8     no   yes     936

次の表は、show cable modulation-profile コマンドの出力で表示されるフィールドについて説明しています。

表 8:フィールドの説明

フィールド 説明
Mod 変調プロファイル グループ番号 A。変調プロファイル グループは、アップストリーム送信クラスのさまざまなタイプのアップストリーム送信の特性を定義するバースト プロファイルのセットです。
IUC 内部使用コード。各アップストリーム送信バーストは IUC と呼ばれる番号を持つクラスに属します。 アップストリーム タイム スロットの割り当てに使用される IUC コード別に、メッセージが帯域幅にマップされます。 これらのタイプは現在、次のように定義されています。
  • request:要求バースト(IUC 1)
  • reqdata:要求/データ バースト(IUC 2)
  • initial:初期レンジング バースト(IUC 3)
  • station:ステーション レンジング バースト(IUC 4)
  • short:ショート グラント バースト(IUC 5)
  • long:ロング グラント バースト(IUC 6)
タイプ 変調タイプ
Preamb length プリアンブル長
Diff enco 差分符号化イネーブル(yes)またはディセーブル(no)
FEC T bytes 各 FEC コードワードごとに訂正できるバイト数。
FEC k bytes FEC コード ワード当たりの情報バイト数
FEC CW size ポスト FEC コード ワードのサイズ(バイト単位)。これは通常 k + 2T バイトです。つまり、FEC 情報バイト数(k)に各 FEC のコード ワード(T)内で訂正できるバイト数の 2 倍を加えたものです。
Scrambl seed 16 進形式のスクランブラ シード値
Max B size 最大バースト サイズ。
Guard time size 連続するバースト間の時間(シンボル単位)
Last CW short 短縮された最終コードワードの FEC の取り扱い。
Scrambl スクランブラ イネーブル(yes)またはディセーブル(no)
Preamb offset プリアンブル値ビット

設定した変調プロファイルのパラメータが適切であることを確認するには、プロファイル 2 に対して、show cable modulation-profile コマンドを発行します。

ubr7246#show cable modulation-profile 2

Mod IUC     Type Preamb Diff FEC    FEC   Scrambl Max  Guard Last Scrambl Preamb
                 length enco T      CW    seed    B    time  CW           offset
                             BYTES  size          size size  short
2   request qpsk 64     no   0x0    0x10  0x152   1    8     no   yes     440
2   initial qpsk 128    no   0x5    0x22  0x152   0    48    no   yes     384
2   station qpsk 128    no   0x5    0x22  0x152   0    48    no   yes     384
2   short   qam  144    no   0x6    0x4B  0x152   6    8     no   yes     864
2   long    qam  160    no   0x8    0xDC  0x152   0    8     no   yes     848

関連情報


Document ID: 23710