ダイヤルとアクセス : ダイヤルオンデマンド ルーティング(DDR)

アイドル タイムアウトの概要およびトラブルシューティング

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2008 年 6 月 20 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

ダイヤルアップ リンクでは、予期せずコールがドロップされることがあります。 この問題は、ハードウェアの障害や電話会社の問題など、さまざまなことが原因で発生します。 予期しないコール ドロップの最も一般的な原因の 1 つとして アイドル タイムアウトの発生を挙げることができます。

また、アイドル タイムアウトの一般的な問題として、アイドル タイムアウトが終了しないためにリンクが接続解除されない問題があります。 このため、コールの接続時間単位で課金されている場合は、請求額が高額になる可能性があります。

この文書では、アイドル タイムアウトの設定、およびアイドル タイムアウトに関連するトラブルシューティングについて説明します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

一般的な問題および症状

次の症状は、アイドル タイムアウトに問題がある可能性を示します。

  • 接続の確立後、コールが 2 分(120 秒)ごとに接続解除される。

    このような接続解除は、通常、120 秒のデフォルト アイドル タイムアウトがイネーブルになっている状態で、対象トラフィック定義が定義されていないか、またはインターフェイスに適用されていないことが原因で発生します。 dialer in-band コマンドを使用すると、インターフェイスにおける 120 秒のデフォルト アイドル タイムアウトを有効にすることができますが、この値は show running-configuration 出力には表示されません。 デフォルト アイドル タイムアウトが表示されないため、120 秒の接続解除は誤診される場合があります。

  • 接続の確立後、コールが x 分ごとに接続解除される。

    このような接続解除は、通常、アイドル タイムアウトが(dialer idle-timeout コマンドを使用して)設定されている状態で、対象トラフィック定義が定義されていないか、またはインターフェイスに適用されていないことが原因で発生します。

  • コールの接続解除が早すぎる。 この問題は、ダイヤラ全体のアイドル タイムアウト値が小さいか、または対象トラフィック定義が制限されている場合に発生します。

  • コールが接続解除されない。 この問題は、ダイヤラ全体のアイドル タイムアウト値が大きく、対象トラフィック定義があまり制限されていない場合に発生します。

アイドル タイムアウト

アイドル タイムアウトのキー コマンドは dialer idle-timeout です。このコマンドは、非同期、グループ非同期、ISDN、およびダイヤラの各インターフェイスで使用するインターフェイス設定コマンドです (ppp timeout idle コマンドも頻繁に使用しますが、このコマンドは仮想アクセス インターフェイスに対して使用するため、このドキュメントでは扱いません。 ppp timeout idle の詳細については、ドキュメント『PPP ユーザごとのタイムアウト』を参照してください)。

dialer idle-timeout {x} コマンドは、任意のダイヤラ対応インターフェイスで設定できます。 アイドル カウンタでは、何秒間接続がアイドル状態になっていると解除されるかが制御されます。 カウンタのリセットまたはカウント ダウンは、ルータで決定される「対象トラフィック」に基づいて決定されます。 ルータは、対象トラフィック(dialer-list で定義)を検出すると、アイドル タイマーをリセットします。このような場合以外は、アイドル タイマーはカウント ダウンを続けます。 タイマーがゼロになると、コールは接続解除されます。

このコマンドを使用する場合の注意点は、次のとおりです。

  • このコマンドは、ダイヤラ対応のインターフェイスに対してだけ適用できます。 デフォルトでは、すべての ISDN インターフェイス(Basic Rate Interface(BRI; 基本速度インターフェイス)および Primary Rate Interface(PRI; 一次群速度インターフェイス))がダイヤラ対応であるため、このコマンドは問題なく追加できます。

  • デフォルトでは、非同期インターフェイス(たとえば、interface async x または interface group-async x)はダイヤラ対応ではありません。 これらのインターフェイスは、コマンド dialer in-band を適用してダイヤラ対応にする必要があります。 仮想テンプレート(および仮想アクセス インターフェイス)は、ダイヤラ対応ではなくポイントツーポイントだけに対応しています。 従って、それらは Cisco IOS を実行するこのコマンドを使用できませんか。 アイドルタイムアウト 構造への機能拡張が含まれていた時、ソフトウェア バージョン 12.2(4)T。

  • 非同期インターフェイスに dialer in-band コマンドを入力した場合にだけ dialer idle-timeout を設定できます。

  • ダイヤラ対応インターフェイス(ISDN または dialer in-band を使用する非同期)の場合、デフォルトのアイドル タイムアウトは 120 秒(2 分)です。 異なるアイドル タイムアウト値を使用してコマンド dialer idle-timeout を明示的に設定しない限り、デフォルト値が使用されます。

    注: デフォルトのアイドル タイムアウトは、デフォルトであるため設定には表示されません。 アイドル タイムアウトがインターフェイスに設定されているかどうかを確認するには、show dialer コマンドを使用します。

  • 接続解除を選択するまでユーザの接続が継続されるようにするには、dialer idle-timeout 0 コマンドを使用します。 dialer idle-timeout のゼロ オプションは、Cisco IOS ソフトウェア リリース 12.1(3)T から導入されたオプションです。このオプションを使用すると、タイムアウトを無限に設定できます。

対象トラフィック

Dial-on-Demand Routing(DDR; ダイヤルオンデマンド ルーティング)を使用すると、すべてのトラフィックを対象か非対象のいずれかに分類できます。 対象トラフィックの場合、ルータはピアに接続されます。 非対象トラフィックの場合、コールは接続されません。 ただし、接続済みの接続の場合、対象トラフィックには別の目的があります。 対象トラフィックは、アイドル タイムアウトをリセットして最大値に戻す場合に使用します(dialer idle-timeout コマンドを使用して設定します)。 接続されると、アイドル タイマーのカウント ダウンが開始されます。 ルータが対象トラフィック定義に一致するパケットを受信すると、アイドル タイマーはリセットされ、最大値に戻されます。

対象と見なされるトラフィックは、dialer-list {n} コマンド(グローバル コンフィギュレーション モード)を使用して定義します。{n} は、インターフェイス設定の dialer-group {n} コマンド文の数値と一致します。

対象トラフィックを定義する方法には 2 種類あります。 簡単な方法(dialer-list コマンドだけを使用)では、プロトコル全体(IP や IPX など)を対象または非対象のいずれかに指定します。 ただし、詳細な対象トラフィック定義(たとえば、HTTP トラフィックは対象、Telnet トラフィックは非対称)を設定する必要がある場合は、access-list と組み合せて dialer-list コマンドを使用する必要があります。

対象トラフィックの設定の詳細については、「アイドル タイムアウトおよび対象トラフィックの設定」のセクションを参照してください。

対象トラフィックの方向指定

デフォルトでは、dialer idle-timeout は、発信方向と着信方向の両方の対象トラフィックによって最大値にリセットされます。 着信トラフィックだけがアイドル タイムアウトをリセットする必要がある場合は、追加キーワード inbound を使用します。 アイドル タイムアウトをリセットするには、着信および発信トラフィックに either キーワードを使用します。 このキーワードは、Cisco IOS ソフトウェア リリース 12.1(1)T で導入されました。

長所: 着信トラフィックだけがダイヤラ アイドル タイマーをリセットするように設定すると、予期しないインターネット トラフィックによってアイドル接続の解除が妨害されないようにすることができます。

対象トラフィックおよびアイドル タイムアウトの定義

対象トラフィックは、DDR リンクの両端に定義されている必要があります。 コールを受信するルータが着信コールだけを処理して発信コールを生成しない場合でも、対象トラフィックを定義する必要があります。

着信非同期コールおよび ISDN コールの場合の対象トラフィック定義は、次のとおりです。

ISDN ユーザの場合(Interface Dialer X に対応)

dialer-group コマンドおよび dialer-list コマンドは、アイドル タイムアウトを適用するかどうかに関係なく、ダイヤラ インターフェイス上では必要となります。 dialer-group コマンドおよび dialer-list コマンドは、カプセル化障害を防ぐためにダイヤラ インターフェイス上では必要となります。 この要件は ISDN ユーザにだけ該当し、非同期ユーザおよびグループ非同期インターフェイスには該当しません。

アイドル タイムアウトを適用するには、dialer in-band コマンドおよび dialer idle-timeout コマンドを追加します。 ただし、dialer in-band が設定されているが dialer idle-timeout が設定されていない場合、ISDN ユーザのアイドル タイムアウトはデフォルトで 2 分になります。

接続解除を選択するまで ISDN ユーザの接続が継続されるようにするには、dialer idle-timeout 0 コマンドを使用します。 dialer idle-timeout のゼロ オプションは、Cisco IOS ソフトウェア リリース 12.1(3)T から導入されたオプションです。このオプションを使用すると、タイムアウトを無限に設定できます。

ISDN ユーザの場合(interface Bri x および interface Serial x:23 に対応)

デフォルトでは、すべての物理 ISDN インターフェイスが DDR に対応しています。 つまり、このインターフェイスでは、dialer in-band がすでにイネーブルになっています。 アイドル タイムアウトを適用するには、dialer idle-timeout コマンドを追加します。 ただし、dialer in-band が設定されているが dialer idle-timeout が設定されていない場合、ISDN ユーザのアイドル タイムアウトはデフォルトで 2 分になります。

dialer-group コマンドおよび dialer-list コマンドは、アイドル タイムアウトを適用するかどうかに関係なく、そのインターフェイス上で必要となります。 dialer-group コマンドおよび dialer-list コマンドは、カプセル化障害を防ぐためにそのインターフェイス上で必要となります。 この要件は ISDN ユーザにだけ該当し、非同期ユーザおよびグループ非同期インターフェイスには該当しません。

接続解除を選択するまで ISDN ユーザの接続が継続されるようにするには、dialer idle-timeout 0 コマンドを使用します。 dialer idle-timeout のゼロ オプションは、Cisco IOS ソフトウェア リリース 12.1(3)T から導入されたオプションです。このオプションを使用すると、タイムアウトを無限に設定できます。

非同期ユーザの場合(Interface Group-Async X に対応)

アイドル タイムアウトを非同期ユーザに適用するには、グループ非同期インターフェイスで次のコマンドを設定します。

  • dialer in-band

  • dialer idle-timeout

  • dialer-group

対応する dialer-list も必要となります。 dialer-group コマンドおよび dialer-list コマンドを使用して、グループ非同期インターフェイスの対象トラフィックを指定します。

非同期ユーザでは、対象トラフィックは、アイドル タイムアウトをリセットする場合にだけ使用されます。 対象トラフィックが定義されていない場合、リンクでトラフィックが受け渡しされているかどうかに関係なく、ユーザは、ダイヤラ アイドル タイムアウト(デフォルトは 120 秒)が発生したときに接続解除されます。 対象トラフィックが定義されている場合は、Network Access Server(NAS; ネットワーク アクセス サーバ)がこれらのパケットを認識してアイドル タイムアウトをリセットするため、ユーザは、リンクが実際にアイドルになっている場合にだけ接続解除されます。

対象トラフィックを修正して、たとえば HTTP(Web)トラフィックだけを対象にすることができます。 このような場合、ユーザが Web を 300 秒間(または特定のダイヤラ アイドル タイムアウト)参照しないと、このユーザは接続解除されます。 ユーザのトラフィック パターンに応じて対象トラフィックを設定してください。

接続解除を選択するまで非同期ユーザの接続が継続されるようにするには、次の設定のように、グループ非同期インターフェイスから次のコマンドを削除します。

  • dialer in-band

  • dialer idle-timeout

  • dialer-group

dialer idle-timeout 0 コマンドを使用すると、アイドル タイムアウトを無限に設定できます。 ダイヤラ アイドル タイムアウトのゼロ オプションは、Cisco IOS ソフトウェア リリース 12.1(3)T から導入されたオプションです。このオプションを使用すると、タイムアウトを無限に設定できます。

アイドル タイムアウトおよび対象トラフィックの設定

このセクションでは、アイドル タイムアウトおよび対象トラフィックをルータで設定する方法について説明します。 この設定は、次のすべての DDR 対応インターフェイスに適用できます。

interface BRI
interface async x
interface dialer x
interface group-async x
interface serial x:23

Authentication, Authorization, and Accounting(AAA; 認証、許可、アカウンティング)サーバを使用すると、ユーザごとにタイムアウトを指定できます。 詳細については、ドキュメント『PPP ユーザごとのタイムアウト』を参照してください。

設定例

次の設定例には、対象トラフィックの簡単な定義が含まれています。 この例では、すべての IP トラフィックが対象トラフィックに指定されています。

interface BRI0/0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer idle-timeout 900
!--- Idle-timeout is set at 900 seconds (15 minutes)
dialer-group 1
!--- Apply interesting traffic definition from dialer-list 1
isdn switch-type basic-5ess
no cdp enable
ppp authentication chap
!
dialer-list 1 protocol ip permit
!--- Designate all IP traffic as interesting.  
This definition was applied to BRI0/0 using dialer-group 1.   
Note that the dialer-list and dialer-group numbers match

前述の設定では、少なくとも 900 秒間(15 分)は接続のアクティブ状態が維持され、その後、双方向(デフォルト)の IP トラフィックによってアイドル タイムアウトがリセットされて 900 秒に戻されます。 このため、IP トラフィックがいずれの方向にも 15 分間送信されない場合、ルータは、アイドル タイムアウトが発生したと判断して回線を接続解除します。

注: ルーティング プロトコルをこの DDR リンクで実行すると、周期的なトラフィックによってリンクが無期限にアップし続けます。 このため、前述の対象トラフィック定義は、ルーティング プロトコル(または他の周期的なトラフィック)が実行されているリンクでは使用しないようにしてください

アクセス リストの使用

次の例では、Basic Rate Interface(BRI; 基本速度インターフェイス)を使用するルータがコールを受信しており、inbound キーワードを使用して dialer idle-timeout コマンドが無効にされています。 このコマンドを使用すると、ダイヤラ リストに準拠する着信トラフィックだけがダイヤラ アイドル タイマーをリセットできます。 この場合は、ポート 80 の TCP トラフィック(HTTP トラフィック)だけがアイドル タイムアウトを 10 分(600 秒)にリセットできます。 このため、エンド ユーザが Web を 10 分間参照しない場合は、接続が解除されます。

ISDN インターフェイスの使用

interface BRI0/0   
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer idle-timeout 600 inbound

!--- Idle timeout is 600 seconds.  Only inbound interesting traffic will reset 
the idle timeout

dialer-group 1

!--- Apply the interesting traffic defintion from dialer-list 1

peer default ip address pool dialin
isdn switch-type basic-5ess
no cdp enable
ppp authentication chap
!
access-list 101 permit tcp any any eq 80

!--- Permit tcp port 80 (http) from any host to any other host

access-list 101 deny ip any any

!--- All other IP traffic is uninteresting

dialer-list 1 protocol ip list 101

!--- Use list 101 for granular interesting traffic definition
ip local pool dialin 10.1.1.2 10.1.1.254

非同期インターフェイスの使用

デフォルトでは非同期インターフェイスは DDR に対応していないため、dialer in-band を使用してこのインターフェイスを DDR 対応に変更します。

Interface group-async 1
ip unnumbered ethernet 0
no ip directed-broadcast
encapsulation ppp
dialer in-band
dialer idle-timeout 600
dialer-group 1
peer default ip address pool dialin
no cdp enable
ppp authentication chap
!
access-list 101 permit tcp any any eq 80
access-list 101 deny ip any any

!--- Access-lists have an implicit deny.  However, we are explicitly denying IP 
here for clarity.


dialer-list 1 protocol ip list 101
ip local pool dialin 10.1.1.2 10.1.1.254

アイドル タイムアウトの改良

Cisco IOS ソフトウェア リリース 12.2(4)T がリリースされる前は、ダイヤラ アイドル タイマーは、ダイヤラ対応のインターフェイス(dialer in-band コマンドを使用した BRI、PRI、group-async など)の対象トラフィックに対してだけリセットできました。 アイドル タイムアウトは、仮想テンプレート インターフェイスに接続しているユーザには適用できませんでした。

Cisco IOS ソフトウェア リリース 12.2(4)T では、Customer Profile Idle Timer Enhancements for Interesting Traffic 機能として、Virtual Access Dialup Network (VPDN; 仮想アクセス ダイヤルアップ ネットワーク)セッションにおけるアイドル タイマー問題に対応するための新規のコマンドおよび機能性が提供されいます。これらのコマンドおよび機能は仮想アクセス(予測)インターフェイスを使用しており、PPP アイドル タイマー メカニズムに依存しています。

アイドル タイムアウトの確認

アイドル タイムアウト動作の確認およびトラブルシューティングを行うには、次の手順を実行します。

  1. show user コマンドを使用して、コールが接続されているかどうかを確認します。

  2. show caller timeoutshow dialer、および show caller user を使用して、アイドル タイムアウトが接続されたインターフェイスに正しく割り当てられているかどうかを確認します。 show コマンドを複数回実行すると、接続解除時間が減少します。

  3. 対象トラフィック(dialer-list x で定義)をリンク経由で発信します。 実行コンフィギュレーションを確認して、対象トラフィック定義を特定する必要があります。

  4. show caller timeoutshow dialer、および show caller user を再度実行して、アイドル タイムアウトがリセットされたかどうかを確認します。 リセットされていない場合は、(dialer-list を使用して)対象トラフィックが適切に定義されていないか、または(dialer-group を使用して)対象トラフィックがインターフェイスに適用されていません。

アイドル タイムアウトの動作を確認する場合に使用するコマンドは、次のとおりです。

  • show caller timeout:インストールされている絶対タイムアウト、アイドル タイムアウト、およびタイムアウトによってユーザが接続解除されるまでの時間を表示。

  • show dialer [interface type number]:DDR に設定されたインターフェイスの一般的な診断情報を表示します。 ダイヤラが正常に立ち上がると、dialer state is data link layer up というメッセージが表示されます。 physical layer up が表示された場合、回線プロトコルは立ち上がりましたが、Network Control Protocol(NCP; ネットワーク制御プロトコル)は立ち上がっていません。 ダイヤリングを開始したパケットのソース アドレスと宛先アドレスが、「Dial reason」の行に表示されます。 このコマンドを使用すると、タイマーの設定および接続がタイムアウトするまでの時間も表示されます。

  • show caller user username detail:特定ユーザのパラメータ(割り当てられている IP アドレス、PPP および PPP バンドル パラメータなど)を表示。 ご使用の Cisco IOS ソフトウェア バージョンでこのコマンドがサポートされていない場合には、show user コマンドを使用します。

ISDN コールの場合

次に示す設定は、dialer rotary-group 1 コマンドを使用して interface dialer 1 にリンクされている BRI インターフェイスを使用する受信側ルータの設定です。 interface dialer 1 は、dialer in-band を使用して DDR 対応になっています。

interface BRI0
   description 96665500
   no ip address
   encapsulation ppp
   no ip route-cache
   no ip mroute-cache
   dialer rotary-group 1
   dialer-group 1
   isdn switch-type basic-5ess
   no cdp enable
   ppp authentication pap
 !
 interface Dialer1
   ip address 10.1.1.1 255.255.255.0
   encapsulation ppp
   no ip route-cache
   no ip mroute-cache
   dialer in-band
   dialer idle-timeout 600
   dialer-group 1
   peer default ip address pool dialin
   no cdp enable
   ppp authentication chap callin
   ppp chap hostname cisco
   ppp chap password 7 <deleted>
 !
 ip local pool dialin 10.1.1.2 10.1.1.255
 dialer-list 1 protocol list 101
 access-list 101 permit icmp any any
 access-list 101 permit tcp any any eq 80
 access-list 101 deny ip any any

!--- Only http traffic and icmp traffic are interesting
 
 !

アイドル タイムアウトの確認を行うには、次の手順を実行します。

  1. コールが接続されたかどうかを確認します。 ユーザが接続されたかどうかを確認するには、show user コマンドを使用します。 次に、例を示します。

    isdn2-4#show user
    
    Line   User  Host(s)       Idle     Location
    * 2 vty 0  idle         00:00:00 172.22.88.109
    
    Interface   User  Mode     Idle      Peer Address
    BR0:1       Preet Sync PPP 00:00:51  PPP: 10.1.1.2
    
  2. アイドル タイムアウトが接続に適用されているかどうかを確認します。 次の例では、ユーザ Preet が interface dialer 1 にダイヤルインして終了します。また、ユーザ Preet は、プール ダイヤルインから IP アドレス 10.1.1.2 を取得します。 この接続で 600 秒(10 分)のアイドル タイムアウトが使用されているかどうかを確認します。

    isdn2-4#show dialer interface dialer1
    Di1 - dialer type = IN-BAND SYNC NO-PARITY
    Load threshold for dialing additional calls is 255
    Idle timer (600 secs), Fast idle timer (20 secs)
    !--- The idle timeout value configured on int dialer 1.   If the default 
    is in use, this value will be 120.
    
    Wait for carrier (30 secs), Re-enable (15 secs)
    Number of active calls = 1
    
    Dial String   Successes   Failures   Last DNIS   Last status
    
    BRI0 - dialer type = ISDN
    Rotary group 1, priority = 0
    0 incoming call(s) have been screened.
    0 incoming call(s) rejected for callback.
    
    BRI0:1 - dialer type = ISDN
    Idle timer (600 secs), Fast idle timer (20 secs)
    !--- The user Preet obtained the idle timeout of 600 seconds.
    
    Wait for carrier (30 secs), Re-enable (15 secs)
    Dialer state is data link layer up
    Time until disconnect 557 secs
    

    対象トラフィックがリンクを通過しない場合は、接続解除時間のカウント ダウンが開始されます。 いずれの方向に対しても、対象トラフィックが 43 秒間通過していません。 このため、ユーザは 600 - 43 = 557 秒後に接続解除されます。 ユーザが接続すると、Time until disconnect フィールドでカウント ダウンが開始され、対象トラフィックが受信されると最大値にリセットされます。

    Connected to 4086666700 (Preet)
    BRI0:2 - dialer type = ISDN
    Idle timer (600 secs), Fast idle timer (20 secs)
    Wait for carrier (30 secs), Re-enable (15 secs)
    Dialer state is idle

    アイドル タイムアウトを確認には、show caller timeout コマンドも使用できます。

    isdn2-4#show caller timeout
    Line    User   Limit     Remaining   Timer  Type
    vty 2    -     00:10:00  00:09:59    Idle   Exec
    BR0:1   Preet  00:10:00  00:09:13    Dialer idle
    

    Limit フィールドには、設定されているアイドル タイムアウトの最大値(分単位)が表示され、その他のフィールドには、接続解除されるまでの時間が表示されます。

  3. 対象トラフィックをピアに発信します。 ここでは、対象トラフィックのピアへの発信について確認します。 実行コンフィギュレーションを確認して、対象トラフィック定義を特定します。 access-list 101 には、ポート 80 への Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)および TCP トラフィックが対象として定義されています。 このため、ルータから 10.1.1.2(ユーザ Preet がネゴシエートする IP アドレス)に対して PING を実行します。

    isdn2-4#ping 10.1.1.2
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 36/37/40 ms
    isdn2-4#
  4. アイドル タイムアウトがリセットされたかどうかを確認します。 show caller timeoutshow dialer、および show caller user の各コマンドを使用して、アイドル タイムアウトがリセットされたかどうかを確認します。

    isdn2-4#show caller timeout 
     Line     User      Limit    Remaining  Timer Type 
     vty 2    -         00:10:00 00:09:59   Idle Exec 
     BR0:1    Preet     00:10:00 00:09:59   Dialer idle
    !--- Idle-timout is reset back to maximum
    
    
    isdn2-4#show dialer interface dialer1
    
    Di1 - dialer type = IN-BAND SYNC NO-PARITY
    Load threshold for dialing additional calls is 255
    Idle timer (600 secs), Fast idle timer (20 secs)
    Wait for carrier (30 secs), Re-enable (15 secs)
    Number of active calls = 1
    
    Dial String   Successes   Failures   Last DNIS   Last status
    
    BRI0 - dialer type = ISDN
    Rotary group 1, priority = 0
    0 incoming call(s) have been screened.
    0 incoming call(s) rejected for callback.
    
    BRI0:1 - dialer type = ISDN
    Idle timer (600 secs), Fast idle timer (20 secs)
    Wait for carrier (30 secs), Re-enable (15 secs)
    Dialer state is data link layer up
    Time until disconnect 599 secs
    
    !--- Idle timeout is reset back to maximum.
    
    
    Connected to 4086666700 (Preet)
    
    BRI0:2 - dialer type = ISDN
    Idle timer (600 secs), Fast idle timer (20 secs)
    Wait for carrier (30 secs), Re-enable (15 secs)
    Dialer state is idle
    isdn2-4# 
    

ユーザ名に基づいたタイムアウト情報を表示する場合、show caller user コマンドも使用できます。

isdn2-4#show caller user Preet
 User: Preet, line BR0:1, service PPP 
 Connected for 00:05:36, Idle for 00:02:37
!--- Shows the inactivity for the last two minutes and 37 seconds. 
This counter increments to ten minutes and then the call is disconnected.


Timeouts: Limit    Remaining Timer  Type
          00:10:00 00:07:22  Dialer idle
!--- Time until idle disconnect.


PPP: LCP Open, PAP (<- none), IPCP
Dialer: Connected to 4086666700, inbound
        Type is ISDN, group Di1
IP: Local 10.1.1.1/24, remote 10.1.1.2
Counts: 215 packets input, 5392 bytes, 0 no buffer
        0 input errors, 0 CRC, 0 frame, 0 overrun
        230 packets output, 5603 bytes, 0 underruns
        0 output errors, 0 collisions, 7 interface resets

アイドル タイムアウトがリセットされていない場合は、「 アイドル タイムアウトに関する問題のトラブルシューティング」のセクションに進んでください。

非同期コールの場合

ISP 環境での非同期コールの典型的な設定は、次のとおりです。

 interface Group-Async0
   ip unnumbered Loopback0
   encapsulation ppp
   dialer in-band

!--- Make this interface dialer capable
 
   dialer idle-timeout 600

!---  Idle timeout of 600 seconds (10 minutes)

   dialer-group 1

!--- Interesting traffic definition from dialer-list 1

   async mode interactive
   peer default ip address pool dialin
   ppp authentication pap chap callin
   group-range 1/3/00 1/3/71
   !
   ip local pool dialin 10.1.1.3 10.1.1.255
 dialer-list 1 protocol list 101

!--- Interesting traffic definition is defined by access-list 101

access-list 101 permit icmp any any

!--- Permit icmp from any host to any other host

 access-list 101 permit tcp any any eq 80

!--- Permit tcp port 80 (http traffic)

access-list 101 deny ip any any

!--- Deny all other IP traffic.  This interesting traffic definition 
will allow icmp and http traffic to reset the idle timeout. All other IP traffic will not 
affect the timeout.

ISDN の場合と同様、show usersshow dialer、および show caller timeout を使用して、アイドル タイムアウトを確認します。

show users コマンドを使用して、ピアが接続されているインターフェイスおよび IP アドレスを特定します。

c5800#show users
      Line      User  Host(s)         Idle     Location
   * 0 con 0          idle            00:00:00 
     tty 1/3/01 Preet Async interface 00:00:09 PPP: 10.1.1.3
!--- User Preet is connected to async interface 1/3/01 and has IP address 10.1.1.3

Interface    User Mode             Idle     Peer          Address

show dialer コマンドを使用して、タイマーの値を確認します(特定したインターフェイスを指定)。

c5800#show dialer interface async 1/3/01
As1/3/01 - dialer type = IN-BAND ASYNC NO-PARITY
Idle timer (600 secs), Fast idle timer (20 secs)
!--- Idle timeout of 600 seconds is applied to the interface if this value 
is 120 seconds.


!--- Verify that dialer in-band is configured under the group-async interface.

Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Time until disconnect 574 secs (Preet)
!--- Call will be disconnected in 574 seconds unless it receives interesting traffic.
Dial String     Successes    Failures    Last DNIS     Last status

接続解除されるまでの時間を表示するには、show caller timeout コマンドも使用できます。

c5800#show caller timeout
                        Session    Idle      Disconnect
   Line        User     Timeout    Timeout     User in
   con 0        -        -          -           - 
   tty 1/3/01  Preet     -          -           - 
   As1/3/01    Preet     -         00:10:00    00:09:19 

ここでは、対象トラフィックを発信します。 access-list 101 には、ポート 80(HTTP トラフィック)への ICMP および TCP トラフィックが対象と定義されています。 ルータから 10.1.1.3(ユーザ Preet がネゴシエートする IP アドレス)に対して PING を実行し、アイドル タイムアウトをリセットします。

c5800#ping 10.1.1.3
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 10.1.1.3, timeout is 2 seconds:
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 108/113/124 ms

タイムアウトがリセットされたかどうかを確認します。

   c5800#show caller timeout
                      Session Idle    Disconnect
   Line       User    Timeout Timeout User in
   con 0      -        -       -      - 
   tty 1/3/01 Preet    -       -      - 
   As1/3/01   Preet    -     00:10:00 00:09:58
!--- Time to disconnect is close to 10 minutes

これにより、対象トラフィックが正しく定義され、正しく適用されていることが確認できます。 タイムアウトの値を確認するには、show dialer コマンドも使用できます。

c5800#show dialer interface async 1/3/01
   As1/3/01 - dialer type = IN-BAND ASYNC NO-PARITY
   Idle timer (600 secs), Fast idle timer (20 secs)
   Wait for carrier (30 secs), Re-enable (15 secs)
   Dialer state is data link layer up
   Time until disconnect 594 secs (Preet)
   Dial String   Successes    Failures   Last DNIS    Last status

ユーザ固有のパラメータを確認するには、show caller user {username} detailed コマンドを使用できます。

c5800#show caller user preet detailed 
User:   Preet, line tty 1/3/01, service Async
        Active time 00:01:14, Idle time 00:00:18
Timeouts:          Absolute   Idle      Idle
                              Session   Exec
Limits:            -          -         00:10:00
Disconnect in:     -          -         -    
TTY: Line 1/3/01, running PPP on As1/3/01   
Location: PPP: 10.1.1.3   
DS0: (slot/unit/channel)=1/4/0   
Status: Ready, Active, No Exit Banner, Async Interface Active
        HW PPP Support Active   
Capabilities: No Flush-at-Activation, Hardware Flowcontrol In
              Hardware Flowcontrol Out, Modem Callout, Modem RI is CD                 
              Line usable as async interface, Telnet Faststream   
Modem State: Ready

User: Preet, line As1/3/01, service PPP
      Active time 00:01:11, Idle time 00:00:18   
Timeouts:        Absolute Idle
Limits:          -        00:10:00    
Disconnect in:   -        00:09:41 
!--- Idle timeout of 10 minutes. The call will be disconnected in 9 minutes 41 secs 
unless it receives interesting traffic during that time. If the absolute column has a 
value, then the call will be disconnected at that time regardless of the idle timeout.

PPP: LCP Open, CHAP (<- local), IPCP
LCP: -> peer, ACCM, AuthProto, MagicNumber, PCompression, ACCompression          
     <- peer, ACCM, MagicNumber, PCompression, ACCompression   
NCP: Open IPCP   
IPCP: <- peer, Address
      -> peer, Address   
Dialer: Connected, inbound
        Idle timer 600 secs, idle 20 secs
        Type is IN-BAND ASYNC, group As1/3/01   
IP: Local 10.1.1.251, remote 10.1.1.3   
Counts: 12 packets input, 651 bytes, 0 no buffer 
        0 input errors, 0 CRC, 0 frame, 0 overrun           
        13 packets output, 666 bytes, 0 underruns           
        0 output errors, 0 collisions, 0 interface resets

トラブルシューティング:アイドル タイムアウトに関する問題

症状: コールの接続解除が早すぎるか、またはコールの接続がまったく解除されない

コールの接続が途中で解除されるか、またはコールの接続がまったく解除されない場合は、ダイヤラのアイドル タイムアウトおよび対象トラフィック定義をチェックします。 特定のパケットが対象かどうかを確認するには、debug dialer packet コマンドを使用します。 次に、例を示します。

Apr 26 01:57:24.483: Di1 DDR: ip (s=192.168.1.1, d=224.0.0.5), 
64 bytes, outgoing uninteresting (list 101)
Apr 26 01:57:26.225: Di1 DDR: ip (s=192.168.1.1, d=10.1.1.1), 
100 bytes, outgoing interesting (list 101)

前述の例では、OSPF hello は access-list 101 によると非対象となりますが、2 番目のパケットは access-list 101 によると対象となります。 次のようにトラブルシューティングを行います。

  1. ダイヤラ インターフェイス設定の dialer idle timeout を調整します。 デフォルトは 120 秒ですが、必要に応じてこの値を大きくしたり小さくしたりできます。

    router(config-if)#dialer idle-timeout 

    注: コールが接続解除されない場合は、ダイヤラ アイドル タイムアウトのゼロ オプション(Cisco IOS ソフトウェア リリース 12.1(3)T から導入)が設定されていないかどうかを確認してください。

  2. dialer-list コマンドで設定される)対象トラフィック定義を変更します。 コールの接続解除が早すぎる場合は、対象トラフィックの定義を緩和します(いくつかの対象トラフィックを拒否し、それ以外の対象トラフィックを許可します)。 コールの接続がまったく解除されない場合は、対象トラフィックの定義をより限定的なものに変更します(いくつかを対象トラフィックを許可し、それ以外の対象トラフィックを拒否します)。

    ヒント: リンクが接続解除されない場合は、ルーティング プロトコル トラフィック(または任意の周期的トラフィック)が非対象として定義されているかどうかを確認してください。 これにより、周期的な hello によってアイドル タイムアウトがリセットされなくなります。 次に対象トラフィック定義の例を示します。

    access-list 101 remark Interesting traffic for dialer-list 1   
    access-list 101 deny ospf any any
    !--- Mark OSPF as uninteresting.  This will prevent OSPF hellos from 
    keeping the link up.
    
    
    access-list 101 deny udp any any eq ntp
    
    !--- Define ntp traffic as NOT interesting.  This will prevent periodic ntp 
    traffic from keeping the link up indefinitely.
    
    
    access-list 101 permit ip any any
    !--- All other IP traffic is interesting. Change this depending on your 
    traffic needs.
    
    dialer-list 1 protocol ip list 101
    !--- This interesting traffic is applied to the dialer interface using 
    dialer-group 1.
    
    

    詳細については、ドキュメント ダイヤルアップ テクノロジーを参照して下さい: 概要および説明

症状: 数秒ごとにコールが接続解除される

別の問題として、コールが「x」秒(通常は 120 秒)ごとに接続解除されるという問題があります。 特定の状況において、トラフィックがリンクを通過している場合でも、DDR によってアイドル タイムアウトがリセットされない場合があります。 この原因としては、次の理由が考えられます。

  • 対象トラフィックが定義されていない。

  • 対象トラフィック定義がインターフェイスに適用されていない。

  • インターフェイスがダイヤラに対応していない。

この問題を解決する手順は、次のとおりです。

  1. dialer-list が定義されており、インターフェイスで(dialer-list を示す)dialer-group が定義されているかどうかを確認します。 対象トラフィック定義を次のように設定します。

    router(config)#interface dialer 1
    router(config-if)#dialer-group 1
    router(config-if)#exit
    router(config)#dialer-list 1 protocol ip permit
    

    頻繁に接続解除される問題が解決した後、必要に応じて対象トラフィック定義を調整します。

  2. dialer in-band がグループ非同期インターフェイスおよびダイヤラ インターフェイスに設定されているかどうかを確認します。 このコマンドは、interface BRI x および interface Serial x:23(PRI 用)などのダイヤラ対応インターフェイスでは必要ありません。

  3. ダイヤラ アイドル タイムアウトを目的の値に調整します。

    router(config-if)#dialer idle-timeout 900
    

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 23423