LAN スイッチング : EtherChannel

CatcOsスイッチと外部ルータ間のFEC およびISL/802.1q トランキング設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 9 月 17 日) | 英語版 (2015 年 10 月 7 日) | フィードバック


目次


概要

このドキュメントでは、CatalystOS(CatOS)を実行している Catalyst 6500 スイッチと Cisco 7500 ルータ間の Fast EtherChannel(FEC)、スイッチ間リンク(ISL)、および 802.1q トランキングの設定例を紹介します。 各コマンドの実行結果は、そのコマンドを実行する場所で示されます。 この設定では Catalyst 6000 スイッチが使用されていますが、CatOS を実行している Catalyst 4000 または Catalyst 5000 ファミリ スイッチと置き換えることができます。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • Catalyst 6000 シリーズ スイッチ

    • EtherChannel をサポートするには、CatOS リリース 5.1(1) CSX 以降が必要です。

  • Cisco 7000 または 7500 シリーズ ルータ

    • 7000 シリーズ Route Switch Processor (RSP7000)または Chassis Interface(CI) (RSP7000CI)の Cisco 7000 シリーズ ルータ、または Fast Ethernet Interface Processors (FEIP)または Versatile Interface Processor (VIP2)ポートアダプタが付いている Cisco 7500 シリーズ ルータ

    • PA-2FEISL ポートアダプタを使用している場合、ハードウェアリビジョン 1.2 またはそれ以降がなければなりません。

      詳細については、Field Notice: *Expired* FN - 8791_11301999 -詳細については PA-2FEISL 2-Port Fast Ethernet ISL 交換推奨事項

    • encapsulation dot1q native コマンドは Cisco IOS でもたらされましたか。 ソフトウェア リリース 12.1(3) T。 これは、設定を変更するためのコマンドです。

      Cisco IOS ソフトウェア リリースについては Cisco 7500 802.1Q 設定を詳細についてはこの資料の 12.1(3)T セクションより先に参照して下さい。

    • Cisco 7500 シリーズ ルータでは Cisco Express Forwarding がデフォルトで有効になっています。 ただし、IEEE 802.1Q VLAN 間の IP ルーティングのための Cisco Express Forwarding サポートは Cisco IOS ソフトウェア リリース 12.2 および 12.2T まで利用できません。 前のリリースの 802.1Q カプセル化を設定することはまだ可能性のあるですしかし最初に Cisco Express Forwarding をディセーブルにする global no ip cef コマンドを発行して下さい。

    • 7500 シリーズ ルータがマルチプロトコル ラベル スイッチング(MPLS)および FEC のために設定されるとき、サポートはルーティングに現在利用できません(MPLS か。 MPLS インターフェイスから FEC インターフェイスに流れる IP)パケット。 従って MPLS および FEC 設定がシングル ルータで共存することが、推奨されません。

    • Cisco IOS ソフトウェア リリース 11.1(14)ca またはそれ以降が EtherChannel をサポートするために必要となります。

      Cisco IOS ソフトウェア リリース 11.3(1)T (機能セットと)またはそれ以降が ISL トランキングをサポートするために必要となります。

      Cisco IOS ソフトウェア リリース 12.0(1)T (機能セットと)またはそれ以降が IEEE 802.1Q トランキングをサポートするために必要となります。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • CatOS バージョン 5.5.14 を実行する Catalyst 6500

  • Cisco IOS ソフトウェア リリース 12.2.7b を実行する Cisco 7500

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

重要事項

  • Catalyst 4000 シリーズ スイッチは、ISL トランキングをサポートしていない点に留意してください。 また、Catalyst 5000 シリーズ スイッチのスイッチング モジュールの中には、EtherChannel に対応していないものがあります。 特定のモジュールが可能な EtherChannel であるかどうか幹線エンキャプシュレーションをサポートするどんな判別する show port capabilities モジュールコマンドを発行すれば。

  • EtherChannel およびトランキングの設定に関しては、いくつかのガイドラインがあります。 スイッチのソフトウェアドキュメンテーションを常に参照して下さい。

    たとえば、Catalyst 5000 上でソフトウェア リリース 5.5.x を実行している場合、『ソフトウェア コンフィギュレーション ガイド(5.5)』を参照し、「Fast EtherChannel および Gigabit EtherChannel の設定」という節に記載されている設定のガイドラインと制限事項を慎重に確認してください。

Etherchannel

FEC または Gigabit EtherChannel(GEC)機能を使用すると、複数のポイントツーポイント リンクを 1 つの論理リンクにバンドルできます。 Catalyst 6000 は最大 FEC のための 1600 Mbps か 1.6 Gbps スループットおよび GEC のための 16 Gbps を提供するフルデュプレクスモードの 8 つのポートをサポートします。 Cisco 7500 シリーズ最大 800 Mbps のための FEC 毎に 4 つのポートを、サポートします。 EtherChannel の機能とパフォーマンスは、スイッチまたはルータによって異なります。 詳細については、「Catalyst スイッチに EtherChannel を実装するためのシステム要件」を参照してください。

EtherChannel は 1つ以上のリンクが失敗する場合リンクすべてを渡るトラフィックを分散し、冗長性を提供します。 EtherChannel に 関するおよび設定 例詳細については Catalyst スイッチでの EtherChannel のロード バランシングと冗長性についてを参照して下さい。

詳細については Cisco テクニカル サポート及びドキュメントの EtherChannel ページを参照して下さい。

トランキング

トランキングは 2 つのデバイス間のポイント ツー ポイントリンクまたは EtherChannelバンドル上の複数 の VLAN からのトラフィックを運ぶ方法です。 これらはイーサネットトランキングが設定されます 2 つの方法です:

  • ISL(シスコ独自のトランク カプセル化)

  • 802.1q(IEEE 規格のトランク カプセル化)

詳細については Cisco テクニカル サポート及びドキュメントの VLAN トランキング プロトコル ページを参照して下さい。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

これらの設定 例はこれらの事柄をする方法を示します:

  • VLAN 1 のワークステーション 1 と Catalyst 6500 の VLAN 2 のワークステーション 2 のための 2 つのアクセス ポートを設定して下さい。

  • 10.10.10.1 /24 であるためにワークステーション 1 と Cisco 7500 の 10.10.11.1/24 であるワークステーション 2 のためのデフォルト ゲートウェイを設定して下さい。

  • Catalyst 6500 スイッチと Cisco 7500 ルータ間の 2ポート FEC 上の ISL および 802.1Q トランクを設定して下さい。

  • VLAN 間ルーティングのための IP アドレスで 2 つの port-channel サブインターフェイスを設定して下さい。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

トランキング VLAN 1 および 2 ポート FEC 上の VLAN 2

141.gif

設定

このドキュメントでは、次の設定を使用します。

Catalyst 6500 スイッチ

!--- Set the IP address and default gateway for VLAN 1 for management purposes.

Catalyst6500> (enable) set interface sc0 10.10.10.2 255.255.255.0

Interface sc0 IP address and netmask set.

Catalyst6500> (enable) set ip route default 10.10.10.1

Route added.

!--- Set the VTP mode. In this example, the mode is set to be transparent. Depending on your
!--- network, set the VTP mode accordingly.
!--- For details on VTP, refer to Understanding and Configuring VLAN Trunk Protocol (VTP).

Catalyst6500> (enable) set vtp mode transparent

VTP domain modified

!--- Add VLAN 2. VLAN 1 already exists by default.

Catalyst6500> (enable) set vlan 2

VLAN 2 configuration successful

!--- Add port 3/4 to VLAN 2. Port 3/3 is already in VLAN 1 by default.

Catalyst6500> (enable) set vlan 2 3/4

VLAN 2 modified.
VLAN 1 modified.
VLAN  Mod/Ports
---- -----------------------
2     3/4

!--- Set the port speed to 100 and duplex to full. One of the requirements for EtherChannel
!--- to work is for speed and duplex to be the same on both sides. To guarantee this, hard
!--- code both speed and duplex on ports 3/1 and 3/2.

Catalyst6500> (enable) set port speed 3/1-2 100

Ports 3/1-2 transmission speed set to 100Mbps.

Catalyst6500> (enable) set port duplex 3/1-2 full

Ports 3/1-2 set to full-duplex.

!--- Enable FEC on ports 3/1 and 3/2. Because routers do not understand Port Aggregation
!--- Protocol (PAgP), set the channel mode to one which causes ports to channel but which
!--- does not generate PAgP frames.

Catalyst6500> (enable) set port channel 3/1-2 on

Port(s) 3/1-2 are assigned to admin group 105.
Port(s) 3/1-2 channel mode set to on.

!--- Enable trunking on ports 3/1 and 3/2. Because routers do not understand Dynamic
!--- Trunking Protocol (DTP), set the trunking mode to nonegotiate, which causes ports to
!--- trunk but which does not generate DTP frames.
!--- Note: Because EtherChannel is configured first, any trunk settings that are applied
!--- now to one port automatically apply to all other ports in the channel.
!--- Enter the trunking encapsulation as either ISL…

Catalyst6500> (enable) set trunk 3/1 nonegotiate isl

Port(s) 3/1-2 trunk mode set to nonegotiate.
Port(s) 3/1-2 trunk type set to isl.

!--- …or as dot1q.
!--- Ensure that the native VLAN (default is VLAN 1) matches across the link. For more
!--- information about the native VLAN and 802.1Q trunking, refer to Trunking Between
!--- Catalyst 4500/4000, 5500/5000, and 6500/6000 Series Switches Using 802.1Q
!--- Encapsulation with Cisco CatOS System Software.

Catalyst6500> (enable) set trunk 3/1 nonegotiate dot1q

Port(s) 3/1-2 trunk mode set to nonegotiate.
Port(s) 3/1-2 trunk type set to dot1q.

Catalyst6500> (enable) show config

This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
.........
..................
..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Thu May 2 2002, 01:26:26
!
#version 5.5(14)
!
!
#system
set system name  Catalyst6500
!
#!
#vtp
set vtp mode transparent
set vlan 1 name default type ethernet mtu 1500 said 100001 state active
set vlan 2 name VLAN0002 type ethernet mtu 1500 said 100002 state active
set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active
set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state active stp ieee
set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active stp ibm
set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state active
mode srb aremaxhop 7 stemaxhop 7
backupcrf off
!
#ip
set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255

set ip route 0.0.0.0/0.0.0.0 10.10.10.1
!
#set boot command
set boot config-register 0x2102
set boot system flash bootflash:cat6000-sup.5-5-14.bin
!
#port channel
set port channel 3/1-2 105
!
# default port status is enable
!
!
#module 1 empty
!
#module 2 : 2-port 1000BaseX Supervisor
!
#module 3 : 48-port 10/100BaseTX Ethernet
set vlan 2    3/4
set port disable    3/5

set port speed      3/1-2  100
set port duplex     3/1-2  full
set trunk 3/1  nonegotiate isl 1-1005
set trunk 3/2  nonegotiate isl 1-1005

!--- If IEEE 802.1Q is configured, you will see this output instead:
set trunk 3/1  nonegotiate dot1q 1-1005
set trunk 3/2  nonegotiate dot1q 1-1005


set port channel 3/1-2 mode on
!
#module 4 : 24-port 100BaseFX MM Ethernet
!
#module 5 empty
!
#module 6 empty
!
#module 15 empty
!
#module 16 empty
end

Cisco 7500 ルータ

!--- Configure a port-channel interface to enable FEC.

7500# configure terminal

 Enter configuration commands, one per line. End with CNTL/Z.

7500(config)# interface port-channel 1

01:34:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
          state to down

!--- Configure full-duplex to match the duplex setting on the Catalyst switch side.

7500(config-if)# full-duplex

7500(config-if)# exit

!--- If you are using ISL trunking, configure two port-channel sub-interfaces and issue the
!--- encapsulation isl <VLAN> command to enable ISL trunking.
!--- Configure IP addresses for InterVLAN routing.

7500(config)# interface port-channel 1.1

7500(config-subif)# encapsulation isl 1

7500(config-subif)# ip address 10.10.10.1 255.255.255.0

7500(config-subif)# exit

7500(config)# interface port-channel 1.2

7500(config-subif)# encapsulation isl 2

7500(config-subif)# ip address 10.10.11.1 255.255.255.0

7500(config-subif)# exit

!--- If you are using 802.1Q trunking, issue the encapsulation dot1Q <vlan> native
!--- command to configure two port-channel sub-interfaces and enable 802.1Q trunking.
!--- Configure the IP addresses for InterVLAN routing.

!--- Note: The encapsulation dot1Q 1 native command was added in Cisco IOS Software
!--- Release 12.1(3)T. If you are using an earlier version of Cisco IOS, see the
!--- Cisco 7500 802.1Q Configuration for Cisco IOS Software Releases Earlier than 12.1(3)T
!--- section of this document, to configure 802.1Q trunking on the router.




!--- Ensure that the native VLAN (default is VLAN 1) matches across the link. For more
!--- information about the native VLAN and 802.1Q trunking, refer to Trunking Between
!--- Catalyst 4500/4000, 5500/5000, and 6500/6000 Series Switches Using 802.1Q
!--- Encapsulation with Cisco CatOS System Software.

7500(config)# interface port-channel 1.1

7500(config-subif)# encapsulation dot1Q 1 native

7500(config-subif)# ip address 10.10.10.1 255.255.255.0

7500(config-subif)# exit

7500(config)# interface port-channel 1.2

7500(config-subif)# encapsulation dot1Q 2

7500(config-subif)# ip address 10.10.11.1 255.255.255.0

7500(config-subif)# exit

!--- Configure the FastEthernet interfaces for speed 100, depending on the port adapter.
!--- Some FastEthernet port adapters can autonegotiate speed (10 or 100) and duplex (half
!--- or full). Others are only capable of 100 (half or full).

7500(config)# interface fastethernet 5/1/0

7500(config-if)# speed 100

!--- Issue the channel-group command, to configure the FastEthernet interfaces to be
!--- members of port-channel 1.

7500(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1500.

7500(config-if)# no shut

7500(config-if)#
%Interface MTU set to channel-group MTU 1500.

FastEthernet5/1/0 added as member-1 to port-channel1

01:46:09: %LINK-3-UPDOWN: Interface FastEthernet5/1/0, changed state to up
01:46:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/0,
          changed state to up
01:46:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1,
          changed state to up

Router(config-if)# exit

Router(config)# interface fastethernet 5/1/1

Router(config-if)# speed 100

Router(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1500.

Router(config-if)# no shut

Router(config-if)#
%Interface MTU set to channel-group MTU 1500.

FastEthernet5/1/1 added as member-2 to port-channel1

01:54:52: %LINK-3-UPDOWN: Interface FastEthernet5/1/1, changed state to up
01:54:53: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/1,
          changed state to up

Router(config-if)# exit

!--- Remember to save the configuration.

7500# write memory

Building configuration...
[OK]
7500#

!--- Note: To make this setup work and to successfully ping between Workstation 1 and
!--- Workstation 2, you must ensure that the default gateways on the workstations are setup
!--- properly. For Workstation 1, the default gateway should be 10.10.10.1; and for 
!--- Workstation 2, the default gateway should be 10.10.11.1.

7500# show running-config

Building configuration...

Current configuration : 1593 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service single-slot-reload-enable
!
hostname 7500
!
boot system disk1:rsp-jsv-mz.122-7b.bin
!
ip subnet-zero
!
ip cef
call rsvp-sync
!
!
!
interface Port-channel1
 no ip address
 full-duplex
 hold-queue 300 in
!
interface Port-channel1.1
 encapsulation isl 1
 ip address 10.10.10.1 255.255.255.0
!
interface Port-channel1.2
 encapsulation isl 2
 ip address 10.10.11.1 255.255.255.0

!--- If 802.1Q trunking is configured, you will see this output instead:
interface Port-channel1.1
 encapsulation dot1Q 1 native
 ip address 10.10.10.1 255.255.255.0
!
interface Port-channel1.2
 encapsulation dot1Q 2
 ip address 10.10.11.1 255.255.255.0


!
interface FastEthernet5/1/0
 no ip address
 no ip mroute-cache
 speed 100
 full-duplex
 channel-group 1
!
interface FastEthernet5/1/1
 no ip address
 no ip mroute-cache
 speed 100
 full-duplex
 channel-group 1
!
!
ip classless
no ip http server
ip pim bidir-enable
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

先の Cisco IOS ソフトウェア リリース 12.1(3)T よりのための Cisco 7500 802.1Q 設定
12.1(3)T よりも前のバージョンの Cisoco IOS では、サブインターフェイスで encapsulation dot1Q 1 native コマンドを使用できません。 ただし、上記のとおり、リンク間で本来の VLAN を一致させる必要があることに変わりありません。 ソフトウェア バージョンの 802.1q トランキングを 12.1(3)T より先に設定するために、主要なポートチャネル 1 インターフェイスの VLAN 1 のための IP アドレスを、ない port-channel サブインターフェイス設定して下さい。
 

!--- Configure a port-channel interface to enable FEC.

7500# configure terminal

 Enter configuration commands, one per line. End with CNTL/Z.

7500(config)# interface port-channel 1

01:34:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
          state to down

!--- Configure full-duplex to match the duplex setting on the Catalyst switch side.

7500(config-if)# full-duplex

7500(config-if)# exit

!--- Do not configure an interface port-channel 1.1
!--- Instead, create a port-channel 1 main interface and configure the IP address
!--- for VLAN 1 here.

7500(config)# interface port-channel 1

7500(config-if)# full-duplex

7500(config-if)# ip address 10.10.10.1 255.255.255.0

7500(config-if)# exit

7500(config)#

!--- It is still necessary to create a subinterface for VLAN 2.

7500(config)# interface port-channel 1.2

7500(config-subif)# encapsulation dot1Q 2

7500(config-subif)# ip address 10.10.11.1 255.255.255.0

7500(config-subif)# exit

!--- Configure the FastEthernet interfaces for speed 100, depending on the port adapter.
!--- Some FastEthernet port adapters can autonegotiate speed (10 or 100) and duplex (half
!--- or full). Others are only capable of 100 (half or full).

7500(config)# interface fastethernet 5/1/0

7500(config-if)# speed 100

!--- Issue the channel-group command to configure the FastEthernet interfaces to be
!--- members of port-channel 1.

7500(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1500.

7500(config-if)# no shut

7500(config-if)#
%Interface MTU set to channel-group MTU 1500.

FastEthernet5/1/0 added as member-1 to port-channel1

01:46:09: %LINK-3-UPDOWN: Interface FastEthernet5/1/0, changed state to up
01:46:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/0,
          changed state to up
01:46:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1,
          changed state to up

Router(config-if)# exit

Router(config)# interface fastethernet 5/1/1

Router(config-if)# speed 100

Router(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1500.

Router(config-if)# no shut

Router(config-if)#
%Interface MTU set to channel-group MTU 1500.

FastEthernet5/1/1 added as member-2 to port-channel1

01:54:52: %LINK-3-UPDOWN: Interface FastEthernet5/1/1, changed state to up
01:54:53: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/1,
          changed state to up

Router(config-if)# exit

!--- Remember to save the configuration.

7500# write memory

Building configuration...
[OK]
7500#

!--- Note: Remember also that—in any version of software previous to 12.2 or 12.2T for the
!--- 7000/7500 series—you will have to issue the no ip cef command globally before you
!--- configure 802.1Q trunking on a subinterface. Otherwise, you will see this error
!--- message: 802.1q encapsulation not supported with CEF configured on the interface.
!--- See the Components Used section of this document for more information.

7500# show running-config

Building configuration...

Current configuration : 1593 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 7500
!
!
ip subnet-zero
!
no ip cef
!
!
!
interface Port-channel1
ip address 10.10.10.1 255.255.255.0
 full-duplex
 hold-queue 300 in
!
interface Port-channel1.2
 encapsulation dot1Q 2
 ip address 10.10.11.1 255.255.255.0
!
interface FastEthernet5/1/0
 no ip address
 no ip mroute-cache
 speed 100
 full-duplex
 channel-group 1
!
interface FastEthernet5/1/1
 no ip address
 no ip mroute-cache
 speed 100
 full-duplex
 channel-group 1
!
!
ip classless
no ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

7500#

確認

ここでは、設定が正常に動作していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

Catalyst 6500 の show コマンド

  • show interface — sc0 マネージメントインターフェイス IP アドレスおよび VLAN を示します。 この例では、デフォルトVLAN は使用されます(1) VLAN。

    Catalyst6500> (enable) show interface
    
    sl0: flags=51<UP,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63<UP,BROADCAST,RUNNING>
            VLAN 1 inet 10.10.10.2 netmask 255.255.255.0 broadcast 10.10.10.255
    Catalyst6500> (enable)
  • show ip route - デフォルト ゲートウェイを表示します。 この例では、10.10.10.1 は port-channel 1 の(802.1q トランキングのために)または port-channel 1.1 の IP アドレスです(ISL トランキングのために)。

    Catalyst6500> (enable) show ip route
    
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled
    
    The primary gateway: 10.10.10.1
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default          10.10.10.1       0x0          UG      0           sc0
    10.10.10.0       10.10.10.2       0xffffff00   U       8           sc0
    default          default          0xff000000   UH      0           sl0
    Catalyst6500> (enable)
  • show port capabilities mod/port —スイッチング モジュールのハードウェア互換性のクィック ルックを与えます。 この例では、ポート 3/1 (および 3/2)が可能な幹線エンキャプシュレーションがそれサポートする、および他の情報わかります EtherChannel であることが。

    Catalyst6500> (enable) show port capabilities 3/1
    
    Model                    WS-X6248-RJ-45
    Port                     3/1
    Type                     10/100BaseTX
    Speed                    auto,10,100
    Duplex                   half,full
    Trunk encap type         802.1q,ISL
    Trunk mode               on,off,desirable,auto,nonegotiate
    Channel                  yes
    Broadcast suppression    percentage(0-100)
    Flow control             receive-(off,on),send-(off)
    Security                 yes
    Membership               static,dynamic
    Fast start               yes
    QOS scheduling           rx-(1q4t),tx-(2q2t)
    CoS rewrite              yes
    ToS rewrite              DSCP
    UDLD                     yes
    Inline power             no
    AuxiliaryVlan            1..1000,untagged,dot1p,none
    SPAN                     source,destination
    COPS port group          not supported
    Catalyst6500> (enable)
  • show port counters mod は/port — 可能性のある Port エラーのクィック ルックを与えます。 この例では、このポートにまったくエラーが発生していません。 ポートのエラーを経験する場合、詳細についてはスイッチポートとインターフェイス障害のトラブルシューティングを参照して下さい。

    Catalyst6500> (enable) show port counters 3/1
    
    Port  Align-Err  FCS-Err    Xmit-Err   Rcv-Err    UnderSize
    ----- ---------- ---------- ---------- ---------- ---------
     3/1           0          0          0          0         0
    
    Port  Single-Col Multi-Coll Late-Coll  Excess-Col Carri-Sen Runts     Giants
    ----- ---------- ---------- ---------- ---------- --------- --------- ---------
     3/1           0          0          0          0         0         0         -
    
    Last-Time-Cleared
    --------------------------
    Thu May 2 2002, 02:11:55
    Catalyst6500> (enable)
  • show port mod —ポートステータス、VLAN、トランクおよび速度 および デュプレックス 情報を示します。 この例では、ワークステーション 1 のためのアクセス ポートは VLAN 1.にある 3/3 です。 ワークステーション 2 のためののためのアクセス ポートは VLAN 2.ポート 3/1 および 3/2 のトランキングおよび FEC ポートの 3/4 です。

    Catalyst6500> (enable) show port 3
    
    Port  Name                 Status     VLAN       Duplex Speed Type
    ----- -------------------- ---------- ---------- ------ ----- ------------
     3/1                       connected  trunk        full   100 10/100BaseTX
     3/2                       connected  trunk        full   100 10/100BaseTX
     3/3                       connected  1          a-half  a-10 10/100BaseTX
     3/4                       connected  2          a-full a-100 10/100BaseTX
    
    !--- Output suppressed.
    
    
  • どのポートが特定の VLAN に割り当てられるか show vlan —示します。 この例のトランク ポートが正常であるこの出力に(3/1 および 3/2)出て来ないことに注意して下さい。

    Catalyst6500> (enable) show vlan
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    1    default                          active    119     2/1-2
                                                            3/3,3/5-48
                                                            4/1-24
    2    VLAN0002                         active    124     3/4
    
    !--- Output suppressed.
    
    
  • show trunk - トランキング モード、カプセル化のタイプ、許可されている VLAN、およびアクティブな VLAN を表示します。 この例では、VLAN 1(デフォルトで常に許可されアクティブ)および VLAN 2 がトランクに対して現在アクティブな VLAN です。 両方のトランク ポートが VLAN 1 にある点に注意してください。

    Catalyst6500> (enable) show trunk
    
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     3/1      nonegotiate  isl            trunking      1
     3/2      nonegotiate  isl            trunking      1
    
    Port      VLANs allowed on trunk
    --------  ---------------------------------------------------------------------
     3/1      1-1005
     3/2      1-1005
    
    Port      VLANs allowed and active in management domain
    --------  ---------------------------------------------------------------------
     3/1      1-2
     3/2      1-2
    
    Port      VLANs in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     3/1      1-2
     3/2      1-2

    802.1q トランキングに関しては、前のコマンドの出力はこれに変わります:

    Catalyst6500> (enable) show trunk
    
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native VLAN
    --------  -----------  -------------  ------------  -----------
     3/1      nonegotiate  dot1q          trunking      1
     3/2      nonegotiate  dot1q          trunking      1
    
    Port      VLANs allowed on trunk
    --------  ---------------------------------------------------------------------
     3/1      1-1005
     3/2      1-1005
    
    Port      VLANs allowed and active in management domain
    --------  ---------------------------------------------------------------------
     3/1      1-2
     3/2      1-2
    
    Port      VLANs in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     3/1      1-2
     3/2      1-2
    Catalyst6500> (enable)
  • show port channel - Etherchannel の状態を表示します。 この例では、PAgP フレームが送信されることを防ぐべき 2 ポート FEC (ポート 3/1 および 3/2)がある、あります。 また 7500 ルータのリモート ポートチャンネルインターフェイスを表示できます。

    Catalyst6500> (enable)  show port channel
    
    Port  Status     Channel              Admin Ch
                     Mode                 Group Id
    ----- ---------- -------------------- ----- -----
     3/1  connected  on                     105   833
     3/2  connected  on                     105   833
    ----- ---------- -------------------- ----- -----
    
    Port  Device-ID                       Port-ID                   Platform
    ----- ------------------------------- ------------------------- ----------------
    3/1  7500                            Port-channel1.1           cisco RSP4
    3/2  
    ----- ------------------------------- ------------------------- ----------------
    Catalyst6500> (enable)

    802.1q トランキングの FEC に関しては、前のコマンドの出力はこれに変わります:

    Catalyst6500> (enable) show port channel
    
    Port  Status     Channel              Admin Ch
                     Mode                 Group Id
    ----- ---------- -------------------- ----- -----
     3/1   connected  on                    257   769
     3/2   connected  on                    257   769
    ----- ---------- -------------------- ----- -----
    
    Port  Device-ID                       Port-ID                   Platform
    ----- ------------------------------- ------------------------- ----------------
     3/1       7500                            FastEthernet5/1/0         cisco RSP4
     3/2       7500                            FastEthernet5/1/1         cisco RSP4
    ----- ------------------------------- ------------------------- ----------------
    Catalyst6500> (enable)

Ciscoデバイスからの show-tech support コマンドの出力がある場合、潜在的な問題および修正を表示するのに Output Interpreter ツール登録ユーザのみ)を使用できます。

Cisco 7500 ルータの show コマンド

  • show interface port-channel チャネル番号—物理インターフェイスのためのメンバー ステータスを提供します。 この例では、2 ポート FEC は Catalyst 6000 のポート 3/1 および 3/2 と 7500 の interface fastethernet 5/1/0 および 5/1/1 の間で設定されます。 Port-channel 1 は up/up ように示します。

    それは 802.1q トランキングのためのネイティブ VLAN IP アドレスであることをこの場合意味する IP アドレスを設定してもらいます。 Cisco IOS ソフトウェア リリースについては Cisco 7500 802.1Q 設定を詳細についてはこの資料の 12.1(3)T セクションより先に参照して下さい。 出力はまた show interface ポート チャネル 1.2 コマンドからの VLAN 2 802.1Q サブインターフェイスのために、示されています。

    7500# show interface port-channel 1
    
    Port-channel1 is up, line protocol is up
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      Internet address is 10.10.10.1/24
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      Full-duplex, Unknown Speed
      ARP type: ARPA, ARP Timeout 04:00:00
        No. of active members in this channel: 2
            Member 0 : FastEthernet5/1/0
            Member 1 : FastEthernet5/1/1
      Last input 00:00:14, output never, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/300/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue :0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         6720 packets input, 923310 bytes, 0 no buffer
         Received 5010 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 watchdog
         0 input packets with dribble condition detected
         1902 packets output, 573088 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    7500#
    
    7500# show interface port-channel 1.2
    
    Port-channel1.2 is up, line protocol is up
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      Internet address is 10.10.11.1/24
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation 802.1q Virtual LAN, Vlan ID  2.
      ARP type: ARPA, ARP Timeout 04:00:00

    これは ISL トランキングおよび FEC のための出力です:

    7500# show interface port-channel 1
    
    Port-channel1 is up, line protocol is up 
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec, 
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      Full-duplex, Unknown Speed
      ARP type: ARPA, ARP Timeout 04:00:00
        No. of active members in this channel: 2 
            Member 0 : FastEthernet5/1/0
            Member 1 : FastEthernet5/1/1
      Last input 00:00:01, output never, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/300/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue :0/40 (size/max)
      5 minute input rate 0 bits/sec, 1 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         113 packets input, 7278 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 watchdog
         0 input packets with dribble condition detected
      13 packets output, 2264 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    
    7500# show interface port-channel 1.1
    
    Port-channel1.1 is up, line protocol is up
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      Internet address is 10.10.10.1/24
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ISL Virtual LAN, Color 1.
      ARP type: ARPA, ARP Timeout 04:00:00
    
    7500# show interface port-channel 1.2
    
    Port-channel1.2 is up, line protocol is up
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      Internet address is 10.10.11.1/24
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ISL Virtual LAN, Color 2.
      ARP type: ARPA, ARP Timeout 04:00:00
  • どのエラーでもインターフェイスにあるかどうか show interfaces fastethernet スロット/ポートアダプタは/port — ルータの物理インターフェイスのステータスを表示し。 この例では、それは誤りが無いです。

    7500# show interface fastethernet 5/1/0
    
    FastEthernet5/1/0 is up, line protocol is up
      Hardware is cyBus FastEthernet Interface, address is 0001.6490.f8a8
      (bia 0001.6490.f8a8)
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      Full-duplex, 100Mb/s, 100BaseTX/FX
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 1d00h, output 00:00:07, output hang never
      Last clearing of "show interface" counters 1d00h
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue :0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         2929 packets input, 425318 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 watchdog
         0 input packets with dribble condition detected
         12006 packets output, 1539768 bytes, 0 underruns
         0 output errors, 0 collisions, 6 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    7500#

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 23307