音声とユニファイド コミュニケーション : Cisco AS5300 シリーズ ユニバーサル ゲートウェイ

Dialout/EZ でCisco Access Server を使用する方法

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

Tactical Software の DialOut/EZ 製品を使用すると、デスクトップ LAN のユーザはアウトバウンド非同期通信のモデム プールとしてネットワーク アクセス サーバ(NAS)のポートを共有できます。 DialOut/EZ のユーザはデスクトップでもはや専用モデムおよび電話線を必要としませんが、アクセス サーバのダイヤル ポートがデスクトップ コミュニケーション アプリケーションにローカルモデムとして現われるように代りに通信(COM:)ポート リダイレクタ ソフトウェアを使用します。 Windows ユーザは中央 NAS/access サーバによってリモート オンライン サービスにアクセスし、PC からのファクシミリを送信 するためにダイヤルできます。 Cisco IOS か。 NAS で動作するソフトウェア リリースは COMポート 制御プロトコル(RFC 2217)をサポートする必要があります。 会社の Webサイトからの Tactical Software の DialOut/EZ についての詳細をで調べることができます: http://www.tacticalsoftware.comleavingcisco.com

注: DialOut/EZ は Ciscoダイヤルアウト ユーティリティのための置換です。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Tactical Software は Cisco IOS Software release 12.0(9) またはそれ以降が NAS で DialOut/EZ と相互運用するためにインストールされていることを必要とします。

  • Cisco バグ ID CSCds28071 が原因で、Cisco は Cisco IOS ソフトウェア リリース 12.1(8) またはそれ以降を実行することを推奨します。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

インストールおよび設定

Dialout/EZ the Virtual COM Portのための適切なモデムドライバをインストールする

  1. DialOut/EZ をインストールして下さい。

    クライアントワークステーションの完全な DialOut/EZ インストール情報に関しては、Tactical Software の Webサイトのユーザガイドを参照して下さい: DialOut/EZ.

  2. モデムドライバをダウンロードして下さい。

    DialOut/EZ 仮想 な COMポートにそれらに接続されるモデム デバイスがありません。 DialOut/EZ ユーザはモデムのために適切な .inf ファイルを使用する必要があります(仮想 な COMポートでモデムドライバをインストールして下さい)。 MICA、NextPort および Microcom .inf ファイルは Cisco Webサイトからのダウンロード可能です。 他のプラットフォームに関しては規定 された .inf ファイルを使用して下さい。

    モデム タイプ プラットフォーム .inf ファイル
    MICA 3600、AS5200,AS5300,AS5800 mdcsmica.inf
    Nextport AS5350,AS5400 AS5800、AS5850
    Microcom AS5200 mnpv90.inf
    NM xAM 2600、3600 Microcom DeskPorte V.34 FAST
    WICxAM 2600、3600 mdmrock5.inf (または規格 28800 ビット/秒モデム ファイル)

    注: Windows XP に関しては、Cisco は .inf ファイルをはたらかないかもしれません提供しました。 Windows 組み込み .inf ファイルを代りに使用することを試みて下さい。

  3. モデムドライバをインストールして下さい。

    モデムドライバを Windows PC でインストールするために、次のプロシージャを使用して下さい:

    1. Start > Settings > Control Panel > Phone および Modem Options

    2. モデムを選択し、新しいモデムを追加するために追加して下さい

    3. select モデムを検出する; リストからそれを選択しましたり、そして『Next』 をクリック します。

    4. モデムの製造業者およびモデルを選んで下さい。 左のウィンドウで『Cisco』 を選択 することは右側のウィンドウの MICA を表示する。

    5. .inf ファイルが保存される位置に『Have Disk』 を選択 し、参照して下さい。

    6. 選択されたポート オプションでは、EZ ダイヤルアウト インストールの間に選択される COMポートを使用して下さい(たとえば、5) COM。

アクセスサーバの設定

文字モード モデム ダイヤルアウト アプリケーションだけのために必要とされる IOS ソフトウェア コンフィギュレーションはラインコンフィギュレーションの下で(DialOut/EZ とのような)行きます:

line starting_line_number ending_line_number
     modem dtr-active  
     
! -- If the router is for dialin and dialout use "modem inout" instead

     transport input telnet
     
! -- Or transport input all could be used

     escape-character NONE 
     
! -- Due to Bug CSCdv12194 for the AS5350/AS5400.

     rotary 1 
     
! -- Specifies the use of TCP port 7001 in the Dialout/EZ manager 
     ! -- window to dial out rotary 1

外付けモデムが使用される場合、望まれるようにラインコンフィギュレーションの下で RS232 物理層およびフレーム パラメータを追加して下さい:

speed 115200 
    
 ! --  Set to the highest speed supported by the modems

     flowcontrol hardware
     parity even 
     databits 7 
     
! -- Or databits 8

     stopbits 1 
     
! -- Recommended for best throughput

ダイヤルアウト行にコントロール アクセスにほしい場合、ラインコンフィギュレーションモードの次を追加して下さい:

password password

また、認証、許可、アカウンティング(AAA)を設定し、行にリストを下記のものの追加して下さい:

login authentication listname

どのトランクがダイヤルアウト コールのために使用されるか制御したかったら、もたらされる Cisco IOS ソフトウェア リリース 12.1(T) で modem dialout controller コマンドを使用して下さい(現在、AS5300 だけでサポートされて)。 詳細については、アナログ発信のための T1 または E1 インターフェイスの modem dialout controller コマンドを使用した設定を参照して下さい。

ヒント: 時々 DialOut/EZ は IOS software からのパスワード OK メッセージによって混乱できます。 この問題を避けるために、ルータの AAA を(ローカルかサーバーベース)設定して下さい。 設定 例のためのこの資料の AAA セクションの AS5xxx を参照して下さい。

オプション: また各コールの後でデフォルト 設定にモデムをリセットするために modemcap を設定できます。 ラインコンフィギュレーションの下でコマンド modem autoconfigure type MICA を使用して下さい。 (モデムの種類(MICA、NextPort、Microcom、等)に関係なくすべてのルータに工場出荷時状態 &F)を適用することができる設定 するこの modemcap。 modemcap に関する詳細については、Cisco アクセス サーバの内蔵デジタル アナログモデムのための推奨される modemcap を参照して下さい。

同じアクセス サーバはダイヤルイン、またダイヤルアウト(アプリケーション)に使用することができます。 広範囲の設定 例に関しては DialOut/EZ ユーティリティ用のセクション サンプル NAS コンフィギュレーションを参照して下さい。

DialOut/EZ のトラブルシューティング

DialOut/EZ 関連 問題を解決するために下記に説明されている方式に続いて下さい:

  1. NAS execプロンプトからの NAS モデムに Telnet を反転させて下さい。 良い応答を返す必要がある AT コマンドの発行によってモデムに接続できます確認して下さい。 モデムに接続できる場合 atdt ######## コマンドを使用してリモートデバイスの数にダイヤルすることを試みて下さい。 接続が正常である場合、ルータコンフィギュレーションは正しく、ハードウェアは正しくはたらいています。

    注: バイナリ Telnet TCPポート 範囲を使用して下さい: ロータリー ダイヤルアウトのために特定の行を、か 7000+ rotary_number 使用する 6000+line。

    下記の例は成功コールを示します:

    maui-nas-03#telnet 172.22.53.150 7001
    
    ! -- Reverse Telnet to an up/up interface on the router 
    ! -- and use port 7000+rotary
    
    Trying 172.22.53.150, 7001 ... Open
    User Access Verification
    !
    Username: admin
    Password:
    at
    OK
    
    ! -- Modem is responding
    
    atdt 81560
    
    ! -- Dial number 81560 to connect to remote device. 
    ! -- This may take up to 30 seconds.
    
    CONNECT 33600 /V.42/V.42bis
    
    ! -- Call is connected to the remote device.
    
      User Access Verification
    
    ! -- Username prompt by remote device
    
      Username: cisco
      Password: maui-nas-01>

    逆 Telnet が modem at コマンド モードに達しない場合、NAS は不適切に設定されています。 次の項目をチェックします。

    1. Telnet で接続している IP アドレス LAN の PC ホストから up/up および ping 可能 なべきであるにインターフェイス。 ルータ インターフェイスを ping できなかったらルーティング関連の問題のための LAN を解決して下さい。

    2. モデム回線はモデム inout (ダイヤルイン/ダイヤルアウトのために)または modem dtr-active があるはずです(ダイヤルアウトだけのために)。

    3. 行は transport input telnetトランスポート入力すべてで設定する必要があります。

    成功するが、マニュアルコールが失敗した逆 Telnet が modem at コマンド モードに達することに場合、問題は Telco またはリモートルータ問題である可能性があります。 リモートルータを、行解決し、更に続行する前に接続を再検査して下さい。 詳細についてはダイヤル テクノロジーの接続性のトラブルシューティング - 非 DDR コールアウトを参照して下さい。

  2. LAN の PC ホストからの逆 Telnet を試みて下さい。 Open ウィンドウ ハイパーターミナル(か Windows Telnet)および DialOut/EZ のために使用しているポートおよびルータの IP アドレスへの Telnet (たとえば 7001)。 モデムおよびダイヤルアウトに達することができる場合 NAS からのダイヤルアウトがはたらいていることを)間違って何も LAN (以前にと確認しましたありません。

  3. 逆 Telnet が modem at コマンド モードに達しない場合、NAS は不適切に設定されていますまたは IPネットワークははたらいていません。 次の項目をチェックします。

    1. Telnet で接続している IP アドレス LAN の PC ホストから up/up および ping 可能 なべきであるにインターフェイス。 ルータ インターフェイスを ping できなかったらルーティング関連の問題のための LAN を解決して下さい。

    2. Telnet接続をブロックしている access-class がないはずです。

    次のスクリーンキャプチャーは成功したハイパーターミナルセッションを示します:

    hyperterm1.gif

    hyperterm2.gif

    注: Microsoft Windows Telnet クライアントを使用し、AAA が NAS で設定されれば、ウィンドウ Telnetログインは失敗するかもしれません。 この失敗はアプリケーション設定によって引き起こされ、パスワードを入力する不可能によって特徴付けられます従ってログオンは失敗します。 このセッションの Telnetアプリケーション設定を訂正するために、ホスト PC で下記のプロシージャに従って下さい:

    1. Start > Run >telnet は、『OK』 をクリック します。

    2. unset crlf コマンドをタイプして下さい。 (これはキャリッジリターンを <CR><LF> よりもむしろ Telnet <CR><NUL> として送信 するようにします。)

    3. モデムに Telnet で接続するのに開いた <ip_address> <port> を使用して下さい。

    4. ハイパーターミナル例が上で示す通りモデムに今接続する必要があり、atdt を使用して今手動 ダイヤルを始めることができます。 次のスクリーンキャプチャーは例です:

      wintelnet1.gif

  4. 直接 DialOut/EZ によって NAS モデムに接続するべき使用 ハイパーターミナルは COMポートをエミュレートしました。 詳細については http://www.tacticalsoftware.com のインストールのleavingcisco.com DialOut/EZ User Guide の 章を参照して下さい。 これは DialOut/EZ によってエミュレートされる COMポートが機能していることを確認します。

    DialOut/EZ によってエミュレートされる COMポート上のハイパーターミナルがはたらかない場合、問題は IOS の DialOut/EZ 通信に独特よう。 次の情報を収集する。

    • これらのデバッグは NAS が Telnet接続を受信したかどうか確認します。

      debug telnet 
      debug modem
      
    • DialOut/EZ トレース ログ: Trace ウィンドウ メニュー オプションを選択することは有効に されて Trace ウィンドウ タブが DialOut/EZ ポートモニタ 3.0 ウィンドウを、開きます。 トレースし始めるためにこのウィンドウの下部ので Enable Trace チェックボックスをチェックして下さい。 更なる分析のためのログを保存することを確かめて下さい。 詳細については Tactical Software の Webサイトのユーザガイドのトラブルシューティングについて記述されている個所を参照して下さい。

  5. DialOut/EZ はモデムに接続できることを確認したので次にエンド アプリケーション 開始を接続持って下さい。 エンド アプリケーションが DialOut/EZ 接続を使用して互いに話すことができない場合問題はエンド アプリケーションに独特である可能性があります。 DialOut/EZ トレース ログはこの問題の解決で役立つかもしれません。 また Windows TAPI モデムログおよびアプリケーションから利用可能 なまたロギングをつけて下さい。 次のマイクロソフトの記事のためのleavingcisco.com Microsoft の Webサイトを参照して下さい: 詳細については Modemlog.txt ファイル(Q142730)を作成し使用する方法。

    オペレーションが望まれるようにそれでもはたらかない場合、IOS デバッグ、DialOut/EZ トレース ログおよび(該当する場合) Windows モデムログを収集し、アプリケーションがどこに失敗しているか判別するために結果を分析して下さい。

    Tactical Software を参照して下さい: その他の情報leavingcisco.com のための FAQ

DialOut/EZ ユーティリティ用のNAS 設定例

AS25xx 、NM xAM 、WIC xAM

以下は外部アナログモデムを持つルータのためのサンプル コンフィギュレーション ファイル、Cisco AS2509 のような、Cisco AS2510、Cisco AS2511、または 26xx および 36xx シリーズ ルータのような内部 アナログモデム(NM xAM および WICxAM)を持つ Cisco AS2512 アクセス サーバ、またルータです。

下記の例は着信 および 発信コールが可能なルータを示します。 ルータが送信 使用だけのためである場合、必要のラインコンフィギュレーションはすべてです。

interface Group-Async1
   
! -- Group-Async interface used for dialin calls
   ! -- This is not used for dialout

    ip unnumbered Ethernet0
    no ip mroute-cache
    encapsulation ppp
    no ip route-cache
    async default routing
    async dynamic address
    async mode interactive
    peer default ip address pool local
    dialer in-band
    no cdp enable
    ppp authentication chap
    group-range 1 8
    
! -- Range of lines include 1 through 8
    ! -- Modems 1 through 8 can now be used for incoming or outgoing calls

   !
   line 1 8
    
! -- Line configuration used for Dialout/EZ

    modem InOut
    
! -- Modem can be used for dialing and dialout
    ! -- If the line is used for dialout only use "modem dtr-active"

    rotary 1
    
! -- The lines are placed in a rotary
    ! -- They are accessed by Dialout EZ using port (7000 + rotary)=7001

    transport preferred telnet
    transport input all
    
! -- You could also use transport input telnet instead

    rxspeed 115200
    txspeed 115200
    
! -- Speed for external modems
    ! -- This is not needed for internal analog modems (NM-xAM, WIC-xAM)
 
    flowcontrol hardware
    
! -- Flowcontrol for external modems
    ! -- This is not needed for internal analog modems (NM-xAM, WIC-xAM

AAA のないAS5xxx

以下は AAA なしに Cisco AS5xxx シリーズ アクセス サーバのためのサンプル コンフィギュレーション ファイルです。

この例は着信コールを受け入れるおよびアウトバウンドコールを作るルータを示したものです:

controller T1 0
   
! -- T1 interface used for incoming and outgoing calls

    framing esf
    clock source line primary
    linecode b8zs
    pri-group timeslots 1-24
   !
   interface Serial0:23
   
! -- D-channel configuration for T1 0
   ! -- This configuration is only needed for incoming calls

    ip address 10.15.2.80 255.255.255.0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no keepalive
    dialer idle-timeout 400
    dialer map ip 10.15.2.60 6661210
    dialer-group 1
    isdn incoming-voice modem
    
! -- Incoming analog calls will be switched to the modems

    peer default ip address pool setup_pool
    no fair-queue
    no cdp enable
    ppp authentication chap
    ppp multilink
   !
   interface Group-Async1
   
! -- Group-async configuration for incoming calls
   ! -- This configuration is not used for outgoing calls

    ip unnumbered Ethernet0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    async dynamic address
    async dynamic routing
    async mode interactive
    peer default ip address pool setup_pool
    ppp authentication chap pap
    group-range 1 48
    
! -- Range of lines include 1 through 48
    ! -- Modems 1 through 48 can now be used for incoming or outgoing calls

   !
   line 1 48
   
! -- Line configuration for Dialout/EZ

    exec-timeout 0 0
    autoselect during-login
    autoselect ppp
    
! -- The autoselect commands are used for protocol selection for incoming calls
    ! -- This is not needed if the router only makes outbound calls

    modem InOut
    
! -- Modem can be used for dialing and dialout if the line is used for
    ! -- dialout only use, modem dtr-active transport preferred telnet

    rotary 1
    
! -- The lines are placed in a rotary
    ! -- They are accessed by Dialout EZ using port (7000 + rotary)=7001

    transport input all
    transport input telnet
    
! -- Configure one or both of the above commands

AAA のあるAS5xxx

以下はサーバベースAAA が設定されている Cisco AS5xxx シリーズ アクセス サーバのためのサンプル コンフィギュレーション ファイルです。

次の例は、ダイヤルインおよびダイヤルアウト呼び出しのために設定されるアクセス サーバを示したものです:

aaa new-model
   aaa authentication login default radius
   
! -- Use the radius server for login on the default list
   ! -- for local AAA replace "radius" with "local" 
   ! -- (make sure to configure the username/password locally as well

   aaa authentication ppp ppptac radius
   
! -- Use the radius server for ppp on the list named ppptac
   ! -- This is used for incoming ppp calls and is not used for outgoing 
   ! -- Dialout/EZ calls
   !

   controller T1 0
   
! -- T1 interface used for incoming and outgoing calls

    framing esf
    clock source line primary
    linecode b8zs
    pri-group timeslots 1-24
   !
   interface Serial0:23
   
! -- D-channel configuration for T1 0
   ! -- This configuration is only needed for incoming calls

    ip address 10.15.2.80 255.255.255.0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no keepalive
    dialer idle-timeout 400
    dialer map ip 10.15.2.60 name test 5551210
    dialer-group 1
    isdn incoming-voice modem
    peer default ip address pool setup_pool
    no fair-queue
    no cdp enable
    ppp authentication chap ppptac
    ppp multilink
   !
   !
   interface Group-Async1
   
! -- Group-async configuration for incoming calls
   ! -- This configuration is not used for outgoing calls

    ip unnumbered Ethernet0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    async dynamic address
    async dynamic routing
    async mode interactive
    peer default ip address pool setup_pool
    ppp authentication chap pap ppptac
    
! -- Use list named ppptac for authentication

    group-range 1 48
    
! -- Range of lines include 1 through 48
    ! -- Modems 1 through 48 can now be used for incoming or outgoing calls

   !
   !
   radius-server host 10.4.1.10
   radius-server timeout 20
   radius-server key nas1
   
! -- Radius server configuration

   !
   line 1 48
    
! -- Line configuration for Dialout/EZ as well as dialin calls

    exec-timeout 0 0
    autoselect during-login
    autoselect ppp
    
! -- The autoselect commands are used for protocol selection for incoming calls
    ! -- This is not needed if the router only makes outbound calls

    modem InOut
    
! -- Modem can be used for dialing and dialout
    ! -- If the line is used for dialout only, use modem dtr-active transport 
    ! -- preferred telnet

    rotary 1
    
! -- The lines are placed in a rotary
    ! -- They are accessed by Dialout EZ using port (7000 + rotary)=7001

    transport preferred telnet
    transport input all
    
! -- You could also use transport input telnet instead

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 23241