IP : ダイナミック アドレスの割り当てと解決

DHCP サーバオプションを動的に設定する方法

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2009 年 10 月 29 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

DHCP により、再使用可能な IP アドレスが自動的に DHCP クライアントに割り当てられるようになります。 このドキュメントは、Domain Name System(DNS; ドメイン ネーム システム)や Windows Internet Name Service(WINS; Windows インターネット ネーム サービス)アドレスなどの DHCP オプションを設定する方法を例示して、Customer Premises Equipment(CPE; 宅内装置)の背後にあるローカル クライアントからの DHCP 要求に対応しています。

以前は、ネットワーク管理者は Cisco IOS を手動で設定しなければなりませんでしたか。 この機能と有効に なる各デバイスの DHCPサーバ。 ルータが配置された後に、それぞれの場所に行って修正を加えるので、手間、時間、および費用がかかります。

このため、Cisco IOS DHCP サーバが拡張され、構成情報が自動的にアップデートされるようになりました。 ネットワーク管理者は、1 つ以上の中央集中型 DHCP サーバを設定することで、DHCP プール内の特定の DHCP オプションをアップデートできます。 これらのオプション パラメータを、リモート サーバから中央のサーバに要求したり、リモート サーバにインポートしたりできます。

前提条件

要件

このドキュメントの読者は、次の項目の知識を持っていることが推奨されます。

  • DHCP

  • ドメイン ネーム システム(DNS)

  • Windows インターネット ネーム サービス(WINS)

使用するコンポーネント

この設定は、次のバージョンのソフトウェアとハードウェアを使用して作成およびテストされています。

  • Cisco IOS(R) ソフトウェア リリース 12.2(27)

  • NM-1E で PC とクライアントに接続された 2 台の Cisco 3660 ルータ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

Cisco IOS DHCP サーバの機能は、Cisco IOS ソフトウェア リリース 12.0(1)T で導入されています。 Cisco IOS を必要としますか。 Cisco 1700 シリーズ ルータと併用するためのソフトウェア リリース 12.0(2)T または それ 以降。 DHCP サーバ機能をサポートするルータの詳細は、『Cisco IOS DHCP サーバ』の「サポート対象プラットフォーム」セクションを参照してください。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションは、DNS および WINS 用の DHCP サーバ オプションの設定について説明しています。 これらのサーバ オプションは「中央」のルータで設定され、「リモート」のルータがインポートします。 リモートの PC またはクライアントは、これらのインポートされたオプションを DHCPACK の段階で「リモート」のルータから受け取ります。

注: このドキュメントで使用されているコマンドの詳細を調べるには、DHCP Commands または Command Lookup Tool登録ユーザ専用)を使用してください。一部のツールについて、ゲスト登録のお客様はアクセスできない場合があることをあらかじめご了承ください。

ネットワーク構成図

この文書では、次のダイヤグラムに示すネットワーク設定を使用します。

/image/gif/paws/22920/dhcp_ser_01.gif

設定

このドキュメントでは、次の設定を使用します。

中央のサーバ(3660)
Central# show running-config 
Building configuration...
.
.
.
ip dhcp excluded-address 10.0.0.1 10.0.0.5

!--- This range must not be assigned to DHCP clients.

!
ip dhcp pool Central   
   network 10.0.0.0 255.255.255.0

!--- Specify the network number and mask for DHCP clients.
   
   domain-name Central

!--- Specify the domain name for the client.
   
   dns-server 10.0.0.2

!--- Specify the DNS server you want to respond to DHCP clients who


!--- need to correlate the host name to the IP address.
   
   netbios-name-server 10.0.0.2

!--- Specify the Network Basic Input/Output System (NetBIOS)


!--- WINS server (for Microsoft DHCP clients)
 
!
.
.
!
interface FastEthernet0/0 
 ip address 10.0.0.1 255.255.255.0 
 duplex auto 
 speed auto
!
.
.
!
end

注: Cisco ルータを DHCP サーバとして使用する場合は、DHCP プールごとに 1 つのドメインのみ使用できます。つまり、ルータは、ドメイン名を 2 つ持つクライアントに DHCP リースを送信できません。 ダイナミック プールにスタティック マッピングを混在させることはできません。 混在させると、% This command may not be used with network, origin, vrf, or relay pools というエラー メッセージが表示されます。

リモート サーバ(3660)
Remote# show running-config 
Building configuration...
.
.
.
ip dhcp excluded-address 192.168.1.1

!--- This ip address must not be assigned to DHCP clients.

!
ip dhcp pool Client   
   import all

!--- Import DHCP option parameters into the database.
   
   network 192.168.1.0 255.255.255.248

!--- Specify the network number and mask for DHCP clients.

   default-router 192.168.1.1

!--- Specify the default gateway for DHCP clients.
	
!
.
.
!
interface FastEthernet0/0 
 ip address dhcp 
 duplex auto 
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.1.1 255.255.255.248
 duplex auto
 speed auto
!
end

service config コマンドは、boot host または boot network コマンドと組み合せて使用します。 service config コマンドが入力されて、boot host または boot network コマンドで指定されたファイルから、ルータで自動的にシステム設定が行われるようにされます。

また、service config コマンドは、boot host または boot network コマンドなしでも使用できます。 ホストまたはネットワークのコンフィギュレーション ファイル名を指定しない場合、ルータはデフォルトのコンフィギュレーション ファイルを使用します。 デフォルトのネットワーク コンフィギュレーション ファイルは network-config です。 デフォルトのホスト コンフィギュレーション ファイルは host-config であり、ここで host はルータのホスト名です。 Cisco IOS ソフトウェアでこのホスト名を解決できない場合は、デフォルトのホスト コンフィギュレーション ファイルは router-config になります。

boot host コマンドは、service config コマンドと組み合せて使用します。 service config コマンドがない場合、ルータは boot host コマンドを無視して、NVRAM にある構成情報を使用します。 NVRAM の構成情報が無効であるか、または欠落している場合、service config コマンドが自動的に有効になります。 ネットワーク サーバは、リモート ホストから 2 つのコンフィギュレーション ファイルのロードを試みます。 1 つ目は、ネットワーク内のすべてのネットワーク サーバに適用されるコマンドを含んだネットワーク コンフィギュレーション ファイルです。 boot network コマンドを使用して、ネットワーク コンフィギュレーション ファイルを識別します。 2 つ目は、特定のネットワーク サーバに適用されるコマンドを含んだホスト コンフィギュレーション ファイルです。 boot host コマンドを使用して、ホスト コンフィギュレーション ファイルを識別します。

デフォルトでは TFTP サーバを監視するようになっており、オプション 150 はクライアント側ではなくサーバ側で拒否されるため、オプション 150 が設定されていても、クライアントはブロードキャストを送信します。 TFTP 以外でも、次のケースで 150 オプションが使用可能です。

  • 150 Etherboot

  • 150 GRUB コンフィギュレーション パス名

DHCP オプションは、option code ascii string tftp-server-name コマンドで設定できます。 サーバに名前がなく、IP アドレスだけが設定されている場合は、option code ip ip address コマンドを使用します。

確認

このセクションでは、設定が正しく動作していることを確認するために使用できる情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show ip dhcp import — DHCPサーバ データベースにインポートされるオプション パラメータを表示する。

Remote#show ip dhcp import
Address Pool Name: Client
Domain Name Server(s): 10.0.0.2
NetBIOS Name Server(s): 10.0.0.2
Domain Name Option: Central
Central#show ip dhcp server statistics
Memory usage         13906
Address pools        1
Database agents      1
Automatic bindings   1
Manual bindings      0
Expired bindings     0
Malformed messages   0

Message              Received
BOOTREQUEST          0
DHCPDISCOVER         1
DHCPREQUEST          1
DHCPDECLINE          0
DHCPRELEASE          0
DHCPINFORM           0

Message              Sent
BOOTREPLY            0
DHCPOFFER            1
DHCPACK              1
DHCPNAK              0
Central#show ip dhcp binding
IP address       Client-ID/Hardware address	 	Lease expiration            Type
10.0.0.6         0063.6973.636f.2d30.                   Apr 25 2005 12:30 AM        Automatic
                 3036.302e.3563.6634.
                 2e61.3961.382d.4574.        
                 30

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

トラブルシューティングのためのコマンド

注: debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

Microsoft Windows オペレーティング システムが使用されている PC またはクライアントからの ipconfig /all コマンドの出力には、DHCP によって設定された TCP/IP コンフィギュレーションの値が含まれます。 DHCP オプションleavingcisco.com に関する詳細については RFC 2132 を参照して下さい。

C:\>ipconfig /all 
  
Windows 2000 IP Configuration 
  
  Host Name . . . . . . . . . . . . : PC 
  Primary DNS Suffix . . . . . . .  : cisco.com 
  Node Type . . . . . . . . . . . . : Hybrid 
  IP Routing Enabled. . . . . . . . : No
  WINS Proxy Enabled. . . . . . . . : No 
  DNS Suffix Search List. . . . . . : cisco.com 
                                       
Ethernet adapter Local Area Connection :
	 
  Connection-specific DNS Suffix . : Central 
  Description . . . . . . . . . .  : 3Com EtherLink XL 10/100 PCI TX NIC(3C905B-TX) 
  Physical Address. . . . . . . .  : 00-10-5A-86-5A-CA 
  DHCP Enabled. . . . . . . . . .  : Yes 
  Autoconfiguration Enabled . . .  : Yes 
  IP Address. . . . . . . . . . .  : 192.168.1.2 
  Subnet Mask . . . . . . . . . .  : 255.255.255.248 
  Default Gateway . . . . . . . .  : 192.168.1.1
  DHCP Server . . . . . . . . . .  : 10.0.0.6 
  DNS Servers . . . . . . . . . .  : 10.0.0.2 
  Primary WINS Server . . . . . .  : 10.0.0.2 
  Lease Obtained. . . .  . . . . . : Tuesday, April 26, 2005 6:04:29 PM 
  Lease Expires . . . . . . . .. . : Wednesday, April 27, 2005 6:04:29 PM

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 22920