非同期転送モード(ATM) : IP-ATM 間サービス クラス

ブリッジド ATM PVC での QoS サービス ポリシーと CBWFQ/LLQ の適用

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 5 月 1 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

この文書では、RFC 1483 ブリッジフォーマットの Protocol Data Unit(PDU; プロトコル データ ユニット)を受け入れるよう設定された ATM インターフェイスでの、Class-Based Weighted Fair Queueing(CBWFQ; クラスベース均等化キューイング)や Low Latency Queueing(LLQ; 低遅延キューイング)などの、高度なキューイング オプションの設定例を説明します。

Cisco IOS(R) ソフトウェアサポート RFC1483 ブリッジド アプリケーションのネットワーク外のルーティングのための 3 つのプロトコル(別の IPネットワーク番号に)。 これらのプロトコルは、Integrated Routing and Bridging(IRB)、Route-Bridge Encapsulation(RBE)、ブリッジ型の Permanent Virtual Circuit(PVC; 相手先固定接続)です。 これらすべてのプロトコルにより、ATM PVC はブリッジフォーマットの PDU を受信することができます。 この資料は繋がれた PVC のようなブリッジングプロトコルで設定される PVC を示します。

モジュラ Quality of Service(QOS)Command Line Interface(CLI; コマンドライン インターフェイス)(MQC)を使用して設定されたサービス ポリシーは、QoS メカニズムを、インターフェイス、サブインターフェイス、または VC に適用します。 ブリッジド PVC では、高度なキューイング メカニズムを適用するサービス ポリシーは、RBE でのみサポートされています。 IRB を実行するよう設定された ATM VC のサービス ポリシーは、サポートされていません。 そのような VC で、IPアクセスリスト(ACL)で一致する class-map を定義すれば、このクラスへのパケット一致は発生しないし、すべてのパケットはデフォルト クラスに分類されます。

前提条件

要件

この ドキュメント を 読む人はこれらのトピックのナレッジがあるはずです::

IRB 設定は VC 単位の CBWFQ か LLQ をサポートしません。 設定は ATM 設定上の RBE か PPPoE に CBWFQ か LLQ を設定することを試みる前に移行する必要があります。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • NM-1A-OC3 ATMインターフェイスの Cisco 2620 ルータ

  • Cisco IOS ソフトウェア リリース 12.2(27)

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

QoS サービス ポリシーは、キュー項目数を管理し、トラフィックをマークし、VC 単位でクリティカルでないトラフィックを識別します。 具体的には、このポリシーはこれらの目標を達成します:

  • NBAR を Napster のようなビジネスに重要でない トラフィックを、分類するために使用します。

  • クラスベース の ポリシング 機能をトラフィックを準拠 し、超過し、違反することの優先値をマークするのに使用します。

  • クラス ベース WRED をキュー項目数を管理するために適用します。

    service-policy output コマンドと random-detect-group コマンドは、PVC のレベルでは、互いに排他的で同時には使用できません。 サービス ポリシーの適用によって CBWFQ を有効にした VC に、WRED グループを適用することはできません。 ただし policy-map の中のクラスの random-detect コマンドを設定する場合、両方の機能を加えることができます。

  • set コマンドでクラスベース マーキングをトラフィックタイプによってこれらの IP 優先順位値をマークするために加えます。

優先順位値 トラフィック タイプ
1 、Napster のようなビジネスに重要でない
4 正常なトラフィックに使用するデフォルト
5 Voice over IP(VoIP)などの将来のリアルタイム トラフィック用に予約済。
6 と 7 ネットワーク制御 トラフィック専用

輻輳が発生しうるポイントは、DSL 接続ユーザに情報を供給する ATM VC です。 IP フローは、最大 100 Mbps でファースト イーサネット インターフェイスに着信し、ATM VC から外部に送出されます。 これらは、T1 インターフェイス(1.544 Mbps)のデフォルトの Peak Cell Rate(PCR; ピーク セルレート)を使用して、Unspecified Bit Rate(UBR; 未指定ビット レート)ATM サービス カテゴリ用に設定されています。 従って、ファーストイーサネット インターフェイスに着く QoS サービス ポリシーはトラフィックを示します。 書かれている値は WRED によってそれから IP 優先順位に基づいてサービス クラスを作成し、クラスごとのユニークなドロップする レベルを通して Differentiated Service を提供するために使用されます。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/22820/bridging_cbwfq1.gif

UBR サービス カテゴリの ATM VC は、定義上、最小帯域幅を提供しません。 そのため、CBWFQ または LLQ を適用して UBR VC に帯域幅を保証することはできません。 そうするために、VBR-nrt または ABR のような UBR 以外何かに ATM サービス カテゴリを、変更して下さい。 詳細についてはこれで、ATM バーチャル サーキットのための UBR サービス カテゴリについてを参照して下さい。

設定

このドキュメントでは次の設定を使用しています。

Cisco 2600 ルータ
class-map match-any HTTP-HACKS 

!--- Use the class-map command in global configuration mode
!--- in order to match packets to a specified class.


   match protocol http url "*.ida*"  
   
!--- In order to configure NBAR to match HTTP traffic 
!--- by URL, HOST, or Multi-purpose Internet Mail Extension (MIME)-type, use the
!--- match protocol http command in class-map configuration mode.

   match protocol http url "*cmd.exe*"  
   match protocol http url "*root.exe*"  
   match protocol http url "*Admin.dll*"  
   match protocol http url "*readme.eml*"  
class-map match-any JUNK  
   match protocol napster 
   match protocol fasttrack
class-map match-all IP-PREC-4  match ip precedence 4class-map match-all DEFAULT  
match any
! 
policy-map DSL-OUT-C

!--- Use this command
!--- in order to create or modify a policy map that can be attached to one or more 
!--- interfaces to specify a service policy.

  class IP-PREC-4
   police 32000 250000 5000000 conform-action set-prec-transmit 4 exceed-action
 set-prec-transmit 3 violate-action set-prec-transmit 2
  
!--- Use this command to mark a packet with different quality of service (QoS) 
!--- values based on conformance to the service-level agreement.

! 
policy-map LAN-IN  
  class HTTP-HACKS  
     police 8000 1000 1000 conform-action drop exceed-action
       drop  
  class JUNK  
   set ip precedence 1  
  class DEFAULT  
   set ip precedence 4  
! 
policy-map DSL-OUT  
   class class-default
    
!-- Used to make class-default a single FIFO queue 
!-- inside the WFQ system. 
 
    bandwidth percent 1 
    
    random-detect  
    random-detect exponential-weighting-constant 7  
    random-detect precedence 0   20    40    10  
    random-detect precedence 1   22    40    10 
    random-detect precedence 2   24    40    10 
    random-detect precedence 3   26    40    10 
    random-detect precedence 4   28    40    10  
    random-detect precedence 5   31    40    10  
    random-detect precedence 6   33    40    10  
    random-detect precedence 7   35    40    10  
    random-detect precedence rsvp   37    40    10 
    service-policy DSL-OUT-C
    
!--- In order to use a service policy as a QoS policy within a policy map
!--- (called a hierarchical service policy), use the service-policy command
!--- in policy-map class configuration mode.

! 
interface Loopback1  
  ip address 172.16.1.1 255.255.255.0  
!  
interface FastEthernet0/0  
  ip address 10.1.1.1 255.255.255.192  
  service-policy input LAN-IN  
  
!--- Use this command in order to attach a policy map to an input interface
!--- or virtual circuit (VC), or an output interface or VC, to be used as 
!--- the service policy for that interface or VC.

!  
interface ATM1/0  
  no ip address  
  no atm ilmi-keepalive 
!  
interface ATM1/0.4 point-to-point  
  ip unnumbered Loopback1  
  no ip redirects  
  no ip unreachables  
  no ip mroute-cache  
  atm route-bridged ip  
  pvc 1/35  
   service-policy output DSL-OUT  
  ! 
!  
interface ATM1/0.5 point-to-point  
  ip unnumbered Loopback1  
  no ip redirects  
  no ip unreachables  
 no ip mroute-cache  
  atm route-bridged ip 
 
!--- Use in order to configure an interface to use ATM RBE.

  pvc 1/36
   service-policy output DSL-OUT 
!
ip route 172.16.1.2 255.255.255.255 ATM1/0.4
ip route 172.16.1.3 255.255.255.255 ATM1/0.5
end

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show queueing interface atm:インターフェイス上の特定の VC のキューに関する統計情報を表示します。 アクティブな「メッセージ交換」の非ゼロ値は IP フローがレイヤ3 キューに入る混雑時間の間に表示する。

    2600# show queueing interface atm1/0.4
            Interface ATM1/0.4 VC 1/35
            Queueing strategy: weighted fair
            Total output drops per VC: 0
            Output queue: 0/512/64/0 (size/max total/threshold/drops)
               Conversations  0/1/64 (active/max active/max total)
               Reserved Conversations 1/1 (allocated/max allocated)
               Available Bandwidth 0 kilobits/sec
  • サービス ポリシーを監視するとき show policy-map interface atm —これらの統計情報をチェックするのにこのコマンドを使用して下さい:

    • 増分することはクラスを一致するパケットの評価します。 これがはたらかない場合、CEF が有効に なること、そしてパケットが CEF スイッチング パスに従っていることを確認して下さい。 パケットが CEF スイッチであるかどうか表示するために show interface stats コマンドを発行して下さい。

    • 「packets」値を「pkts matched」値と比較します。 「pkts matched」値が増加するのは、輻輳が発生している間のみです。 詳細については、show policy-map interface 出力の知識パケットカウンタを参照して下さい。

    • ランダム廃棄の数を訂正します。 " mean queue depth " フィールドの値を監視し、このフィールドが最小 しきい値の上の値に達するかどうか判別します。 WRED は中間キュー項目数が水平な特定の IP 優先順位のための最小 しきい値の上に上がるときパケットを無作為にドロップし始めます。

2600# show policy-map interface atm1/0.4
ATM1/0.4: VC 1/35 -
 Service-policy output: DSL-OUT
 Class-map: class-default (match-any)
     29121 packets, 41550530 bytes
     5 minute offered rate 0 bps, drop rate 0 bps
     Match: any
     Queueing
       Output Queue: Conversation 73
       Bandwidth 1 (%)
       (pkts matched/bytes matched) 59/8894
       (depth/total drops/no-buffer drops) 0/0/0
        exponential weight: 7
        mean queue depth: 0

 class    Transmitted      Random drop   Tail drop    Minimum   Maximum   Mark
          pkts/bytes       pkts/bytes    pkts/bytes   thresh    thresh    prob
 0        15791/22456790       0/0           0/0          20        40    1/10
 1           0/0               0/0           0/0          22        40    1/10
 2         8555/13041140       0/0           0/0          24        40    1/10
 3         3417/5207580        0/0           0/0          26        40    1/10
 4         1358/845020         0/0           0/0          28        40    1/10
 5           0/0               0/0           0/0          31        40    1/10
 6           0/0               0/0           0/0          33        40    1/10
 7           0/0               0/0           0/0          35        40    1/10
 rsvp        0/0               0/0           0/0          37        40    1/10
     Service-policy : DSL-OUT-C
 Class-map: IP-PREC-4 (match-all)
   13330 packets, 19093740 bytes
   5 minute offered rate 0 bps, drop rate 0 bps
   Match: ip precedence 4
   police:
     32000 bps, 250000 limit, 5000000 extended limit
     conformed 1358 packets, 845020 bytes; action: set-prec-transmit 4
     exceeded 3417 packets, 5207580 bytes; action: set-prec-transmit 3
     violated 8555 packets, 13041140 bytes; action: set-prec-transmit 2
     conformed 0 bps, exceed 0 bps, violate 0 bps
 Class-map: class-default (match-any)
   15791 packets, 22456790 bytes
   5 minute offered rate 0 bps, drop rate 0 bps
   Match: any 

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連情報


Document ID: 22820