WAN : フレーム リレー

Distributed Traffic Shaping 設定例

2013 年 2 月 10 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2008 年 1 月 24 日) | 英語版 (2005 年 6 月 1 日) | フィードバック


目次


概要

このドキュメントでは Distributed Traffic Shaping(DTS)を説明しており、現在利用可能な情報が多数統合されています。

トラフィック シェーピング(TS)により、特定のインターフェイスでトラフィック フローを制御するメカニズムが提供されます。  「分散」TS は、Cisco 7500 や 12000 シリーズ インターネット ルータのようなハイエンド プラットフォーム固有の機能です。  これらのプラットフォームには、メイン プロセッサ(Route Switch Processor(RSP; ルータ スイッチ プロセッサ) または Gigabit Route Processor(GRP; ギガビット ルート プロセッサ))から、個々のインターフェイス プロセッサ(Versatile Interface Processor(VIP; 多用途インターフェイス プロセッサ)または Line Card(LC; ライン カード))にトラフィック シェーピングをオフロードさせる機能があります。  Distributed Cisco Express Forwarding (DCEF)が切り替えの望ましいモードのネットワークでは、VIP の DTS かラインカードはトラフィック・ シェーピングのための論理的な選択です。

DTS でトラフィックをシェーピングする理由

この資料を、多分読めば、トラフィックをなぜの形成したいと思うか既に概念があっています。  分散されたパズルのピースに例えると、きわめて明確なはずです。メイン プロセッサが行う作業を個々のカード プロセッサに分散しています。  シェーピングに関しては、多数のお客様は単にプロバイダーとの契約に基づく回線の保証速度を超えないようにされています。  これによりクラウドでの廃棄が防止され、その結果、プロバイダーがパケットを廃棄した際の TCP/IP による再転送が削減されます。  トラフィックを形成する必要がある一般的 な シナリオは下記に描写されます。  この例では、ブランチ・ オフィスに 128K 回線があるただ場合 T1 比率でトラフィックを転送するセントラルサイトのための必要がありません:

DTS を使用する理由は、他にもたくさんあります。  利点はいろいろ関連 Quality of Service (QoS) 機能性およびいろいろなトラフィック の 種類を渡って帯域幅をできるだけ効率的に使うためにドライブが含まれています。  DTS はインターフェイス レベルでトラフィック・ シェーピングを設定します、サブインターフェイスは、または ATM かフレームリレーパーマネントバーチャルサーキット(PVC)の水平な論理インターフェイス水平になります。

シェーピングにより一連のネットワーク ゴールを達成し、次の基準をキーとすることが可能です。

  • 物理的のか論理インターフェイスのすべてのトラフィック
  • 簡単および拡張 IP ACL(IP アドレス、TCP/UDP ポート、IP 優先順位)によって分類されるトラフィック
  • QoS グループ(Committed Access Rate(CAR)によって内部パケット ラベルが適用されたアップストリーム、または QoS Policy Propagation(QPPB)で分類されるトラフィック)
DTS は平均パケットサイズが 250 バイトのまたはより大きい、時 VIP2-50 をまたはよりよい 8M スタティックRAM (SRAM)と使用するとき OC-3 レートまでサポートする VIP ごとの 200 までの図形キューをサポートし。 通常のトラフィック シェーピング(GTS)とは異なり、DTS では Weighted Fair Queueing(WFQ; 重み付け均等化キューイング)をイネーブルにする必要はありません。 その代り、DTS はシェープキューのために公平キューイングか分散 First In First Out (FIFO; 先入れ先出し)を使用します。

プラットフォーム特有の項目

次の表は、プラットフォームに依存する TS の設定方法を示します。ここでは主に、この機能がハイエンドのプラットフォームで重要であることが示されています。
 
 
12000 シリーズ
7500 シリーズ
7200、3600、2600、およびその他の非 VIP プラットフォーム
サポートされるシェーピング メカニズム
DTS
DTS
GTS かフレームリレーTS
コンフィギュレーション コマンド
ポリシーマップの shape コマンドを使用。
ポリシーマップの shape コマンドを使用。
メイン インターフェイスでの traffic-rate または frame-relay traffic-shaping、および FRTS - map-class 設定コマンドでシェーピング パラメータを指定
Distributed Cisco Express Forwarding(dCEF)の必要の有無
デフォルトは CEF です
必要(show cef linecard コマンドにより確認) 
いいえ

7500 シリーズでの DTS 注記

Cisco 7500 シリーズでは、Frame Relay Traffic Shaping(FRTS; フレーム リレー トラフィック シェーピング)が非分散モードの RSP で実行されるため、現在、frame-relay traffic-shaping コマンドを使用して FRTS を設定する機能はブロックされています。 dCEF と FRTS を使用すると、CEF「パント」隣接関係によりすべてのパケットが RSP でファーストスイッチされますが、これは転送のパフォーマンスを最大化するのに最適とはいえません。

Cisco IOS ® ソフトウェア リリース 12.1(5)T 現在で、QoS ポリシーは VIP の分散モードで動作する必要があります; Route/Switch Processor (RSP)ベースの QoS はもはやサポートされません。 したがって、Cisco 7500 シリーズで VIP インターフェイスに DTS を実装するには、shape コマンドと Modular QoS Command Line Interface(MQC)の他のコマンドを使用する必要があります。

Cisco 7500 シリース以外のプラットフォームで Cisco IOS ソフトウェア リリース 12.1(2)T が Low Latency Queueing(LLQ; 低遅延キューイング)のサポートを導入する一方で、VIP での分散 LLQ(dLLQ)は 12.1(5)T で導入されました。 分散型のバージョンでは、この機能のパフォーマンスが向上しました。 Data-Link Connection Identifier(DLCI; データリンク接続識別子)ごとに一意のサービスポリシーを設定できます。 マップクラスを使用しなくても、サブインターフェイスまたは DLCI に直接 service-policy コマンドを適用できます。 ただし、マップクラスの中の dLLQ を設定することを推奨します。

フレーム リレー インターフェイスに分散 FRF.12(フラグメンテーション)を適用する場合には、マップクラスを定義して、マップクラスの下でサービスポリシーを適用する必要があります。 FRF.12 は Cisco IOS ソフトウェア バージョン 12.0(4)T で導入され、Cisco IOS ソフトウェア バージョン 12 1(2)T からのように Cisco 805、1600、1700、2500、4500、および 4700 のルータ プラットフォームに伸びます。 追加詳細は追加プラットフォームの FRF.12 サポートで利用できます。

Cisco 12000 シリーズ インターネット ルータ DTS 注記

12000 シリーズでは、ファスト スイッチングとプロセス スイッチングはオプションではありません。 送信先プレフィックスがインバウンド・ ラインカード(LC)の表の転送エントリに解決することができない場合パケットは廃棄されます。 隣接関係にマッチするパケットだけが、Gigabit Routing Processor(GRP;ギガビット ルート プロセッサ)にパントされます。 さらに、12000 で、LC CPU は機能のための GRP にパケットをパントしないし、(no ip unreachables コマンドが設定されない限り) LC は到達不能 インターネット制御メッセージ・プロトコル (ICMP)を送信 します。 12000 では、GRP にパントされるトラフィックは、ルータ上のインターフェイスを宛先とするパケットまたはルータを送信元とするパケットだけです。 その他の情報に関しては、エンジンタイプによって QoS 機能を参照して下さい。

DTS の設定

VIP ベースのフレーム リレー インターフェイスに DTS を設定するには、最初の 2 つのステップを使用します(7500 シリーズ)。
  1. 次のコマンドによって、dCEF を有効にします。
  2. router(config)#ip cef distributed
  3. 分散スイッチングでフレームリレー インターフェイスがイネーブルにされていることを確認します。
router(config-if)# interface serial 2/0/0
router(config-if)# ip route-cache distributed
router#show ip interface serial 2/0/0
Serial8/0/0 is up, line protocol is up
  Internet address is 64.0.0.2/24
  Broadcast address is 255.255.255.255
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is disabled
  IP Flow switching is disabled
  IP CEF switching is enabled
  IP Distributed switching is enabled
  IP Fast switching turbo vector
  IP CEF switching with tag imposition turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast, Distributed, CEF
  Router Discovery is disabled
  IP output packet accounting is disabled
  1. 作成トラフィック・ クラスの(必要な)
  2. DTS を使用するトラフィックポリシーの設定(必要な)
  3. トラフィックポリシーを接続し、有効に します DTS を(必要な)
  4. 監視しますおよび管理 DTS (オプションの)の

トラフィック・ クラスの作成

モジュラ QoS CLI を使用して機能をイネーブルにする最初のステップは、トラフィック クラスの作成です。
 

  コマンド 目的
ステップ 1 
Router(config)# class-map [match-any | match-all] class-name

名前と、基準の一部またはすべてが一致して構成するかを指定します。

Modular QoS CLI の情報、およびトラフィック・ クラスを作成する手順に関しては、モジュラー Quality of Service コマンド・ライン・インターフェイス 外観を参照して下さい。

DTS を使用するトラフィックポリシーの設定

DTS をイネーブルにするには、トラフィック ポリシーを設定する必要があります。 ルータに定義されたクラスの数だけ、最大で 256 までトラフィック ポリシーを設定できます。

トラフィック ポリシーを設定するには、policy-map コマンドを使用して、まずグローバル設定モードでトラフィック ポリシー名を指定します。次に、ポリシーマップ設定モードで下の表の設定コマンドを使用して、トラフィック クラス名とトラフィック シェーピングを設定します。

トラフィック ポリシーでポリシーが定義された他のどのクラスとも一致基準が合わない場合、トラフィックはトラフィック ポリシーのデフォルト クラスに誘導されます。
 

  コマンド 目的
ステップ 1 
Router(config)# policy-map 
policy-name

作成するトラフィック ポリシーの名前を指定します。
ステップ 2 
Router(config-pmap)# class class-name 

 
トラフィック ポリシーに含まれる事前定義トラフィック クラスの名前を指定します。 このプロセスの前のステップで、このクラスが定義されています。
ステップ 3 
Router(config-pmap-c)# shape 
<average | peak> <meanrate>[<burst size> [<excess 
burst size>]]
ターゲットの bps レートを指定します。

サービス ポリシーおよび DTS を有効に することを接続します

インターフェイス、サブインターフェイス、またはマップクラスにトラフィック ポリシーを付加して、インターフェイスで DTS をイネーブルにするには、インターフェイス(またはマップクラス)設定モードで次のコマンドを使用します。  dLLQ および FRF.12 のアプリケーションはフレームリレーマップクラスに適用されるサービス ポリシーがあるために強く推奨されます。

フラグメンテーションに関する詳細は「FRF.12 および DTS」を参照してください。
 

コマンド 目的
Router(config-if)# service-policy output policy-name
* APPLY TO FR MAP-CLASS for llq and fragmentation
有効 DTS はインターフェイスかマップクラスに特定のトラフィック ポリシーを接続し。

監視しますおよび DTS の管理

DTS 機能のモニタリングと保守には、必要に応じて EXEC モードで次のコマンドを使用します。

QoS に関する追加監視コマンドに関しては、show policy-map interface を参照して下さい。
 

コマンド 目的
Router# show interface [interface-name] shape

トラフィック・ シェーピングの詳細ステータスを表示する。
Router# show policy policy-name

特定のトラフィック ポリシーを構成するすべてのクラスの設定を表示します。
Router# show policy policy-name class class-name

特定のトラフィック ポリシーの特定のクラスの設定を表示します。

設定例

メインインターフェイスの DTS
インターフェイス pos1/0/0 で出かける次の例では、トラフィックは 10Mbits/sec の比率で形成されます。
router(config)# class-map class-interface-all

router(config-cmap)# match any

router(config-cmap)# exit

router(config)# policy-map DTS-interface-all-action
router(config-pmap)# class class-interface-all

router(config-pmap-c)# shape average 10000000 
router(config-pmap-c)# exit

router(config)# interface pos1/0/0

router(config-if)# service-policy output DTS-interface-all-action

メインインターフェイスのクラス・ ベース DTS

次の例では、2 つのクラスは作成され、一致条件はアクセスリスト番号に基づいて定義されます。 インターフェイス fdi4/0/0 から出力され、アクセス リスト 10 の基準に一致するトラフィックが 16 Mbps にシェーピングされます。 アクセス リスト 20 の基準に一致するトラフィックが 8 Mbps にシェーピングされます。

注: 次の IP アドレスは単なる例です。

router(config)# access-list 10 permit 171.69.0.0

router(config)# access-list 20 permit 192.168.0.0

router(config)# class-map class1

router(config-cmap)# match access-group 10

router(config-cmap)# exit

router(config)# class-map class2

router(config-cmap)# match access-group 20

router(config-cmap)# exit

router(config)# policy-map DTS-interface-class-action
router(config-pmap)# class class1

router(config-pmap-c)# shape average 16000000

router(config-pmap-c)# exit

router(config-pmap)# class class2

router(config-pmap-c)# shape average 8000000

router(config-pmap-c)# exit

router(config-pmap)# interface fd4/0/0

router(config-if)# service-policy output DTS-interface-class-action
追加設定例』を参照してください。

問題を識別するツール

フレームリレー カプセル化で設定される VIPインターフェイスはバス エラーとインターフェイスがトラフィックを通過させている間サービス ポリシーを適用している場合クラッシュするかもしれません。 この問題は Cisco IOS ソフトウェアのさまざまなバージョンで解決されています(Cisco Bug ID CSCdt88568)。 このに関する詳細については ddts および追加バグは、Cisco TACツールBug Toolkit を参照します。

ツール情報

その他のリソースについては、シスコの「アクセスダイヤル テクノロジー用の TAC ツール」を参照してください。

関連情報

関連トピック

その他の文書



Document ID: 22600