WAN : フレーム リレー

分散トラフィック シェーピングの設定例

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2014 年 2 月 19 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは Distributed Traffic Shaping(DTS)を説明しており、現在利用可能な情報が多数統合されています。

トラフィック シェーピング(TS)により、特定のインターフェイスでトラフィック フローを制御するメカニズムが提供されます。 「分散」TS は、Cisco 7500 や 12000 シリーズ インターネット ルータのようなハイエンド プラットフォーム固有の機能です。 これらのプラットフォームには、メイン プロセッサ(Route Switch Processor(RSP)または Gigabit Route Processor(GRP))から、個々のインターフェイス プロセッサ(Versatile Interface Processor(VIP)またはラインカード(LC))にトラフィック シェーピングをオフロードさせる機能があります。 分散型シスコ エクスプレス フォワーディング(dCEF)がスイッチングの推奨モードになっているネットワークでは、DTS やラインカードでの VIP がトラフィック シェーピングの論理的選択になります。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

DTS でトラフィックをシェーピングする理由

このドキュメントをお読みの方には、トラフィックをシェーピングする理由がすでに存在することでしょう。 分散されたパズルのピースに例えると、きわめて明確なはずです。メイン プロセッサが行う作業を個々のカード プロセッサに分散しています。 シェーピングに関しては、多数のお客様は単にプロバイダーとの契約に基づく回線の保証速度を超えないようにされています。 これによりクラウドでのドロップが防止され、その結果、プロバイダーがパケットを廃棄した際の TCP/IP による再送信が削減されます。 トラフィックのシェーピングが必要となる一般的なシナリオを次に示します。 この例では、ブランチ オフィスに 128K 回線だけがある場合、セントラル サイトでは T1 レートでトラフィックを転送する必要はありません。

dts-config-01.gif

DTS を使用する理由は、他にもたくさんあります。 利点には、関連の Quality of Service(QoS)機能の分類、多様なタイプのトラフィックに渡って帯域幅をできるだけ効率的に使用するためのドライブが含まれます。 DTS でのトラフィック シェーピングの設定は、インターフェイス レベル、サブインターフェイス レベル、または ATM やフレーム リレー相手先固定接続(PVC)の論理インターフェイス レベルで行われます。

シェーピングにより一連のネットワーク ゴールを達成し、次の基準をキーとすることが可能です。

  • 物理または論理インターフェイスでのトラフィックすべて

  • 簡単および拡張 IP アクセス コントロール リスト(ACL)(IP アドレス、TCP/UDP ポート、IP プレシデンス)によって分類されるトラフィック

  • QoS グループ(専用アクセス レート(CAR)によって内部パケット ラベルが適用されたアップストリーム、または QoS Policy Propagation(QPPB)で分類されるトラフィック)

DTS は、平均パケット サイズが 250 バイト以上で 8M のスタティック RAM(SRAM)装備の VIP2-50 以上が使用されている場合、OC-3 レートまでをサポートしながら、VIP あたり最大で 200 のシェープ キューをサポートします。 通常のトラフィック シェーピング(GTS)とは異なり、DTS では重み付け均等化キューイング(WFQ)をイネーブルにする必要はありません。 その代わり、DTS はシェーピングされたキューに均等化キューイングまたは分散ファーストイン ファーストアウト(FIFO)を使用します。

プラットフォーム特有の項目

次の表は、プラットフォームによって異なる TS の設定方法を示します。主に、この機能がハイエンド プラットフォームで重要であることが示されています。

  12000 シリーズ 7500 シリーズ 7200、3600、2600、およびその他の非 VIP プラットフォーム
サポートされるシェーピング メカニズム DTS DTS GTS またはフレーム リレー TS
コンフィギュレーション コマンド ポリシーマップでの shape コマンド ポリシーマップでの shape コマンド メイン インターフェイスでの traffic-rate または frame-relay traffic-shaping、および FRTS - map-class コンフィギュレーション コマンドでシェーピング パラメータを指定
分散型シスコ エクスプレス フォワーディング(dCEF)の必要の有無 デフォルト値は CEF です 必要(show cef linecard コマンドにより確認) いいえ

7500 シリーズでの DTS 注記

Cisco 7500 シリーズでは、フレーム リレー トラフィック シェーピング(FRTS)が非分散モードの RSP で実行されるため、現在、frame-relay traffic-shaping コマンドを使用して FRTS を設定する機能はブロックされています。 dCEF と FRTS を使用すると、CEF「パント」隣接関係によりすべてのパケットが RSP で高速スイッチされますが、これは転送のパフォーマンスを最大化するのに最適とはいえません。

Cisco IOS 現在か。 ソフトウェア リリース 12.1(5)T は VIP の分散モードで、QoS ポリシー動作する必要があります; Route/Switch Processor(RSP)ベースの QoS はサポートされなくなりました。 したがって、Cisco 7500 シリーズで VIP インターフェイスに DTS を実装するには、shape コマンドとモジュラ QoS コマンドライン インターフェイス(MQC)の他のコマンドを使用する必要があります。

Cisco 7500 シリーズ以外のプラットフォームで Cisco IOS ソフトウェア リリース 12.1(2)T が低遅延キューイング(LLQ)のサポートを導入する一方で、VIP での分散 LLQ(dLLQ)は 12.1(5)T で導入されました。 分散型のバージョンでは、この機能のパフォーマンスが向上しました。 データ リンク接続識別子(DLCI)ごとに一意のサービス ポリシーを設定できます。 マップクラスを使用しなくても、サブインターフェイスまたは DLCI に直接 service-policy コマンドを適用できます。 ただし、Cisco では、マップクラス内に dLLQ を設定することを推奨します。

フレーム リレー インターフェイスに分散 FRF.12(フラグメンテーション)を適用する場合には、マップクラスを定義して、マップクラスの下でサービスポリシーを適用する必要があります。 FRF.12 は Cisco IOS ソフトウェア バージョン 12.0(4)T で導入され、Cisco IOS ソフトウェア バージョン 12 1(2)T からは Cisco 805、1600、1700、2500、4500、および 4700 ルータ プラットフォームに拡大されています。 詳細については、『追加プラットフォームでの FRF.12 のサポート』を参照してください。

12000 シリーズ インターネット ルータの DTS の注意事項

12000 シリーズでは、高速スイッチングとプロセス スイッチングはオプションではありません。 宛先プレフィックスを、着信ラインカード(LC)テーブル内の転送エントリに解決できない場合、パケットはドロップされます。 隣接関係に一致するパケットだけが、Gigabit Routing Processor(GRP)にパントされます。 さらに 12000 では、LC CPU は機能用に GRP へのパケットのパントは行わず、LC から Internet Control Message Protocol(ICMP)到達不能メッセージが送信されます(no ip unreachables コマンドが設定されていない場合に限る)。 12000 では、GRP にパントされるトラフィックは、ルータのインターフェイスを宛先とするパケットまたはルータを送信元とするパケットだけです。 詳細については、『12000 シリーズ インターネット ルータでは、どのような Quality of Service(QoS)機能を利用できますか』を参照してください。

設定

VIP ベースのフレーム リレー インターフェイスに DTS を設定するには、最初の 2 つのステップを使用します(7500 シリーズ)。

  1. dCEF を有効にするには、次のコマンドを使用します。

    router(config)#ip cef distributed
    
  2. 分散スイッチングでフレーム リレー インターフェイスがイネーブルにされていることを確認します。

    router(config-if)#interface serial 2/0/0
    router(config-if)#ip route-cache distributed
    router#show ip interface serial 2/0/0
    Serial8/0/0 is up, line protocol is up
      Internet address is 64.0.0.2/24
      Broadcast address is 255.255.255.255
      ICMP redirects are always sent
      ICMP unreachables are always sent
      ICMP mask replies are never sent
      IP fast switching is enabled
      IP fast switching on the same interface is disabled
      IP Flow switching is disabled
      IP CEF switching is enabled
      IP Distributed switching is enabled
      IP Fast switching turbo vector
      IP CEF switching with tag imposition turbo vector
      IP multicast fast switching is enabled
      IP multicast distributed fast switching is disabled
      IP route-cache flags are Fast, Distributed, CEF
      Router Discovery is disabled
      IP output packet accounting is disabled
  3. トラフィック クラスを作成します。 (必須)

  4. DTS のトラフィック ポリシーを設定します。 (必須)

  5. トラフィック ポリシーを接続し、DTS をイネーブルにします。 (必須)

  6. DTS をモニタおよび保守します。 (オプション)

注: このドキュメントで使用されているコマンドの詳細を調べるには、コマンド検索ツール登録ユーザ専用)を使用してください。

トラフィック クラスの作成

Modular QoS CLI を使用して機能を有効にする最初のステップは、トラフィック クラスの作成です。

Router(config)#class-map [match-any | match-all] class-name:名前と、一部の基準またはすべての基準のいずれが一致する必要があるのかを指定します。

Modular QoS CLI に関する情報、およびトラフィック クラスを作成する手順は『モジュラ Quality of Service コマンドライン インターフェイス(CLI)の概要』を参照してください。

DTS のトラフィック ポリシーの設定

DTS をイネーブルにするには、トラフィック ポリシーを設定する必要があります。 ルータに定義されたクラスの数だけ、最大で 256 までトラフィック ポリシーを設定できます。

トラフィック ポリシーを設定するには、policy-map コマンドを使用して、まずグローバル コンフィギュレーション モードでトラフィック ポリシー名を指定します。次に、class および shape コンフィギュレーション コマンドを使用して、トラフィック クラス名とトラフィック シェーピングを設定します。

  1. Router(config)#policy-map policy-name:作成するトラフィック ポリシーの名前を指定します。

  2. Router(config-pmap)#class class-name:トラフィック ポリシーに含まれる事前定義済みのトラフィック クラスの名前を指定します。 このプロセスの前のステップで、このクラスが定義されています。

  3. Router(config-pmap-c)#shape {average | peak} cir [bc] [be]:平均またはピーク レート トラフィック シェーピングを指定します。

トラフィック ポリシーでポリシーが定義された他のどのクラスとも一致基準が合わない場合、トラフィックはトラフィック ポリシーのデフォルト クラスに誘導されます。

トラフィック ポリシーを接続し、DTS をイネーブルにする

インターフェイス、サブインターフェイス、またはマップクラスにトラフィック ポリシーを付加して、インターフェイスで DTS をイネーブルにするには、インターフェイス(またはマップクラス)コンフィギュレーション モードで次のコマンドを使用します。

  • Router(config-if)#service-policy output policy-name:DTS をイネーブルにして、インターフェイスまたはマップクラスに指定のトラフィック ポリシーを付加します。

注: dLLQ および FRF.12 のアプリケーションでは、サービス ポリシーをフレーム リレー マップクラスに適用することを強くお勧めします。

フラグメンテーションに関する情報については、『Cisco 7500 シリーズでの分散型 QoS を使用したフレーム リレー トラフィック シェーピング』を参照してください。

DTS のモニタと保守

DTS 機能をモニタおよび保守するには、EXEC モードで以下のコマンドを使用します。

  • Router# show interface [interface-name] shape:トラフィック シェーピングの状態を表示します。

  • Router# show policy policy-name:指定されたトラフィックのポリシーを構成するすべてのクラスの設定を表示します。

  • Router# show policy policy-name class class-name:指定したトラフィックのポリシーの指定したクラスの設定を表示します。

QoS モニタ コマンドの詳細については、『show policy-map interface 出力内のパケット カウンタについて』を参照してください。

設定例

メイン インターフェイスの DTS

この例では、インターフェイス pos1/0/0 から出力されるトラフィックが 10 Mbit/秒のレートでシェーピングされます。

router(config)#class-map class-interface-all

router(config-cmap)#match any

router(config-cmap)#exit

router(config)#policy-map DTS-interface-all-action
router(config-pmap)#class class-interface-all

router(config-pmap-c)#shape average 10000000 
router(config-pmap-c)#exit

router(config)#interface pos1/0/0

router(config-if)#service-policy output DTS-interface-all-action

メイン インターフェイスのクラスベース DTS

次の例では、2 つのクラスが作成され、アクセス リスト番号に基づいて一致基準が定義されます。 インターフェイス fd4/0/0 から送信され、アクセス リスト 10 の基準に一致するトラフィックが 16 Mbps にシェーピングされます。 アクセス リスト 20 の基準に一致するトラフィックが 8 Mbps にシェーピングされます。

router(config)#access-list 10 permit 171.69.0.0

router(config)#access-list 20 permit 192.168.0.0

router(config)#class-map class1

router(config-cmap)#match access-group 10

router(config-cmap)#exit

router(config)#class-map class2

router(config-cmap)#match access-group 20

router(config-cmap)#exit

router(config)#policy-map DTS-interface-class-action
router(config-pmap)#class class1

router(config-pmap-c)#shape average 16000000

router(config-pmap-c)#exit

router(config-pmap)#class class2

router(config-pmap-c)#shape average 8000000

router(config-pmap-c)#exit

router(config-pmap)#interface fd4/0/0

router(config-if)#service-policy output DTS-interface-class-action

注: この設定で使用されている IP アドレスは、サンプルにすぎません。

追加の設定例については、「分散型トラフィック シェーピングの設定」を参照してください。

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

フレーム リレー カプセル化が設定されている VIP インターフェイスは、インターフェイスでトラフィックを渡している間にサービス ポリシーを適用するとバス エラーでクラッシュすることがあります。 この問題は Cisco IOS ソフトウェアのさまざまなバージョンで解決されています(Cisco Bug ID CSCdt88568)。 この ddts および追加のバグの詳細については、Cisco サポート ツールおよびリソース、または Bug Toolkit登録ユーザのみ)を参照してください。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 22600