LAN スイッチング : EtherChannel

2900XL/3500XL/2950 シリーズ スイッチと Cisco IOS ソフトウェアが稼働する Catalyst スイッチ間のレイヤ 2 EtherChannel とトランキングの設定

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2006 年 2 月 26 日) | 英語版 (2015 年 10 月 7 日) | フィードバック


目次

DTP

概要

この資料は IEEE 802.1Q/Inter スイッチ リンク(ISL)で設定 例を(L2) Cisco IOS を実行する Cisco Catalyst 2900XL/3500XL 間のトランキングおよびレイヤ2 EtherChannel か Catalyst 2950 シリーズ スイッチおよび Catalyst 6500/6000 スイッチ提供したものですか。 ソフトウェア。 この例の Catalyst 6500/6000 の代わりに、Cisco IOS ソフトウェアが稼働する Catalyst 4500/4000 スイッチを使用することもできます。 このドキュメントでは、スイッチ間にトランキングとチャネリングを設定する際に考慮する必要がある最重要事項を説明しています。 また、設定例も示されています。

このドキュメントでは、各スイッチの 4 つのファースト イーサネット ポートをトランクとして設定し、Fast EtherChannel(FEC)にバンドルしています。 3500 XL の ISL にはトランキング プロトコルが、2950 の例には 802.1Q がそれぞれ使用されています。

注: Catalyst 2950 では、ISL トランキングはサポートされません。 802.1Q トランキングを使用してください。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントでの例を作成するにあたっては、ラボ環境で、次のスイッチをクリアな設定で使用しています。

  • Cisco IOS ソフトウェア リリース 12.0(5)WC2 が稼働する Catalyst 3548 XL スイッチ

  • Cisco IOS ソフトウェア リリース 12.1(6)EA2c が稼働する Catalyst 2950-24 スイッチ

  • Cisco IOS ソフトウェア リリース 12.1(11b)E が稼働するスーパーバイザ エンジン II 搭載の Catalyst 6509 スイッチ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

DTP

デバイス間のトランクについては、スタティックに設定しても、または Dynamic Trunking Protocol(DTP; ダイナミック トランキング プロトコル)を使用して設定してもかまいません。 DTP を使うと、互いに接続する両デバイスは、実際にトランク接続を形成する前に、トランクに関する設定をネゴシエートできます。 設定可能な Cisco IOS ソフトウェア スイッチ ポート(トランキング)モードには、 dynamic(ポートが、access モードまたは trunk モードのどちらかでネゴシエートする)、trunk(無条件でポートがトランキングに設定される)、および access(トランク以外のアクセス ポート)の各モードがあります。 スタティック(非 DTP ネゴシエート)トランクの両側で最もよく使われるモード設定の組み合せは、trunk-trunk です。 ダイナミック(DTP でネゴシエートされた)トランクの場合の一般的な設定は、dynamic - dynamic です。 これ以外の組み合せでも、有効な結果が得られる場合がありますが、このドキュメントでは取り扱いません。 Port Aggregation Protocol(PAgP; ポート集約プロトコル)対応スイッチと PagP 非対応デバイスの間のトランク接続では、トランク モードをオンにする必要があります。

注: ほとんどの Cisco ルータと一部の Catalyst スイッチでは、DTP がサポートされていないため、スタティック トランキングを設定する必要があります。 たとえば、Catalyst XL シリーズ、Catalyst 2948G-L3、Catalyst 4908G-L3、Catalyst 8500 シリーズ、および 2/3/4/7xxx シリーズなどの Cisco ルータは、DTP をサポートしません。そのため、スタティック トランキングの設定が必要となります。

802.1q ネイティブ VLAN に関する考察

802.1Q トランキングでは、トランク経由で送信されるフレームに 4 バイトの 802.1Q タグ フィールドが挿入されます。このフレームには、VLAN に関する情報が含まれています。 dot1q タグは、トランク経由で送信される各フレームに挿入されますが、native VLAN 経由で送信される、タグなしのフレームには挿入されません。 ほとんどの場合、特別な設定要件がない限り(それに関しては、この文書では扱いません)、native VLAN はトランクの両側で一致する必要があります。 ネイティブ VLAN が一致していない場合、スイッチには、ミスマッチを表示する Cisco Discovery Protocol(CDP)メッセージが記録されます。 致命的な不一致でない限り、この設定によって、2 つの異なる native VLAN を 1 つの大きなレイヤ 2(L2)のブロードキャスト ドメイン(VLAN)に効果的に統合できます。 これら 2 つの VLAN では、そのようにブリッジされたネイティブ VLAN について、1 つの共通の Spanning-Tree Protocol(STP; スパニング ツリー プロトコル)トポロジが計算されますが、結果的に、サポートされる STP の最大直径を超えてしまうリスクが伴います。

注: 近隣ルータやサードパーティ デバイスで、すべての VLAN のタグ付けが必要になる特別なケースがあります。 このようなケースの場合は、ダミーの VLAN を作成するという回避策を実行し、その VLAN を native VLAN として設定できます。 この結果、その他すべての必要な VLAN にタグが付けられるので、VLAN はトランクを通じて近隣ルータやサードパーティのデバイスにトラフィックを渡すことができます。 Cisco IOS ソフトウェア リリース 12.1.11bEX、12.1.13E 以降では、Cisco IOS ソフトウェアが稼働する Catalyst 6500 で、ネイティブ VLAN を含むすべての VLAN トラフィックがタグ付けされる 802.1Q トランキング オプションがサポートされます。 vlan dot1q tag native コマンドをグローバル コンフィギュレーション モードで実行してください。 Cisco IOS ソフトウェアが稼働する Catalyst 4500/4000 で vlan dot1q tag native コマンドが使用できるようになったのは、Cisco IOS ソフトウェア リリース 12.2(18)EW 以降です。

PAGP

Gigabit EtherChannel(GEC)および FEC をスイッチ間に設定する場合は、スタティックに設定することも、PAgP を使用してダイナミックに設定することもできます。 PAgP を使用すると、互いに接続する両デバイスは、実際にチャネルが形成される前に、チャネルに関する設定をネゴシエートすることができます。 PAgP チャネル モードには、 desirable(ポートが、自身でチャネル ネゴシエーションを開始する)、auto(デフォルト。ポートはネゴシエーションを開始しないものの、もう一方の側で開始されたネゴシエーションには応答する)、および on(無条件にポートがチャネルに設定され、PAgP フレームは交換されない)の各モードがあります。 PAgP 対応スイッチと PAgP 非対応デバイスの接続にチャネルを形成するには、on モードを指定する必要があります。

スタティック(PAgP 以外でネゴシエートされた)チャネルの両側で最もよく使用されるモードの組み合わせは、on - on です。 ダイナミック(PAgP でネゴシエートされた)チャネルの場合の一般的な設定は、desirable - desirable または desirable - auto のどちらかです。 desirable モードが設定された接続ポートは、チャネリングを開始する前にチャネル ネゴシエーションを実行して、チャネルの動作時にはチャネルを検証し続けます。 この設定では、PAgP によって保護が強化されるので、相互接続する両側のスイッチが PAgP をサポートする場合は推奨される設定です。

注: PAgP には、意図的な設定制限がいくつかあります。 チャネルをネゴシエートするポートには、同じ速度、デュプレックス、トランキング カプセル化、および VLAN が設定されている必要があります。 さらに、特定のプラットフォームでは、リンク間でのチャネルのロード バランシング アルゴリズムが設定可能な場合があります。

注: EtherChannel は、アップするとすぐに、1 つの一意な STP ポートと見なされます。 したがって、ネゴシエートされていないチャネルを設定する際に STP の不一致が発生しないようにするには、次の処理を実行します。

  1. 両側を設定するために、チャネルの全ポートをシャットダウンする。

  2. 両側で設定を実行する。

  3. すべてのポートをもう一度有効にする。

ポートがアップ状態のときに、このようなチャネルを設定しようとすると、一時的な STP の不一致やループが発生する恐れがあります。 この手順を適用できるのは、PAgP が未使用の場合に限られます。

Catalyst 2900XL/3500XL

Catalyst 2900 XL/3500 XL シリーズ スイッチでは、DTP および PAgP がサポートされていないので、スタティック トランクおよびスタティック チャネルを設定する必要があります。 詳細は、上記の注を参照してください。 Catalyst 2900 XL/3500 XL シリーズ スイッチでは、現在、ISL トランキングおよび 802.1Q トランキングのカプセル化がサポートされています。 詳細については、次のドキュメントを参照してください。

ISL は Cisco IOS ソフトウェア リリース 11.2(8)SA4 以降で、802.1Q は Cisco IOS ソフトウェア リリース 11.2(8)SA5 以降でサポートされています。

Cisco IOS ソフトウェア リリース 11.2(8)SA1 または 11.2(8)SA2 が稼働する Catalyst 2900 XL の場合、1 台のスイッチに 4 つの EtherChannel(ポート グループ)を設定でき、グループごとのポート数は無制限です。 リンク間でのチャネルのロード バランシングは、常に送信先アドレス ベースで行われます。 Switched Port Analyzer(SPAN; 交換ポート アナライザ)およびポート セキュリティ機能はサポートされていません。

Cisco IOS ソフトウェア リリース 11.2(8)SA3 以降が稼働する Catalyst 2900 XL、Cisco IOS ソフトウェア リリース 11.2(8)SA6 以降が稼働する Catalyst 3500XL、および Catalyst 2950 の場合、チャネルのリンク間のロード バランシングを、発信元 MAC アドレス ベースまたは送信先 MAC アドレス ベースのどちらかに設定できます。 デフォルトは発信元 MAC アドレス ベースです。 発信元ベースのフォワーディングでは、FEC(ポート グループ)に最大 8 ポートを使用できます。 宛先ベースのフォワーディングでは、ポート グループごとのポート数に制限はありません。 スイッチごとに最大 12 のポート グループを設定でき、さらに発信元ベースと送信先ベースのグループの混在が可能です。 SPAN およびポート セキュリティはサポートされていません。

Catalyst 2950

Catalyst 2950 スイッチは 802.1Q トランキングのみをサポートし、ISL トランキングをサポートしません。 Catalyst 2950 スイッチでは、Cisco IOS ソフトウェア リリース 12.1 で DTP および PAgP によるダイナミック トランキングとチャネル ネゴシエーションがサポートされます。Cisco IOS ソフトウェア リリース 12.0 ではスタティック モードだけがサポートされます。 EtherChannel のロード バランシングでは、発信元 MAC アドレスのフォワーディングまたは宛先 MAC アドレスのフォワーディングのいずれかを使用できます。 ロード バランシング方式を設定するには、port-channel load-balance グローバル設定コマンドを発行します。 これらのスイッチは、チャネルごとに最大 8 個のスイッチ ポートまでサポートします。

Cisco IOS ソフトウェアが稼働する Catalyst 6500

Cisco IOS ソフトウェアが動作する Catalyst 6500 スイッチでは、L2(スイッチポート)およびレイヤ 3(L3)(ルーテッド ポート)の EtherChannel 設定がサポートされます。 Cisco IOS ソフトウェア リリース 12.2(18)SXE 以降が稼動する Catalyst 6500/6000 シリーズ スイッチでは、最大で 128 の EtherChannel がサポートされます(12.2(18)SXE よりも前の Cisco IOS ソフトウェア リリースでサポートされるのは 64 であり、12.1(2)E 以前でサポートされるのは 256 です)。 Catalyst 6000 シリーズ スイッチでは、任意のモジュールの LAN ポートを最大 8 つまで互換性を持つように設定して、EtherChannel を形成できます。ただし、WS-X6816 などの Digital Feature Card(DFC; デジタル フィーチャ カード)搭載のモジュールは例外です。これらのモジュールの場合、現時点では同じ DFC モジュールにあるポートだけしか L2 チャネルに使用できません。 ただし、L3 チャネルの場合は、DFC 搭載の異なるモジュール間での設定が可能です。 Cisco IOS ソフトウェア リリース 12.1(11b)EX 以降が稼働する Catalyst 6500/6000 では、この制限が解除されています。 このドキュメントでは、L2 EtherChannel を設定しています。

Cisco IOS ソフトウェアが稼働する Catalyst 6500/6000 では、port-channel load-balance グローバル設定コマンドを発行すると、任意の発信元、送信先、および発信元と送信先の組み合せで、MAC アドレス、IP アドレス、レイヤ 4(L4)のポート情報のいずれかを使用して、EtherChannel のロード バランシングを行うように設定できます。 デフォルトでは、発信元 IP アドレスと送信先 IP アドレスとの間でハッシュ関数が使用されます。

Catalyst 6500/6000 スイッチでは、ISL トランキングと 802.1Q トランキングの両方のカプセル化と DTP がサポートされています。 ポート機能に関する詳細情報は、show interface interface_id capabilities コマンドを発行すると表示されます。

Catalyst 4000 Cisco IOSソフトウェアを実行する

Cisco IOS ソフトウェアが稼働する Catalyst 4000 スイッチ(スーパーバイザ エンジン III および IV 搭載)では、L2(スイッチポート)および L3(ルーテッド ポート)の EtherChannel 設定がサポートされています。 Catalyst 4000 シリーズのスイッチでは、最大 64 の EtherChannel がサポートされています。 Catalyst 4000 シリーズ スイッチでは、互換性があるように設定されたイーサネット インターフェイスを最大で 8 つ使用して EtherChannel を構成できます。これらのインターフェイスは、どのモジュールにあっても、モジュールをまたがっていても構いません。 各 EtherChannel にあるインターフェイスは、すべて同一の速度である必要があり、さらに L2 インターフェイスまたは L3 インターフェイスのどちらかに設定されている必要があります。

Cisco IOS ソフトウェアが稼働する Catalyst 4000 では、port-channel load-balance グローバル設定コマンドを発行して、任意の発信元、送信先、および発信元と送信先の組み合せで、MAC アドレス、IP アドレス、L4 のポート情報のいずれかを使用して、EtherChannel のロード バランシングを行うように設定できます。 デフォルトでは、発信元 IP アドレスと送信先 IP アドレスとの間でハッシュ関数が使用されます。

Cisco IOS ソフトウェアが稼働する Catalyst 4000 では、ISL トランキングと 802.1Q トランキングのカプセル化と DTP がサポートされています。 ただし、一部 ISL を使用できないモジュールがあります。 そのようなモジュールを網羅した詳細なリストは、『レイヤ\ 2\ イーサネット\ インターフェイスの設定』の「VLAN トランクについて」を参照してください。 将来のソフトウェア リリースでは、show interface capabilities コマンドを発行するとポート機能に関する詳細情報が表示されるようになります。 現時点では、このコマンドは使用できません。

設定 1: Catalyst 3500 XL と Cisco IOS ソフトウェアが稼働する Catalyst 6500 との間の ISL トランキングと EtherChannel の設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

この設定では、次のネットワーク設定を使用します。

/image/gif/paws/22422/144-a.gif

Catalyst 3524 XL

!--- Catalyst 3500 XL does not support DTP/PAgP.
!--- First, shut down the secondary ports involved in the channel 
!--- and then enable them back when the configuration is complete on both switches.



Cat3500XL#show run
Building configuration...
Current configuration:
!

version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3500XL
ip subnet-zero
!
interface FastEthernet0/1
!

!--- Output suppressed.


!
interface FastEthernet0/17
port group 1

!--- Assigned port to port channel 1.


switchport trunk encapsulation isl

!--- Configured the port to use the trunking encapsulation ISL.


switchport mode trunk

!--- Configured the port to be in trunking mode.


!
interface FastEthernet0/18

!--- Repeated the trunk and channel configuration.


port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/19

!--- Repeated the trunk and channel configuration.


Port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/20

!--- Repeated the trunk and channel configuration.


Port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/21
!

!--- Output suppressed.


!
interface FastEthernet0/48
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!

interface VLAN1
ip address 10.10.10.1 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
line con 0
transport input none
stopbits 1
line vty 0 4
login

Catalyst 6500(Cisco IOS ソフトウェア)

!--- Catalyst 3500 XL does not support DTP/PAgP.
!--- First, shut down the secondary ports involved in the channel, 
!--- and then enable them back when the configuration is complete on both switches.



Cat6500#show run
Building configuration...
Current configuration : 3999 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6500
!
boot bootldr bootflash:c6msfc2-boot-mz.121-8b.E9
!
redundancy 
main-cpu  
auto-sync standard
ip subnet-zero
!
!
no mls ip multicast aggregate
no mls ip multicast non-rpf cef
mls qos statistics-export interval 300
mls qos statistics-export delimiter |
!
interface Port-channel1


!--- This interface will be created and configured automatically. 
!--- You do not need to input this part of the configuration.


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address
!
interface GigabitEthernet1/1 
no ip address 
shutdown
!

!--- Output suppressed.


!
interface FastEthernet4/2 
switchport

!--- Setting the interface as an L2 port, as by default the port is a routed port.



!--- Note: Catalyst 4500/4000 that runs Cisco IOS Software defaults to the L2 port.


switchport trunk encapsulation dot1q

!--- Setting the trunk encapsulation to dot1q.


switchport mode trunk

!--- Configured port to be in trunking mode. 


no ip address 
channel-group 1 mode on

!--- Configured the port to participate in port channel 1 with channel mode on.


! 
Interface FastEthernet4/3

!--- Repeated the trunk and channel configuration. 


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
! 
interface FastEthernet4/4

!--- Repeated the trunk and channel configuration.


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
! 
interface FastEthernet4/5

!--- Repeated the trunk and channel configuration. 


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
!
interface FastEthernet4/6 
no ip address 
shutdown
!
!
interface VLAN 1 
ip address 10.10.10.2  255.255.255.0
!
ip classless
no ip http server
!
line con 0
line vty 0 4
!
end
Cat6500# 

設定 2: Catalyst 2950 と Cisco IOS ソフトウェアが稼働する Catalyst 6500 との間の DTP と PAgP を使用した 802.1Q トランキングと EtherChannel の設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

この設定では、次のネットワーク設定を使用します。

/image/gif/paws/22422/144-b.gif

Catalyst 2950

!--- Catalyst 2950 with Cisco IOS Software Release 12.1 supports PAgP. 
!--- There is no need to shut down the ports as both Catalyst 2950 and 6500 can negotiate 
!--- channeling in desirable mode.



Cat2950#show run
Building configuration...
Current configuration : 1380 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat2950
!
ip subnet-zero
no ip finger
!
interface Port-channel1 
switchport mode trunk
!
interface FastEthernet0/1
!         
interface FastEthernet0/2 
switchport mode trunk

!--- Configured port to be in trunking mode.


channel-group 1 mode desirable

!--- Configured port to participate in PAgP-negotiated port channel 1.


!
interface FastEthernet0/3

!--- Repeated trunk and channel configuration.
 

switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/4

!--- Repeated trunk and channel configuration. 


switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/5

!--- Repeated trunk and channel configuration. 


switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/6
!

!--- Output suppressed.


!
interface FastEthernet0/25
!
interface FastEthernet0/26
!
interface VLAN1 
ip address 10.10.10.1 255.255.255.0 
no ip route-cache
!
ip http server
!
line con 0 
transport input none
line vty 5 15
!
end 
Cat2950#

Catalyst 6500(Cisco IOS ソフトウェア)

!--- Catalyst 2950 with Cisco IOS Software Release 12.1 supports PAgP. 
!--- There is no need to shut down the ports as both Catalyst 2950 and 6500 can negotiate 
!--- channeling in desirable mode.


Cat6500#show run
Building configuration...
Current configuration : 3999 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6500
!
boot bootldr bootflash:c6msfc2-boot-mz.121-8b.E9
!
redundancy 
main-CPU  
auto-sync standard
ip subnet-zero
!
!
no mls ip multicast aggregate
no mls ip multicast non-rpf cef
mls qos statistics-export interval 300
mls qos statistics-export delimiter |
!
interface Port-channel1


!--- This interface will be created and configured automatically. 
!--- You do not need to input this part of the configuration.


switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address
!
interface GigabitEthernet1/1 
no ip address 
shutdown
!

!--- Output suppressed.


!
interface FastEthernet4/2 
switchport

!--- Setting the interface as an L2 port, as by default the port is a routed port.



!--- Note: Catalyst 4500/4000 that runs Cisco IOS Software defaults to the L2 port.


switchport trunk encapsulation dot1q


!--- Setting the trunk encapsulation to dot1q.


switchport mode trunk

!--- Configured port to be in trunking mode. 


No ip address 
channel-group 1 mode desirable

!--- Configured port to participate in port channel 1 with channel mode desirable.


! 
Interface FastEthernet4/3

!--- Repeated trunk and channel configuration. 


switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/4

!--- Repeated trunk and channel configuration.
  

switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/5

!--- Repeated trunk and channel configuration. 


switchport
switchport trunk encapsulation dot1q
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/6 
no ip address 
shutdown
!
!
interface VLAN 1 
ip address 10.10.10.2  255.255.255.0
!
ip classless
no ip http server
!
!
line con 0
line vty 0 4
!
end
Cat6500# 

確認: ISL トランキング

ここでは、設定が正常に動作していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

Catalyst 3500XL

Cat3500XL#show cdp neighbor  
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat3500XL        Fas 0/20           136        R S I      Catalyst 6Fas 4/5
Cat3500XL        Fas 0/19           136        R S I      Catalyst 6Fas 4/4
Cat3500XL        Fas 0/18           136        R S I      Catalyst 6Fas 4/3
Cat3500XL        Fas 0/17           136        R S I      Catalyst 6Fas 4/2
Cat3500XL#



Cat3500XL#show port group 
Group  Interface              Transmit Distribution
-----  ---------------------  ---------------------
1  FastEthernet0/18       source address
1  FastEthernet0/17       source address
1  FastEthernet0/20       source address
1  FastEthernet0/19       source address
Cat3500XL#


Cat3500XL#show etherchannel summary
Flags:  d - default     D - down
I - in use

Group Ports
----- -----
1     Fa0/18(I) Fa0/17(Id) Fa0/20(I) Fa0/19(I)
Cat3500XL#

注: 8 ポートの EtherChannel が設定されていて Cisco IOS ソフトウェア リリース 12.0(5)WC5 より前のリリースが稼働している場合に、show etherchannel summary コマンドを発行するとスイッチがクラッシュします。

Cat3500XL#show interfaces fastethernet0/17 switchport 
Name: Fa0/17
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
Cat3500XL#

Catalyst 6500(Cisco IOS ソフトウェア)

Cat6500#show interfaces fastethernet 4/2 capabilities 
FastEthernet4/2
Model:                 WS-X6248-RJ-45
Type:                  10/100BaseTX
Speed:                 10,100,auto
Duplex:                half,full
Trunk encap. type:     802.1Q,ISL
Trunk mode:            on,off,desirable,nonegotiate
Channel:               yes
Broadcast suppression: percentage(0-100)
Flowcontrol:           rx-(off,on),tx-(none)
Fast Start:            yes
QOS scheduling:        rx-(1q4t), TX(2q2t)
CoS rewrite:           yes
ToS rewrite:           yes
Inline power:          no
SPAN:                  source/destination

Cat6500#

Cat6500#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat6500          Fas 4/5            135         T S       WS-C3548-XFas 0/20
Cat6500          Fas 4/4            135         T S       WS-C3548-XFas 0/19
Cat6500          Fas 4/3            134         T S       WS-C3548-XFas 0/18
Cat6500          Fas 4/2            134         T S       WS-C3548-XFas 0/17
Cat6500#


Cat6500#show interfaces port-channel 1 etherchannel 
Age of the Port-channel   = 01d:07h:30m:43s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     11     Fa4/2    on         
1     22     Fa4/3    on         
2     44     Fa4/4    on         
3     88     Fa4/5    on         

Time since last port bundled:    01d:06h:51m:22s    Fa4/5
Time since last port Un-bundled: 01d:06h:52m:30s    Fa4/5

Cat6500#


Cat6500#show etherchannel ?
<1-269>       Channel group number
brief         Brief information
detail        Detail information
load-balance  Load-balance/frame-distribution scheme among ports in
port-channel
port          Port information
port-channel  Port-channel information
summary       One-line summary per channel-group


Cat6500#show etherchannel summary 
Flags:  D - down        P - in port-channel
I - stand-alone s - suspended
R - Layer3      S - Layer2
U - port-channel in use
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Fa4/2(P)   Fa4/3(P)   Fa4/4(P)   Fa4/5(P)   

Cat6500#


Cat6500#show etherchannel port-channel 
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:07h:35m:28s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     11     Fa4/2    on         
1     22     Fa4/3    on         
2     44     Fa4/4    on         
3     88     Fa4/5    on         

Time since last port bundled:    01d:06h:56m:08s    Fa4/5
Time since last port UN-bundled: 01d:06h:57m:15s    Fa4/5


Cat6500#show interfaces port-channel 1 switchport
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative private-vlan host-association: none 
Administrative private-vlan mapping: none 
Operational private-vlan: none 
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Cat6500#

確認: 802.1q トランキング

ここでは、設定が正常に動作していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

Catalyst 2950

Cat2950#show cdp neighbors 
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat2950          Fas 0/4            120        R S I      Catalyst 6Fas 4/4
Cat2950          Fas 0/5            120        R S I      Catalyst 6Fas 4/5
Cat2950          Fas 0/3            120        R S I      Catalyst 6Fas 4/3
Cat2950          Fas 0/2            120        R S I      Catalyst 6Fas 4/2
Cat2950#



Cat2950#show etherchannel port-channel
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:08h:27m:08s
Logical slot/port   = 1/0           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     00     Fa0/2    desirable-SL  
0     00     Fa0/3    desirable-SL  
0     00     Fa0/4    desirable-SL  
0     00     Fa0/5    desirable-SL  

Time since last port bundled:    00d:00h:07m:17s    Fa0/5
Time since last port UN-bundled: 01d:08h:10m:06s    Fa0/5

Cat2950#



Cat2950#show etherchannel load-balance 
Source MAC address
Cat2950#


Cat2950#show interfaces port-channel 1 switchport 
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Protected: false

Voice VLAN: none (Inactive)
Appliance trust: none
Cat2950#

Catalyst 6500(Cisco IOS ソフトウェア)

Cat6500#show etherchannel port-channel 
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:08h:25m:07s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
1     11     Fa4/2    desirable-SL  
3     22     Fa4/3    desirable-SL  
0     44     Fa4/4    desirable-SL  
2     88     Fa4/5    desirable-SL  

Time since last port bundled:    00d:00h:09m:53s    Fa4/3
Time since last port UN-bundled: 00d:00h:09m:56s    Fa4/5

Cat6500#

トラブルシューティング

ここでは、設定に関するトラブルシューティングについて説明します。

トラフィックが 802.1Q トランクに渡されない

この問題は次のいずれかが原因で発生する可能性があります。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 22422