音声 : H.323

LLQ、PPP LFI、および cRTP を使用したフレームリレー ATM インターワーキングの VoIP QOS

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 10 月 30 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントは、Multilink PPP over ATM and Frame Relay Interworking(MLPoATM / MLPoFR)を使用した Voice over IP(VoIP)の設定例を示しています。 設定例の中央フォーカスは Quality of Service (QoS)のプロビジョニングするきちんと ATM/フレーム リレーによって相互に作用する WAN を渡る音声をサポートするためにです。 設定例はまた圧縮リアルタイム プロトコル(CRTP)を利用します、Cisco IOS 以来の ATM でサポートされたか。 ソフトウェア リリース 12.2(2)T。

資料はネットワークの構築で使用されるために設定指導、設定例および確認コマンドのための読まれたスタンドアロンである場合もあります。 ATM/フレームリレー インターワーキングの使用に関する特定の問題については、背景情報もあわせて記載されています。 VoIP over Frame Relay または PPP のための QoS に関する詳細についてはこれらの文書を参照して下さい:

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

これらの技術領域について詳しく知っているはずです:

  • アクセス コントロール リスト

  • ATM Permanent Virtual Circuit(PVC; 相手先固定接続)

  • フレームリレー PVC(Data-Link Connection Identifier(DLCI; データリンク接続識別子)

  • 帯域幅管理

  • LLQ

  • LFI

  • 仮想テンプレートと仮想アクセス インターフェイス

  • MLPPP

  • cRTP

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • ATMルータとして Cisco 3640

  • フレームリレールータとして Cisco 2620

  • Cisco IOS ソフトウェア リリース 12.2(8)T (IP Plus)

注:  一般指標として、cRTP が使用される場合 ATMルータで最新の Cisco IOS 12.2 メインライン メンテナンスリリースが MLPoATM/フレーム Cisco IOS ソフトウェア リリース 12.2T のために使用するべき推奨される Cisco IOS ソフトウェア リリース必要となりますです。

関連した機能はこれらの Cisco IOS ソフトウェア リリースで導入されました:

  • LFI は Cisco IOS ソフトウェア リリース 11.3 で導入されました。

  • LLQ は Cisco IOS ソフトウェア リリース 12.0(7)T で導入されました。

  • フレームリレーおよび ATM での PVC 単位の LLQ は Cisco IOS ソフトウェア リリース 12.1(2)T で導入されました。

  • フレームリレーおよび ATM 仮想回線でのマルチリンク PPP LFI は Cisco IOS ソフトウェア リリース 12.1(5)T で導入されました。

  • ATM での cRTP は Cisco IOS ソフトウェア リリース 12.2(2)T で導入されました。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

ATM/フレーム リレーによって相互に作用するネットワークを渡る VoIP に最小に された エンドツーエンド遅延およびジッター回避を提供することの重要な問題は次のとおりです:

  • 音声トラフィックの完全優先権(Low Latency Queueing(LLQ; 低遅延キューイング))

  • Link Fragmentation and Interleaving(LFI; リンク断片化およびインターリービング)

  • 音声の Frame Relay Traffic Shaping(FRTS; フレームリレー トラフィック シェーピング)

  • ATM トラフィック シェーピング

これらの文書はバックグラウンド情報の有用なもとを提供します:

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用します。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/22383/voip-qos-fr-atm-01.gif

設定

このドキュメントでは、次の設定を使用します。

注: この設定で、2 人のルータが ATM インターワーキングスイッチにフレーム リレーに続けて接続されることに注意することは重要です。 ただし、ほとんどのトポロジで、音声対応ルータは任意の場所に配置できます。 通常、音声 ルータは ATM/Frame WAN に接続される他のルータに LAN 接続を使用します。 そのような場合、WAN に、フレーム リレー接続されるルータおよび ATM は LLQ、LFI および MLPPP のために設定されなければなりません従ってこれらのコンフィギュレーションに示すように QoS およびない音声ゲートウェイを提供できます。

フレームリレー接続ルータ

!--- Note: This configuration is commented and numbered 
!--- in the order that commands should be entered.


version 12.2
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname FR
!
enable password cisco
!
username ATM password 0 cisco
voice-card 0
dspfarm
!
ip subnet-zero
!
!
!
!


!--- access-list 105 permit ip any any dscp ef specifies 
!--- that all traffic with Differentiated Services Code Point (DSCP)
!--- are set to 40 falls into this access-list.
!--- This class-map command defines a class of traffic called "voice".


access-list 105 permit ip any any dscp ef 
access-list 105 permit udp any any  range 16384 32767
access-list 105 permit ip any any precedence critical
!
class-map match-all voice 
match access-group 105
!

!         
!

!--- This policy-map command defines a policy for LLQ called "VoIP" and 
!--- maps the "voice" class to the "VOIP" policy.
!--- "priority" defines the amount of bandwidth reserved for the priority queue.
!--- "class-default" specifies that the default class is also mapped to this policy.  
!--- "fair-queue" specifies that all other traffic is served in the WFQ.


policy-map VOIP 
  class voice 
    priority 48 
  class class-default  
   fair-queue 


!--- Note: Although it is possible to queue various types of 
!--- real-time traffic to the priority queue, 
!--- Cisco recommends that you direct only voice traffic 
!--- to it. Real-time traffic such as video or voice
!--- could introduce variations in delay. Please note voice and 
!--- video should not be combined in the same PVC.
!--- (the priority queue is a First In First Out (FIFO) 
!--- queue). Voice traffic requires that delay be 
!--- nonvariable in order to avoid jitter.

!--- Note: The sum of the values for priority and 
!--- bandwidth statements needs to be less 
!--- than or equal to 75% of the link bandwidth. 
!--- Otherwise service-policy cannot be 
!--- assigned to the link. When configuring VoIP over a 
!--- 64 Kbps link to support two 
!--- voice calls, it is common to allocate more than 75% 
!--- (48 Kbps) of the link bandwidth to 
!--- the priority queue. In such cases, you can use the  
!--- max-reserved-bandwidth <#%> command in order to raise 
!--- available bandwidth to a value more than 75%.


!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
interface Loopback0
 ip address 10.1.1.2 255.255.255.0
!
!
interface FastEthernet0/0
 ip address 172.17.111.16 255.255.255.224
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay IETF
 no ip route-cache
 no ip mroute-cache
 frame-relay traffic-shaping
!

!--- Choose the frame relay interface to be 
!--- associated with the virtual interface. The
!--- virtual template could equally have been associated 
!--- with the physical interface. 
!--- The "class mlp" associates the virtual template interface 
!--- defined in "interface Virtual-Template1" with a Frame Relay DLCI.
!--- Associates a Frame Relay map class with a DLCI.


interface Serial0/0.1 point-to-point 
 no ip route-cache
 no ip mroute-cache
 frame-relay interface-dlci 16 ppp Virtual-Template1 
  class mlp 


!--- The interface command creates a virtual 
!--- template called Virtual-Template1. 
!--- A bandwidth of 64 Kbps is assigned to this 
!--- template interface. This bandwidth is used
!--- by Cisco IOS to calculate the data fragment size as noted regarding
!--- interleaving of PPP segments.

!--- "ip rtp header-compression"—cRTP is supported in an ATM/Frame Relay Interworking 
!--- environment. It requires Cisco IOS Software Release 12.2(2)T on the 
!--- ATM router.

!--- "service-policy output VOIP"—The VoIP policy created earlier is assigned 
!--- to this interface in the outbound direction.
 
!--- PPP multilink is enabled and the 
!--- maximum delay per segment is specified. This bandwidth is   
!--- used by Cisco IOS to calculate the data fragement size as noted.

!--- Interleaving of PPP segments is enabled, which allows 
!--- voice packets to be expedited. Voice  
!--- packets need only wait behind a single segment of 
!--- a previously queued data packet (for example, 10 ms 
!--- delay) rather than wait until the end of the 
!--- entire data packet. Cisco IOS calculates the  
!--- data fragment size using the following formula: 
!--- fragment size = delay x bandwidth/8

!
interface Virtual-Template1 
 bandwidth 64 
 ip unnumbered loopback0
 ip rtp header-compression 
 no ip route-cache
 load-interval 30
 max-reserved-bandwidth 99
 service-policy output VOIP 
 ppp multilink 
 ppp multilink fragment-delay 10 
 ppp multilink interleave 
!


!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.111.1
no ip http server
ip pim bidir-enable
!
!
!

!--- A map class called mlp is created.
!--- With "no frame-relay adaptive-shaping", adaptive
!--- shaping is disabled. You do not 
!--- want to exceed CIR and have voice packets
!--- possibly queued within the Frame Relay network. 
!--- Waiting for a BECN to resolve this 
!--- situation could result in poor voice quality.
!--- The frame-relay cir 64000 command forces the router to transmit 
!--- at the desired CIR rate rather than line
!--- rate for the port.
!--- "frame-relay bc 640" configures the Bc value to force the desired 
!--- Tc (shaping interval) value is 10 ms. 
!--- This formula should be used to determine 
!--- the Bc value to use: Tc = Bc/CIR. A 
!--- smaller Tc value reduces the interval a voice 
!--- packet has to wait to be sent.
!--- As in "frame-relay be 0", the Be value should be set to zero
!--- in order to avoid voice being sent as part of a burst
!--- that is not guaranteed by the Frame Relay network.


map-class frame-relay mlp

 no frame-relay adaptive-shaping
 frame-relay cir 64000  
 frame-relay bc 640 
 frame-relay be 0 


!
call rsvp-sync
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 123 voip
 destination-pattern 123
 session target ipv4:10.1.1.1
 ip qos dscp cs5 media
 ip qos dscp cs5 signaling
 no vad
!
dial-peer voice 456 pots
 destination-pattern 456
 port 1/0/0
!
!
line con 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
!
!
end

ATM 接続ルータ

!--- Note: This configuration is commented only 
!--- where additional consideration is required from the 
!--- above configuration of the Frame Relay router.


version 12.2
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname ATM
!
enable password cisco
!
username FR password 0 cisco
memory-size iomem 25
ip subnet-zero
!
!
!
access-list 105 permit ip any any dscp ef
access-list 105 permit udp any any  range 16384 32767
access-list 105 permit ip any any precedence critical
!
class-map match-all voice
 match access-group 105
!
!

!--- Note: Matching commands to the Frame Relay 
!--- router side of the network.


!
!
policy-map VOIP
  class voice
    priority 48
  class class-default
   fair-queue


!--- Note: Matching commands to the Frame Relay 
!--- router side of the network.


!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
controller T1 2/0
 framing sf
 linecode ami
!
!
!
!
interface ATM0/0
 no ip address
 ip route-cache
 no atm ilmi-keepalive
!

!--- "interface ATM0/0.1 point-to-point" chooses the ATM subinterface.
!---  The physical interface could equally have been used.
!--- "pvc 10/100" creates an ATM PVC. 
!--- "cbr 64"—A VBR PVC has been defined on this example.
!--- This exapmle uses VBR non-realtime and the sustained 
!--- cell rate (SCR) should be equal to the peak
!--- cell rate (PCR)  in order to avoid bursting. 
!--- ATM cell tax and the possibility
!--- of ATM bandwidth expansion due to poor 
!--- fragment/cell alignment, means that it  
!--- cannot be assumed that the PCR/SCR on the ATM 
!--- side should equal the CIR of the Frame Relay side.
!--- Maintain the value of CIR on the Frame-Relay side to define 
!--- our SCR, in this case, 64 kbps. This value may in some networks
!--- require some fine-tuning as the CIR on the Frame side does not
!--- exactly match the SCR on the ATM but makes for a good-enough estimation
!--- for most purposes.
!--- Refer to Designing and Deploying
!--- Multilink PPP over Frame Relay and ATM
!--- for more information. 
!--- "encapsulation aal5snap" is required.
!--- "protocol ppp Virtual-Template1" associates the virtual 
!--- template with the ATM PVC.


interface ATM0/0.1 point-to-point
 ip route-cache
 pvc 10/100 
  cbr 64 
  encapsulation aal5snap 
  protocol ppp Virtual-Template1 


!
!
interface loopback0
 ip address 10.1.1.1 255.255.255.0
!
interface Ethernet3/0
 ip address 172.17.111.15 255.255.255.224
 half-duplex
!
interface Ethernet3/1
 no ip address
 shutdown
 half-duplex
!
interface Virtual-Template1
 bandwidth 64
 ip unnumbered loopback0
 ip rtp header-compression
 no ip route-cache
 load-interval 30
 max-reserved-bandwidth 99
 service-policy output VOIP
 ppp multilink
 ppp multilink fragment-delay 10
 ppp multilink interleave


!--- Note: The virtual template is created in 
!--- exactly the same way as for the
!--- Frame Relay router side of the network. 
!--- An additional consideration for
!--- the ATM router is that the fragment size 
!--- should be optimized to fit into
!--- an integral number of ATM cells. 
!--- Refer to Designing and Deploying
!--- Multilink PPP over Frame Relay and ATM 
!--- for more information on this issue.


!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.111.1
ip http server
ip pim bidir-enable
!
!
call rsvp-sync
!
voice-port 1/0/0
 description FXS
!
voice-port 1/0/1
!
voice-port 1/1/0
 description FXO
!
voice-port 1/1/1
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 456 voip
 destination-pattern 456
 session target ipv4:10.1.1.2
 ip qos dscp cs5 media
 ip qos dscp cs5 signaling
 no vad   
!
dial-peer voice 123 pots
 destination-pattern 123
 port 1/1/0
!
!
line con 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
!
!
end

確認

ここでは、設定が正常に動作していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

これらの show コマンドは DLCI および PVC 統計情報、物理的 なおよび仮想インターフェイス ステータス、ポリシー(QoS)アプリケーションおよび cRTP 情報が含まれている環境を相互に作用する ATM/Frame リレーの動作状態の確認で役立ちます:

  • show ppp multilink interface interface-name - バンドルの状態(アップまたはダウン)、どの仮想アクセス インターフェイスがバンドル(MLPPP バンドル)か、およびどれがメンバ(PPP リンク)かを確認します。 このコマンドはまたかどうかキャリアドロップ セル/帯(失われたフラグメント <> 0)確認します。 許容されるフラグメント損失は、Cyclic Redundancy Check(CRC; 巡回冗長検査)エラーが原因のものに限られます。

  • show user - 仮想アクセス インターフェイスに関連付けられている番号を表示します。 このコマンドまたは show ppp multilink コマンドの情報を使用して、インターフェイスについての統計情報を表示したり、インターフェイスをクリアーしたりできます。

  • show frame-relay pvc dlci —トラフィック形成パラメータ、フラグメンテーション値および破棄された パケットのような情報を表示する。 また、物理インターフェイスが仮想インターフェイスにバインドされているかどうかも表示されます。

  • show atm pvc pvc - アクティブなすべての ATM PVC とトラフィックに関する情報を表示します。

  • show policy-map interface interface-name - PQ でのすべての LLQ 処理と廃棄を表示します。 このコマンドのさまざまなフィールドに関する詳細については show policy-map interface コマンド出力のパケットカウンタを理解することを参照して下さい。

    注: virtual-access2 インターフェイスには常にファンシー キューイングが適用されます。 その他のインターフェイスでは FIFO キューイングが使用されます。

  • show ip rtp header-compression - RTP ヘッダー圧縮に関する統計情報を表示します(設定されている場合)。 統計情報が bundle interface である virtual-access2 インターフェイスに接続されることに注意して下さい。

これらのコマンドの例はここに示されています:

FR#show ppp multilink interface virtual-access 2
Virtual-Access2, bundle name is ATM
Bundle up for 00:22:42
0 lost fragments, 0 reordered, 0 unassigned
0 discarded, 0 lost received, 231/255 load
0x2E5 received sequence, 0x10C31 sent sequence
Member links: 1 (max not set, min not set)
Virtual-Access1, since 00:22:42, last rcvd seq 0002E4 160 weight

この出力はフレームリレールータの show users を示したものです。

FR#show users
Line User Host(s) Idle Location
67 vty 1 idle 00:00:00 10.1.1.1
Interface User Mode Idle Peer Address
Vi1 Virtual PPP (FR ) - 
Vi2 Virtual PPP (Bundle) 00:00:00 10.1.1.1
FR#

この出力は ATMルータの show users を示したものです。

ATM#show users 
Line User Host(s) Idle Location
131 vty 1 idle 00:00:00 64.104.207.95
Interface User Mode Idle Peer Address
Vi1 Virtual PPP (ATM ) - 
Vi2 Virtual PPP (Bundle) 00:00:02 10.1.1.2
ATM#

この出力は show frame-relay pvc コマンドを示したものです。

FR#show frame-relay pvc 16
 PVC Statistics for interface Serial0/0 (Frame Relay DTE)
 DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1
  
     input pkts 2301 output pkts 2295 in bytes 152266 
     out bytes 151891 dropped pkts 0 in FECN pkts 0 
     in BECN pkts 0 out FECN pkts 0 out BECN pkts 0 
     in DE pkts 0 out DE pkts 0 
     out bcast pkts 0 out bcast bytes 0 
     5 minute input rate 9000 bits/sec, 9 packets/sec
     5 minute output rate 9000 bits/sec, 9 packets/sec
     pvc create time 23:46:56, last time pvc status changed 00:22:56
     Bound to Virtual-Access1 (up, cloned from Virtual-Template1) 
     
!--- PPP link interface.

     cir 64000 bc 640 be 0 byte limit 80 interval 10 
     mincir 64000 byte increment 80 Adaptive Shaping none
     pkts 2296 bytes 152053 pkts delayed 9 bytes delayed 375
     shaping active 
     traffic shaping drops 0
     Queueing strategy: fifo
     Output queue 0/40, 0 drop, 0 dequeued
FR#

この出力は ATMルータの show atm pvc 10/100 コマンドを示したものです。

ATM#show atm pvc 10/100 
     ATM0/0.1: VCD: 1, VPI: 10, VCI: 100
     CBR, SusRate: 128
     AAL5-LLC/SNAP, etype:0x0, Flags: 0x820, VCmode: 0x0
     OAM frequency: 0 second(s), OAM retry frequency: 1 second(s)
     OAM up retry count: 3, OAM down retry count: 5
     OAM Loopback status: OAM Disabled
     OAM VC state: Not Managed
     ILMI VC state: Not Managed
     InARP frequency: 15 minutes(s)
     Transmit priority 1
     InPkts: 729, OutPkts: 729, InBytes: 49700, OutBytes: 51158
     InPRoc: 0, OutPRoc: 729
     InFast: 729, OutFast: 0, InAS: 0, OutAS: 0
     InPktDrops: 0, OutPktDrops: 0/0/0 (holdq/outputq/total)
     CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0, LengthViolation: 0, 
     CPIErrors: 0
     OAM cells received: 0
     F5 InEndloop: 0, F5 InSegloop: 0, F5 InAIS: 0, F5 InRDI: 0
     F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0
     OAM cells sent: 0
     F5 OutEndloop: 0, F5 OutSegloop: 0, F5 OutRDI: 0
     F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0
     OAM cell drops: 0
     Status: UP
   PPP: Virtual-Access2 from Virtual-Template1 
    
!--- MLPPP bundle interface.

ATM#

これはフレームリレールータの show policy-map です。

FR#show policy-map interface Virtual-Access2
Service-policy output: VoIP
Class-map: voice (match-all)
15483 packets, 959502 bytes
30 second offered rate 24000 bps, drop rate 0 bps
Match: ip dscp 40 
Weighted Fair Queueing 
Strict Priority 

!--- LLQ Strict Priority Queue for voice.

Output Queue: Conversation 24 
Bandwidth 48(kbps) Burst 1500 (Bytes)
(pkts matched/bytes matched) 15536/962784
(total drops/bytes drops) 0/0 

!--- No drops in the voice queue.

Class-map: class-default (match-any)
139 packets, 19481 bytes
30 second offered rate 1000 bps, drop rate 0 bps
Match: any 
Weighted Fair Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 16 
(total queued/total drops/no-buffer drops) 0/0/0

この出力は ATMルータの show policy map コマンドを示したものです。

ATM#show policy-map interface Virtual-Access2 
Service-policy output: VOIP
Class-map: voice (match-all)
11293 packets, 699718 bytes
30 second offered rate 24000 bps, drop rate 0 bps
Match: ip dscp 40 
Weighted Fair Queueing
Strict Priority 

!--- LLQ Strict Priority Queue for voice.

Output Queue: Conversation 24 
Bandwidth 48 (kbps) Burst 1500 (Bytes)
(pkts matched/bytes matched) 11352/703376
(total drops/bytes drops) 0/0 

!--- No drops in the voice queue.

Class-map: class-default (match-any)
63 packets, 9772 bytes
30 second offered rate 0 bps, drop rate 0 bps
Match: any 
Weighted Fair Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 16 
(total queued/total drops/no-buffer drops) 0/0/0
ATM#

この出力はフレームリレールータの show ip rtp header-compression コマンドを示したものです。

FR#show ip rtp header-compression
RTP/UDP/IP header compression statistics:
Interface Virtual-Access1:
Rcvd: 0 total, 0 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 0 total, 0 compressed,
0 bytes saved, 0 bytes sent
Connect: 16 rx slots, 16 tx slots,
0 long searches, 0 misses 0 collisions

Interface Virtual-Template1:
Rcvd: 0 total, 0 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 0 total, 0 compressed,
0 bytes saved, 0 bytes sent
Connect: 16 rx slots, 16 tx slots,
0 long searches, 0 misses 0 collisions

Interface Virtual-Access2:
Rcvd: 23682 total, 23681 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 327 total, 233 compressed,
8821 bytes saved, 5159 bytes sent
2.70 efficiency improvement factor
Connect: 16 rx slots, 16 tx slots,
0 long searches, 94 misses 0 collisions
71% hit ratio, five minute miss rate 0 misses/sec, 0 max

この出力は ATMルータの show ip rtp header-compression コマンドを示したものです。

ATM#show ip rtp header-compression
RTP/UDP/IP header compression statistics:
Interface Virtual-Access1:
Rcvd: 0 total, 0 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 0 total, 0 compressed,
0 bytes saved, 0 bytes sent
Connect: 16 rx slots, 16 tx slots,
0 long searches, 0 misses 0 collisions, 0 negative cache hits

Interface Virtual-Template1:
Rcvd: 0 total, 0 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 0 total, 0 compressed,
0 bytes saved, 0 bytes sent
Connect: 16 rx slots, 16 tx slots,
0 long searches, 0 misses 0 collisions, 0 negative cache hits

Interface Virtual-Access2:
Rcvd: 283 total, 233 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 25341 total, 25340 compressed,
955537 bytes saved, 564463 bytes sent
2.69 efficiency improvement factor
Connect: 16 rx slots, 16 tx slots,
0 long searches, 1 misses 0 collisions, 100 negative cache hits
99% hit ratio, five minute miss rate 0 misses/sec, 0 max

トラブルシューティング

このセクションでは、設定のトラブルシューティングについて説明します。

この項では、MLP LFI の理解を深めるため、および設定のトラブルシューティングに実際に役立つ例として、いくつかのデバッグ例を示します。

トラブルシューティングのためのコマンド

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

注: debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

  • debug ppp negotiation - PPP と PPP バンドル リンクを表すために 2 つの仮想アクセス インターフェイスをコピーするプロセスを具体的に示します。 仮想アクセス インターフェイス 1(Vi1)は、(ATM またはフレーム)PVC がバインドされている PPP リンクです。 仮想インターフェイス 2(Vi2)は、キューイング ポリシーが適用されている PPP バンドル リンクです。

  • debug ppp multilink fragment - 大きなデータ パケットが小さな音声パケットにインターリーブされる概念を具体的に示します。 バンドル インターフェイスにファンシー キューイングが割り当てられているため、インターリービングは Vi2 インターフェイス(MLP レベル)で実行されます。

これは debug ppp negotiation コマンドのためのコマンド 出力です。

FR(config-if)#no shut
FR(config-if)#^Z
FR#
FR#
6d23h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Mar 7 23:20:42.842: Vi1 PPP: Treating connection as 
a dedicated line 

!--- Vi1 is the PPP link to which the PVC is bound.

*Mar 7 23:20:42.842: Vi1 PPP: Phase is ESTABLISHING, Active Open
*Mar 7 23:20:42.842: Vi1 LCP: O CONFREQ [Closed] id 197 len 19
*Mar 7 23:20:42.842: Vi1 LCP: MagicNumber 0xF44128D2 (0x0506F44128D2)
*Mar 7 23:20:42.842: Vi1 LCP: MRRU 1524 (0x110405F4)
*Mar 7 23:20:42.842: Vi1 LCP: EndpointDisc 1 FR (0x1305014652) 

!--- Router FR at one end of PPP discovery.

*Mar 7 23:20:42.858: Vi1 LCP: I CONFREQ [REQsent] id 14 len 20
*Mar 7 23:20:42.858: Vi1 LCP: MagicNumber 0x294819D4 (0x0506294819D4)
*Mar 7 23:20:42.858: Vi1 LCP: MRRU 1524 (0x110405F4)
*Mar 7 23:20:42.858: Vi1 LCP: EndpointDisc 1 ATM (0x13060141544D) 

!--- Router ATM at the other end of PPP discovery.

*Mar 7 23:20:42.858: Vi1 LCP: O CONFACK [REQsent] id 14 len 20

*Mar 7 23:20:42.862: Vi1 LCP: MagicNumber 0x294819D4 (0x0506294819D4)
*Mar 7 23:20:42.862: Vi1 LCP: MRRU 1524 (0x110405F4)
*Mar 7 23:20:42.862: Vi1 LCP: EndpointDisc 1 ATM (0x13060141544D)
*Mar 7 23:20:42.870: Vi1 LCP: I CONFACK [ACKsent] id 197 len 19
*Mar 7 23:20:42.870: Vi1 LCP: MagicNumber 0xF44128D2 (0x0506F44128D2)
*Mar 7 23:20:42.870: Vi1 LCP: MRRU 1524 (0x110405F4)
*Mar 7 23:20:42.870: Vi1 LCP: EndpointDisc 1 FR (0x1305014652)
*Mar 7 23:20:42.870: Vi1 LCP: State is Open
*Mar 7 23:20:42.870: Vi1 PPP: Phase is FORWARDING, Attempting Forward
*Mar 7 23:20:42.874: Vi1 PPP: Phase is ESTABLISHING, Finish LCP
*Mar 7 23:20:42.874: Vi1 PPP: Phase is VIRTUALIZED
*Mar 7 23:20:42.942: Vi2 PPP: Phase is DOWN, Setup
*Mar 7 23:20:43.222: Vi1 IPCP: Packet buffered while building MLP bundle interface
6d23h: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up 

!--- MLP level queuing.

*Mar 7 23:20:43.226: Vi2 PPP: Treating connection as a dedicated line
*Mar 7 23:20:43.226: Vi2 PPP: Phase is ESTABLISHING, Active Open
*Mar 7 23:20:43.226: Vi2 LCP: O CONFREQ [Closed] id 1 len 19
*Mar 7 23:20:43.226: Vi2 LCP: MagicNumber 0xF4412A53 (0x0506F4412A53)
*Mar 7 23:20:43.226: Vi2 LCP: MRRU 1524 (0x110405F4)
*Mar 7 23:20:43.230: Vi2 LCP: EndpointDisc 1 FR (0x1305014652)
*Mar 7 23:20:43.230: Vi2 MLP: 
Added first link Vi1 to bundle ATM 

!--- PVCs make up the bundle.

*Mar 7 23:20:43.230: Vi2 PPP: Phase is UP
*Mar 7 23:20:43.230: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10
*Mar 7 23:20:43.234: Vi2 IPCP: Address 10.1.1.2 (0x03060A010102)
*Mar 7 23:20:43.234: Vi2 PPP: Pending ncpQ size is 1
*Mar 7 23:20:43.234: Vi1 IPCP: Redirect packet to Vi1
*Mar 7 23:20:43.234: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10
*Mar 7 23:20:43.234: Vi2 IPCP: Address 10.1.1.1 (0x03060A010101)
*Mar 7 23:20:43.234: Vi2 IPCP: O CONFACK [REQsent] id 1 len 10
*Mar 7 23:20:43.234: Vi2 IPCP: Address 10.1.1.1 (0x03060A010101)
*Mar 7 23:20:43.266: Vi2 IPCP: I CONFACK [ACKsent] id 1 len 10
*Mar 7 23:20:43.266: Vi2 IPCP: Address 10.1.1.2 (0x03060A010102)
*Mar 7 23:20:43.266: Vi2 IPCP: State is Open
*Mar 7 23:20:43.266: Vi2 IPCP: Install route to 10.1.1.1
*Mar 7 23:20:43.270: Vi2 IPCP: Add link info for cef entry 10.1.1.1

このコマンド 出力は debug ppp multilink fragment コマンドからあります。

*Mar 7 23:16:08.034: Vi2 MLP: 
Packet interleaved from queue 24
*Mar 7 23:16:08.038: Vi1 MLP: O ppp UNKNOWN(0x0000) (0000) size 64 
*Mar 7 23:16:08.038: Vi2 MLP: Packet interleaved from queue 24
*Mar 7 23:16:08.038: Vi1 MLP: O ppp UNKNOWN(0x0000) (0000) size 64 
*Mar 7 23:16:08.038: Vi2 MLP: Packet interleaved from queue 24
*Mar 7 23:16:08.038: Vi1 MLP: O ppp UNKNOWN(0x0000) (0000) size 64 
*Mar 7 23:16:08.038: Vi1 MLP: O frag 0000829B size 160 
*Mar 7 23:16:08.042: Vi1 MLP: I ppp IP (0021) size 64 direct
*Mar 7 23:16:08.046: Vi1 MLP: I ppp IP (0021) size 64 direct

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 22383