ブロードバンド ケーブル : データオーバーケーブル サービス インターフェイス仕様(DOCSIS)

DOCSIS および CMTS における max-cpe コマンドの使用

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 8 月 11 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、新しい cable modem max-cpe n コマンドとデータオーバーケーブル サービス インターフェイス仕様(DOCSIS)のコンフィギュレーション ファイルで指定された MAX-CPE パラメータの関係について説明します。 DOCSISコンフィギュレーションファイルはケーブルモデムにロードされ、Cisco IOS を実行する UBR7200 シリーズ ルータでコードすることができますか。 ソフトウェア リリース 12.1(2)EC1 または それ 以上。

はじめに

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

前提条件

次の項目に関する知識があることが推奨されます。

  • この文書の情報は、シスコのハードウェアである uBR7246(NPE150)プロセッサ(リビジョン B)と、Cisco IOS ソフトウェア(UBR7200-IST-M)バージョン 12.1(2)EC1 に基づいています。

  • この文書では、ブリッジ モードでのケーブル モデムについてだけ言及しています。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

背景説明

ケーブルのお客様からは、ケーブル モデムのコンフィギュレーション ファイルの値ではホストの数を制限しても、Cable Modem Termination System(CMTS; ケーブル モデム終端システム)に対して、ケーブル モデムに接続できる CPE の数を増やしたいという要望があります。 ケーブルモデムに接続する CPE を増やす変更は、Cisco IOS ソフトウェア リリース 12.0(9.5)SC および Cisco IOS ソフトウェア リリース 12.1(1.0.3)EC1 IOS トレインの CSCdp52029(登録ユーザ専用)から組み込まれています。

この要望の理由としては、ケーブル モデムでは、割り当てられた CPE の数を CMTS カウントで同時に保持できないことがあります。 ケーブル モデムの初期化の際、MAX_CPE と CMTS で同期が取られるのは、登録要求フローの中で MAX-CPE カウントが CMTS に送られるときだけです。

ケーブル モデムがリロードされる場合、割り当てられた CPE のカウントをゼロにすると通知する CMTS へのフローは発生しません。 しかし、ケーブル モデムはゼロから再スタートします。 ケーブル モデムの背後にある新規の CPE から、オンラインになる要求があった場合、ケーブル モデムの MAX-CPE カウントが今はゼロであるため、これを許可します。 ただし、MAX-CPE カウントの値がゼロでない CMTS の場合は、この要求に応えることができず、CMTS 上に次のメッセージが表示されます。

 
%UBR7200-5-MAXHOST: New host with IP address x.x.x.x 
 and MAC yyyy.yyyy.yyyy on SID 3 (CM zzzz.zzzz.zzzz) is ignored.

これは DOCSISコンフィギュレーションファイルのデフォルト MAX-CPE エントリが 1 つに設定 されるというファクトによって明記していなかったら、激化します。

1 つの例として、MAX-CPE カウントの値が 1 である CMTS への登録要求を出しているケーブル モデムの場合があります。 ケーブルのお客様からは、ケーブル モデムの電源をオフ/オンすることによって、設置作業者のラップトップをケーブル モデムからはずして、エンド ユーザの PC をケーブル モデムの接続に復帰する機能が望まれています。 失敗の原因を次に示します。 リロードにケーブルモデム ゼロに設定された MAX-CPE 数がしかしあった後、CMTS はまだインストーラのラップトップ エントリを覚えています、1 つの MAX-CPE 数に匹敵し。

x.x.x.x が CMTS でクリアされるべきホストの IP か MAC アドレスに匹敵する clear cable host x.x.x.x コマンドの発行によって利用可能 な対応策があります。 しかし、この回避策は、ケーブルのお客様にはあまり知られていません。

実装

CMTS に新しい設定コマンドが追加されました。 モデムごとの許可されたホストの最大数を(ケーブルモデム 設定 ファイルの MAX-CPE 値を無効にする)規定 するために、ケーブルインターフェイス コンフィギュレーションモードの cable modem max-cpe n コマンドを発行して下さい。 n は 1 つから 255 に匹敵します。

CMTS により、ケーブル モデムに接続されるホストの数が最大 <n> まで有効になります。 無制限、か n へのセットがケーブルモデムのコンフィギュレーション ファイルの MAX-CPE 値より大きいとき、このコマンドはコンフィギュレーション ファイル値を無効にします。 DHCP サーバにより、1 台のケーブル モデムの背後にあるホストに割り当てられた IP アドレスの数が制御されます。

ケーブル モデムの設定ファイルで <n> より多い数のホスト数が指定されていた場合は、設定ファイルの設定が優先されます。 アクティブなホストの数の制御は、ケーブル モデムに依存します。

cable modem max-cpe unlimited コマンドを実行することにより、1 台のケーブル モデムに接続する CPE 数が CMTS によって制限されることはなくなります。 無制限に設定することで、CPE の最大数の管理はケーブル モデムに任され、1 台のケーブル モデムの背後にある CPE に割り当てられる IP アドレスの数の管理は DHCP サーバに任されます。

注意 注意: cable modem max-cpe unlimited コマンドを不用意に使用すると、DoS 攻撃を可能にしてシステムのセキュリティ ホールが開放される場合があります。 具体的には、ユーザが大量の IP アドレスを取得できるようになるため、1 人のユーザによって有効な IP アドレスがすべて予約されてしまい、ネットワーク全体が停止することがあります。 このため、cable modem max-cpe unlimited コマンドを有効にする場合、1 台のケーブル モデムの背後にある CPE に割り当てる IP アドレスの数を、DHCP サーバで厳しく管理することを推奨します。

no cable modem max-cpe コマンドを実行すると、デフォルト設定が有効になります。 設定ファイルにある max-cpe の値は、1 台のケーブル モデムに接続される CPE の数を、CMTS によって制限するために使用されます。

show cable modem detail コマンドはケーブルモデムのための DOCSISコンフィギュレーションファイルの設定によって cable modem max-cpe n が発行されるとき MAX-CPE 値を、もし可能なら、設定される値表示し。

次のサンプル ログ出力を参照してください。 ここでは、MAX-CPE が 4 になるように CMTS を設定し、その後 unlimited に設定しています。

test-cmts#show cable modem detail 
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 ............. yes ................ 37.37
Cable4/0/U0 2 .... 0001.9659.47ab 1 ............. yes ................ 33.70
Cable4/0/U0 3 .... 0001.9659.47bf .1 ............. yes ................ 30.67
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 ............. yes ................ 28.84
Cable4/0/U0 5 .... 0001.9659.47eb 1 ............. yes ................ 30.89

test-cmts#conf t
Enter configuration commands, one per line. End with CNTL/Z.
test-cmts(config)#cable modem max-cpe ?
<1-255> Number
unlimited Max CPE not enforced

test-cmts(config)#cable modem max-cpe 4
test-cmts(config)#end
test-cmts#
00:05:11: %SYS-5-CONFIG_I: Configured from console by console


test-cmts#show cable modem detail
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 (4) .........yes ................37.00
Cable4/0/U0 2 .... 0001.9659.47ab 1 (4) ........ yes ................33.54
Cable4/0/U0 3 .... 0001.9659.47bf .1 (4) ........ yes ................30.70
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 (4) ........ yes ................ 29.00
Cable4/0/U0 5 .... 0001.9659.47eb 1 (4) ........ yes ................ 30.92

test-cmts#conf t
Enter configuration commands, one per line. End with CNTL/Z.
test-cmts(config)#cable modem max
test-cmts(config)#cable modem max-cpe ?
<1-255> Number
unlimited Max CPE not enforced

test-cmts(config)#cable modem max-cpe unli
test-cmts(config)#cable modem max-cpe unlimited 
test-cmts(config)#^Z 
test-cmts#
00:06:06: %SYS-5-CONFIG_I: Configured from console by console


test-cmts#show cable modem detail
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 (ul) .........yes ............... 36.64
Cable4/0/U0 2 .... 0001.9659.47ab 1 (ul) ........ yes ............... 33.26
Cable4/0/U0 3 .... 0001.9659.47bf. 1 (ul) ....... .yes ............... 30.73
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 (ul) ...... . yes ............... 29.15
Cable4/0/U0 5 .... 0001.9659.47eb 1 (ul) ...... . yes ............... 30.95

test-cmts#wr t
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname test-cmts
!
boot system flash ubr7200-ist-mz.121-2.EC1
no logging buffered
!
cable modem max-cpe 4
ip subnet-zero 
!
interface FastEthernet0/0
ip address 10.200.68.4 255.255.255.0
half-duplex
!
interface Cable4/0
ip address 10.200.69.49 255.255.255.240 secondary
ip address 10.200.69.33 255.255.255.240
ip accounting precedence input
ip accounting precedence output
no keepalive
cable max-hosts 10
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable upstream 0 frequency 20000000
cable upstream 0 power-level 0
cable upstream 0 rate-limit
no cable upstream 0 shutdown
cable upstream 1 shutdown
cable upstream 2 shutdown
cable upstream 3 shutdown
cable upstream 4 shutdown
cable upstream 5 frequency 20000000
cable upstream 5 power-level 0
cable upstream 5 rate-limit
cable upstream 5 shutdown
cable dhcp-giaddr policycable
helper-addrress 10.200.68.11
! 
router rip
network 10.0.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.200.68.1
ip route 10.200.32.0 255.255.224.0 10.200.68.2
no ip http server
!
line con 0
exec-timeout 0 0
password ww
login
transport input none
line aux 0
line vty 0 4
password ww
login
!
end

test-cmts#

注: CPE の DOCSISコンフィギュレーションファイルで許可された数だけ可能にするために CMTS が、割り当てケーブルモデムを通したホストの指定 番号、まだケーブルモデム自身制限 されるが。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 22177