サービス品質(QoS) : QoS パケット マーキング

Quality of Service(QoS)操作手順

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2009 年 1 月 14 日) | 英語版 (2015 年 4 月 22 日) | フィードバック


目次


概要

この資料は Quality of Service (QoS) 機能がとき Cisco IOS を実行するルータのインターフェイスに応用受信か送信実行される順序を説明したものですか。 ソフトウェア。 QoS ポリシーは、Modular QoS Command Line Interface(MQC; モジュラ QoS コマンドライン インターフェイス)を使用して設定されます。 またこのドキュメントでは、DSCP や IP Precedence などの IP ヘッダー マーキングや、ルータによる QoS ポリシー コンポーネントの評価順位についても説明しています。

前提条件

要件

このドキュメントを読むには、次の知識が必要です。

  • 基本的な QoS の方法論

使用するコンポーネント

このドキュメントの「設定例」のセクションの出力例は、Cisco IOS ソフトウェア リリース 12.2 が稼働している Cisco 7513 シリーズ プラットフォームでキャプチャしたものです。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

共通分類

分類とは、フローのカテゴリ グループにトラフィックを分類するトラフィック クラスを定義するプロセスです。 分類では、QoS ポリシーが処理する各トラフィック クラスごとに、「一致基準」が定義されます。 明確にいうと、分類とは、サービス ポリシー適用時にパケットがチェックされる「トラフィック フィルタ」を定義することです。

分散プラットフォームと非分散プラットフォームの両方で、ポリシー マップの単一クラスへのパケットの照合が行われます。 照合は、最初に一致するクラスが見つかった時点で終了します。 ポリシー マップ内の 2 つのクラスが、同じ IP 優先順位または IP アドレス範囲に一致している場合、パケットは常に最初に一致したクラスに属すことになります。 このため、ポリシー マップ内のクラス順位は非常に重要です。

この分類方法は「共通分類」と呼ばれ、次の利点があります。

  • 精度の高いアカウンティング、および「共通分類」を適用する前に発生していた重複アカウンティングの回避。

  • Access Control List(ACL; アクセス制御リスト)のチェックを機能ごとに 1 回ではなく、クラスごとに 1 回実行することによる、CPU への影響の軽減。

  • キャッシングによる、パケット ヘッダーの検索の迅速化。

service-policy コマンドにより、入力または出力ポリシー マップを添付すると、共通分類は自動的にイネーブルになります。

次表では、共通分類に関する動作の順位を示しています。 大切なことは、この表から、QoS 機能のコンテキストでの分類の発生時期を理解することです。 受信パス上では、パケットはスイッチ前に分類されます。 発信パスでは、パケットはスイッチング後に分類されます。

着信 発信
  1. Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)を介したsQoS ポリシーの伝搬(QPPB)
  2. 共通分類を入力
  3. ACL を入力
  4. 入力マーキング(クラスベースのマーキング、または Committed Access Rate(CAR; 専用アクセス レート))
  5. ポリシング(クラスベース ポリシング機能または CAR による)を入力
  6. IP セキュリティ(IPSec)
  7. Cisco Express Forwarding (CEF)または Fast Switching
  1. CEF または Fast Switching
  2. 出力側の共通分類
  3. 出力 ACL
  4. 出力マーキング
  5. 出力ポリシング(クラスベースのポリサーまたは CAR による)
  6. キューイング(Class-Based Weighted Fair Queueing (CBWFQ)および低遅延キューイング(LLQ))および重み付けランダム早期検出 (WRED)

着信側の Network-Based Application Recognition(NBAR)は、ACL の後、ポリシー ベース ルーティングの前で発生します。

機能の順位付けと再マーキング値の使用に関しての重要な変更が適用されました。 これら変更には、MQC 出力分類の前への、入力 CAR、入力 MAC、および IP 優先順位アカウンティング機能の実行の移動が含まれています。

  • 入力レート制限(CAR)は、プロセス スイッチング パスに沿って、ルータに着信するパケットに適用されます。 あらかじめ CEF を使用するルータによってスイッチされたパケットだけがレート制限を受けます。

  • 入力 CAR や QPPB によって設定された、新しい IP 優先順位の値は、ATM VC バンドルの Virtual Circuit(VC; 仮想回線)の選択に使用できます。

  • 入力 CAR または QPPB によって設定された IP 優先順位、Differentiated Services Code Point(DSCP)、および QoS グループの各値は、MQC 出力パケット分類に使用できます。

同一ルータ上でのマーキングおよび他の QoS 動作

使用頻度の高い QoS は、パケットを再マーキングして、同一インターフェイスまたは同一ルータ上の再マーキング値と見なされるアクションを適用することです。 共通分類では、マーキングと QoS アクションの両方を設定できます。

次の QoS 機能を使って、パケットを再マーキングできます。

  • クラスベースのマーキングに関する set コマンド

  • クラスベース ポリシングの際の policee コマンド

  • CAR

次表では、サービス ポリシーの QoS アクションによって、再マーキング値が考慮されるかどうかを示しています。

ポリシーの場所 発信ポリシー アクションが使用する値
同じポリシーの QoS アクションのマーキングと適用 QoS 動作では、共通分類する際にパケットの本来の値を使用します。 パケットの転送時、パケットは新しい値を搬送し、次のルータではこの新しい値が使用されます。
着信ポリシーでのマーキングと、発信ポリシーでの QoS アクションの適用 QoS 動作では、送信ポリシーに対してトラフィックを分類する際に新しい値またはリマークした値を使用します。

発信パスでは、QoS 機能の適用の前に、共通分類が行われます。 この方法が実行された結果、発信ポリシーに適用される QoS 機能は、元の優先順位値で作用します。 同じルータの再マーキング値をベースにアクションを取る必要がある場合は、着信インターフェイスでパケットにマーキングし、発信インターフェイスで、この新しい優先順位値をベースに、その他の QoS アクションを適用することが必要です。

ネットワーク図

このセクションの構成では、次のネットワーク ダイアグラムを使用します。

/image/gif/paws/22141/qos_orderofop_3b.gif

Multilayer Switch Feature Card(MSFC; マルチレイヤ スイッチ フィーチャ カード)は、ホストとして動作しています。

設定

この例は、動作順位がパケットのマーキングにどのような影響を与えるかを示しています。

マーキングとシェーピングのポリシー設定の分離
class-map match-all In_Mark
   match any 
policy-map In_Bound
  class In_Mark
    set ip precedence 5 

!--- Use Private address below:

interface FastEthernet4/0/0 
 ip address  10.20.3.2 255.255.255.0
ip route-cache distributed  
 service-policy input In_Bound

!--- Apply the input policy for class-based marking.

  
class-map match-all Out_Shaper
match ip precedence 5 
! 
policy Map Outbound_Shaper
class  Out_Shaper 
    shape average 64000 256 256 

!--- Use Private address below:

interface Serial2/0/0 
 ip address 172.16.20.1 255.255.255.252
ip route-cache distributed 
 service-policy output Outbound_Shaper

!--- Apply the output policy for class-based shaping.

次のステップを実行し、ポリシーのマーキングとシェーピングを確認します。

  1. 172.16.20.2 の宛先アドレスに ping コマンドを使用します。 この ping は、「In_Mark」というクラスマップの基準に一致します。

    msfc#ping 172.16.20.2
      
    Type escape sequence to abort. 
    Sending 5, 100-byte ICMP Echos to 40.1.44.2, timeout is 2 seconds: 
    !!!!! 
    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
  2. show policy-map interface fast 4/0/0 コマンドを使用して、入力クラスベースのマーキング ポリシーの一致カウンタを表示します。 IP パケットでこの分類メカニズムが一致し、IP 優先順位値が 5 に再マーキングされます。

    7513#show policy-map interface fast 4/0/0 
     FastEthernet4/0/0 
      Service-policy input: In_Bound
     
        Class-map: In_Mark (match-all) 
          5 packets, 570 bytes 
          5 minute offered rate 0 bps, drop rate 0 bps 
          Match: any 
          QoS Set 
            ip precedence 5 
              Packets marked 5
     
        Class-map: class-default (match-any) 
          0 packets, 0 bytes 
          5 minute offered rate 0 BPS, drop rate 0 BPS 
          Match: any
  3. show policy-map interface serial 2/0/0 コマンドを使用して、発信側クラスベースのシェーピング ポリシーの一致カウンタを表示します。 パケット ヘッダーの再マーキングされた IP 優先順位値 5 に、この分類メカニズムが一致し、パケットが適切なクラスにキューイングされます。

    7513#show policy-map interface serial 2/0/0 
     Serial2/0/0 
    
      Service-policy output: Outbound_Shaper
    
        Class-map: Out_Shaper(match-all) 
          5 packets, 520 bytes 
          5 minute offered rate 0 BPS, drop rate 0 BPSMatch: ip precedence 5 
          queue size 0, queue limit 16 
          packets output 5, packet drops 0 
          tail/random drops 0, no buffer drops 0, other drops 0 
          Shape: cir 64000,  Bc 256,  Be 256 
            output bytes 520, shape rate 0 BPS 
    
        Class-map: class-default (match-any) 
          0 packets, 0 bytes 
          5 minute offered rate 0 BPS, drop rate 0 BPS 
          Match: any  (1327)

次の例で、トラフィック クラスのシェーピングとマーキングの両方に適用される単一のサービス ポリシーを設定すると、どのような動作が行われるか確認できます。

マーキングとシェーピングでの単一ポリシー設定
class-map match-all prec5 
  match any 
! 
policy-map shape_five
  class prec5 
    set ip precedence 5 
    shape average 64000 256 256
int serial1/0/0
  service-policy out shape_five

show policy-map interface serial 2/0/0 コマンドの出力で、ルータが 5 つの ping パケットに再マーキングしたにもかかわらず、それらパケットは class-default のクラスにキューイングされたことがわかります。 このルータの QoS 分類メカニズムでは、IP 優先順位フィールドの再マーキング値が考慮されませんでした。

7513#show policy-map interface serial 2/0/0 
 Serial2/0/0
  
  Service-policy output: shape_five
 
    Class-map: prec5 (match-all) 
      0 packets, 0 bytes 
      5 minute offered rate 0 BPS, drop rate 0 BPS 
      Match:  any
      queue size 0, queue limit 16 
      packets output 0, packet drops 0 
      tail/random drops 0, no buffer drops 0, other drops 0 
      QoS Set 
        ip precedence 5 
          Packets marked 5 
      Shape: cir 64000,  BC 256,  Be 256 
        output bytes 0, shape rate 0 BPS 

    Class-map: class-default (match-any) 
      5 packets, 520 bytes 
      5 minute offered rate 0 BPS, drop rate 0 BPS 
      Match: any

関連情報


Document ID: 22141