スイッチ : Cisco Catalyst 4500 シリーズ スイッチ

Cisco IOS ソフトウェアが稼動する Catalyst 4500/4000 スーパーバイザ エンジン II+/II+TS/II+10GE/III/IV/V/V 10GE モジュールおよび Catalyst 4900 スイッチのパスワード回復手順

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2010 年 8 月 10 日) | 英語版 (2015 年 10 月 7 日) | フィードバック


目次


概要

このドキュメントは、スーパーバイザ エンジン II-Plus(WS-X4013+)、 スーパーバイザ エンジン II-Plus-TS(WS-X4013+TS)、スーパーバイザ エンジン II-Plus-10GE(WS-X4013+10GE)、スーパーバイザ エンジン III(WS-X4014)、スーパーバイザ エンジン IV(WS-X4515)、スーパーバイザ エンジン V(WS-X4516)、スーパーバイザ エンジン V-10GE(WS-X4516-10GE)モジュールを備えた Catalyst 4500/4000 スイッチ、Cisco Catalyst 4948、Cisco Catalyst 4948 10GE、および Cisco Catalyst 4900M スイッチで、失われたパスワードまたは未知のパスワードを回復する方法について説明します。

Catalyst 4500/4000 シリーズ スイッチ、スーパバイザ エンジン II+、II+10GE、II+TS、III、IV、V および V-10GE サポート Cisco IOS だけではか。 ソフトウェアおよびスーパバイザ エンジン I および II サポート Catalyst OSソフトウェアだけ。 スーパーバイザ エンジン I または II でパスワードを回復するには、『CatOS を稼動する Catalyst 1200、1400、2901、2902、2926T/F、2926GS/L、2948G、2980G、4000、5000、5500、6000、6500 のパスワード回復手順』を参照してください。

前提条件

要件

このドキュメントに関する固有の要件はありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

ステップバイステップ手順

次の手順を実行してパスワードを回復します。

次の手順を実行するときには、スイッチに物理的にアクセスでき、スーパーバイザ エンジン モジュールにコンソールからアクセスできることを確認してください。 スイッチのコンソール接続の詳細は、『Catalyst スイッチのコンソール ポートへのモデムの接続』を参照してください。

ヒント: 説明どおりの手順に従う限り、スイッチのコンフィギュレーションは失われません。 ベスト プラクティスとして、TFTP サーバまたはネットワーク管理サーバですべての Cisco デバイスのコンフィギュレーションのコピーをバックアップしておくことを推奨します。

  1. デバイスの電源のオフ/オンを行います。

    電源のオフ/オンとは、つまり、デバイスの電源を切り、また電源を入れることです。

    5 秒以内に Ctrl+C キーを押して、自動ブートを停止します。 この操作で ROM モニタ(ROMmon)プロンプト モードになります。

    
    !--- Here, you power cycle the switch.
    
    ********************************************************** 
     *                                                        * 
     * Welcome to ROM Monitor for WS-X4014 System.            * 
     * Copyright (c) 1999-2000, 2001 by Cisco Systems, Inc.   * 
     * All rights reserved.                                   * 
     *                                                        * 
     **********************************************************
     
     ROM Monitor Program Version 12.1(10r)EY(1.21) 
    
     Board type 1, Board revision 7
     Swamp FPGA revision 16, Dagobah FPGA revision 43 
     
     Timer interrupt test passed.
    
     MAC Address  : 00-02-b9-83-af-fe 
     IP Address   : 172.16.84.122 
     Netmask      : 255.255.255.0 
     Gateway      : 172.16.84.1 
     TftpServer   : Not set. 
     Main Memory  : 256 MBytes
    
    
     ***** The system will autoboot in 5 seconds *****
    
    
     Type control-C to prevent autobooting. 
    
    !--- At this point, press Ctrl-C.
    
    Autoboot cancelled......... please wait!!!
    Autoboot cancelled......... please wait!!!
    rommon 1 > [interrupt]  
    
    !--- The module ended in the ROMmon.
    
    rommon 1 > [interrupt]
  2. rommon プロンプトで confreg コマンドを発行します。

    ここでパスワード回復のために、太字で表示されている箇所の選択を行います。

    rommon 1 > set
    
    rommon 1 > confreg
    
     Configuration Summary : 
     => load ROM after netboot fails
     => console baud: 9600
     => autoboot from: commands specified in 'BOOT' environment variable
    
     do you wish to change the configuration? y/n  [n]:  y
     enable  "diagnostic mode"? y/n  [n]:  n
     enable  "use net in IP bcast address"? y/n  [n]:  n
     disable "load ROM after netboot fails"? y/n  [n]:  n
     enable  "use all zero broadcast"? y/n  [n]:  n
     enable  "break/abort has effect"? y/n  [n]:  n
     enable  "ignore system config info"? y/n  [n]:  y
    
     change console baud rate? y/n  [n]:  n
    
     change the boot characteristics? y/n  [n]:  n
    
     Configuration Summary : 
     => load ROM after netboot fails
     => ignore system config info
     => console baud: 9600
     => autoboot from: commands specified in 'BOOT' environment variable
    
     do you wish to save this configuration? y/n  [n]:  y
     You must reset or power cycle for new configuration to take effect
    

    また、ROMmon プロンプトで confreg 0x2142 コマンドを使用して、コンフィギュレーション レジスタ値が NVRAM に格納されているスタートアップ コンフィギュレーションをバイパスするように設定することもできます。

    rommon 1 >confreg 0x2142
    You must reset or power cycle for the new configuration to take effect.
  3. モジュールがリブートするように reset コマンドを発行します。

    手順 2 で行った変更に従い、モジュールはリブートしますが、保存したコンフィギュレーションは無視します。

    rommon 2 > reset
    
    Resetting .......
    
    rommon 3 >
    
     ********************************************************** 
     *                                                        * 
     * Welcome to ROM Monitor for WS-X4014 System.            * 
     * Copyright (c) 1999-2000, 2001 by Cisco Systems, Inc.   * 
     * All rights reserved.                                   * 
     *                                                        * 
     **********************************************************
    
    !--- Output suppressed.
    
    Press RETURN to get started! 
    
    !--- Press Return.
    
    00:00:21: %SYS-5-RESTART: System restarted --
    Cisco Internetwork Operating System Software 
    IOS (tm) Catalyst 4000 L3 Switch Software (cat4000-IS-M), 
       Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
    TAC Support: http://www.cisco.com/tac
    Copyright (c) 1986-2002 by cisco Systems, Inc.
    Compiled Thu 24-Jan-02 17:34 by ccai
    00:00:21: %SNMP-5-COLDSTART: SNMP agent on host Switch 
       is undergoing a cold start
    Switch>
  4. コンフィギュレーション レジスタ値が 0x2142 であることを確認します。

    この値によって、モジュールは、保存したコンフィギュレーションのロードを行わずにフラッシュからブートします。 Switch プロンプトで enable コマンドを発行すると、イネーブル モードに移ります。 次に、show version コマンドを発行すると、コンフィギュレーション レジスタ値をチェックできます。

    Switch> enable
    Switch#show version
    Cisco Internetwork Operating System Software 
    IOS (TM) Catalyst 4000 L3 Switch Software (cat4000-IS-M),
       Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
    TAC Support: http://www.cisco.com/tac
    Copyright (c) 1986-2002 by cisco Systems, Inc.
    Compiled Thu 24-Jan-02 17:34 by ccai
    Image text-base: 0x00000000, data-base: 0x00AA2B8C
    
    ROM: 12.1(10r)EY(1.21)
    Switch uptime is 5 minutes
    System returned to ROM by reload
    Running default software
    
    cisco WS-C4006 (MPC8245) processor (revision 7) with 262144K bytes of memory.
    Processor board ID FOX04183666
    Last reset from Reload
    32 Gigabit Ethernet/IEEE 802.3 interface(s)
    467K bytes of non-volatile configuration memory.
    
    Configuration register is 0x2142
    
    Switch#
  5. configure memory コマンドまたは copy startup-config running-config コマンドを発行すると、NVRAM をメモリにコピーできます。

    configure terminal コマンドは発行しないでください。このコマンドはモジュールのデフォルト コンフィギュレーションを表示します。

    Switch#configure memory
    
    Uncompressed configuration from 1307 bytes to 3014 bytes
    Switch#
    00:13:52: %SYS-5-CONFIG_I: Configured from memory by console
    c-4006-SUPIII#
  6. show ip interface brief コマンドを発行して、以前に使用中だったインターフェイスが「up up」のステータスを示すことを確認します。

    パスワード回復よりも前に使用中であったインターフェイスのいずれかが「down」を示す場合、そのインターフェイスに no shutdown コマンドを発行して、インターフェイスをアップ状態にします。

  7. write terminal コマンドまたは show running-config コマンドを発行して、モジュールに保存したコンフィギュレーションを表示します。

    c-4006-SUPIII#show running-config 
    Building configuration...
    
    Current configuration : 3014 bytes
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service compress-config
    !
    hostname c-4006-SUPIII
    !
    boot system flash bootflash:
    !
    vtp mode transparent
    
    !--- Output suppressed.
    
    line con 0
     stopbits 1
    line vty 0 4
     login
    !
    end
    
    c-4006-SUPIII#

    これで、モジュールのパスワードを変更する準備が整いました。

  8. 次のコマンドを発行してパスワードを変更します。

    c-4006-SUPIII#configure terminal 
    Enter configuration commands, one per line.  End with CNTL/Z.
    c-4006-SUPIII(config)#no enable secret
    
    !--- This step is necessary if the switch had an enable 
    !--- secret password.
    
    
    c-4006-SUPIII(config)#enable secret < password > 
    [Choose a strong password with at least one capital letter,
     one number, and one special character.]
    
    !--- This command sets the new password.
    
    
  9. コンフィギュレーション レジスタ値を 0x2102 に戻したことを確認します。

    次の手順を config プロンプトで実行して、コンフィギュレーション レジスタ値を変更して確認します。

    c-4006-SUPIII(config)#config-register 0x2102
    c-4006-SUPIII(config)# ^Z
    c-4006-SUPIII#
    00:19:01: %SYS-5-CONFIG_I: Configured from console by console
    c-4006-SUPIII#write memory 
    
    !--- This step saves the configuration.
    
    Building configuration...
    Compressed configuration from 3061 bytes to 1365 bytes[OK]
    c-4006-SUPIII#show version 
    
    !--- This step verifies the value change.
    
    Cisco Internetwork Operating System Software 
    IOS (TM) Catalyst 4000 L3 Switch Software (cat4000-IS-M), 
    Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
    TAC Support: http://www.cisco.com/tac
    Copyright (c) 1986-2002 by cisco Systems, Inc.
    Compiled Thu 24-Jan-02 17:34 by ccai
    Image text-base: 0x00000000, database: 0x00AA2B8C
    
    ROM: 12.1(10r)EY(1.21)
    c-4006-SUPIII uptime is 20 minutes
    System returned to ROM by reload
    Running default software
    
    cisco WS-C4006 (MPC8245) processor (revision 7) with 262144K bytes of memory.
    Processor board ID FOX04183666
    Last reset from Reload
    32 Gigabit Ethernet/IEEE 802.3 interface(s)
    467K bytes of nonvolatile configuration memory.
    
    Configuration register is 0x2142 (will be 0x2102 at next reload)
    
    c-4006-SUPIII#

    この時点で、パスワードは変更されました。

出力例および手順例

次のサンプル出力は、Catalyst 4000 スーパーバイザ エンジン III でのパスワード回復手順の結果です。

c-4006-SUPIII> enable
Password: 
Password: 
Password: 
% Bad secrets 

!--- Here, you power cycle the switch.

********************************************************** 
 *                                                        * 
 * Welcome to ROM Monitor for WS-X4014 System.            * 
 * Copyright (c) 1999-2000, 2001 by Cisco Systems, Inc.   * 
 * All rights reserved.                                   * 
 *                                                        * 
 **********************************************************
 
 ROM Monitor Program Version 12.1(10r)EY(1.21) 

 Board type 1, Board revision 7
 Swamp FPGA revision 16, Dagobah FPGA revision 43 
 
 Timer interrupt test passed.

 MAC Address  : 00-02-b9-83-af-fe 
 IP Address   : 172.16.84.122 
 Netmask      : 255.255.255.0 
 Gateway      : 172.16.84.1 
 TftpServer   : Not set. 
 Main Memory  : 256 Mbytes


 ***** The system will autoboot in 5 seconds *****

 Type control-C to prevent autobooting. 

!--- At this point, press Ctrl-C.


Autoboot cancelled......... please wait!!!
Autoboot cancelled......... please wait!!!
rommon 1 > [interrupt]

rommon 1 > [interrupt]

rommon 1 > confreg

 Configuration Summary : 
 => load ROM after netboot fails
 => console baud: 9600
 => autoboot from: commands specified in 'BOOT' environment variable

 do you wish to change the configuration? y/n [n]:  y
 enable "diagnostic mode"? y/n [n]:  n
 enable "use net in IP bcast address"? y/n [n]:  n
 disable "load ROM after netboot fails"? y/n [n]:  n
 enable "use all zero broadcast"? y/n [n]:  n
 enable "break/abort has effect"? y/n [n]:  n
 enable "ignore system config info"? y/n [n]:  y

 change console baud rate? y/n [n]:  n

 change the boot characteristics? y/n [n]:  n

 Configuration Summary : 
 => load ROM after netboot fails
 => ignore system config info
 => console baud: 9600
 => autoboot from: commands specified in 'BOOT' environment variable

 do you wish to save this configuration? y/n [n]:  y
 You must reset or power cycle for new configuration to take effect

rommon 2 > reset

Resetting .......


rommon 3 >

 ********************************************************** 
 *                                                        * 
 * Welcome to ROM Monitor for WS-X4014 System.            * 
 * Copyright (c) 1999-2000, 2001 by Cisco Systems, Inc.   * 
 * All rights reserved.                                   * 
 *                                                        * 
 **********************************************************
 
 ROM Monitor Program Version 12.1(10r)EY(1.21) 

 Board type 1, Board revision 7
 Swamp FPGA revision 16, Dagobah FPGA revision 43 
 
 Timer interrupt test passed.

 MAC Address  : 00-02-b9-83-af-fe 
 IP Address   : 172.16.84.122 
 Netmask      : 255.255.255.0 
 Gateway      : 172.16.84.1 
 TftpServer   : Not set. 
 Main Memory  : 256 Mbytes

 ***** The system will autoboot in 5 seconds *****


 Type control-C to prevent autobooting.
 . . . . .

 ******** The system will autoboot now ********


 config-register = 0x2142 
 Autobooting using BOOT variable specified file.....

 Current BOOT file is --- bootflash: 

Rommon reg: 0x2B004180
Decompressing the image : ###########################
#####################################################
####################################### [OK]

k2diags version 1.6

prod: WS-X4014  part: 73-6854-07  serial: JAB0546060Z

Power-on-self-test for Module 1:  WS-X4014
Status: (. = Pass, F = Fail)

Traffic using serdes loopback (L2; one port at a time)...
switch port 0: .       switch port 1: .       switch port 2: .       
switch port 3: .       switch port 4: .       switch port 5: .       
switch port 6: .       switch port 7: .       switch port 8: .       

!--- Output suppressed.

Module 1 Passed


Exiting to ios...

Rommon reg: 0x2B000180
Decompressing the image : ##########################

!--- Output suppressed.

######################################################### [OK]

              Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

           cisco Systems, Inc.
           170 West Tasman Drive
           San Jose, California 95134-1706



Cisco Internetwork Operating System Software 
IOS (TM) Catalyst 4000 L3 Switch Software (cat4000-IS-M),
   Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 24-Jan-02 17:34 by ccai
Image text-base: 0x00000000, database: 0x00AA2B8C

cisco WS-C4006 (MPC8245) processor (revision 7) with 262144K bytes of memory.
Processor board ID FOX04183666
Last reset from Reload
32 Gigabit Ethernet/IEEE 802.3 interface(s)
467K bytes of nonvolatile configuration memory.


Press RETURN to get started!


00:00:21: %SYS-5-RESTART: System restarted --
Cisco Internetwork Operating System Software 
IOS (TM) Catalyst 4000 L3 Switch Software (cat4000-IS-M),
   Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 24-Jan-02 17:34 by ccai
00:00:21: %SNMP-5-COLDSTART: SNMP agent on host Switch is undergoing a cold start
Switch> enable
Switch# show version
Cisco Internetwork Operating System Software 
IOS (TM) Catalyst 4000 L3 Switch Software (cat4000-IS-M),
   Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 24-Jan-02 17:34 by ccai
Image text-base: 0x00000000, database: 0x00AA2B8C

ROM: 12.1(10r)EY(1.21)
Switch uptime is 5 minutes
System returned to ROM by reload
Running default software

cisco WS-C4006 (MPC8245) processor (revision 7) with 262144K bytes of memory.
Processor board ID FOX04183666
Last reset from Reload
32 Gigabit Ethernet/IEEE 802.3 interface(s)
467K bytes of nonvolatile configuration memory.

Configuration register is 0x2142

Switch#

Switch#configure memory

Uncompressed configuration from 1307 bytes to 3014 bytes
c-4006-SUPIII#
00:13:52: %SYS-5-CONFIG_I: Configured from memory by console
c-4006-SUPIII#show running-config 
Building configuration...

Current configuration : 3014 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname c-4006-SUPIII
!
boot system flash bootflash:
!
vtp mode transparent
!
vlan 20
  private-vlan primary
!
vlan 100
!
vlan 202
  private-vlan association 440
!         
vlan 440
  private-vlan isolated
!
vlan 500
ip subnet-zero
no ip domain-lookup
!
ip multicast-routing
!
!
interface GigabitEthernet1/1
 no switchport
 ip address 10.1.1.1 255.255.255.0
 ip pim dense-mode
!
interface GigabitEthernet1/2
 no switchport
 ip address 20.1.1.1 255.255.255.0
!

!--- Output suppressed.

!
interface Vlan1
 ip address 172.16.84.140 255.255.255.0
 ip pim dense-mode
!
interface Vlan2
 no ip address
 shutdown
!
interface Vlan20
 no ip address
 shutdown
!

!--- Output suppressed.

!         
line con 0
 stopbits 1
line vty 0 4
 login
!
end

c-4006-SUPIII#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
c-4006-SUPIII(config)#no enable secret

!--- This step is necessary if the switch had 
!--- an enable secret password.

c-4006-SUPIII(config)#enable secret < password > 
[Choose a strong password with at least one capital letter, 
one number, and one special character.]
c-4006-SUPIII(config)#config-register 0x2102
c-4006-SUPIII(config)#^Z
c-4006-SUPIII#
00:19:01: %SYS-5-CONFIG_I: Configured from console by console
c-4006-SUPIII#write memory
Building configuration...
Compressed configuration from 3061 bytes to 1365 bytes[OK]
c-4006-SUPIII#show version
Cisco Internetwork Operating System Software 
IOS (TM) Catalyst 4000 L3 Switch Software (cat4000-IS-M),
   Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 24-Jan-02 17:34 by ccai
Image text-base: 0x00000000, database: 0x00AA2B8C

ROM: 12.1(10r)EY(1.21)
c-4006-SUPIII uptime is 20 minutes
System returned to ROM by reload
Running default software

cisco WS-C4006 (MPC8245) processor (revision 7) with 262144K bytes of memory.
Processor board ID FOX04183666
Last reset from Reload
32 Gigabit Ethernet/IEEE 802.3 interface(s)
467K bytes of nonvolatile configuration memory.

Configuration register is 0x2142 (will be 0x2102 at next reload)

c-4006-SUPIII#

関連情報


Document ID: 21229