LAN スイッチング : EtherChannel

Cisco IOS システム ソフトウェアを実行する Catalyst スイッチと Cisco ルータ間の EtherChannel の設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2005 年 3 月 29 日) | 英語版 (2015 年 10 月 7 日) | フィードバック


目次


概要

この設定 例は、Cisco IOS を実行する Ciscoルータと Cisco Catalyst 6500 スイッチ間の VLANトランキングなしで、レイヤ3 (L3) EtherChannel を設定する方法を示しますか。 トラブルシューティング」)を参照してください。 EtherChannel は、Fast EtherChannel(FEC)、または Gigabit EtherChannel(GEC)とも呼ばれます。 この用語は、EtherChannel を構成するのに使用されるインターフェイスやポートの速度によって異なります。 この例では、Cisco ルータと Catalyst 6500 スイッチの 2 つのファスト イーサネット ポートが、FEC にバンドルされています。 この文書中では、FEC、GEC、ポート チャネル、チャネル、およびポート グループという用語は、すべて EtherChannel に関して使用されています。

また、このドキュメントには、スイッチとルータのコンフィギュレーション ファイル、および関連するサンプルの show コマンドの出力だけが含まれています。

前提条件

要件

この設定を開始する前に、次の要件が満たされていることを確認してください。

  • Cisco IOS ソフトウェアが稼働する Catalyst 6500/6000 および 4500/4000 シリーズ スイッチ

    • Cisco IOS ソフトウェアが稼働する 6500/6000 および 4500/4000 シリーズ スイッチは、最大 8 個の互換構成のイーサネット インターフェイスをすべてのモジュールで使用して、レイヤ 2(L2)およびレイヤ 3(L3)の両方の EtherChannel をサポートします。 各 EtherChannel のすべてのインターフェイスは、同一の速度にしておく必要があります。 また、すべて L2 または L3 インターフェイスとして設定する必要があります。

    • EtherChannel のロード バランシングでは、MAC アドレス、IP アドレス、または TCP ポート番号のいずれも使用できます。

      注: 選択されたモードは、そのスイッチで設定されているすべての EtherChannel に適用されます。

    • Catalyst 6500/6000 Cisco IOS ソフトウェア リリース 12.1E 以降および Catalyst 4500/4000 Cisco IOS ソフトウェア リリース 12.1(8a)EW 以降。

  • Cisco ルータ

    • IP トラフィックは、ポート チャネルのインターフェイス経由で配信されますが、他のルーティング プロトコルからのトラフィックは 1 つのリンクで送信されます。 ブリッジされたトラフィックは、パケット内の L3 情報に基づいて配信されます。 レイヤ 3 情報がパケット内になければ、トラフィックは最初のリンク経由で送信されます。

  • さまざまなタイプの Cisco ルータが EtherChannel をサポートしています。 Ciscoルータの EtherChannel をサポートするコードのバージョンかプラットフォームを見つけるために、Cisco Feature Navigator II 登録ユーザのみ)を使用して下さい。 EtherChannel をサポートするルータおよび Cisco IOS ソフトウェア リリースのリストは、FEC 機能の下にあります。

他の Cisco 製品の EtherChannel のハードウェアおよびソフトウェア要件についてはCatalyst スイッチで EtherChannel を実装するためのシステム要件を参照してください。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS ソフトウェア リリース 12.1(8b)E10 が稼働している Catalyst 6500 スイッチ

  • Cisco IOS ソフトウェア リリース 12.1(21) が稼働している Cisco 7500 ルータ

この文書の Catalyst スイッチの設定は、Cisco IOS ソフトウェアが稼動する Catalyst 6500/6000 および Catalyst 4500/4000 シリーズの全スイッチに適用されます。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

注: 確実にデフォルト設定にするには、write erase コマンドを使用してすべてのデバイスの設定をクリアします。 write erase コマンドでデフォルト以外の設定をすべて消去してから、デバイスをリロードします。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

重要事項

物理インターフェイスで最初に channel-group コマンドを発行した場合、ポート チャネル インターフェイスが自動的に作成されます。 物理インターフェイスをチャネル化する前にポート チャネルを設定した場合、最初にポート チャネル インターフェイスを削除します。 これが該当するのは Catalyst スイッチだけです。 7500 ルータでは、設定の順序が変わります。 設定する前にポートチャンネルインターフェイスを設定して下さいか。物理インターフェイスの下のチャンネルグループ。

Cisco IOS ソフトウェアが稼動する Catalyst 6500/6000 と 4500/4000 では、ポートチャネルの設定順序が重要です。 物理インターフェイスで channel-group コマンドを実行する前に switchport コマンドを実行するのが最適な順序です。

物理インターフェイス(インターフェイス ギガビット イーサネット 1/1)で、switchport コマンドより先に channel-group コマンドを発行すると、自動的にポートチャネル インターフェイスが作成され、L3 インターフェイスになります。 次に物理インターフェイスで switchport コマンドを発行すると、物理インターフェイスは L2 インターフェイスになります。 また、すでに作成したポートチャネル インターフェイスに関連付けられた物理インターフェイスはありません。 channel-group コマンドが物理インターフェイスの下に表示されていないことに注意してください。 この場合、新しく設定されたポートチャネル インターフェイスで switchport コマンドを最初に発行する必要があります。 これにより、物理ポートは再度、channel-group コマンドを受け付けるようになります。 この場合、ポート チャネルは L3 インターフェイスから L2 インターフェイスに変更されました。

逆に、物理インターフェイスでまず switchport コマンドを発行し、次に channel-group コマンドを発行するとします。 この場合、ポート チャネル インターフェイスが自動的に作成され、設定されたすべての switchport コマンドを継承します。

Cisco IOS ソフトウェアが稼動している Catalyst 6500/6000 スイッチでは、デフォルトでは、すべてのポートが L3 ポートです。 Cisco IOS ソフトウェアが稼動している Catalyst 4500/4000 スイッチでは、デフォルトでは、すべてのポートが L2 ポートです。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/21066/135-a.gif

設定

このドキュメントでは、次の設定を使用します。

注: コメントおよび説明は青色の斜体で表示されます。

Catalyst 6500 スイッチ(VLAN トランキングを使用しない)
Building configuration...
?
Current configuration : 5869 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6500
!
boot buffersize 126968
boot system flash slot0:c6sup11-jsv-mz.121-8b.E15.bin
boot bootldr bootflash:c6msfc-boot-mz.121-8b.E15
enable password ww
!
redundancy
?main-cpu
? auto-sync standard
ip subnet-zero
!
!
no ip finger
!
!
!
!

!--- In this example, you configure L3 EtherChannel.
!--- For more details, refer to this document:
!--- Configuring EtherChannels.
!--- A logical port-channel interface is automatically created?
!--- when ports are grouped into a channel group.


interface Port-channel 1
?ip address 11.1.1.2 255.255.255.0
 duplex full
 speed 100

!--- If you specify the speed and duplex setting at the port channel 
!--- level, these settings pass down to the physical ports.
!--- In other words, the physical ports inherit the same speed 
!--- and duplex settings as the port-channel interface.

 hold-queue 300 in
!
interface GigabitEthernet1/1
?no ip address
?shutdown
!
interface GigabitEthernet1/2
?no ip address
?shutdown
!
interface FastEthernet3/1
 no ip address
 duplex full
 speed 100

!--- Port is a member of channel group 1. Routers do not support 
!--- EtherChannel negotiation (Port Aggregation Protocol [PAgP]), so PAgP
!--- needs to be disabled. On a Catalyst 4500/4000 switch, all ports are
!--- L2 ports by default. Convert this port from a physical L2 port to
!--- a physical L3 port with the no switchport command.

channel-group 1 mode on

interface FastEthernet3/2
?no ip address
 duplex full
 speed 100

!--- Port is a member of channel group 1. Routers do not support 
!--- EtherChannel negotiation (PAgP), so PAgP needs to be disabled.
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default. 
!--- Convert this port from a physical L2 port to a physical L3 port 
!--- with the no switchport command.


channel-group 1 mode on


interface FastEthernet3/3
?no ip address
?switchport
?switchport mode access
!

!--- Output suppressed.

!
ip classless
no ip http server
!
!
!
line con 0
?transport input none
line vty 0 4
!
end

Catalyst 7500 ルータ(VLAN トランキングを使用しない)

!--- Output suppressed.

!
interface Port-channel1
?ip address 11.1.1.1 255.255.255.0
 full-duplex
?hold-queue 300 in
!
interface FastEthernet0/0
?no ip address
?full-duplex
 speed 100
?channel-group 1
!
interface FastEthernet0/1
?no ip address???
?full-duplex
 speed 100???????????????????????????? ?
?channel-group 1

!--- Output suppressed.

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

show コマンド

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show etherchannel channel-id port-channel:Cisco IOS スイッチ内でポート チャネルを確認します。

  • show interfaces port-channel channel-id:Cisco IOS ルータ内でポート チャネルを確認します。

show コマンドの出力例

Catalyst 6500/6000 スイッチ

  • show etherchannel channel-id port-channel

Router#show etherchannel 1 port-channel
Port-channels in the group:
----------------------
Port-channel: Po1
------------
Age of the Port-channel = 01h:56m:20s

Logical slot/port = 10/1 Number of ports in agport = 2
GC = 0x00010001 HotStandBy port = null
Passive port list = Fa3/1 Fa3/2
Port state = Port-channel L3-Ag Ag-Inuse
Ports in the Port-channel:
Index Load Port
-------------------
0 55 Fa3/1
1 AA Fa3/2
Time since last port bundled: 01h:55m:44s Fa3/2
Router#

Cisco 7500 ルータ

  • show interfaces port-channel channel-id

Router#show interfaces port-channel 1
Port-channel1 is up, line protocol is up
Hardware is FastEtherChannel, address is 00e0.1476.7600 (bia 0000.0000.0000)
Internet address is 11.1.1.1/24
MTU 1500 bytes, BW 400000 Kbit, DLY 100 usec, rely 255/255, load 62/255
Encapsulation ARPA, loopback not set, keepalive set (10 sec), hdx
ARP type: ARPA, ARP Timeout 04:00:00
No. of members in this fechannel: 2
Member 0 : FastEthernet0/0
Member 1 : FastEthernet0/1
Last input never, output never, output hang never
Last clearing of "show interface" counters 10:51:55
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/300, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 98281000 bits/sec, 8762 packets/sec
4545 packets input, 539950 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 watchdog, 0 multicast
0 input packets with dribble condition detected
342251216 packets output, 3093422680 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 21066