Cisco インターフェイスとモジュール : Cisco コンテンツ スイッチング モジュール

コンテント スイッチ モジュールでの透過キャッシュの設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 10 月 30 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、Cisco コンテンツ エンジンをキャッシュとして使用した、コンテンツ スイッチ モジュール(CSM)での透過キャッシュの設定方法について説明します。 透過キャッシュは、ユーザとサーバの間に位置します。 CSM は、ユーザとキャッシュの間に導入されます。 CSM はレイヤ 5 の機能によってコンテンツを動的に解析し、キャッシュが可能かどうかを判断するという高度な機能を備えています。 次のガイドラインが適用されます。

  • キャッシュ可能なら、CSM ロードは設定されたプレディクタに基づいてキャッシュ サービスに要求のバランスをとります。

  • キャッシュ可能、CSM は起源 サーバにそれを直接送信 します。 これは要求を起源 サーバにキャッシュによってリダイレクトしてもらうためキャッシュ不可能 な オブジェクトがキャッシュに行くと発生するパーフォーマンスヒットを避けます。

利用可能 なキャッシュ上のデータをどのようにに配りたいと思うか左右される複数のバランシング方式が(たとえば、全 URL、URLストリング、等あります)。

キャッシュへ送るファイル拡張子のリストを使用して CSM を設定することもできます。 このリストは Extension Qualifier List(EQL; 拡張子修飾子リスト)といいます。 vserver 透過的なの下で slb-policy CACHE-POLICY を設定すれば、マップ キャッシャブルurl リストにリストされているファイル拡張子を用いる要求だけがキャッシュ 送信 されます。 ファイル拡張子がマップ キャッシャブルurl リストにリストされていない場合、要求は slb-policy NONCACHE-POLICY を見つけます。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Catalyst 6000 Supervisor Cisco IOS か。 MSFC1 (c6sup11-dsv-mz.121-8a.EX)の Supervisor Engine 1 のためのソフトウェア リリース 12.1(8)EX

  • Catalyst 6000 CSM ソフトウェア リリース 2.1(2) (c6slb-apc.2-1-2.bin)

  • Cisco Content Engine 565 実行 Cisco Application and Content Networking System(ACNS)ソフトウェア リリース 5.1.3

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションではこの資料に説明がある機能を、設定するための情報が表示されます。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

CSM のトランスペアレント キャッシング

config_transp_caching_19680.gif

設定

このドキュメントでは、次の設定を使用します。

CSM
Building configuration...
Current configuration : 4500 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat
!
boot buffersize 126968
enable password cisco
!
redundancy
 main-cpu
  auto-sync standard
ip subnet-zero
!
ip name-server 10.107.241.185
!

!--- CSM located in slot 3. Module is running as active
!--- cache and client side on the same CSM VLAN 100.

module ContentSwitchingModule 3
 vlan 100 client
  ip address 10.107.249.251 255.255.255.248
  gateway 10.107.249.249
!

!--- End user located in CSM VLAN 200.

 vlan 200 server
  ip address 10.107.249.251 255.255.255.248
!

!--- Probe setup to check the availability of the Content
!--- Engine default probe values. Interval is 300 seconds.

 probe CACHEPROBE tcp
!

!--- Serverfarm CACHE.
!--- Note: Issue the no nat server command.
!--- CSM needs to do a Layer 2 rewrite.
!--- Balancing predictor is hash URL.

 serverfarm CACHE
  no nat server
  no nat client
  predictor hash url
  real 10.107.249.254
   inservice
  real 10.107.249.252
   inservice
  probe CACHEPROBE
!

!--- Serverfarm OUTBOUND.
!--- Note: Use the serverfarm OUTBOUND to bypass the cache.
!--- Requests that do not match the map CACHEABLE url list
!--- will use serverfarm OUTBOUND. The NAT server has no
!--- effect, as no reals are configured.
!--- Balancing predictor forward.

 serverfarm OUTBOUND
  nat server
  no nat client
  predictor forward
!

!--- Map CACHEABLE URL.

 map CACHEABLE url

!--- Extension Qualifier List (EQL).

  match protocol http url *.pdf
  match protocol http url *.fdf
  match protocol http url *.au
  match protocol http url *.bmp
  match protocol http url *.z
  match protocol http url *.gif
  match protocol http url *.html
  match protocol http url *.js
  match protocol http url *.mocha
  match protocol http url *.jpeg
  match protocol http url *.jpg
  match protocol http url *.jpe
  match protocol http url *.jfif
  match protocol http url *.pjpeg
  match protocol http url *.pjp
  match protocol http url *.mp2
  match protocol http url *.mpa
  match protocol http url *.abs
  match protocol http url *.mpeg
  match protocol http url *.mpg
  match protocol http url *.mpe
  match protocol http url *.mpv
  match protocol http url *.vbs
  match protocol http url *.m1v
  match protocol http url *.pcx
  match protocol http url *.txt
  match protocol http url *.text
  match protocol http url *.mov
  match protocol http url *.tiff
  match protocol http url *.tar
  match protocol http url *.avi
  match protocol http url *.wav
  match protocol http url *.gz
  match protocol http url *.zip
!
 map NONCACHABLE url
  match protocol http url *
!
 policy CACHE-POLICY
  url-map CACHEABLE
  serverfarm CACHE
!
 policy NONCACHE-POLICY
  url-map NONCACHABLE
  serverfarm OUTBOUND
!

!--- Vserver TRANSPARENT.
!--- Note: Virtual IP is all zeros.
!--- Use of persistence rebalance for HTTP 1.1.
!--- Parse-lengh set to 2000 bytes.
!--- Two policies added to vserver TRANSPARENT.

 vserver TRANSPARENT
  virtual 0.0.0.0 0.0.0.0 tcp www
  serverfarm CACHE
  persistent rebalance
  parse-length 2000
  slb-policy CACHE-POLICY
  slb-policy NONCACHE-POLICY
  inservice
!

!--- Fault Tolerance group 1.
!--- Used to configure redundancy between modules 3 and 4.

 ft group 1 vlan 250
  priority 20
!

!--- CSM located in slot 4. Module is running as standby
!--- cache and client side on the same CSM VLAN 100.

module ContentSwitchingModule 4
 vlan 100 client
  ip address 10.107.249.253 255.255.255.248
  gateway 10.107.249.249
!

!--- End user located in CSM VLAN 200.
!--- Note: Module 3 and 4 VLAN IP addresses are different.

 vlan 200 server 
  ip address 10.107.249.253 255.255.255.248
!

!--- Probe setup to check availability of Content Engine.
!--- Default probe values. Interval 300 seconds.

!
 probe CACHEPROBE tcp
!

!--- Serverfarm CACHE.
!--- Note: Issue the no nat server command. CSM needs to
!--- do a Layer 2 rewrite.
!--- Balancing predictor is hash URL.

 serverfarm CACHE
  no nat server
  no nat client
  predictor hash url
  real 10.107.249.254
   inservice
  real 10.107.249.252
   inservice
  probe CACHEPROBE
!

!--- Serverfarm OUTBOUND
!--- Note: Use the serverfarm OUTBOUND to bypass the cache.
!--- Requests that do not match the CACHEABLE URL list will
!--- use serverfarm OUTBOUND. The NAT server has no effect,
!--- as no reals are configured.
!--- Balancing predictor forward.

 serverfarm OUTBOUND
  nat server
  no nat client
  predictor forward
!

!--- Map CACHEABLE URL.

 map CACHEABLE url

!--- Extension Qualifier List (EQL).

  match protocol http url *.pdf
  match protocol http url *.fdf
  match protocol http url *.au
  match protocol http url *.bmp
  match protocol http url *.z
  match protocol http url *.gif
  match protocol http url *.html
  match protocol http url *.js
  match protocol http url *.mocha
  match protocol http url *.jpeg
  match protocol http url *.jpg
  match protocol http url *.jpe
  match protocol http url *.jfif
  match protocol http url *.pjpeg
  match protocol http url *.pjp
  match protocol http url *.mp2
  match protocol http url *.mpa
  match protocol http url *.abs
  match protocol http url *.mpeg
  match protocol http url *.mpg
  match protocol http url *.mpe
  match protocol http url *.mpv
  match protocol http url *.vbs
  match protocol http url *.m1v
  match protocol http url *.pcx
  match protocol http url *.txt
  match protocol http url *.text
  match protocol http url *.mov
  match protocol http url *.tiff
  match protocol http url *.tar
  match protocol http url *.avi
  match protocol http url *.wav
  match protocol http url *.gz
  match protocol http url *.zip
!
 map NONCACHABLE url
  match protocol http url *
!
 policy CACHE-POLICY
  url-map CACHEABLE
  serverfarm CACHE
!
 policy NONCACHE-POLICY
  url-map NONCACHABLE
  serverfarm OUTBOUND
!

!--- Vserver TRANSPARENT.
!--- Note: Virtual IP is all zeros.
!--- Use of persistence rebalance for HTTP 1.1.
!--- Parse-lengh set to 2000 bytes.
!--- Two policies added to vserver TRANSPARENT.

 vserver TRANSPARENT
  virtual 0.0.0.0 0.0.0.0 tcp www
  serverfarm CACHE
  persistent rebalance
  parse-length 2000
  slb-policy CACHE-POLICY
  slb-policy NONCACHE-POLICY
  inservice
!

!--- Fault Tolerance group 1.
!--- Used to configure redundancy between modules 3 and 4.

 ft group 1 vlan 250
!
interface GigabitEthernet1/1
 no ip address
 shutdown
!
interface GigabitEthernet1/2
 no ip address
 shutdown
!

!--- CSM client side VLAN. Uplink to the Internet.

interface FastEthernet2/1
 no ip address
 switchport
 switchport access vlan 100
!
interface FastEthernet2/2
 no ip address
 shutdown
!

!--- Cache Engine connected to FE2/3 and FE2/4.
!--- CSM client side VLAN.

interface FastEthernet2/3
 no ip address
 duplex full
 speed 100
 switchport
 switchport access vlan 100
!
interface FastEthernet2/4
 no ip address
 duplex full
 speed 100
 switchport
 switchport access vlan 100
!

!--- CSM Server side VLAN. Connection to end users.

interface FastEthernet2/5
 no ip address
 switchport
 switchport access vlan 200
!

!--- MSFC VLAN 100. Content Engine and client uses this
!--- address as the default gateway.

interface Vlan100
 ip address 10.107.249.250 255.255.255.248
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.107.249.249
no ip http server
!
line con 0
line vty 0 4
password cisco
login
!
end

Content Engine
device mode content-engine
!
hostname ce1
!
http proxy incoming 80

!--- Accept proxy requests on port 80.

!
http l4-switch enable


!--- Instructs the Content Engine to accept traffic that is
!--- directed to any destination IP.

!
ip domain-name cisco.com
!
!
interface Fastethernet 0/0
 ip address 10.107.249.254 255.255.255.248
 exit
!
interface Fastethernet 0/1
 exit
!
ip default-gateway 10.107.249.250
!
primary-interface Fastethernet 0/0
!
!
no auto-register enable
!
ip name-server 10.107.241.185
!
!
username admin password 1 bVmDmMMmZAPjY
username admin privilege 15
!
authentication login local enable primary
authentication configuration local enable primary
!
! End of ACNS configuration

確認

このセクションでは、設定が正しく動作していることを確認するための情報が提供されています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

注: debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

CSM Debug および Show コマンド

  • show module

  • show arp — Server Load Balancing (SLB) アドレス解決プロトコル (ARP) キャッシュ リストを提供します。

  • show conns — SLB 接続 情報を提供します。

  • show dfp — SLB ダイナミック フィードバック プロトコル(DFP) マネージャ情報を提供します。

  • show ft — SLB フォールト トレランス(FT)情報を提供します。

    cat# show module csm 3 ft
    
    FT group 1, vlan 250
    This box is active
    priority 20, heartbeat 1, failover 3, preemption is off
    
    cat# show module csm 4 ft
    
    FT group 1, vlan 250
    This box is in standby state
    priority 10, heartbeat 1, failover 3, preemption is off
  • show map — SLB マップ情報を提供します。

  • show memory — SLB メモリ情報を提供します。

  • show natpools — SLB クライアント NATプール 情報を提供します。

  • show policy — SLB ポリシー情報を提供します。

  • show probe — SLB プローブ 情報を提供します。

  • show reals — SLB 実サーバ 情報を提供します。

  • show serverfarms — SLB サーバファーム情報を提供します。

  • show static — SLB 静的なサーバ NAT 情報を提供します。

  • show stats — SLB 統計情報を提供します。

  • show status — SLB ステータス情報を提供します。

  • show sticky — SLB スティッキー データベースを提供します。

  • show tech-support — SLB 技術的なデバッグ情報を提供します。

  • show vlan — SLB VLAN 情報を提供します。

  • show vservers — SLB 仮想サーバ 情報を提供します。

    show module csm 3 vservers name transparent detail
    
    TRANSPARENT, state = OPERATIONAL, v_index = 10
      virtual = 0.0.0.0/0:80, TCP, service = NONE, advertise = FALSE
      idle = 3600, replicate csrp = none, vlan = ALL
      max parse len = 2000, persist rebalance = TRUE
      conns = 0, total conns = 47
      Default policy:
        server farm = CACHE
        sticky: timer = 0, subnet = 0.0.0.0, group id = 0
      Policy           Tot Conn     Client pkts  Server pkts
      ------------------------------------------------------
      CACHE-POLICY     44           249          203
      NONCACHE-POLICY  37           111          37
      (default)        0            0            0
  • モジュール csm か。 —トランスペアレント キャッシングのための CSM を設定します。 また設定している CSM の位置を規定 します。

    cat(config)# module csm ?
    
    <1-6>  slot where the CSM module resides
  • vserver proxy —仮想サーバを設定します。

    cat(config-module-csm)# vserver proxy
    
    cat(config-slb-vserver)# ?
    
  • vserver advertise —仮想 IP アドレスをアドバタイズして下さい。

  • vserver client —クライアント IP アドレスを設定 します。

  • vserver default —デフォルトにコマンドを設定 します。

  • vserver exit — Server Load Balancing サブモードを終了します。

  • vserver idle —アイドルタイマーを設定 します。

  • vserver inservice —有効はこの仮想サーバのために保守します。

  • no vserver —コマンドを否定するか、またはデフォルトを設定します。

  • vserver parse-length —最大レイヤ7 を解析します長さを設定 します。

  • vserver persistent —接続持続を有効に するか、またはディセーブルにします。

  • vserver replicate — vserver フォールト トレランス 複製を設定 します。

  • vserver serverfarm —実サーバ ファームを設定 します。

  • vserver slb-policy — Server Load Balancing ポリシーを設定 します。

  • vserver sticky —スティッキー タイマを設定 します。

  • vserver url-hash —セットは URL ハッシュ アルゴリズムのために一致する前に付けましたり/サフィックス。

  • vserver virtual —仮想サーバを設定します。

  • serverfarm cache —サーバファームを設定します。

    cat(config-module-csm)# serverfarm cache
    
    cat(config-slb-sfarm)# ?
    
  • サーバファームは bindid — DFP のための ID を結合 します。

  • serverfarm default —デフォルトにコマンドを設定 します。

  • serverfarm exit —出口 SLB サーバファーム サブモード。

  • serverfarm failaction —リアルサーバ障害で奪取 する 処理。

  • serverfarm nat — SLB のためのアドレス 変換を設定 します。

  • serverfarm — コマンドを否定しませんし、デフォルトを設定しません。

  • serverfarm predictor —ロード バランシング予言アルゴリズムを設定 します。

  • serverfarm probe —プローブの使用のために設定します。

  • serverfarm real —実サーバを設定します。

  • serverfarm redirect-vserver — SLB リダイレクト 仮想サーバを設定します。

Content Engine show コマンド

  • show statistics http savings — Content Engine から統計情報を保存します。

    ce1# show statistics http savings
    
                           Statistics - Savings
                         Requests           Bytes
    -----------------------------------------------
    Total:               635                2764599
    Hits:                113                254517
    Miss:                505                2483555
    Savings:            17.8 %              9.2 %

    見てわかるように、113 のヒットがありました。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 19680