ブロードバンド ケーブル : ケーブル モデム

Cisco 以外のケーブルモデムでのCiscoルータの設定方法

2016 年 6 月 18 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 6 月 5 日) | 英語版 (2016 年 4 月 21 日) | フィードバック


目次


概要

シスコ以外のケーブル モデム(CM)が使用されていて、CM がブリッジングのみに対応している特定の環境では、Cisco 806 などの Cisco ルータはイーサネット インターフェイスで CM に接続できます。 ルーティングは、CM の背後にあるルータによって実行されます。 次の手順は、ルータにクライアント PC や宅内装置(CPE)を接続します。 この接続が確立された後、ネットワーク アドレス変換(NAT)がルータで設定されます。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS を実行する 806 シリーズ ルータか。 リリース 12.2(2)XI

  • ブリッジとして機能する CM ルータ

  • CPE として機能する Windows 2000 を実行する PC

  • uBR7246VXR Cable Modem Termination System (CMTS)

注: Cisco 806 ルータ コンフィギュレーションだけこの資料で示されています。 CMTS の設定に関する詳細については、ケーブル技術 設定例およびテクニカルノートを参照して下さい。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/broadband-cable/cable-modems/19268-router-behind-cm-19268.gif

設定

この資料は 806 ルータコンフィギュレーションを使用します:

806 ルータコンフィギュレーション
Building configuration...
Current configuration : 1673 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
logging rate-limit console 10 except errors
enable secret 5 $1$1m1W$uRyUMZQpUAp31C9OM2HQR.
!
username Router password 7 08325C5C00170247425D5506382E2523
username Cisco privilege 15 password 7
134146563C5D020B6F2B793C060703061E2A16706F7E62470C3416
ip subnet-zero
ip name-server 24.29.99.81
ip name-server 24.29.99.82
ip dhcp excluded-address 10.10.10.1 


!--- Issue the ip dhcp excluded-address command to exclude IP 
!--- addresses from being assigned by the DHCP server. This excludes 
!--- E0 IP address.

ip dhcp excluded-address 10.10.10.2
ip dhcp excluded-address 10.10.10.10
ip dhcp excluded-address 10.10.10.3
ip dhcp excluded-address 10.10.10.4
ip dhcp excluded-address 10.10.10.5
ip dhcp excluded-address 10.10.10.6
ip dhcp excluded-address 10.10.10.7
ip dhcp excluded-address 10.10.10.8
ip dhcp excluded-address 10.10.10.9
!
ip dhcp pool CLIENT 

!--- Configures a DHCP address pool.

import all
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server 24.29.99.82
!
no ip dhcp-client network-discovery
lcp max-session-starts 0
!
!
!
interface Ethernet0 

!--- This interface connects to the internal network, including CPE.

ip address 10.10.10.1 255.255.255.0
ip nat inside 

!--- IP NAT configuration.

no ip route-cache
no cdp enable
!
interface Ethernet1 

!--- This interface connects to the same Ethernet segment as the CM.
 
ip address dhcp 

!--- This command allows the router to obtain IP address dynamically.

ip nat outside 

!--- IP NAT configuration.

no ip route-cache
no cdp enable
!
ip nat inside source list 102 interface Ethernet1 overload 

!--- IP NAT configuration.

ip classless
ip route 0.0.0.0 0.0.0.0 66.108.112.1

!--- IP address 66.108.112.1 is the next hop IP address, also called 
!--- the default gateway. Your Internet service provider (ISP) can tell you what IP address to 
!--- configure as the next hop address.

ip http server
!
access-list 102 permit ip 10.10.10.0 0.0.0.255 any
line con 0
exec-timeout 120 0
stopbits 1
line vty 0 4
exec-timeout 30 0
login local
length 0
!
scheduler max-task-time 5000
end
Router#

                     

                      
                     

                     

確認

ルータがイーサネット E1 の IP アドレスを動的に得たことを確認するために、show ip interface brief コマンドを使用して下さい。

Router#show ip interface brief

Interface                  IP-Address      OK? Method Status Protocol
Ethernet0                  10.10.10.1      YES NVRAM  up    up
Ethernet1                  66.108.115.5    YES DHCP   up    up

ルーティング テーブルに正しいエントリがあることを確認して下さい。 たとえば、このディスプレイで、デフォルト ルートは 66.108.112.1 にあります。 これは DHCPプロセスによってルータがイーサネットインターフェイスの IP アドレスを受け取るときインストールされています。

Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 66.108.112.1 to network 0.0.0.0
66.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       66.0.0.0/8 is directly connected, Ethernet1
C       66.108.112.0/21 is directly connected, Ethernet1
10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Ethernet0
S*   0.0.0.0/0 [1/0] via 66.108.112.1

トラブルシューティング

ルータが CM の後ろで接続されるとき、発生するかもしれない最初の問題はルータのイーサネットインターフェイスで IP アドレスを動的に得ていません。 ほとんどの ISP は CM の後ろの 1 つのホストか PC だけ割り当てます。 いくつかの ISP はホスト名に基づいて PC に IP アドレスを割り当てます。 従って CM の後ろのルータがあれば、そして hostname コマンドを使用して設定されるルータのホスト名は ISP によってつけられる同じホスト名であるはずです。

ルータが IP アドレスを動的に得ない場合、チェックするべき最初の事柄はインターフェイスコンフィギュレーションコマンド IP アドレス dhcp 存在です。 このコマンドは CM に接続されるイーサネットインターフェイスの下にあります。 コマンドは IOSソフトウェアリリース 12.1(2)T で導入されました。

存在 する ip address dhcp コマンドしかし CM の後ろのルータがそれでも IP アドレスを得なかったら、IP アドレスを受け取る場合検出するために CM の後ろの PC を接続して下さい。 これは DHCP サービスがきちんとはたらいていることを確認します。 従って ISP は一般的に CM の後ろの 1 ホストだけ割り当てま、最初のホストとして CM 数の後ろの PC を接続します。 このエントリは 24 時間 ISP データベースに残ります。 その結果 CM の後ろのルータを接続すれば、ISP はルータが第 2 ホストである考え、それをと拒否します。 これが発生する場合、Windows 2000 PC のこれらのステップの完了によって PC の IP アドレスを解放して下さい:

  1. Start メニューから『Run』 を選択 して下さい。

  2. cmd を入力しそしてキャリッジリターンを Return を押して下さい。

  3. プロンプトで、ipconfig /release を入力して下さい。

  4. PC の IP アドレスを解放した後、CM をリブートし、もう一度試して下さい。

これがはたらかない場合、ISP を呼出し、CMTS における最初のホストエントリを削除するためにそれらを頼む必要があります。

もう一つの方式はルータのイーサネットインターフェイスを設定することです。 これはコマンド MAC アドレス ieee-address を使用して PC の MAC アドレスと CM に接続します。

PC として CM に接続するイーサネットインターフェイスの同じ MAC アドレスの使用によって、ISP は約 1 ホストおよび 1 IP アドレスだけを学びます。 PC はルータの後ろで一度接続されていて拒否されません。 NAT はルータで IP アドレス 変換を受け入れるために設定されなければなりません。

トラブルシューティングのためのコマンド

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

注: debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

  • debug dhcp detail — DHCP デバッグ情報を表示する debug dhcp detail コマンドを使用して下さい。 これが Ciscoルータがイーサネットインターフェイスのための IP アドレスをなぜ得なかったか解決するのに使用されています。

  • debug ip dhcp server [イベント] [連結] [パケット] — DHCPサーバ デバッグを表示する debug ip dhcp server コマンドを使用して下さい。 これはルータに接続される PC が IP アドレスをなぜの得なかったか判別を助けます。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 19268