IP : 拡張内部ゲートウェイ ルーティング プロトコル(EIGRP)

EIGRP ルータ ID の重複の防止

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 6 月 6 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

Enhanced Interior Gateway Routing Protocol(EIGRP)のルータ ID が重複すると、EIGRP 外部経路の再配布に関する問題の原因になります。 この文書では、この問題と、問題を防止する適切な設定について説明します。

通常、EIGRP ルータ ID の選択方法は、Open Shortest Path First(OSPF)と同じです。 ループバック インターフェイスに割り当てられた最上位 IP アドレスが、ルータ ID として選択されます。 設定されるループバックアドレスがない場合他のどのインターフェイスにも割り当てられる最も高い IP アドレスは Router ID として選択されます。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

この設定は Cisco IOS を使用して作成され、テストされましたか。 ソフトウェア リリース 12.2(10b)。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

問題

重複した EIGRPルータ ID を持つルータの存在による再割り当てされたルートによって直面する問題はこのネットワーク セットアップの助けによって理解される場合があります。

ネットワーク図

eigrp DUPid.jpg

設定

ルータ 4
interface Loopback0

 ip address 1.1.1.1 255.255.255.255

!

interface Loopback1

 ip address 10.10.10.10 255.255.255.0

!

interface Ethernet0

 ip address 172.16.3.4 255.255.255.0

!

router rip

 version 2

 network 10.0.0.0

 network 172.16.0.0

ルータ 3
interface Loopback0

 ip address 2.2.2.2 255.255.255.255

!

interface Ethernet0

 ip address 172.16.3.3 255.255.255.0

 ip pim sparse-dense-mode

!

interface Serial1

 ip address 172.16.13.3 255.255.255.0

 clockrate 4000000

!

router eigrp 7

 redistribute rip metric 1 1 1 1 1

 network 172.16.0.0

!

router rip

 version 2

 network 172.16.0.0

ルータ 1
interface Loopback0

 ip address 2.2.2.2 255.255.255.0

!

interface Serial1

 ip address 172.16.13.1 255.255.255.0

 no ip mroute-cache

!

router eigrp 7

 network 172.16.0.0

 auto-summary

 no eigrp log-neighbor-changes

show コマンド

以前に示されているように、ルータ 3 は EIGRP にルーティング情報プロトコル (RIP)ルーティングを再配布します。 これは 3 ルーティング テーブルおよび EIGRPトポロジーテーブルです。

Router-3#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
R    10.0.0.0/8 [120/1] via 172.16.3.4, 00:00:25, Ethernet0 
!--- Router 3 sees network 10.0.0.0.

     172.16.0.0/24 is subnetted, 3 2 subnets
C       172.16.13.0 is directly connected, Serial1
C       172.16.3.0 is directly connected, Ethernet0
router-3#


router-3#show ip eigrp topology 10.0.0.0 255.0.0.0
IP-EIGRP (AS 7): topology entry for 10.0.0.0/8
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2560000256
  Routing Descriptor Blocks:
  0.0.0.0, from Redistributed, Send flag is 0x0
      Composite metric is (2560000256/0), Route is External
      Vector metric:
        Minimum bandwidth is 1 Kbit
        Total delay is 10 microseconds
        Reliability is 1/255
        Load is 1/255
        Minimum MTU is 1
        Hop count is 0
      External data:
        Originating router is 2.2.2.2 (this system)
!--- Shows that Router 3 is the originating router of the external route.

        AS number of route is 0
        External protocol is RIP, external metric is 1
        Administrator tag is 0 (0x00000000)
router-3#

前の出力から、ルータ 3 が RIP によってネットワーク 10.0.0.0 について学習したことがわかります。 再配布によって、ルートは外部ルートとして EIGRPトポロジーテーブルに入力されました。 それが外部ルートの送信元ルータであることをルータ 3 はまた示します; その EIGRPルータ ID は 2.2.2.2 です。

ルータ 3 は外部ルートを再配布するようであるのでルータ 1 ルーティング テーブルでそれを見ることを期待します。 これはルータ 1.のためのルーティング テーブルおよび EIGRPトポロジーテーブルのディスプレイです。

router-1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 3 2 subnets
C       172.16.13.0 is directly connected, Serial1
D       172.16.3.0 [90/2195456] via 172.16.13.3, 00:31:59, Serial1
router-1#


router-1# show ip eigrp topology
IP-EIGRP Topology Table for AS(7)/ID(2.2.2.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 172.16.13.0/24, 1 successors, FD is 2169856
         via Connected, Serial1
P 172.16.3.0/24, 1 successors, FD is 2195456
         via 172.16.13.3 (2195456/281600), Serial1
router-1#

前の出力から 10.0.0.0/8 の期待されたルートがルータ 1.のルーティング テーブルか EIGRPトポロジーテーブルにないことがわかります。 この理由としては、ルータ 1 とルータ 3 の EIGRP ルータ ID が同じであることが考えられます。 Cisco IOS ソフトウェア Release 12.0(2) と それ以降では、Cisco は show ip eigrp events コマンドで調べることができる EIGRP イベント ログの重複したルータID を記録します。 これはルータ 1 のためのこれの出力です:

router-1 #show ip eigrp events 
Event information for AS 7:
1    18:06:15.863 Change queue emptied, entries: 1
2    18:06:15.863 Ignored route, metric: 10.0.0.0 2560512256
3    18:06:15.863 Ignored route, neighbor info: 172.16.13.3 Serial2
4    18:06:15.863 Ignored route, dup router: 2.2.2.2


!--- Output suppressed.

前の出力から重複したルータID がルータ 1 がルータ 3.からのルートを受け付けないという原因であることがわかります。

解決策

これを解決するには、ループバック インターフェイスの最上位 IP アドレスを変更することにより、いずれかのルータのルータ ID を変更します。 Router ID を変更するためにまた ause Cisco IOS ソフトウェア リリース 12.1(6) またはそれ以降、eigrp router-id <router-id> router サブコマンドを使用できれば。 この例では、ルータ 1 のルータ ID を変更しています。

router-1(config)#router eigrp 7 
router-1(config-router)#eigrp router-id 3.3.3.3

EIGRPルータ ID を変更した後問題クリア IP eigrp < 自律システム コマンド。

外部ルートはここに示されているようにルーティング テーブルに今現われます。

router-1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, IA - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set
     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 2 subnets
C       172.16.13.0 is directly connected, Serial1
D       172.16.3.0 [90/2195456] via 172.16.13.3, 00:00:00, Serial1
D EX 10.0.0.0/8 [170/2560512256] via 172.16.13.3, 00:00:00, Serial1
router-1# 

関連情報


Document ID: 18685