サービス品質(QoS) : QoS ポリシング

フレーム リレー PVC へのパケット マーキングの設定

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2009 年 1 月 14 日) | 英語版 (2015 年 4 月 22 日) | フィードバック


目次


概要

このドキュメントでは、フレームリレー インターフェイスでのパケット マーキングを設定するためのコマンドについて説明しています。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

クラスベースのパケット マーキング

クラスベースのパケット マーキングでは、set コマンドや、モジュラ Quality of Service(QoS)Command Line Interface(CLI; コマンドライン インターフェイス)のコマンドを使用してパケット ヘッダーのフィールド値を変更します。

現在の Cisco IOS か。 ソフトウェア リリース割り当てこれらの操作をする:

  • IP Type of Service(ToS; タイプ オブ サービス)バイトに、IP precedence ビットまたは IP Differentiated Services Code Point(DSCP; DiffServ コード ポイント)を設定する。

  • レイヤ 2 Class of Service(CoS; サービス クラス)値を設定する。

  • ローカル QoS グループ値にパケットを関連付ける。

  • パケットの ATM ヘッダーの Cell Loss Priority(CLP; セル損失率優先度)ビットを 0 から 1 に変更する。

入力ポリシーと出力ポリシーの両方がサポートされています。 クラスベースのマーキングを設定する際には、次の制限事項に注意してください。

  • 出力ポリシーでは、Frame Relay Traffic Shaping(FRTS; フレームリレー トラフィック シェーピング)が必要。

  • Cisco エクスプレス フォワーディングでスイッチングされたパケットだけがサポートされる。

  • set atm-clp コマンドを含むポリシー マップは、出力ポリシーとしてのみ適用可能。

次に、DSCP 値の設定例を示します。

設定例:クラスベースのマーキング
class-map user1
  match access-group 101
!
class-map user2
  match access-group 102
!
policy-map dscp
  class user1
    set ip dscp AF11
  class user2
    set ip dscp AF12
!
map-class frame set-dscp
  service-policy input dscp
!
int s0/0/0:0
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping
!
int s0/0/0:0.125
 frame-relay interface-dlci 125
  class set-dscp

廃棄適性ビットの設定

モジュラ QoS CLI では、フレームリレー フレーム内の Discard Eligible(DE; 廃棄適性)ビットの値を変更するコマンドとして、2 つのコマンドがサポートされています。 set fr-de(クラスベースのシェーピング)と set-frde-transmit(クラスベースのポリシング)です。

set-frde-transmit コマンドは、Any Transport over MPLS(AToM)で伝送されるフレームリレー トラフィックには適用されません。

フレームリレーでは、DE ビットを使用した 2 レベルのパケット プライオリティ設定方式がサポートされています。 元々、フレームの相対的な重要度を表現するための DE ビット設定は、フレームリレー スイッチなどのネットワーク デバイスだけで行われていました。 最近の Cisco IOS ソフトウェア リリースでは、ルータでも DE ビットを設定できます。

次の図は、フレームリレー フレームの形式を示しています。 DE ビットは、フレームリレーの輻輳通知メカニズムを制御する 3 つのビットのうちの 1 つです。

/image/gif/paws/18662/config_fr_pvc.gif

クラスベースのマーキングを監視するには、次のコマンドを発行します。

  • show frame-relay pvc [dlci-number]:すべての Permanent Virtual Circuit(PVC; 相手先固定接続)コンポーネントの統計情報を表示します。 これには次の統計情報が含まれています。

    • FRTS およびサービス ポリシーの情報

    • フラグメンテーション

    • 入出力されたパケットの数

    • Backward Explicit Congestion Notification(BECN; 逆方向明示的輻輳通知)ビット、Forward Explicit Congestion Notification(FECN; 順方向明示的輻輳通知)ビット、および DE ビットが設定されたフレームの数

設定例:DE ビットによる照合
class-map match-fr-de
  match fr-de

!--- Define a class-map named “match-fr-de” to match packets with the FR DE bit set.

!
policy-map set-de
  class match-fr-de
   set ip precedence 1

!--- All packets that match the class have IP precedence set to 1.

!
map-class frame-relay pvc150
   service-policy input set-DE

!--- Apply the policy map to the map class.

!
interface Serial0.1 point-to-point
   frame-relay class pvc150
   frame-relay interface-dlci 150

!--- Associate a map class to the Frame Relay data-link connection identifier (DLCI).

Router# show policy-map interface s0.1

Serial0.1

 Service-policy input: set-prec

   Class-map: match-fr-de (match-all)
     358 packets, 103820 bytes
     30 second offered rate 18000 bps, drop rate 0 BPS  Match: fr-de
     QoS Set
       ip precedence  1
         Packets marked 359

   Class-map: class-default (match-any)
     643 packets, 186470 bytes
     30 second offered rate 32000 BPS, drop rate 0 BPS
     Match: any  (1201)

Cisco IOS ソフトウェア リリース 12.2(2)T では、police コマンドの一部として set-frde-transmit オプションを使用することにより、DE ビットの設定がサポートされるようになりました (詳細は、『トラフィック ポリシング』を参照してください)。 これは、クラスベースのポリシングなど、レート制限メカニズムで DE ビットを設定する場合にも便利です。 このような QoS ポリシーの目的は、不適合のパケットに DE ビットを設定してフレームリレーで転送することで、輻輳発生時にダウンストリームのスイッチで不適合のトラフィックをすべて廃棄できるようにすることです。

クラスベースのポリシングではパケットのマーキングがサポートされていますが、この機能は、ポリサーのトークン バケット メカニズムによる処理を回避するためにパケットのマーキングが必要になる場合にだけ使用することを推奨いたします。

次の設定例では、police コマンドを使用して、トラフィック総量を 800 Kbps に制限しています。 適合するトラフィックはすべて IP precedence 7 で転送され、不適合のトラフィックには DE ビットが設定されます。

設定例:DE ビットの設定
policy-map set-DE
  class class-default
   police 800000 1000 1000 conform-action
   set-prec-transmit 7 exceed-action set-frde-transmit
   violate-action set-frde-transmit
!
map-class frame-relay pvc100
  frame-relay traffic-rate 1000000
  frame-relay mincir 1000000
  service-policy input set-DE
!
interface S0/0
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping
!
interface Serial0/0.1 point-to-point
  ip address 10.1.1.1 255.255.255.252
  no ip directed-broadcast
  frame-relay class pvc100
  frame-relay interface-dlci 100

router# show policy-map set-DE

 Policy Map set-DE
    Class class-default
      police 800000 1000 1000 conform-action
      set-prec-transmit 7 exceed-action
      set-frde-transmit violate-action
      set-frde-transmit

router# show frame-relay PVC 100

PVC Statistics for interface Serial0 (Frame Relay DTE)

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = STATIC, INTERFACE = Serial0/0.1

input pkts 0       output pkts 13000    in bytes 0
out bytes 3770000  dropped pkts 0       in FECN pkts 0
in BECN pkts 0     out FECN pkts 0      out BECN pkts 0
in DE pkts 0       out DE pkts 4447
out bcast pkts 0   out bcast bytes 0
PVC create time 00:51:50, last time PVC status changed 00:51:50

service policy set-DE

  Service-policy output: set-DE (1069)

   Class-map: class-default (match-any) (1071/2)
     11519 packets, 3340510 bytes
     30 second offered rate 1140000 BPS, drop rate 0bps
      Match: ip precedence 1  (1075)
      police:
        800000 BPS, 1000 limit, 1000 extended limit
        conformed 4448 packets, 1289920 bytes; action:
        set-prec-transmit 7
        exceeded 11 packets, 3190 bytes; action:
        set-frde-transmit
        violated 8475 packets, 2457750 bytes; action:
        set-frde-transmit
        conformed 394000 BPS, exceed 1000 BPS violate
        749000 BPS
   Output queue size 20/max total 600/drops 1451

設定をテストする際には、次の点に注意してください。

  • クラスベースのマーキングでは Cisco エクスプレス フォワーディングが必要です。 Cisco エクスプレス フォワーディングが有効になっていない場合は、グローバル コンフィギュレーション モードで ip cef コマンドを発行して有効にしてください。

  • 元々、クラスベースのマーキングは Cisco エクスプレス フォワーディングでスイッチングされたパケットだけに適用されるものでした。 そのため、同じルータで ping を使用してトラフィックを生成した場合、それらのパケットはプロセス スイッチングによって処理されるため、一致するパケットのカウンタは増加しませんでした。

  • ルータで生成されたパケットに対するクラスベースのマーキングは、Cisco IOS ソフトウェア リリース 12.2(6.8)T からサポートされるようになりました。

サービス ポリシーを適用する箇所の選択

で Cisco 7200 シリーズ、Cisco 2600/3600 シリーズおよび他の非ルート/スイッチ プロセッサ(RSP)プラットフォームは、サービス ポリシー マップクラスの内で適用する必要があります; それはフレームリレー PVC に直接適用することができません。 出力ポリシーでは FRTS が必要です。FRTS を有効にするには、frame-relay traffic-shaping コマンドを使用します。 このコマンドでは PVC キューが設定されます。 そのため、通常、サービス ポリシーは DLCI 設定モードまたは PVC 内で設定する必要があります。

現在の Cisco IOS ソフトウェア リリースでは、インターフェイス、サブインターフェイス、および VC へのポリシー マップの適用(service-policy コマンドを使用)が、フレームリレー インターフェイスでサポートされています。 次の表に、サポートされるポリシーの組み合わせを示します。

入力ポリシー 出力ポリシー
1 つの論理インターフェイス上でサポート 複数の PVC など、ピアである複数の論理インターフェイス上でサポート

メイン インターフェイスとサブインターフェイスはピア インターフェイスでないため、サービス ポリシーを同時にサポートすることはできません。

1 つまたは 2 つの論理インターフェイス上で同時にサポート 有効な組み合わせ
  • PVC とメイン インターフェイス
  • サブインターフェイスとメイン インターフェイス
無効な組み合わせ
  • PVC とサブインターフェイス
  • PVC、サブインターフェイス、およびメイン インターフェイス

元々は、set コマンドを使用して直接メイン インターフェイスにサービス ポリシーを設定しても、サブインターフェイスのトラフィックはマーキングされませんでした。 次の例は、この問題の症状を示しています。

Interface Serial5/1:1
no ip address
 encapsulation frame-relay
 no keepalive
 service-policy output set

!--- Avoid the placement of a service policy on a main interface.

 no fair-queue
 frame-relay class data-map
 frame-relay traffic-shaping
!
interface Serial5/1:1.1 point-to-point
 ip address 23.0.0.2 255.0.0.0
 frame-relay interface-dlci 300

giulia# show policy-map interface

 Serial5/1:1

  Service-policy output: set

    Class-map: prec-0 (match-all)
      100 packets, 10400 bytes

!--- Packets are classified correctly.

      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: ip precedence 0
      QoS Set
        ip precedence 1
          Packets marked 0

!--- No packets are marked.


    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: any

回避策は、サービス ポリシーをサブインターフェイスに適用することです。

レガシー構文 - DE リスト

新しい Cisco モジュラ QoS CLI 構文をサポートしていない Cisco IOS ソフトウェア リリースでは、Cisco のレガシー DE マーキング構文を使用して DE ビットを設定できます。 レガシー構文では、DE リストを使用して、廃棄の対象となるパケットの特性を指定します。また、影響を受ける DLCI を識別する DE グループも指定できます。

Router(config)# frame-relay de-list list-number 
              {protocol protocol | interface typenumber} characteristic


!--- Issue this command on one line.

DE リストはプロトコルやインターフェイスに基づいて作成できます。また、パケットのフラグメンテーション、特定の Transmission Control Protocol(TPC; 伝送制御プロトコル)ポート、User Datagram Protocol(UDP; ユーザ データグラム プロトコル)ポート、アクセス リスト番号、パケット サイズなど、さまざまな特性に基づいて DE リストを作成することも可能です。 詳細は、『Cisco IOS ワイドエリア ネットワーキング コマンド リファレンス』で frame-relay de-list コマンドの説明を参照してください。

DE リストと影響を受ける DLCI を指定する DE グループを定義するには、インターフェイス コンフィギュレーション モードで、frame-relay de-group group-number dlci コマンドを発行します。


関連情報


Document ID: 18662