サービス品質(QoS) : QoS ポリシング

フレームリレーPVC のCBWFQ 設定

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 4 月 24 日) | 英語版 (2015 年 4 月 22 日) | フィードバック


目次


概要

この文書では、フレームリレー インターフェイスに Class-Based Weighted Fair Queueing(CBWFQ)を設定するための構成例について説明します。 CBWFQ は、モジュラ Quality of Service Command Line Interface(QoS CLI; Qos コマンド行インターフェイス)のコマンドを使用してポリシーマップに設定したとおりに、bandwidth コマンドによって有効化されます。

はじめに

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

前提条件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

CBWFQ 次の Cisco IOS 現在でサポートされますか。 プラットフォームによるソフトウェア リリース:

  • Versatile Interface Processors(VIP)を搭載した Cisco 7500 シリーズ(分散 CBWFQ):12.1(5)T

  • Cisco 7200 シリーズ、2600/3600 シリーズ、および 7500 以外のシリーズのプラットフォーム:12.1(2)T

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

シェーピングとキューイング

キューイングはシェーピングという点において一般に使用されます、出力レートを減らし、こうして輻輳を誘導する。 次のシェーピング機構によって CBWFQ およびプラットフォームによってコマンドを使用して下さい。

  Cisco 7500 シリーズ 7200、3600、2600、およびその他の非 VIP プラットフォーム
サポートされるシェーピング メカニズム 分散トラフィック シェーピング(DTS) フレームリレー トラフィック シェーピング(フレームリレー TS)
コンフィギュレーション コマンド ポリシーマップの shape コマンドを使用。 メイン インターフェイスで frame-relay traffic-shaping を使用。シェーピング パラメータの指定には map-class 設定コマンドを使用。
分散型シスコ エクスプレス フォワーディング(dCEF)の必要の有無 必要(show cef linecard コマンドにより確認) なし

Cisco 7200、3600、2600 シリーズ

Cisco IOS 12.1(2)T では、Cisco 7200、2600/3600 および他のルート スイッチ プロセッサ(RSP)以外のプラットフォームにおいて CBWFQ がサポートされます。 (詳細については、フレーム リレー上の低遅延キューイング(LLQ を)参照して下さい。) これらのプラットフォームでは、フレームリレー インターフェイス上の CBWFQ は、常にフレーム リレー TS に関連しています。 frame-relay traffic-shaping コマンドを使用して、フレームリレー TS を有効化します。 これらのプラットフォームでは、汎用トラフィック シェーピング(GTS)および shape コマンドによって、CBWFQ を使用できません。 次に設定例を示します。

Cisco 7200、3600、2600 シリーズ上での CBWFQ の構成例
 policy-map mypolicy 
  class voice 
   priority 16 
  class priority-data 
   bandwidth 16 

!--- Create a policy-map and apply the bandwidth 
!--- command to a class. 

! 
 int s0/0 
  encapsulation frame-relay IETF 
  load-interval 30 
  frame-relay traffic-shaping 

!--- Enable Frame Relay TS. 

! 
 interface Serial0/0.1 point-to-point 
  frame-relay interface-dlci 100 
    class frclass 

!--- Apply the map-class to the Frame Relay PVC. 

! 
 map-class frame-relay frclass 
  service-policy output mypolicy 
  frame-relay cir 64000 
  frame-relay bc 640 

!--- Apply the service policy inside the map-class.

サービスポリシーをメイン インターフェイス上では有効化できても、マップクラス コマンド内で有効化できない場合は、インターフェイスに直接フレームリレー TS を適用できません。 そのため、キューイング メカニズムは、Virtual Circuit(VC; 仮想回線)単位のキューではなく、1 つの大きなインターフェイス キューに適用されることに注意してください。

では Cisco 7200 シリーズ、Cisco IOS ソフトウェア バージョン 12.0(26)S およびそれ以降から、フレームリレーマップクラス コマンドの出力サービスポリシーをもう設定することはできません。 その代り Cisco 7500 設定は以降のセクションで説明されているように適用するはずです。 階層的 な policy-map は親ポリシーのシェーピングおよび子ポリシーのキューイングで設定する必要があります。 親ポリシーは本管かサブインターフェイスにそれから接続する必要があります。 map-class frame-relay コマンドのサービス ポリシー 出力を設定することを試みる場合次のエラーメッセージが現れます:

c7200(config)#map-class frame-relay
	 stef
c7200(config-map-class)#frame-relay cir
	 64000
c7200(config-map-class)#service-policy output
	 aan
Frame relay output service policy is not
	 supported

Cisco 7500 シリーズ

Cisco IOS 12.1(5)T 現在で、QoS ポリシーは VIP の分散モードで動作する必要があります; Rsp ベース QoS がもはやサポートされないので。 したがって、7500 シリーズの場合、shape コマンドとモジュラ QoS CLI のその他のコマンドを使用して、VIP のフレームリレー インターフェイスに DTS を実装します。 DTS は GTS とフレームリレー TS を統合します。 構成例については、「分散トラフィック シェーピングの設定」および次に示します。

階層型ポリシーによる DTS の設定例
ip cef distributed 
 !  
 class-map 1  
   match < >  

!--- Define match-on criteria.

 class-map 2  
   match < >

!--- Define match-on criteria.

 !  
 policy-map CBWFQ  
   class 1  
     bandwidth < >  
     !-- Define value in kbps or percent.  
   class 2  
     priority < > 
 
!--- Define value in kbps or percent.

 !  
 Policy-map SHAPE  
    class class-default  
     shape average    
     service-policy CBWFQ  
 !  
 int s0/0/0  
   encapsulation frame-relay  
   ip route-cache distributed  
 !  
 int s0/0/0.1 point-to-point  
   ip address a.b.c.d  
   frame-relay interface-dlci xxx  
    class cisco  
 !  
 map-class frame-relay cisco  
   service-policy output SHAPE

サービス ポリシーを適用する箇所の選択

CBWFQ を設定するときは、モジュラ QoS CLI コマンドを使用して、複数のトラフィック クラスおよび 1 つ以上の QoS 機能によってトラフィック ポリシー マップを作成します。 IOS の現在のバージョンでは、フレームリレー インターフェイスは、service-policy コマンドによるインターフェイス、サブインターフェイス、および VC へのポリシーマップの適用をサポートします。 正しく組み合わされたポリシーだけがサポートされます。 次の表で、トラフィック シェーピングによって QoS ポリシーを適用できる場所を説明します。

  Cisco 7500 シリーズ Cisco 7200、2600/3600 シリーズ、および他のプラットフォーム
メイン インターフェイス メインインターフェイスのサービス ポリシーを設定して下さい サポートされてフレームリレーTS が有効に ならない キューイング メカニズムは単一 のインターフェイス パイプにときだけ適用し。
サブインターフェイス フレームリレーのマップクラス内にサービスポリシーを設定。 サブインターフェイスにマップクラスを適用できます。フレームリレーのマップクラス内にサービスポリシーを設定し、frame-relay traffic-shaping コマンドにより VC 単位のキューイングを有効化。 サブインターフェイスにマップクラスを適用できます。
VC レベル   フレームリレーマップクラス内のサービス ポリシーを設定し、frame-relay traffic-shaping コマンドで VC 単位のキューイングを有効に して下さい。 VC にマップクラスを適用できます。

既知の問題

フレームリレー インターフェイスに CBWFQ を設定する場合は、次の事項に注意してください。

  • ルータがリロードされると、サービスポリシーのパケット マッチ カウンタは、ポリシーがメイン インターフェイスに適用されても増加しない場合があります。 この問題を解決するには、Weighted Fair Queueing(WFQ; 均等化キューイング)の分類フラグをメイン インターフェイスからサブインターフェイスにコピーします。

  • 物理インターフェイス レベルでは、LLQ およびフレームリレー TS を同時に設定できません。 ルータは、リロードされると、稼動設定からサービスポリシーを取り除きます。 インターフェイス上でフレームリレー TS を有効化するときは、マップクラスにサービスポリシーを適用する必要があります。 この組み合せを設定するように試みはエラーメッセージ CBWFQ という結果に終ります: このインターフェイスでサポートされなくて

  • CBWFQ によるサービスポリシーを直接フレームリレーのメイン インターフェイス(非 VC 単位キューイングなど)に適用するときに、bandwidth 文をサブインターフェイスやメイン インターフェイス上で設定すると、ルータのリロード後にポリシーが除去される場合があります。 ルータにより、次のようなログ メッセージが報告される場合があります。

    CBWFQ: Not enough available bandwidth for all classes Available 44 (kbps) 
        Needed 1 00 (kbps)
        CBWFQ: Removing service policy on Serial1/0

    この問題を解決するには、サブインターフェイスで bandwidth コマンドを変更したときの通知を無視するように CBWFQ の動作を変更します。フレームリレーのマップクラス外で CBWFQ を設定できるのは、メイン インターフェイス レベルに限られるからです。 対応策として、サブインターフェイスから bandwidth コマンドを削除して下さい。 サブインターフェイスで bandwidth を使用してルーティング メトリックに影響を与えるには、Open Shortest Path First(OSPF)のコストや Enhanced Interior Gateway Routing Protocol(EIGRP)の遅延などの、別の方法を使用してください。

設定に関する注記

  • bandwidth および priority のコマンドにより、エンティティで使用可能な総帯域幅量を計算する場合は、エンティティが整形フレームリレーの Permanent Vitual Circuit(PVC; 相手先固定接続)であれば次のガイドラインが呼び出されます。

    • Minimum Acceptable Committed Information Rate(minCIR; 最小許容認定情報レート)が設定されていない場合は、CIR を 2 で割ります。

    • minCIR が設定されている場合は、計算に minCIR 設定が使用されます。

    • 上記のレートから得られた帯域幅全体を帯域幅クラスとプライオリティ クラスに割り当てることができます。 したがって、max-reserved-bandwidth コマンドは、フレームリレー PVC でサポートされません。ただし、総帯域幅はレイヤ 2 オーバーヘッドも確実に収容できる大きさに設定する必要はあります。 詳細については、どんなバイトが IP to ATM CoS キューイングかによって考慮されるか参照して下さい

  • CIR または minCIR に、アクセス レートを設定しないでください。 設定すると、出力キューが積み上がって、CBWFQ クラスに大きな遅延が発生する場合があります。 これは、整形レートでは、フラグのオーバーヘッド バイトや Cyclic Redundancy Check(CRC; サイクリック冗長性検査)フィールドが考慮されないので、回線レートでのシェーピングは加入超過になり、インターフェイスの輻輳が発生するからです。 アクセス レートでのシェーピングは、まったく意味がありません。 トラフィックのシェーピングは通常、アクセス レートの 95 % で行う必要があります。つまり、より一般には、集約整形レートは常にアクセス レートの 95% 以下にする必要があります。

  • FRF 12 が設定されると、出力キューのサイズは、現在、分割されているバイト数を収容できるように拡張します。 すなわち、パケットキューからフラグメント キューに行きます。

  • VC 単位の WFQ は、12.0(7)T に含まれます。

  • GTS による CBWFQ は、12.1(2)T に含まれます。


関連情報


Document ID: 18661